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Figure 1.  Application visibility in all network segments using Performance Agent in branch office
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Cisco® Performance Agent is a licensed software feature of Cisco I0S® Software that offers comprehensive
application performance and network usage data valuable for network administrators to accurately characterize
user experience and optimize the use of network resources. When enabled, the feature can be configured to
export application performance analytics, traffic statistics, and WAN optimization metrics in a NetFlow Version 9
template-based format, making it easier for management applications to consume.

Cisco Performance Agent provides visibility into branch-office applications and network performance. It collects
application response time metrics and reports to the Cisco Prime" Network Analysis Module (NAM) or partner
reporting tool. Cisco Performance Agent can be deployed in Cisco 880 and 890 Series Integrated Services
Routers, part of the Cisco Integrated Services Routers Generation 2 (ISR G2) portfolio. You can use Cisco
Performance Agent as an application performance data source; the application works with Cisco Wide Area
Application Services (WAAS) Express. The Cisco Flow Agent is used as an application performance data source
and works with the Cisco Wide Area Application Engine (WAE) and Cisco WAAS Services-Ready Engine (SRE).
When the Cisco Performance Agent is deployed with Cisco WAAS Express, it will also report Cisco WAAS
optimization statistics. The performance agent takes advantage of Network-Based Application Recognition
(NBAR) Deep Packet Inspection (DPI) for a more accurate application representation. It provides the Cisco
Common Classification Policy Language (C3PL) user interface for configuration.

When using WAN optimization, application visibility in all network segments can be achieved by deploying the
NAM in the data center. You can use Cisco Performance Agent running in the branch-office router and Cisco Flow
Agent running in the Cisco WAE appliance in the data center as data sources for collecting application
performance data.

The Cisco Prime NAM measures and reports application response time, traffic statistics, WAN bandwidth usage,
LAN and WAN data throughput, and other application performance metrics. You can use the NAM to identify the
source of performance degradation across multiple network segments based on the following data:

e Transaction time (TT)

« Monitoring the WAN latency using the server-network-delay (SND) metric

« Monitoring the LAN latency using the client-network-delay (CND) metric
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o Monitoring the server processing time using the application-delay (AD) metric

This document describes two common use cases for the following deployment scenarios:
e Application performance visibility without WAN optimization

« Application performance visibility across various network segments before and after WAN optimization

Hardware and Software Requirements
« Hardware for Cisco Performance Agent: Cisco 880 and 890 Series and Cisco ISR G2 routers
o Software for Cisco Performance Agent: Cisco |IOS Software Release 15.1(4)M or later

e Cisco Prime Network Analysis Module, running software Version 5.1 or later
Application Performance Visibility Without WAN Optimization

Topology
Figure 2 shows the topology for measuring and managing application performance without WAN optimization.

Figure 2.  Topology for Measuring and Managing Application Performance Without WAN Optimization
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Cisco Performance Agent is used as an application performance data source from the branch office to the NAM.
Optionally, it can also be used on the data center side. No WAN optimization is used in this use case. Application
performance is measured and reported in the NAM.

Cisco Performance Agent Data Source Configuration in the Branch-Office Router

To collect application performance data from branch-office and data center routers, configure the following: The
keyword MACE (Measurement, Aggregation, and Correlation Engine) is used for Cisco Performance Agent
configuration.

I Configure flow exporter

fl ow exporter nace-export
destination 172.30.104. 128
transport udp 3000

!

I Configure PA flow record

flow record type nmace nace-record
col l ect application nane

collect art all
|
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I Configure PA flow nonitor

type

flow nonitor type mace nace-nonitor

record nmace-record
exporter mace-export
|

! interesting traffic

access-list 100 permt tcp any host 10.0.0.1 eq 80

cl ass-map natch-any mace-tr
mat ch access-group 100
!

I Configure PA policy map

affic

policy-map type nace mace_gl obal

class mace-traffic

fl ow nonitor nmace-nonitor
|

I Enable PAin the WAN i nterface

interface Serial0/0/0
mace enabl e

Using Cisco Prime NAM to Report Application Performance

Step 1. To validate data from Cisco Performance Agent is received on the NAM, go to Setup > Traffic > NAM
Data Sources. An example is shown in Figure 3.

Figure 3.  Validating data from Cisco Performance Agent on NAM

Sefup > Traffic > NAM Data Sources

| Device Type - Adiviy | Status | Data Source Da
| sPaN DATA PORT DATAPORT 1 Ph
| span DATA PORT - DATAPORT 2 Ph
192.168 156 242 NETFLOW R S iR ACTIVE NDE-192.168.156.242-0-0 En
=1 Last Netflow data received: Tue Apr 12
|| 192168156233 NETFLOW gt ACTIVE NDE-192.168.156.2334D-0 En
192 168 156 225 NETFLOW No data received INACTIVE NDE-192 168 156 2254D-0 En
192 168.156.172 NETFLOW No data received INACTIVE NDE-192.168156.172-D-0 En
Last Netflow data received: Tue Apr 12
| 192.168.156 250 NETFLOW a0 2044 ACTIVE NDE-192.168.156.250-D-0 En
[C] 192168156170 NETFLOW No data received INACTIVE NDE-192.168 156.1704D-0 En
Last PA data received: Tue Apr 12 22.07:01 4
T 192168156.174 PA s ACTIVE ]}:M 92168.156.174-Client, >
B : . s WAE-192.168.156.208-Client,
[[] 192188156206 WAAS Cich WA S DL DEST AL ant ACTIVE WAE-192.168.156.206-CItWAN,

collection: Tue Apr 12 22:08:24 2011 (188
bytes

WAE-192.168.156 206-Passthru

Step 2. After confirming that Cisco Performance Agent data is received, the NAM reports on Cisco Performance
Agent in the different dashboards, such as traffic summary (for example, Monitor > Overview > Traffic
Summary), as shown in Figure 4.
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Figure 4.

NAM Summary Reports
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On the same dashboard, Top N DSCP (differentiated services code point) and Top N VLAN charts are provided.

Step 3. Cisco Prime NAM can also report on interface usage as well as Top Application, Host, or DSCP per
interface (Analyze> Traffic > NDE Interface) in the Cisco Performance Agent, as shown in Figure 5.

Figure 5.

Time Range Custom
From 2011-Mar-25, 18:00
To 2011-Mar-29, 10:00

Interface Traffic Report

Interface Selector

MEEEEERUET Group View
» MNOE-192.168 156 242-1D-0
» MNDE-192.168.156.233-1D-0
MDE-192.168.156.225-1D-0
NDE-192.168.156.172-ID-0
» NDE-192.168.156.250-ID-0
NDE-192.168.156.170-ID-0
» PA-192.168.156.174-Passthru
PA-192.168.156.174-Client
if5
if-6
v PA-192.168.156.174-CIWAN

“

Enter speed for this interface: Setup = Network = NDE Interface Capacity

3/26/11 3/27/11 3/28/11 3/25/11
Time
20000
40000 | = = — =
]

3/26/11 3f27/11 3/28/11 3/29/11

-8 Ingress Bytss/sac  —- Egress Bytes/sac
== B

On the same dashboard, Top N Application (In and Out), Host (In and Out), and DSCP (In and Out) charts are

provided.
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Application Performance Visibility with WAN Optimization

Topology
Figure 6 shows the topology for measuring and managing application performance across various network
segments.

Figure 6.  Topology for Measuring and Managing Application Performance Across Network Segments
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Cisco Performance Agent is used as an application performance data source from the branch-office router. Cisco
Flow Agent is used as an application performance data source from the Cisco WAAS appliance in the data center.
The Cisco Prime NAM in the data center correlates metrics from all sources and presents the overall application
performance report. As part of the initial WAAS deployment lifecycle, the NAM can report on traffic for application
response time (latency) trends through the Cisco Performance Agent. This information helps with short listing
candidate applications or servers for WAAS optimization. Cisco WAAS is deployed after a site is selected with a
baseline of an application or server measured with the NAM. With WAN optimization service turned on in the
branch office and data center, application performance is measured and reported in the NAM, helping users to
analyze the effect of WAN optimization. Data measurements are used to ensure service-level agreements (SLAS)
for the application delivery are met.

Cisco Performance Agent Data Source Configuration in the Branch-Office Router

The following configuration will send traffic in pass-through mode without WAN optimization on the branch-office
router:

paramat er-map type waas waas_gl obal
no tfo optimze

The following shows the configuration for Cisco Performance Agent:

! Configure flow exporter
fl ow exporter nace-export
destination 172.30.104.128 ! NAM | P address
transport udp 3000
!
I Configure flow record of the type PA
flow record type mace nace-record
coll ect application nane
collect art all
col l ect waas all
1

I Configure flow nonitor using PA
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flow nonitor type nace nmace-nonitor
record mace-record

exporter mace-export

!

I Configure PA to nonitor WAAS policies
mace nmonitor waas all rmace-nonitor

!

I WAN interface with WAAS enabl ed
interface Serial 0/0/0

waas enabl e

After you measure application performance for a baseline, you can configure traffic to be sent using WAN
optimization and then measure the application performance using the Cisco Prime NAM:

paranat er-map type waas waas_gl obal
tfo optimze full

Cisco Flow Agent Data Source Configuration in Data Center Using Cisco WAAS Appliance

To collect performance data from the data center segment with the WAN optimization service, configure the
following in the Cisco WAAS appliance:

flow nmonitor tcpstat-vl host 40.40.91.50 ! NAM I P Address
flow monitor tcpstat-vl enable
tfo optinmize full

Using Cisco Prime NAM to Report Application Performance

Step 1: Following step 3 in the section “Using Cisco Prime NAM to Report Application Performance” to help
shortlist candidates for WAN optimization (predeployment), the Cisco Prime NAM can report on WAN
optimization parameters after the WAAS has deployed (postdeployment), such as transaction time
improvement from the Analyze > WAN Optimization > Application Performance Analysis menu (Figure 7).

Figure 7. Application Performance Analysis with and without WAN optimization

Analyze > WAN Optimization = Application Performance Analysis
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The same dashboard has the following charts: compression ratio, average concurrent connections, and
multisegment network time that shows before and after WAAS optimization.

Step 2: To complete the WAAS deployment lifecycle, the NAM provides dashboards to help you perform a
detailed analysis and troubleshoot WAN optimization from the Analyze > WAN Optimization >
Conversation Multi-Segments menu (Figure 8).

Figure 8.  Conversation Multi-Segments

Analyze = WAN Optimization = Conversation Multi-segments

| Interactive Report — Multi-Segment
Filter = Expori
Site Data Center Average Average Average Average R
' _— __ Client WAN Server Server .
Client
Client Client Site | Server SewversSite | Application | b SREr Finrark B E:::(anﬁl;n
Server Time{ms) | Time(ms) | Time(ms) | Time (ms)
Application 192.168.156.21 [S;'r‘an"UE: 19216815616 Data Center cifs 3 24 55 21 56
Data Rate 192.168.156.23 gz"‘?fpﬁe 19216815616 Data Center cifs 23 70 14 16 86
Time Range Last 1 hour
& 192.168.156.22 ?:er‘rfpfse 19216815616 DataCenter cifs 3 S 53 10 64
From 2011-Apr-18, 15:31 Siridnee
19216815624 192168.15616 DataCenter  cifs a6 54 a9 11 68
To 2011-Apr18, 16:31 e
an Jose "
10216818625 (A1 19216815645 DataCenter cifs 66 49 60 7 72
San Jose
Detail DC Conversation 182.168.18821  2108F 18216815848 DalaCenter hilp _ 1 27 82 16,341
San Jose
19216816621 -0 19216815616 DataCenter hitp = 2 39 92 9,531
San Jose
19216818621 TS 19216815616 DataCenfer hifp = 2 36 85 21,422
3an Jose
19216818621  o1-0F 19216815645 DataCenter hifp = 1 22 127 1,953
San Jose
182.168.18821  31-05F 18216815848 DalaCenter hilp _ 2 27 92 4230
San Jose
19218818821 - 19216815616 DataCenter hips = 2 36 14 6,595
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Troubleshooting

Useful Cisco Performance Agent CLI commands
Following are some useful Cisco Performance Agent command-line interface (CLI) commands:

« Show mace metrics (displays all Cisco Performance Agent metrics that were collected at the last export
timeout):

Rout er # show nace netrics ?

A.B.C.D Source |IP Address

any Al'l Source | P addresses

art Application Response Time Metrics
fl User defined

nane Narme a specific Fl ow Mnitor
sunmmary MACE Metrics Summary

waas WAAS Metrics

o Display Cisco Performance Agent metric summary:

Rout er # show mace netrics sunmary

Segnent Client Pkts Server Pkts Fl ows Exported
0 0 0 0

1 618 771 155

2 906 890 155

4 0 0 0

8 0 0 0

16 182 181 46
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e Display Cisco Performance Agent metrics:

LIUT#sh mace metrics 1,1,1,1

key fields: | Client | Server | Det, Port | Protocol | Segment [D

HACE Metrics: | DSCP AppId
| cByte cPkts =Byte sPkt=

ART Metrics: | sumRT sLmAD sumiT =umCHT =umSHT =unTD sumTT riam T
| =Pkt= zByte cPkt= chyte new55 rumR

WARS Metricz: | optMode
| InBytes QutBytes LZByteln LZBytelut  DREByteln  DREBytelut

Rec, 1 1 1,1.1.1 | 2,3,3.2 | 80 | B |1

HACE Metrics: | 0 0
| 3085 141 203126 142

ART Metrics: | 1BE 144 2016 2004 12 21E0 28068 1
| 142 200254 141 261 1 1

WAAS Metrics: | 7
| 261 2000253 30643 2odoil 200254 200254

Rec, 2 11,111 | 2,3.3.2 | 80 | B | 2

HACE Metrics: | 0 0
| AB170 266 40353 205

ART Metrics: | 28142 27ha2 g 4 4 28712 30164 140
| 256 32157 2R 7R42 1 140

WARS Metrics: | 7
| 32167 TERZ 239 389 261 261

Troubleshooting Cisco Performance Agent

Cisco Performance Agent uses Flexible NetFlow (FNF) to export performance data to the Cisco Prime NAM.

e Symptom: The Cisco Prime NAM is not receiving data collected from Cisco Performance Agent.
Check whether FNF sent data to NAM (show flow exporter statistics):

MUT#sh flow exporter statistics
Flow Exporter fel:
Packet send statistics (last cleared 00:01:45 ago):
Successfully sent: 2 (1865 bytes)

Client =zend statistics:
Client: MACE EXPORTEE GROUP MACE-EXP-1

Records added: G
- zent: G
Bytes added: 1256
- zent: 1356

e Symptom: FNF has sent data to the NAM from Cisco Performance Agent, but the NAM is not receiving data
from the Cisco Performance Agent.
Troubleshoot the network path between Cisco WAAS Express and Cisco Prime NAM.
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¢ Symptom: FNF did not send data.
Check Cisco Performance Agent (show mace metrics summary). Check whether flows are exported.

« Symptom: Flows are not exported by Cisco Performance Agent.
Debug Cisco Performance Agent to identify the error (debug mace cp):

Rout er # #debug mace cp
MACE Control - Pl ane debugging is on
*Mar 4 03:46:40.251: MACE export tiner process started at 46 mnutes & 40

sec
*Mar 4 03:46:40.251: Next tinmer expiry after O minutes and 20 seconds.
*Mar 4 03:47:00.255: MACE export process wokeup at 47 minutes and O
seconds.
*Mar 4 03:47:00.255: Next tiner expiry after 1 mnutes and 0 seconds.
*Mar 4 03:47:00.259: Total Active L4 flows =5
*Mar 4 03:47:00.259: Total Dead L4 _flows = 39

For More Information

For more information about the Cisco Prime NAM and Cisco WAAS Express:

e Cisco Prime NAM: http://www.cisco.com/go/nam

e Cisco WAAS Express: http://www.cisco.com/en/US/products/ps11211/index.html
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