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Cisco Network Analysis Module Software 5.0 Migration 

The Cisco® Network Analysis Module (NAM) team is pleased to introduce Cisco Network Analysis Module 

Software 5.0, a major software release that offers new and enhanced capabilities that allow network 

administrators to quickly understand how traffic over the network is being used and how it is performing to 

manage and improve the delivery of business-critical applications. NAM 5.0 comes with a next-generation 

GUI that includes preconfigured dashboards, providing a comprehensive graphical overview of network 

performance, and workflows with helpful features such as contextual navigation, interactive reports, and 

one-click packet captures. It also comes with a set of features such as packet- and flow-based analytics, 

site-based metrics, enhanced Cisco Wide Area Application Services (WAAS) and voice analytics, and 

more, all in one box. NAM 4.x customers can obtain NAM 5.0 by navigating to the Cisco.com Software 

Center and downloading the new software release using their SMARTnet® contract access privileges. 

This document helps Cisco’s valued NAM 4.x customers upgrade their software to NAM 5.0 and take advantage of 

the valuable capabilities that NAM 5.0 has to offer. Besides pertinent upgrade information, it also includes pointers 

on configuring some of the new NAM features and mapping of NAM 4.x features to 5.0. The document is in a 

question-and-answer format and provides references and links to other documents, where needed, to help ensure 

that sufficient explanation is provided yet avoid document clutter. 

This document will cover a common set of questions regarding NAM 5.0 installation, configuration, and navigation. 

Any reference to NAM 5.0 in this document refers to NAM with software release 5.0. 

If any further information is desired, please contact your Cisco sales team or nam-info@cisco.com. 

NAM Install/Upgrade 

Q. Would you summarize at a high level what I should d o and the order I should do it in to make sure that  

my upgrade will be successful? 

A. Check your NAM to make sure it meets the minimum system and browser requirements, and then follow the 

procedure on upgrading NAM software as laid out in the Installation and Configuration Guides for your NAM 

form factor. A link to download the NAM Installation and Configuration Guides for your form factor can be found 

in the Appendix. 

Q. What are the minimum system requirements to support  NAM Software 5.0? 

A. Please refer to the NAM 5.0 Release Notes under System Requirements on page 7. A link to download the NAM 

5.0 Release Notes can be found in the Appendix. 

Q. What browsers are supported in NAM 5.0? 

A. NAM 5.0 has been tested with Internet Explorer 8.0 and Firefox 3.6. Please refer to the NAM 5.0 Release Notes 

under Browser Requirements on page 11. A link to download the NAM 5.0 Release Notes can be found in the 

Appendix. 

Q. Given that NAM 5.0 introduces a new embedded Perfor mance Database and a new internal data schema, 

can I upgrade from NAM 4.x, or is a fresh install r equired? 

A. It is recommended to do a fresh install with ‘upgrade <ftp-url> --install’ in the NAM console, removing all saved 

reports and capture files. NAM 5.0 will perform better with a contiguous hard drive. Please refer to the NAM 5.0 
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Release Notes under Upgrading to NAM 5.0 on page 12 for further information. A link to download the NAM 5.0 

Release Notes can be found in the Appendix. 

Q. After upgrading NAM 5.0, do I need to reenable Teln et, Secure Shell (SSH) Protocol, HTTP, or HTTPS for  

access? 

A. Yes. Please follow the instructions found in the NAM Installation and Configuration Guide for your NAM form 

factor. Link to download the NAM Installation and Configuration Guides for your form factor can be found in the 

Appendix. 

Note that the NAM 5.0 Strong Crypto patch needs to be downloaded from Cisco Connection Online and applied 

to use SSH and HTTPS. 

Q. I logged in to the NAM GUI but the menu tabs are mi ssing. 

A. Not being able to view the menu tabs is likely due to opening browsers (Firefox and Internet Explorer) with 

previous NAM 4.x Java scripts. If you clear your browser cache, the NAM 5.0 menu should be properly 

presented. 

Internet Explorer 8.x: Tools > Internet Options > General ; under Browsing History, click the Delete  button. 

Firefox 3.6.x: Tools > Advanced > Network ; under Offline Storage, click the Clear Now  button. 

Q. Do I need to reconfigure Switched Port Analyzer (SP AN), VLAN, NetFlow, WAAS Flow Agent, and so on 

to be sent to NAM after I upgrade to 5.0? 

A. No. After the install is done, make sure you configured NAM to its previous IP address. NAM will automatically 

detect your configured data sources. You can validate these data sources from Setup > Traffic > NAM Data 

Sources . 

NAM Configuration 

Q. I would like my reports to be presented in the same  way as in NAM 4.x by selecting the configured data  

source (for example, Data Port 1, and so on). How w ould I replicate that in NAM 5.0? 

A. From Interactive Report , found on the left panel, click Filter , then select the Data Source  you want to display. 

The Site  field should be left blank. See Figure 1. If you are interested in understanding the Site field, proceed to 

the next question. 

Figure 1.   Data Source Filter 

 

Q. What is the Site field in the Interactive Report? 

A. NAM 5.0 introduces the concept of sites, which allows the user to configure either a group of IP addresses 

(subnet), data sources, or VLANs by location, department, group of users, and so on, to mirror a logical network 

partition/topology. See Figure 2 for an example of a site. 
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Figure 2.   Site Filter 

 

Q. How do I set up sites? 

A. Select Setup > Network > Sites;  click Create  to define your site. 

Tip: Use the autodetect button to select subnets for your site rule as seen below in Figure 3 

Figure 3.   Autodetect Subnets in Site Rules 

 

Q. How do I generate a report to perform a trend analy sis? 

A. Since NAM 5.0 collects the data and stores it in a database, you can perform an on-demand trend analysis by 

navigating to Interactive Report. Click Filter  then select the Time Range  drop-down box as seen in Figure 4. 

This will update the screen with the time specified and the corresponding aggregated data. 

For further information regarding configuration of time intervals for data aggregation, please refer to the NAM 

5.0 User Guide, page 2-74, ”Aggregation interval.” A link to download the NAM 5.0 User Guide can be found in 

the Appendix. 
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Figure 4.   Time Range Filter 

 

Q. How do I export a report? 

A. From Interactive Report , click Export  and then configure the appropriate export settings as shown in Figure 5. 

This will allow you to export data using email so you can create your own focused reports. You must configure 

the email server first by going to Administration > System > E-Mail Setting . 

Refer to the “Scheduled Exports” section, page 2-53, in the NAM 5.0 User Guide for additional information on 

configuring a scheduled export. A link to download the NAM 5.0 User Guide can be found in the Appendix. 

Figure 5.   Export a Report 

 

NAM Navigation 

Q. Are the menus different between NAM 4.x and NAM 5.0 ? 

A. Yes. The different menus include Alarms and Reports and are covered below. 

Q. How do I access the Alarms menu in NAM 5.0? 

A. In 5.0 alarms can be accessed as follows: Monitor > Overview > Alarm Summary . 

Q. How do I configure an alarm? 

A. Refer to the “Alarms” section, page 2-36, in the NAM 5.0 User Guide for information on configuring an alarm. A 

link to download the NAM 5.0 User Guide can be found in the Appendix. 

Q. How do I access the Reports menu in NAM 5.0? 

A. In 5.0 computed data is automatically stored in the NAM’s new Performance Database. See the previous 

question “How do I generate a report to perform a trend analysis?” 
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Q. What are the differences between the Monitor and An alyze menus in NAM 4.x and NAM 5.0? 

A. The Monitor menu provides four dashboards - Traffic Summary, Response Time Summary, Site Summary, and 

Alarm Summary. The Analyze menu includes contextual navigation for Traffic, Response Time, Media, WAN 

Optimization, and Managed Device. Refer to the NAM 5.0 User Guide, Chapter 3, ”Monitoring and Analysis,” 

page 3-1 for additional information on descriptions for these menus. A link to download the NAM 5.0 User Guide 

can be found in the Appendix. 

Q. What is the zoom and pan capability found on the An alysis dashboards in 5.0? 

A. The Analysis dashboards include a new zoom and pan capability to help you analyze the performance of a 

specific application over time (Analyze > Traffic > Application ). With zoom and pan, you can shrink the silver 

bar to zoom into a spike in the graph and move that bar by panning left or right as seen in Figure 6. The action 

of zooming and panning will update the corresponding charts. In this example, the zoom and pan capability 

helps the user quickly pinpoint a distressed server during a specific time period with minimal mouse clicks. 

Figure 6.   Zoom Bar 

 

Q. What are the WAAS views available for NAM 5.0? 

A. In 5.0 the presentation of WAAS data has been enhanced and extended to allow users to quickly view both the 

benefits of WAAS optimization and the opportunities to fine-tune WAAS. Analysis views include three primary 

dashboards: Top Talkers Detail, Application Performance Analysis, and Conversation Multisegments. These 

dashboards can be found under Analyze > WAN Optimization > Top Talkers Detail, Ap plication 

Performance Analysis, Conversation Multisegments . The Top Talkers Detail dashboard is useful  

in understanding application performance prior to WAAS deployment to help in determining which applications 

to optimize. The Application Performance Analysis dashboard allows the user to analyze the results of the 

optimization by viewing TCP flow optimization, data redundancy elimination, and persistent LZ compression 

metrics. The Conversation Multisegments dashboard shows both the server and client LAN and WAN segments 

by network time and by transaction and volume analysis. Refer to the “WAN Optimization” section, page 3-16, in 

the NAM 5.0 User Guide for additional information on these three views. A link to download the NAM 5.0 User 

Guide can be found in the Appendix. 

Q. Can you describe the new Voice/RTP dashboard in NAM  5.0? 

A. The Voice/RTP dashboard, which can be found under Analyze > Media > RTP Streams, Voice Call Statistic s, 

includes (1) voice call statistics over time so you can trend active, new, and terminated calls, and (2) call quality 

statistics over time based on Mean Opinion Score (MOS) values. Coupled with Top N charts on jitter and packet 

loss, the Voice/RTP dashboard allows you to easily visually correlate how your users are experiencing the 

delivery of voice over IP (VoIP). Refer to the “Media” section, page 3-34, in the NAM 5.0 User Guide for 

additional information on Voice/RTP views. A link to download the NAM 5.0 User Guide can be found in the 

Appendix. 
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Q. Is there a more convenient way to navigate to the i nformation I’m interested in than going through eac h 

of the Analyze menus? 

A. Yes. From the Monitor or Analyze tab, you can left-click on any of the data points in the charts and you will be 

presented with a list of navigation options as seen in Figure 7. 

Figure 7.   Contextual Navigation 

 

Q. Is there a more convenient way to capture packets f rom an interesting data point on the chart than goi ng 

through the steps of creating a user-defined captur e session? 

A. Yes. For most charts, you can left-click on any of the data points; you will be presented with a list of options, and 

you can select Capture as seen in Figure 8. You can view the status of the one-click captures on the Sessions 

dashboard at Capture > Packet Capture/Decode > Sessions . 

Figure 8.   One-Click Capture 

 

More Questions? 

Additional NAM resources can be found at http://www.cisco.com/go/nam or you can contact the NAM product 

marketing team at nam-info@cisco.com. 

Appendix 

NAM 5.0 Release Notes: 

http://www.cisco.com/en/US/docs/net_mgmt/network_analysis_module_software/5.0/release/notes/nam50note.html. 

Catalyst 6500 Series and Cisco 7600 NAM Blade Install and Configuration Guide: 

http://www.cisco.com/en/US/products/sw/cscowork/ps5401/prod_installation_guides_list.html. 

Branch Router Series NME-NAM Install and Configuration Guide: 

http://www.cisco.com/en/US/products/sw/cscowork/ps5401/prod_installation_guides_list.html. 

http://www.cisco.com/go/nam
mailto:nam-info@cisco.com
http://www.cisco.com/en/US/docs/net_mgmt/network_analysis_module_software/5.0/release/notes/nam50note.html
http://www.cisco.com/en/US/products/sw/cscowork/ps5401/prod_installation_guides_list.html
http://www.cisco.com/en/US/products/sw/cscowork/ps5401/prod_installation_guides_list.html
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NAM Series Appliance Install and Configuration Guide: 

http://www.cisco.com/en/US/products/ps10113/prod_installation_guides_list.html. 

WAAS NAM VB Install and Configuration Guide: 

http://www.cisco.com/en/US/products/ps10506/prod_installation_guides_list.html. 

NAM 5.0 User Guide: 

http://www.cisco.com/en/US/docs/net_mgmt/network_analysis_module_software/5.0/user/guide/nam50_ug.html. 
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