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Preface

Purpose
This guide provides the information a system administrator needs to troubleshoot problems with 
Cisco Unified Personal Communicator.

Audience
This guide is intended for the system administrator who has a thorough understanding of voice and data 
networking terminology and concepts. This guide is not for end users. 

Because of the close interaction of this application with Cisco Unified Communications Manager 
(formerly known as Cisco Unified CallManager), Cisco Unified Presence, Cisco voice-mail servers, and 
Cisco web conferencing servers, many of the tasks in this guide require familiarity with these products.

For changes that occurred to this product after the publish date of this guide, see the release notes at this 
URL:

http://www.cisco.com/en/US/products/ps6844/prod_release_notes_list.html

The release notes include important information about system requirements, product limitations, 
restrictions, caveats, and documentation updates.

Organization
Table 1 provides the organization of this guide.

Table 1 Document Organization

Chapter and Title Description

Chapter 1, “Troubleshooting Cisco Unified 
Personal Communicator”

Describes how to troubleshoot problems with the 
application.

Appendix A, “Third-Party Copyright and 
License Information”

Provides third-party copyright and license information.
vii
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Preface
Conventions
Conventions
Notes, cautions, and timesavers use these conventions and symbols:

Note Means reader take note. Notes contain helpful suggestions or references to material not covered in the 
guide.

Caution Means reader be careful. In this situation, you might do something that could result in equipment 
damage or loss of data.

Timesaver Means the described action saves time. You can save time by performing the action described in the 
paragraph.

Tip Means the information contains useful tips.

Obtaining Documentation, Obtaining Support, and Security 
Guidelines

For information on obtaining documentation, obtaining support, providing documentation feedback, 
security guidelines, and also recommended aliases and general Cisco documents, see the monthly 
What’s New in Cisco Product Documentation, which also lists all new and revised Cisco technical 
documentation, at:

http://www.cisco.com/en/US/docs/general/whatsnew/whatsnew.html

This product contains cryptographic features and is subject to United States and local country laws 
governing import, export, transfer and use. Delivery of Cisco cryptographic products does not imply 
third-party authority to import, export, distribute or use encryption. Importers, exporters, distributors 
and users are responsible for compliance with U.S. and local country laws. By using this product you 
agree to comply with applicable laws and regulations. If you are unable to comply with U.S. and local 
laws, return this product immediately. 

A summary of U.S. laws governing Cisco cryptographic products may be found at: 
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html. If you require further assistance please 
contact us by sending e-mail to export@cisco.com. 
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C H A P T E R 1

Troubleshooting Cisco Unified 
Personal Communicator

This chapter provides troubleshooting information for common Cisco Unified Personal Communicator 
issues.

 • How to Use Diagnostic Tools, page 1-2

 • How to Resolve Audio Problems, page 1-8

 • How to Resolve Starting Calls and Sending E-Mail Problems, page 1-9

 • How to Resolve Contact List Problems, page 1-9

 • How to Resolve Desk-Phone Problems, page 1-10

 • How to Resolve Directory Problems, page 1-12

 • How to Resolve Instant Messaging Problems, page 1-15

 • How to Resolve Log In and Network Connection Problems, page 1-16

 • How to Resolve Online Help Problems, page 1-17

 • How to Resolve Reachability Status Problems, page 1-17

 • How to Resolve Soft-Phone Problems, page 1-21

 • How to Resolve Video Problems, page 1-22

 • How to Resolve Voice-Mail Problems, page 1-24

 • How to Resolve Cisco Unified MeetingPlace Express Web Conferencing Problems, page 1-27

 • How to Resolve Cisco Unified MeetingPlace Web Conferencing Problems, page 1-36

Note The Cisco Unified Personal Communicator online help also contains troubleshooting information that 
end users can use to solve many problems. You can access this information at this URL: 
http://www.cisco.com/en/US/products/ps6844/products_user_guide_list.html

For Cisco Unified Presence troubleshooting information, see the serviceability administration guide at 
this URL:

http://www.cisco.com/en/US/products/ps6837/tsd_products_support_series_home.html
1-1
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How to Use Diagnostic Tools
 • Capturing Detailed Logs for Other Application Problems, page 1-2

 • Capturing Logs Automatically When the Applications Crashes, page 1-3

 • Capturing Call Statistics for Audio and Video Problems, page 1-3

 • Capturing Server Connection Status Information, page 1-6

 • Diagnosing Problems by Using the TAC Case Collection Tool, page 1-7

Capturing Detailed Logs for Other Application Problems
Sometimes, you need detailed log files to help troubleshoot problems with Cisco Unified 
Personal Communicator. Detailed logs have these characteristics:

 • By default, detailed logging is disabled, and logs are collected at the information level (3).

 • When enabled, detailed logging applies only to the client computer on which Cisco Unified 
Personal Communicator is running when users enabled it.

 • Detailed logs are collected at the verbose level (5).

 • Detailed logs remains enabled until the user changes the setting.

Restrictions

Caution You should ask users to enable detailed logging only when you are trying to resolve a specific issue. 
Detailed logging will cause degraded performance especially in lower-end computers. Make sure to 
instruct users to disable detailed logging when your troubleshooting activities are completed.

Procedure

Step 1 Tell users to follow the user guide instructions for capturing log files:

 • Enable detailed logging on their computers (Help > Enable Detailed Logging).

 • If possible, restart Cisco Unified Personal Communicator to clear the logs and to put the application 
in a known state. If the problem is intermittent or unexpected, capture the logs without restarting the 
application.

 • Recreate the problem, if possible.

 • Manually launch the Problem Reporting Tool (Problem Reporting Assistant on Mac) and send the 
report to you.

Step 2 Provide the Zip file to the Cisco Technical Assistance Center (TAC) representative, if requested.
1-2
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Capturing Logs Automatically When the Applications Crashes
If Cisco Unified Personal Communicator unexpectedly crashes, the Problem Reporting Tool (Problem 
Reporting Assistant on Mac) automatically collects installation, application, and client computer system 
information to automate the trace and crash-dump collection process on the client computer. It also 
creates a dump file.

Before You Begin

Users who roam from one computer to another must generate the problem report on the computer from 
which the problem occurred so that the correct logs are attached. By design, log files do not roam with 
a user from computer to computer.

Procedure

Step 1 Tell users to follow the user guide instructions for capturing log files:

 • Locate the automatically generated Zip file on their desktop. 

 • Send the Zip file from their desktop to you through e-mail.

Step 2 Provide the Zip file to the Cisco Technical Assistance Center (TAC) representative, if requested.

Troubleshooting Tips

 • If a blue screen failure occurs, the Problem Reporting Tool (Problem Reporting Assistant on Mac) 
does not generate an application crash dump even if the cause of the blue screen might be attributed 
to an interoperability issue between Cisco Unified Personal Communicator and the operating 
system.

 • The tool uses GMT so the date stamp in the filename of the generated report (for example) could 
appear incorrect.

Capturing Call Statistics for Audio and Video Problems
Cisco Unified Personal Communicator provides call statistics to help you diagnose and resolve audio 
and video quality issues. The application generates audio call statistics information; video call statistics 
information is generated only when a call is escalated to video or originated with video. Statistics are 
generated when a call is streaming (active) but not when the call is held.

When detailed logging is enabled, call statistics are logged on all significant call events. At the end of 
each call, call statistics information is saved to the log file.

 • If the user has the Call Statistics window open, information is logged in abbreviated form on a 
consistent basis for as long as the window is opened, providing data that you can plot over time to 
track trends.

 • If the user clicks Save to Log, the application dumps a full version of the statistics to the log file in 
a tabular format.
1-3
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Procedure

Step 1 Tell users to follow the user guide instructions to enable detailed logging, capture log files, and send the 
log through the Problem Reporting Tool (Problem Reporting Assistant on Mac).

Step 2 Provide this information to the Cisco Technical Assistance Center (TAC) representative, if requested.

Related Topics

 • Events That Cause Call Statistics Collection, page 1-4

 • Call Statistics Refresh Rate and Log Format, page 1-4

 • Statistics for Calls Involving IP Phones, page 1-5

 • Audio Call Statistics Field Information, page 1-5

 • Video Call Statistics Field Information, page 1-6

Events That Cause Call Statistics Collection

Call statistics are collected when these significant events occur: 

 • When a call is suspended or held, video is paused, or audio is muted

 • When a call is over (hung up or otherwise terminated)

 • Shortly after a call is established (5 to 10 seconds)

 • Shortly after any media renegotiation (when video is added or when a call is held and resumed)

 • When an I-Frame is requested

 • When a significant stream error occurs

Related Topics

 • Call Statistics Refresh Rate and Log Format, page 1-4

Call Statistics Refresh Rate and Log Format

Call statistics are saved to the log under these conditions:

 • Call statistics are saved to the log in full format whenever one of the significant call events occur, 
including the end of a call. Therefore, each call has at least one full dump in table format of the calls 
statistics in the log. 

 • Call statistics are saved to the log in abbreviated format for each Audio RTCP Receiver Report that 
is sent or received (about every 5 seconds). Because the Audio RTCP Receiver Report triggers the 
log capture, the log contains data from all RTCP reports: audio and video, send and receive, and 
incoming and outgoing.

 • If the user has the Call Statistics window open, statistics are refreshed once a second. These statistics 
are shown in the window and are also saved to the log in abbreviated format (short, comma-delimited 
form). 
1-4
Troubleshooting Guide for Cisco Unified Personal Communicator, Release 1.2

OL-11717-01



 

Chapter 1      Troubleshooting Cisco Unified Personal Communicator
How to Use Diagnostic Tools
Note Because the statistics that come from RTCP reports occur about every 5 seconds, the statistics in the Call 
Statistics window might not change once a second even though the check for new statistics occurs every 
second. Other statistics, such as some of those for video, change each second.

Statistics for Calls Involving IP Phones

Many IP phones, including Cisco Unified IP Phones, do not support sending RTP Control Protocol 
(RTCP) reports. Therefore, for calls involving these phones, RTCP-derived statistics are not available 
and display as 0 in the call statistics. 

Related Topics

 • Audio Call Statistics Field Information, page 1-5

 • Video Call Statistics Field Information, page 1-6

Audio Call Statistics Field Information

Table 1-1 describes the fields on the Help > Show Call Statistics > Audio Statistics tab (on Windows) 
and on the Help > Show Call Statistics > Audio tab (on Mac). 

The Audio Transmit column shows statistics on outgoing data and local information.

The Audio Receive column shows statistics on incoming data and remote information.

These RTCP-derived statistics display as 0 when RTCP reports are not available:

 • Received Total Packets

 • Received Packets Lost

 • Received Total Bytes

 • Transmitted Average Jitter

 • Transmitted Maximum Jitter

If you make Cisco Unified Personal Communicator-to-Cisco Unified Personal Communicator calls, 
RTCP reports are available in both directions and all fields are populated.

Table 1-1 Audio Call Statistics (Transmitted and Received) 

Field Description

Codec Current audio codec

Bitrate Current audio bit rate of the codec in kbps

Total Packets Number of audio packets

Packets Lost Number of packets lost

Average Jitter Interarrival jitter in milliseconds

Maximum Jitter Maximum observed jitter in milliseconds

Total Bytes Number of bytes sent and received
1-5
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Video Call Statistics Field Information

Table 1-2 describes the fields on the Help > Show Call Statistics > Video Statistics tab (on Windows) 
and on the Help > Show Call Statistics > Video tab (on Mac). For audio-only calls, the fields display 
zero or --. If Cisco Unified Personal Communicator is only sending or only receiving video, half the 
values are zero or --. 

The Video Transmit column shows statistics on outgoing data and local information.

The Video Receive column shows statistics on incoming data and remote information.

These RTCP-derived statistics display as 0 when RTCP reports are not available:

 • Received Total Packets

 • Received Packets Lost

 • Transmitted Average Jitter

 • Transmitted Maximum Jitter

If you make Cisco Unified Personal Communicator-to-Cisco Unified Personal Communicator calls, 
RTCP reports are available in both directions and all fields are populated.

Capturing Server Connection Status Information
The server health window (Help > Show Server Health on Windows and Help > Show System 
Diagnostics on Mac) provides this information:

 • Client configuration information such as server addresses, protocols used to connect to servers, user 
IDs, and other server-specific configuration information

Table 1-2 Video Call Statistics (Transmitted and Received) 

Field Description

Codec Current video codec

Bitrate Current video bit rate in kbps

Resolution Reported resolution (CIF, QVGA, and so forth)

Total Packets Number of video packets

Packets Lost Number of packets lost

Average Jitter Interarrival jitter in milliseconds

Maximum Jitter Maximum observed jitter in milliseconds

Frame Rate Current frame rate in frames per second (fps)

Total Frames Total frames sent and received

Total Partial Frames Number of partial frames

Partial Frame Lost Number of partial frames lost

Total i-Frame Requests Number of i-Frames requested

Total Frame Errors Number of frame errors

Total Bytes Number of bytes sent and received
1-6
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 • Status of the connected state of the server that is updated in real time

 – For LDAP and web conferencing servers (Cisco Unified MeetingPlace or Cisco Unified 
MeetingPlace Express) that do not maintain constant connections to Cisco Unified 
Personal Communicator, the status shows the result of the most recent interaction; no polling 
or heartbeat mechanism is implemented.

 – At start up, Cisco Unified Personal Communicator checks the connection to the web 
conferencing server and shows the connection status as successful in the server health window 
even though the user might have entered invalid user credentials. User credentials are checked 
when the user launches the web conferencing session from within Cisco Unified 
Personal Communicator. If the credentials are invalid, a message is displayed in the server 
health window.

Procedure

Step 1 Tell users to follow the troubleshooting instructions in the user guide to access the server health window 
(Help > Show Server Health on Windows and Help > Show System Diagnostics on Mac) and to 
provide that information to you.

Note Status transitions are logged and provided in the Problem Reporting Tool (Problem Reporting Assistant 
on Mac); users do not need to note this information or provide it with the Zip file. 

Step 2 Provide the information to the Cisco Technical Assistance Center (TAC) representative, if requested.

Related Topics

 • How to Resolve Log In and Network Connection Problems, page 1-16

Diagnosing Problems by Using the TAC Case Collection Tool
By using the Cisco Technical Assistance Center (TAC) Case Collection tool, you can interactively 
diagnose common problems involving hardware, configuration, and performance issues with solutions 
provided by Cisco TAC engineers. 

Restriction

This tool is available only to registered Cisco.com users with a Cisco service contract.

Procedure

Step 1 Log in to Cisco.com.

Step 2 Choose Support > Tools and Resources, and select TAC Case Collection.

Step 3 Select a technology or product area to begin troubleshooting. 

For example, if you select Voice, you access a knowledge base for voice-over-data networks and IP 
telephony:

 • Voice applications, Cisco Unified Communications Manager, Cisco Unity Connection, and so forth 

 • Voice quality (with diagnostic sound samples)
1-7
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 • Voice gateways

 • Other voice-related issues

For details, click the TAC Case Collection link at this URL:

http://www.cisco.com/en/US/support/tsd_most_requested_tools.html

How to Resolve Audio Problems
 • One-Way Audio Problems, page 1-8

 • User on Hears Robotic Sounds While Connected Through a Low-Bandwidth Link, page 1-8

One-Way Audio Problems

Problem   The user reports very low volume or one-way audio problems. 

Solution   Try these solutions:

 • Verify that the user has correctly identified and established the audio device and tried the 
troubleshooting solutions described in the Cisco Unified Personal Communicator user guide.

 • If the one-way audio problem occurs over a Cisco VPN client (for Windows), make sure the Stateful 
Firewall setting is disabled on the client computer.

 • If the user experiences no audio or one-way audio problems, check the firewall configuration on the 
client computer or on the network. Verify that the correct network ports for Cisco Unified 
Personal Communicator operation are open. For details, see the release notes as this URL:

http://www.cisco.com/en/US/products/ps6844/prod_release_notes_list.html

Related Topics

 • How to Resolve Reachability Status Problems, page 1-17

User on Hears Robotic Sounds While Connected Through a Low-Bandwidth 
Link

Problem   The user experiences hearing robotic sounds with another caller while connected through a 
low-bandwidth link, such as a broadband connection or a low-bandwidth interoffice trunk.

Solution   In Cisco Unified Communications Manager Administration, change the Cisco Unified 
Personal Communicator soft-phone device configuration to use a low bitrate codec. This selection helps 
reduce the upstream bandwidth consumption and improve voice quality. 

Step 1 In Cisco Unified Communications Manager Administration, if you do not have a predefined device pool, 
create a region (System > Region).

Step 2 Change the audio codec selection to iLBC (preferred) or to G.729 (alternatively). 

Step 3 Create the device pool (System > Device Pool), and select the region just created that has the G.729 
codec configuration.
1-8
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Step 4 Click Save.

Step 5 Choose Phone > Device. 

Step 6 Search for the Cisco Unified Personal Communicator soft-phone device that needs to be altered. 

Step 7 On the Phone Configuration page, change the Device Pool field to a predefined pool that you configured 
with codec in Step 2. 

Step 8 Click Save.

How to Resolve Starting Calls and Sending E-Mail Problems
 • Button and Menu Item Are Not Selectable When Making a Call or Sending an E-mail, page 1-9

Button and Menu Item Are Not Selectable When Making a Call or Sending an 
E-mail

Problem   The user reports the button and menu item are not selectable (grayed out) when trying to place 
a call or place a video call, and when sending an e-mail.

Solution   Try these solutions:

 • Ask users to try the solutions described in the troubleshooting section of the user guide.

 • Check the LDAP directory server, and make sure that the contact information is complete (valid 
e-mail address or phone number). 

 • Confirm that you added Cisco Unified Personal Communicator as a phone type to Cisco Unified 
Communications Manager Administration for this user to create the soft-phone audio and video 
capability. 

 • Confirm that Cisco Unified Personal Communicator is properly integrated with the voice-mail 
server. 

For details, see the Cisco Unified Personal Communicator installation guide at this URL:

http://www.cisco.com/en/US/products/ps6844/prod_installation_guides_list.html

How to Resolve Contact List Problems
 • Cannot Add a Contact to Any Existing Group or to Any New Group, page 1-9

Cannot Add a Contact to Any Existing Group or to Any New Group

Problem   The user reports not being able to add a contact to any existing group or to any new group. The 
Add Contact to Group option is greyed out on the right-click menu, and the Actions > Add Contact 
to Group menu does not add the contact to the group.
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Solution   Try these solutions:

 • The UserID attribute in the LDAP Attribute Mapping table might be incorrectly configured in 
Cisco Unified Presence Administration (Application > Unified Personal Communicator > 
Settings). For details about configuring the Cisco Unified Presence LDAP settings, see the 
Cisco Unified Personal Communicator installation guide at this URL:

http://www.cisco.com/en/US/products/ps6844/prod_installation_guides_list.html

 • Make sure the contact to be added is in the Cisco Unified Communications Manager and in the 
Cisco Unified Presence databases.

How to Resolve Desk-Phone Problems
 • Cisco Unified Personal Communicator Remains in No Phone Mode (Disabled) After Launching, 

page 1-10

 • Cisco Unified Personal Communicator Changes to Disabled Mode After Logging In and Selecting 
Desk-Phone Mode, page 1-11

Cisco Unified Personal Communicator Remains in No Phone Mode (Disabled) 
After Launching

Problem   The user reports that when Cisco Unified Personal Communicator is launched, it remains in the 
No Phone mode (Disabled mode on Mac).

Solution   Try these solutions:

 • Ask the user to access the server health window (Help > Show Server Health on Windows and 
Help > Show System Diagnostics on Mac) and to provide that information to you. The window 
provides status information that helps you resolve connection and configuration problems.

 • Instruct the user to try switching to soft-phone mode to see if the phone registers. If the application 
returns to No Phone (or to Disabled on Mac) mode, check the configuration in Cisco Unified 
Communications Manager Administration and in Cisco Unified Presence Administration.

 • Instruct the user to choose the phone to control through the Cisco Unified Personal Communicator 
interface. For details, see the user guide at this URL:

http://www.cisco.com/en/US/products/ps6844/products_user_guide_list.html

 • The Cisco Unified IP Phone is not configured in Cisco Unified Communications Manager 
Administration.

Configure the Cisco Unified IP Phone to be controlled through CTI. 

In Cisco Unified Communications Manager Administration, perform these steps:

a. Add the Cisco Unified IP Phone to the database, and configure it to be controlled from CTI.

b. Associate the phone to the end user.

c. Add the end user to the CTI users group (Standard CTI Enabled).

d. Add the end user to a user group (Standard CCM End Users).
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e. Add Cisco Unified Personal Communicator as a soft-phone device, and configure a shared line 
between the soft-phone and the phone.

f. Set up the user account, and associate the directory number (primary extension) to the user.

For detailed Cisco Unified Communications Manager Administration steps, see the Cisco Unified 
Personal Communicator installation guide at this URL:

http://www.cisco.com/en/US/products/ps6844/prod_installation_guides_list.html

 • The CTI gateway is not correctly configured in Cisco Unified Presence Administration. Choose 
Application > Unified Personal Communicator > CTI Gateway Server and Application > 
Unified Personal Communicator > CTI Gateway Profile.

For detailed Cisco Unified Presence Administration steps, see the Cisco Unified 
Personal Communicator installation guide at this URL:

http://www.cisco.com/en/US/products/ps6844/prod_installation_guides_list.html

Cisco Unified Personal Communicator Changes to Disabled Mode After 
Logging In and Selecting Desk-Phone Mode

Problem   The user reports that after logging in to Cisco Unified Personal Communicator and selecting 
desk-phone mode, the application automatically changes to the disabled mode after a few seconds.

Solution   One or more servers are incorrectly configured.

Step 1 In Cisco Unified Communications Manager Administration, perform these steps:

a. Add the Cisco Unified IP Phone to the database, and configure it to be controlled from CTI.

b. Set up the user account, and associate the directory number (primary extension) to the user.

c. Associate the phone to the end user.

d. Add the end user to the CTI users group (Standard CTI Enabled).

e. Add the end user to a user group (Standard CCM End Users).

f. Add Cisco Unified Personal Communicator as a soft-phone device, and configure a shared line 
between the soft phone and the desk phone.

g. Assign capabilities to users.

For detailed Cisco Unified Communications Manager Administration steps, see the Cisco Unified 
Personal Communicator installation guide at this URL:

http://www.cisco.com/en/US/products/ps6844/prod_installation_guides_list.html

Step 2 In Cisco Unified Presence Administration, perform these steps:

a. Verify that the configuration of the CTI gateway server and the CTI gateway profile are correct by 
choosing Application > Unified Personal Communicator > CTI Gateway Server and 
Application > Unified Personal Communicator > CTI Gateway Profile.

b. Restart the Cisco Unified Presence synchronization agent. 

From Cisco Unified Presence Administration, select Cisco Unified Serviceability in the navigation 
window, and click Go. Then choose Tools > Control Center - Network Services, and select the 
presence server. In the CUPS Services section, select Cisco UPS Sync Agent, and click Restart.
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c. Restart the Cisco CTIManager service.

From Cisco Unified Communications Manager Administration, select Cisco Unified 
Communications Manager Serviceability in the navigation window, and click Go. Then choose 
Tools > Control Center - Feature Services, and select the server. In the CM Services section, select 
Cisco CTIManager, and click Restart.

Note You can start, stop, or restart only feature services that are activated. Go to the Tools > Service 
Activation menu to do this.

For detailed Cisco Unified Presence Administration steps, see the Cisco Unified 
Personal Communicator installation guide at this URL:

http://www.cisco.com/en/US/products/ps6844/prod_installation_guides_list.html

How to Resolve Directory Problems
 • Directory Search Returns No Results, Incorrect Results, or Unexpected Results, page 1-12

 • Cannot Connect to LDAP Server to Resolve Names, page 1-13

 • User Experiences Slow LDAP Directory Searches, page 1-13

 • Single-Character or Group-Character Searches Provide Users Whose Names Are Blank Or Whose 
Phone Numbers Are Shown As Unknown, page 1-14

 • Wrong Picture Is Displayed When Dialing a Contact in the Corporate Directory, page 1-14

 • Phone Number Does Not Resolve to a Name, page 1-14

Directory Search Returns No Results, Incorrect Results, or Unexpected Results

Problem   The user reports that a directory search returns no results, incorrect results, or unexpected 
results. The Cisco Unified Personal Communicator log file contains little or no indication of failure.

Solution   Try these solutions:

 • Instead of using anonymous bind in Cisco Unified Presence Administration (Application > Unified 
Personal Communicator > LDAP Profile), create a search account just for Cisco Unified 
Personal Communicator use with read-only privileges over the directory. 

 • Verify that the directory server is reachable from the client (ping or use Telnet to port 389 or 
whatever is configured in Cisco Unified Presence).

 • Check the searchbase. It should be in canonical form (for example, cn=Users,dc=cisco,dc=com).

 • Verify that the bind credentials refer to a user that has permissions to read the search base.

 • Use a third-party LDAP tool to bind as the user specified and search for all objects in the search 
base. Make sure that user account objects appear.
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Cannot Connect to LDAP Server to Resolve Names

Problem   The user cannot connect to the LDAP server to resolve names.

Possible Cause   The LDAP server or the network is down.

Solution   If the error is a network error (such as a bad address or a bad port), examine the Cisco Unified 
Personal Communicator log file for details. Ask the user to access the server health window 
(Help > Show Server Health on Windows and Help > Show System Diagnostics on Mac) and to 
provide that information to you. The window provides status information that helps you determine 
connection and configuration problems.

Possible Cause   Anonymous bind failed.

Solution   For anonymous bind failure messages, configure the LDAP server to allow anonymous bind.

User Experiences Slow LDAP Directory Searches

Problem   The user experiences slow LDAP directory searches.

Solution   Try these solutions:

 • Narrow the search to containers where users, not other objects, reside.

 • For Active Directory environments, make sure the configuration points to the AD Global Catalog 
server port. You configure the port number to 3268 in Cisco Unified Presence Administration 
(Application > Cisco Unified Personal Communicator > LDAP Server).

 • This problem might be the result of not having the proper fields indexed on the LDAP server. 
Cisco Unified Personal Communicator requires fields to be indexed for maximum performance. The 
style of index (initial versus medial versus final versus equal) should be:

 – FirstName: contains/medial

 – LastName: contains/medial

 – Nickname: contains/medial

 – UserID: contains/medial AND exact/equals

 – BusinessEmail: contains/medial AND exact/equals

 – BusinessPhoneNumber: contains/medial AND exact/equals

Only the fields that are actually mapped in Cisco Unified Presence matter; for example if Nickname 
is not mapped, then there is nothing to index for it.

For details about indexing, see your LDAP server documentation and this URL:

http://msdn2.microsoft.com/en-us/library/ms676931.aspx
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Single-Character or Group-Character Searches Provide Users Whose Names 
Are Blank Or Whose Phone Numbers Are Shown As Unknown

Problem   The user reports that while searching for a single character or a group of characters, the search 
displays user names that match the search criteria and displays users whose name are blank (does not 
contain any characters) and whose phone number is shown as Unknown. 

Solution   Try these solutions:

 • Check for objects beneath your LDAP directory base that are not users. Isolate your users in one 
subtree. 

 • Modify your search base through Cisco Unified Presence Administration under Application > 
Unified Personal Communicator > LDAP Profile. Only search under users, not under the whole 
tree.

Wrong Picture Is Displayed When Dialing a Contact in the Corporate Directory

Problem   The user reports that when dialing a number for a contact in the corporate directory, the wrong 
picture is displayed.

Solution   Check the dialing rules in Cisco Unified Communications Manager Administration by 
choosing Call Routing > Dial Rules > Application Dial Rules. Based on the dialed number from 
Cisco Unified Personal Communicator, the application checks the dialed number against the directory, 
matches it, and displays the matched name and picture. For detailed conceptual and task-based 
information on dial rules, see the Cisco Unified Communications Manager Administration online help 
or the Cisco Unified Communications Manager Administration Guide at this URL:

http://www.cisco.com/en/US/products/sw/voicesw/ps556/tsd_products_support_series_home.html

Phone Number Does Not Resolve to a Name

Problem   The user reports that when double-clicking a contact to call, the conversation window shows 
the phone number instead of the name.

Solution   Check the dialing rules in Cisco Unified Communications Manager Administration by 
choosing Call Routing > Dial Rules > Application Dial Rules. Based on the dialed number from 
Cisco Unified Personal Communicator, the application checks the dialed number against the directory, 
matches it, and displays the matched name and picture. For detailed conceptual and task-based 
information on dial rules, see the Cisco Unified Communications Manager Administration online help 
or the Cisco Unified Communications Manager Administration Guide at this URL:

http://www.cisco.com/en/US/products/sw/voicesw/ps556/tsd_products_support_series_home.html
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How to Resolve Instant Messaging Problems
 • Send Instant Message Option is Disabled, page 1-15

 • User Has Unknown State and Cannot Receive Messages, page 1-15

Send Instant Message Option is Disabled

Problem   The user reports that the Send Instant Message option is not selectable (disabled). 

Solution   Try these solutions:

 • Verify that the user tried to send an instant message to only one user at a time.

 • Make sure the selected remote user is in the Cisco Unified Presence database. Choose Bulk 
Administration > Cisco Unified Presence > Cisco Unified Presence User Update, and follow the 
instructions in the online help.

 • Make sure the instant messaging is enabled for the cluster. In Cisco Unified Presence choose 
Cisco Unified Presence > Settings, select Enable Instant Messaging, and click Save.

 • Verify that there is no network outage that is impacting connectivity.

 • Verify that the instant message target user is in a known state.

User Has Unknown State and Cannot Receive Messages

Problem   The user reports receiving the message “Remote user has an unknown state and may not be able 
to receive messages” after sending an instant message to this remote user.

Solution   In some situations, Cisco Unified Personal Communicator might not be able to determine 
whether the remote user has a valid user ID in the Cisco Unified Presence database. For example, if the 
user searches the LDAP directory and the search returns a userID field that is not empty, Cisco Unified 
Personal Communicator allows the user to compose an instant message. After sending the message, the 
error message is returned. 

When the LDAP search returns an empty userID field, Cisco Unified Personal Communicator disables 
the Send Instant Message button.

Try these solutions:

 • Tell the user to contact the remote user by some other means.

 • If possible, add the remote user to the Cisco Unified Presence database. Make sure this user is a 
Cisco Unified Personal Communicator or an IP Phone Messenger user and on the same cluster as 
the local user.
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How to Resolve Log In and Network Connection Problems
 • Login to Cisco Unified Personal Communicator Fails After Entering Correct Information, 

page 1-16

Login to Cisco Unified Personal Communicator Fails After Entering Correct 
Information

Problem   The user reports receiving an error message during initial Cisco Unified 
Personal Communicator login but has entered the correct username, password, and the 
Cisco Unified Presence IP address or hostname.

Solution   Try these solutions:

 • Ask the user to access the server health window (Help > Show Server Health on Windows and 
Help > Show System Diagnostics on Mac) and to provide that information to you. The window 
provides status information that helps you determine connection and configuration problems.

Note For the Mac, server status information is not enabled until the login is successful.

 • Check the Cisco Unified Presence server, and make sure it is up. 

 • Verify that the Cisco Unified Communications Manager server is up. 

 • Check the Cisco Unified Communications Manager credential policy (User Management > 
Credential Policy Default). If you checked User Must Change at Next Login, tell users to change 
their credentials through the Cisco Unified Communications Manager user web pages. 
Cisco Unified Personal Communicator does not detect expired credentials in Cisco Unified 
Communications Manager and does not allow the user to change the credentials through 
Cisco Unified Personal Communicator.

If you checked Does Not Expire, users might need to occasionally reset their credentials through 
Cisco Unified Communications Manager user web pages.

 • Verify that the Cisco Unified Personal Communicator-specific configuration in Cisco Unified 
Communications Manager Administration and in Cisco Unified Presence Administration is correct. 
For details, see the Cisco Unified Personal Communicator installation guide at this URL:

http://www.cisco.com/en/US/products/ps6844/prod_installation_guides_list.html

 • Verify that the Cisco Unified Personal Communicator installation complies with the server and 
network requirements as described in the release notes at this URL:

http://www.cisco.com/en/US/products/ps6844/prod_release_notes_list.html
1-16
Troubleshooting Guide for Cisco Unified Personal Communicator, Release 1.2

OL-11717-01

http://www.cisco.com/en/US/products/ps6844/prod_installation_guides_list.html
http://www.cisco.com/en/US/products/ps6844/prod_release_notes_list.html


 

Chapter 1      Troubleshooting Cisco Unified Personal Communicator
How to Resolve Online Help Problems
How to Resolve Online Help Problems
 • User Unable to View Online Help, page 1-17

User Unable to View Online Help

Problem   The user is unable to view the online help.

Solution   Try these solutions:

 • Set the browser to allow blocked content. For example, with Internet Explorer 6, an alert directs 
them to the Information Bar, where they must click and choose Allow Blocked Content.

 • Tell users the location of the user guide PDF:

 – On the Cisco website:

http://www.cisco.com/en/US/products/ps6844/products_user_guide_list.html 

 – From the application folder on the local hard disk:

C:\Program Files\Cisco Systems\Cisco Unified 
Personal Communicator\resources\XXX\help\CUPC-help, where XXXX represents the 
numbered folder that holds the documentation in your language. For example, the 1033 
directory holds English-language documentation.

How to Resolve Reachability Status Problems
 • User in Contact List Shows Offline Status Even When Logged In to Cisco Unified 

Personal Communicator, page 1-17

 • Reachability Status of Contacts in the Contact List Is Incorrect or Missing, page 1-19

 • Reachability Status Does Not Change from Available to Busy, page 1-20

 • Reachability Information for Contacts in the Contact List Is Not Available for Large Contact Lists, 
page 1-21

User in Contact List Shows Offline Status Even When Logged In to Cisco Unified 
Personal Communicator

Problem   The user reports that another user in the contact list shows offline status (grey circle) even 
though that user is logged in to Cisco Unified Personal Communicator. 

Solution   Try these solutions:

 • Verify that Cisco Unified Personal Communicator is enabled for the user in Cisco Unified 
Communications Manager Administration. Choose System > Licensing > Capabilities 
Assignment, and check Enable UPC.

 • Verify that the user is on the same Cisco Unified Communications Manager cluster to which the 
Cisco Unified Presence server is connected.
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 • Tell the user to check their Cisco Unified PresenceUser Options page and make sure that the user 
with the offline status is not in a blocked user list. The user with the offline status might have 
selected to hide their presence status by device, changed their default presence rules, or created a 
user-defined policy that could cause this problem. 

Possible Cause   The Enterprise Presence Server Contact Name is not correctly configured.

Solution   

Step 1 In Cisco Unified Presence Administration, choose System > Service Parameters.

Step 2 Select a server and the Cisco UPS Presence Engine service from the drop-down lists. 

The Enterprise Presence Server Contact Name specifies the string that is inserted into the Contact header 
field of the SIP message. The format is:

Cisco Unified Presence IP address:5070;transport=tcp

For example: 172.27.13.111:5070;transport=tcp

Possible Cause   The Proxy Domain parameter is incorrectly configured in Cisco Unified Presence 
Administration. In a non-DNS environment, the proxy domain must be the IP address of the 
Cisco Unified Presence server. In a DNS environment that supports name-to-IP address resolution 
(without a DNS SRV), a domain name such as cisco.com is valid, and Cisco Unified 
Personal Communicator takes advantage of domain name resolution in this case.

Cisco Unified Personal Communicator derives the name of the Cisco Unified Presence SIP Proxy server 
from the name in the Proxy Profile, which appears in the Cisco Unified Personal Communicator log as 
Presence.Primary.Address and the Proxy Domain as Presence.Domain. If the former is in dotted-decimal 
notation, it is used as is; otherwise, the proxy name and domain are concatenated to form the fully 
qualified domain name (unless the name is found to already include the domain). 

An example of a configuration that does not work is a non-decimal proxy name (for example, 
gigantic-75) used with a dotted-decimal domain (10.32.134.75). These erroneously combine as 
gigantic-75.10.32.134.75, which does not resolve.

Solution   

Step 1 In Cisco Unified Presence Administration, choose System > Service Parameters.

Step 2 For Server, select the Cisco Unified Presence server.

Step 3 For Service, select Cisco UP SIP Proxy. 

Step 4 Scroll down and enter the IP address of the Cisco Unified Presence server into the Proxy Domain field. 

Step 5 Click Save.
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Possible Cause   Method/Event-Based Routing Configuration is not correctly configured. 

Solution   

Step 1 In Cisco Unified Presence Administration, choose Cisco Unified Presence > Proxy Server > 
Method/Event Routing). 

Step 2 Add four method/event routes listed in Table 1-3:

Reachability Status of Contacts in the Contact List Is Incorrect or Missing

Problem   The user reports that the reachability status of contacts in the Contacts list is incorrect or 
missing.

Solution   Try these solutions:

 • If the user is connected through Cisco Systems VPN Client software, make sure it is version 4.0.5 
or later. When the VPN client software is launched, from the Options menu, deselect (uncheck) 
Stateful Firewall. For Mac OS X, verify that the system firewall is not blocking incoming traffic. 
For details about configuring a computer for network ports used by Cisco Unified 
Personal Communicator details, see the release notes at this URL:

http://www.cisco.com/en/US/products/ps6844/prod_release_notes_list.html

 • In Cisco Unified Presence Administration, choose System > Troubleshooter. If any errors are 
displayed for the presence engine or the proxy server, follow the instructions to resolve these issues.

 • If the reachability issue is for users in a Cisco Unified Presence intercluster configuration, make 
sure that the users in question are not defined as valid users on both clusters.

 • Verify that you selected TCP as the Proxy Listener in Cisco Unified Presence Administration 
(Application > Unified Personal Communicator > Proxy Profile). Do not use the UDP setting for 
the Proxy Listener. For installation information, see the installation guide at this URL:

http://www.cisco.com/en/US/products/ps6844/prod_installation_guides_list.html

After making these changes, test to see if the reachability status information is correct by logging into 
Cisco Unified Personal Communicator. 

Table 1-3 Method/Event-Based Routing Configuration 

Field 1 2 3 4

Name DBChange_Route Login_Route PUBLISH_TCP SUBSCRIBE_TCP

Description DBChange_Route Login_Route PUBLISH_TCP SUBSCRIBE_TCP

Content Token DBChangePkg LoginPkg PUBLISH SUBSCRIBE

Content Category Event Type-Based Event Type-Based Method-Based Method-Based

Destination Address1

1. Destination address: Cisco Unified Presence fully qualified domain name or IP address of the next hop where the SIP message will be sent.

Cisco Unified Presence 
IP address or FQN

Cisco Unified Presence 
IP address or FQN

Cisco Unified Presence 
IP address or FQN

Cisco Unified Presence 
IP address or FQN

Destination Port 5065 5065 5070 5070

Protocol Type UDP UDP TCP TCP
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If the problem is not resolved or if disabling the firewall is not acceptable, verify that firewalls on the 
client computer or on the network are configured to pass Cisco Unified Personal Communicator traffic 
to avoid blocking reachability status information. For details about the network ports used by 
Cisco Unified Personal Communicator, see the release notes at this URL:

http://www.cisco.com/en/US/products/ps6844/prod_release_notes_list.html

Related Topics

 • How to Resolve Contact List Problems, page 1-9

Reachability Status Does Not Change from Available to Busy

Problem   The user reports that while in a call with another Cisco Unified Personal Communicator user, 
the reachability status does not change from available to busy for either one of them.

Solution   Try these solutions:

 • Make sure the users have Cisco Unified Personal Communicator set to Available mode on the 
Windows client or the Automatically Change Status for Activity on the Mac client. Follow the 
instructions in the user guide at this URL:

http://www.cisco.com/en/US/products/ps6844/products_user_guide_list.html

 • Make sure there is a presence gateway configured:

 – In Cisco Unified Presence Administration, choose Cisco Unified Presence > Presence 
Engine > Presence Gateways. Make sure that the Cisco Unified Presence gateway is set to the 
IP address of the correct Cisco Unified Communications Manager server.

 – In Cisco Unified Presence Administration, choose Cisco Unified Presence > Presence 
Engine > User-Agent Configuration. Make sure there is an entry called 
Cisco-UCModel01/x.x.x, where x.x.x corresponds to the Cisco Unified Personal Communicator 
release number. Click this link, and view the User-Agent Configuration information. Verify that 
the Reachability Version is set to RFC 4479 for Cisco Unified Personal Communicator Release 
1.2(1).

 – If the reachability issue is for users in a Cisco Unified Presence intercluster configuration, make 
sure that the users in question are not defined as valid users on both clusters.

 • Make sure the configuration in Cisco Unified Communications Manager Administration is correct:

 – Choose System > Service Parameter, and select the Cisco Unified Communications Manager 
server and service. Find the Clusterwide Parameters (System-Presence) section and set Default 
Inter-Presence Group Subscription to Allow Subscription.

 – Configure a presence SIP trunk. Choose System > Security Profile > SIP Trunk Security 
Profile. Find the trunk security profile for your system, and make sure Accept Presence 
Subscription is checked. Also check Accept Out-of-Dialing REFER, Accept Unsolicited 
Notifications, and Accept Replaces Header.

 – Make sure there is an association between the line configured for the user and the user in 
Cisco Unified Communications Manager. Choose Device > Phone, and find the directory 
number. In the Association Information section on the left side of the window, click the link for 
the line, and on the Directory Number Configuration window, scroll to the bottom of the page 
and make sure the user is associated with the line. Make sure you associate the line and user for 
all the phones using that directory number.
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 – Make sure the user has a primary extension assigned in Cisco Unified 
Communications Manager Administration. Choose User Management > End User.

 – Restart the SIP trunk. Choose Device > Trunk. Select the SIP trunk, and click Reset Selected.

 • Check that the user has not selected a Privacy setting (for example, created a blocked list, configured 
user-defined policies, or modified default reachability status settings) in the Cisco Unified Presence 
User Options web pages. For details, see the troubleshooting section in the Cisco Unified 
Personal Communicator user guide at this URL:

http://www.cisco.com/en/US/products/ps6844/products_user_guide_list.html

Reachability Information for Contacts in the Contact List Is Not Available for 
Large Contact Lists

Problem   The user reports that reachability information for contacts in the contact list is not available for 
large contact lists or when connected through a moderately lossy network (such as VPN over the 
Internet).

Solution   You might have configured Cisco Unified Personal Communicator to use UDP signaling with 
the Cisco Unified Presence SIP proxy server. Instead, you should select TCP as the Proxy Listener in 
Cisco Unified Presence Administration (Application > Unified Personal Communicator > Proxy 
Profile). Do not use the UDP setting for the Proxy Listener. For details about creating SIP proxy server 
profiles, see the installation guide at this URL:

http://www.cisco.com/en/US/products/ps6844/prod_installation_guides_list.html

How to Resolve Soft-Phone Problems
 • Cisco Unified Personal Communicator Does Not Connect the Phone, page 1-21

 • Cisco Unified Personal Communicator Changes to Desk Phone or to Disabled After Selecting 
Soft-Phone Mode, page 1-22

Cisco Unified Personal Communicator Does Not Connect the Phone

Problem   The user reports that on the Windows client, the application does not connect to the phone. On 
the Mac client, the icon within the application continuously spins without connecting the phone. The 
server health window (Help > Show Server Health on Windows and Help > Show System Diagnostics 
on the Mac) shows that Cisco Unified Personal Communicator correctly connects to the Logon and 
Presence servers. For the Phone Configuration (TFTP) server, it shows an unreachable error for UDP.

Solution   Check the firewall configuration on the affected client computer, and make sure that UDP traffic 
is not blocked. For details about network ports used by the application, see the Cisco Unified 
Personal Communicator release notes at this URL:

http://www.cisco.com/en/US/products/ps6844/prod_release_notes_list.html
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Cisco Unified Personal Communicator Changes to Desk Phone or to Disabled 
After Selecting Soft-Phone Mode

Problem   The user reports that after logging in to Cisco Unified Personal Communicator and selecting 
soft-phone mode, the application automatically changes to either Desk Phone or to Disabled after a few 
seconds.

Possible Cause   The soft phone could not register at that time. 

Solution   Try these solutions:

 • Ask the user to access the server health window (Help > Show Server Health on Windows and 
Help > Show System Diagnostics on Mac) and to provide that information to you. The window 
provides status information that helps you determine connection and configuration problems.

 • Instruct the user to try switching to soft-phone mode to see if the phone registers. If the application 
returns to No Phone (or to Disabled on Mac) mode, you should check the configuration in 
Cisco Unified Communications Manager Administration and in Cisco Unified Presence 
Administration. 

 • Verify that the TFTP server configuration in Cisco Unified Presence Administration (Application > 
Cisco Unified Personal Communicator > Settings) is correct. Verify that the a firewall is not 
blocking the soft-phone configuration file. For details about network ports used by Cisco Unified 
Personal Communicator, see the release notes at this URL:

http://www.cisco.com/en/US/products/ps6844/prod_release_notes_list.html

Possible Cause   The user is not correctly configured for soft-phone use in Cisco Unified 
Communications Manager Administration. 

Solution   For details about adding Cisco Unified Personal Communicator as a phone type in 
Cisco Unified Communications Manager Administration and specifying the soft-phone device name, 
see the Cisco Unified Personal Communicator installation guide at this URL:

http://www.cisco.com/en/US/products/ps6844/prod_installation_guides_list.html

How to Resolve Video Problems
 • Supported Video Telephony Camera Does Not Function, page 1-23

 • Full-Screen Overlaid on Second Monitor When Calling a Cisco Unified Video Advantage Endpoint, 
page 1-23

 • Incoming Video is Black, page 1-23

 • Video Merge Does Not Create a Video Conference, page 1-24
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Supported Video Telephony Camera Does Not Function

Problem   The user reports that a supported video telephony camera does not function.

Solution   Disconnect the camera from the client computer and then reconnect it. 

The Windows OS should automatically identify and locate the correct driver. If it does not, you can point 
it to this location (depending on the camera type):

drive:\Program Files\Cisco Systems\Cisco Unified Personal Communicator\CameraDriver

drive:\Program Files\Cisco Systems\Cisco Unified Personal Communicator\CameraDriver2

Full-Screen Overlaid on Second Monitor When Calling a Cisco Unified 
Video Advantage Endpoint

Problem   When a Cisco Unified Personal Communicator user calls another user who is using 
Cisco Unified Video Advantage 2.0(2), the remote user sees a full screen video on the second monitor 
with both local and remote video overlaid on one another. This produces a flickering effect. The remote 
user is using a Dell computer with an NVIDIA NVS, 120 ms, 512 MB video card with driver version 
6.14.10.8469. There is no problem when using other video cards.

Solution   Some dual video cards have an option to automatically select any display, which is not currently 
playing in a window (hardware overlay), to play video in a full-screen mode. This option is enabled by 
default, which causes the problem. 

Step 1 Right click on desktop, choose Properties > Settings tab> Advanced.

Step 2 Select the Quadro NVS 110M tab. 

Step 3 Click on the icon for the external monitor (or on the green button on the left).

Step 4 From the View Display Settings menu, select the full screen video option.

Step 5 For Full Screen Device, select Disable to disable the auto-select setting.

Incoming Video is Black

Problem   The user reports that the call connects, but the incoming video is black and there is no incoming 
audio.

Solution   Try these solutions:

 • Check the firewall configuration on the client computer or on the network. Verify that the correct 
network ports for Cisco Unified Personal Communicator operation are open. For details, see the 
release notes as this URL:

http://www.cisco.com/en/US/products/ps6844/prod_release_notes_list.html

 • Tell the user to click Hold/Resume. If this resolves the problem, suspect that Cisco Unified 
Communications Manager is experiencing a problem with different types of video endpoints.
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Video Merge Does Not Create a Video Conference

Problem   The user reports that a video merge does not create a video conference, and an audio-only 
conference is established instead.

Solution   Verify that a video conference bridge is available to be allocated and is available in the media 
resource group in Cisco Unified Communications Manager Administration for the originating 
Cisco Unified Personal Communicator device. Follow the video conferencing configuration steps in the 
Cisco Unified Personal Communicator installation guide at this URL:

http://www.cisco.com/en/US/products/ps6844/prod_installation_guides_list.html

How to Resolve Voice-Mail Problems
 • Voice Mail Does Not Appear in the Recent Pane, page 1-24

 • Voice-Mail Server Is Up, User Credentials Are Correct, But Voice-Mail Messages Are Not 
Downloaded, page 1-26

 • Send to Voicemail Option Is Not Selectable, page 1-27

Voice Mail Does Not Appear in the Recent Pane

Problem   The user reports that voice mail does not appear in the Recent pane. The Cisco Unified 
Personal Communicator log file contains this entry: 

[4044] WARN LCVoiceMail - %Logon failure: unknown user name or bad password 

Possible Cause   The voice-mail server or the network is down.

Solution   Try these solutions:

 • Ask the user to access the server health window (Help > Show Server Health on Windows and 
Help > Show System Diagnostics on Mac) and to provide the information to you. The window 
provides status information that helps you determine connection and configuration problems.

 • If the server cannot be contacted, the application attempts to reconnect at regular intervals. When 
the connection succeeds, the server downloads the voice-mail messages. Check the voice-mail 
server and network, and resolve the problem. 

Possible Cause   The user supplied incorrect voice-mail server credentials in Cisco Unified 
Personal Communicator (File > Preferences > Accounts).

Solution   If the connection to the server fails because the user credentials are incorrect, the application 
does not attempt to reconnect. The user must log out and then log in with the correct credentials so that 
the application can try to reconnect.
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Possible Cause   The password expired, or multiple failed login attempts caused the account to lock. 

Solution   Unlock the Cisco Unity (with Microsoft Exchange) account password. In Cisco Unity 
Administration, choose Subscribers > Subscribers > Account for the subscriber, and uncheck 
Cisco Unity Account Status.

Solution   Unlock the Cisco Unity Connection account password:

Step 1 From Cisco Unity Connection Administration, navigate to the individual user configuration page.

Step 2 From the navigation pane on the left, choose Users > Users, search for the user, and click the user name.

Step 3 From the menu, choose Edit > Password Settings.

Step 4 On the Edit Passwords Settings (Voicemail) window, for the Choose Password option, choose Web 
Application.

You should see the message: Password is locked due to too many failed logon attempts.

Step 5 Click Unlock Password.

Tip You can periodically run a User Lockout report on Cisco Unity Connection to see which accounts are 
locked. For details about generating user-specific reports, see the Cisco Unity Connection User Moves, 
Adds, and Changes Guide at this URL: 
http://www.cisco.com/en/US/products/ps6509/prod_maintenance_guides_list.html

Possible Cause   The password needs to be reset.

Solution   Reset the Cisco Unity Connection account password:

Step 1 From Cisco Unity Connection Administration, navigate to the individual user configuration page. From 
the navigation pane on the left, choose Users > Users, search for the user, and click the user name.

Step 2 From the menu, choose Edit > Change Password.

Step 3 On the Change Password (Voicemail) window, for the Choose Password option, choose Web 
Application.

Step 4 Enter a new password in the Password and Confirm Password fields.

Step 5 Communicate this new password to the user, provide the URL (Cisco Unity Connection address or 
hostname) to the user to log in, and instruct the user to change this default password to their own. 

Step 6 Tell the user to enter the personalized password in Cisco Unified Personal Communicator Account > 
Preferences > Unity window.

Possible Cause   Full IMAP (headers and body) access is not enabled on Cisco Unity Connection. 

Solution   The application connects to the server by using the Internet Mail Access Protocol (IMAP) to 
retrieve the voice-mail headers and to download the voice-mail message contents upon user request. In 
Cisco Unity Connection Administration, select Allow Users to Access Voice Mail Using an IMAP 
Client.
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Possible Cause   The IMAP is not properly configured for Cisco Unity with Exchange. 

Solution   Verify the IMAP configuration on the Exchange server. For configuration details, see the 
Cisco Unified Personal Communicator installation guide at this URL:

http://www.cisco.com/en/US/products/ps6844/prod_installation_guides_list.html

Voice-Mail Server Is Up, User Credentials Are Correct, But Voice-Mail 
Messages Are Not Downloaded

Problem   The user reports that the server can be contacted and the user credentials are correct, but 
voice-mail messages are not downloaded.

Solution   Try these solutions:

 • Ask the user to access the server health window (Help > Show Server Health on Windows and 
Help > Show System Diagnostics on Mac) and to provide that information to you. The window 
provides status information that helps you determine connection and configuration problems.

If the status for voice mail is OK (green) and existing voicemail are missing, delete the voice-mail 
cache by deleting all the files in these directories:

 – For Windows XP—C:\Documents and Settings\<USERID>\Local Settings\Application 
Data\Cisco\Unified Personal Communicator\VoiceMail

 – For Windows Vista—C:\Users\<user>\AppData\Local\Cisco\Unified Personal 
Communicator\VoiceMail 

 – For Mac—HOME/Library/Caches/Cisco/UnifiedPersonalCommunicator/VoiceMail 

This causes Cisco Unified Personal Communicator to download all the voice mails again.

 • Check the server configuration to ensure that IMAP is enabled. For details about configuring the 
voice-mail server, see the Cisco Unified Personal Communicator installation guide at this URL:

http://www.cisco.com/en/US/products/ps6844/prod_installation_guides_list.html

 • With Cisco Unity Connection, if you configured port 7993, make sure you enabled free licensing. 
In Cisco Unity Connection Administration, expand Class of Service in the left pane, and then click 
Class of Service. In the Search Results table, click the display name of the applicable class of 
service. Check Allows Users to Use Unified Client to Access Voice Mail.

 – On the Cisco Unity Connection server, type netstat -a -b and look for this information:

TCP    shibui-unity:7993      shibui-unity:0         LISTENING       3920   
[CuIMAPSvr.exe].  

This response verifies that Cisco Unified Personal Communicator is listening on port 7993.

 – Check the firewall configuration. On a remote computer, use Telnet to access Cisco Unified 
Personal Communicator port 7993. For example, if the IP address of the computer running 
Cisco Unified Personal Communicator is 10.77.27.178, enter telnet 10.77.27.178 7993. You 
should see a message similar to this:

* OK  UMSS IMAP4rev1 Server Completed.

If the connection attempt fails, add port 7993 to your firewall. For details about the network 
ports used by Cisco Unified Personal Communicator, see the release notes at this URL:

http://www.cisco.com/en/US/products/ps6844/prod_release_notes_list.html
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Send to Voicemail Option Is Not Selectable

Problem   The user reports that the Send to Voicemail option is not selectable (grayed out). 

Solution   Try these solutions:

 • Verify that the VoiceMail.PilotNumber in the Cisco Unified Personal Communicator log file is 
valid. 

 • Make sure that the voice-mail server profile is configured in Cisco Unified Presence Administration 
by choosing Application > Unified Personal Communicator > Unity Profile.

 – For the Voice Messaging Pilot drop-down list, select the number that the user dials to access 
their voice messages. 

 – Make sure that the user is a member of this profile by choosing Application > Unified Personal 
Communicator > User Settings.

 • Verify that the Cisco Unified Communications Manager configuration is correct; verify that a 
voice-mail pilot number is configured in the Voice Mail > Voice Mail Pilot menu. Follow the online 
help instructions for this page.

How to Resolve Cisco Unified MeetingPlace Express Web 
Conferencing Problems

Note In this section, messages that refer to Cisco Unified MeetingPlace Express also apply to Cisco Unified 
MeetingPlace Express VT unless stated otherwise.

 • Web Conferencing Button Is Not Selectable in Cisco Unified Personal Communicator, page 1-28

 • Conference Is Initiated on Host But Meeting Room Does Not Launch for Other Participants, 
page 1-28

 • Slow Performance When Escalating to a Web Conference from Within a Cisco Unified 
Personal Communicator Conversation, page 1-29

 • Unable to Start or End a Web Conferencing Session, page 1-29

 • Unable to Start or End a Web Conferencing Session; Error Communicating with the Server, 
page 1-30

 • Unable to Start or End a Web Conferencing Session; Could Not Contact Server, page 1-30

 • System Attempted to Schedule a Web Conference Without a Preferred Language, page 1-31

 • Web Conferencing Server Has Reached Its Licensed Capacity, page 1-31

 • Unable to Log In to the Web Conferencing Server; Internal Error; Login Module Exception, 
page 1-31

 • User Login ID or Password for Web Conferencing Server Is Invalid or Has Expired, page 1-32

 • User Profile Is Locked or Inactive, page 1-33

 • Web Conference That You Attempted to End No Longer Exists, page 1-33

 • Web Conference That You Attempted to End Has an Invalid Meeting Type, page 1-33

 • System Attempted to Schedule a Web Conference with an Invalid Length, page 1-34
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 • System Attempted to Schedule a Web Conference with a Duration That Exceeds the Maximum, 
page 1-34

 • System Attempted to Schedule a Web Conference for an Invalid Number of Parties, page 1-34

 • System Attempted to End a Web Conference Without Specifying a Meeting ID, page 1-35

 • Password for the Web Conferencing Server Is Missing, page 1-35

 • Web Conferencing Server Cannot Schedule the Meeting; Internal Scheduling Error, page 1-35

 • Web Conferencing Server Is Not Ready to Accept Requests, page 1-35

 • Login ID for Web Conferencing Server Is Missing, page 1-36

Web Conferencing Button Is Not Selectable in Cisco Unified 
Personal Communicator

Problem   The user reports that the Web Conferencing escalation button is not selectable (grayed out) in 
Cisco Unified Personal Communicator.

Solution   Try these solutions:

 • Verify that you configured a web conferencing server through the Cisco Unified Presence 
Administration web application under the Application > Unified Personal Communicator > 
MeetingPlace Server menu. The server name or IP address fields cannot be blank.

 • Ask the user to access the server health window (Help > Show Server Health on Windows and 
Help > Show System Diagnostics on Mac) and to provide that information to you. The window 
provides status information that helps you determine connection and configuration problems.

 • Verify that the user entered a username for this account in Cisco Unified Personal Communicator 
(File > Preferences > Accounts) as described in the Cisco Unified Personal Communicator user 
guide. The Username field cannot be blank.

Conference Is Initiated on Host But Meeting Room Does Not Launch for Other 
Participants

Problem   The user reports that after clicking the Web Conferencing escalation button, the conference is 
initiated only on the host, but the meeting room does not launch for the other Cisco Unified 
Personal Communicator clients in the call. 

Solution   The two most common causes of this problem are both configuration issues: 

 • Your dial plan rules in Cisco Unified Communications Manager Administration are not correct or 
are not complete. The phone number used to call the other party needs to be able to match with an 
LDAP directory entry using the dial rules.

 • Your LDAP attribute mappings are incorrect. There must be a mapping between the Cisco Unified 
Personal Communicator UserID attribute and a similar field in the LDAP attribute map. Check the 
settings in the LDAP Attribute Mapping table in Cisco Unified Presence Administration 
(Application > Unified Personal Communicator > Settings).

For details, see the Cisco Unified Personal Communicator installation guide at this URL:

http://www.cisco.com/en/US/products/ps6844/prod_installation_guides_list.html
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If these actions do not resolve the problem, gather the Cisco Unified Personal Communicator log file. 
Obtain a snapshot of the Cisco Unified MeetingPlace Express System Information Capture log, and send 
it to the Cisco TAC for assistance. For details about this log, see the troubleshooting information in the 
Cisco Unified MeetingPlace Express administrator configuration and maintenance guide at this URL:

http://www.cisco.com/en/US/products/ps6533/prod_maintenance_guides_list.html

Ask the user to capture the Cisco Unified Personal Communicator logs by using the Problem Reporting 
Tool (Problem Reporting Assistant on Mac) and to submit them to you.

Slow Performance When Escalating to a Web Conference from Within a 
Cisco Unified Personal Communicator Conversation

Problem   The user reports slow performance when escalating to a web conference from within a 
Cisco Unified Personal Communicator conversation.

Solution   Try these solutions:

 • If you are using Cisco Unified MeetingPlace Express Release 1.1.4 or later, reboot the server. 

 • If you are using Cisco Unified MeetingPlace Express Release 1.1.1 or 1.1.2, apply the hotfix 
attached to CSCsd22143. For details about accessing the Bug Toolkit, see the release notes at this 
URL:

http://www.cisco.com/en/US/products/ps6844/prod_release_notes_list.html

Unable to Start or End a Web Conferencing Session

Problem   The user receives the message “Unable to start a web conferencing session” or the message 
“Unable to end the web conferencing session.” 

Solution   Try these solutions:

 • Check the Cisco Unified MeetingPlace Express server, and make sure it is up. 

 • Verify that the URL being used by the user (found by clicking the Invite Participants button or by 
looking in the Cisco Unified Personal Communicator log file) is valid and can be reached from the 
client computer. 

 • Make sure the Cisco Unified MeetingPlace Express server and Cisco Unified 
Personal Communicator are using the same protocol (for example, HTTP versus HTTPS). 

 • Obtain a snapshot of the Cisco Unified MeetingPlace Express System Information Capture log, and 
send it to the Cisco TAC for assistance. For details about this log, see the troubleshooting 
information in the Cisco Unified MeetingPlace Express administrator configuration and 
maintenance guide at this URL:

http://www.cisco.com/en/US/products/ps6533/prod_maintenance_guides_list.html

If these actions do not resolve the problem, obtain a snapshot of the Cisco Unified MeetingPlace Express 
System Information Capture log, and send it to the Cisco TAC for assistance. For details about this log, 
see the troubleshooting information in the Cisco Unified MeetingPlace Express administrator 
configuration and maintenance guide at this URL:

http://www.cisco.com/en/US/products/ps6533/prod_maintenance_guides_list.html

Ask the user to capture the Cisco Unified Personal Communicator logs by using the Problem Reporting 
Tool (Problem Reporting Assistant on Mac) and to submit them to you.
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Unable to Start or End a Web Conferencing Session; Error Communicating with 
the Server

Problem   The user receives the message “Unable to start a web conferencing session. Error 
communicating with the web conferencing server” or the message “Unable to end the web conferencing 
session. Error communicating with the web conferencing server.”

Solution   Try these solutions:

 • Check the Cisco Unified MeetingPlace Express server, and make sure it is up. 

 • Verify that the URL being used by the user (found by clicking the Invite Participants button or by 
looking in the Cisco Unified Personal Communicator log file) is valid and can be reached from the 
client computer. 

 • Make sure the Cisco Unified MeetingPlace Express server and Cisco Unified 
Personal Communicator are using the same protocol (for example, HTTP versus HTTPS). 

If these actions do not resolve the problem, obtain a snapshot of the Cisco Unified MeetingPlace Express 
System Information Capture log, and send it to the Cisco TAC for assistance. For details about this log, 
see the troubleshooting information in the Cisco Unified MeetingPlace Express administrator 
configuration and maintenance guide at this URL:

http://www.cisco.com/en/US/products/ps6533/prod_maintenance_guides_list.html

Ask the user to capture the Cisco Unified Personal Communicator logs by using the Problem Reporting 
Tool (Problem Reporting Assistant on Mac) and to submit them to you.

Unable to Start or End a Web Conferencing Session; Could Not Contact Server

Problem   The user receives the message “Unable to start a web conferencing session. Could not contact 
the web conferencing server” or the message “Unable to end the web conferencing session. Could not 
contact the web conferencing server.”

Solution   Try these solutions:

 • Check the Cisco Unified MeetingPlace Express server, and make sure it is up. 

 • Verify that the URL (found by clicking the Invite Participants button or by looking in the 
Cisco Unified Personal Communicator log file) being used by the user is valid and can be reached 
from the client computer. 

 • Make sure the Cisco Unified MeetingPlace Express server and Cisco Unified 
Personal Communicator are using the same protocol (for example, HTTP versus HTTPS). 

If these actions do not resolve the problem, obtain a snapshot of the Cisco Unified MeetingPlace Express 
System Information Capture log, and send it to the Cisco TAC for assistance. For details about this log, 
see the troubleshooting information in the Cisco Unified MeetingPlace Express administrator 
configuration and maintenance guide at this URL:

http://www.cisco.com/en/US/products/ps6533/prod_maintenance_guides_list.html

Ask the user to capture the Cisco Unified Personal Communicator logs by using the Problem Reporting 
Tool (Problem Reporting Assistant on Mac) and to submit them to you.
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System Attempted to Schedule a Web Conference Without a Preferred 
Language

Problem   The user receives the message “The system attempted to schedule a web conference without a 
preferred language. Please contact your administrator for assistance.”

Solution   Try these solutions:

 • Check the Cisco Unified Personal Communicator log file to see what value was used for the 
language as shown in this example:

INFO LCMiddleware - ((CUPC5402 - MWMSG_WEBCONF_SCHEDULINGCONF)) Scheduling a web conf 
[[HOST:http://<server URL>]], [[USER:<userid>]], duration=60, ports=3, lang=en 

 • Check Cisco Unified MeetingPlace Express, and make sure the language licenses were purchased, 
downloaded, installed, and enabled. 

 • Configure language preferences in the user groups or the user profiles. Follow the instructions in the 
basic operations section of the Cisco Unified MeetingPlace Express administrator configuration and 
maintenance guide at this URL:

http://www.cisco.com/en/US/products/ps6533/prod_maintenance_guides_list.html

Web Conferencing Server Has Reached Its Licensed Capacity

Problem   The user receives the message “The web conferencing server has reached its licensed capacity 
for the current time. Please try your meeting again later.”

Solution   Buy more licenses, or change the Cisco Unified MeetingPlace Express web floater ports or web 
overbook ports settings or both. For details, see the administrator configuration and maintenance guide 
for Cisco Unified MeetingPlace Express at this URL:

http://www.cisco.com/en/US/products/ps6533/prod_maintenance_guides_list.html

Unable to Log In to the Web Conferencing Server; Internal Error; Login Module 
Exception

Problem   The user receives the message “Unable to log into the web conferencing server. Internal error, 
login module exception. Contact your administrator or try again later.”

Solution   Try these solutions:

 • Verify the Cisco Unified MeetingPlace Express user login credentials by having the user log in to 
the server directly. 

 • Check the Cisco Unified MeetingPlace Express server for errors. For details, see the 
troubleshooting information in the Cisco Unified MeetingPlace Express administrator configuration 
and maintenance guide at this URL:

http://www.cisco.com/en/US/products/ps6533/prod_maintenance_guides_list.html

 • Obtain a snapshot of the Cisco Unified MeetingPlace Express System Information Capture log, and 
send it to the Cisco TAC for assistance. 
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Chapter 1      Troubleshooting Cisco Unified Personal Communicator
How to Resolve Cisco Unified MeetingPlace Express Web Conferencing Problems
User Login ID or Password for Web Conferencing Server Is Invalid or Has 
Expired

Problem   The user receives the message “In order to perform this action, please do one or more of the 
following, as needed. Make sure the Cisco Unified MeetingPlace Express username and password 
entered in the Account Preferences in Cisco Unified Personal Communicator are correct and not expired. 
Try to log into Cisco Unified MeetingPlace Express directly. If you cannot, please contact your 
administrator.”

Solution   Try these solutions:

 • To check for an invalid password, have the user check their web conferencing credentials in 
Cisco Unified Personal Communicator (File > Preferences > Accounts) as described in the 
Cisco Unified Personal Communicator user guide. Verify the web conferencing user login 
credentials by having the user log in to the server directly.

 • To solve an expired password or locked account, log in to Cisco Unified MeetingPlace Express, and 
unlock the account. Then, reset the password to the default for your company. For details about 
unlocking a user profile and modifying user profiles (resetting the password), see the Cisco Unified 
MeetingPlace Express configuration and maintenance guide at this URL:

http://www.cisco.com/en/US/products/ps6533/products_installation_and_configuration_guides_lis
t.html

 • Provide the company default Cisco Unified MeetingPlace Express password to the user, ask them to 
log in to Cisco Unified MeetingPlace Express, access their profile, and personalize their password 
by following the instructions in the Cisco Unified MeetingPlace Express user guide at this URL:

http://www.cisco.com/en/US/products/ps6533/products_user_guide_list.html

The user must then enter this personalized password as their web conferencing credentials in 
Cisco Unified Personal Communicator (File > Preferences > Accounts).

User Password Has Expired on Cisco Unified MeetingPlace Express

Problem   The user receives a message that their password has expired on the Cisco Unified 
MeetingPlace Express server and to log in to Cisco Unified MeetingPlace directly and change their 
password.

Solution   Provide the user with user guide for Cisco Unified MeetingPlace Express web conferencing 
server at this URL:

http://www.cisco.com/en/US/products/ps6533/products_user_guide_list.html

It describes how to change passwords.
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Chapter 1      Troubleshooting Cisco Unified Personal Communicator
How to Resolve Cisco Unified MeetingPlace Express Web Conferencing Problems
User Profile Is Locked or Inactive

Problem   The user receives a message that their user profile on Cisco Unified MeetingPlace Express is 
locked or inactive and that starting a meeting is not possible until this problem is corrected. 

Solution   Try these solutions:

 • To solve an expired password or locked account, log in to Cisco Unified MeetingPlace Express, and 
unlock the account. Then, reset the password to the default for your company. For details about 
unlocking a user profile and modifying user profiles (resetting the password), see the Cisco Unified 
MeetingPlace Express configuration and maintenance guide at this URL:

http://www.cisco.com/en/US/products/ps6533/products_installation_and_configuration_guides_lis
t.html

 • Provide the company default Cisco Unified MeetingPlace Express password to the user, ask them to 
log in to Cisco Unified MeetingPlace Express, access their profile, and personalize their password 
by following the instructions in the Cisco Unified MeetingPlace Express user guide at this URL:

http://www.cisco.com/en/US/products/ps6533/products_user_guide_list.html

The user must then enter this personalized password as their web conferencing credentials in 
Cisco Unified Personal Communicator (File > Preferences > Accounts).

Web Conference That You Attempted to End No Longer Exists

Problem   The user receives the message “The web conference you attempted to end no longer exists.”

Solution   No action is required. This problem in unlikely to occur, but if it does, it causes no harm. 

Web Conference That You Attempted to End Has an Invalid Meeting Type

Problem   The user receives the message “The web conference you attempted to end has an invalid 
meeting type. Please contact your administrator for assistance.”

Solution   This problem is most likely a Cisco Unified Personal Communicator software defect. Ask the 
user to capture the Cisco Unified Personal Communicator logs by using the Problem Reporting Tool 
(Problem Reporting Assistant on Mac) and to submit them to you. 

Obtain a snapshot of the Cisco Unified MeetingPlace Express System Information Capture log, and send 
it to the Cisco TAC for assistance. For details about this log, see the troubleshooting information in the 
Cisco Unified MeetingPlace Express administrator configuration and maintenance guide at this URL:

http://www.cisco.com/en/US/products/ps6533/prod_maintenance_guides_list.html
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Chapter 1      Troubleshooting Cisco Unified Personal Communicator
How to Resolve Cisco Unified MeetingPlace Express Web Conferencing Problems
System Attempted to Schedule a Web Conference with an Invalid Length

Problem   The user receives the message “The system attempted to schedule a web conference with an 
invalid length. Please contact your administrator for assistance.”

Solution   Try these solutions:

 • Check the Cisco Unified Personal Communicator log file to see what value was used for the length 
(duration) as shown in this example:

INFO LCMiddleware - ((CUPC5402 - MWMSG_WEBCONF_SCHEDULINGCONF)) Scheduling a web conf 
[[HOST:http://<server URL>]], [[USER:<userid>]], duration=60, ports=3, lang=en 

 • Check the Cisco Unified MeetingPlace Express “Maximum meeting length” setting on the Meeting 
Configuration page. Meetings can be scheduled for no longer than this number of minutes.

 • Change the conference server setting to be at least as large as the value in the log.

System Attempted to Schedule a Web Conference with a Duration That 
Exceeds the Maximum

Problem   The user receives the message “The system attempted to schedule a web conference with a 
duration that exceeds the configured maximum on the web conferencing server. Please contact your 
administrator for assistance.”

Solution   Try these solutions:

 • Check the Cisco Unified Personal Communicator log file to see what value was used for the length. 

 • Check the Cisco Unified MeetingPlace Express “Maximum meeting length” value on the Meeting 
Configuration page. Users cannot schedule meetings longer than this number of minutes. Consider 
whether the meeting length accurately reflects the typical meeting duration conducted by your 
company. Most likely, the configured meeting length is too small.

System Attempted to Schedule a Web Conference for an Invalid Number of 
Parties

Problem   The user receives the message “The system attempted to schedule a web conference for an 
invalid number of parties. Please contact your administrator for assistance.”

Solution   Try these solutions:

 • Check the Cisco Unified Personal Communicator log file to see what value was used for parties 
(ports) as shown in this sample log file:

INFO LCMiddleware - ((CUPC5402 - MWMSG_WEBCONF_SCHEDULINGCONF)) Scheduling a web conf 
[[HOST:http://<server URL>]], [[USER:<userid>]], duration=60, ports=3, lang=en 

 • On Cisco Unified MeetingPlace Express, check the “Maximum ports per meeting” setting on the 
Meeting Configuration page. Compare the conference server setting to the value in the log. If the 
value in the log is not the number of parties + 1, contact the Cisco TAC.
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How to Resolve Cisco Unified MeetingPlace Express Web Conferencing Problems
System Attempted to End a Web Conference Without Specifying a Meeting ID

Problem   The user receives the message “The system attempted to end a web conference without 
specifying a meeting ID. Please report this problem to your administrator.”

Solution   This problem is most likely a Cisco Unified Personal Communicator software defect. Contact 
the Cisco TAC for assistance.

Password for the Web Conferencing Server Is Missing

Problem   The user receives the message “Your password for the web conferencing server is missing. 
Please verify your Cisco Unified MeetingPlace credentials as configured in Account Preferences.”

Solution   Have the user check their web conferencing credentials in Cisco Unified 
Personal Communicator (File > Preferences > Accounts) as described in the Cisco Unified 
Personal Communicator user guide at this URL:

http://www.cisco.com/en/US/products/ps6844/products_user_guide_list.html

Web Conferencing Server Cannot Schedule the Meeting; Internal Scheduling 
Error

Problem   The user receives the message “The web conferencing server could not schedule the meeting. 
Internal scheduling error. Please contact your administrator for assistance.”

Solution   Test to see if this user can schedule the meeting through the Cisco Unified 
MeetingPlace Express web user interface. If yes, the problem is most likely the result of a Cisco Unified 
MeetingPlace Express software bug. Obtain a snapshot of the Cisco Unified MeetingPlace Express 
System Information Capture log, and send it to the Cisco TAC for assistance. For details about this log, 
see the troubleshooting information in the Cisco Unified MeetingPlace Express administrator 
configuration and maintenance guide at this URL:

http://www.cisco.com/en/US/products/ps6533/prod_maintenance_guides_list.html

Web Conferencing Server Is Not Ready to Accept Requests

Problem   The user receives the message “The web conferencing server is not currently ready to accept 
requests. Please try your request again later, or contact your administrator.”

Solution   Try these solutions:

 • Check the Cisco Unified MeetingPlace Express server, and make sure it is up. 

 • Verify that the URL being used by the user (found in the Cisco Unified Personal Communicator log 
file) is valid and can be reached from the client computer. 

 • Make sure the Cisco Unified MeetingPlace Express server and Cisco Unified 
Personal Communicator are using the same protocol (for example, HTTP versus HTTPS). 
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How to Resolve Cisco Unified MeetingPlace Web Conferencing Problems
If these actions do not resolve the problem, obtain a snapshot of the Cisco Unified MeetingPlace Express 
System Information Capture log, and send it to the Cisco TAC for assistance. For details about this log, 
see the troubleshooting information in the Cisco Unified MeetingPlace Express administrator 
configuration and maintenance guide at this URL:

http://www.cisco.com/en/US/products/ps6533/prod_maintenance_guides_list.html

Ask the user to capture the Cisco Unified Personal Communicator logs by using the Problem Reporting 
Tool (Problem Reporting Assistant on Mac) and to submit them to you.

Login ID for Web Conferencing Server Is Missing

Problem   The user receives the message “Your login ID for the web conferencing server is missing. 
Please verify your Cisco Unified MeetingPlace credentials as configured in Account Preferences.”

Solution   Have the user check the web conferencing credentials in Cisco Unified Personal Communicator 
(File > Preferences > Accounts) as described in the Cisco Unified Personal Communicator user guide 
at this URL:

http://www.cisco.com/en/US/products/ps6844/products_user_guide_list.html

How to Resolve Cisco Unified MeetingPlace Web Conferencing 
Problems

 • Web Conferencing Button Is Not Selectable in Cisco Unified Personal Communicator, page 1-37

 • Conference Is Initiated on Host But Meeting Room Does Not Launch for Other Participants, 
page 1-37

 • User Profile Is Locked or Inactive, page 1-37

 • User Password Has Expired on Cisco Unified MeetingPlace, page 1-37

 • User Can Access Cisco Unified MeetingPlace from a Browser But Cisco Unified 
Personal Communicator Reports the Credentials Are Wrong, page 1-38

 • Password for the Web Conferencing Server Is Missing, page 1-38

 • User Does Not Have Permission to Start or End a Meeting, page 1-38

 • Web Conferencing Session Will Not Start or End, page 1-38

 • Unable to Start or End Web Conferencing Session; Web Server Is Not Connected, page 1-39

 • Meeting No Longer Exists on the Cisco Unified MeetingPlace Server, page 1-39

 • Cisco Unified MeetingPlace Host Name Is Not Resolving, page 1-39

 • Proxy Server Host Name Is Not Resolving, page 1-40

 • Web Server Does Not Respond Within Timeout Interval, page 1-40

 • Web Server Returns an Empty Response, page 1-40

 • Security Certificate Is Not Verifiable, page 1-41

 • Security Certificate Is Invalid, page 1-41

 • Security Certificate Is Invalid or Not Readable, page 1-42

 • Security Certificate Does Not Match Target Host Name, page 1-42
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Chapter 1      Troubleshooting Cisco Unified Personal Communicator
How to Resolve Cisco Unified MeetingPlace Web Conferencing Problems
Web Conferencing Button Is Not Selectable in Cisco Unified 
Personal Communicator

Problem   The user reports that the Web Conferencing escalation button is not selectable (grayed out) in 
Cisco Unified Personal Communicator.

Solution   To resolve this issue, see the “Web Conferencing Button Is Not Selectable in Cisco Unified 
Personal Communicator” section on page 1-28. The solution applies to web conferencing through 
Cisco Unified MeetingPlace Express and through Cisco Unified MeetingPlace.

Conference Is Initiated on Host But Meeting Room Does Not Launch for Other 
Participants

Problem   The user reports that after clicking the Web Conferencing escalation button, the conference is 
initiated only on the host, but the meeting room does not launch for the other Cisco Unified 
Personal Communicator clients in the call.

Solution   To resolve this issue, see the “Conference Is Initiated on Host But Meeting Room Does Not 
Launch for Other Participants” section on page 1-28. The solution applies to web conferencing through 
Cisco Unified MeetingPlace Express and through Cisco Unified MeetingPlace.

User Profile Is Locked or Inactive

Problem   The user receives the message “Your user profile on Cisco Unified MeetingPlace is locked or 
inactive. You will not be able to start a meeting until this is corrected. Please contact your administrator 
for assistance.”

Solution   Try these solutions:

 • If the user knows their password, unlock the profile in MeetingTime. From the System tab, select 
View Locked Profiles. Click Execute. On the Locked Profiles window, select the profile, and click 
Set to Group. 

If the user does not know their password, change the user password in MeetingTime, and unlock the 
profile. From the Configure tab, select User Profile. Locate the user profile by searching for the user 
ID. For the User password field, enter a new password. Change Profile active? to Group Dflt (Yes).

 • Change the user password in MeetingTime. From the Configure tab, select User Profile. Locate the 
user profile by searching for the user ID. For the User password field, enter a new password.

User Password Has Expired on Cisco Unified MeetingPlace

Problem   The user receives the message “Your password has expired on the Cisco Unified MeetingPlace 
server. Please log into Cisco Unified MeetingPlace directly and change your password, or contact your 
administrator for assistance.”

Solution   Provide the user with user guide for Cisco Unified MeetingPlace web conferencing server at 
this URL:

http://www.cisco.com/en/US/products/sw/ps5664/ps5669/products_user_guide_list.html

It describes how to change passwords.
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Chapter 1      Troubleshooting Cisco Unified Personal Communicator
How to Resolve Cisco Unified MeetingPlace Web Conferencing Problems
User Can Access Cisco Unified MeetingPlace from a Browser But 
Cisco Unified Personal Communicator Reports the Credentials Are Wrong

Problem   The user reports being able to access Cisco Unified MeetingPlace from a browser, but 
Cisco Unified Personal Communicator provides a message that the user credentials are wrong.

Solution   Ask the user to verify their Cisco Unified MeetingPlace credentials from a browser. If 
automatically logged in to Cisco Unified MeetingPlace, ask the user to click the sign-out link in the 
browser and then try to log in again. If the log-in attempt fails, the credentials in Cisco Unified 
Personal Communicator are incorrect. If the user does not know their password, change it in 
MeetingTime. From the Configure tab, select User Profile. Locate the user profile by searching for the 
user ID. For the User password field, enter a new password.

Password for the Web Conferencing Server Is Missing

Problem   The user receives the message “Your password for the web conferencing server is missing. 
Please verify your Cisco Unified MeetingPlace credentials as configured in Account Preferences.”

Solution   Have the user check their web conferencing credentials in Cisco Unified 
Personal Communicator (File > Preferences > Accounts) as described in the Cisco Unified 
Personal Communicator user guide at this URL:

http://www.cisco.com/en/US/products/ps6844/products_user_guide_list.html

User Does Not Have Permission to Start or End a Meeting

Problem   The user receives one of these message:

 • “You do not have permission to start a meeting on the Cisco Unified MeetingPlace server. Please 
contact your system administrator for assistance.”

 • “You do not have permission to end one of these meetings on the Cisco Unified MeetingPlace 
server.”

Solution   Cisco Unified MeetingPlace allows you to create user profiles without providing the ability to 
schedule (start or end) meetings. Log in to MeetingTime, and make sure the Scheduling Restriction field 
is not set to Cannot Schedule for this user profile. For other solutions, see the troubleshooting section in 
Cisco Unified MeetingPlace audio server administration guide at this URL:

http://www.cisco.com/en/US/products/sw/ps5664/ps5669/prod_troubleshooting_guides_list.html

Web Conferencing Session Will Not Start or End

Problem   The user receives the message “Unable to start a web conferencing session” or the message 
“Unable to end the web conferencing session.”

Solution   Try these solutions:

 • Check the Cisco Unified MeetingPlace server, and make sure it is up. 

 • If the problem persists, ask the user to capture the Cisco Unified Personal Communicator logs by 
using the Problem Reporting Tool (Problem Reporting Assistant on Mac) and to submit them to you. 
Send them to the Cisco TAC for assistance. 
1-38
Troubleshooting Guide for Cisco Unified Personal Communicator, Release 1.2

OL-11717-01

http://www.cisco.com/en/US/products/ps6844/products_user_guide_list.html
http://www.cisco.com/en/US/products/sw/ps5664/ps5669/prod_troubleshooting_guides_list.html


 

Chapter 1      Troubleshooting Cisco Unified Personal Communicator
How to Resolve Cisco Unified MeetingPlace Web Conferencing Problems
Unable to Start or End Web Conferencing Session; Web Server Is Not 
Connected

Problem   The user receives one of these messages:

 • “Unable to start a web conferencing session. The Cisco Unified MeetingPlace web server is not 
connected to MeetingPlace. Please wait a few minutes and try again. If the problem persists, please 
contact your administrator for assistance.”

 • “Unable to end a web conferencing session. The Cisco Unified MeetingPlace web server is not 
connected to MeetingPlace. Please wait a few minutes and try again. If the problem persists, please 
contact your administrator for assistance.”

Solution   This problem could occur if the Cisco Unified MeetingPlace web server is up, but it is not 
connected to the Cisco Unified MeetingPlace audio server. Resolve any network problems between the 
two servers. Make sure the audio server is up and is not rebooting.

Meeting No Longer Exists on the Cisco Unified MeetingPlace Server

Problem   The user receives the message “This meeting no longer exists on the 
Cisco Unified MeetingPlace server.”

Solution   No action is required. This problem in unlikely to occur, but if it does, it causes no harm.

Cisco Unified MeetingPlace Host Name Is Not Resolving

Problem   The user receives the message “There was a problem resolving the host name of the 
Cisco Unified MeetingPlace server. Please contact your administrator for assistance.”

Solution   This problem is most likely the result of DNS problems on the client (for example, the client is 
pointing to the wrong DNS server or there is no DNS entry for the server) where the name of the web 
server that you configured in Cisco Unified Presence Administration cannot be resolved through a DNS 
lookup on the client.

Try these solutions:

 • Verify the Cisco Unified MeetingPlace server address, port, and protocol in Cisco Unified 
Personal Communicator. Choose Help > System Diagnostics, and click Web Conferencing. Ping 
the server address from the client computer (or put it in a browser) to check the connectivity.

 • Make sure the Cisco Unified MeetingPlace server and Cisco Unified Personal Communicator are 
using the same protocol (for example, HTTP versus HTTPS). 

 • Check the Cisco Unified MeetingPlace server, and make sure it is up. 

The web server must be able to connect to itself by using the hostname you configured on the Web 
Server administrative page. This is also the hostname used by end users to connect to this web 
server. Connection problems are most likely caused by firewall-related configurations. For details 
about HTTP connection problems, see the Cisco Unified MeetingPlace web conferencing 
installation and upgrade guide at this URL:

http://www.cisco.com/en/US/products/sw/ps5664/ps5669/prod_installation_guides_list.html
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Chapter 1      Troubleshooting Cisco Unified Personal Communicator
How to Resolve Cisco Unified MeetingPlace Web Conferencing Problems
If these actions do not resolve the problem, obtain a snapshot of the Cisco Unified MeetingPlace log 
files, and send them to the Cisco TAC for assistance. For details about capturing logs, see the 
Cisco Unified MeetingPlace documentation at this URL:

http://www.cisco.com/en/US/products/sw/ps5664/ps5669/tsd_products_support_series_home.html

Ask the user to capture the Cisco Unified Personal Communicator logs by using the Problem Reporting 
Tool (Problem Reporting Assistant on Mac) and to submit them to you.

Proxy Server Host Name Is Not Resolving

Problem   The user receives the message “There was a problem resolving the name of your proxy server 
while attempting to contact the Cisco Unified MeetingPlace server. Please contact your administrator for 
assistance.”

Solution   Cisco Unified Personal Communicator Release 1.2(1) does not support proxy servers between 
Cisco Unified Personal Communicator and the web conferencing server.

Web Server Does Not Respond Within Timeout Interval

Problem   The user receives the message “The Cisco Unified MeetingPlace server did not respond within 
the timeout interval. If the problem persists, please contact your administrator for assistance.”

Solution   The problem is likely caused by a network latency problem or by a web server that is extremely 
busy. Ask the user to try again in a few minutes. If the problem persists, review your network 
infrastructure to reduce latency and improve traffic patterns.

Web Server Returns an Empty Response

Problem   The user receives the message “The Cisco Unified MeetingPlace server returned an empty 
response. If the problem persists, please contact your administrator for assistance.”

Solution   Try these solutions:

 • Check the Cisco Unified MeetingPlace server, and make sure it is up. 

 • Verify that the URL being used by the user is valid and can be reached from the client computer. The 
URL can be found in Cisco Unified Personal Communicator Help > System Diagnostics, and click 
Web Conferencing. The display shows server address, ports, and protocols.

 • Make sure the Cisco Unified MeetingPlace server and Cisco Unified Personal Communicator are 
using the same protocol (for example, HTTP versus HTTPS). 

If these actions do not resolve the problem, obtain a snapshot of the Cisco Unified MeetingPlace log 
files, and send them to the Cisco TAC for assistance. Ask the user to capture the Cisco Unified 
Personal Communicator logs by using the Problem Reporting Tool (Problem Reporting Assistant on 
Mac) and to submit them to you.
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Chapter 1      Troubleshooting Cisco Unified Personal Communicator
How to Resolve Cisco Unified MeetingPlace Web Conferencing Problems
Security Certificate Is Not Verifiable

Problem   The user receives one of these messages:

 • “There was a problem verifying the authenticity of the SSL security certificate from the 
Cisco Unified MeetingPlace server. Please contact your administrator for assistance. Would you like 
to ignore this warning and try to start the web conference anyway?”

 • There was a problem verifying the authenticity of the SSL security certificate from the 
Cisco Unified MeetingPlace server. Please contact your administrator for assistance. Would you like 
to ignore this warning and try to end the web conference anyway?”

Solution   This problem occurs only if you configured the web server for HTTPS, and you are using a 
self-signed SSL certificate on the web server. 

Ask the user to access the web server with their browser. When prompted about the certificate, the user 
should choose the option to import it. The user should also restart Cisco Unified 
Personal Communicator.

For details, see the Cisco Unified MeetingPlace web conferencing server configuration guide at this 
URL:

http://www.cisco.com/en/US/products/sw/ps5664/ps5669/products_installation_and_configuration_gui
des_list.html

Security Certificate Is Invalid

Problem   The user receives one of these message:

 • “The SSL security certificate from the Cisco Unified MeetingPlace server is invalid. Please contact 
your administrator for assistance. Would you like to ignore this warning and try to start the web 
conference anyway?”

 • “The SSL security certificate from the Cisco Unified MeetingPlace server is invalid. Please contact 
your administrator for assistance. Would you like to ignore this warning and try to end the web 
conference anyway?”

Solution   This problem can occur if there is a problem verifying the SSL certificate or if the certificate 
has expired. Try these solutions:

 • Verify the certificate installation and configuration on the Cisco Unified MeetingPlace web 
conferencing server. For details, see the Cisco Unified MeetingPlace web conferencing server 
configuration guide at this URL:

http://www.cisco.com/en/US/products/sw/ps5664/ps5669/products_installation_and_configuration
_guides_list.html

 • Obtain a snapshot of the Cisco Unified MeetingPlace log files, and send them to the Cisco TAC for 
assistance. For details about capturing logs, see the Cisco Unified MeetingPlace documentation at 
this URL:

http://www.cisco.com/en/US/products/sw/ps5664/ps5669/tsd_products_support_series_home.html

 • Ask the user to capture the Cisco Unified Personal Communicator logs by using the Problem 
Reporting Tool (Problem Reporting Assistant on Mac) and to submit them to you. Provide this report 
to Cisco TAC.
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Chapter 1      Troubleshooting Cisco Unified Personal Communicator
How to Resolve Cisco Unified MeetingPlace Web Conferencing Problems
Security Certificate Is Invalid or Not Readable

Problem   The user receives the message “There was a problem verifying the authenticity of the SSL 
security certificate from the Cisco Unified MeetingPlace server. The CA certificate file is invalid or 
could not be read. Please contact your administrator for assistance.”

Solution   This problem is likely due to a security problem on the client. Try these solutions:

 • Obtain a snapshot of the Cisco Unified MeetingPlace log files, and send them to the Cisco TAC for 
assistance. For details about capturing logs, see the Cisco Unified MeetingPlace documentation at 
this URL:

http://www.cisco.com/en/US/products/sw/ps5664/ps5669/tsd_products_support_series_home.html

 • Ask the user to capture the Cisco Unified Personal Communicator logs by using the Problem 
Reporting Tool (Problem Reporting Assistant on Mac) and to submit them to you. Provide this report 
to Cisco TAC.

Security Certificate Does Not Match Target Host Name

Problem   The user receives one of these messages:

 • “The name on the Cisco Unified MeetingPlace web server SSL security certificate does not match 
the target host name. Please contact your administrator to correct the problem. Would you like to 
ignore this warning and try to start the web conference anyway?”

 • “The name on the Cisco Unified MeetingPlace web server SSL security certificate does not match 
the target host name. Please contact your administrator to correct the problem. Would you like to 
ignore this warning and try to end the web conference anyway?”

 • “The name on the Cisco Unified MeetingPlace web server SSL security certificate does not match 
the target host name. Please contact your administrator to correct the problem.”

Solution   The name in the SSL certificate that is installed on the Cisco Unified MeetingPlace web server 
does not exactly match the name of the server that is configured in Cisco Unified Presence 
Administration. 

Try these solutions:

 • View the name on the SSL certificate. Access the web server from a browser, and when prompted, 
click the button to view the certificate. Compare the name in the certificate with the name configured 
in Cisco Unified Presence Administration and in Cisco Unified MeetingPlace.

 • Change the server name in Cisco Unified Presence Administration to match the one in the 
certificate. Choose Application > Unified Personal Communicator > MeetingPlace Server. 

 – Make sure that the web server name in Cisco Unified Presence Administration is a fully 
qualified domain name. 

 – Verify that you did not configure the server name as an IP address.

 • Sign in to Cisco Unified MeetingPlace Web Conferencing with your System Manager-level user ID 
and password, and choose Admin > Web Server. Verify that you configured the web conferencing 
server host name with a fully qualified domain name (hostname.domain.com). This host name must 
match the value in the SSL certificate. 
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Third-Party Copyright and License Information

THE SPECIFICATIONS AND INFORMATION REGARDING THE PRODUCTS IN THIS MANUAL ARE SUBJECT TO CHANGE WITHOUT 
NOTICE. ALL STATEMENTS, INFORMATION, AND RECOMMENDATIONS IN THIS MANUAL ARE BELIEVED TO BE ACCURATE BUT 
ARE PRESENTED WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED. USERS MUST TAKE FULL RESPONSIBILITY FOR 
THEIR APPLICATION OF ANY PRODUCTS.

THE SOFTWARE LICENSE AND LIMITED WARRANTY FOR THE ACCOMPANYING PRODUCT ARE SET FORTH IN THE INFORMATION 
PACKET THAT SHIPPED WITH THE PRODUCT AND ARE INCORPORATED HEREIN BY THIS REFERENCE. IF YOU ARE UNABLE TO 
LOCATE THE SOFTWARE LICENSE OR LIMITED WARRANTY, CONTACT YOUR CISCO REPRESENTATIVE FOR A COPY.

The Cisco implementation of TCP header compression is an adaptation of a program developed by the University of California, Berkeley (UCB) as 
part of UCB’s public domain version of the UNIX operating system. All rights reserved. Copyright © 1981, Regents of the University of California. 

NOTWITHSTANDING ANY OTHER WARRANTY HEREIN, ALL DOCUMENT FILES AND SOFTWARE OF THESE SUPPLIERS ARE 
PROVIDED “AS IS” WITH ALL FAULTS. CISCO AND THE ABOVE-NAMED SUPPLIERS DISCLAIM ALL WARRANTIES, EXPRESSED 
OR IMPLIED, INCLUDING, WITHOUT LIMITATION, THOSE OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND 
NONINFRINGEMENT OR ARISING FROM A COURSE OF DEALING, USAGE, OR TRADE PRACTICE.

IN NO EVENT SHALL CISCO OR ITS SUPPLIERS BE LIABLE FOR ANY INDIRECT, SPECIAL, CONSEQUENTIAL, OR INCIDENTAL 
DAMAGES, INCLUDING, WITHOUT LIMITATION, LOST PROFITS OR LOSS OR DAMAGE TO DATA ARISING OUT OF THE USE OR 
INABILITY TO USE THIS MANUAL, EVEN IF CISCO OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH 
DAMAGES.

Required Notices: 

H.263

UB VIDEO INC. IS THE LICENSOR OF THE UB VIDEO H.263 PROFILE 3 CODEC (ANNEXES I, J, K AND T).

H.264

PORTIONS OF THE H.264 CODEC WERE PROVIDED BY VANGUARD SOFTWARE SOLUTIONS INC   1995-2005 ALL RIGHTS RESERVED

THIS PRODUCT IS LICENSED UNDER THE AVC PATENT PORTFOLIO LICENSE FOR THE PERSONAL AND NON-COMMERCIAL USE 
OF A CONSUMER TO (i) ENCODE VIDEO IN COMPLIANCE WITH THE AVC STANDARD ("AVC VIDEO") AND/OR (ii) DECODE AVC 
VIDEO THAT WAS ENCODED BY A CONSUMER ENGAGED IN A PERSONAL AND NON-COMMERCIAL ACTIVITY AND/OR WAS 
OBTAINED FROM A VIDEO PROVIDER LICENSED TO PROVIDE AVC VIDEO. NO LICENSE IS GRANTED OR SHALL BE IMPLIED FOR 
ANY OTHER USE. ADDITIONAL INFORMATION MAY BE OBTAINED FROM MPEG LA, L.L.C. SEE HTTP://WWW.MPEGLA.COM

resiprocate, dum - http://www.resiprocate.org

The Vovida Software License v. 1.0

Copyright (c) 2000 Vovida Networks, Inc.  All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation 
and/or other materials provided with the distribution.
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3. The names "VOCAL", "Vovida Open Communication Application Library", and "Vovida Open Communication Application Library (VOCAL)" 
must not be used to endorse or promote products derived from this software without prior written permission. For written permission, please contact 
vocal@vovida.org.

4. Products derived from this software may not be called "VOCAL", nor may "VOCAL" appear in their name, without prior written permission.

THIS SOFTWARE IS PROVIDED "AS IS" AND ANY EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE 
IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE AND NONINFRINGEMENT ARE 
DISCLAIMED. IN NO EVENT SHALL VOVIDA NETWORKS, INC. OR ITS CONTRIBUTORS BE LIABLE FOR ANY DAMAGES IN EXCESS 
OF $1,000, NOR FOR ANY INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT 
LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS 
INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT 
(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF 
THE POSSIBILITY OF SUCH DAMAGE.

ares

Copyright 1998 by the Massachusetts Institute of Technology.

Permission to use, copy, modify, and distribute this software and its documentation for any purpose and without fee is hereby granted, provided that 
the above copyright notice appear in all copies and that both that copyright notice and this permission notice appear in supporting documentation, 
and that the name of M.I.T. not be used in advertising or publicity pertaining to distribution of the software without specific, written prior permission. 

M.I.T. makes no representations about the suitability of this software for any purpose. It is provided "as is" without express  or implied warranty.

Neon, G.711

neon is an HTTP and WebDAV client library, with a C language API.

Bindings for other languages may also be available, see the web site for more details.

neon is Copyright (C) 1999-2004 Joe Orton <joe@manyfish.co.uk>

Portions are:

Copyright (C) 1999-2000 Tommi Komulainen <Tommi.Komulainen@iki.fi>

Copyright (C) 1999-2000 Peter Boos <pedib@colorfullife.com>

Copyright (C) 1991, 1995, 1996, 1997 Free Software Foundation, Inc.

Copyright (C) 2004 Aleix Conchillo Flaque <aleix@member.fsf.org>

Copyright (C) 2004-2005, Vladimir Berezniker @ http://public.xdi.org/=vmpn

GNU Lesser General Public License (LGPL) 

This library is free software; you can redistribute it and/or modify it under the terms of the GNU Library General Public     License as published by 
the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of 
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU Library General Public License for more details.

You should have received a copy of the GNU Library General Public License along with this library; if not, write to the Free Software Foundation, 
Inc., 59 Temple Place - Suite 330, Boston,MA 02111-1307, USA

iLBC

Full Copyright Statement

Copyright (C) The Internet Society (2004).

This document is subject to the rights, licenses and restrictions contained in BCP 78, and except as set forth therein, the authors retain all their rights.

This document and the information contained herein are provided on an"AS IS" basis and THE CONTRIBUTOR, THE ORGANIZATION HE/SHE 
REPRESENTS OR IS SPONSORED BY (IF ANY), THE INTERNET SOCIETY AND THE INTERNET ENGINEERING TASK FORCE 
DISCLAIM ALL WARRANTIES, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO ANY WARRANTY THAT THE USE OF THE 
INFORMATION HEREIN WILL NOT INFRINGE ANY RIGHTS OR ANY IMPLIED WARRANTIES OF MERCHANTABILITY OR FITNESS 
FOR A PARTICULAR PURPOSE.

Intellectual Property
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The IETF takes no position regarding the validity or scope of any Intellectual Property Rights or other rights that might be claimed to pertain to the 
implementation or use of the technology described in this document or the extent to which any license under such rights might or might not be 
available; nor does it represent that it has made any independent effort to identify any such rights. Information on the IETF's procedures with respect 
to rights in IETF Documents can be found in BCP 78 and BCP 79.

Copies of IPR disclosures made to the IETF Secretariat and any assurances of licenses to be made available, or the result of an attempt made to obtain 
a general license or permission for the use of such proprietary rights by implementers or users of this specification can be obtained from the IETF 
on-line IPR repository at http://www.ietf.org/ipr.

The IETF invites any interested party to bring to its attention any copyrights, patents or patent applications, or other proprietary rights that may cover 
technology that may be required to implement this standard. Please address the information to the IETF at ietf- ipr@ietf.org.

AES

Copyright (C) Mok-Kong Shen 2003. mok-kong.shen@t-online.de

Free license:

This work and all modified versions of it may be freely copied, modified, redistributed and used for all legal civilian purposes without formality albeit 
at licensee's own risk and responsibility, subject to the following conditions:

(1) A copy of this copyright notice with the release history list and the site modification history list must be included in any copy of this work or any 
modified version of it.

(2) If this work or any modified version of it forms part of a software in object code or binary code, a document for users should accompany the 
software stating this fact and include this copyright notice as well as an URL of the licensee where the source code of the package in the version 
actually being used in the software can be found.

(3) Any modification (except dropping of the Supplement) should be appropriately documented in the site modification history list below. The last 
date of site modification (at the beginning of the package) is to be updated.

(4) In case of non-trivial modifications, i.e. those stemming from efficiency or correctness considerations or from issues of interoperability with other 
AES implementations, a copy of the modified package is to be immediately sent to the copyright owner at the address above.

(5) Eventual negative or unfavourable consequences and losses or damages of any form to any persons in connection with the use of this work or its 
modified versions do not constitute any liabilities on the part of the copyright owner.

This free license is unlimited in time [1]. Any attempt of non-compliance with the above terms or any occurence of // their practical unsatisfiability 
due to whatever reasons, however, automatically terminates the license. Such termination does not affect other licensees who have previously 
obtained materials from the person with the terminated license but  who continue to comply with the above terms.

Other licenses:

Any usages of the contents of the package that don't qualify for a free license as stated in the above require explicit // specific licenses from the 
copyright owner.

[1] Since copyright grants could be revoked after 35 years (see http://www.copyright.gov/title17/92chap2.html#203), it // could be argued that this 
license is not timeless for sure On the other hand, the lifespan of AES itself isn't likely to exceed that period. So the issue is not practically relevant 
in our context.

DES - (http://www.itl.nist.gov/fipspubs/fip46-2.htm)

Cryptographic devices implementing this standard may be covered by U.S. and foreign patents issued to the International Business Machines 
Corporation. However, IBM has granted nonexclusive, royalty-free licenses under the patents to make, use and sell apparatus which complies with 
the standard. The terms, conditions and scope of the licenses are set out in notices published in the May 13, 1975 and August 31, 1976 issues of the 
Official Gazette of the United States Patent and Trademark Office (934 O.G. 452 and 949 O.G. 1717).

MD5

Copyright (C) 1991-2, RSA Data Security, Inc. Created 1991. All rights reserved.

License to copy and use this software is granted provided that it is identified as the "RSA Data Security, Inc. MD5 Message-Digest Algorithm" in all 
material mentioning or referencing this software or this function.

License is also granted to make and use derivative works provided that such works are identified as "derived from the RSA Data Security, Inc. MD5 
Message-Digest Algorithm" in all material mentioning or referencing the derived work.

RSA Data Security, Inc. makes no representations concerning either the merchantability of this software or the suitability of this software for any 
particular purpose. It is provided "as is" without express or implied warranty of any kind.

These notices must be retained in any copies of any part of this documentation and/or software.
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SHA1

Copyright (C) The Internet Society (2001). All Rights Reserved.

This document and translations of it may be copied and furnished to others, and derivative works that comment on or otherwise explain it or assist 
in its implementation may be prepared, copied, published and distributed, in whole or in part, without restriction of any kind, provided that the above 
copyright notice and this paragraph are included on all such copies and derivative works. However, this document itself may not be modified in any 
way, such as by removing the copyright notice or references to the Internet Society or other Internet organizations, except as needed for the purpose 
of developing Internet standards in which case the procedures for copyrights defined in the Internet Standards process must be followed, or as required 
to translate it into languages other than English.

The limited permissions granted above are perpetual and will not be revoked by the Internet Society or its successors or assigns. This document and 
the information contained herein is provided on an "AS IS" basis and THE INTERNET SOCIETY AND THE INTERNET ENGINEERING TASK 
FORCE DISCLAIMS ALL WARRANTIES, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO ANY WARRANTY THAT THE USE 
OF THE INFORMATION HEREIN WILL NOT INFRINGE ANY RIGHTS OR ANY IMPLIED WARRANTIES OF MERCHANTABILITY OR 
FITNESS FOR A PARTICULAR PURPOSE.

OpenSSL

This product includes software developed by the OpenSSL Project for use in the OpenSSL Toolkit. (http://www.openssl.org/ 
<http://www.openssl.org/> )

This product includes cryptographic software written by Eric Young (eay@cryptsoft.com).

This product includes software written by Tim Hudson (tjh@cryptsoft.com <mailto:tjh@cryptsoft.com> ).

LICENSE ISSUES\

  ==============\

\

  The OpenSSL toolkit stays under a dual license, i.e. both the conditions of\

  the OpenSSL License and the original SSLeay license apply to the toolkit.\

  See below for the actual license texts. Actually both licenses are BSD-style\

  Open Source licenses. In case of any license issues related to OpenSSL\

  please contact openssl-core@openssl.org.\

* Certain portions of the code are copyright (c)1998-2005 The OpenSSL Project and 

other portions are copyright (c)1998-2007 The OpenSSL Project.  All rights reserved.\

 *\

 * Redistribution and use in source and binary forms, with or without\

 * modification, are permitted provided that the following conditions\

 * are met:\

 *\

 * 1. Redistributions of source code must retain the above copyright\

 *    notice, this list of conditions and the following disclaimer.\

 *\

 * 2. Redistributions in binary form must reproduce the above copyright\

 *    notice, this list of conditions and the following disclaimer in\

 *    the documentation and/or other materials provided with the\

 *    distribution.\

 *\

 * 3. All advertising materials mentioning features or use of this\

 *    software must display the following acknowledgment:\

 *    "This product includes software developed by the OpenSSL Project\
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 *    for use in the OpenSSL Toolkit. (http://www.openssl.org/)"\

 *\

 * 4. The names "OpenSSL Toolkit" and "OpenSSL Project" must not be used to\

 *    endorse or promote products derived from this software without\

 *    prior written permission. For written permission, please contact\

 *    openssl-core@openssl.org.\

 *\

 * 5. Products derived from this software may not be called "OpenSSL"\

 *    nor may "OpenSSL" appear in their names without prior written\

 *    permission of the OpenSSL Project.\

 *\

 * 6. Redistributions of any form whatsoever must retain the following\

 *    acknowledgment:\

 *    "This product includes software developed by the OpenSSL Project\

 *    for use in the OpenSSL Toolkit (http://www.openssl.org/)"\

 *\

 * THIS SOFTWARE IS PROVIDED BY THE OpenSSL PROJECT ``AS IS'' AND ANY\

 * EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE\

 * IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR\

 * PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE OpenSSL PROJECT OR\

 * ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,\

 * SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT\

 * NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;\

 * LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)\

 * HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,\

 * STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)\

 * ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED\

 * OF THE POSSIBILITY OF SUCH DAMAGE.\

 * ====================================================================\

 *\

 * This product includes cryptographic software written by Eric Young\

 * (eay@cryptsoft.com).  This product includes software written by Tim\

 * Hudson (tjh@cryptsoft.com).\

 *\

 */\

\

 Original SSLeay License\

 -----------------------\

\

/* Copyright (C) 1995-1998 Eric Young (eay@cryptsoft.com)\

 * All rights reserved.\

 *\

 * This package is an SSL implementation written\
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 * by Eric Young (eay@cryptsoft.com).\

 * The implementation was written so as to conform with Netscapes SSL.\

 *\

 * This library is free for commercial and non-commercial use as long as\

 * the following conditions are aheared to.  The following conditions\

 * apply to all code found in this distribution, be it the RC4, RSA,\

 * lhash, DES, etc., code; not just the SSL code.  The SSL documentation\

 * included with this distribution is covered by the same copyright terms\

 * except that the holder is Tim Hudson (tjh@cryptsoft.com).\

 *\

 * Copyright remains Eric Young's, and as such any Copyright notices in\

 * the code are not to be removed.\

 * If this package is used in a product, Eric Young should be given attribution\

 * as the author of the parts of the library used.\

 * This can be in the form of a textual message at program startup or\

 * in documentation (online or textual) provided with the package.\

 *\

 * Redistribution and use in source and binary forms, with or without\

 * modification, are permitted provided that the following conditions\

 * are met:\

 * 1. Redistributions of source code must retain the copyright\

 *    notice, this list of conditions and the following disclaimer.\

 * 2. Redistributions in binary form must reproduce the above copyright\

 *    notice, this list of conditions and the following disclaimer in the\

 *    documentation and/or other materials provided with the distribution.\

 * 3. All advertising materials mentioning features or use of this software\

 *    must display the following acknowledgement:\

 *    "This product includes cryptographic software written by\

 *     Eric Young (eay@cryptsoft.com)"\

 *    The word 'cryptographic' can be left out if the rouines from the library\

 *    being used are not cryptographic related :-).\

 * 4. If you include any Windows specific code (or a derivative thereof) from\

 *    the apps directory (application code) you must include an acknowledgement:\

 *    "This product includes software written by Tim Hudson (tjh@cryptsoft.com)"\

 *\

 * THIS SOFTWARE IS PROVIDED BY ERIC YOUNG ``AS IS'' AND\

 * ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE\

 * IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE\

 * ARE DISCLAIMED.  IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE\

 * FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL\

 * DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS\

 * OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)\

 * HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT\
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 * LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY\

 * OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF\

 * SUCH DAMAGE.\

 *\

 * The licence and distribution terms for any publically available version or\

 * derivative of this code cannot be changed.  i.e. this code cannot simply be\

 * copied and put under another distribution licence\

 * [including the GNU Public Licence.]\

 */}

Libxml2

Except where otherwise noted in the source code (e.g. the files hash.c, list.c and the trio files, which are covered by a similar licence but with different 
Copyright notices) all the files are:

Copyright (C) 1998-2003 Daniel Veillard.  All Rights Reserved.

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to 
deal in the Software without restriction, including without limitation the rights

to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is 
furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED 
TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.  IN NO EVENT 
SHALL THE DANIEL VEILLARD BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF 
CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER 
DEALINGS IN THE SOFTWARE.

Except as contained in this notice, the name of Daniel Veillard shall not be used in advertising or otherwise to promote the sale, use or other dealings 
in this Software without prior written authorization from him.

NTP

This document and the NTPTime program and source code are all Copyright (c) Tom Horsley, 1997-2004. All rights reserved. The right to unlimited 
distribution and use of this program is granted to anyone who agrees to keep the copyright notice intact and not alter the program.

Translation: You want changes in the program, make 'em yourself, but don't go distributing the new version with my name on it (or with your name 
on it either, since you didn't write most of it :-). If there are changes you would like to see distributed, by all means send 'em in to me, and if I like 
'em I'll incorporate them in the next version.

expat 

The MIT License

Copyright (c) 1998, 1999, 2000 Thai Open Source Software Center Ltd

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to 
deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or 
sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED 
TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT 
SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN 
ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE 
OR OTHER DEALINGS IN THE SOFTWARE.

Libcurl 
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COPYRIGHT AND PERMISSION NOTICE 

Copyright (c) 1996 - 2007, Daniel Stenberg, <daniel@haxx.se>.

 

All rights reserved.

 

Permission to use, copy, modify, and distribute this software for any purpose

with or without fee is hereby granted, provided that the above copyright

notice and this permission notice appear in all copies.

 

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR

IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,

FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT OF THIRD PARTY RIGHTS. IN

NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM,

DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR

OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE

OR OTHER DEALINGS IN THE SOFTWARE.

Except as contained in this notice, the name of a copyright holder shall not

be used in advertising or otherwise to promote the sale, use or other dealings

in this Software without prior written authorization of the copyright holder.

OpenTNEF LICENSE 

License Terms:

Use, Modification and Redistribution (including distribution of any modified or derived work) in source and binary forms is permitted only if each 
of the following conditions is met:

1. Redistributions qualify as "freeware" or "Open Source Software" under one of the following terms:

   (a) Redistributions are made at no charge beyond the reasonable cost of materials and delivery.

   (b) Redistributions are accompanied by a copy of the Source Code or by an irrevocable offer to provide a copy of the Source Code for up to three 
years at the cost of materials and delivery.  Such redistributions must allow further use, modification, and redistribution of the Source Code under 
substantially the same terms as this license.  For the purposes of redistribution "Source Code" means the complete compilable and linkable source 
code of OpenTNEF including all modifications.

2. Redistributions of source code must retain the copyright notices as they appear in each source code file, these license terms, and the 
disclaimer/limitation of liability set forth as paragraph 6 below.

3. Redistributions in binary form must reproduce the Copyright Notice, these license terms, and the disclaimer/limitation of liability set forth as 
paragraph 6 below, in the documentation and/or other materials provided with the distribution.  For the purposes of binary distribution the "Copyright 
Notice" refers to the following language:

   "Copyright (c) 2003 P.L.Daniels, All rights reserved." 

4. Neither the name of OpenTNEF, nor Paul L Daniels, nor the the names of their contributors may be used to endorse or promote products derived 
from this software without specific prior written permission.  
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5. All redistributions must comply with the conditions imposed by the University of California on certain embedded code, whose copyright notice 
and conditions for redistribution are as follows:

   (a) Copyright (c) 2003 P.L.Daniels, All rights reserved.

   (b) Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

      (i)   Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

      (ii)  Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the 
documentation and/or other materials provided with the distribution.

      (iii) Neither the name of OpenTNEF, nor P.L.Daniels, nor the names of its contributors may be used to endorse or promote products derived from 
this software without specific prior written permission.

6. Disclaimer/Limitation of Liability: THIS SOFTWARE IS PROVIDED BY P.L.Daniels. AND CONTRIBUTORS "AS IS" AND ANY EXPRESS 
OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS 
FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL SENDMAIL, INC., THE REGENTS OF THE UNIVERSITY OF 
CALIFORNIA OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR 
CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS 
OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER 
IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE 
OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. 

Boost Software License - Version 1.0 

August 17th, 2003 

Permission is hereby granted, free of charge, to any person or organization obtaining a copy of the software and accompanying documentation covered 
by this license (the "Software") to use, reproduce, display, distribute, execute, and transmit the Software, and to prepare derivative works of the 
Software, and to permit third-parties to whom the Software is furnished to do so, all subject to the following: 

The copyright notices in the Software and this entire statement, including the above license grant, this restriction and the following disclaimer, must 
be included in all copies of the Software, in whole or in part, and all derivative works of the Software, unless such copies or derivative works are 
solely in the form of machine-executable object code generated by a source language processor. 

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED 
TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE AND NON-INFRINGEMENT. IN NO 
EVENT SHALL THE COPYRIGHT HOLDERS OR ANYONE DISTRIBUTING THE SOFTWARE BE LIABLE FOR ANY DAMAGES OR 
OTHER LIABILITY, WHETHER IN CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE 
SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

License for V19 

(See source code for similar V18 license at http://www.portaudio.com/docs/portaudio_h.txt.) 

PortAudio Portable Real-Time Audio Library 

Copyright (c) 1999-2000 Ross Bencina and Phil Burk 

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to 
deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or 
sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions: 

PCRE LICENCE

PCRE is a library of functions to support regular expressions whose syntax and semantics are as close as possible to those of the Perl 5 language.

Release 7 of PCRE is distributed under the terms of the "BSD" licence, as specified below. The documentation for PCRE, supplied in the "doc" 
directory, is distributed under the same terms as the software itself.

The basic library functions are written in C and are freestanding. Also included in the distribution is a set of C++ wrapper functions.
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THE BASIC LIBRARY FUNCTIONS

---------------------------

Copyright (c) 1997-2006 University of Cambridge

All rights reserved.

THE C++ WRAPPER FUNCTIONS

-------------------------

Contributed by:   Google Inc.

Copyright (c) 2006, Google Inc.

All rights reserved.

THE "BSD" LICENCE 

-----------------

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met: 

    * Redistributions of source code must retain the above copyright notice,

      this list of conditions and the following disclaimer.

    * Redistributions in binary form must reproduce the above copyright

      notice, this list of conditions and the following disclaimer in the 

      documentation and/or other materials provided with the distribution.

    * Neither the name of the University of Cambridge nor the name of Google

      Inc. nor the names of their contributors may be used to endorse or

      promote products derived from this software without specific prior

      written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED 
WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A 
PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR 
ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED 
TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) 
HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING 
NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE 
POSSIBILITY OF SUCH DAMAGE. 

End

PSMTabBarControl

Portions of this software Copyright 2004 The Shiira Project. All rights reserved.

Check them out at: http://hmdt-web.net/shiira/

Credit to the sweet coding goodness of Positive Spin Media at www.positivespinmedia.com. 

Copyright (c) 2005, Positive Spin Media

All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:
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    •    Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

    •    Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the 
documentation and/or other materials provided with the distribution.

    •    Neither the name of Positive Spin Media nor the names of its contributors may be used to endorse or promote products derived from this software 
without specific prior written permission.

        

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED 
WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A 
PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR 
ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED 
TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) 
HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING 
NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE 
POSSIBILITY OF SUCH DAMAGE.

imap-2004c1 

University of Washington IMAP toolkit

Version 2004 of IMAP toolkit

Copyright © 1988-2005 University of Washington

This University of Washington Distribution (IMAP Toolkit code and documentation) is made available to the open source community as a public 
service by the University of Washington. Contact the University of Washington at imap-license@cac.washington.edu for information on placing or 
integrating modifications to the Distribution into proprietary systems. Unmodified distribution is governed by the terms identified below. 

Under this license, this Distribution may be used as-is or may be modified and the original version and modified versions may be copied, distributed, 
publicly displayed and performed provided that the following conditions are met:

Modified versions are distributed with source code and documentation and with permission for others to use any code and documentation (whether 
in original or modified versions) as granted under this license; 

if modified, the source code, documentation, and user run-time elements should be clearly labeled by placing an identifier of origin (such as a name, 
initial, or other tag) after the version number; 

users, modifiers, distributors, and others coming into possession or using the Distribution in original or modified form accept the entire risk as to the 
possession, use, and performance of the Distribution; 

this copyright management information (software identifier and version number, copyright notice and license) shall be retained in all versions of the 
Distribution; 

the University of Washington may make modifications to the Distribution that are substantially similar to modified versions of the Distribution, and 
may make, use, sell, copy, distribute, publicly display, and perform such modifications, including making such modifications available under this or 
other licenses, without obligation or restriction; 

modifications incorporating code, libraries, and/or documentation subject to any other open source license may be made, and the resulting work may 
be distributed under the terms of such open source license if required by that open source license, but doing so will not affect this Distribution, other 
modifications made under this license or modifications made under other University of Washington licensing arrangements; 

no permission is granted to distribute, publicly display, or publicly perform modifications to the Distribution made using proprietary materials that 
cannot be released in source format under conditions of this license; 

the name of the University of Washington may not be used in advertising or publicity pertaining to Distribution of the software without specific, prior 
written permission; 

pursuant to U.S. laws, Distribution may not be downloaded, acquired or otherwise exported or re-exported (i) into, or to a national or resident of any 
country to which the U.S. has embargoed goods; or to anyone on the U.S. Treasury Department's list of Specially Designated Nations or the U.S. 
Commerce Department's Table of Denial Orders. By downloading the Distribution, you represent that: 1) you are not located in or under the control 
of a national or resident of any such country or on any such list; and 2) you will not export or re-export the Distribution to any prohibited country, or 
to any prohibited person, entity, or end-user as specified by U.S. export controls. 

This software is made available "as is", and 

THE UNIVERSITY OF WASHINGTON DISCLAIMS ALL WARRANTIES, EXPRESS OR IMPLIED, WITH REGARD TO THIS SOFTWARE, 
INCLUDING WITHOUT LIMITATION ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR 
PURPOSE, AND IN NO EVENT SHALL THE UNIVERSITY OF WASHINGTON BE LIABLE FOR ANY SPECIAL, INDIRECT OR 
CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN 
AN ACTION OF CONTRACT, TORT (INCLUDING NEGLIGENCE) OR STRICT LIABILITY, ARISING OUT OF OR IN CONNECTION WITH 
THE USE OR PERFORMANCE OF THIS SOFTWARE.
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Netscape Portable Runtime 

To obtain more information about the Mozilla source code used in this product, go to: http://www.mozilla.org/projects/nspr. 

Mozilla Public License Version 1.1

1. Definitions.

1.0.1. "Commercial Use" 

means distribution or otherwise making the Covered Code available to a third party. 

1.1. "Contributor" 

means each entity that creates or contributes to the creation of Modifications. 

1.2. "Contributor Version" 

means the combination of the Original Code, prior Modifications used by a Contributor, and the Modifications made by that particular Contributor. 

1.3. "Covered Code" 

means the Original Code or Modifications or the combination of the Original Code and Modifications, in each case including portions thereof. 

1.4. "Electronic Distribution Mechanism" 

means a mechanism generally accepted in the software development community for the electronic transfer of data. 

1.5. "Executable" 

means Covered Code in any form other than Source Code. 

1.6. "Initial Developer" 

means the individual or entity identified as the Initial Developer in the Source Code notice required by Exhibit A. 

1.7. "Larger Work" 

means a work which combines Covered Code or portions thereof with code not governed by the terms of this License. 

1.8. "License" 

means this document. 

1.8.1. "Licensable" 

means having the right to grant, to the maximum extent possible, whether at the time of the initial grant or subsequently acquired, any and all of the 
rights conveyed herein. 

1.9. "Modifications" 

means any addition to or deletion from the substance or structure of either the Original Code or any previous Modifications. When Covered Code is 
released as a series of files, a Modification is: 

a. Any addition to or deletion from the contents of a file containing Original Code or previous Modifications. 

b. Any new file that contains any part of the Original Code or previous Modifications. 

1.10. "Original Code" 

means Source Code of computer software code which is described in the Source Code notice required by Exhibit A as Original Code, and which, at 
the time of its release under this License is not already Covered Code governed by this License. 

1.10.1. "Patent Claims" 

means any patent claim(s), now owned or hereafter acquired, including without limitation, method, process, and apparatus claims, in any patent 
Licensable by grantor. 

1.11. "Source Code" 

means the preferred form of the Covered Code for making modifications to it, including all modules it contains, plus any associated interface 
definition files, scripts used to control compilation and installation of an Executable, or source code differential comparisons against either the 
Original Code or another well known, available Covered Code of the Contributor's choice. The Source Code can be in a compressed or archival form, 
provided the appropriate decompression or de-archiving software is widely available for no charge. 

1.12. "You" (or "Your") 

means an individual or a legal entity exercising rights under, and complying with all of the terms of, this License or a future version of this License 
issued under Section 6.1. For legal entities, "You" includes any entity which controls, is controlled by, or is under common control with You. For 
purposes of this definition, "control" means (a) the power, direct or indirect, to cause the direction or management of such entity, whether by contract 
or otherwise, or (b) ownership of more than fifty percent (50%) of the outstanding shares or beneficial ownership of such entity. 
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2. Source Code License.

2.1. The Initial Developer Grant.

The Initial Developer hereby grants You a world-wide, royalty-free, non-exclusive license, subject to third party intellectual property claims: 

a. under intellectual property rights (other than patent or trademark) Licensable by Initial Developer to use, reproduce, modify, display, perform, 
sublicense and distribute the Original Code (or portions thereof) with or without Modifications, and/or as part of a Larger Work; and 

b. under Patents Claims infringed by the making, using or selling of Original Code, to make, have made, use, practice, sell, and offer for sale, and/or 
otherwise dispose of the Original Code (or portions thereof). 

c. the licenses granted in this Section 2.1 (a) and (b) are effective on the date Initial Developer first distributes Original Code under the terms of this 
License. 

d. Notwithstanding Section 2.1 (b) above, no patent license is granted: 1) for code that You delete from the Original Code; 2) separate from the 
Original Code; or 3) for infringements caused by: i) the modification of the Original Code or ii) the combination of the Original Code with other 
software or devices. 

2.2. Contributor Grant.

Subject to third party intellectual property claims, each Contributor hereby grants You a world-wide, royalty-free, non-exclusive license 

a. under intellectual property rights (other than patent or trademark) Licensable by Contributor, to use, reproduce, modify, display, perform, 
sublicense and distribute the Modifications created by such Contributor (or portions thereof) either on an unmodified basis, with other Modifications, 
as Covered Code and/or as part of a Larger Work; and 

b. under Patent Claims infringed by the making, using, or selling of Modifications made by that Contributor either alone and/or in combination with 
its Contributor Version (or portions of such combination), to make, use, sell, offer for sale, have made, and/or otherwise dispose of: 1) Modifications 
made by that Contributor (or portions thereof); and 2) the combination of Modifications made by that Contributor with its Contributor Version (or 
portions of such combination). 

c. the licenses granted in Sections 2.2 (a) and 2.2 (b) are effective on the date Contributor first makes Commercial Use of the Covered Code. 

d. Notwithstanding Section 2.2 (b) above, no patent license is granted: 1) for any code that Contributor has deleted from the Contributor Version; 2) 
separate from the Contributor Version; 3) for infringements caused by: i) third party modifications of Contributor Version or ii) the combination of 
Modifications made by that Contributor with other software (except as part of the Contributor Version) or other devices; or 4) under Patent Claims 
infringed by Covered Code in the absence of Modifications made by that Contributor. 

3. Distribution Obligations.

3.1. Application of License.

The Modifications which You create or to which You contribute are governed by the terms of this License, including without limitation Section 2.2. 
The Source Code version of Covered Code may be distributed only under the terms of this License or a future version of this License released under 
Section 6.1, and You must include a copy of this License with every copy of the Source Code You distribute. You may not offer or impose any terms 
on any Source Code version that alters or restricts the applicable version of this License or the recipients' rights hereunder. However, You may include 
an additional document offering the additional rights described in Section 3.5. 

3.2. Availability of Source Code.

Any Modification which You create or to which You contribute must be made available in Source Code form under the terms of this License either 
on the same media as an Executable version or via an accepted Electronic Distribution Mechanism to anyone to whom you made an Executable 
version available; and if made available via Electronic Distribution Mechanism, must remain available for at least twelve (12) months after the date 
it initially became available, or at least six (6) months after a subsequent version of that particular Modification has been made available to such 
recipients. You are responsible for ensuring that the Source Code version remains available even if the Electronic Distribution Mechanism is 
maintained by a third party. 

3.3. Description of Modifications.

You must cause all Covered Code to which You contribute to contain a file documenting the changes You made to create that Covered Code and the 
date of any change. You must include a prominent statement that the Modification is derived, directly or indirectly, from Original Code provided by 
the Initial Developer and including the name of the Initial Developer in (a) the Source Code, and (b) in any notice in an Executable version or related 
documentation in which You describe the origin or ownership of the Covered Code. 

3.4. Intellectual Property Matters

(a) Third Party Claims

If Contributor has knowledge that a license under a third party's intellectual property rights is required to exercise the rights granted by such 
Contributor under Sections 2.1 or 2.2, Contributor must include a text file with the Source Code distribution titled "LEGAL" which describes the 
claim and the party making the claim in sufficient detail that a recipient will know whom to contact. If Contributor obtains such knowledge after the 
Modification is made available as described in Section 3.2, Contributor shall promptly modify the LEGAL file in all copies Contributor makes 
available thereafter and shall take other steps (such as notifying appropriate mailing lists or newsgroups) reasonably calculated to inform those who 
received the Covered Code that new knowledge has been obtained. 

(b) Contributor APIs
A-13
Troubleshooting Guide for Cisco Unified Personal Communicator, Release 1.2

OL-11717-01



 

Appendix A      Third-Party Copyright and License Information
If Contributor's Modifications include an application programming interface and Contributor has knowledge of patent licenses which are reasonably 
necessary to implement that API, Contributor must also include this information in the LEGAL file. 

(c) Representations.

Contributor represents that, except as disclosed pursuant to Section 3.4 (a) above, Contributor believes that Contributor's Modifications are 
Contributor's original creation(s) and/or Contributor has sufficient rights to grant the rights conveyed by this License. 

3.5. Required Notices.

You must duplicate the notice in Exhibit A in each file of the Source Code. If it is not possible to put such notice in a particular Source Code file due 
to its structure, then You must include such notice in a location (such as a relevant directory) where a user would be likely to look for such a notice. 
If You created one or more Modification(s) You may add your name as a Contributor to the notice described in Exhibit A. You must also duplicate 
this License in any documentation for the Source Code where You describe recipients' rights or ownership rights relating to Covered Code. You may 
choose to offer, and to charge a fee for, warranty, support, indemnity or liability obligations to one or more recipients of Covered Code. However, 
You may do so only on Your own behalf, and not on behalf of the Initial Developer or any Contributor. You must make it absolutely clear than any 
such warranty, support, indemnity or liability obligation is offered by You alone, and You hereby agree to indemnify the Initial Developer and every 
Contributor for any liability incurred by the Initial Developer or such Contributor as a result of warranty, support, indemnity or liability terms You 
offer. 

3.6. Distribution of Executable Versions.

You may distribute Covered Code in Executable form only if the requirements of Sections 3.1, 3.2, 3.3, 3.4 and 3.5 have been met for that Covered 
Code, and if You include a notice stating that the Source Code version of the Covered Code is available under the terms of this License, including a 
description of how and where You have fulfilled the obligations of Section 3.2. The notice must be conspicuously included in any notice in an 
Executable version, related documentation or collateral in which You describe recipients' rights relating to the Covered Code. You may distribute the 
Executable version of Covered Code or ownership rights under a license of Your choice, which may contain terms different from this License, 
provided that You are in compliance with the terms of this License and that the license for the Executable version does not attempt to limit or alter 
the recipient's rights in the Source Code version from the rights set forth in this License. If You distribute the Executable version under a different 
license You must make it absolutely clear that any terms which differ from this License are offered by You alone, not by the Initial Developer or any 
Contributor. You hereby agree to indemnify the Initial Developer and every Contributor for any liability incurred by the Initial Developer or such 
Contributor as a result of any such terms You offer. 

3.7. Larger Works.

You may create a Larger Work by combining Covered Code with other code not governed by the terms of this License and distribute the Larger Work 
as a single product. In such a case, You must make sure the requirements of this License are fulfilled for the Covered Code. 

4. Inability to Comply Due to Statute or Regulation.

If it is impossible for You to comply with any of the terms of this License with respect to some or all of the Covered Code due to statute, judicial 
order, or regulation then You must: (a) comply with the terms of this License to the maximum extent possible; and (b) describe the limitations and 
the code they affect. Such description must be included in the LEGAL file described in Section 3.4 and must be included with all distributions of the 
Source Code. Except to the extent prohibited by statute or regulation, such description must be sufficiently detailed for a recipient of ordinary skill 
to be able to understand it. 

5. Application of this License.

This License applies to code to which the Initial Developer has attached the notice in Exhibit A and to related Covered Code. 

6. Versions of the License.

6.1. New Versions

Netscape Communications Corporation ("Netscape") may publish revised and/or new versions of the License from time to time. Each version will 
be given a distinguishing version number. 

6.2. Effect of New Versions

Once Covered Code has been published under a particular version of the License, You may always continue to use it under the terms of that version. 
You may also choose to use such Covered Code under the terms of any subsequent version of the License published by Netscape. No one other than 
Netscape has the right to modify the terms applicable to Covered Code created under this License. 

6.3. Derivative Works

If You create or use a modified version of this License (which you may only do in order to apply it to code which is not already Covered Code 
governed by this License), You must (a) rename Your license so that the phrases "Mozilla", "MOZILLAPL", "MOZPL", "Netscape", "MPL", "NPL" 
or any confusingly similar phrase do not appear in your license (except to note that your license differs from this License) and (b) otherwise make it 
clear that Your version of the license contains terms which differ from the Mozilla Public License and Netscape Public License. (Filling in the name 
of the Initial Developer, Original Code or Contributor in the notice described in Exhibit A shall not of themselves be deemed to be modifications of 
this License.) 

7. DISCLAIMER OF WARRANTY

COVERED CODE IS PROVIDED UNDER THIS LICENSE ON AN "AS IS" BASIS, WITHOUT WARRANTY OF ANY KIND, EITHER 
EXPRESSED OR IMPLIED, INCLUDING, WITHOUT LIMITATION, WARRANTIES THAT THE COVERED CODE IS FREE OF DEFECTS, 
MERCHANTABLE, FIT FOR A PARTICULAR PURPOSE OR NON-INFRINGING. THE ENTIRE RISK AS TO THE QUALITY AND 
PERFORMANCE OF THE COVERED CODE IS WITH YOU. SHOULD ANY COVERED CODE PROVE DEFECTIVE IN ANY RESPECT, YOU 
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(NOT THE INITIAL DEVELOPER OR ANY OTHER CONTRIBUTOR) ASSUME THE COST OF ANY NECESSARY SERVICING, REPAIR OR 
CORRECTION. THIS DISCLAIMER OF WARRANTY CONSTITUTES AN ESSENTIAL PART OF THIS LICENSE. NO USE OF ANY 
COVERED CODE IS AUTHORIZED HEREUNDER EXCEPT UNDER THIS DISCLAIMER. 

8. Termination

8.1. This License and the rights granted hereunder will terminate automatically if You fail to comply with terms herein and fail to cure such breach 
within 30 days of becoming aware of the breach. All sublicenses to the Covered Code which are properly granted shall survive any termination of 
this License. Provisions which, by their nature, must remain in effect beyond the termination of this License shall survive. 

8.2. If You initiate litigation by asserting a patent infringement claim (excluding declatory judgment actions) against Initial Developer or a 
Contributor (the Initial Developer or Contributor against whom You file such action is referred to as "Participant") alleging that: 

a. such Participant's Contributor Version directly or indirectly infringes any patent, then any and all rights granted by such Participant to You under 
Sections 2.1 and/or 2.2 of this License shall, upon 60 days notice from Participant terminate prospectively, unless if within 60 days after receipt of 
notice You either: (i) agree in writing to pay Participant a mutually agreeable reasonable royalty for Your past and future use of Modifications made 
by such Participant, or (ii) withdraw Your litigation claim with respect to the Contributor Version against such Participant. If within 60 days of notice, 
a reasonable royalty and payment arrangement are not mutually agreed upon in writing by the parties or the litigation claim is not withdrawn, the 
rights granted by Participant to You under Sections 2.1 and/or 2.2 automatically terminate at the expiration of the 60 day notice period specified 
above. 

b. any software, hardware, or device, other than such Participant's Contributor Version, directly or indirectly infringes any patent, then any rights 
granted to You by such Participant under Sections 2.1(b) and 2.2(b) are revoked effective as of the date You first made, used, sold, distributed, or had 
made, Modifications made by that Participant. 

8.3. If You assert a patent infringement claim against Participant alleging that such Participant's Contributor Version directly or indirectly infringes 
any patent where such claim is resolved (such as by license or settlement) prior to the initiation of patent infringement litigation, then the reasonable 
value of the licenses granted by such Participant under Sections 2.1 or 2.2 shall be taken into account in determining the amount or value of any 
payment or license. 

8.4. In the event of termination under Sections 8.1 or 8.2 above, all end user license agreements (excluding distributors and resellers) which have 
been validly granted by You or any distributor hereunder prior to termination shall survive termination. 

9. LIMITATION OF LIABILITY

UNDER NO CIRCUMSTANCES AND UNDER NO LEGAL THEORY, WHETHER TORT (INCLUDING NEGLIGENCE), CONTRACT, OR 
OTHERWISE, SHALL YOU, THE INITIAL DEVELOPER, ANY OTHER CONTRIBUTOR, OR ANY DISTRIBUTOR OF COVERED CODE, OR 
ANY SUPPLIER OF ANY OF SUCH PARTIES, BE LIABLE TO ANY PERSON FOR ANY INDIRECT, SPECIAL, INCIDENTAL, OR 
CONSEQUENTIAL DAMAGES OF ANY CHARACTER INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF GOODWILL, 
WORK STOPPAGE, COMPUTER FAILURE OR MALFUNCTION, OR ANY AND ALL OTHER COMMERCIAL DAMAGES OR LOSSES, 
EVEN IF SUCH PARTY SHALL HAVE BEEN INFORMED OF THE POSSIBILITY OF SUCH DAMAGES. THIS LIMITATION OF LIABILITY 
SHALL NOT APPLY TO LIABILITY FOR DEATH OR PERSONAL INJURY RESULTING FROM SUCH PARTY'S NEGLIGENCE TO THE 
EXTENT APPLICABLE LAW PROHIBITS SUCH LIMITATION. SOME JURISDICTIONS DO NOT ALLOW THE EXCLUSION OR 
LIMITATION OF INCIDENTAL OR CONSEQUENTIAL DAMAGES, SO THIS EXCLUSION AND LIMITATION MAY NOT APPLY TO YOU. 

10. U.S. government end users

The Covered Code is a "commercial item," as that term is defined in 48 C.F.R. 2.101 (Oct. 1995), consisting of "commercial computer software" and 
"commercial computer software documentation," as such terms are used in 48 C.F.R. 12.212 (Sept. 1995). Consistent with 48 C.F.R. 12.212 and 48 
C.F.R. 227.7202-1 through 227.7202-4 (June 1995), all U.S. Government End Users acquire Covered Code with only those rights set forth herein. 

11. Miscellaneous

This License represents the complete agreement concerning subject matter hereof. If any provision of this License is held to be unenforceable, such 
provision shall be reformed only to the extent necessary to make it enforceable. This License shall be governed by California law provisions (except 
to the extent applicable law, if any, provides otherwise), excluding its conflict-of-law provisions. With respect to disputes in which at least one party 
is a citizen of, or an entity chartered or registered to do business in the United States of America, any litigation relating to this License shall be subject 
to the jurisdiction of the Federal Courts of the Northern District of California, with venue lying in Santa Clara County, California, with the losing 
party responsible for costs, including without limitation, court costs and reasonable attorneys' fees and expenses. The application of the United 
Nations Convention on Contracts for the International Sale of Goods is expressly excluded. Any law or regulation which provides that the language 
of a contract shall be construed against the drafter shall not apply to this License. 

12. Responsibility for claims

As between Initial Developer and the Contributors, each party is responsible for claims and damages arising, directly or indirectly, out of its 
utilization of rights under this License and You agree to work with Initial Developer and Contributors to distribute such responsibility on an equitable 
basis. Nothing herein is intended or shall be deemed to constitute any admission of liability. 

13. Multiple-licensed code

Initial Developer may designate portions of the Covered Code as "Multiple-Licensed". "Multiple-Licensed" means that the Initial Developer permits 
you to utilize portions of the Covered Code under Your choice of the MPL or the alternative licenses, if any, specified by the Initial Developer in the 
file described in Exhibit A. 

Exhibit A - Mozilla Public License.

"The contents of this file are subject to the Mozilla Public License
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Version 1.1 (the "License"); you may not use this file except in

compliance with the License. You may obtain a copy of the License at

http://www.mozilla.org/MPL/

Software distributed under the License is distributed on an "AS IS"

basis, WITHOUT WARRANTY OF ANY KIND, either express or implied. See the

License for the specific language governing rights and limitations

under the License.

The Original Code is ______________________________________.

The Initial Developer of the Original Code is ________________________.

Portions created by ______________________ are Copyright (C) ______

_______________________. All Rights Reserved.

Contributor(s): ______________________________________.

Alternatively, the contents of this file may be used under the terms

of the _____ license (the  "[___] License"), in which case the

provisions of [______] License are applicable instead of those

above. If you wish to allow use of your version of this file only

under the terms of the [____] License and not to allow others to use

your version of this file under the MPL, indicate your decision by

deleting the provisions above and replace them with the notice and

other provisions required by the [___] License. If you do not delete

the provisions above, a recipient may use your version of this file

under either the MPL or the [___] License."

NOTE: The text of this Exhibit A may differ slightly from the text of the notices in the Source Code files of the Original 

Code. You should use the text of this Exhibit A rather than the text found in the Original Code Source Code for Your Modifications. 

tinyxml 

This software contains code from tinyxml. 

convertUTF 

Copyright 2001-2004 Unicode, Inc. 

Disclaimer 

This source code is provided as is by Unicode, Inc. No claims are made as to fitness for any particular purpose. No warranties of any kind are 
expressed or implied. The recipient agrees to determine applicability of information provided. If this file has been purchased on magnetic or optical 
media from Unicode, Inc., the sole remedy for any claim will be exchange of defective media within 90 days of receipt. 

Limitations on Rights to Redistribute This Code 

Unicode, Inc. hereby grants the right to freely use the information supplied in this file in the creation of products supporting the Unicode Standard, 
and to make copies of this file in any form for internal or external distribution as long as this notice remains attached. 
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