Tip

CHAPTER 7

Real-Time Monitoring Configuration

This chapter contains the following information for configuring the Cisco Unified CallManager
Real-Time Monitoring Tool (RTMT).

e Installing the Real-Time Monitoring Tool (RTMT), page 7-1

e Upgrading RTMT, page 7-2

e Uninstalling RTMT, page 7-3

e Using RTMT, page 7-3

e Configuring E-mail Notification, page 7-5

e Working with Configuration Profiles, page 7-5

e Working with Predefined Objects, page 7-7

e Working with Devices, page 7-10

e Working with CTI Applications, Devices, and Lines, page 7-14
¢ Where to Find More Information, page 7-18

For information on alert, performance monitoring, trace collection, and syslog viewer configuration, see
the “Where to Find More Information” section on page 7-18.

Installing the Real-Time Monitoring Tool (RTMT)

~

Note

Tip

You can install RTMT, which works for resolutions 800*600 and above, on a Windows 98, Windows XP,
Windows 2000, or Red Hat Linux with KDE and/or Gnome client.

If you have previously installed RTMT for use with a Cisco Unified CallManager server that is running
Microsoft Windows, you must install RTMT for Cisco Unified CallManager 5.0 in a different folder on
your local computer.

Cisco strongly recommends that you do not install RTMT on a server where you installed
Cisco Unified CallManager. Using RTMT on a server where Cisco Unified CallManager exists may
cause call-processing interruptions.
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M Upgrading RTMT

Step 1
Step 2
Step 3
Step 4
Step 5

Step 6
Step 7
Step 8

Step 9

Step 10

To install the tool, perform the following procedure:

Procedure

From Cisco Unified CallManager Administration, choose Application > Plugins.

Click the Find button.

Click the Download link for the Cisco Unified CallManager Real-Time Monitoring Tool.
Download the executable to your preferred location.

Double-click the RTMT icon that displays on the desktop or locate the directory where you downloaded
the file and run the RTMT installation file.

The extraction process begins.
In the RTMT welcome window, click Next.
To accept the license agreement, click Yes.

Choose the location where you want to install RTMT. If you do not want to use the default location, click
Browse and navigate to a different location. Click Next.

To begin the installation, click Next.
The Setup Status window displays. Do not click Cancel.

To complete the installation, click Finish.

Additional Information
See the Related Topics, page 7-19.

Upgrading RTMT

Tip

Step 1
Step 2
Step 3

When you use the tool (RTMT), it saves user preferences and downloaded module jar files locally on the
client machine. The system saves profiles in the Cisco Unified CallManager database, so you can access
these items in RTMT after you upgrade the tool.

To ensure compatibility, Cisco recommends that you upgrade RTMT after you complete the
Cisco Unified CallManager upgrade on all servers in the cluster.

To upgrade RTMT, perform the following procedure:

Procedure

From Cisco Unified CallManager Administration, choose Application > Plugins.
Click the Find button.

If you are planning to install the RTMT tool on a computer that is running the Microsoft Windows
operating system, click the Download link for the Cisco Unified CallManager Real-Time Monitoring
Tool-Windows. If you are planning to install the RTMT tool on a computer that is running the Linux
operating system, click the Download link for the Cisco Unified CallManager Real-Time Monitoring
Tool-Linux.
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Step 4
Step 5

Step 6
Step 7

Step 8

Uninstalling RTMT W

Download the executable to your preferred location.

Double-click the RTMT icon that displays on the desktop or locate the directory where you downloaded
the file and run the RTMT installation file.

The extraction process begins.

In the RTMT welcome window, click Next.

Because you cannot change the installation location for upgrades, click Next.
The Setup Status window displays; do not click Cancel.

In the Maintenance Complete window, click Finish.

Additional Information
See the Related Topics, page 7-19.

Uninstalling RTMT

On a Windows client, you uninstall RTMT through Add/Remove Programs under the Control Panel.
(Start > Settings > Control Panel >Add/Remove Programs)

To uninstall RTMT on a Red Hat Linux with KDE and/or Gnome client, choose Start >
Accessories > Uninstall Real-time Monitoring tool from the task bar.

Additional Information
See the Related Topics, page 7-19.

Using RTMT

Step 1

Step 2
Step 3

Before You Begin

Before you can use RTMT, you must activate the Cisco AMC Service on each node in the cluster. From
Cisco Unified CallManager Serviceability, choose Tools > Service Activation and check the Cisco
AMC Service check box. Click Update.

Procedure

After you install the plug-in, perform one of the following tasks:

¢ From your Windows desktop, double-click the Cisco Unified CallManager Real-Time
Monitoring Tool icon.

¢ Choose Start > Programs > Cisco CallManager Serviceability > Real-Time Monitoring Tool >
Real-Time Monitoring Tool.

The Real-Time Monitoring Tool Login window displays.
In the Host IP Address field, enter either the IP address or host name of the first node.

In the User Name field, enter the CCM Administrator application user username; for example, the default
username for this user equals CCMAdministrator.
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W Using RTMT
Stepd  In the Password field, enter the CCMAdministrator application user password that you established for
the username; for example, the default password for this user equals ciscocisco.
>
Note  If the authentication fails or if the server is unreachable, the tool prompts you to reenter the
server and authentication details, or you can click the Cancel button to exit the application. After
the authentication succeeds, RTMT launches the monitoring module from local cache or from a
remote node, when the local cache does not contain a monitoring module that matches the
backend Cisco Unified CallManager version.
Step5  Enter the port that the application will use to listen to the server. The default setting equals 8443.
Step6  Check the Secure Connection check box.
Step7 Click OK.
Step8  Add the certificate store by clicking Yes.
Step9  See the following list for tasks that you can perform in RTMT:

To configure the mail server for e-mail alerts, see the “Configuring E-mail Notification” section on
page 7-5.

To create configuration profiles, see the “Adding Configuration Profiles” section on page 7-6.
To monitor predefined objects, see the “Working with Predefined Objects” section on page 7-7.
To work with devices, see the “Working with Devices” section on page 7-10.

To work with CTI applications, devices, and lines, see the “Working with CTI Applications,
Devices, and Lines” section on page 7-14.

To work with Alerts, see the “Alert Configuration in RTMT” section on page 8-1.

To work with performance monitoring objects, see the “Configuring and Using Performance
Monitoring” section on page 9-1.

To collect and view traces, see the “Trace Collection and Log Central in RTMT” section on
page 10-1.
To use SysLog Viewer, see the “Using SysLog Viewer in RTMT” section on page 11-1.

To configure the trace setting for RTMT, choose Edit > Trace Setting. Click the radio button that
applies.

To hide the Quick Launch Channel, which is the pane that displays on the left side of the window,
choose Edit > Hide Quick Launch Channel.

To display the Quick Launch Channel after it is hidden, choose Edit > Hide Quick Launch
Channel.

To close a monitoring window, choose Window > Close. To close all monitoring windows that
display, choose Window > Close All Windows.

To access Cisco Unified CallManager Administration or Cisco Unified CallManager Serviceability
from the RTMT window, choose Application > CCMAdmin webpage (or CCM Serviceability
webpage).

To access the Serviceability Report Archive option from RTMT, choose System > Report Archive.
If the Security Alert window displays, click Yes. Enter the administrative user name and password
for the server; then, click OK.

To determine the RTMT version that is installed, choose Help > About. The version information
displays in the window. After you view the information, click OK.
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e To access documentation for RTMT, choose Help > Help Topics (or For this Window). For
additional information on RTMT or Cisco Unified CallManager Serviceability, refer to the
Cisco Unified CallManager Serviceability System Guide and the Cisco Unified CallManager
Serviceability Administration Guide.

e To monitor JVM information, click System > JVM Information. The JAVA heap memory usage
displays in the window. Click OK.

e To log out of RTMT, choose System > Log Off. Performing this task logs off the current user, and
the Real-Time Monitoring Tool Login window displays.

e To exit the application, choose System > Exit. Performing this task closes the application.

Additional Information
See the Related Topics, page 7-19.

Configuring E-mail Notification
To configure e-mail notification, perform the following procedure:

Procedure

Step 1 In the Mail Server field, enter the e-mail recipient information.
Step2  In the Port field, enter the port number of the mail server.

Step3  Click OK.

Additional Information

See the Related Topics, page 7-19.

Working with Configuration Profiles

This section provides information on the following topics:
e Using the Default Configuration Profile, page 7-5
¢ Adding Configuration Profiles, page 7-6
e Restoring Profiles, page 7-6
¢ Deleting Configuration Profiles, page 7-7

Using the Default Configuration Profile

When you initially load RTMT, the system includes a default profile that is called CM-Default. The first
time that you use RTMT, it will use the CM-Default profile and display the summary page in the monitor
pane. CM-Default monitors all registered phones dynamically in all the Cisco Unified CallManager

Cisco Unified CallManager Serviceability Administration Guide
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B Working with Configuration Profiles

nodes. If your cluster includes five Cisco Unified CallManager-configured nodes, CM-Default displays
all registered phones for each node in a Cisco Unified CallManager cluster, as well as calls in progress
and active gateway ports and channels.

See the “Adding Configuration Profiles” section on page 7-6 for information on how to create your own
configuration profile.

Additional Information
See the Related Topics, page 7-19.

Adding Configuration Profiles

Step 1

Step 2

Step 3
Step 4

After you open multiple monitoring windows in RTMT (such as CPU & Memory, SDL Queue, and
performance counters), you can create your own configuration profiles so that you can restore these
monitoring windows in a single step rather than opening each window again. You can switch between
different profiles during the same RTMT session or use the configuration profile in subsequent RTMT
sessions.

The following procedure describes how to create a profile.

Procedure

Choose System > Profile.

The Preferences dialog box displays.

Click Save.

The Save Current Configuration dialog box displays.

In the Configuration name field, enter a name for this particular configuration profile.

In the Configuration description field, enter a description of this particular configuration profile.

~

Note  You can enter whatever you want for the configuration profile name and description.

The system creates the new configuration profile.

Additional Information

See the Related Topics, page 7-19.

Restoring Profiles

Step 1

Perform the following procedure to restore a profile that you configured:

Procedure

Choose System > Profile.
The Preferences dialog box displays.

Cisco Unified CallManager Serviceability Administration Guide
m. oL-9418-01 |



| Chapter7 Real-Time Monitoring Configuration

Working with Predefined Objects 1l

Step2  Click the profile that you want to restore.
Step3  Click Restore.

All windows with precanned settings and/or performance monitoring counters for the restored
configuration open.

Additional Information
See the Related Topics, page 7-19.

Deleting Configuration Profiles

Perform the following procedure to delete a profile that you configured:

Procedure

Step 1 Choose System > Profile.

The Preferences dialog box displays.
Step2  Click the profile that you want to delete.
Step3  Click Delete.
Step4  Click Close.

Additional Information
See the Related Topics, page 7-19.

Working with Predefined Objects

The tool (RTMT) provides a set of default monitoring objects that monitor the health of the system.
Default objects include performance counters or critical event status for services that are supported with
Cisco Unified CallManager.

This section provides information on the following topics:
e Viewing/Monitoring a Predefined Object, page 7-7
e Working with Devices, page 7-10
e Working with CTI Applications, Devices, and Lines, page 7-14

Viewing/Monitoring a Predefined Object

The monitoring pane for a category, that is, a predefined object, displays the activities of predefined
monitoring objects. The following procedure describes how to view information for a category.

Cisco Unified CallManager Serviceability Administration Guide
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Procedure

Step 1 To view or monitor a category, perform one of the following tasks:

¢ In the Quick Launch Channel, click the View tab. Then, click a category; for example, Summary,
Server, Call Process, and so on. If an icon displays for the category, click the icon to display the
information that you want to monitor.

e Depending on which category you want to display, choose one of the following options
fromTable 7-1:

Table 7-1 Menu Path for Categories

Category Menu Path Data that Displays

Summary Monitor > Summary Displays memory usage, CPU usage, registered phones, calls in
progress, and active gateway ports and channels

Server Monitor > Server > CPU Usage and e CPU Usage and Memory—Displays memory and CPU usage

Memory (or Process, Disk Usage, or

. . e Process—Displays the process name, process ID (PID) and
Critical Services)

percentage of CPU and memory that is used by the process, the
resident and shared memory, and the Nice (level)

e Disk Usage—Displays the percentage of disk usage per the
largest partition in each host

e C(Critical Services—Displays the services for a specific server

Call Process Monitor > Call Process > Call e (Call Activity—Displays the call activity for each
Activity (or Gateway Activity, Trunk Cisco Unified CallManager server in the cluster, including calls
Activity, SDL Queue, or SIP completed, calls attempted, and calls in progress
Activity)

e Gateway Activity—Displays gateway activity for the
Cisco Unified CallManager cluster, including active ports, ports
in service, and calls completed

e Trunk Activity—Displays the trunk activity for the
Cisco Unified CallManager cluster, including calls in progress
and calls completed

¢ SDL Queue—Displays SDL queue information, including
number of signals in queue and number of processed signals.

e SIP Activity—Displays SIP activity for each
Cisco Unified CallManager server in the cluster, including
summary requests, summary responses, summary of failure
responses in, summary of failure responses out, retry requests
out, and retry responses out.

Cisco Unified CallManager Serviceability Administration Guide
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Table 7-1 Menu Path for Categories (continued)
Category Menu Path Data that Displays
Service Monitor > Service > Cisco TFTP (or | ¢ Cisco TFTP—Displays Cisco TFTP status for each
Heartbeat or Database Summary) Cisco Unified CallManager server in the cluster, including total

TFTP requests, total TFTP requests found, and total TFTP
requests aborted

e Heartbeat—Displays heartbeat information for the
Cisco Unified CallManager, Cisco TFTP, and the
Cisco CallManager Attendant Console service

e Database Summary—Displays summary information for the
database on the Cisco Unified CallManager server, including
connection requests that are queued in the database, connection
requests that are queued in memory, total number of clients
connected, and the number of device resets that are in the queue.

Device Monitor > Device Summary (or Device Summary displays information for each

Phone Summary) Cisco Unified CallManager server in the cluster, including the
number of registered phone devices, registered gateway devices, and
registered media resource devices.

Device Search displays cluster name and device types in tree
hierarchy and allows you to query for information on phones and
devices.

Phone Summary displays information for each

Cisco Unified CallManager server in the cluster, including the
number of registered phones, registered SIP phones, registered
SCCP phones, partially registered phones, and the number of failed
registration attempts.

Tip Instead of choosing Monitor > Device Summary or
Monitor > Phone Summary, you can choose Device > Open
Device Search to display the cluster name and device or
phone types in the tree hierarchy.

Tip To monitor devices, you must perform additional
configuration steps, as described in the “Finding Specific
Devices to Monitor” section on page 7-11.

Cisco Unified CallManager Serviceability Administration Guide
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Table 7-1 Menu Path for Categories (continued)
Category Menu Path Data that Displays
CTI Manager |Monitor > CTI Manager Displays cluster name and CTI types (application, device, and line)

in tree hierarchy

To monitor specific CTI types, you must perform additional
configuration steps, as described in the following sections:

¢ Finding CTI Applications to Monitor, page 7-14
e Finding CTI Devices to Monitor, page 7-15
e Finding CTI Lines to Monitor, page 7-16

You cannot choose CTI Manager by using the menu bar. To monitor
the number of open devices, lines, and CTI connections in a single
window for each Cisco Unified CallManager server in the cluster,
see the “Working with Devices” section on page 7-10.

Performance Performance > Open Performance Displays perfmon counters.

For more information on using perfmon counters, see the
“Configuring and Using Performance Monitoring” section on
page 9-1.

Step2  Some categories allow you to choose a specific server or device type to monitor. To choose a specific
server or device type to monitor, perform one of the following tasks in the panes that are listed:

¢ CPU and Memory Usage pane—To monitor CPU and memory usage for specific server, choose the
server from the Host drop-down list box.

e Disk Usage pane—To monitor disk usage for a specific server, choose the server from the Disk
Usage at Host drop-down list box.

e (Critical Services pane—To monitor critical services for a specific server, choose the server from the
Critical Services at Host drop-down list box.

e Gateway Activity pane—To monitor the gateway activity for a specific gateway type, choose the
gateway type from the Gateway Type drop-down list box.

e Trunk Activity pane—To monitor the trunk activity for a specific trunk type, choose the trunk type
from the Trunk Type drop-down list box.

¢ SDL Queue pane—To monitor the SDL queue information for a specific SDL Queue type, choose
the type from the SDL Queue Type drop-down list box.

Additional Information
See the Related Topics, page 7-19.

Working with Devices

This section contains information on the following topics:
¢ Finding Specific Devices to Monitor, page 7-11

e Viewing Phone Information, page 7-12

Cisco Unified CallManager Serviceability Administration Guide
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e Viewing Device Properties, page 7-13

e Configuring Polling Rate for Devices and Performance Monitoring Counters, page 7-13

Finding Specific Devices to Monitor

Step 1

Step 2

Step 3

Step 4
Step 5

By performing the following procedure, you can monitor data for the following device types:
e Phones
e Gateway Devices
e H.323 Devices
e CTI Devices
e Voice Mail Devices

e Media Resources

e Hunt List
e SIP Trunk
Procedure

Perform one of the following tasks:

¢ Choose Search > Device > <device type; for example, Phone, Gateway, Hunt List, and so on>. A
device selection window displays where you enter the search criteria. Go to Step 4.

¢ In the quick launch channel, click Device; then, click the Device Search icon.
e Choose Device > Open Device Search.

The Device Search window displays the cluster names and tree hierarchy that lists all device types that
you can monitor.

Je

ﬁ After you display the Device Search or CTI Search panes, you can right-click a device type and
choose CCMAdmin to go to Cisco Unified CallManager Administration.

To find all devices in the cluster or to view a complete list of device models from which you can choose,
right-click the cluster name and choose Monitor.

To monitor a specific device type, right-click or double-click the device type from the tree hierarchy.

pe

Tip If you right-click the device type, you must choose Monitor for the device selection window to
display.

In the Select device with status window, click the radio button that applies.

In the drop-down list box next to the radio button that you clicked, choose Any CallManager or a
specific Cisco Unified CallManager server for which you want the device information to display.

Je

Tip In the remaining steps, you can choose the < Back, Next >, Finish, or Cancel buttons.
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Cisco Unified CallManager Serviceability Administration Guide g



Chapter7  Real-Time Monitoring Configuration |

Bl Working with Devices

Step 6
Step 7

Step 8
Step 9

Step 10
Step 11
Step 12

Click the Next > button.

In the Search by device model pane, click the radio button that applies.

Je

ﬁ If you chose Device Model, choose the device type for which you want the device information
to display.
Click Next.

In the Search with name pane, click one of the following radio buttons and enter the appropriate
information in the corresponding fields, if required.

Click Next.
In the Monitor following attributes pane, check one or all of the search attributes.

Click Finish.

Additional Information
See the Related Topics, page 7-19.

Viewing Phone Information

Step 1

Step 2

Step 3
Step 4

Step 5
Step 6

Step 7
Step 8

Step 9
Step 10

You can view information about phones that display in the RTMT device monitoring pane. This section
describes how to view phone information.

Procedure

To display the phone in the RTMT device monitoring pane, see the “Finding Specific Devices to
Monitor” section on page 7-11.

Perform one of the following tasks:
¢ Right-click the phone for which you want information to display and choose Open.
¢ Click the phone and choose Device > Open.

In the Select Device with Status pane, click the radio button that applies.

In the drop-down list box next to the radio button that you clicked, choose Any CallManager or a
specific Cisco Unified CallManager server for which you want the device information to display.

In the Search By Device Model pane, choose the phone protocol that you want to display.

Click the Any Model or Device Model radio button. If you click on the Device Model radio button, then
you will choose a particular phone model that you want to display.

Click Next.

In the Search With Name pane, click the radio button that applies and enter the appropriate information
in the corresponding fields.

In the Monitor following attributes pane, check one or all of the search attributes.

Click Finish.

Cisco Unified CallManager Serviceability Administration Guide
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The Device Information window displays. For more information on the device, choose any field that is
displayed in the left pane of the window.

Additional Information
See the Related Topics, page 7-19.

Viewing Device Properties

Step 1

Step 2

Step 3
Step 4

You can view the properties of devices that display in the RTMT device monitoring pane. This section
describes how to view device properties.

Procedure

Display the device in the RTMT device monitoring pane. See the “Finding Specific Devices to Monitor”
section on page 7-11.

Perform one of the following tasks:

¢ Right-click the device for which you want property information and choose Properties.

e Click the device for which you want property information and choose Device > Properties.
To display the device description information, click the Description tab.

To display other device information, click the Other Info tab.

Additional Information

See the Related Topics, page 7-19.

Configuring Polling Rate for Devices and Performance Monitoring Counters

Note

Step 1

Cisco Unified CallManager polls counters, devices, and gateway ports to gather status information. In
the RTMT monitoring pane, you configure the polling intervals for the performance monitoring counters
and devices.

High-frequency polling rate may adversely affect Cisco Unified CallManager performance. The
minimum polling rate for monitoring a performance counter in chart view equals 5 seconds; the
minimum rate for monitoring a performance counter in table view equals 1 second. The default value for
both equals 10 seconds.

The default value for devices equals 10 minutes.

Perform the following procedure to update the polling rate:

Procedure

Display the device or performance monitoring counter in the RTMT monitoring pane.
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Step 2
Step 3
Step 4

Click the device and choose Edit > Polling Rate.
In the Polling Interval pane, specify the time that you want to use.

Click OK.

Additional Information

See the Related Topics, page 7-19.

Working with CTI Applications, Devices, and Lines

This section contains information on the following topics:
e Viewing CTI Manager Information, page 7-14
¢ Finding CTI Applications to Monitor, page 7-14
¢ Finding CTI Devices to Monitor, page 7-15
e Finding CTI Lines to Monitor, page 7-16

e Viewing Application Information, page 7-17

Viewing CTl Manager Information

To display a chart of open devices, lines, and CTI connections for each Cisco Unified CallManager
server in the cluster, click CTIT in the quick launch channel; then, click the CTI Manager icon.

Additional Information
See the Related Topics, page 7-19.

Finding CTI Applications to Monitor

Step 1

Step 2

Step 3

Perform the following procedure to find specific CTI applications to monitor:

Procedure

Perform one of the following tasks:

e Choose Search > CTI > CTI Applications; the selection window displays where you can enter the
search criteria. Go to Step 3.

¢ In the quick launch channel, click CTI; then, click the CTI Search icon. The CTI search window
displays the cluster names and tree hierarchy that lists all CTI types that you can monitor.

From the tree hierarchy, right-click or double-click Applications:

Je

ﬁ If you right-click the option, choose Monitor.

From the CTI Manager drop-down list box, choose the CTI Manager that you want to monitor.
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Stepd  From the Applications Status drop-down list box, choose the application status.
Step5  Click Next.
Step6  In the Application Pattern pane, click the radio button that applies.

Step7  Enter the information in the field for the radio button that you clicked; for example, if you clicked the
IP Subnet radio button, enter the IP address and the subnet mask in the field.

Step8  Click Next.

Step 9 In the Monitor following attributes window, check one or all of the check boxes for the attributes that
you want to monitor.

Step10  Click Finish.

The applications monitoring pane displays the information that you chose.

Additional Information
See the Related Topics, page 7-19.

Finding CTI Devices to Monitor
Perform the following procedure to find specific CTI devices to monitor.

Procedure

Step1  Perform one of the following tasks:

¢ Choose Monitor > CTI > CTI Devices; the selection window where you can enter the search
criteria displays. Go to Step 3.

¢ In the quick launch channel, click CTI; then, click the CTI Search icon. The CTI search window
displays the cluster names and tree hierarchy that lists all CTI types that you can monitor.

Step2  From the tree hierarchy, right-click or double-click Devices.

Je

ﬁ If you right-click the option, choose Monitor.

Step3  From the CTI Manager drop-down list box, choose the CTI Manager that you want to monitor.
Step4  From the Devices Status drop-down list box, choose the device status.
Step5 In the Devices pane, click the radio button that applies.

Je

ﬁ If you chose Device Name, enter the device name in the field.

Step6  Click Next.
Step7  In the Application Pattern window, click the radio button that applies.

Step8  Enter the information in the field for the radio button that you clicked; for example, if you clicked IP
Subnet, enter the IP address and subnet mask in the field.

Step9  Click Next.

Cisco Unified CallManager Serviceability Administration Guide
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Step10 In the Monitor following attributes window, check one or all check boxes for the attributes that you want
to monitor.

Step11  Click Finish.

The devices monitoring pane displays the information that you chose.

Additional Information

See the Related Topics, page 7-19.

Finding CTI Lines to Monitor

Perform the following procedure to find specific CTI lines to monitor.

Procedure

Step1  Perform one of the following tasks:

¢ Choose Monitor > CTI > CTI Lines; the selection window displays where you can enter the search
criteria. Go to Step 3.

¢ In the quick launch channel, click CTI; then, click the CTI Search icon. The CTI search window
displays the cluster names and tree hierarchy that lists all CTI types that you can monitor.

Step2  From the tree hierarchy, right-click or double-click Lines.

Je

ﬁ If you right-click the option, choose Monitor.

Step3  From the CTI Manager & Status drop-down list box, choose the CTI manager that you want to monitor.
Step 4 From the Lines Status drop-down list box, choose the status.
Step5  In the Devices pane, click the radio button that applies.

Je

ﬁ If you chose Device Name, enter the device name in the field.

Step6  In the Lines pane, click the radio button that applies:

~

Note If you chose Directory Number, enter the directory number in the field.

Step7  Click Next.
Step8 In the Application Pattern pane, click the radio buttons apply:

Step9  Enter the information in the field for the radio button that you clicked; for example, if you clicked IP
Subnet, enter the IP address and subnet mask in the field.

Step10  Click Next.

Step 11 In the Monitor following attributes window, check one or all check boxes for the attributes that you want
to monitor.

Step12 Click Finish.
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The lines monitoring pane displays the information that you chose.

Additional Information
See the Related Topics, page 7-19.

Viewing Application Information

You can view the application information for selected devices such as the Cisco IP phone, CTI port, and
CTI route point. This section describes how to view application information.

Procedure

Step1  Display the devices in the RTMT monitoring pane, as described in the “Finding CTI Devices to Monitor”
section on page 7-15.

Step2  Perform one of the following tasks:

¢ Right-click the device for which you want application information; for example, CTI; then, choose
App Info.

e Click the device for which you want application information and choose Device > App Info.

The Application Information window displays the CTI manager node name, application ID, user ID,
application IP address, application status, app time stamp, device time stamp, device name, and CTI
device open status.

Step 3 To view updated information, click Refresh. To close the window, click OK.

Additional Information

See the Related Topics, page 7-19.

Working with Categories

Categories allow you to monitor performance monitoring counters and devices. For example, the default
category, CallManager, allows you to monitor 6 performance monitoring counters in graph format. If you
want to monitor more counters, you can configure a new category and display the data in table format.

If you perform various searches for devices, for example, for phones, gateways, and so on, you can create
a category for each search and save the results in the category.

Adding a Category
To add a category, perform the following procedure:

Procedure

Step1  Display the Performance Monitoring or Devices tree hierarchy.
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Step 2
Step 3

Choose Edit > Add New Category.
Enter the name of the category; click OK.
The category tab displays at the bottom of the window.

Additional Information
e See the Related Topics, page 7-19.

Renaming a Category

Step 1

Step 2

To rename a category, perform the following procedure:

Procedure

Perform one of the following tasks:
e Right-click the category tab that you want to rename and choose Rename Category.
¢ Click the category tab that you want to rename and choose Edit > Rename Category.
Enter the new name and click OK.

The renamed category displays at the bottom of the window.

Additional Information
e See the Related Topics, page 7-19.

Deleting a Category

To delete a category, perform one of the following tasks:
e Right-click the category tab that you want to delete and choose Remove Category.

e Click the category tab that you want to delete and choose Edit > Remove Category.

Additional Information
See the Related Topics, page 7-19.

Where to Find More Information

e Alert Configuration in RTMT, page 8-1

e Configuring and Using Performance Monitoring, page 9-1

e Trace Collection and Log Central in RTMT, page 10-1

e Real-Time Monitoring Tool, Cisco Unified CallManager Serviceability System Guide
e Alerts, Cisco Unified CallManager Serviceability System Guide

e Performance Objects and Counters, Cisco Unified CallManager Serviceability System Guide
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Related Topics

Additional Information
See the Related Topics, page 7-19.

Related Topics

Adding a Category, page 7-17

Renaming a Category, page 7-18

Deleting a Category, page 7-18

Real-Time Monitoring Configuration, Cisco Unified CallManager Serviceability System Guide
Viewing CTI Manager Information, page 7-14

Finding CTI Applications to Monitor, page 7-14

Finding CTI Devices to Monitor, page 7-15

Finding CTI Lines to Monitor, page 7-16

Configuring and Using Performance Monitoring, page 9-1
Working with Devices, page 7-10

Viewing Device Properties, page 7-13

Finding Specific Devices to Monitor, page 7-11

Viewing Phone Information, page 7-12

Configuring Polling Rate for Devices and Performance Monitoring Counters, page 7-13
Using the Default Configuration Profile, page 7-5

Restoring Profiles, page 7-6

Using the Default Configuration Profile, page 7-5

Deleting Configuration Profiles, page 7-7

Adding Configuration Profiles, page 7-6

Working with Configuration Profiles, page 7-5

Working with Predefined Objects, page 7-7

Alert Configuration in RTMT, page 8-1

Configuring and Using Performance Monitoring, page 9-1
Using SysLog Viewer in RTMT, page 11-1

Installing the Real-Time Monitoring Tool (RTMT), page 7-1
Uninstalling RTMT, page 7-3

Upgrading RTMT, page 7-2

Using RTMT, page 7-3
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