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Real-Time Monitoring Configuration

This chapter contains the following information for configuring the Cisco Unified CallManager 
Real-Time Monitoring Tool (RTMT). 

• Installing the Real-Time Monitoring Tool (RTMT), page 18-1

• Uninstalling RTMT, page 18-2

• Using RTMT, page 18-3

• Configuring E-mail Notification, page 18-4

• Working with Configuration Profiles, page 18-5

• Working with Predefined Objects, page 18-7

• Working with Devices, page 18-10

• Working with CTI Applications, Devices, and Lines, page 18-13

• Where to Find More Information, page 18-18

Tip For information on alert, performance monitoring, trace collection, and syslog viewer configuration, see 
the “Where to Find More Information” section on page 18-18.

Installing the Real-Time Monitoring Tool (RTMT)
You can install RTMT, which works for resolutions 800*600 and above, on a Windows 98, Windows XP, 
Windows 2000, or Red Hat Linux with KDE and/or Gnome client.

Tip Ensure that the RTMT version that you install is compatible with the Cisco Unified CallManager version 
that runs in your cluster; for example, the RTMT version that supports Cisco Unified CallManager 4.X 
does not support Cisco Unified CallManager 5.X, but the RTMT version that supports Cisco Unified 
CallManager 5.0 supports Cisco Unified CallManager 5.1.

To monitor Cisco Unified CallManager 4.X and 5.X clusters simultaneously, you must install multiple 
versions of RTMT (one version per Cisco Unified CallManager release). If you install multiple versions 
of the plug-in, you can install the versions on the same client as long as the versions exist in different 
folders. If the installation detects another version in the folder, a message displays. To continue the 
installation, install the version in a different folder.
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Uninstalling RTMT
To install the tool, perform the following procedure:

Procedure

Step 1 From Cisco Unified CallManager Administration, choose Application > Plugins.

Step 2 Click the Find button.

Step 3 To install the RTMT tool on a client that is running the Microsoft Windows operating system, click the 
Download link for the Cisco Unified CallManager Real-Time Monitoring Tool-Windows. To install the 
RTMT tool on a client that is running the Linux operating system, click the Download link for the 
Cisco Unified CallManager Real-Time Monitoring Tool-Linux.

Step 4 Download the executable to the preferred location on your client.

Step 5 To install the Windows version, double-click the RTMT icon that displays on the desktop or locate the 
directory where you downloaded the file and run the RTMT installation file.

The extraction process begins.

Step 6 To install the Linux version, ensure that the file has execute privileges; for example, enter the following 
command, which is case sensitive: chmod +x CcmServRtmtPlugin.bin

Step 7 After the RTMT welcome window displays, click Next.

Step 8 To accept the license agreement, click I accept the terms of the license agreement; then, click Next.

Step 9 Choose the location where you want to install RTMT. If you do not want to use the default location, click 
Browse and navigate to a different location. Click Next.

Step 10 To begin the installation, click Next.

The Setup Status window displays. Do not click Cancel.

Step 11 To complete the installation, click Finish.

Additional Information

See the Related Topics, page 18-18.

Uninstalling RTMT

Tip When you use the tool (RTMT), it saves user preferences and downloaded module jar files (the cache) 
locally on the client machine. The system saves the cache in the Cisco Unified CallManager database. 
When you uninstall RTMT, you choose whether to delete or save the cache.

On a Windows client, you uninstall RTMT through Add/Remove Programs under the Control Panel. 
(Choose Start > Settings > Control Panel >Add/Remove Programs.)

To uninstall RTMT on a Red Hat Linux with KDE and/or Gnome client, choose Start > 
Accessories > Uninstall Real-time Monitoring tool from the task bar.

Additional Information

See the Related Topics, page 18-18.
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Using RTMT
Before You Begin

Before you can use RTMT, you must activate the Cisco AMC Service on each node in the cluster. From 
Cisco Unified CallManager Serviceability, choose Tools > Service Activation and check the Cisco 
AMC Service check box. Click Update.

Procedure

Step 1 After you install the plug-in, perform one of the following tasks:

• From your Windows desktop, double-click the Cisco Unified CallManager Real-Time 
Monitoring Tool icon.

• Choose Start > Programs > Cisco CallManager Serviceability > Real-Time Monitoring Tool > 
Real-Time Monitoring Tool.

The Real-Time Monitoring Tool Login window displays. 

Step 2 In the Host IP Address field, enter either the IP address or host name of the first node.

Step 3 In the User Name field, enter the CCMAdministrator application user username; for example, the default 
username for this user equals CCMAdministrator.

Step 4 In the Password field, enter the CCMAdministrator application user password that you established for 
the username.

Note If the authentication fails or if the server is unreachable, the tool prompts you to reenter the 
server and authentication details, or you can click the Cancel button to exit the application. After 
the authentication succeeds, RTMT launches the monitoring module from local cache or from a 
remote node, when the local cache does not contain a monitoring module that matches the 
backend Cisco Unified CallManager version.

Step 5 Enter the port that the application will use to listen to the server. The default setting equals 8443.

Step 6 Check the Secure Connection check box.

Step 7 Click OK.

Step 8 Add the certificate store by clicking Yes.

Step 9 See the following list for tasks that you can perform in RTMT:

• To configure the mail server for e-mail alerts, see the “Configuring E-mail Notification” section on 
page 18-4.

• To create configuration profiles, see the “Adding Configuration Profiles” section on page 18-5.

• To monitor predefined objects, see the “Working with Predefined Objects” section on page 18-7.

• To work with devices, see the “Working with Devices” section on page 18-10.

• To work with CTI applications, devices, and lines, see the “Working with CTI Applications, 
Devices, and Lines” section on page 18-13.

• To work with Alerts, see “Alert Configuration in RTMT” in the Cisco CallManager Serviceability 
Administration Guide, Release 5.0(4).

• To work with performance monitoring objects, see the “Configuring and Using Performance 
Monitoring” section in the Cisco CallManager Serviceability Administration Guide, Release 5.0(4).
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Configuring E-mail Notification
• To collect and view traces, see the “Trace Collection and Log Central in RTMT” in the Cisco 
CallManager Serviceability Administration Guide, Release 5.0(4).

• To use SysLog Viewer, see the “Using SysLog Viewer in RTMT” in the Cisco CallManager 
Serviceability Administration Guide, Release 5.0(4).

• To configure the trace setting for RTMT, choose Edit > Trace Setting. Click the radio button that 
applies.

• To hide the Quick Launch Channel, which is the pane that displays on the left side of the window, 
choose Edit > Hide Quick Launch Channel.

To display the Quick Launch Channel after it is hidden, choose Edit > Hide Quick Launch 
Channel.

• To close a monitoring window, choose Window > Close. To close all monitoring windows that 
display, choose Window > Close All Windows.

• To access Cisco Unified CallManager Administration or Cisco Unified CallManager Serviceability 
from the RTMT window, choose Application > CCMAdmin webpage (or CCM Serviceability 
webpage).

• To access the Serviceability Report Archive option from RTMT, choose System > Report Archive. 
If the Security Alert window displays, click Yes. Enter the administrative user name and password 
for the server; then, click OK.

• To determine the RTMT version that is installed, choose Help > About. The version information 
displays in the window. After you view the information, click OK.

• To access documentation for RTMT, choose Help > Help Topics (or For this Window). For 
additional information on RTMT or Cisco Unified CallManager Serviceability, refer to the 
Cisco Unified CallManager Serviceability System Guide, Release 5.0(4), and the 
Cisco Unified CallManager Serviceability Administration Guide, Release 5.0(4).

• To monitor JVM information, click System > JVM Information. The JAVA heap memory usage 
displays in the window. Click OK.

• To log out of RTMT, choose System > Log Off. Performing this task logs off the current user, and 
the Real-Time Monitoring Tool Login window displays. 

• To exit the application, choose System > Exit. Performing this task closes the application.

Additional Information

See the Related Topics, page 18-18.

Configuring E-mail Notification
To configure e-mail notification, perform the following procedure:

Procedure

Step 1 In the Mail Server field, enter the e-mail recipient information.

Step 2 In the Port field, enter the port number of the mail server.
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Working with Configuration Profiles
Step 3 Click OK.

Additional Information

See the Related Topics, page 18-18.

Working with Configuration Profiles
This section provides information on the following topics:

• Using the Default Configuration Profile, page 18-5

• Adding Configuration Profiles, page 18-5

• Restoring Profiles, page 18-6

• Deleting Configuration Profiles, page 18-6

Using the Default Configuration Profile
When you initially load RTMT, the system includes a default profile that is called CM-Default. The first 
time that you use RTMT, it will use the CM-Default profile and display the summary page in the monitor 
pane. CM-Default monitors all registered phones dynamically in all the Cisco Unified CallManager 
nodes. If your cluster includes five Cisco Unified CallManager-configured nodes, CM-Default displays 
all registered phones for each node in a Cisco Unified CallManager cluster, as well as calls in progress 
and active gateway ports and channels. 

See the “Adding Configuration Profiles” section on page 18-5 for information on how to create your own 
configuration profile.

Additional Information

See the Related Topics, page 18-18.

Adding Configuration Profiles
After you open multiple monitoring windows in RTMT (such as CPU & Memory, SDL Queue, and 
performance counters), you can create your own configuration profiles, so you can restore these 
monitoring windows in a single step rather than opening each window again. You can switch between 
different profiles during the same RTMT session or use the configuration profile in subsequent RTMT 
sessions. 

The following procedure describes how to create a profile.

Procedure

Step 1 Choose System > Profile.

The Preferences dialog box displays.

Step 2 Click Save.

The Save Current Configuration dialog box displays.
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Working with Configuration Profiles
Step 3 In the Configuration name field, enter a name for this particular configuration profile.

Step 4 In the Configuration description field, enter a description of this particular configuration profile.

Note You can enter whatever you want for the configuration profile name and description.

The system creates the new configuration profile.

Additional Information

See the Related Topics, page 18-18.

Restoring Profiles
Perform the following procedure to restore a profile that you configured:

Procedure

Step 1 Choose System > Profile.

The Preferences dialog box displays.

Step 2 Click the profile that you want to restore.

Step 3 Click Restore.

All windows with precanned settings and/or performance monitoring counters for the restored 
configuration open.

Additional Information

See the Related Topics, page 18-18.

Deleting Configuration Profiles
Perform the following procedure to delete a profile that you configured:

Procedure

Step 1 Choose System > Profile.

The Preferences dialog box displays.

Step 2 Click the profile that you want to delete.

Step 3 Click Delete.

Step 4 Click Close.
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Additional Information

See the Related Topics, page 18-18.

Working with Predefined Objects
The tool (RTMT) provides a set of default monitoring objects that monitor the health of the system. 
Default objects include performance counters or critical event status for services that are supported with 
Cisco Unified CallManager. 

This section provides information on the following topics:

• Viewing/Monitoring a Predefined Object, page 18-7

• Working with Devices, page 18-10

• Working with CTI Applications, Devices, and Lines, page 18-13

Viewing/Monitoring a Predefined Object
The monitoring pane for a category, that is, a predefined object, displays the activities of predefined 
monitoring objects. The following procedure describes how to view information for a category.

Procedure

Step 1 To view or monitor a category, perform one of the following tasks:

• In the Quick Launch Channel, click the View tab. Then, click a category; for example, Summary, 
Server, Call Process, and so on. If an icon displays for the category, click the icon to display the 
information that you want to monitor.

• Depending on which category you want to display, choose one of the following options 
fromTable 18-1:

Table 18-1 Menu Path for Categories

Category Menu Path Data that Displays

Summary Monitor > Summary Displays memory usage, CPU usage, registered phones, calls in 
progress, and active gateway ports and channels 

Server Monitor > Server > CPU Usage and 
Memory (or Process, Disk Usage, or 
Critical Services)

• CPU Usage and Memory—Displays memory and CPU usage

• Process—Displays the process name, process ID (PID) and 
percentage of CPU and memory that is used by the process, the 
resident and shared memory, and the Nice (level)

• Disk Usage—Displays the percentage of disk usage per the 
largest partition in each host

• Critical Services—Displays the services for a specific server
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Call Process Monitor > Call Process > Call 
Activity (or Gateway Activity, Trunk 
Activity, SDL Queue, or SIP 
Activity)

• Call Activity—Displays the call activity for each Cisco 
Unified CallManager server in the cluster, including calls 
completed, calls attempted, and calls in progress

• Gateway Activity—Displays gateway activity for the 
Cisco Unified CallManager cluster, including active ports, ports 
in service, and calls completed

• Trunk Activity—Displays the trunk activity for the Cisco 
Unified CallManager cluster, including calls in progress and 
calls completed

• SDL Queue—Displays SDL queue information, including 
number of signals in queue and number of processed signals.

• SIP Activity—Displays SIP activity for each Cisco Unified 
CallManager server in the cluster, including summary requests, 
summary responses, summary of failure responses in, summary 
of failure responses out, retry requests out, and retry responses 
out

Service Monitor > Service > Cisco TFTP (or 
Heartbeat or Database Summary)

• Cisco TFTP—Displays Cisco TFTP status for each 
Cisco Unified CallManager server in the cluster, including total 
TFTP requests, total TFTP requests found, and total TFTP 
requests aborted

• Heartbeat—Displays heartbeat information for the Cisco 
Unified CallManager, Cisco TFTP, and the Cisco CallManager 
Attendant Console service

• Database Summary—Displays summary information for the 
database on the Cisco Unified CallManager server, including 
change notification requests that are queued in the database, 
change notification requests that are queued in memory, total 
number of clients connected, and the number of device resets 
that are in the queue 

Table 18-1 Menu Path for Categories (continued)

Category Menu Path Data that Displays
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Viewing/Monitoring a Predefined Object
Step 2 Some categories allow you to choose a specific server or device type to monitor. To choose a specific 
server or device type to monitor, perform one of the following tasks in the panes that are listed:

• CPU and Memory Usage pane—To monitor CPU and memory usage for specific server, choose the 
server from the Host drop-down list box.

• Disk Usage pane—To monitor disk usage for a specific server, choose the server from the Disk 
Usage at Host drop-down list box.

• Critical Services pane—To monitor critical services for a specific server, choose the server from the 
Critical Services at Host drop-down list box.

Device Monitor > Device Summary (or 
Phone Summary)

Device Summary displays information for each Cisco Unified 
CallManager server in the cluster, including the number of registered 
phone devices, registered gateway devices, and registered media 
resource devices.

Device Search displays cluster name and device types in tree 
hierarchy and allows you to query for information on phones and 
devices.

Phone Summary displays information for each Cisco Unified 
CallManager server in the cluster, including the number of registered 
phones, registered SIP phones, registered SCCP phones, partially 
registered phones, and the number of failed registration attempts.

Tip Instead of choosing Monitor > Device Summary or 
Monitor > Phone Summary, you can choose Device > Open 
Device Search to display the cluster name and device or 
phone types in the tree hierarchy.

Tip To monitor devices, you must perform additional 
configuration steps, as described in the “Finding Specific 
Devices to Monitor” section on page 18-10.

CTI Manager Monitor > CTI Manager Displays cluster name and CTI types (application, device, and line) 
in tree hierarchy

To monitor specific CTI types, you must perform additional 
configuration steps, as described in the following sections:

• Finding CTI Applications to Monitor, page 18-14

• Finding CTI Devices to Monitor, page 18-14

• Finding CTI Lines to Monitor, page 18-15

You cannot choose CTI Manager by using the menu bar. To monitor 
the number of open devices, lines, and CTI connections in a single 
window for each Cisco Unified CallManager server in the cluster, 
see the “Working with Devices” section on page 18-10.

Performance Performance > Open Performance Displays perfmon counters. 

For more information on using perfmon counters, see the 
“Configuring and Using Performance Monitoring” in the Cisco 
CallManager Serviceability Administration Guide, Release 5.0(4).

Table 18-1 Menu Path for Categories (continued)

Category Menu Path Data that Displays
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Working with Devices
• Gateway Activity pane—To monitor the gateway activity for a specific gateway type, choose the 
gateway type from the Gateway Type drop-down list box.

• Trunk Activity pane—To monitor the trunk activity for a specific trunk type, choose the trunk type 
from the Trunk Type drop-down list box.

• SDL Queue pane—To monitor the SDL queue information for a specific SDL queue type, choose 
the type from the SDL Queue Type drop-down list box.

Tip To zoom in on the monitor of a predefined object, click and drag the left mouse button over the area of 
the chart in which you are interested. Release the left mouse button when you have the selected area. 
RTMT updates the monitored view. To zoom out and reset the monitor to the initial default view, press 
the “R” key. 

Additional Information

See the Related Topics, page 18-18.

Working with Devices
This section contains information on the following topics:

• Finding Specific Devices to Monitor, page 18-10

• Viewing Phone Information, page 18-12

• Viewing Device Properties, page 18-12

• Configuring Polling Rate for Devices and Performance Monitoring Counters, page 18-13

Finding Specific Devices to Monitor
By performing the following procedure, you can monitor data for the following device types:

• Phones

• Gateway Devices

• H.323 Devices

• CTI Devices

• Voice Mail Devices

• Media Resources

• Hunt List

• SIP Trunk

Procedure

Step 1 Perform one of the following tasks:

• Choose Search > Device > <device type; for example, Phone, Gateway, Hunt List, and so on>. A 
device selection window displays where you enter the search criteria. Go to Step 4.
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• In the quick launch channel, click Device; then, click the Device Search icon.

• Choose Device > Open Device Search.

The Device Search window displays the cluster names and tree hierarchy that lists all device types that 
you can monitor.

Tip After you display the Device Search or CTI Search panes, you can right-click a device type and 
choose CCMAdmin to go to Cisco Unified CallManager Administration.

Step 2 To find all devices in the cluster or to view a complete list of device models from which you can choose, 
right-click the cluster name and choose Monitor.

Step 3 To monitor a specific device type, right-click or double-click the device type from the tree hierarchy.

Tip If you right-click the device type, you must choose Monitor for the device selection window to 
display.

Step 4 In the Select device with status window, click the radio button that applies.

Step 5 In the drop-down list box next to the radio button that you clicked, choose Any CallManager or a 
specific Cisco Unified CallManager server for which you want the device information to display.

Tip In the remaining steps, you can choose the < Back, Next >, Finish, or Cancel buttons.

Step 6 Click the Next > button.

Step 7 In the Search by device model pane, click the radio button that applies.

Tip If you chose Device Model, choose the device type for which you want the device information 
to display.

Step 8 Click Next.

Step 9 In the Search with name pane, click one of the following radio buttons and enter the appropriate 
information in the corresponding fields, if required.

Step 10 Click Next.

Step 11 In the Monitor following attributes pane, check one or all of the search attributes.

Step 12 Click Finish.

Additional Information

See the Related Topics, page 18-18.
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Viewing Phone Information
You can view information about phones that display in the RTMT device monitoring pane. This section 
describes how to view phone information.

Procedure

Step 1 To display the phone in the RTMT device monitoring pane, see the “Finding Specific Devices to 
Monitor” section on page 18-10.

Step 2 Perform one of the following tasks:

• Right-click the phone for which you want information to display and choose Open.

• Click the phone and choose Device > Open.

Step 3 In the Select Device with Status pane, click the radio button that applies.

Step 4 In the drop-down list box next to the radio button that you clicked, choose Any CallManager or a 
specific Cisco Unified CallManager server for which you want the device information to display.

Step 5 In the Search By Device Model pane, choose the phone protocol that you want to display.

Step 6 Click the Any Model or Device Model radio button. If you click the Device Model radio button, choose 
a particular phone model that you want to display.

Step 7 Click Next.

Step 8 In the Search With Name pane, click the radio button that applies and enter the appropriate information 
in the corresponding fields. 

Step 9 In the Monitor following attributes pane, check one or all of the search attributes.

Step 10 Click Finish.

The Device Information window displays. For more information on the device, choose any field that 
displays in the left pane of the window.

Additional Information

See the Related Topics, page 18-18.

Viewing Device Properties
You can view the properties of devices that display in the RTMT device monitoring pane. This section 
describes how to view device properties.

Procedure

Step 1 Display the device in the RTMT device monitoring pane. See the “Finding Specific Devices to Monitor” 
section on page 18-10.

Step 2 Perform one of the following tasks:

• Right-click the device for which you want property information and choose Properties.

• Click the device for which you want property information and choose Device > Properties.

Step 3 To display the device description information, click the Description tab.
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Step 4 To display other device information, click the Other Info tab.

Additional Information

See the Related Topics, page 18-18.

Configuring Polling Rate for Devices and Performance Monitoring Counters
Cisco Unified CallManager polls counters, devices, and gateway ports to gather status information. In 
the RTMT monitoring pane, you configure the polling intervals for the performance monitoring counters 
and devices.

Note High-frequency polling rate may adversely affect Cisco Unified CallManager performance. The 
minimum polling rate for monitoring a performance counter in chart view equals 5 seconds; the 
minimum rate for monitoring a performance counter in table view equals 1 second. The default value for 
both equals 10 seconds. 

The default value for devices equals 10 minutes.

Perform the following procedure to update the polling rate:

Procedure

Step 1 Display the device or performance monitoring counter in the RTMT monitoring pane.

Step 2 Click the device and choose Edit > Polling Rate.

Step 3 In the Polling Interval pane, specify the time that you want to use.

Step 4 Click OK.

Additional Information

See the Related Topics, page 18-18.

Working with CTI Applications, Devices, and Lines
This section contains information on the following topics:

• Viewing CTI Manager Information, page 18-14

• Finding CTI Applications to Monitor, page 18-14

• Finding CTI Devices to Monitor, page 18-14

• Finding CTI Lines to Monitor, page 18-15

• Viewing Application Information, page 18-16
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Viewing CTI Manager Information
To display a chart of open devices, lines, and CTI connections for each Cisco Unified CallManager 
server in the cluster, click CTI in the quick launch channel; then, click the CTI Manager icon.

Additional Information

See the Related Topics, page 18-18.

Finding CTI Applications to Monitor
Perform the following procedure to find specific CTI applications to monitor:

Procedure

Step 1 Perform one of the following tasks:

• Choose Search > CTI > CTI Applications; the selection window displays where you can enter the 
search criteria. Go to Step 3.

• In the quick launch channel, click CTI; then, click the CTI Search icon. The CTI search window 
displays the cluster names and tree hierarchy that lists all CTI types that you can monitor.

Step 2 From the tree hierarchy, right-click or double-click Applications:

Tip If you right-click the option, choose Monitor.

Step 3 From the CTI Manager drop-down list box, choose the CTI Manager that you want to monitor.

Step 4 From the Applications Status drop-down list box, choose the application status.

Step 5 Click Next.

Step 6 In the Application Pattern pane, click the radio button that applies.

Step 7 Enter the information in the field for the radio button that you clicked; for example, if you clicked the 
IP Subnet radio button, enter the IP address and the subnet mask in the field.

Step 8 Click Next.

Step 9 In the Monitor following attributes window, check one or all of the check boxes for the attributes that 
you want to monitor.

Step 10 Click Finish.

The applications monitoring pane displays the information that you chose.

Additional Information

See the Related Topics, page 18-18.

Finding CTI Devices to Monitor
Perform the following procedure to find specific CTI devices to monitor.
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Procedure

Step 1 Perform one of the following tasks:

• Choose Monitor > CTI > CTI Devices; the selection window where you can enter the search 
criteria displays. Go to Step 3.

• In the quick launch channel, click CTI; then, click the CTI Search icon. The CTI search window 
displays the cluster names and tree hierarchy that lists all CTI types that you can monitor.

Step 2 From the tree hierarchy, right-click or double-click Devices.

Tip If you right-click the option, choose Monitor.

Step 3 From the CTI Manager drop-down list box, choose the CTI Manager that you want to monitor.

Step 4 From the Devices Status drop-down list box, choose the device status.

Step 5 In the Devices pane, click the radio button that applies.

Tip If you chose Device Name, enter the device name in the field.

Step 6 Click Next.

Step 7 In the Application Pattern window, click the radio button that applies.

Step 8 Enter the information in the field for the radio button that you clicked; for example, if you clicked IP 
Subnet, enter the IP address and subnet mask in the field.

Step 9 Click Next.

Step 10 In the Monitor following attributes window, check one or all check boxes for the attributes that you want 
to monitor.

Step 11 Click Finish.

The devices monitoring pane displays the information that you chose.

Additional Information

See the Related Topics, page 18-18.

Finding CTI Lines to Monitor
Perform the following procedure to find specific CTI lines to monitor.

Procedure

Step 1 Perform one of the following tasks:

• Choose Monitor > CTI > CTI Lines; the selection window displays where you can enter the search 
criteria. Go to Step 3.

• In the quick launch channel, click CTI; then, click the CTI Search icon. The CTI search window 
displays the cluster names and tree hierarchy that lists all CTI types that you can monitor.
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Step 2 From the tree hierarchy, right-click or double-click Lines.

Tip If you right-click the option, choose Monitor.

Step 3 From the CTI Manager & Status drop-down list box, choose the CTI manager that you want to monitor.

Step 4 From the Lines Status drop-down list box, choose the status.

Step 5 In the Devices pane, click the radio button that applies. 

Tip If you chose Device Name, enter the device name in the field.

Step 6 In the Lines pane, click the radio button that applies:

Note If you chose Directory Number, enter the directory number in the field.

Step 7 Click Next.

Step 8 In the Application Pattern pane, click the radio buttons apply:

Step 9 Enter the information in the field for the radio button that you clicked; for example, if you clicked IP 
Subnet, enter the IP address and subnet mask in the field.

Step 10 Click Next.

Step 11 In the Monitor following attributes window, check one or all check boxes for the attributes that you want 
to monitor.

Step 12 Click Finish.

The lines monitoring pane displays the information that you chose.

Additional Information

See the Related Topics, page 18-18.

Viewing Application Information
You can view the application information for selected devices such as the Cisco IP Phone, CTI port, and 
CTI route point. This section describes how to view application information.

Procedure

Step 1 Display the devices in the RTMT monitoring pane, as described in the “Finding CTI Devices to Monitor” 
section on page 18-14.

Step 2 Perform one of the following tasks:

• Right-click the device for which you want application information; for example, CTI; then, choose 
App Info.

• Click the device for which you want application information and choose Device > App Info.
18-16
Cisco Unified CallManager New and Changed Information Guide

OL-11473-01



 

Chapter 18      Real-Time Monitoring Configuration
Working with Categories
The Application Information window displays the CTI manager node name, application ID, user ID, 
application IP address, application status, app time stamp, device time stamp, device name, and CTI 
device open status.

Step 3 To view updated information, click Refresh. To close the window, click OK.

Additional Information

See the Related Topics, page 18-18.

Working with Categories
Categories allow you to monitor performance monitoring counters and devices. For example, the default 
category, CallManager, allows you to monitor six performance monitoring counters in graph format. If 
you want to monitor more counters, you can configure a new category and display the data in table 
format.

If you perform various searches for devices, for example, for phones, gateways, and so on, you can create 
a category for each search and save the results in the category.

Adding a Category
To add a category, perform the following procedure:

Procedure

Step 1 Display the Performance Monitoring or Devices tree hierarchy.

Step 2 Choose Edit > Add New Category.

Step 3 Enter the name of the category; click OK.

The category tab displays at the bottom of the window.

Additional Information

• See the Related Topics, page 18-18.

Renaming a Category
To rename a category, perform the following procedure:

Procedure

Step 1 Perform one of the following tasks:

• Right-click the category tab that you want to rename and choose Rename Category.

• Click the category tab that you want to rename and choose Edit > Rename Category.
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Step 2 Enter the new name and click OK.

The renamed category displays at the bottom of the window.

Additional Information

• See the Related Topics, page 18-18.

Deleting a Category
To delete a category, perform one of the following tasks:

• Right-click the category tab that you want to delete and choose Remove Category.

• Click the category tab that you want to delete and choose Edit > Remove Category.

Additional Information

See the Related Topics, page 18-18.

Where to Find More Information
• Alert Configuration in RTMT, Cisco CallManager Serviceability Administration Guide, Release 

5.0(4)

• Configuring and Using Performance Monitoring, Cisco CallManager Serviceability Administration 
Guide, Release 5.0(4)

• Trace Collection and Log Central in RTMT, Cisco CallManager Serviceability Administration 
Guide, Release 5.0(4)

• Real-Time Monitoring Tool, Cisco Unified CallManager New and Changed Information Guide, 
Release 5.1(1)

• Alerts, Cisco Unified CallManager Serviceability System Guide, Release 5.0(4)

• Performance Objects and Counters, Cisco Unified CallManager New and Changed Information 
Guide, Release 5.1(1)

Additional Information

See the Related Topics, page 18-18.

Related Topics
• Adding a Category, page 18-17

• Renaming a Category, page 18-17

• Deleting a Category, page 18-18

• Viewing CTI Manager Information, page 18-14

• Finding CTI Applications to Monitor, page 18-14

• Finding CTI Devices to Monitor, page 18-14
18-18
Cisco Unified CallManager New and Changed Information Guide

OL-11473-01



 

Chapter 18      Real-Time Monitoring Configuration
Related Topics
• Finding CTI Lines to Monitor, page 18-15

• Configuring and Using Performance Monitoring, Cisco CallManager Serviceability Administration 
Guide, Release 5.0(4)

• Working with Devices, page 18-10

• Viewing Device Properties, page 18-12

• Finding Specific Devices to Monitor, page 18-10

• Viewing Phone Information, page 18-12

• Configuring Polling Rate for Devices and Performance Monitoring Counters, page 18-13

• Using the Default Configuration Profile, page 18-5

• Restoring Profiles, page 18-6

• Using the Default Configuration Profile, page 18-5

• Deleting Configuration Profiles, page 18-6

• Adding Configuration Profiles, page 18-5

• Working with Configuration Profiles, page 18-5

• Working with Predefined Objects, page 18-7

• Alert Configuration in RTMT, Cisco CallManager Serviceability Administration Guide, Release 
5.0(4)

• Using SysLog Viewer in RTMT, Cisco CallManager Serviceability Administration Guide, Release 
5.0(4)

• Installing the Real-Time Monitoring Tool (RTMT), page 18-1

• Uninstalling RTMT, page 18-2

• Using RTMT, page 18-3
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