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Preface

This preface contains the following sections:

 • Audience and Use, page v

 • Documentation Conventions, page vi

 • Related Documentation, page vi

 • Obtaining Documentation and Submitting a Service Request, page vii

 • Cisco Product Security Overview, page vii

Audience and Use
The Administration Guide for Cisco Unity Connection Serviceability provides descriptions and 
procedures for configuring alarms, traces, clusters, and services through Cisco Unity Connection 
Serviceability. It is intended for administrators who configure, troubleshoot, and support a Cisco Unity 
Connection or a Cisco Unified Communications Manager Business Edition system. This guide requires 
knowledge of IP networking technology.

Tip For Cisco Unity Connection, you must perform serviceability-related tasks in both Cisco Unified 
Serviceability and Cisco Unity Connection Serviceability; for example, you may need to start and stop 
services, view alarms, and configure traces in both applications to troubleshoot a problem. 
 
Cisco Unified Serviceability supports the functionality described in the Cisco Unified Serviceability 
Administration Guide; for tasks that are specific to Cisco Unity Connection Serviceability, use this 
guide, the Administration Guide for Cisco Unity Connection Serviceability.
v
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Documentation Conventions

The Administration Guide for Cisco Unity Connection Serviceability also uses the following 
conventions:

Note Means reader take note. Notes contain helpful suggestions or references to material not covered in the 
document.

Caution Means reader be careful. In this situation, you might do something that could result in equipment damage 
or loss of data.

Related Documentation
For descriptions and URLs of Cisco Unity Connection documentation on Cisco.com, see the 
Documentation Guide for Cisco Unity Connection Release 8.x. The document is shipped with 
Cisco Unity Connection and is available at 
http://www.cisco.com/en/US/docs/voice_ip_comm/connection/8x/roadmap/8xcucdg.html.

For descriptions and URLs of Cisco Unified Communications Manager Business Edition documentation 
on Cisco.com, see the Cisco Unified Communications Manager Business Edition Documentation Guide. 
The document is shipped with Cisco Unified CMBE and is available at 
http://www.cisco.com/en/US/products/ps7273/products_documentation_roadmaps_list.html.

Table 1 Conventions in the Administration Guide for Cisco Unity Connection Serviceability 

Convention Description

boldfaced text Boldfaced text is used for:

 • Key and button names. (Example: Select OK.)

 • Information that you enter. (Example: Enter Administrator in the User Name 
box.)

< > 
(angle brackets)

Angle brackets are used around parameters for which you supply a value. 
(Example: In your browser, go to https://<Cisco Unity Connection server IP 
address>/cuadmin.)

-  
(hyphen)

Hyphens separate keys that must be pressed simultaneously. (Example: Press 
Ctrl-Alt-Delete.)

>  
(right angle 
bracket)

A right angle bracket is used to separate selections that you make in the navigation 
bar of Cisco Unity Connection Administration. (Example: In Cisco Unity 
Connection Administration, go to Contacts > System Contacts.)
vi
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Obtaining Documentation and Submitting a Service Request
For information on obtaining documentation, submitting a service request, and gathering additional 
information, see the monthly What’s New in Cisco Product Documentation, which also lists all new and 
revised Cisco technical documentation, at:

http://www.cisco.com/en/US/docs/general/whatsnew/whatsnew.html

Subscribe to the What’s New in Cisco Product Documentation as a Really Simple Syndication (RSS) feed 
and set content to be delivered directly to your desktop using a reader application. The RSS feeds are a free 
service and Cisco currently supports RSS Version 2.0.

Cisco Product Security Overview
This product contains cryptographic features and is subject to United States and local country laws 
governing import, export, transfer and use. Delivery of Cisco cryptographic products does not imply 
third-party authority to import, export, distribute or use encryption. Importers, exporters, distributors 
and users are responsible for compliance with U.S. and local country laws. By using this product you 
agree to comply with applicable laws and regulations. If you are unable to comply with U.S. and local 
laws, return this product immediately.

Further information regarding U.S. export regulations may be found at 
http://www.access.gpo.gov/bis/ear/ear_data.html.
vii
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C H A P T E R 1

Introduction to Cisco Unity Connection 
Serviceability in Version 8.x

This chapter provides basic information on Cisco Unity Connection Serviceability and contains the 
following sections:

 • Understanding Cisco Unity Connection Serviceability in Version 8.x, page 1-1

 • Configuring Browsers on Administrator Workstations for Version 8.x, page 1-2

 • Accessing Cisco Unity Connection Serviceability in Version 8.x, page 1-3

 • Using the Cisco Unity Connection Serviceability Interface in Version 8.x, page 1-4

Understanding Cisco Unity Connection Serviceability in Version 
8.x

Cisco Unity Connection Serviceability, a web-based troubleshooting tool for Cisco Unity Connection, 
provides the following functionality:

 • Displaying Connection alarm definitions, which you can use for troubleshooting.

 • Enabling Connection traces. You can collect and view trace information in the Real-Time 
Monitoring Tool (RTMT).

 • Configuring the logs to which Connection trace information will be saved.

 • Managing a cluster and the servers, if a Connection cluster is configured.

Note The Connection cluster feature is not supported for use with Cisco Unified Communications 
Manager Business Edition.

 • Viewing the status of the Connection feature services.

 • Activating, deactivating, starting, and stopping the Connection services.

 • Generating reports that can be viewed in different file formats.

Depending on the service and component involved, you may perform serviceability-related tasks in both 
Cisco Unity Connection Serviceability and Cisco Unified Serviceability. For example, you may need to 
start and stop services, view alarms, and configure traces in both applications to troubleshoot a problem.
1-1
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Chapter 1      Introduction to Cisco Unity Connection Serviceability in Version 8.x
Configuring Browsers on Administrator Workstations for Version 8.x
Cisco Unity Connection Serviceability supports the functionality that is described in the Administration 
Guide for Cisco Unity Connection Serviceability. For information on using Cisco Unified Serviceability, 
see the Cisco Unified Serviceability Administration Guide.

Configuring Browsers on Administrator Workstations for 
Version 8.x

To access Cisco Unity Connection Serviceability, Cisco Unity Connection Administration, Cisco 
Unified Serviceability, Disaster Recovery System, and other web applications on the Connection or 
Cisco Unified CMBE server, the browser(s) must be set up correctly on an administrator workstation.

See the applicable section, depending on the browser(s) installed on the computer:

 • Firefox, page 1-2

 • Microsoft Internet Explorer, page 1-2

Firefox
Do the following tasks to set up Firefox for accessing the Connection web applications.

1. Confirm that the software required for correct browser configuration is installed. See the “Software 
Requirements—Administrator Workstations” section of the applicable requirements document:

 • System Requirements for Cisco Unity Connection Release 8.x at 
http://www.cisco.com/en/US/docs/voice_ip_comm/connection/8x/requirements/8xcucsysreqs.
html.

 • System Requirements for Cisco Unity Connection in Cisco Unified CMBE Release 8.x at 
http://www.cisco.com/en/US/docs/voice_ip_comm/connection/8x/requirements/8xcucmbesysr
eqs.html.

2. Configure Firefox:

a. Enable Java.

b. Enable Java Script > Enable Change Images in Java Script Advanced.

c. Allow sites to set cookies. (For security purposes, we recommend that you set this to Allow 
Sites to Set Cookies for the Originating Website Only.)

Microsoft Internet Explorer
Do the following tasks to set up Internet Explorer for accessing the Connection web applications.

1. Confirm that the software required for correct browser configuration is installed. See the “Software 
Requirements—Administrator Workstations” section of the applicable requirements document:

 • System Requirements for Cisco Unity Connection Release 8.x at 
http://www.cisco.com/en/US/docs/voice_ip_comm/connection/8x/requirements/8xcucsysreqs.
html.

 • System Requirements for Cisco Unity Connection in Cisco Unified CMBE Release 8.x at 
http://www.cisco.com/en/US/docs/voice_ip_comm/connection/8x/requirements/8xcucmbesysr
eqs.html.
1-2
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Chapter 1      Introduction to Cisco Unity Connection Serviceability in Version 8.x
Accessing Cisco Unity Connection Serviceability in Version 8.x
2. Configure Internet Explorer:

a. Enable Active scripting.

b. Download and run ActiveX controls.

c. Enable Java scripting.

d. Accept all cookies.

e. Automatically check for newer versions of temporary Internet files.

f. Enable Medium-High privacy.

g. If you are running Microsoft Windows Server 2003 and using Internet Explorer version 6.0 to 
access the Cisco Personal Communications Assistant, add the Connection server to the Trusted 
Sites list by doing the following procedure, “To Add the Connection or Cisco Unified CMBE 
Server to the List of Trusted Sites (Windows Server 2003 with Internet Explorer 6.0 Only).”

To Add the Connection or Cisco Unified CMBE Server to the List of Trusted Sites (Windows Server 2003 with 
Internet Explorer 6.0 Only)

Step 1 Open the Cisco Personal Communications Assistant Sign-In page. It is not necessary to sign in to the 
Cisco PCA.

Step 2 On the Internet Explorer File menu, select Add This Site To > Trusted Sites Zone.

Step 3 In the Trusted Sites dialog box, select Add.

Step 4 Select Close to close the Trusted Sites dialog box.

Step 5 Restart Internet Explorer.

Accessing Cisco Unity Connection Serviceability in Version 8.x
The first time that you sign in to Cisco Unity Connection Serviceability, you use the username and 
password for the default administrator account that the installer specified for the account during 
installation. Later, you can use the username and password for any additional administrator accounts that 
you create.

To Access Cisco Unity Connection Serviceability in Version 8.x

Step 1 By using a supported web browser, open a browser session.

Step 2 Go to https://<Cisco Unity Connection server IP address>/cuservice.

Step 3 Enter an applicable username and password, and select Login.

After you have logged on to Cisco Unity Connection Serviceability, you can access all applications that 
appear in the Navigation drop-down box except for Cisco Unified Operating System Administration and 
Disaster Recovery System without having to sign in to each application. 
1-3
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Chapter 1      Introduction to Cisco Unity Connection Serviceability in Version 8.x
Using the Cisco Unity Connection Serviceability Interface in Version 8.x
You cannot access Cisco Unified Operating System Administration or Disaster Recovery System by 
using the Cisco Unity Connection Serviceability username and password. To access these applications 
from Cisco Unity Connection Serviceability, you must select the Logout link in the upper-right corner 
of Cisco Unity Connection Serviceability, then select the application from the Navigation drop-down 
box and select Go.

If you have already logged on to one of the applications that display in the Navigation drop-down box 
(not Cisco Unified Operating System Administration or Disaster Recovery System), you can access 
Cisco Unity Connection Serviceability without logging in. From the Navigation drop-down box, select 
Cisco Unity Connection Serviceability and select Go.

Using the Cisco Unity Connection Serviceability Interface in 
Version 8.x

In addition to troubleshooting, generating reports, and doing service-related tasks in Cisco Unity 
Connection Serviceability, you can do the following tasks:

 • To display documentation for a single window, select Help > This Page.

 • To display a list of documents that are available with this release of Connection or Cisco 
Unified CMBE (or to access the Help index), select Help > Contents.

 • To verify the version of Cisco Unity Connection Serviceability running on the server, select Help > 
About or select the About link in the upper-right corner of the window.

 • To go directly to the home page in Cisco Unity Connection Serviceability from a configuration 
window, select Cisco Unity Connection Serviceability from the Navigation drop-down box.

 • To access Cisco Unity Connection Administration or other applications, select the applicable 
application from the Navigation drop-down box and select Go.

 • To sign out of Cisco Unity Connection Serviceability, select the Logout link in the upper-right 
corner of the window.

 • On each Cisco Unity Connection Serviceability configuration page, configuration icons appear that 
correspond to the configuration buttons at the bottom of the page. (For example, you can select 
either the Save icon or the Save button to complete the task.)
1-4
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C H A P T E R 2

Using Alarms in Version 8.x

This chapter provides information on using alarms in Cisco Unity Connection Serviceability and 
contains the following sections:

 • Understanding Alarms in Version 8.x, page 2-1

 • Alarm Definitions in Version 8.x, page 2-1

 • Viewing Alarm Definitions in Version 8.x, page 2-2

 • Alarm Configurations in Version 8.x, page 2-2

Understanding Alarms in Version 8.x
Cisco Unity Connection Serviceability alarms provide information on runtime status and the state of the 
system, so you can troubleshoot problems that are associated with the system. For example, you can use 
alarms to determine whether there are any ports enabled to set MWIs. Alarm information includes the 
catalog, name, severity, explanation, recommended action, routing list, and parameters.

You can enable or disable alarms to appear as syslog messages on the local server or on a remote server 
that you specify. You can also set the severity level that you want to appear.

You use the trace and log central option in the Real-Time Monitoring Tool (RTMT) to collect alarms. 
You use the SysLog Viewer in RTMT to view alarms.

Alarm Definitions in Version 8.x
Alarm definitions describe alarm messages—what they mean and how to recover from them.

You search the Alarm Message Definitions page for alarm information. When you select an alarm, a 
description of the alarm information and a recommended action appears on the Alarm Information page. 
To help with troubleshooting, the definitions include the alarm name, description, severity, explanation, 
recommended action, routing list, and parameters.
2-1
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Viewing Alarm Definitions in Version 8.x
Viewing Alarm Definitions in Version 8.x
You can search for and view alarm definitions in Alarm Message Definitions for Cisco Unity Connection 
Release 8.0 at 
http://www.cisco.com/en/US/docs/voice_ip_comm/connection/8x/alarm_messages/80cucalrmmsgdefs.
html.

Alarm Configurations in Version 8.x
This section describes how to enable and disable alarms. Do the applicable procedure.

To Enable Alarms in Version 8.x

Step 1 In Cisco Unity Connection Serviceability, select Alarm > Configurations.

Step 2 In the Alarm Configurations window, do the applicable action:

 • To enable the system to log the alarms in the application logs area in the SysLog Viewer, under Local 
Syslogs, check the Enable Alarm check box.

 • To enable the system to store the alarms on a remote syslog server, under Remote Syslogs, check 
the Enable Alarm check box and, in the Server Name field, enter the IP address or host name of the 
remote syslog server.

Step 3 Under the syslog for which you have enabled alarms, in the Alarm Event Level field, select the severity 
level that you want.

Step 4 Select Save.

To Disable Alarms in Version 8.x

Step 1 In Cisco Unity Connection Serviceability, select Alarm > Configurations.

Step 2 In the Alarm Configurations window, uncheck the applicable Enable Alarm check box.

Step 3 Select Save.
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C H A P T E R 3

Using Traces in Version 8.x

This chapter provides information on using traces in Cisco Unity Connection Serviceability and contains 
the following sections:

 • Understanding Traces in Version 8.x, page 3-1

 • Configuring Trace Log Files in Version 8.x, page 3-2

 • Enabling Micro Traces in Version 8.x, page 3-2

 • Available Micro Traces in Version 8.x, page 3-3

 • Enabling Macro Traces in Version 8.x, page 3-9

 • Available Macro Traces in Version 8.x, page 3-10

Understanding Traces in Version 8.x
Cisco Unity Connection Serviceability traces help troubleshoot problems in the following ways:

 • You can specify the log file parameters for each Connection component, including the maximum 
number of log files and the maximum file size that can be created when you run traces for a 
component.

 • You can enable micro traces and the level of micro-trace information that you want.

 • You can enable macro traces (preselected groups of micro traces) and the level of macro-trace 
information that you want.

After you have configured the log files and enabled the traces, you collect trace log files in one of the 
following ways:

 • By using the trace and log central option in the Real-Time Monitoring Tool (RTMT). For 
information, see the “Working with Trace and Log Central” chapter (in the “Tools for Traces, Logs, 
and Plug-Ins” part) of the Cisco Unified Real-Time Monitoring Tool Administration Guide at 
http://www.cisco.com/en/US/products/ps6509/prod_maintenance_guides_list.html.

 • By using the command line interface (CLI). For information, see the Command Line Interface 
Reference Guide for Cisco Unified Communications Solutions at 
http://www.cisco.com/en/US/products/ps6509/prod_maintenance_guides_list.html.

Note Enabling macro or micro traces decreases system performance. Enable traces only for troubleshooting 
purposes.
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Configuring Trace Log Files in Version 8.x
Configuring Trace Log Files in Version 8.x
Revised September 10, 2012
Do the procedure in this section to configure trace log files for Cisco Unity Connection services.

Note Before trace information can be written to the log files, you must enable micro traces or macro traces 
that will provide the troubleshooting information in the areas that you select.

To Configure Trace Log Files in Version 8.x

Step 1 In Cisco Unity Connection Serviceability, select Trace > Configuration.

The Trace Configuration page appears.

Step 2 In the Server drop-down box, select the applicable Connection or Cisco Unified CMBE server, and select 
Go.

Step 3 From the Component drop-down box, select the component for which you want to configure trace log 
files, and select Go.

Note The drop-down box displays all components (active and inactive).

Step 4 In the Maximum No. of Files field, enter the maximum number of trace log files that will be created for 
this component.

Step 5 In the Maximum File Size field, enter the size limit (in megabytes) for the trace log files that will be 
created for this component.

Step 6 If you want to return to the default settlings, select Set Default. Otherwise, skip to the next step.

Step 7 Select Save.

Step 8 If you want the new trace log files to replace the old trace log files for this component, select Restart 
Log Files.

Note While changing the Maximum File Size  and the Maximum No.of files options for the Connection 
Conversation Manager component, you must restart Connection Conversation Manager service for the 
changes to take effect

Enabling Micro Traces in Version 8.x
Enable micro traces when you are troubleshooting problems with specific Cisco Unity Connection 
components. For example, if the Alert Central tool in Real-Time Monitoring Tool (RTMT) has 
notification errors, enable the Notifier trace. However, keep in mind that running traces can affect system 
performance and hard-disk space.

Note Enabling micro traces decreases system performance. Enable traces only for troubleshooting purposes.
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Available Micro Traces in Version 8.x
To Enable Micro Traces in Version 8.x

Step 1 In Cisco Unity Connection Serviceability, select Trace > Micro Traces.

The Micro Traces page appears.

Step 2 In the Server drop-down box, select the applicable Connection or Cisco Unified CMBE server, and select 
Go.

Step 3 From the Micro Trace drop-down box, select the micro trace that you want to enable, and select Go.

Step 4 Under Micro-Trace Levels, check the check boxes for the micro-trace levels that you want to enable.

Step 5 Select Save.

Tip You may need to enable traces in Cisco Unity Connection Serviceability and Cisco Unified 
Serviceability to troubleshoot Connection issues. To troubleshoot Connection components, enable traces 
in Cisco Unity Connection Serviceability. Similarly, to troubleshoot services that are supported in Cisco 
Unified Serviceability, enable traces in Cisco Unified Serviceability. For information on how to enable 
traces in Cisco Unified Serviceability, see the Cisco Unified Serviceability Administration Guide at 
http://www.cisco.com/en/US/products/ps6509/prod_maintenance_guides_list.html.

Available Micro Traces in Version 8.x
Revised November 16, 2010
Table 3-1 lists each micro trace that is available, a description of what it analyzes, and the filename of 
the trace log that it generates.

Table 3-1 Micro Traces in Version 8.x 

Micro Trace Name What the Trace Analyzes Filename of Trace Log

Arbiter Conversations, ports, and call 
routing rules that are used for calls

diag_CuCsMgr_*.uc

AudioStore The audio recording service used by 
web-based applications that use 
Media Master to playback or record 
audio streams

diag_Tomcat_*.uc

AxlAccess Interaction with the AXL server to 
get and set phone-related properties

diag_Tomcat_*.uc

BulkAdministrationTool Bulk Administration Tool that is 
used for creating, updating, and 
deleting multiple users or system 
contacts

diag_Tomcat_*.uc

CCL The retrieval of meeting information 
for the calendaring feature

diag_CuCsMgr_*.uc 
diag_CuGalSvc_*.uc 
diag_Tomcat_*.uc

CDE Conversation engine and 
conversation events

diag_CuCsMgr_*.uc
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Available Micro Traces in Version 8.x
CDL Information retrieval from the 
database

diag_CuCsMgr_*.uc 
diag_Tomcat_*.uc

CiscoPCA The Cisco Personal 
Communications Assistant 
(Cisco PCA)

diag_Tomcat_*.uc

CML The retrieval of messages from the 
Cisco Unity Connection message 
store; the retrieval of messages from 
an Exchange server (by using 
IMAP) for using Text-to-Speech 
feature to read email messages

diag_CuCsMgr_*.uc 
diag_CuNotifier_*.uc 
diag_Tomcat_*.uc

Common Low-level activities for components 
that are shared by Cisco Unity 
Connection services

<any>

ConfigData Detection that configuration data 
has been updated in the database

<any>

ConvRoutingRules The conversation to which the 
Arbiter routes calls

diag_CuCsMgr_*.uc

ConvSub User activities and usage diag_CuCsMgr_*.uc

CsEws

(Connection 8.5 and 
later)

Exchange Web Services calls from 
Connection to Exchange for single 
inbox, calendaring, and 
text-to-speech

diag_CuCsMgr_*.uc 
diag_CuMbxSync_*.uc

CsExchangeMbxLocator

(Connection 8.5 and 
later)

Autodiscovery of Exchange 
mailboxes for single inbox, 
calendaring, and text-to-speech

diag_CuCsMgr_*.uc 
diag_CuMbxSync_*.uc

CsLicense Functions related to license 
processing

diag_CuLicSvr_*.uc

CsMalUmss Access to the message store by the 
CML, Notifier, and IMAP server

diag_CuCsMgr_*.uc 
diag_Tomcat_*.uc

CsMbxSync

(Connection 8.5 and 
later)

Single inbox synchronization diag_CuMbxSync_*.uc

CsWebDav Calendar activities in connection 
with Exchange

diag_CuCsMgr_*.uc 
diag_CuGalSvc_*.uc 
diag_Tomcat_*.uc

Cuals The activities of the web services to 
add users

diag_Tomcat_*.uc

Cuca The activities of Cisco Unity 
Connection Administration

diag_Tomcat_*.uc

CuCcmSynchronization
Tasks

Synchronization of the user data 
from Cisco Unified CM

diag_Tomcat_*.uc

Table 3-1 Micro Traces in Version 8.x (continued)

Micro Trace Name What the Trace Analyzes Filename of Trace Log
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CuCmDbEventListener Detection of changes in the Cisco 
Unified CM database

diag_CuCmDbEventListener_*.uc

CuCsMgr Main Cisco Unity Connection 
process; starting and stopping 
Connection

diag_CuCsMgr_*.uc

CuDbProxy Database replication for 
Cisco Unity Connection clusters

diag_CuDbProxy_*.uc

CuEncrypt Encryption (except for messaging) 
and the encryption audit logs

<any>

CuESD The activities of Cisco Unity 
Connection external service 
diagnostic tools

diag_Tomcat_*.uc

CuFileSync File replication for Cisco Unity 
Connection clusters

diag_CuFileSync_*.uc

CuGal The retrieval of calendar and contact 
information from Exchange

diag_CuGalSvc_*.uc

CuImapSvr Access to voice messages by IMAP 
clients

diag_CuImapSvr_*.uc

CuReplicator Replication for digital networking

Note We recommend that the 
Debug Traces and Debug 
Statistics micro-trace levels 
be enabled for no more than 
one hour because they can 
produce a large number of 
log entries.

diag_CuReplicator_*.uc

CuService The activities of Cisco Unity 
Connection Serviceability

diag_Tomcat_*.uc

CuSnmpAgt The activities of the Cisco Unity 
Connection SNMP subagent

diag_CuSnmpAgt_*.uc

DataSysAgentTasks Data SysAgent tasks diag_CuSysAgent_*.uc

DbEvent Component notification of database 
changes

<any>

DPAPI The activities of the diagnostic 
portal application programming 
interface web service

diag_Tomcat_*.uc

EWSNotify

(Connection 8.5 and 
later) 

Exchange EWS mailbox 
synchronization notifications

<date in the format 
yyyy_mm_dd>.stderrout.log.*

FailureConv Activation of the Failure 
Conversation when a system error 
occurs

diag_CuCsMgr_*.uc

Table 3-1 Micro Traces in Version 8.x (continued)

Micro Trace Name What the Trace Analyzes Filename of Trace Log
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Feeder For Intersite Networking, checks the 
local site change-tracking database 
for directory changes and responds 
to poll requests from the remote site 
gateway Reader task

diag_Tomcat_*.uc

FeedReader For Intersite Networking, 
periodically polls the remote site 
gateway for any directory changes 
since the last poll interval

diag_Tomcat_*.uc

LicenseClient Functions related to license 
management

diag_CuCsMgr_*.uc

Logger Writing traces logs and events <any>

MediaMasterControl The Media Master on the client 
workstation

diag_Tomcat_*.uc

MediaMasterUMS The UMS service, which handles 
streams audio recordings between 
the Media Master and the 
AudioStore

diag_Tomcat_*.uc

MediaMasterWeb The web page rendering module that 
is used in web-based applications 
that have the Media Master

diag_Tomcat_*.uc

MessageEventService Detection of arrival or deletion of 
messages

diag_Tomcat_*.uc

MiuAdm Functions in Cisco Unity 
Connection Administration relating 
to testing voice messaging ports and 
generating certificates

diag_Tomcat_*.uc

MiuCall The process between the Miu and 
conversations

diag_CuCsMgr_*.uc

MiuDatatbase Media activities relating to 
accessing the database

diag_CuCsMgr_*.uc

MiuGeneral Tracking calls through the phone 
user interface (TUI); call control 
functions; turning message waiting 
indicators (MWIs) on and off; 
notification and outdial functions; 
basic media or WAV file usage

diag_CuCsMgr_*.uc

MiuIO Media or WAV file usage with TAPI 
(circuit-switched or Cisco Unified 
CallManager) integrations

diag_CuCsMgr_*.uc

MiuMethods Handing of incoming calls; call 
control; turning messaging waiting 
indicators (MWIs) on and off; 
notification and outdial functions; 
media or WAV file usage

diag_CuCsMgr_*.uc

Table 3-1 Micro Traces in Version 8.x (continued)

Micro Trace Name What the Trace Analyzes Filename of Trace Log
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MiuSIP SIP call control diag_CuCsMgr_*.uc

MiuSIPStack Low-level SIP interactions for call 
control

diag_CuCsMgr_*.uc

MiuSkinny SCCP call control diag_CuCsMgr_*.uc

MiuTranscode Low-level media functions relating 
to transcoding

diag_CuCsMgr_*.uc

Mixer Low-level activities relating to 
media and the Text-to-Speech 
feature

diag_CuMixer_*.uc

Monitor Monitoring the status of voice 
messaging ports and call processing 
during a call; the server-side 
functions for displaying port status 
in Real-Time Monitoring Tool

diag_CuCsMgr_*.uc

MTA Delivery of voice messages to the 
message store

diag_MTA_*.uc

Notifier Notification of messages and 
selected events; turning message 
waiting indicators (MWIs) on and 
off

diag_CuCsMgr_*.uc 
diag_CuNotifier_*.uc

PCAMeetingPlace Activities of the Cisco Personal 
Communications Assistant relating 
to MeetingPlace for the calendar 
feature

diag_Tomcat_*.u

PCAUnifiedCM Activities of the Cisco Personal 
Communications Assistant relating 
to the Cisco Unified 
Communications Manager 
integration

diag_Tomcat_*.uc

PhoneManager The management of IP phone 
applications

diag_CuCsMgr_*.uc

PhraseServer The prompts that play and the user 
DTMF input; the logs are written to 
a file

diag_CuCsMgr_*.uc

PhraseServerToMonitor The prompts that play and the user 
DTMF input; the logs are written to 
the monitor

diag_CuCsMgr_*.uc

ReportDataHarvester Conversion of the content in the data 
log files to entries in the reports 
database

diag_CuReportDataHarvester_*.uc

ResourceLoader Using the selected language in the 
GUI; filling strings with product or 
message information

<any>

Table 3-1 Micro Traces in Version 8.x (continued)

Micro Trace Name What the Trace Analyzes Filename of Trace Log
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ResourceManager Monitoring and providing available 
resources to the Arbiter as needed

diag_CuCsMgr_*.uc

RoutingRules Call routing decisions diag_CuCsMgr_*.uc

RSS RSS feeds that are used for checking 
voicemail from an RSS client

diag_Tomcat_*.uc

RulesEngine Evaluation of personal call transfer 
rules for a user during a call

diag_CuCsMgr_*.uc 
diag_Tomcat_*.uc

SMTP SMTP functions diag_SMTP_*.uc

SocketPoolHelper Socket connections to the IMAP 
server

<any>

SRM Functions related to cluster 
management

diag_CuSrm_*.uc

SslInit Initialization procedures for 
components that use OpenSSL

<any>

SttClient Detects messages that need to be 
transcribed; attaches completed 
transcriptions to original messages

diag_MTA_*.uc

SttService Communication between 
Cisco Unity Connection and the 
third-party external transcription 
service

diag_SttService_*.uc

SysAgent System Agent component, which 
schedules system tasks that the 
administrator enters (such as 
resynchronizing MWIs)

diag_CuSysAgent_*.uc

TaskRequest Functions related to the Task 
Management tool

diag_CuSysAgent_*.uc

TextToSpeech The activities of the Text to Speech 
feature

diag_CuCsMgr_*.uc

ThreadPool The use of threads by the processor <any>

TimerHelper The timer used by the Conversation 
Manager component

<any>

TranscodeWeb The web server audio format 
transcoding utilities that transcode 
the incoming audio streams into the 
audio format that Cisco Unity 
Connection uses

diag_Tomcat_*.uc

TRaP Phone Record and Playback 
(TRaP), which lets clients use the 
phone as a recording and playback 
device

diag_CuCsMgr_*.uc 
diag_Tomcat_*.uc

UmssSysAgentTasks Messaging tasks for the System 
Agent component

diag_CuSysAgent_*.uc

Table 3-1 Micro Traces in Version 8.x (continued)

Micro Trace Name What the Trace Analyzes Filename of Trace Log
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Enabling Macro Traces in Version 8.x
Enable macro traces, which are preselected sets of micro traces, when you are troubleshooting general 
areas of Connection functionality. For example, if there are MWI problems, enable the Traces for MWI 
Problems macro trace. However, keep in mind that running traces can affect system performance and 
hard-disk space.

Caution Enabling macro traces decreases system performance. Enable traces only for troubleshooting purposes.

To Enable Macro Traces

Step 1 In Cisco Unity Connection Serviceability, select Trace > Macro Traces.

The Macro Traces page appears.

Step 2 In the Server drop-down box, select the applicable Connection or Cisco Unified CMBE server, and select 
Go.

Step 3 Check the check box of the macro trace that you want to enable.

Step 4 Expand the macro trace, and check the check boxes for the levels that you want to enable.

Step 5 Select Save.

UnityAssistant The activities of the Messaging 
Assistant web tool in the 
Cisco Personal Communications 
Assistant

diag_Tomcat_*.uc

UnityInbox The activities of the Messaging 
Inbox web tool in the 
Cisco Personal Communications 
Assistant

diag_Tomcat_*.uc

UnityPCTR The activities of the Cisco Unity 
Connection Personal Call Transfer 
Rules web tool in the 
Cisco Personal Communications 
Assistant

diag_CuCsMgr_*.uc

VirtualQueue Call queuing diag_CuCsMgr_*.uc

VMREST Interactions with Representational 
State Transfer (REST) API clients

diag_Tomcat_*.uc

VMWS Interactions with voice messaging 
web services

diag_Tomcat_*.uc

VUI The voice user interface diag_CuCsMgr_*.uc

Table 3-1 Micro Traces in Version 8.x (continued)

Micro Trace Name What the Trace Analyzes Filename of Trace Log
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Tip You may need to enable traces in Cisco Unity Connection Serviceability and Cisco Unified 
Serviceability to troubleshoot Connection issues. To troubleshoot Connection components, enable traces 
in Cisco Unity Connection Serviceability. Similarly, to troubleshoot services that are supported in Cisco 
Unified Serviceability, enable traces in Cisco Unified Serviceability. For information on how to enable 
traces in Cisco Unified Serviceability, see the Cisco Unified Serviceability Administration Guide at 
http://www.cisco.com/en/US/products/ps6509/prod_maintenance_guides_list.html.

Available Macro Traces in Version 8.x
Revised November 16, 2010
Table 3-2 lists each macro trace that is available, a description of what it analyzes, and the filename of 
the trace log that it generates.

Table 3-2 Macro Traces in Version 8.x 

Macro Trace Name What the Trace Analyzes Filename of Trace Log

Call Flow Diagnostics The flow of a call through Cisco Unity 
Connection

diag_CuCsMgr_*.uc

Message Tracking 
Traces

Message handing; the objects that handle 
messages from delivery to deletion

diag_CuSysAgent_*.uc 
diag_MTA_*.uc 
diag_CuCsMgr_*.uc 
diag_CuImapSvr_*.uc 
diag_Tomcat_*.uc

Call Control (Miu) 
Traces

Call control functions diag_CuCsMgr_*.uc

Traces for MWI 
Problems

Turning message waiting indicators (MWIs) 
on and off

diag_CuCsMgr_*.uc 
diag_CuNotifier_*.uc

Traces for Other 
Notification Problems

Notification and outdial functions diag_CuCsMgr_*.uc 
diag_CuNotifier_*.uc

Unity Startup Cisco Unity Connection startup functions diag_CuCsMgr_*.uc 
diag_CuNotifier_*.uc

Conversation Traces Conversation usage diag_CuCsMgr_*.uc

Voice User 
Interface/Speech 
Recognition Traces

Voice user interface (VUI) diag_CuCsMgr_*.uc

Media (Wave) Traces Media and WAV file usage diag_CuCsMgr_*.uc 
diag_CuMixer_*.uc

Text to Speech (TTS) 
Traces

The Text to Speech (TTS) feature; also can log 
traces on other Cisco Unity Connection 
components that interact with TTS

diag_CuCsMgr_*.uc

Connection 
Serviceability Web 
Service

The activity of Cisco Unified Serviceability diag_Tomcat_*.uc
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ViewMail for Outlook The activity of Cisco Unity Connection 
ViewMail for Microsoft Outlook clients

diag_CuCsMgr_*.uc 
diag_CuImapSvr_*.uc 
diag_MTA_*.uc 
diag_Tomcat_*.uc

Digital Networking Digital networking functions diag_CuReplicator_*.uc

Single Inbox Single inbox message synchronization <date in the format 
yyyy_mm_dd>.stderrout. 
log.* 
diag_CuMbxSync_*.uc

Table 3-2 Macro Traces in Version 8.x (continued)

Macro Trace Name What the Trace Analyzes Filename of Trace Log
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Managing Server Status and Ports in a 
Cisco Unity Connection 8.x Cluster

The Cluster Management page in Cisco Unity Connection Serviceability lets you change the status of 
servers in a Connection cluster, stop all ports on a server from taking new calls, and restart all ports on 
a server to take calls.

For the applicable procedures, see the “Administering a Cisco Unity Connection 8.x Cluster” chapter of 
the Cluster Configuration and Administration Guide for Cisco Unity Connection Release 8.x at 
http://www.cisco.com/en/US/docs/voice_ip_comm/connection/8x/cluster_administration/guide/8xcucc
agx.html.

Note The Connection cluster feature is not supported for use with Cisco Unified Communications Manager 
Business Edition.
4-1
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Managing Cisco Unity Connection 8.x Services

This chapter provides information on managing services in Cisco Unity Connection Serviceability and 
contains the following sections:

 • Cisco Unity Connection Services in Version 8.x, page 5-1

 • Managing Services in Control Center in Version 8.x, page 5-4

Cisco Unity Connection Services in Version 8.x
Revised March 10, 2011
Cisco Unity Connection has the services described in Table 5-1.

Table 5-1 Cisco Unity Connection Services in Version 8.x 

Service Description

Status Only Services

Connection DB This service enables the Connection database and can be 
deactivated only by using the command-line interface (CLI).

Connection Server Role Manager This service enables the server status when a Connection 
cluster is configured and can be deactivated only by using 
the command-line interface (CLI).

Connection Serviceability This service enables the Cisco Unity Connection 
Serviceability Administration interface and can be 
deactivated only by using the command-line interface (CLI).

Critical Services

Connection Conversation Manager This service enables Connection to handle calls. Disabling 
this service will degrade the ability of Connection to 
function.

Connection Mailbox Sync

(Connection 8.5 and later)

This service synchronizes messages between Connection 
and Exchange.

Connection Message Transfer Agent This service enables the delivery of messages to the message 
store. Disabling this service will degrade the ability of 
Connection to function.
5-1
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Connection Mixer This service enables the audio (media stream) for calls, 
recorded messages, and Text to Speech (TTS). Disabling 
this service will degrade the ability of Connection to 
function.

Connection Notifier This service enables notification of messages, such as 
turning message waiting indicators (MWIs) on and off. 
Disabling this service will degrade the ability of Connection 
to function.

Base Services

Connection Administration This service enables Cisco Unity Connection 
Administration and the settings that are saved in the 
interface.

Connection DB Event Publisher This service enables notifying Connection components of 
changes to the Connection database.

Connection Exchange Notification Web 
Service

(Connection 8.5 and later)

This service allows single inbox to receive message change 
notifications from Exchange Web Services-based external 
services. 

Connection License Server This service enables the Connection licensing by reading the 
installed license files, tracking the number of seats that are 
in use, and enabling licensed features.

Connection SNMP Agent This service enables the Simple Network Management 
Protocol (SNMP), which uses the Cisco-Unity-MIB.

Optional Services

Connection Access Layer This service enables the sharing of user data between 
Connection and other servers by using Cisco Unity Access 
Layer (CUAL), a HTTP/SOAP web service. For example, 
this service can be used by Cisco Unified Communications 
Manager Business Edition (CMBE) or by Digital 
Networking with Cisco Unity.

Connection CM Database Event 
Listener

This service enables the detection of changes in the Cisco 
Unified Communications Manager database.

Connection Database Proxy This service allows tools that are not installed on the 
Connection server (COBRAS, User Data Dump, 
Distribution List Builder, and so on) to gain direct access to 
the Connection database via ODBC from a Windows client 
on the network.

The service is off by default. To use any of these tools, you 
must enable the service, configure the time out for the 
service, and create a user that has the remote admin role. For 
more information, see the help file for the applicable tool.

Connection Diagnostic Portal Service This service enables access to data on Connection by the 
Diagnostic Portal in the Real-Time Monitoring Tool 
(RTMT).

Table 5-1 Cisco Unity Connection Services in Version 8.x (continued)

Service Description
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Connection Digital Networking 
Replication Agent

This service enables the replication of data between 
Connection servers for Digital Networking.

Connection Directory Feeder For Intersite Networking, this service checks the local site 
change-tracking database for directory changes and 
responds to poll requests from the remote site gateway 
Reader task.

Connection File Syncer This service enables the replication of files for Connection 
clusters.

Connection Groupware Caching Service This service enables Connection to cache calendar data 
(from Exchange, MeetingPlace, or MeetingPlace Express 
servers) and to cache Exchange contacts.

Connection IMAP Server This service enables access to data on Connection by IMAP 
clients.

Connection Inbox RSS Feed This service enables RSS feeds for checking voicemail from 
RSS clients.

Connection Integrated Mailbox 
Configuration

This service enables sharing of user data between 
Connection and Cisco Unified Communications Manager.

Connection Jetty This service enables Java web clients.

Connection Message Event Service This service enables access to voice message data on 
Connection by Cisco Unified Mobility Advantage.

Connection Personal Communication 
Assistant

This service enables access to data on Connection by the 
Cisco Personal Communications Assistant (Cisco PCA).

Connection Realtime Monitoring APIs This service enables access to data on Connection by 
Real-Time Monitoring Tool (RTMT).

Connection Reports Data Harvester This service enables conversion of data in log files to entries 
in the reports database, which is used to generate reports.

Connection REST Service This service enables Representational State Transfer 
(REST) API clients.

Connection SMTP Server This service enables access to data on Connection by an 
SMTP server.

Connection SpeechView This service enables the SpeechView feature and 
communicates with the third-party external transcription 
service.

Connection System Agent This service enables schedules system tasks (such as 
resynchronizing MWIs) that the administrator can enter in 
Cisco Unity Connection Administration.

Connection Voicemail Web Service This service enables access to data on Connection through 
Voicemail Web Service (VMWS) by Cisco Unified 
Communications Widgets such as Visual Voicemail.

Table 5-1 Cisco Unity Connection Services in Version 8.x (continued)

Service Description
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Managing Services in Control Center in Version 8.x
Control Center in Cisco Unity Connection Serviceability lets you do the following tasks:

 • Activate and deactivate Connection services in the Optional Services section.

 • Start and stop all Connection services except the services in the Status Only Services section.

Stopping Connection services in the Critical Services section may cause calls in progress to be 
dropped and degrades the normal function of the Connection or Cisco Unified CMBE server.

When a Cisco Unity Connection cluster is configured, stopping a service in the Critical Services 
section for the server with Primary status causes the status for the servers in the cluster to change.

 • View the status the status of Connection services.

 • Refresh the status of Connection services.

Tip You may need to manage services in both Cisco Unity Connection Serviceability and Cisco Unified 
Serviceability to troubleshoot a problem. 
 
The Cisco Unified Serviceability services are described in the Cisco Unified Serviceability 
Administration Guide.

This section contains five procedures; do the applicable procedure to activate, deactivate, start, or stop 
Connection services, or to refresh the status of services. You can activate, deactivate, start, and stop only 
one service at a time.

To Activate a Service in Control Center in Version 8.x

Step 1 In Cisco Unity Connection Serviceability, select Tools > Service Management.

Step 2 From the Server drop-down box, select the applicable Connection or Cisco Unified CMBE server, and 
select Go.

Step 3 Under Optional Services, locate the service that you want to activate.

Step 4 In the Change Activate Status column, select Activate.

To Deactivate a Service in Control Center in Version 8.x

Step 1 In Cisco Unity Connection Serviceability, select Tools > Service Management.

Connection Voice Recognition 
Transport

This service enables generation and placement of dynamic 
grammars that are used by the speech-recognition engine for 
the voice user interface (VUI).

Connection Voice Recognizer This service is the speech-recognition engine that enables 
voice recognition for the voice user interface (VUI).

Table 5-1 Cisco Unity Connection Services in Version 8.x (continued)

Service Description
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Step 2 From the Server drop-down box, select the applicable Connection or Cisco Unified CMBE server, and 
select Go.

Step 3 Under Optional Services, locate the service that you want to deactivate.

Step 4 In the Change Activate Status column, select Deactivate.

To Start a Service in Control Center in Version 8.x

Step 1 In Cisco Unity Connection Serviceability, select Tools > Service Management.

Step 2 From the Server drop-down box, select the applicable Connection or Cisco Unified CMBE server, and 
select Go.

Step 3 Locate the service that you want to start.

Note Services that are deactivated must be activated before they can be started.

Step 4 In the Change Service Status column, select Start.

To Stop a Service in Control Center in Version 8.x

Step 1 In Cisco Unity Connection Serviceability, select Tools > Service Management.

Step 2 From the Server drop-down box, select the applicable Connection or Cisco Unified CMBE server, and 
select Go.

Step 3 Locate the service that you want to stop.

Note Services in the Status Only Services section cannot be started or stopped in Cisco Unity 
Connection Serviceability. You must use the command line interface (CLI) to start or stop these 
services. 
 
When a Connection cluster is configured, stopping a service in the Critical Services section for 
the server with Primary status will cause the status for the servers in the cluster to change. To 
prevent the status change when the service is stopped, in Cisco Unity Connection 
Administration, you must uncheck the Automatically Change Server Status When the Publisher 
Server Fails check box on the System Settings > Advanced > Cluster Configuration page.

Step 4 In the Change Service Status column, select Stop.

Note Stopping Connection services in the Critical Services section may cause calls in progress to be 
dropped and degrades the normal function of the Connection or Cisco Unified CMBE server. 
 
A service that is not activated cannot be started or stopped.

Step 5 If you are prompted that the cluster server status will change, select OK.
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To Refresh Service Status in Control Center in Version 8.x

Step 1 In Cisco Unity Connection Serviceability, select Tools > Service Management.

Step 2 From the Server drop-down box, select the applicable Connection or Cisco Unified CMBE server, and 
select Go.

Step 3 Select Refresh.

The status information is updated to reflect the current status.
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Using Reports in Version 8.x

This chapter provides information on using reports in Cisco Unity Connection Serviceability and 
contains the following sections:

 • Understanding Reports in Version 8.x, page 6-1

 • Setting Report Configuration Parameters in Version 8.x, page 6-5

 • Generating and Viewing Reports in Version 8.x, page 6-5

Understanding Reports in Version 8.x
Revised May 14, 2013

Cisco Unity Connection Serviceability lets you gather information about system configuration and call 
handlers into reports.

Table 6-1 describes the reports that you can generate in Cisco Unity Connection Serviceability.

Table 6-1 Reports Available in Cisco Unity Connection Serviceability in Version 8.x 

Report Name Description of Output

Phone Interface 
Failed Logon

Includes the following information for every failed attempt to sign in to 
Connection by phone:

 • Name of user, alias, caller ID, and extension of user who failed to sign 
in.

 • Date and time the failed logon occurred.

 • Whether the maximum number of failed sign-ins has been reached for 
the user.

Users Includes the following information for each user:

 • Last name, first name, and alias.

 • Information that identifies the Connection or Cisco Unified CMBE 
server associated with the user.

 • Billing ID, class of service, and extension.

 • Whether the account is locked.

 • Whether the user has enabled personal call transfer rules.
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Message Traffic Includes totals for the following traffic categories:

 • Voice.

 • Fax.

 • Email.

 • Non-delivery receipt (NDR).

 • Delivery receipt.

 • Read receipt.

 • Hourly totals.

 • Daily totals.

Port Activity Includes the following information for voice messaging ports:

 • Name.

 • Number of inbound calls handled.

 • Number of outbound MWI calls handled.

 • Number of outbound AMIS calls handled.

 • Number of outbound notification calls handled.

 • Number of outbound TRaP calls handled.

 • Total number of calls handled.

Mailbox Store Includes the following information about the specified mailbox stores:

 • Mail database name.

 • Display name.

 • Server name.

 • Whether access is enabled.

 • Mailbox store size.

 • Last error.

 • Status.

 • Whether the mail database can be deleted.

Dial Plan Includes a list of the search spaces configured on the Connection or Cisco 
Unified CMBE server, with an ordered list of partitions assigned to each 
search space.

If the server is part of a Digital Network, also lists the search spaces and 
associated partition membership on every other Connection location on the 
network.

Dial Search Scope Includes a list of all users and their extensions in the specified partition that 
is configured in the Connection directory. If a partition is not specified, lists 
all users and their extensions for all partitions that are configured in the 
directory.

Table 6-1 Reports Available in Cisco Unity Connection Serviceability in Version 8.x (continued)

Report Name Description of Output
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User Phone Login and 
MWI

Includes the following information about phone logins, MWI activity, and 
message notifications to phone devices per user:

 • Name, extension, and class of service.

 • Date and time for each activity.

 • The source of each activity.

 • Action completed (for example, Login, MWI On or Off, and Phone 
Dialout).

 • Dial out number and results (applicable only for message notifications 
to phone devices).

 • The number of new messages for a user at time of login.

User Message 
Activity

Includes the following information about messages sent and received, per 
user:

 • Name, extension, and class of service.

 • Date and time for each message.

 • Type of message.

 • Action completed (for example, new message, message saved, and so 
on).

 • Information on the message sender.

Distribution Lists Includes the following information:

 • Name and display name of the list.

 • Date and time the list was created. (Date and time are given in 
Greenwich Mean Time.)

 • A count of the number of users included in the list.

 • If the Include List Members check box is checked, a listing of the alias 
of each user who is a member of the list.

User Lockout Includes user alias, hack count (the number of failed logon attempts for the 
user), credential type (a result of “TUI PIN” indicates a logon attempt from 
the Connection conversation; a result of “GUI Password” indicates a logon 
attempt from a web application), and the date and time that the account was 
locked.

(Date and time are given in Greenwich Mean Time.)

Unused Voicemail 
Accounts

Includes user alias and display name, and the date and time that the user 
account was created.

(Date and time are given in Greenwich Mean Time.)

Table 6-1 Reports Available in Cisco Unity Connection Serviceability in Version 8.x (continued)

Report Name Description of Output
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Transfer Call Billing Includes the following information for each call:

 • Name, extension, and billing ID of the user.

 • Date and time that the call occurred.

 • The phone number dialed.

 • The result of the transfer (connected, ring-no-answer (RNA), busy, or 
unknown).

Outcall Billing 
Detail

Includes the following information, arranged by day and by the extension of 
the user who placed the call:

 • Name, extension, and billing ID.

 • Date and time the call was placed.

 • The phone number called.

 • The result of the call (connected, ring-no-answer (RNA), busy, or 
unknown).

 • The duration of the call in seconds.

Outcall Billing 
Summary

Arranged by date and according to the name, extension, and billing ID of 
the user who placed the call, and is a listing of the 24 hours of the day, with 
a dialout time in seconds specified for each hour span.

Call Handler  
Traffic

Includes the following information for each call handler, in rows for each 
hour of a day:

 • Total number of calls.

 • Number of times each key on the phone keypad was pressed.

 • Extension.

 • Invalid extension.

 • Number of times the after greeting action occurred.

 • Number of times the caller hung up.

System Configuration Includes detailed information about all aspects of the configuration of the 
Connection system.

SpeechView Activity 
Report By User

Includes the total number of transcribed messages, failed transcriptions, and 
truncated transcriptions for a given user during a given time period. If the 
report is run for all users, then the output is broken out by user.

SpeechView Activity 
Summary Report 

Includes the total number of transcribed messages, failed transcriptions, and 
truncated transcriptions for the entire system during a given time period. 
When messages are sent to multiple recipients, the message is transcribed 
only once, so the transcription activity is counted only once.

Table 6-1 Reports Available in Cisco Unity Connection Serviceability in Version 8.x (continued)

Report Name Description of Output
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Setting Report Configuration Parameters in Version 8.x
Cisco Unity Connection is automatically set to gather and store data from which you can generate 
reports. The parameters listed in this section can be adjusted, depending on the report output that you 
want to generate. All report parameter settings are found on the System Settings > Advanced > Reports 
page in Cisco Unity Connection Administration.

Reports data is gradually written over, depending on the parameters you set for retention of data. We 
recommend that if you want to keep reports for historical purposes, you develop a schedule for regularly 
generating reports, and save them in a location separate from the Connection or Cisco Unified CMBE 
server.

Milliseconds Between Data Collection Cycles—Set by default to 30 minutes (1,800,000 milliseconds). 
This setting controls the amount of time Connection waits between cycles of gathering report data.

Days to Keep Data in Reports Database—Set by default to 180 days. Note that even if you specify 
more than this number of days in the time range for the report you are generating, the number of days of 
data is limited by what you set here.

Maximum Records in Report Output—Set by default to 25,000 records. The maximum value allowed 
for this field is 30,000 records. If the report you want to generate exceeds the maximum number of 
records allowed, you can generate the report in pieces (for example by reducing the date range or number 
of user accounts included in each iteration).

Note The Maximum Records in Report Output setting for the User Message Activity Report has been 
restricted to 15,000 records—rather than the default of 25,000 records—because of the size of the report.

Minimum Records Needed to Display Progress Indicator—Set by default to 2,500 records. The 
maximum value allowed for this field is 10,000 records. The purpose of the progress indicator is to warn 
you if the report you request is large and likely to take a long time to complete. In Connection, reports 
are generated from within a browser, and the browser session must be kept open while the report is being 
generated. Depending on the size of the database, and the type of report being generated, a report can 
take a long time to generate; meanwhile, you will be unable to use the browser, and must keep the 
Connection Administration session open.

Generating and Viewing Reports in Version 8.x
When you generate a report, you can specify some or all of the following:

 • The objects (for example, user accounts or call handlers) to include in the report.

 • The date and time range to include.

 • The sort order for the data in the report.
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You can select one of the following file formats for the report:

The best time to generate reports is when the system is not busy: after regular business hours when 
Connection is not processing many calls, or when there are no other processes running (for example, 
before or after a full backup). Requests to generate reports are queued. If multiple reports are generated 
at one time (from separate browsers), the reports wait in line and only one is processed at a time.

Caution Generating large reports when the system is busy will use system resources and could potentially result 
in slower response time for system users.

Note that reports cannot be scheduled in advance. If you shut down the Connection or Cisco 
Unified CMBE server, or close the Connection Administration browser session while reports are being 
generated, the report generation will be canceled.

To Generate and View a Report in Version 8.x

Step 1 In Cisco Unity Connection Serviceability, select Tools > Reports.

Step 2 On the Serviceability Reports page, select the name of the report that you want to generate.

Step 3 Select the applicable file format for the report output.

Step 4 If the fields are available, set a date range by selecting the beginning and ending month, day, year, and 
time.

Step 5 Set other parameters, as applicable.

Step 6 Select Generate Report.

Step 7 View the report output, depending on the file format you chose in Step 3:

Web page HTML file. Report output appears in your web browser.

Select this format to quickly view a small report.

For archiving purposes, we recommend that you generate PDF reports.

Comma-delimited file Text file (also known as a comma-separated, or CSV, file). Report output 
appears as a string of data, separated by commas. 

Select this format if you want to view or print the information in another 
application, for example, a spreadsheet application.

PDF file Report output appears as a PDF that can be printed and saved. 

We recommend that you select this format if you plan to archive reports.

Web Page Output appears in your browser window.

Comma-delimited File File download dialog box opens, asking whether you want to open or save the 
file.

PDF File File download dialog box opens, asking whether you want to open or save the 
file.
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Using the Voice Network Map Tool in Version 8.x

This chapter provides information on using the Voice Network Map Tool in Cisco Unity Connection 
Serviceability and contains the following sections:

 • Understanding the Voice Network Map Tool in Version 8.x, page 7-1

 • Configuring Remote Access to Other Cisco Unity Connection Locations in a Connection Site in 
Version 8.x, page 7-2

 • Viewing Replication Status Information in the Voice Network Map Tool in Version 8.x, page 7-3

Understanding the Voice Network Map Tool in Version 8.x
The Voice Network Map tool provides a consolidated visual representation of the health of the locations 
in a Cisco Unity Connection site. (The tool also identifies any location in the site that acts as an intersite 
gateway, but does not display health information about other sites.)

With the tool, you can quickly locate replication problems in a site, and get information about the status 
of replication between any two locations in the site.

The tool includes a site display, a data display, and a key that explains the meaning of the icons that you 
may see in the site display.

The site display includes an icon for each location in the Connection site. The icon itself gives you an 
indicator of the health of the location (or, in some cases, indicates that the tool is unable to gather data 
from the location).

The data display shows information about the pair of locations that you select in the site display. This 
information includes whether one location is currently pulling or pushing directory information with the 
other, and information about the USN, or sequence numbers, of replication messages sent to and from a 
location. (When two locations are fully synchronized, the Last USN Sent and Last USN Acknowledged 
values for the location that is sending replication updates equal the Last USN Received value for the 
location that is receiving updates. During replication, it is normal for the Last USN Acknowledged value 
to lag behind the Last USN Sent value.) You can also find the push/pull state and USN information in 
Cisco Unity Connection Administration, but the Voice Network Map tool simplifies access to the 
information by providing it all in one visual display.

Use the key for more information about the icons in the site display. Move the pointer over an icon in 
the key to see the information about it. You can view additional icons by selecting the (More) link.
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Tip Right-click a location icon for options to access Cisco Unity Connection Serviceability or Cisco Unity 
Connection Administration for that location. If the location is a gateway to an intersite link, you can also 
view a map of the servers in the remote site.

Configuring Remote Access to Other Cisco Unity Connection 
Locations in a Connection Site in Version 8.x

In order for the Voice Network Map tool to collect the data that it needs from other locations in the 
Cisco Unity Connection site, the location on which you use the tool must have sign-in information for 
other locations in the site. The sign-in information is not replicated between locations in the site, so if 
you intend to use the Voice Network Map tool on multiple locations in the site, do the procedure in this 
section on each location on which you will use the tool.

Note The sign-in information is also used when editing objects across the network in Bulk Edit mode in 
Connection Administration. Changes you make to the sign-in information also affect access to Bulk Edit 
mode. 

To Configure Remote Access to Other Cisco Unity Connection Locations in a Connection Site in Version 8.x

Step 1 In Cisco Unity Connection Administration, expand Networking, then select Connection Location 
Passwords.

Step 2 On the Search Enterprise Administration Passwords page, select a Connection location from the list.

Step 3 In the Alias field, enter the username for the account you use to sign in to the remote server. The account 
must have the System Administrator role.

Step 4 In the Password field, enter the password for the account you use to sign in to the remote server.

Step 5 Select Add New.

Step 6 Select Save.

Tip You may want to configure remote access only on an as-needed basis. When remote access is no 
longer needed, you can delete the sign-in information by checking the check box next to the 
applicable account on the Search Enterprise Administration Password page, and selecting Delete 
Selected.

Step 7 Repeat Step 2 through Step 6 as necessary to configure remote access to additional locations in the 
Connection site.
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Viewing Replication Status Information in the Voice Network 
Map Tool in Version 8.x

To use the Voice Network Map Tool, you must have configured remote access to other locations in the 
Cisco Unity Connection site so that the tool can collect the data it needs. See the “Configuring Remote 
Access to Other Cisco Unity Connection Locations in a Connection Site in Version 8.x” section on 
page 7-2.

To View Replication Status Information in the Voice Network Map Tool in Version 8.x

Step 1 In Cisco Unity Connection Serviceability, from the Tools menu, select Voice Network Map.

Step 2 On the Voice Network Map page, select the first location for which you would like to view replication 
status information.

Step 3 To see the replication state and data about USN messages sent, received, and acknowledged between the 
location you selected in Step 2 and another location, move the pointer over the second location.

Tip You can quickly change the second location by moving the pointer to a new location. 
Alternatively, to “lock” the information display to a pair of locations, press the Control key and 
select the second location. To release the lock, repeat the action of pressing the Control key and 
selecting the second location.

Step 4 To change the first location, select a new location, then repeat Step 3.

Step 5 The tool periodically updates the display information based on the update interval you specify. To 
change the update interval:

a. Select the Config tab.

b. In the Update Interval field, enter a value for the frequency at which the display information updates. 
The minimum value is 15 seconds, and the default value is 30 seconds. Note that the interval is reset 
to the default each time the Tomcat service is restarted.

c. Select Save.

Step 6 To pause periodic updates so that the current data continues to display, select the Pause tab. The tab label 
changes to Resume, which you select to have the tool resume periodic updates.

Step 7 To do an immediate update of replication information without waiting for the next update interval, select 
the Update tab.
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