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Preface

This preface contains the following sections:

 • Audience and Use, page v

 • Documentation Conventions, page vi

 • Related Documentation, page vi

 • Obtaining Documentation and Submitting a Service Request, page vii

 • Cisco Product Security Overview, page vii

Audience and Use
The Administration Guide for Cisco Unity Connection Serviceability provides descriptions and 
procedures for configuring alarms, traces, clusters, and services through Cisco Unity Connection 
Serviceability. It is intended for administrators who configure, troubleshoot, and support a Cisco Unity 
Connection or a Cisco Unified Communications Manager Business Edition system. This guide requires 
knowledge of IP networking technology.

Tip For Cisco Unity Connection, you must perform serviceability-related tasks in both Cisco Unified 
Serviceability and Cisco Unity Connection Serviceability; for example, you may need to start and stop 
services, view alarms, and configure traces in both applications to troubleshoot a problem.

Cisco Unified Serviceability supports the functionality described in the Cisco Unified Serviceability 
Administration Guide; for tasks that are specific to Cisco Unity Connection Serviceability, use this 
guide, the Administration Guide for Cisco Unity Connection Serviceability.
v
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Documentation Conventions

The Administration Guide for Cisco Unity Connection Serviceability also uses the following 
conventions:

Note Means reader take note. Notes contain helpful suggestions or references to material not covered in the 
document.

Caution Means reader be careful. In this situation, you might do something that could result in equipment damage 
or loss of data.

Related Documentation
For descriptions and URLs of Cisco Unity Connection documentation on Cisco.com, see the 
Documentation Guide for Cisco Unity Connection Release 7.x. The document is shipped with 
Cisco Unity Connection and is available at 
http://www.cisco.com/en/US/docs/voice_ip_comm/connection/7x/roadmap/7xcucdg.html.

For descriptions and URLs of Cisco Unified Communications Manager Business Edition documentation 
on Cisco.com, see the Cisco Unified Communications Manager Business Edition Documentation Guide. 
The document is shipped with Cisco Unified CMBE and is available at 
http://www.cisco.com/en/US/products/ps7273/products_documentation_roadmaps_list.html.

Table 1 Conventions in the Administration Guide for Cisco Unity Connection Serviceability 

Convention Description

boldfaced text Boldfaced text is used for:

 • Key and button names. (Example: Click OK.)

 • Information that you enter. (Example: Enter Administrator in the User Name 
box.)

< >
(angle brackets)

Angle brackets are used around parameters for which you supply a value. 
(Example: In your browser, go to https://<Cisco Unity Connection server IP 
address>/cuadmin.)

- 
(hyphen)

Hyphens separate keys that must be pressed simultaneously. (Example: Press 
Ctrl-Alt-Delete.)

> 
(right angle 
bracket)

A right angle bracket is used to separate selections that you make in the navigation 
bar of Cisco Unity Connection Administration. (Example: In Cisco Unity 
Connection Administration, go to Contacts > System Contacts.)
vi
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Obtaining Documentation and Submitting a Service Request
For information on obtaining documentation, submitting a service request, and gathering additional 
information, see the monthly What’s New in Cisco Product Documentation, which also lists all new and 
revised Cisco technical documentation, at:

http://www.cisco.com/en/US/docs/general/whatsnew/whatsnew.html

Subscribe to the What’s New in Cisco Product Documentation as a Really Simple Syndication (RSS) feed 
and set content to be delivered directly to your desktop using a reader application. The RSS feeds are a free 
service and Cisco currently supports RSS Version 2.0.

Cisco Product Security Overview
This product contains cryptographic features and is subject to United States and local country laws 
governing import, export, transfer and use. Delivery of Cisco cryptographic products does not imply 
third-party authority to import, export, distribute or use encryption. Importers, exporters, distributors 
and users are responsible for compliance with U.S. and local country laws. By using this product you 
agree to comply with applicable laws and regulations. If you are unable to comply with U.S. and local 
laws, return this product immediately.

Further information regarding U.S. export regulations may be found at 
http://www.access.gpo.gov/bis/ear/ear_data.html.
vii
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C H A P T E R 1

Introduction to Cisco Unity Connection 
Serviceability

This chapter provides basic information on Cisco Unity Connection Serviceability and contains the 
following sections:

 • Understanding Cisco Unity Connection Serviceability, page 1-1

 • Configuring Browsers on Administrator Workstations, page 1-2

 • Accessing Cisco Unity Connection Serviceability, page 1-3

 • Using the Cisco Unity Connection Serviceability Interface, page 1-4

Understanding Cisco Unity Connection Serviceability
Cisco Unity Connection Serviceability, a web-based troubleshooting tool for Cisco Unity Connection, 
provides the following functionality:

 • Displaying Connection alarm definitions, which you can use for troubleshooting.

 • Enabling Connection traces. You can collect and view trace information in the Real-Time 
Monitoring Tool (RTMT).

 • Configuring the logs to which Connection trace information will be saved.

 • Managing a cluster and the servers, if a Connection cluster is configured.

Note The Connection cluster feature is not supported for use with Cisco Unified Communications 
Manager Business Edition.

 • Viewing the status of the Connection feature services.

 • Activating, deactivating, starting, and stopping the Connection services.

 • Generating reports that can be viewed in different file formats.

Depending on the service and component involved, you may perform serviceability-related tasks in both 
Cisco Unity Connection Serviceability and Cisco Unified Serviceability. For example, you may need to 
start and stop services, view alarms, and configure traces in both applications to troubleshoot a problem.

Cisco Unity Connection Serviceability supports the functionality that is described in the Administration 
Guide for Cisco Unity Connection Serviceability. For information on using Cisco Unified Serviceability, 
see the Cisco Unified Serviceability Administration Guide.
1-1
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Configuring Browsers on Administrator Workstations
Configuring Browsers on Administrator Workstations
To access Cisco Unity Connection Serviceability, Cisco Unity Connection Administration, Cisco 
Unified Serviceability, Disaster Recovery System, and other web applications on the Connection or 
Cisco Unified CMBE server, the browser(s) must be set up correctly on an administrator workstation.

See the applicable section, depending on the browser(s) installed on the computer:

 • Firefox, page 1-2

 • Microsoft Internet Explorer, page 1-2

Firefox
Do the following tasks to set up Firefox for accessing the Connection web applications.

1. Confirm that the software required for correct browser configuration is installed. See the “Software 
Requirements—Administrator Workstations” section of the applicable requirements document:

 • System Requirements for Cisco Unity Connection at 
http://www.cisco.com/en/US/products/ps6509/prod_installation_guides_list.html.

 • System Requirements for Cisco Unity Connection in Cisco Unified CMBE at 
http://www.cisco.com/en/US/products/ps7273/prod_installation_guides_list.html.

2. Configure Firefox:

a. Enable Java.

b. Enable Java Script > Enable Change Images in Java Script Advanced.

c. Allow sites to set cookies. (For security purposes, we recommend that you set this to Allow 
Sites to Set Cookies for the Originating Web Site Only.)

Microsoft Internet Explorer
Do the following tasks to set up Internet Explorer for accessing the Connection web applications.

1. Confirm that the software required for correct browser configuration is installed. See the “Software 
Requirements—Administrator Workstations” section of the applicable requirements document:

 • System Requirements for Cisco Unity Connection at 
http://www.cisco.com/en/US/products/ps6509/prod_installation_guides_list.html.

 • System Requirements for Cisco Unity Connection in Cisco Unified CMBE at 
http://www.cisco.com/en/US/products/ps7273/prod_installation_guides_list.html.

2. Configure Internet Explorer:

a. Enable Active scripting.

b. Download and run ActiveX controls.

c. Enable Java scripting.

d. Accept all cookies.

e. Automatically check for newer versions of temporary Internet files.

f. Enable Medium-High privacy.
1-2
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Chapter 1      Introduction to Cisco Unity Connection Serviceability
Accessing Cisco Unity Connection Serviceability
g. If you are running Microsoft Windows Server 2003 and using Internet Explorer version 6.0 to 
access the Cisco Personal Communications Assistant, add the Connection server to the Trusted 
Sites list by doing the following procedure, “To Add the Connection or Cisco Unified CMBE 
Server to the List of Trusted Sites (Windows Server 2003 with Internet Explorer 6.0 Only).”

To Add the Connection or Cisco Unified CMBE Server to the List of Trusted Sites (Windows Server 2003 with 
Internet Explorer 6.0 Only)

Step 1 Open the Cisco Personal Communications Assistant Login page. It is not necessary to log in to the 
Cisco PCA.

Step 2 On the Internet Explorer File menu, click Add This Site To > Trusted Sites Zone.

Step 3 In the Trusted Sites dialog box, click Add.

Step 4 Click Close to close the Trusted Sites dialog box.

Step 5 Restart Internet Explorer.

Accessing Cisco Unity Connection Serviceability
The first time that you log on to Cisco Unity Connection Serviceability, you use the username and 
password for the default administrator account that the installer specified for the account during 
installation. Later, you can use the username and password for any additional administrator accounts that 
you create.

To Access Cisco Unity Connection Serviceability

Step 1 By using a supported web browser, open a browser session.

Step 2 Go to https://<Cisco Unity Connection server IP address>/cuservice.

Step 3 Enter an applicable username and password, and click Login.

After you have logged on to Cisco Unity Connection Serviceability, you can access all applications that 
appear in the Navigation drop-down box except for Cisco Unified Operating System Administration and 
Disaster Recovery System without having to log on to each application. 

You cannot access Cisco Unified Operating System Administration or Disaster Recovery System by 
using the Cisco Unity Connection Serviceability username and password. To access these applications 
from Cisco Unity Connection Serviceability, you must click the Logout link in the upper-right corner of 
Cisco Unity Connection Serviceability, then click the application from the Navigation drop-down box 
and click Go.

If you have already logged on to one of the applications that display in the Navigation drop-down box 
(not Cisco Unified Operating System Administration or Disaster Recovery System), you can access 
Cisco Unity Connection Serviceability without logging in. From the Navigation drop-down box, click 
Cisco Unity Connection Serviceability and click Go.
1-3
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Using the Cisco Unity Connection Serviceability Interface
Using the Cisco Unity Connection Serviceability Interface
In addition to troubleshooting, generating reports, and doing service-related tasks in Cisco Unity 
Connection Serviceability, you can do the following tasks:

 • To display documentation for a single window, click Help > This Page.

 • To display a list of documents that are available with this release of Connection or Cisco 
Unified CMBE (or to access the Help index), click Help > Contents.

 • To verify the version of Cisco Unity Connection Serviceability running on the server, click Help > 
About or click the About link in the upper-right corner of the window.

 • To go directly to the home page in Cisco Unity Connection Serviceability from a configuration 
window, click Cisco Unity Connection Serviceability from the Navigation drop-down box.

 • To access Cisco Unity Connection Administration or other applications, click the applicable 
application from the Navigation drop-down box and click Go.

 • To log out of Cisco Unity Connection Serviceability, click the Logout link in the upper-right corner 
of the window.

 • On each Cisco Unity Connection Serviceability configuration page, configuration icons appear that 
correspond to the configuration buttons at the bottom of the page. (For example, you can click either 
the Save icon or the Save button to complete the task.)
1-4
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C H A P T E R 2

Using Alarms

This chapter provides information on using alarms in Cisco Unity Connection Serviceability and 
contains the following sections:

 • Understanding Alarms, page 2-1

 • Alarm Definitions, page 2-1

 • Viewing Alarm Definitions, page 2-1

Understanding Alarms
Cisco Unity Connection Serviceability alarms provide information on runtime status and the state of the 
system, so you can troubleshoot problems that are associated with the system. For example, you can use 
alarms to determine whether there are any ports enabled to set MWIs. Alarm information includes the 
catalog, name, severity, explanation, recommended action, routing list, and parameters.

You use the trace and log central option in the Real-Time Monitoring Tool (RTMT) to collect alarms. 
You use the SysLog Viewer in RTMT to view alarms.

Alarm Definitions
Alarm definitions describe alarm messages—what they mean and how to recover from them.

You search the Alarm Message Definitions page for alarm information. When you click an alarm, a 
description of the alarm information and a recommended action appears on the Alarm Information page. 
To help with troubleshooting, the definitions include the alarm name, description, severity, explanation, 
recommended action, routing list, and parameters.

Viewing Alarm Definitions
This section describes how to search for and view alarm definitions.

To View Alarm Definitions

Step 1 In Cisco Unity Connection Serviceability, click Alarm > Definitions.
2-1
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Viewing Alarm Definitions
Step 2 In the Alarm Message Definitions window, enter search criteria for the definitions that you want to view, 
then click Find.

Tip To display all alarm definitions, leave the search criteria blank and click Find.

The definition list displays. Multiple pages of alarm definitions may exist. To choose another page, click 
the applicable navigation button at the bottom of the Alarm Message Definitions window. To change the 
number of alarms that display in the window, choose a different value from the Rows per Page 
drop-down list box.

Step 3 In the list, click the hyperlink alarm definition for which you want alarm details.

The Alarm Information window displays.

Step 4 To return to the Alarm Message Definitions window, click Back to Find/List Alarms from the Related 
Links drop-down list box and click Go.
2-2
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Using Traces

This chapter provides information on using traces in Cisco Unity Connection Serviceability and contains 
the following sections:

 • Understanding Traces, page 3-1

 • Configuring Trace Log Files, page 3-2

 • Enabling Micro Traces, page 3-2

 • Available Micro Traces, page 3-3

 • Enabling Macro Traces, page 3-8

 • Available Macro Traces, page 3-9

Understanding Traces
Revised May 2009
Cisco Unity Connection Serviceability traces help troubleshoot problems in the following ways:

 • You can specify the log file parameters for each Connection component, including the maximum 
number of log files and the maximum file size that can be created when you run traces for a 
component.

 • You can enable micro traces and the level of micro-trace information that you want.

 • You can enable macro traces (preselected groups of micro traces) and the level of macro-trace 
information that you want.

After you have configured the log files and enabled the traces, you collect trace log files in one of the 
following ways:

 • By using the trace and log central option in the Real-Time Monitoring Tool (RTMT). For 
information, see the “Working with Trace and Log Central” chapter (of the “Tools for Traces, Logs, 
and Plug-Ins” part) of the Cisco Unified Real-Time Monitoring Tool Administration Guide.

 • By using the command line interface (CLI). For information, see the Command Line Interface 
Reference Guide for Cisco Unified Communications Solutions.

Note Enabling macro or micro traces decreases system performance. Enable traces only for troubleshooting 
purposes.
3-1
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Configuring Trace Log Files
Configuring Trace Log Files
Do the procedure in this section to configure trace log files for Cisco Unity Connection services.

Note Before trace information can be written to the log files, you must enable micro traces or macro traces 
that will provide the troubleshooting information in the areas that you select.

To Configure Trace Log Files

Step 1 In Cisco Unity Connection Serviceability, click Trace > Configuration.

The Trace Configuration page appears.

Step 2 In the Server drop-down box, click the applicable Connection or Cisco Unified CMBE server, and click 
Go.

Step 3 From the Component drop-down box, choose the component for which you want to configure trace log 
files, and click Go.

Note The drop-down box displays all components (active and inactive).

Step 4 In the Maximum No. of Files field, enter the maximum number of trace log files that will be created for 
this component.

Step 5 In the Maximum File Size field, enter the size limit (in megabytes) for the trace log files that will be 
created for this component.

Step 6 If you want to return to the default settlings, click Set Default. Otherwise, skip to the next step.

Step 7 Click Save.

Step 8 If you want the new trace log files to replace the old trace log files for this component, click Restart Log 
Files.

Enabling Micro Traces
Enable micro traces when you are troubleshooting problems with specific Cisco Unity Connection 
components. For example, if the Alert Central tool in Real-Time Monitoring Tool (RTMT) has 
notification errors, enable the Notifier trace. However, keep in mind that running traces can affect system 
performance and hard-disk space.

Note Enabling micro traces decreases system performance. Enable traces only for troubleshooting purposes.

To Enable Micro Traces

Step 1 In Cisco Unity Connection Serviceability, choose Trace > Micro Traces.

The Micro Traces page appears.
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Available Micro Traces
Step 2 In the Server drop-down box, click the applicable Connection or Cisco Unified CMBE server, and click 
Go.

Step 3 From the Micro Trace drop-down box, click the micro trace that you want to enable, and click Go.

Step 4 Under Micro-Trace Levels, check the check boxes for the micro-trace levels that you want to enable.

Step 5 Click Save.

Tip You may need to enable traces in Cisco Unity Connection Serviceability and Cisco Unified 
Serviceability to troubleshoot Connection issues. To troubleshoot Connection components, enable traces 
in Cisco Unity Connection Serviceability. Similarly, to troubleshoot services that are supported in Cisco 
Unified Serviceability, enable traces in Cisco Unified Serviceability. For information on how to enable 
traces in Cisco Unified Serviceability, see the Cisco Unified Serviceability Administration Guide.

Available Micro Traces
Revised May 2009
Table 3-1 lists each micro trace that is available, a description of what it analyzes, and the filename of 
the trace log that it generates.

Table 3-1 Micro Traces 

Micro Trace Name What the Trace Analyzes File Name of Trace Log

Arbiter Conversations, ports, and call 
routing rules that are used for calls

diag_CuCsMgr_*.uc

AudioStore The audio recording service used by 
web-based applications that use 
Media Master to playback or record 
audio streams

diag_Tomcat_*.uc

AxlAccess Interaction with the AXL server to 
get and set phone-related properties

diag_Tomcat_*.uc

BulkAdministrationTool Bulk Administration Tool that is 
used for creating, updating, and 
deleting multiple users or system 
contacts

diag_Tomcat_*.uc

CCL The retrieval of meeting information 
for the calendaring feature

diag_CuCsMgr_*.uc
diag_CuGalSvc_*.uc
diag_Tomcat_*.uc

CDE Conversation engine and 
conversation events

diag_CuCsMgr_*.uc

CDL Information retrieval from the 
database

diag_CuCsMgr_*.uc
diag_Tomcat_*.uc
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Available Micro Traces
CML The retrieval of messages from the 
Cisco Unity Connection message 
store; the retrieval of messages from 
an Exchange server (by using 
IMAP) for using Text-to-Speech 
feature to read e-mail messages

diag_CuCsMgr_*.uc
diag_CuNotifier_*.uc
diag_Tomcat_*.uc

CiscoPCA The Cisco Personal 
Communications Assistant 
(Cisco PCA)

diag_Tomcat_*.uc

Common Low-level activities for components 
that are shared by Cisco Unity 
Connection services

<any>

ConfigData Detection that configuration data 
has been updated in the database

<any>

ConvRoutingRules The conversation to which the 
Arbiter routes calls

diag_CuCsMgr_*.uc

ConvSub User activities and usage diag_CuCsMgr_*.uc

CsLicense Functions related to license 
processing

diag_CuLicSvr_*.uc

CsMalUmss Access to the message store by the 
CML, Notifier, and IMAP server

diag_CuCsMgr_*.uc
diag_Tomcat_*.uc

CsWebDav Calendar activities in connection 
with Exchange

diag_CuCsMgr_*.uc
diag_CuGalSvc_*.uc
diag_Tomcat_*.uc

CuCcmSynchronization
Tasks

Synchronization of the user data 
from Cisco Unified CM

diag_Tomcat_*.uc

CuCmDbEventListener Detection of changes in the Cisco 
Unified CM database

diag_CuCmDbEventListener_*.uc

CuCsMgr Main Cisco Unity Connection 
process; starting and stopping 
Connection

diag_CuCsMgr_*.uc

CuDbProxy Database replication for 
Cisco Unity Connection clusters

diag_CuDbProxy_*.uc

CuESD The activities of Cisco Unity 
Connection external service 
diagnostic tools

diag_Tomcat_*.uc

CuEncrypt Encryption (except for messaging) 
and the encryption audit logs

<any>

CuFileSync File replication for Cisco Unity 
Connection clusters

diag_CuFileSync_*.uc

CuGal The retrieval of calendar and contact 
information from Exchange

diag_CuGalSvc_*.uc

Table 3-1 Micro Traces (continued)

Micro Trace Name What the Trace Analyzes File Name of Trace Log
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Available Micro Traces
CuImapSvr Access to voice messages by IMAP 
clients

diag_CuImapSvr_*.uc

CuReplicator Replication for digital networking

Note We recommend that the 
Debug Traces and Debug 
Statistics micro-trace levels 
be enabled for no more than 
one hour because they can 
produce a large number of 
log entries.

diag_CuReplicator_*.uc

CuService The activities of Cisco Unity 
Connection Serviceability

diag_Tomcat_*.uc

CuSnmpAgt The activities of the Cisco Unity 
Connection SNMP subagent

diag_CuSnmpAgt_*.uc

Cuals The activities of the web services to 
add users

diag_Tomcat_*.uc

Cuca The activities of Cisco Unity 
Connection Administration

diag_Tomcat_*.uc

DataSysAgentTasks Data SysAgent tasks diag_CuSysAgent_*.uc

DbEvent Component notification of database 
changes

<any>

FailureConv Activation of the Failure 
Conversation when a system error 
occurs

diag_CuCsMgr_*.uc

LicenseClient Functions related to license 
management

diag_CuCsMgr_*.uc

Logger Writing traces logs and events <any>

MTA Delivery of voice messages to the 
message store

diag_MTA_*.uc

MediaMasterControl The Media Master on the client 
workstation

diag_Tomcat_*.uc

MediaMasterUMS The UMS service, which handles 
streams audio recordings between 
the Media Master and the 
AudioStore

diag_Tomcat_*.uc

MediaMasterWeb The web page rendering module that 
is used in web-based applications 
that have the Media Master

diag_Tomcat_*.uc

MessageEventService Detection of arrival or deletion of 
messages

diag_Tomcat_*.uc

Table 3-1 Micro Traces (continued)

Micro Trace Name What the Trace Analyzes File Name of Trace Log
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Available Micro Traces
MiuAdm Functions in Cisco Unity 
Connection Administration relating 
to testing voice messaging ports and 
generating certificates

diag_Tomcat_*.uc

MiuCall The process between the Miu and 
conversations

diag_CuCsMgr_*.uc

MiuDatatbase Media activities relating to 
accessing the database

diag_CuCsMgr_*.uc

MiuGeneral Tracking calls through the 
telephone user interface (TUI); call 
control functions; turning message 
waiting indicators (MWIs) on and 
off; notification and outdial 
functions; basic media or WAV file 
usage

diag_CuCsMgr_*.uc

MiuIO Media or WAV file usage with TAPI 
(circuit-switched or Cisco Unified 
CallManager) integrations

diag_CuCsMgr_*.uc

MiuMethods Handing of incoming calls; call 
control; turning messaging waiting 
indicators (MWIs) on and off; 
notification and outdial functions; 
media or WAV file usage

diag_CuCsMgr_*.uc

MiuSIP SIP call control diag_CuCsMgr_*.uc

MiuSIPStack Low-level SIP interactions for call 
control

diag_CuCsMgr_*.uc

MiuSkinny SCCP call control diag_CuCsMgr_*.uc

MiuTranscode Low-level media functions relating 
to transcoding

diag_CuCsMgr_*.uc

Mixer Low-level activities relating to 
media and the Text-to-Speech 
feature

diag_CuMixer_*.uc

Monitor Monitoring the status of voice 
messaging ports and call processing 
during a call; the server-side 
functions for displaying port status 
in Real-Time Monitoring Tool

diag_CuCsMgr_*.uc

Notifier Notification of messages and 
selected events; turning message 
waiting indicators (MWIs) on and 
off

diag_CuCsMgr_*.uc
diag_CuNotifier_*.uc

PCAMeetingPlace Activities of the Cisco Personal 
Communications Assistant relating 
to MeetingPlace for the calendar 
feature

diag_Tomcat_*.u

Table 3-1 Micro Traces (continued)

Micro Trace Name What the Trace Analyzes File Name of Trace Log
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PCAUnifiedCM Activities of the Cisco Personal 
Communications Assistant relating 
to the Cisco Unified 
Communications Manager 
integration

diag_Tomcat_*.uc

PhoneManager The management of IP phone 
applications

diag_CuCsMgr_*.uc

PhraseServer The prompts that play and the user 
DTMF input; the logs are written to 
a file

diag_CuCsMgr_*.uc

PhraseServerToMonitor The prompts that play and the user 
DTMF input; the logs are written to 
the monitor

diag_CuCsMgr_*.uc

RSS RSS feeds that are used for checking 
voice mail from an RSS client

diag_Tomcat_*.uc

ReportDataHarvester Conversion of the content in the data 
log files to entries in the reports 
database

diag_CuReportDataHarvester_*.uc

ResourceLoader Using the selected language in the 
GUI; filling strings with product or 
message information

<any>

ResourceManager Monitoring and providing available 
resources to the Arbiter as needed

diag_CuCsMgr_*.uc

RoutingRules Call routing decisions diag_CuCsMgr_*.uc

RulesEngine Evaluation of personal call transfer 
rules for a subscriber during a call

diag_CuCsMgr_*.uc
diag_Tomcat_*.uc

SMTP SMTP functions diag_SMTP_*.uc

SRM Functions related to cluster 
management

diag_CuSrm_*.uc

SocketPoolHelper Socket connections to the IMAP 
server

<any>

SslInit Initialization procedures for 
components that use OpenSSL

<any>

SysAgent System Agent component, which 
schedules system tasks that the 
administrator enters (such as 
resynchronizing MWIs)

diag_CuSysAgent_*.uc

TRaP Telephone Record and Playback 
(TRaP), which lets clients use the 
phone as a recording and playback 
device

diag_CuCsMgr_*.uc
diag_Tomcat_*.uc

TaskRequest Functions related to the Task 
Management tool

diag_CuSysAgent_*.uc

Table 3-1 Micro Traces (continued)

Micro Trace Name What the Trace Analyzes File Name of Trace Log
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Enabling Macro Traces
Revised May 2009
Enable macro traces, which are preselected sets of micro traces, when you are troubleshooting general 
areas of Connection functionality. For example, if there are MWI problems, enable the Traces for MWI 
Problems macro trace. However, keep in mind that running traces can affect system performance and 
hard-disk space.

Caution Enabling macro traces decreases system performance. Enable traces only for troubleshooting purposes.

To Enable Macro Traces

Step 1 In Cisco Unity Connection Serviceability, click Trace > Macro Traces.

TextToSpeech The activities of the Text to Speech 
feature

diag_CuCsMgr_*.uc

ThreadPool The use of threads by the processor <any>

TimerHelper The timer used by the Conversation 
Manager component

<any>

TranscodeWeb The web server audio format 
transcoding utilities that transcode 
the incoming audio streams into the 
audio format that Cisco Unity 
Connection uses

diag_Tomcat_*.uc

UmssSysAgentTasks Messaging tasks for the System 
Agent component

diag_CuSysAgent_*.uc

UnityAssistant The activities of the Cisco Unity 
Assistant web tool in the 
Cisco Personal Communications 
Assistant

diag_Tomcat_*.uc

UnityInbox The activities of the Cisco Unity 
Inbox web tool in the 
Cisco Personal Communications 
Assistant

diag_Tomcat_*.uc

UnityPCTR The activities of the Cisco Unity 
Personal Call Transfer Rules web 
tool in the Cisco Personal 
Communications Assistant

diag_CuCsMgr_*.uc

VMWS Interactions with voice messaging 
web services

diag_Tomcat_*.uc

VUI The voice user interface diag_CuCsMgr_*.uc

VirtualQueue Call queuing diag_CuCsMgr_*.uc

Table 3-1 Micro Traces (continued)

Micro Trace Name What the Trace Analyzes File Name of Trace Log
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Available Macro Traces
The Macro Traces page appears.

Step 2 In the Server drop-down box, click the applicable Connection or Cisco Unified CMBE server, and click 
Go.

Step 3 Check the check box of the macro trace that you want to enable.

Step 4 Expand the macro trace, and check the check boxes for the levels that you want to enable.

Step 5 Click Save.

Tip You may need to enable traces in Cisco Unity Connection Serviceability and Cisco Unified 
Serviceability to troubleshoot Connection issues. To troubleshoot Connection components, enable traces 
in Cisco Unity Connection Serviceability. Similarly, to troubleshoot services that are supported in Cisco 
Unified Serviceability, enable traces in Cisco Unified Serviceability. For information on how to enable 
traces in Cisco Unified Serviceability, see the Cisco Unified Serviceability Administration Guide.

Available Macro Traces
Revised May 2009
Table 3-2 lists each macro trace that is available, a description of what it analyzes, and the filename of 
the trace log that it generates.

Table 3-2 Macro Traces 

Macro Trace Name What the Trace Analyzes File Name of Trace Log

Call Flow Diagnostics The flow of a call through Cisco Unity 
Connection

diag_CuCsMgr_*.uc

Message Objectid 
Tracking Traces

Message handing; the objects that handle 
messages from delivery to deletion

diag_CuSysAgent_*.uc
diag_MTA_*.uc
diag_CuCsMgr_*.uc
diag_CuImapSvr_*.uc
diag_Tomcat_*.uc

Call Control (Miu) 
Traces

Call control functions diag_CuCsMgr_*.uc

Traces for MWI 
Problems

Turning message waiting indicators (MWIs) 
on and off

diag_CuCsMgr_*.uc
diag_CuNotifier_*.uc

Traces for Other 
Notification Problems

Notification and outdial functions diag_CuCsMgr_*.uc
diag_CuNotifier_*.uc

Unity Startup Cisco Unity Connection startup functions diag_CuCsMgr_*.uc
diag_CuNotifier_*.uc

Conversation Traces Conversation usage diag_CuCsMgr_*.uc

Voice User 
Interface/Speech 
Recognition Traces

Voice user interface (VUI) diag_CuCsMgr_*.uc

Media (Wave) Traces Media and WAV file usage diag_CuCsMgr_*.uc
diag_CuMixer_*.uc
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Text to Speech (TTS) 
Traces

The Text to Speech (TTS) feature; also can log 
traces on other Cisco Unity Connection 
components that interact with TTS

diag_CuCsMgr_*.uc

Connection 
Serviceability Web 
Service

The activity of Cisco Unified Serviceability diag_Tomcat_*.uc

ViewMail for Outlook The activity of Cisco Unity Connection 
ViewMail for Microsoft Outlook clients

diag_CuCsMgr_*.uc
diag_CuImapSvr_*.uc
diag_MTA_*.uc
diag_Tomcat_*.uc

Digital Networking Digital networking functions diag_CuReplicator_*.uc

Table 3-2 Macro Traces (continued)

Macro Trace Name What the Trace Analyzes File Name of Trace Log
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Managing Server Status and Ports in a 
Cisco Unity Connection Cluster

The Cluster Management page in Cisco Unity Connection Serviceability lets you change the status of 
servers in a Connection cluster, stop all ports on a server from taking new calls, and restart all ports on 
a server to take calls.

For the applicable procedures, see the “Administering a Cisco Unity Connection Cluster” chapter of the 
Cluster Configuration and Administration Guide for Cisco Unity Connection Release 7.x at 
http://www.cisco.com/en/US/docs/voice_ip_comm/connection/7x/cluster_administration/guide/7xcucc
agx.html.

Note The Connection cluster feature is not supported for use with Cisco Unified Communications Manager 
Business Edition.
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Managing Cisco Unity Connection Services

This chapter provides information on managing services in Cisco Unity Connection Serviceability and 
contains the following sections:

 • Cisco Unity Connection Services, page 5-1

 • Managing Services in Control Center, page 5-2

Cisco Unity Connection Services
Revised October 22, 2010
Cisco Unity Connection has the following services:

Status Only Services

 • Connection DB

 • Connection Server Role Manager

 • Connection Serviceability

Critical Services

 • Connection Conversation Manager

 • Connection Message Transfer Agent

 • Connection Mixer

 • Connection Notifier

Base Services

 • Connection Administration

 • Connection DB Event Publisher

 • Connection IMAP Server

 • Connection License Server

 • Connection SNMP Agent

Optional Services

 • Connection Access Layer

 • Connection CM Database Event Listener
5-1
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 • Connection Database Proxy

 • Connection Digital Networking Replication Agent

 • Connection File Syncer

 • Connection Groupware Caching Service

 • Connection Inbox RSS Feed

 • Connection Integrated Mailbox Configuration

 • Connection Message Event Service

 • Connection Personal Communication Assistant

 • Connection Realtime Monitoring APIs

 • Connection Reports Data Harvester

 • Connection SMTP Server

 • Connection System Agent

 • Connection Voice Mail Web Service

 • Connection Voice Recognition Transport

 • Connection Voice Recognizer

Managing Services in Control Center
Control Center in Cisco Unity Connection Serviceability lets you do the following tasks:

 • Activate and deactivate Connection services in the Optional Services section.

 • Start and stop all Connection services except the services in the Status Only Services section.

Stopping Connection services in the Critical Services section may cause calls in progress to be 
dropped and degrades the normal function of the Connection or Cisco Unified CMBE server.

When a Cisco Unity Connection cluster is configured, stopping a service in the Critical Services 
section for the server with Primary status causes the status for the servers in the cluster to change.

 • View the status the status of Connection services.

 • Refresh the status of Connection services.

Tip You may need to manage services in both Cisco Unity Connection Serviceability and Cisco Unified 
Serviceability to troubleshoot a problem.

The Cisco Unified Serviceability services are described in the Cisco Unified Serviceability 
Administration Guide.

This section contains five procedures; do the applicable procedure to activate, deactivate, start, or stop 
Connection services, or to refresh the status of services. You can activate, deactivate, start, and stop only 
one service at a time.

To Activate a Service in Control Center

Step 1 In Cisco Unity Connection Serviceability, choose Tools > Service Management.
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Managing Services in Control Center
Step 2 From the Server drop-down box, choose the applicable Connection or Cisco Unified CMBE server, and 
click Go.

Step 3 Under Optional Services, locate the service that you want to activate.

Step 4 In the Change Activate Status column, click Activate.

To Deactivate a Service in Control Center

Step 1 In Cisco Unity Connection Serviceability, choose Tools > Service Management.

Step 2 From the Server drop-down box, choose the applicable Connection or Cisco Unified CMBE server, and 
click Go.

Step 3 Under Optional Services, locate the service that you want to deactivate.

Step 4 In the Change Activate Status column, click Deactivate.

To Start a Service in Control Center

Step 1 In Cisco Unity Connection Serviceability, choose Tools > Service Management.

Step 2 From the Server drop-down box, choose the applicable Connection or Cisco Unified CMBE server, and 
click Go.

Step 3 Under Optional Services, locate the service that you want to start.

Note Services that are deactivated must be activated before they can be started.

Step 4 In the Change Service Status column, click Start.

To Stop a Service in Control Center

Step 1 In Cisco Unity Connection Serviceability, choose Tools > Service Management.

Step 2 From the Server drop-down box, choose the applicable Connection or Cisco Unified CMBE server, and 
click Go.

Step 3 Locate the service that you want to stop.

Note Services in the Status Only Services section cannot be started or stopped in Cisco Unity 
Connection Serviceability. You must use the command line interface (CLI) to start or stop these 
services.

When a Connection cluster is configured, stopping a service in the Critical Services section for 
the server with Primary status will cause the status for the servers in the cluster to change. To 
prevent the status change when the service is stopped, in Cisco Unity Connection 
Administration, you must uncheck the Automatically Change Server Status When the Publisher 
Server Fails check box on the System Settings > Advanced > Cluster Configuration page.
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Managing Services in Control Center
Step 4 In the Change Service Status column, click Stop.

Note Stopping Connection services in the Critical Services section may cause calls in progress to be 
dropped and degrades the normal function of the Connection or Cisco Unified CMBE server.

A service that is not activated cannot be started or stopped.

Step 5 If you are prompted that the cluster server status will change, click OK.

To Refresh Service Status in Control Center

Step 1 In Cisco Unity Connection Serviceability, choose Tools > Service Management.

Step 2 From the Server drop-down box, choose the applicable Connection or Cisco Unified CMBE server, and 
click Go.

Step 3 Click Refresh.

The status information is updated to reflect the current status.
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Using Reports

This chapter provides information on using reports in Cisco Unity Connection Serviceability and 
contains the following sections:

 • Understanding Reports, page 6-1

 • Setting Report Configuration Parameters, page 6-4

 • Generating and Viewing Reports, page 6-5

Understanding Reports
Revised May 2009
Cisco Unity Connection Serviceability lets you gather information about system configuration and call 
handlers into reports.

Table 6-1 describes the reports that you can generate in Cisco Unity Connection Serviceability.

Table 6-1 Reports Available in Cisco Unity Connection Serviceability 

Report Name Description of Output

Phone Interface
Failed Logon

Includes the following information for every failed attempt to log on to 
Connection by phone:

 • Username, alias, caller ID, and extension of user who failed to log on.

 • Date and time the failed logon occurred.

 • Whether the maximum number of failed logons has been reached for 
the user.

Users Includes the following information for each user:

 • Last name, first name, and alias.

 • Information that identifies the Connection or Cisco Unified CMBE 
server associated with the user.

 • Billing ID, class of service, and extension.

 • Whether the account is locked.

 • Whether the user has enabled personal call transfer rules.
6-1
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Message Traffic Includes totals for the following traffic categories:

 • Voice.

 • Fax.

 • E-mail.

 • NDR.

 • Delivery.

 • Read receipt.

 • Hourly totals.

Port Activity Includes the following information for voice messaging ports:

 • Name.

 • Number of inbound calls handled.

 • Number of outbound MWI calls handled.

 • Number of outbound AMIS calls handled.

 • Number of outbound notification calls handled.

 • Number of outbound TRaP calls handled.

 • Total number of calls handled.

Mailbox Store Includes the following information about the specified mailbox stores:

 • Mail database name.

 • Display name.

 • Server name.

 • Whether access is enabled.

 • Mailbox store size.

 • Last error.

 • Status.

 • Whether the mail database can be deleted.

Dial Plan Includes a list of the search spaces configured on the Connection or Cisco 
Unified CMBE server, with an ordered list of partitions assigned to each 
search space.

If the server is part of a Digital Network, also lists the search spaces and 
associated partition membership on every other Connection location on the 
network.

Dial Search Scope Includes a list of all users and their extensions in the specified partition that 
is configured in the Connection directory. If a partition is not specified, lists 
all users and their extensions for all partitions that are configured in the 
directory.

Table 6-1 Reports Available in Cisco Unity Connection Serviceability (continued)

Report Name Description of Output
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Subscriber Message
Activity

Includes the following information about messages sent and received, per 
user:

 • Name, extension, and class of service.

 • Date and time for each message.

 • Information on the source of each message.

 • Action completed (for example, new message, message saved, MWI On 
requested, and so on).

 • Information on the number of new messages received for a user, and on 
the message sender.

 • Dial out number and results.

Distribution Lists Includes the following information:

 • Name and display name of the list.

 • Date and time the list was created. (Date and time are given in 
Greenwich Mean Time.)

 • A count of the number of users included in the list.

 • If the Include List Members check box is checked, a listing of the alias 
of each user who is a member of the list.

User Lockout Includes user alias, the number of failed logon attempts for the user, 
credential type (a result of “4” indicates a logon attempt from the 
Connection conversation; a result of “3” indicates a logon attempt from a 
web application), and the date and time that the account was locked.

(Date and time are given in Greenwich Mean Time.)

Unused Voice Mail
Accounts

Includes user alias and display name, and the date and time that the user 
account was created.

(Date and time are given in Greenwich Mean Time.)

Transfer Call Billing Includes the following information for each call:

 • Name, extension, and billing ID of the user.

 • Date and time that the call occurred.

 • The phone number dialed.

 • The result of the transfer (connected, ring-no-answer (RNA), busy, or 
unknown).

Outcall Billing
Detail

Includes the following information, arranged by day and by the extension of 
the user who placed the call:

 • Name, extension, and billing ID.

 • Date and time the call was placed.

 • The phone number called.

 • The result of the call (connected, ring-no-answer (RNA), busy, or 
unknown).

 • The duration of the call in seconds.

Table 6-1 Reports Available in Cisco Unity Connection Serviceability (continued)

Report Name Description of Output
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Setting Report Configuration Parameters
Cisco Unity Connection is automatically set to gather and store data from which you can generate 
reports. The parameters listed in this section can be adjusted, depending on the report output that you 
want to generate. All report parameter settings are found on the System Settings > Advanced > Reports 
page in Cisco Unity Connection Administration.

Reports data is gradually written over, depending on the parameters you set for retention of data. We 
recommend that if you want to keep reports for historical purposes, you develop a schedule for regularly 
generating reports, and save them in a location separate from the Connection or Cisco Unified CMBE 
server.

Milliseconds Between Data Collection Cycles—Set by default to 30 minutes (1,800,000 milliseconds). 
This setting controls the amount of time Connection waits between cycles of gathering report data.

Days to Keep Data in Reports Database—Set by default to 180 days. Note that even if you specify 
more than this number of days in the time range for the report you are generating, the number of days of 
data is limited by what you set here.

Maximum Records in Report Output—Set by default to 25,000 records. The maximum value allowed 
for this field is 30,000 records. If the report you want to generate exceeds the maximum number of 
records allowed, you can generate the report in pieces (for example by reducing the date range or number 
of user accounts included in each iteration).

Note The Maximum Records in Report Output setting for the User Message Activity Report has been 
restricted to 15,000 records—rather than the default of 25,000 records—because of the size of the report.

Minimum Records Needed to Display Progress Indicator—Set by default to 2,500 records. The 
maximum value allowed for this field is 10,000 records. The purpose of the progress indicator is to warn 
you if the report you request is large and likely to take a long time to complete. In Connection, reports 
are generated from within a browser, and the browser session must be kept open while the report is being 

Outcall Billing
Summary

Arranged by date and according to the name, extension, and billing ID of 
the user who placed the call, and is a listing of the 24 hours of the day, with 
a dialout time in seconds specified for each hour span.

Call Handler 
Traffic

Includes the following information for each call handler, in rows for each 
hour of a day:

 • Total number of calls.

 • Number of times each key on the phone keypad was pressed.

 • Extension.

 • Invalid extension.

 • Number of times the after greeting action occurred.

 • Number of times the caller hung up.

System Configuration Includes detailed information about all aspects of the configuration of the 
Connection system.

Table 6-1 Reports Available in Cisco Unity Connection Serviceability (continued)

Report Name Description of Output
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generated. Depending on the size of the database, and the type of report being generated, a report can 
take a long time to generate; meanwhile, you will be unable to use the browser, and must keep the 
Connection Administration session open.

Generating and Viewing Reports
When you generate a report, you can specify some or all of the following:

 • The objects (for example, user accounts or call handlers) to include in the report.

 • The date and time range to include.

 • The sort order for the data in the report.

You can choose one of the following file formats for the report:

The best time to generate reports is when the system is not busy: after regular business hours when 
Connection is not processing many calls, or when there are no other processes running (for example, 
before or after a full backup). Requests to generate reports are queued. If multiple reports are generated 
at one time (from separate browsers), the reports wait in line and only one is processed at a time.

Caution Generating large reports when the system is busy will use system resources and could potentially result 
in slower response time for system users.

Note that reports cannot be scheduled in advance. If you shut down the Connection or Cisco 
Unified CMBE server, or close the Connection Administration browser session while reports are being 
generated, the report generation will be canceled.

To Generate and View a Report

Step 1 In Cisco Unity Connection Serviceability, choose Tools > Reports.

Step 2 On the Serviceability Reports page, click the name of the report that you want to generate.

Step 3 Select the applicable file format for the report output.

Step 4 If the fields are available, set a date range by clicking the beginning and ending month, day, year, and 
time.

Step 5 Set other parameters, as applicable.

Web page HTML file. Report output appears in your web browser.

Select this format to quickly view a small report.

For archiving purposes, we recommend that you generate PDF reports.

Comma-delimited file Text file (also known as a comma-separated, or CSV, file). Report output 
appears as a string of data, separated by commas. 

Select this format if you want to view or print the information in another 
application, for example, a spreadsheet program.

PDF file Report output appears as a PDF that can be printed and saved. 

We recommend that you choose this format if you plan to archive reports.
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Step 6 Click Generate Report.

Step 7 View the report output, depending on the file format you chose in Step 3:

Web Page Output appears in your browser window.

Comma-delimited File File download dialog box opens, asking whether you want to open or save the 
file.

PDF File File download dialog box opens, asking whether you want to open or save the 
file.
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