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Overview

The Cisco MXE 3500 with Release 3.3 delivers a comprehensive set of media transformation services 
to discover, connect, record, enrich, and deliver video and other forms of rich media. These services 
make video content findable, accessible, and easy to consume anytime, anywhere, on any device. 

This chapter provides an overview of the new features and licensed features available with Release 3.3, 
the Cisco MXE 3500 components, deployment options, transcoding process, and MXE Web UI..

• New Features, page 1-1

• Licensed Features, page 1-2

• Cisco MXE 3500 System Components, page 1-2

• Encode and Transcode Process, Video Pipelines, and Jobs, page 1-3

• Cisco MXE 3500 Web User Interface Overview, page 1-5

New Features
Cisco MXE 3500 Release 3.3 includes the following new features:

• Integrated workflow between Cisco TelePresence Content Server, Cisco MXE 3500, and Cisco 
Show and Share—When Cisco MXE 3500 integration with Cisco TCS is configured, recorded 
videos in Cisco TCS are automatically delivered to the Cisco MXE 3500 for transformation and then 
delivered to Cisco Show and Share for sharing. 

• New ingest formats for VOD—Flash 9 and 10, WebEx (.arf 2.26 and below) files.

• The Video Conversion Interface is enhanced for ease of use. 

• Pulse video analytics for speech and speaker tagging—The Pulse video analytics feature enables 
keyword tagging and speaker identification in video content. The enhanced video content is shared 
through Cisco Show and Share.
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Licensed Features
Table 1-1 describes the Cisco MXE 3500 features that require additional licenses. 

Cisco MXE 3500 System Components
The following sections briefly describe the basic components of the Cisco MXE 3500: 

• Enterprise Control System (ECS), page 1-2

• Configuration and Monitoring (CAM) Service, page 1-3

• Local Control System (LCS), page 1-3)

• Workers, page 1-3

Enterprise Control System (ECS)
The ECS is the software control system that drives all of the intelligence behind the Cisco MXE 3500.

• The ECS controls the entire Cisco MXE 3500.

• The ECS communicates with the SQL database for job/task scheduling, tracking, monitoring, and 
logging.

• The ECS is also responsible for:

– Validating licenses

– Submitting jobs to the Local Control System (LCS), page 1-3

Table 1-1 Cisco MXE 3500 Licensed Features

Licensed Feature Description PIDs

Resource Manager

Resource Node

Enables multiple Cisco MXE 3500 devices to run as a 
single group with one set of user accounts, job profiles, 
licensed features, and user interfaces. 

Enables user-management functionality, such user 
accounts and roles, profile spaces, and user metadata.

• MXE-3500-33RM-K9

• MXE-3500-33RN-K9

Video Conversion 
Interface

Enables an easy-to-use interface for end users to do 
transcoding, post production, and sharing through a portal 
like Cisco Show and Share.

• MXE-3500-UILIC

IP Capture 
(Live Streaming)

Enables the Cisco MXE 3500 to ingest live enterprise TV 
and IPTV feeds and repurpose the content so that it can be 
viewed on a variety of endpoints.

• MXE-3500-LVLIC

Speech to Text Enables the Cisco MXE 3500 to create text transcripts 
from videos.

• MXE-3500-STLIC

Graphics Overlay Enables the Cisco MXE 3500 to embed watermark, 
bumpers, trailers, and text transcripts as text captions. 

• MXE-3500-GRLIC

Pulse Video 
Analytics

Enables keyword tagging and speaker identification and 
sharing through a portal like Cisco Show and Share.

• MXE-PULSE-200

• MXE-PULSE-400P
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– Providing Redundancy/Fault Tolerance in cluster environments

• The ECS runs as a Windows service on the Cisco MXE 3500.

Configuration and Monitoring (CAM) Service
The CAM works along with the ECS. The CAM listens (on port 3051) for incoming requests (new job 
submissions, status requests, configuration related requests, etc.) from the Cisco MXE 3500 UI and Web 
services API. It processes the configuration and monitoring (i.e. status) requests and forwards 
job/license related requests to the ECS for processing.

Local Control System (LCS)
• The LCS is the application that drives all of the encoders and other workers that accomplish tasks, 

such as file management and notification.

• The LCS is “parented” by the Enterprise Control System (ECS), page 1-2.

• The LCS is the “worker ant” of the system; it derives its intelligence from the ECS.

• The LCS runs as a Windows service.

Workers
The following are types of Cisco MXE 3500 workers:

• Preprocessor: the entry point to the system for videos being processed

• Encoder: QuickTime, H.264, MPEG, and WMV

• Distribution worker: FTP, SFTP, and File Copy

• Fileman worker: performs file system cleanup

• Notification worker: HTTP Post or e-mail notifications

Encode and Transcode Process, Video Pipelines, and Jobs
This section includes the following topics:

• Encode and Transcode Process (Live or File > MXE > Transrated), page 1-3

• Data and Video Pipeline, page 1-4

• Running Jobs, page 1-4

Encode and Transcode Process (Live or File > MXE > Transrated)
Decoding, Encoding, and Transcoding Overview

1. File-based video or IP stream is decoded to an uncompressed AVI temp file.

2. This AVI file is written to disk (default behavior) or memory (Immediate Mode).
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3. Encoder specified in the job profile reads the AVI file as a source and outputs the appropriate 
format.

See also: Data and Video Pipeline, page 1-4.

Data and Video Pipeline
Figure 1-1 provides a visual description of the data/video pipeline.

Figure 1-1 Video Pipeline

Running Jobs
A job is a request to the system to encode, decode, and transcode a video.

This section includes the following topics:

• Job Profiles, page 1-4

• Job Submission, page 1-5

• Input Formats (File-Based Inputs), page 1-5

• Output Formats (File Based), page 1-5

Job Profiles

Job profiles are templates that define how jobs should be processed; they can contain part or all of the 
settings, including input and output formats, required to process jobs from beginning to final 
distribution.

The Cisco MXE 3500 comes with a set of default profiles.

See also: Job Profiles
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Job Submission

The following are Cisco MXE 3500 job submission channels: 

• Cisco MXE 3500 User Interface (UI)

• Folder Attendant API

• Video Conversion Interface

See also: Submitting a Job, page 11-1, Automate Job Submission with Folder Attendant, page 11-22, 
Video Conversion Interface (SUI), page 14-43

Input Formats (File-Based Inputs)

• File-Based Inputs

– MPEG1, MPEG-2, MPEG4, WAV, Avid OMF, DV, QuickTime, AVI, WMV, MOD, TOD, MTS, 
Flash 9 and 10, WebEx (.arf) 

• Live

– Time triggers

– IP triggers

– Now

– Duration

Output Formats (File Based)

• Cable VOD

– MPEG-2 Transport Stream, AC3 audio, CableLabs compliant

• Mobile

– 3GP, MPEG4, H264, H263, AAC, AMR, Vidiator™ (partial), PacketVideo™, Apple

• Web

– MP4, Windows Media, Flash 7, Flash 8, QuickTime, MP3, Real

• MPEG-2

– MP@ML, MP@HL, 4:2:2@HL, AC3 audio, Program and Transport Streams, DVD Compliant

Cisco MXE 3500 Web User Interface Overview
The Cisco MXE 3500 web user interface (UI) is described in the following sections:

Note Recommended minimum screen resolution is 1280x1024.

Note The Clear Status button clears custom messages (for example, success or error messages) from the page. 
It does not clear field or job validation messages (for example, missing field messages).
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• Accessing the Cisco MXE 3500 Web UI, page 1-6

UI components 

• Information Panel, page 1-7

• Menu Bar, page 1-8

• Toolbox, page 1-8

• Profile Browser, page 1-9

• Main Window, page 1-9

Note The Cisco MXE 3500 does not support tape job submissions.

Accessing the Cisco MXE 3500 Web UI
Access the Cisco MXE 3500 web UI at http://mxe_IP_address/mxeui/, where mxe_IP_address is the 
hostname or IP address for the Cisco MXE 3500.

On the Log In prompt, enter User Name: admin. Enter the password created during initial configuration, 
or the changed password if you have changed the password from the Cisco MXE 3500 Web UI.

Figure 1-2 Cisco MXE 3500 Login Prompt
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The web UI, shown in Figure 1-3, is the main UI. 

Figure 1-3 User Interface Components

Information Panel
This area provides the following information: 

• Server: Displays the host name of the Cisco MXE 3500. 

• User: Displays the name of the user currently logged into the Cisco MXE 3500. 

• Profile Space: Displays the profile space.

• Logout: Select this link to log out of the Cisco MXE 3500 or log in as a different user. 

• Change Password: Click this link to change the Cisco MXE 3500 web UI admin password. The 
Change Password dialog displays (Figure 1-4). This changes the Cisco MXE 3500 web UI admin 
password only.
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Figure 1-4 Change Password Pop-Up

Menu Bar
The menu bar offers the following options: 

• File: Create a New Profile, Open a Profile, Change Password, or Log Out.

• View: View offers the same options that are available from the Toolbox, page 1-8. Select Customize 
to display or hide user interface components (Navigation column, Toolbox, and Profile Browser). 

• Tools: Reset License Cache: Reset licensing information within the UI application. This option is 
typically performed by an administrator when a Cisco MXE 3500 license is changed / updated on 
the ECS. Choosing the Reset License Cache operation updates the Cisco MXE 3500 UI with the 
latest license information.

• Help: View the software version number, contact Cisco MXE 3500 Technical Support, or read Help 
files. 

Toolbox
The Toolbox is a navigation tool that allows you to quickly view any section:

• Submission: Used to submit File or Live jobs. 

• Profile Management: Used to create and manage component profiles (Preprocessor, Encoder, 
Distribution) and Job Profiles.

• Administration: Used to manage host, system, user and role permissions, profile space, custom 
metadata, Video Conversion Interface (SUI), API, LDAP, and shared folder access settings.

• Monitoring: Used to monitor job status, timed job status, system status, and node health status.

• Reports: Used to create custom status reports.

• Folder Attendant: Used to set up watch folders and track automatically ingested jobs.

Note All functions accessed in the Toolbox can also be accessed from the View menu. 
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Profile Browser
The Profile Browser, shown in Figure 1-5, behaves in the following ways:

• Click Search (next to Filter Text) to populate the results, then click Create New Profile. Note that 
this option is not present if you do not have the correct permissions for profile editing.

• If the current page is Job Submission and the Browse Type is Job Profile, double-clicking on a result 
profile name will select that Job Profile in the Job Submission Job Profile list box. 

• If the current page is Folder Attendant and the Browse Type is Job Profile, double-clicking on a 
Profile in the Results list will select that Job Profile in the Watches Job Profile drop-down.

• If the current page is New Profile or Open Profile and the Browse Type is Job Profile, 
double-clicking on a Profile name will open that Job Profile for editing.

• If the current page is the Job Profile editing page, double-clicking on a profile in the Results list 
(profile types that are not Job Profiles), will select that profile in the Job Profile edit page for 
inclusion in the currently open Job Profile.

• If none of the above conditions are met and you double-click a result task profile name (task profile 
is any non-Job Profile), the chosen profile will be opened for editing in the profile editing content 
page. Note that this behavior will only be active if the user has the correct profile editing 
permissions.

Figure 1-5 Profile Browser

If the Profile Browser is not displayed, depending on your current display, do one of the following: 

• From the main menu, select View > Customize > Toggle Navigation Column

• From the main menu, select View > Customize > Profile Browser 

Main Window
The Main Window displays the page selected from the Toolbox or from the View menu.
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