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For Your Safety 

Explanation of Warning and Caution Icons 

Avoid personal injury and product damage! Do not proceed beyond any symbol 
until you fully understand the indicated conditions. 

The following warning and caution icons alert you to important information about 
the safe operation of this product: 

 You may find this symbol in the document that accompanies this product. 
This symbol indicates important operating or maintenance instructions. 

 You may find this symbol affixed to the product. This symbol indicates a live 
terminal where a dangerous voltage may be present; the tip of the flash points 
to the terminal device. 

  You may find this symbol affixed to the product. This symbol indicates a 
protective ground terminal. 

   You may find this symbol affixed to the product. This symbol indicates a 
chassis terminal (normally used for equipotential bonding). 

 You may find this symbol affixed to the product. This symbol warns of a 
potentially hot surface. 

  You may find this symbol affixed to the product and in this document. This 
symbol indicates an infrared laser that transmits intensity-modulated light 
and emits invisible laser radiation or an LED that transmits intensity-
modulated light. 

Important 

Please read this entire guide. If this guide provides installation or operation 
instructions, give particular attention to all safety statements included in this guide. 
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Safe Operation for Software Controlling Optical 
Transmission Equipment 

If this document discusses software, the software described is used to monitor 
and/or control ours and other vendors’ electrical and optical equipment designed to 
transmit video, voice, or data signals. Certain safety precautions must be observed 
when operating equipment of this nature. 

For equipment specific safety requirements, refer to the appropriate section of the 
equipment documentation. 

For safe operation of this software, refer to the following warnings. 

  WARNING: 

 Ensure that all optical connections are complete or terminated before 
using this equipment to remotely control a laser device. An optical or laser 
device can pose a hazard to remotely located personnel when operated 
without their knowledge. 

 Allow only personnel trained in laser safety to operate this software. 
Otherwise, injuries to personnel may occur. 

 Restrict access of this software to authorized personnel only. 

 Install this software in equipment that is located in a restricted access area. 
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Overview 

The Cisco RF Gateway 1 (RFGW-1) Remote Provisioning Utility (RPU) 
is a Windows-based tool designed to simplify initial provisioning of 
multiple RFGW-1 units in an operator's system.   

Purpose 

This user guide provides the necessary information to install, operate, 
maintain, and upgrade the RPU application. 

Who Should Use This Document 

This document is intended for authorized service personnel who have 
experience working with the RFGW-1 or similar equipment. The 
service personnel should have appropriate background and 
knowledge to complete the procedures described in this document.  

Qualified Personnel 

Only appropriately qualified and skilled personnel should attempt to 
install, operate, maintain, and service this product. 

  WARNING: 

Allow only qualified and skilled personnel to install, operate, 
maintain, and service this product. Otherwise, personal injury or 
equipment damage may occur. 

 

 

 

 

1 Chapter 1 
Introduction 

In This Chapter 

 Features and Benefits ............................................................................. 2 
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Features and Benefits 

Primary Benefits 

The RPU provides the following benefits: 

 Enables mass initial provisioning of RFGW-1 databases in SDV deployments. 
Provisioning of 48 and 96 channel RFGW-1 hardware configurations is 
supported. 

 Enables mass upgrade provisioning of RFGW-1 databases from 48 channels 
to 96 channels. 

 Enables bulk provisioning of run-time port and channel control settings. 

 Generates configuration files in JavaScript Object Notation (JSON) format for 
export. 
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This chapter describes the components for provisioning the RPU.  
 

 

 

2 Chapter 2 
Provisioning 

In This Chapter 

 Before You Begin ..................................................................................... 4 

 Provisioning Overview .......................................................................... 5 
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Before You Begin 
Before you begin, make sure to check the following: 

 Your server is running Windows XP or Windows 7. 

 Microsoft Office Excel 97 or later must be installed on the server.  

 You have the RPU distribution CD or have downloaded the RPU installer. 

 You can connect to the Cisco product server. 
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Provisioning Overview 
The RPU merges a common reference database with unique parameters such as IP 
address, Transport Stream Identifier (TSID), and frequency information from a SDV 
Design File to generate and distribute configuration files for each RFGW-1. These 
operations can also be performed on a per-QAM basis by accessing the embedded 
Web GUI of the RFGW-1. 

The following diagram provides an overview of the RPU application. 

 

The RFGW-1 provisioning parameters are stored internally in .xml database format. 
The provisioning parameters are usually manipulated either using the Web GUI or 
via SNMP sets. 

The RPU uses provisioning data configured in an SDV Design File to create the 
internal .xml RFGW-1 database files. The SDV Design File uses a Microsoft Excel 
spreadsheet. The RPU accesses the SDV Design File and creates RFGW-1 formatted 
database files. These database files are then uploaded via FTP to the RFGW-1. 
 

Reference Database 

The Reference Database is used by the RPU as a template for all RFGW-1 initial 
provisioning settings not configured by the RPU. The Reference Database is 
configured via the Web GUI by the customer on an arbitrarily selected "reference" 
RFGW-1. The RPU imports the database files from the reference RFGW-1. These 
database files will then be used by the RPU to create the database files for each 
RFGW-1 selected. 
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SDV Design File 

SDV Design Files are commonly used by SDV customers to maintain an accounting 
of configuration parameters and service group associations for the various devices in 
the network. The SDV Design File was originally conceived to capture legacy SDV 
Server/GQAM networks in a single common file that could be shared between Cisco 
network engineering and customers. The SDV Design File now supports USRM and 
RFGW-1.   

SDV Design Files have multiple tabs offering various perspectives of how SDV 
equipment is arranged hierarchically into headends, hubs, and service groups. 
Generally, there is a single tab that itemizes all hubs in a network by location name, 
followed by a series of sheets detailing the QAM/service group associations 
including frequency, and TSID assignments. 

1st Generation SDV Design File 

The following worksheet shows a GQAM arrangement in the 1st generation SDV 
Design File. To capture the striping plan of various physical RF ports, GQAM chassis 
are organized in columns (vertically), while service groups are organized across 
rows (horizontally). 
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2nd Generation SDV Design File 

The following sections describe the five tabs of the SDV Design File.   

Hub_Info Sheet 

The following worksheet shows the Hub_Info sheet. 

 

 

RFGW-1 QAMS and System Sheet 

The QAMS and System sheet corresponds to the QAMS and System tabs on the 
RFGW-1 GUI. These tabs are included in the SDV Design File as a common location 
to facilitate communication and discussion regarding an operator's preferences for 
the settings in the Reference Database. Either Cisco network engineering or an 
operator can fill out the parameters in these tabs and share the file with various 
stakeholders. 

Use of these tabs is optional. Currently, neither the RPU nor any other tool reads 
these parameters from the SDV Design File. They are included only for discussion 
and accounting purposes. 
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The following worksheets show the QAMS and System sheets. 

QAMS Sheet 
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System Sheet 
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Device_Info Sheet 

The Device_Info sheet is the primary configuration used for RPU data.  

The following worksheet shows the Device_Info sheet. 

 

The RPU data is divided into two major sections:  

 Identification and IP Configuration 

 Port and Channel Frequency and TSID Configuration 

The following parameters are included in Identification and IP Configuration: 

 Headend – Name of the Headend the RFGW-1 is configured with on the 
network. 

 Hub – Name of the installation location. 

 Equipment Name – Name of the RFGW-1 configured for the equipment name 
database field. 

 Management IP, Gateway, Mask, MAC – IP configuration parameters for the 
management port. 

 Port IP, Mask, Virtual IP – GbE input port IP configuration parameters. 
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Note: If the value for any of the Virtual IP address fields is set to independent, 
the database field GbE Data Port Mode will be set to Four Port Independent. 

 QAM Type – Identifies the type of QAM device. GQAM and RFGW-1 are the 
only supported types. 

Note: The RPU will not create databases or configure GQAM type devices. 
GQAM configuration data will be used in the Data Integrity Tests, and the 
GQAM data will be displayed in the RPU data display dialogs. 

 Max QAM – Identifies the number of QAM channels for the entire device. 48 or 
96 are the supported values. 

The following parameters are included in Port and Channel Frequency and TSID 
Configuration: 

 SG ID – Service Group ID to which this port is assigned.  

Note: This SGID must be configured in the SG_Info sheet. 

 Primary USRM – Name of the Primary USRM (SDV Server) to which this port is 
configured. 

 Backup USRM – Name of the Primary USRM (SDV Server) to which this port is 
configured. 

 Freq 1 – The base frequency assigned to channel 1. 

Note: This frequency must be a standard frequency. 

 TSID 1 to 4 – The TSID assignments for TSID settings for channels 1 to 4. 

 Freq 5 – The base frequency assigned to channel 1. 

Note: This frequency must be a standard frequency. 

 TSID 5 to 8 – The TSID assignments for TSID settings for channels 5 to 8. 
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SG_Info Sheet 

The SG_Info sheet is used to configure SDB Service Group information. The 
following parameters must be configured for use by the RPU:  

 SGID 

 SG Name 

 Primary SDV Server  

The other parameters are used for other system configuration purposes. The RPU 
requires that any service group listed on the Device_Info sheet be defined in the 
SG_Info sheet. 

The following worksheet shows the SG_Info sheet. 

 

3rd Generation SDV Design File 

The 3rd generation SDV design file contains all of the information provided in the 
2nd generation design file plus a new D6_Info sheet. The 3rd generation design file 
also replicates QAM details for each RFGW-1 in the RFGW-1 QAMS sheet. 
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Note: 

 In the 2nd generation design file, RFGW-1 QAMS sheet is used for reference 
only; these fields are not manipulated. 

 If the latest version of RPU1 is imported with a 2nd generation design file, it will 
display the message shown below and disable the controls for JSON file export 
as described in Generating the JSON File (Phase 2 Step 2e) (on page 31). 

 

 

RFGW-1 QAMs Sheet 

The fields on this sheet are the same as those in the corresponding sheet in the 2nd 
generation design file, but with the addition of fields used to generate a JSON file 
that can be exported via HTTP POST method. 

All fields that are color-coded green are mandatory, and each RFGW-1 should have 
an entry in these fields. All other fields can be ignored. 

The QAM details for each RFGW-1 are divided into two groups. One group contains 
RFGW-1 RF Port details, and the other contains RFGW-1 channel details. 

The Port group includes the following parameters: 

 RF Port – Port ID of RFGW-1. 

 Port Control – Possible values are On or Off. 

 Spacing – Defaults to 6 MHZ for all channels. 

 Modulation – Possible values are QAM64 or QAM256. 

 Output Level – Power level in dBmV of the QAM channel. 

 Symbol Rate – Symbol rate of the QAM channel. 

 Combined Carrier – Number of channels going out from the port. Possible 
values are None, Single, Dual, Triple, or Quad. 

The Channel group includes the following parameters: 

 QAM Channel – Channel ID of RFGW-1. 

 ON ID – ON ID assigned for each channel in the RFGW-1. 

 Mode – Possible values are Normal, Mute, or CW. 
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 Spectrum Inversion – Possible values are Normal or Swap. 

 PRBS Stuffing – Possible values are On or Off. 

 Application Mode – Mode in which the RFGW-1s QAM channel should act. 
Possible values are VoD Only, Broadcast Only, SDV Only, or Shared. 

 Interleave Depth – Interleave Depth of a given QAM channel. 

 PMT Rate – Rate at which the PMT table should be generated in the output TS. 

 PAT Rate – Rate at which the PAT table should be generated in the TS. 

 QAM Status – Required field; possible values are OPERATIONAL, OFFLINE, or 
QUIESE. 

The following worksheet shows the RFGW-1 QAMS sheet. 

 

D6_Info Sheet 

This sheet contains the details of the edge device. 

The Channel group includes the following parameters: 

 Equipment Name – Name of the edge device; should match the Equipment 
Name value in the Device_Info sheet. 

 Controller Name and Controller Id – User-configurable entry for the controller. 

 Model Name – Name of the model configured via the GQI model; should be 
UniQAM. 

 Streaming Zone – Streaming zone assigned to the QAM. 

 Annex – ITU mode in which the QAM is working. 
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 Device Status – Operational status of the entire edge device. Possible values are 
OPERATIONAL, OFFLINE, or QUIESE. 

 Name (of Port) – Name assigned to the port of the edge device. 

 MAC Address (of port) – MAC address of the port of the edge device. 

 Bandwidth (of port) – Bandwidth of the port in kbps. 

 Status (of port) – Operational status of the port. Possible values are 
OPERATIONAL, OFFLINE, or QUIESE. 

The following worksheet shows the D6_Info sheet. 
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This chapter describes how to install and operate the RPU. 
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Installing the RPU 
Before installing a new version of the Cisco RPU, you must first uninstall any older 
versions present on the system. 

Uninstalling the Old RPU 

1 On the windows menu, choose Start > Control Panel. 

2 Double-click Add or Remove Programs. 

The program window is displayed. 

3 Highlight the Cisco RFGW Remote Provisioning Utility and click Remove. 

If the RPU uninstall programs asks if you want to remove shared components, 
click Remove All. 

Installing the New RPU 

1 Insert the RPU Installation CD. Contact your RFGW-1 product manager for 
installation CD. 

The following dialog box is displayed. 

Note: If the installer warns that your computer has a more recent version of a 
component being installed, select the option to not install the older component. 
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2 Click OK. 

The following dialog box is displayed. 

 

3 Click the Computer button to start the installation. 

The following dialog box is displayed. 
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4 Click Continue. 

The following dialog box is displayed (depending upon your computer's 
configuration). 

 

5 Click Yes. 

The following dialog box is displayed. 

 

6 Click OK. 

The installation is complete. 
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Initial Provisioning Mode 
The RPU can perform initial provisioning for both 48 and 96 channel RFGW-1 
models. The RPU uses the MAX QAM column of the Device_Info tab of the SDV 
Design File to determine whether the RFGW-1 is intended to be provisioned with 48 
or 96 channels of data.  
 

Importing Provisioning Parameters 

Before starting the provisioning procedure, you must import the Reference Database 
and the SDV Design File. Refer to Importing Reference Database (Phase 1 Step 1c) 
(on page 23) and Importing SDV Design File Spreadsheet (Phase 1 Step 1d) (on page 
24). 
 

Configure RPU Repository Location (Phase 1 Step 1a) 

This feature configures the disk file location where the RPU maintains all of the files 
created and referenced by the RPU. You can locate the RPU repository on a shared 
network drive if desired. 

Configuring the Repository Location 

1 Click Set RPU Repository Dir Path and enter the location of the repository path. 

 

2 Click Test RPU Repository Dir Path. 

This test indicates whether the RPU repository is present and ready for running 
the RPU. 

3 Click Set User Name and enter desired name in the User Name window.  

This name is logged in the RPU log file. 
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Creating Reference Database (Phase 1 Step 1b) 

You must create reference databases to capture all desired provisioning parameters 
that are not included in the SDV Design File spreadsheet. The RPU maintains 
separate reference databases for 48 and 96 channel RFGW-1 models. You must 
identify an appropriate RFGW-1 to be used as the reference for each model. 

Creating the Reference Database 

1 Select the Initial Configuration Mode option. 

 

2 Select the RFGW-1 to be configured during this session.  

Note: In this example, both models are selected. Either one or both of the RFGW-
1 units may be referenced in this step. 

3 Enter the management IP address of the reference unit(s).  

Note: The reference unit must be online to complete this step. 

4 For each unit, click Display Reference RFGW in Browser. 

The RF Gateway Web GUI is displayed. 

5 Configure all common and control parameters.  

Note: Settings such as IP addresses, frequencies, and TSIDs will be overwritten 
with information contained in the SDV Design File spreadsheet. 

6 Click Apply after all settings.   

7 Click Save. This saves all reference database settings to the RFGW-1 database 
files. 

8 Check the Reference Database on Selected RFGW is Ready check box.  

The reference database is ready for collection to the RPU repository. 
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9 Repeat as needed for all RFGW-1 units. 
 

Importing Reference Database (Phase 1 Step 1c) 

There are two options to choose from when importing the reference database: Copy 
Local File or Ftp File From RFGW. We recommend the FTP option. 

Importing the Reference Database 

1 From the Import Method drop-down list, choose Ftp File From RFGW. 

The RPU copies the reference database files from the RF Gateway unit to the 
RPU repository. 

 

2 Click Import Db.   

The RPU copies the RFGW-1 database files from the RFGW-1 unit and imports 
them to the RPU file repository. Progress can be seen in the window to the right 
of the Import Db button. 

3 Repeat as needed for all RFGW-1 models. 
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Importing SDV Design File Spreadsheet (Phase 1 Step 1d) 
1 Click Locate Excel Workbook. 

 

A Windows Open dialog menu opens. 

2 From the Windows menu, browse to the spreadsheet to import. 

3 In the RPU worksheet, click Import Data. 

The RPU extracts all the required data from the spreadsheet and displays the 
Hub names in the Hub List dialog box.  

Note: It may take several minutes to import large files. 

4 To run any or all of the Data Integrity Tests, click the box next to the test. 

5 Click Run Data Rule Tests.  

The results are listed in the RFGW Data Rule Messages list.  
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Note: You can double-click the log report to create a text log file. The RPU 
automatically displays the created log file in the default text editor. 
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Creating Databases and Programming the RFGW-1 
After the provisioning data has been imported, the user is ready to create databases 
and program the RFGW-1 devices. 
 

Verifying SDV Design File Spreadsheet Configuration Data (Phase 2 Step 2a) 

This step allows you to manually verify configuration data imported from the SDV 
Design File spreadsheet. Make sure to check all imported data for each unit.  

Verifying the SDV Design File Spreadsheet Configuration Data 

1 From the Select Hub list, choose the desired hub. 

All RFGW-1s are displayed for this hub. 

 

Note: You can choose how information is displayed by choosing the following 
options from the drop-down list: 

 RFGW 

 Service Group 

 SDV Server 

2 From the Select RFGW list, choose one or more units to display and verify.  

The RFGW Port List list displays the configuration data for the RF outputs of the 
unit(s) selected. The RFGW Video IP Info list displays the configuration data for 
the GbE inputs. 

3 Once the data has been verified as accurate, click Data OK. 
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Creating RFGW-1 Configuration Database (Phase 2 Step 2b) 
1 From the Select HUB list, choose the desired hub to configure.  

All units configured for this hub are displayed in the Select RFGW list. 

 

2 Highlight the unit(s) for which you want to create a configuration database.  

The Status of Db Update list displays the configuration data for all unit(s) 
selected.  

Note: To create databases for more than one unit, hold down the CTRL key and 
click an additional list element, or hold down the SHIFT key to select a range of 
units.  

3 Click Create Configuration DB File. 

The configuration database files are created for each unit selected. 

Note: If you select a single RFGW, the RPU displays the current status of each step in 
the database creation, programming, and verification process.  
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Programming the RFGW-1 with Configuration Database (Phase 2 Step 2c) 

Note: There are two options for programming a list of RFGW-1s. These options are 
configured using the Configure menu.  

1 Select RFGW Reboot Options and Limits.  

 

The following options are available: 

 Asynchronous – Programs each RFGW-1 and does not wait for the unit to 
reboot. The unit will be continuously pinged until it responds. The ping 
status displays the IP addresses and their response status. This is the default 
mode. 

 Synchronous – Programs each RFGW-1 and waits for each unit to reboot.  

Note: For multiple units, the preferred selection is likely to be Asynchronous 
mode. 

2 From the Hub List list, choose the desired hub.   

All units configured for this hub are displayed. 

 

3 In the Select RFGW list, highlight the unit(s) to be programmed. 

Note: To program more than one unit, hold down the CTRL key and click an 
additional list element, or hold down the SHIFT key to select a range of units. 
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4 Click Ping Selected. 

The RPU pings each unit selected and displays the results in the status log 
window. 

Note: If an RFGW does not respond to the ping, it will not be able to be 
programmed.  

5 Click Check SW Version.  

The RPU collects the software version from each selected RFGW-1. 

This software version is compared to the version of the RFGW-1 that provided 
the Reference Database. If the versions do not match, the RFGW-1 will not be 
programmed. This check is meant to prevent the user from configuring RFGW-1 
units with databases that are incompatible with certain software releases. If the 
versions do not match, please contact your local Cisco account team for 
assistance. 

Note: There is an option on the Configure menu to override this default action, 
but this option is not recommended. 

6 If desired, click Display Selected RFGW in Browser. 

This permits the user to watch the RFGW-1 reboot. If multiple units are selected, 
only the last unit will be launched in a browser window. 

7 Click Start RFGW Programming. 

Programming status is displayed in the window. 
 

Verifying RFGW Programming Data (Phase 2 Step 2d) 

This step verifies that the configuration data has been correctly programmed into the 
RFGW-1. 

Verifying RFGW Programming Data 

1 From the Hub List list, choose the desired hub.  
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All RFGW-1s configured for this hub are displayed. 

 

2 Select a single unit to verify.   

The selected RFGW-1 configuration is displayed.  

3 Choose from the following five optional verification techniques. 

 Manual Verify. Displays the RFGW-1 in a browser and uses the GUI interface 
to compare configuration data displayed for the selected RFGW-1. 

Note: You can choose View=>Selected RFGW in Browser from the drop-
down menu to display the currently selected RFGW-1. 

 Auto Verify. Active DB against Created DB. This option collects active 
database files from the RFGW-1 and compares the contents to the database 
files created by the RPU. This process determines if the RFGW-1 has been 
modified since the RPU programmed the unit. 

 Auto Verify. Active DB against SDV Design File. This option collects the 
active database files from the RFGW-1 and compares the contents to the SDV 
Design File spreadsheet at the time it was last imported into the RPU. This 
process determines if the RFGW-1 configuration has been modified and does 
not match the SDV Design File spreadsheet, or if the SDV Design File 
spreadsheet has been modified and imported without updating the RFGW-1. 

 Auto Verify. Created DB against SDV Design File. This process determines if 
the SDV Design File spreadsheet has been modified and imported since the 
creation of the RFGW-1 database. 

 Auto Verify. Created DB against in-Memory DB. This process determines if 
the in memory RFGW-1 settings have been modified since the RPU created 
the RFGW-1 database. 
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4 Click Auto Verify. 

The status is displayed in a window. 

5 If all verification tests passed, click Verify OK. 

The RFGW status display shows the RFGW-1 as verified. 
 

Generating the JSON File (Phase 2 Step 2e) 

This step generates the configurations in JSON format and exports the configuration 
file to a server using the HTTP POST method. 

Note: If the server to which the JSON file is exported does not successfully receive 
and handle the file, the tool with generate a timeout error. 

Generating the JSON File 

1 Import the Excel sheet as described in Importing SDV Design File Spreadsheet 
(Phase 1 Step 1d) (on page 24). 

Note: If a 2nd generation design file is imported, all controls will be disabled as 
shown below. 

 



 

Chapter 3    Installation and General Operation  
 
 

32 OL-30564-01 

2 Click 2e) Generate JSON File. The Generate JSON File screen opens as shown 
below. 

 

3 Choose a hub from the Hub List list. 

4 Choose one or more RFGW-1s from the Select RFGW list. 

5 Click Generate JSON File. 

The tool generates a JSON file containing the QAM configurations of the selected 
RFGWs. Progress is reported in the status area of the window, as shown below. 
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6 Click Open JSON File to open the generated JSON file and confirm that the file 
was generated successfully. The file opens in a simple notepad application, as 
shown below. 

 

7 Click POST JSON to <servername> to send the content of file to the server. 

8 When prompted by the pop-up window, enter the IP address of the server. 

Note: 

 Before sending the file, RPU1 displays the content of the POST request to be 
sent. 

 Progress of the export is reported in the status area of the window. 

9 Monitor the status area of the window and confirm that the export completes 
successfully. 
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RFGW-1 Bulk Provisioning 
The RPU provides a bulk provisioning feature to configure specific settings on one 
or more RFGW-1s. This provisioning is accomplished via SNMP and does not 
require the system to reboot. 
 

Set Port Power/Port Control Levels (Step 3a) 

This feature provides a mechanism to bulk provision one or more RFGW-1 RF port 
power or port control levels. 

Setting Port Power or Port Control Levels 

1 From the Hub List list, choose the desired hub.  

All units configured for this hub are displayed. 

 

2 From the Select RFGW list, choose the unit for which you would like to set 
power/port control levels.  

Note: To display data for more than one unit, hold down the CTRL key and click 
an additional list element, or hold down the SHIFT key to select a range of units. 

3 From the Select Ports list, choose the port to configure. 
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4 Do one of the following as appropriate: 

 To set the port power level, enter the port power setting (in dB) in the field, 
and then check the Set Power is Active check box. 

 To set the port control setting, choose on or off from the drop-down list, and 
then check the Set Port Control is Active check box. 

5 Click Send Update. 

The status log displays the results of all SNMP set commands. 
 

Set Combined Channels (Phase 3 Step 3b) 

This feature allows the user to bulk provision one or more RFGW-1 RF port 
combined channels. 

Setting Combined Channels 

1 From the Hub List list, choose the desired hub. 

All units configured for this hub are displayed. 

 

2 From the Select RFGW list, choose the unit for which you would like to set 
combined channels.  

Note: To display data for more than one unit, hold down the CTRL key and click 
an additional list element, or hold down the SHIFT key to select a range of units. 
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From the Select Ports list, choose the desired port to configure, or to choose multiple 
ports, click one of the following options located under the Select Ports list: 

- All 

- Group 1 

- Group2 

1 Click Send Update. 

The status log displays the results of all SNMP set commands. 
 

Set Channel Mute 

This feature allows the user to bulk provision one or more of the RF Gateways port 
channel mute setting. 

Setting Channel Mute 

1 From the Hub List list, choose the desired hub. 

All units configured for this Hub are displayed. 

 

2 From the Select RFGW list, choose the unit for which you would like to set 
channel mute.  

Note: To display data for more than one unit, hold down the CTRL key and click 
an additional list element, or hold down the SHIFT key to select a range of units. 

3 From the Select Ports list, choose the desired port to configure. 

4 From the Select Chans list, choose the port channels to configure. 
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5 Choose the channel mute state from the Set Channel Mute drop-down list. 

6 Check the Set Channel Mute is Active check box. 

7 From the channel application mode from the Set App Mode drop-down list. 

8 Check the Set App Mode is Active check box. 

9 Click Send Update. 

The status log displays the results of all SNMP set commands. 
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RPU Menu Options 

File Menu 

The File Menu allows the user to import and export database files. 

 File > Import > Import - Copy DB files 

 File > Export > Export - Copy DB Files 

 File > Exit 
 

View Menu 

The View menu allows the user to perform the following tasks. 

 View > Excel Workbook. Opens the workbook configured in the "Import 
Excel Workbook" path in Step 1.c in Microsoft Excel. 

 View > Selected RFGW in Browser. Displays the current RFGW-1 Web GUI 
in the default browser. If more than one unit is selected, the last one in the list 
is displayed. 

 View > Database Files - Database Files - XML Viewer. The RPU has a built-in 
XML viewer dialog. The XML information can be navigated via a tree view. If 
the XML is badly formed, the viewer presents a warning and will not display 
the XML data. 

 Ref 48 Chan DB. Displays the RFGW-1 reference database file configured for 
the 48 channel RFGW-1 models. 

 Ref 48 Chan One Time DB. Displays the RFGW-1 one-time database file 
configured for the 48 channel RFGW-1 models. 

 Ref 96 Chan DB. Displays the RFGW-1 one-time database file configured for 
the 96 channel RFGW-1 models. 

 Ref 96 Chan One Time DB. Displays the RFGW-1 one-time database file 
configured for the 96 channel RFGW-1 models. 

 Selected RFGW DB. Displays the RFGW-1 reference database file configured 
for the currently selected RFGW-1. 

 Selected RFGW One Time DB. Displays the RFGW-1 one-time database file 
configured for the currently selected RFGW-1 models. 

 View > Database Files - Database Files - Text Viewer. Same choices as with 
the XML Viewer. 
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Configure Menu 

The Configure Menu allows you to configure the following. 

 RFGW FTP Account Information - The RPU must have the FTP account 
information to log onto the RFGW-1. 

 

 RFGW Reboot Options and Limits - The RPU must reboot the RFGW-1 to 
get the new database files created by the RPU to become the active database 
files. The following parameters configure the actions and timeouts for reboot. 

– Wait for reboot after uploading DB - Checking this box configures the 
RPU to wait for an RFGW-1 to completely reboot after the programming 
action before continuing on to any other RFGW-1s selected to be 
programmed. 

– Wait Reboot Start Limit (sec). Number of seconds to wait for the RFGW-1 
to start the reboot process. If the RFGW-1 has not started the reboot 
process after the amount of seconds displayed, this is considered a 
failure. 

– Wait Reboot Done Limit (sec). Number of seconds to wait for the RFGW-
1 to complete the reboot process. If the RFGW-1 has not completed the 
reboot process after the amount of seconds displayed, this is considered a 
failure. 
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– Wait After Reboot Done (sec). Number of seconds to wait after the 
RFGW-1 reboots before continuing with processing. The RPU uses a ping 
command to determine if the RFGW-1 rebooted. This extra wait time 
after the ping has responded allows other RFGW-1 services to become 
operational. 

 

 Reference SW Version Match Override - The RPU compares the software 
versions of the RFGW-1 being programmed and the reference RFGW-1. If the 
versions do not match, the RPU will not program the RFGW-1 unless the 
Override Reference SW Match option is selected. 

 

 Lower 48 Frequencies and TSIDs in Upgrade to 96 Channels - The default 
action when in upgrade mode is to only update the upper 48 channels with the 
Frequency and TSID information configured into the SDV Design File 
spreadsheet. This option permits the upgrade of the RFGW-1 database files to 
include the lower 48 Frequency and TSID information as well. This can be useful 
on a network where a new frequency and/or TSID plan is part of the network 
upgrade process. 
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Help Menu 

The Help Menu allows the user to view the following tasks. 

 Help > Manual. Displays the RPU manual document. 

 Help > About. Displays the About dialog that contains the RPU version 
information. 
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Introduction 

This chapter contains information on obtaining product support. 

Obtaining Product Support 

IF… THEN… 

You have general questions about 
this product 

Contact your distributor or sales 
agent for product information or 
refer to product data sheets on 
www.cisco.com. 

You have technical questions about 
this product 

Contact the nearest Technical 
Support center. 

You have customer service questions 
about this product  

Contact the nearest Customer Service 
center. 

 

 

 

4 Chapter 4 
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E 

ECM 

Entitlement Control Messages. 
 

ECMG 

Entitlement Control Message Generator. 
 

EIS 

Event Information Scheduler. 
 

EMM 

Entitlement Management Messages. 
 

ES 

Elementary Stream. 
 
F 

FTP 

File Transfer Protocol. Allows users to transfer text and binary files to and from a personal 
computer, list directories on the foreign host, delete and rename files on the foreign host, and 
perform wildcard transfers between hosts. 

 
G 

GUI 

graphical user interface. A program interface that takes advantage of a computer graphics 
capabilities to make the program visually easier to use. 

 
H 

HTML 

Hypertext Markup Language. 
 

HTTP 

Hypertext Transfer Protocol. 
 
I 

Glossary 
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IP 

Internet Protocol. A standard that was originally developed by the United States Department 
of Defense to support the internetworking of dissimilar computers across a network.  IP is 
perhaps the most important of the protocols on which the Internet is based. It is the standard 
that describes software that keeps track of the internetwork addresses for different nodes, 
routes, and outgoing/incoming messages on a network. Some examples of IP applications 
include email, chat, and Web browsers. 

 

IP address 

Internet protocol address. A 32-bit sequence of numbers used for routing IP data. Each IP 
address identifies a specific component on a specific network. The address contains a network 
address identifier and a host identifier. 

 

ISO 

International Organization for Standardization. An international body that defines global 
standards for electronic and other industries. 

 
J 

JSON 

JavaScript Object Notation. A data interchange format based on a subset of the JavaScript 
programming language and designed for ease of composition and parsing. JSON is a text 
format that is language-independent but uses conventions resembling those of C-family 
languages. 

 
P 

PC 

personal computer. 
 
Q 

QAM 

quadrature amplitude modulation. An amplitude and phase modulation technique for 
representing digital information and transmitting that data with minimal bandwidth. Both 
phase and amplitude of carrier waves are altered to represent the binary code. By 
manipulating two factors, more discrete digital states are possible and therefore larger binary 
schemes can be represented. 

 
R 

RADIUS 

Remote Authentication Dial-In User Service. A networking protocol that provides centralized 
Authentication, Authorization and Accounting (AAA) management for computers to connect 
and use a network service. 

 

RF 

radio frequency. The frequency in the portion of the electromagnetic spectrum that is above 
the audio frequencies and below the infrared frequencies, used in radio transmission systems. 
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RMA 

return material authorization. A form used to return products. 
 

RPU 

Remote Provisioning Utility. 
 

RU 

rack unit. RU is the measuring unit of vertical space in a standard equipment rack. One RU 
equals 1.75" (44.5 mm). 

 
S 

SCG 

Scrambling Control Group. 
 

SCS 

Simulcrypt Synchronizer. 
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