
http://www.cisco.com/go/sba
http://www.cisco.com/go/sba


DEPLOYMENT
GUIDECOLLABORATIONSBA

S M A R T  B U S I N E S S  A R C H I T E C T U R E

August 2012 Series

Help Desk Using Cisco UCCX 
Deployment Guide



PrefaceAugust 2012 Series

Preface

Who Should Read This Guide
This Cisco® Smart Business Architecture (SBA) guide is for people who fill a 
variety of roles:

•	 Systems engineers who need standard procedures for implementing 
solutions

•	 Project managers who create statements of work for Cisco SBA 
implementations

•	 Sales partners who sell new technology or who create implementation 
documentation

•	 Trainers who need material for classroom instruction or on-the-job 
training

In general, you can also use Cisco SBA guides to improve consistency 
among engineers and deployments, as well as to improve scoping and 
costing of deployment jobs.

Release Series
Cisco strives to update and enhance SBA guides on a regular basis. As 
we develop a series of SBA guides, we test them together, as a complete 
system. To ensure the mutual compatibility of designs in Cisco SBA guides, 
you should use guides that belong to the same series.

The Release Notes for a series provides a summary of additions and 
changes made in the series. 

All Cisco SBA guides include the series name on the cover and at the 
bottom left of each page. We name the series for the month and year that we 
release them, as follows:

month year Series

For example, the series of guides that we released in August 2012 are  
the “August 2012 Series”.

You can find the most recent series of SBA guides at the following sites:

Customer access: http://www.cisco.com/go/sba

Partner access: http://www.cisco.com/go/sbachannel

How to Read Commands
Many Cisco SBA guides provide specific details about how to configure 
Cisco network devices that run Cisco IOS, Cisco NX-OS, or other operating 
systems that you configure at a command-line interface (CLI). This section 
describes the conventions used to specify commands that you must enter.

Commands to enter at a CLI appear as follows:

configure terminal

Commands that specify a value for a variable appear as follows:

ntp server 10.10.48.17

Commands with variables that you must define appear as follows:

class-map [highest class name]

Commands shown in an interactive example, such as a script or when the 
command prompt is included, appear as follows:

Router# enable

Long commands that line wrap are underlined. Enter them as one command:

wrr-queue random-detect max-threshold 1 100 100 100 100 100 
100 100 100

Noteworthy parts of system output or device configuration files appear 
highlighted, as follows:

interface Vlan64
  ip address 10.5.204.5 255.255.255.0

Comments and Questions
If you would like to comment on a guide or ask questions, please use the 
SBA feedback form.

If you would like to be notified when new comments are posted, an RSS feed 
is available from the SBA customer and partner pages.

http://ciscosba.com/feedback/?id=Aug12-415


Table of ContentsAugust 2012 Series

What’s In This SBA Guide  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .1

Cisco SBA Collaboration . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1

Route to Success . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1

About This Guide . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1

Introduction  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .2

Business Overview . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2

Technical Overview  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2

Deployment Details  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .5

Preparing the Platform for Unified CCX . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5

Installing Cisco Unified CCX . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8

Configuring the Help  Desk  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 16

Configuring the Client Desktop Software  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 25

Appendix A: Product List   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 29

Appendix B: Changes  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 30

Table of Contents



About This Guide
This deployment guide contains one or more deployment chapters, which 
each include the following sections:

•	 Business	Overview—Describes the business use case for the design. 
Business decision makers may find this section especially useful.

•	 Technology	Overview—Describes the technical design for the  
business use case, including an introduction to the Cisco products that 
make up the design. Technical decision makers can use this section to 
understand how the design works.

•	 Deployment	Details—Provides step-by-step instructions for deploying 
and configuring the design. Systems engineers can use this section to 
get the design up and running quickly and reliably.

You can find the most recent series of Cisco SBA guides at the following 
sites: 

Customer access: http://www.cisco.com/go/sba

Partner access: http://www.cisco.com/go/sbachannel

What’s In This SBA Guide

Cisco SBA Collaboration
Cisco SBA helps you design and quickly deploy a full-service business 
network. A Cisco SBA deployment is prescriptive, out-of-the-box, scalable, 
and flexible. 

Cisco SBA incorporates LAN, WAN, wireless, security, data center, application 
optimization, and unified communication technologies—tested together as a 
complete system. This component-level approach simplifies system integration 
of multiple technologies, allowing you to select solutions that solve your  
organization’s problems—without worrying about the technical complexity.

Cisco SBA Collaboration is a design incorporating unified communications, 
video collaboration, and web conferencing. By building upon the hierarchical 
model of network foundation, network services, and user services,  
Cisco SBA Collaboration provides dependable delivery of business  
applications and services.

Route to Success
To ensure your success when implementing the designs in this guide, you 
should first read any guides that this guide depends upon—shown to the 
left of this guide on the route below. As you read this guide, specific  
prerequisites are cited where they are applicable.

1What’s In This SBA GuideAugust 2012 Series

Collaboration Design Overview Telephony Using Cisco UCM
Deployment Guide

Help Desk Using Cisco UCCX
Deployment Guide
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Introduction

Business Overview
The ability to easily add functionality into the telephony environment for 
corporate help desks has been challenging. Organizations use help desks 
in their Human Resources departments to answer personnel questions, in 
IT departments to help employees with their computer problems, and in 
their facilities departments to maintain and manage their buildings. A help 
desk helps to minimize the time it takes to answer employees’ questions and 
maximize the available internal resources.

Traditional contact center solutions are difficult to implement because of 
the additional hardware components and the complexity of the software 
needed to implement them.  The work is normally done by highly trained 
engineers who spend the majority of their time working with contact centers.  
The complexity makes the implementation a long process and the addi-
tional expertise makes the installation and maintenance quite expensive.  
Agents are required to work at the location of the contact center equipment 
because the inherent limitations of the hardware prevent them from working 
remotely.  It is very difficult to integrate the overall system with the corporate 
data because common interfaces are not readily available.

Technical Overview 
The next-generation IP help desk takes advantage of a company’s internal 
network by making use of the IP private branch exchange (PBX) and other 
IP-based applications to create a better experience for the callers. Calls 
are routed to available agents who have the expertise to answer the ques-
tions, regardless of their physical location in the company. Agents can view 
information about the caller through integration with corporate databases; 
and historical data is saved and viewed in easily readable reports that help 
improve the day-to-day workings of the help desk. These are just a few of 
the benefits offered by a fully integrated IP help desk.

Cisco Unified Contact Center Express (Unified CCX) is the IP-based help 
desk solution offered by Cisco Systems. It is tightly integrated with other 
Cisco Unified Communications platforms. Design and testing is performed 
on the suite of Unified Communications products as part of a complete solu-
tion. Configuration of Unified CCX is easier than traditional systems because 

the components talk to each other over the internal IP network, which helps 
streamline the procedures. For example, when a phone number is created 
on Unified CCX to reach a help desk application, no additional configuration 
is needed in the Cisco Unified Communications Manager (Unified CM). 
The configuration is sent over the network to Unified CM and the directory 
number is created. Unified CM is automatically configured to pass calls for 
the directory number to Unified CCX for further processing.

When a call is placed to the help desk, it is first processed by Cisco Unified 
CM, which recognizes that the number is destined for the Cisco Unified 
CCX application server. Unified CCX receives the incoming call and identi-
fies which application script is needed to handle the request based on the 
extension number that was dialed. The script plays prompts and collects 
digits as dictated by the steps in the script and, if necessary, uses the infor-
mation from the caller to select an appropriate agent. If an appropriate agent 
is not available, the call is put in queue and music is streamed to the caller. 
As soon as an agent is available, Unified CCX instructs Unified CM to ring 
the agent’s phone. When the agent picks up, information about the caller is 
populated into the agent’s desktop application and the conversation begins.

Cisco Unified CCX has the features of a large contact center packaged 
into a single- or dual-server deployment. The system scales up to 400 
concurrent agents, 42 supervisors, 150 agent groups, and 150 skill groups. 
It includes email, outbound calling, inbound calling, workforce optimization, 
and reporting. 
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Figure 1 - Typical Cisco Unified CCX deployment in the foundation architecture
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The Cisco Unified CCX features are listed in more detail below:

•	 Automatic	call	distributor	(ACD)—Unified CCX routes calls by using 
skills or resource groups. Skills-based routing distributes the call based 
on the skill level of the agent for a particular topic. It is the method most 
often used. Resource-group routing distributes calls to agents based on 
the resource group to which the agents are assigned. 

•	 Interactive	voice	response	(IVR)—IVR controls the interaction between 
the caller, prompts, and menus. Depending on the options the caller 
enters into the system, IVR uses an application script to determine how 
to handle the call. IVR can read or write corporate database information, 
play information such as tracking numbers to callers, and collect infor-
mation from the caller through digits or speech recognition. 

•	 Agent	Email—Agent Email allows customers to contact the help desk 
by email. Agents are assigned skills, and email is distributed to agents 
based on their skills. Email agents can use preset templates in their 
replies to avoid writing repetitive emails.

•	 Agent	Desktop—Cisco Agent Desktop is an application that resides on 
the agent’s computer. Agents use the application to log in at the begin-
ning of their shifts, indicate whether they are in a ready state or on a 
break, and log out at the end of the day. When an agent is logged in and 
ready, calls are sent to Agent Desktop, which presents information about 
the incoming call. The application has an integrated browser to access 
a customer database or browse the Internet to help answer a question. 
Agent Desktop is a great tool for agents because everything they need 
to do their job is in one place, which allows them to focus on answering 
the caller’s question. 

•	 Supervisor	Desktop—Cisco Supervisor Desktop helps supervisors 
keep track of real-time statistics such as how many calls are in queue, 
the number of agents available, and the average time a caller is spend-
ing in queue. Supervisors can also use Supervisor Desktop to coach 
agents by silently monitoring calls, chatting with agents, joining a call, 
and pushing a webpage down to an Agent Desktop. Supervisor Desktop 
helps supervisors ensure that calls are being handled on a timely basis 
and agents are not giving callers incorrect information. If there is an 
issue, Supervisor Desktop allows them to quickly address the problem.

•	 Reporting—Cisco Unified CCX saves statistics in an internal database 
that can be accessed by the historical reporting client application to cre-
ate reports. Reports can be scheduled on a recurring basis or created 
as needed. Reports can be general, such as information about the entire 
help desk over a year, or specific, such as information about a particular 
agent for one day. Historical reports allow managers to get a big picture 
of their help desk and to make changes to address issues.

•	 Workforce	Management—Workforce Management is a tool that uses 
a sophisticated algorithm to look through historical data and create a 
schedule that will have the right number of agents on staff at the right 
times during the day. This tool helps ensure that more agents are on 
staff at busy times and agents have scheduled breaks during slow times.

•	 Quality	Manager—Quality Manager is a tool that records calls. Quality 
Manager randomly selects calls throughout the day to be recorded, or 
you can select specific calls to record. This tool also creates standard-
ized score sheets to help determine how well the agent handled the call. 
Quality Manager is a great coaching tool designed to make the help-
desk experience more satisfying for the caller.

Cisco Unified CCX is a powerful application. Through its strong scripting 
engine, easy-to-use desktops, extensive reporting tools, and sophisticated 
workforce optimization, it can successfully operate even the most compli-
cated corporate help desks. The next several sections of this document will 
guide you through the process of installing and configuring Cisco Unified 
CCX in a Unified CM environment.



5Deployment DetailsAugust 2012 Series 5

Deployment Details

Cisco Unified CCX runs on the same Linux operating systems as several 
other Unified Communications platforms from Cisco. You install the operat-
ing system with the application by using the standard installation DVD. 

Preparing the Platform for Unified CCX

1. Prepare a virtual machine for Unified CCX

2. Prepare a server for Unified CCX

Process

For a quick and easy installation experience, it is essential to know up-front 
what information you will need. For Unified CCX, make sure you have com-
pleted the following steps before you start:

•	 If you are installing Unified CCX on a new virtual machine (VM), down-
load the Open Virtualization Archive (OVA) file from the Cisco website at: 
http://www.cisco.com/cisco/software/release.html?mdfid=270569179&s
oftwareid=283733053

•	 Check the Cisco website to determine if there is a patch for your version 
of Unified CCX: http://www.cisco.com/cisco/software/release.html?mdfi
d=270569179&flowid=5217&softwareid=280840578

If you are installing a virtual machine, follow the steps in “Prepare a virtual 
machine for Unified CCX,” later in this guide.

If you are installing a standalone server, locate the Unified CCX DVD that 
shipped with your order, and then follow the steps in “Prepare a server for 
Unified CCX,” later in this guide.

Procedure 1 Prepare a virtual machine for Unified CCX

When you install Cisco Unified CCX on VMware, follow the steps below to 
deploy an OVA file to define the virtual machine requirements. You use the 
Open Virtualization Format (OVF) support of VMware to import and deploy 
the OVA file.  

The Cisco Unified CCX OVA file for 100 agents defines the following virtual 
machine:

•	 Number of virtual CPUs—2 (with 900 MHz reservation)

•	 Amount of RAM—4	GB	(with 4 GB reservation)

•	 Hard disk—146	GB

•	 ESXi support—ESXi	4.0	or	ESXi	4.1 (VM version 7)

•	 OS support—Red	Hat	Enterprise	Linux	4 (32-bit)

The Cisco Unified CCX OVA file for 300 agents defines the following virtual 
machine:

•	 Number of virtual CPUs—2 (with 900 MHz reservation)

•	 Amount of RAM—4	GB	(with 4 GB reservation)

•	 Hard disks—2	x	146	GB

•	 ESXi support—ESXi	4.0	or	ESXi	4.1 (VM version 7)

•	 OS support—Red	Hat	Enterprise	Linux	4 (32-bit)

The Cisco Unified CCX OVA file for 400 agents defines the following virtual 
machine:

•	 Number of virtual CPUs—4 (with 900 MHz reservation)

•	 Amount of RAM—8	GB	(with 8 GB reservation)

•	 Hard disks—2	x	146	GB

•	 ESXi support—ESXi	4.0	or	ESXi	4.1 (VM version 7)

•	 OS support—Red	Hat	Enterprise	Linux	4 (32-bit)

Step 1:  In the VMware vSphere client, choose File	>	Deploy	OVF	Template. 

http://www.cisco.com/cisco/software/release.html?mdfid=270569179&softwareid=283733053
http://www.cisco.com/cisco/software/release.html?mdfid=270569179&softwareid=283733053
http://www.cisco.com/cisco/software/release.html?mdfid=270569179&flowid=5217&softwareid=280840578
http://www.cisco.com/cisco/software/release.html?mdfid=270569179&flowid=5217&softwareid=280840578
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Step 2:  Click the Browse button next to the Deploy	from	a	file	or	URL box, 
find the location of the OVA file that you downloaded from Cisco, and then 
click Next.

Step 3:  Verify the information on the OVF	Template	Details screen, and 
then click Next.

Step 4:  Read the End User License Agreement, click Accept, and then click 
Next.

Step 5:  Enter the following information in the Deploy OVF Template wizard, 
and then click Finish.

•	 On the Name	and	Location page, in the Name box, enter the virtual 
machine name CCX1, and then click	Next.

•	 On the Deployment	Configuration page, choose the Configuration type 
from the pull-down menu, and then click Next.

•	 On the Datastore page, choose the location to store the VM files, and 
then click Next.

•	 On the Disk	Format page, choose a format in which to store the virtual 
machine’s virtual disks, and then click Next.

•	 On the Network	Mapping page, choose the Source	Networks to map to 
the Destination	Networks, and then click Next.

•	 On the Ready	to	Complete	page, verify the settings, and then click 
Finish.

Step 6:  After the virtual machine is created, on the Getting	Started tab, 
choose Edit	virtual	machine	settings.

Step 7:  On the Hardware tab, select CD/DVD	Drive	1.

Step 8:  Select Datastore	ISO	File, click Browse, and then navigate to the 
location of the Cisco Unified CCX bootable installation file.

Step 9:  On the Options tab, choose Boot	Options.	
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Step 10:  Select The	next	time	the	virtual	machine	boots,	force	entry	into	
the	BIOS	setup	screen, and then click OK .

Step 11:  On the Getting	Started tab, choose Power	on	the	virtual	
machine, and then click the Console tab to watch the server boot.

Step 12:  After the machine boots into the PhoenixBIOS Setup Utility, use 
the right arrow key to move to the Boot tab.

Step 13:  Edit the boot order with the + and -	keys to make CD-ROM Drive 
the first item and Hard Drive the second.

Step 14:  To save the BIOS settings, press the F10 key.

Step 15:  To complete the installation, follow the procedures in “Installing 
Cisco Unified CCX,” later in this guide.

Procedure 2 Prepare a server for Unified CCX

When installing Cisco Unified CCX on a standalone server, use the following 
system requirements:

•	 CPU—Single	Xeon	Nehalem	quad-core	E5504	at	2.0	GHz

•	 RAM—8	GB

•	 Hard disks—2	x	146	GB	SAS

•	 OS support—Red	Hat	Enterprise	Linux	4	(32-bit)
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Step 1:  Physically install the server and attach the monitor, keyboard, and 
network cable. 

Step 2:  Insert the Cisco Unified CM DVD into the DVD drive. 

Step 3:  Power up the server. It boots from the DVD. 

Step 4:  After the DVD loads, follow the procedures in “Installing Cisco 
Unified CCX” to complete the installation.

Installing Cisco Unified CCX

1. Install the Unified CCX platform

2. Set up application administration

Process

The process is the same whether you are installing in a virtual environment 
or on a standalone server.

Make sure you have the following information:

•	 Time zone for the server

•	 Host name, IP address, network mask, and default gateway

•	 Domain Name System (DNS) server IP addresses

•	 Administrator ID and password

•	 Organization and unit

•	 Location, state, and country 

•	 Network Time Protocol (NTP) server IP addresses

•	 Security password

•	 Application username and password

Complete the tasks listed below before you start the installation:

•	 Configure Cisco Unified CCX host name (CCX1) in DNS. 

•	 Obtain license files from the Cisco licensing system. 

Procedure 1 Install the Unified CCX platform

Step 1:  On the DVD	Found screen, choose to perform a media check by 
selecting Yes.

Step 2:  If the media check is successful, click OK in order to continue with 
the installation process. 

Step 3:  If the media check does not pass, contact Cisco Technical 
Assistance Center or your local representative to replace the media, and 
then repeat Step 1.  

Step 4:  On the Product	Deployment	Selection page, click OK .

Step 5:  On the Proceed	with	Install page, verify that the version is correct, 
and then click Yes.

Step 6:  On the Platform	Installation	Wizard	page, click Proceed.

Step 7:  On the Apply	Patch	page, do one of the following: 

•	 If no upgrade patch exists for the version you are installing, click No. 

•	 If an upgrade patch does exist, click Yes, and then follow the instructions 
on the screens to complete the process.

Step 8:  On the Basic	Install	page, click Continue.
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Step 9:  On the Timezone	Configuration page, choose the correct time 
zone for the server location, and then click OK .

Step 10:  On the Auto	Negotiation	Configuration page, click Yes.

Step 11:  On the MTU	Configuration page, click No. This keeps the default 
maximum transmission unit (MTU) size.

Step 12:  On the Static	Network	Configuration	page, enter the following 
information, and then click OK .

•	 Host Name—CCX1

•	 IP Address—10.4.48.126

•	 IP Mask—255.255.255.0

•	 GW Address—10.4.48.1

Step 13:  On the first DNS	Client	Configuration page, click Yes.
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Step 14:  On the second DNS	Client	Configuration page, enter the following 
information, and then click OK.

•	 Primary DNS—10.4.48.10

•	 Domain—cisco.local

Step 15:  On the Administrator	Login	Configuration page, enter the follow-
ing information, and then click OK .  

•	 Administrator ID—Admin

•	 Password—[password]

•	 Confirm Password—[password]	
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Step 16:  On the Certificate	Information page, enter the information that will 
be used to generate security certificates, and then click OK .   

•	 Organization—Cisco	Systems,	Inc.

•	 Unit—Unified	Communications	Group

•	 Location—San	Jose

•	 State—California

•	 Country—United	States

These fields must match the information submitted to Cisco, or 
the licenses will not be valid.

Tech Tip

Step 17:  On the First	Node	Configuration page, click Yes.

Step 18:  On the Network	Time	Protocol	Client	Configuration	page, enter 
the following information, and then click OK .

•	 NTP server 1—10.4.48.17
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Step 19:  On the Security	Configuration page, enter the password for 
server-to-server communication, and then click OK . 

These passwords must match the information submitted to Cisco, 
or the licenses will not be valid.

Tech Tip

Step 20:  On the SMTP	Host	Configuration page, click No.

Step 21:  On the Application	User	Configuration page, enter the following 
information, and then click OK . 

•	 Application User Username—CCXAdmin

•	 Password—[password]

•	 Confirm Password—[password]

These values are used to initially access the Cisco Unified CCX 
Administration page and must match the license information 
submitted to Cisco. When specific users are given administrative 
rights during the application setup procedure, the initial user-
name and password entered above will no longer work. 

Tech Tip

Step 22:  On the Platform	Configuration	Confirmation page, click OK .
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Step 23:  On the Unified	CCX	Deployment	Type	Selection page, choose 
Cisco	Unified	Communications	Manager, and then click OK .

The system will go through the rest of the installation process without user 
input. The system will reboot a few times during installation. The process can 
take 60 minutes or more, depending on your hardware. 

Eventually, the server will open the command-line interface (CLI). For access 
to the CLI, use the administrator credentials entered on the Administrator	
Login	Configuration screen in Step 15.

Step 24:  If you deployed your server from a virtual template, return to the 
VMware vSphere client to disable the CD/DVD drive. 

Step 25:  From the vSphere client, navigate to the virtual machine’s Getting	
Started tab, and choose Edit	virtual	machine	settings.

Step 26:  On the Hardware tab, choose CD/DVD	Drive	1. 

Step 27:  Clear Connect	at	power	on, and then click OK . 

Procedure 2 Set up application administration

After the software is installed, use the web interface to complete the rest of 
the procedures. 

Step 1:  Using the web browser on your PC, access the Cisco Unified CCX 
Administration interface. 

Step 2:  In the center of the page, click the Cisco	Unified	Contact	Center	
Express link. 

If you receive a warning about the website’s security certificate, 
ignore it and continue to the page.

Tech Tip

Step 3:  Enter the name and password you entered on the Application User 
Configuration page in Step 21 of, “Install the Unified CCX platform,” and then 
click Login. 

Step 4:  On the Cisco	Unified	CCX	Administrator	Setup screen, choose 
Fresh	Install, and then click Next.

Step 5:  On the Cisco	Unified	CM	Configuration	-	Service	Provider	
Configuration screen, enter the following information, and then click Next.

•	 Unified CM server IP address—10.4.48.110 (publisher)

•	 AXL Admin UserName—CUCMAdmin	

•	 Password—[password] (must match the password on Cisco Unified CM)

Step 6:  On the License	Information screen, enter the location of the Unified 
CCX license file received from Cisco, and then click Next.

Step 7:  After the license has been validated, click Next.

Step 8:  After all of the components are successfully activated, click Next. 
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Step 9:  On the Publisher	Activation screen, click Next.

Step 10:  On the Cisco	Unified	CM	Configuration	screen, in the AXL 
Service Provider Configuration section, under Selected AXL Service 
Providers, select the Unified CM server 10.4.48.110 (publisher), and then 
click the right-facing	arrow to remove it from the list.

Step 11:  Under Available AXL Service Providers, select the Unified CM 
servers 10.4.48.111	(subscriber 1) and 10.4.48.112	(subscriber 2), and 
then click the left-facing	arrow to move them under Selected AXL Service 
Providers. 

Step 12:  In the Cluster Wide Parameters section, enter the following 
information: 

•	 User Name—CUCMAdmin

•	 Password—[password]

Step 13:  In the Unified CM Telephony Subsystem - Unified CM Telephony 
Provider Configuration section, under Available CTI Managers, select the 
Unified CM servers 10.4.48.111	(subscriber 1) and 10.4.48.112	(subscriber 
2), and then click the left-facing	arrow to move them under Selected CTI 
Managers.  

Step 14:  In the Cluster Wide Parameters section, enter the following 
information: 

•	 User Prefix—CCX_jtapi

•	 Password—[password]

•	 Confirm Password—[password] 

Step 15:  In the RmCm Subsystem - RmCm Provider Configuration section, 
under Available CTI Managers, select the Unified CM servers 10.4.48.111	
(subscriber 1) and 10.4.48.112	(Subscriber 2), and then click the left-facing 
arrow to move them under Selected CTI Managers.  
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Step 16:  In the Cluster Wide Parameters section, enter the following 
information, and then click Next.  

•	 User Id—CCX_rmjtapi

•	 Password—[password]

•	 Confirm Password—[password]

Unified CCX will send the user information to the Unified CM server, and the 
application users will be created automatically.

For historical reporting of the number of HR sessions, use the 
maximum number of supervisors or administrators who will be 
running Unified CCX reports at the same time. For the Recording 
Count, enter the maximum number of concurrent ad-hoc record-
ing sessions. 

Tech Tip

Step 17:  On the System	Parameters	Configuration screen, enter the 
following information, and then click Next:

•	 Number of HR sessions—4

•	 Recording Count—25

•	 Number of Outbound seats—100

•	 Codec—G.711

Step 18:  On the Language	Configuration screen, enter the language that 
will be used for default IVR prompts, the Cisco Agent Desktop, and the Cisco 
Supervisor Desktop, and then click Next.

Step 19:  On the Desktop Client Configuration Tool message, click OK .

Make sure you give your own account administrator rights. After 
you give one of the Unified CM users administrator rights, the 
admin user account created during installation will not work. 

Tech Tip
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Step 20:  On the User	Configuration page, select the Cisco Unified CM 
users who need administrative rights, click the left-facing	arrow to move 
them to the Cisco Unified CCX Administrator section, and then click Finish.

The initial application administration setup is now complete.  Please close 
your web browser.

Configuring the Help  Desk

1. Create the call control group

2. Create skills

3. Assign skills to contact service queues

4. Create resources

5. Configure the user’s phone or extension

6. Assign skills to resources

7. Create the supervisors and teams

8. Create scripts and applications

9. Add a trigger

10. Associate application user with CTI

11. Create and upload the prompts

12. Verify Unified CCX Engine status

Process

After you configure the application administration for the first time, the next 
task is to configure the help desk to allow the system to begin taking calls 
from end users.

Procedure 1 Create the call control group

A call control group creates a group of computer telephony integration (CTI) 
ports on Cisco Unified CM that are used to send calls to Unified CCX for 
IVR treatment and queuing. The call stays on the CTI port until it is sent to an 
agent.  

Step 1:  Using your web browser, access the Cisco Unified CCX 
Administration interface. 

Step 2:  In the center of the page, click the Cisco	Unified	Contact	Center	
Express link. 

The account created during the installation of the server will no 
longer work for administering the application.  

Tech Tip

Step 3:  Enter the username and password of one of the users you assigned 
administrative rights in Step 20 of the previous procedure, and then click 
Login. 

Step 4:  Navigate to Subsystems	>	Cisco	Unified	CM	Telephony	>	Call	
Control	Group, and then click Add	New.  

Step 5:  Enter the following information, and then click Add.

•	 Description—Unified	CM	Telephony	Group

•	 Number of CTI ports—4

•	 Media Termination Support—No

•	 Group Type—Inbound

•	 Device Name Prefix—CTIP

•	 Starting Directory Number—8009950

•	 Device Pool—DP_HQ1_1 (default for headquarters location)

•	 DN Calling Search Space—CSS_Base

•	 Location—Hub_None

•	 Partition—PAR_Base  

Leave the rest of the fields at their default settings.
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Procedure 2 Create skills

Create skills for each different type of call you expect to receive in the call 
center. 

Step 1:  Navigate to Subsystems	>	RmCm	>	Skills and click Add	New.

Step 2:  On the Skill	Configuration screen, enter Information	Technology, 
and then click Save.

Step 3:  On the Skills search screen, click Add	New.

Step 4:  On the Skill	Configuration screen, enter Human	Resource, and 
then click Save.

Step 5:  To create additional skills, repeat Step 3 and Step 4.  

Procedure 3 Assign skills to contact service queues

Create contact service queues for each skill entered in the previous 
procedure.

The Contact Service Queue (CSQ) names created here must 
exactly match the queue names referenced in the application 
scripts which are described later in this document. The example 
script uses the CSQ names of IT and HR . Be sure to add these 
queues to the server. 

Tech Tip

Step 1:  Navigate to Subsystems	>	RmCm	>	Contact	Service	Queues and 
click Add	New.

Step 2:  On the first Contact	Service	Queue	Configuration screen, enter 
the following information, and then click Next:

•	 Contact Service Queue Name—IT

•	 Contact Service Queue Type—Voice

•	 Automatic Work—Disabled

•	 Wrap-up Time—Disabled

•	 Resource Pool Selection Model—Resource	Skills

•	 Service Level—5 (seconds)

•	 Service Level Percentage—70 

•	 Prompt—No	Selection
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Step 3:  On the second Contact	Service	Queue	Configuration screen, 
enter the following information, and then click Add:

•	 Resource Selection Criteria—Longest	Available

•	 Select Required Skills—Information	Technology (and then next to the 
window, click Add)

•	 Minimum Competence—5  

Step 4:  For each additional skill, click Add	New, and then repeat Step 2 and 
Step 3.

Procedure 4 Create resources

Perform the next two procedures on your Cisco Unified CM platform. First, 
you will assign phones to the agents and supervisors.

Step 1:  From your browser, access the Unified CM Administration interface.

Step 2:  In the center of the page, click the Cisco	Unified	CM	
Administration link. 

Step 3:  Enter the application administrator username and password for 
Unified CM, and then click Login.

Step 4:  To locate an existing phone, navigate to Device	>	Phone and click 
Find. 

Step 5:  If the agent phone is found, click it to proceed to the next step. If the 
phone does not yet exist, click Add	New to create it.

Step 6:  On the Phone	Configuration page, click line	[1] to add Unified CCX 
information for the specific line on the phone.  

If this is a new phone, fill out the other fields on the Directory Number 
Configuration page that are important to your environment.

Step 7:  Scroll down to the bottom of the page, and click Associate	End	
Users. 

Step 8:  On the	Find	and	List	Users screen, click Find, and then choose the 
appropriate user for this line by selecting the check box next to their name.

Step 9:  Click Add	Selected	and you will return to the previous page. 

Step 10:  Scroll down to the bottom of the Directory	Number	Configuration 
screen, select the check box to the left of the user’s name, and then click 
Save.

Step 11:  Repeat Step 4 through Step 10 for each additional agent and 
supervisor phone.

Procedure 5 Configure the user’s phone or extension

The next set of steps associates the phone to the agent or supervisor user 
ID.

Step 1:  Navigate to User	Management	>	End	User and click Find. 

Step 2:  Select the agent or supervisor from the previous procedure and 
click the user ID. 

Step 3:  On the End	User	Configuration	screen, scroll down to the Device 
Information section, and then click Device	Association.

Step 4:  On the User	Device	Association screen, click Find. 
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Step 5:  Search for the agent device. Select the check box next to the 
agent’s phone, and then click Save	Selected/Changes. 

Step 6:  In the upper-right corner of this page, in the Related Links drop-
down list, choose Back	to	User, and then click Go.

Step 7:  On the End	User	Configuration page, scroll down to the Extension 
Mobility section. Ensure that the Allow	Control	of	Device	from	CTI check 
box is selected.  

Step 8:  Scroll down to the Directory Number Associations section, set the 
IPCC Extension to the agent directory number that you created in the previ-
ous procedure, and then click Save.

Step 9:  For each additional agent or supervisor, repeat Step 2 through Step 
8. 

Procedure 6 Assign skills to resources

Cisco Unified CM users associated with IPCC extensions show up automati-
cally as resources in Cisco Unified CCX. Using the resource list on the Cisco 
Unified CCX Administration page, you assign skills to resources, making 
them available to answer calls in particular Contact Service Queues (CSQs).  

Step 1:  Using your browser, access the Unified CCX Administration 
interface.

Step 2:  In the center of the page, click the Cisco	Unified	Contact	Center	
Express link. 

Step 3:  Enter the name and password of a user with administrative rights to 
Unified CCX, and then click Login. 

Step 4:  Navigate to Subsystems	>	RmCm	>	Resources. On the Resources 
search page, click a user under the Resource	Name.

Step 5:  On the Resource	Configuration page, in the Unassigned Skills 
field, select the skill that you want to assign, and then click the left-facing	
arrow to move it to Assigned Skills. 

Step 6:  Select the Competence Level for the resource and click Update.

Step 7:  For each additional resource, repeat Step 4 through Step 6.
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Procedure 7 Create the supervisors and teams

The first step in building a team is to create a supervisor. A supervisor has 
a full view of a team’s performance and can monitor the agents by using the 
Cisco Supervisor Desktop. 

Step 1:  Navigate to Tools	>	User	Management	>	Supervisor	Capability	
View.

Step 2:  On the User Configuration screen, in the Available Users field, 
select the users you want to designate as supervisors, click the left-facing	
arrow, and then click Update. 

 

Step 3:  Navigate to Subsystems	>	RmCm	>	Teams and click Add	New.

Step 4:  On the Team	Configuration screen, enter the following information, 
and then click Save.

•	 Team Name—Information	Technology

•	 Primary Supervisor—[Supervisor]

•	 Assigned Resources—[Agent	or	supervisor]

•	 Assigned CSQs—Information	Technology

Step 5:  For each additional team, repeat Step 3 and Step 4.

Procedure 8 Create scripts and applications

In this procedure an externally created script is uploaded to the server in 
order to quickly deploy the example configuration. 

This guide uses the example script and prompts from a zip file 
that is included with the document. The zip file can be found on 
http://www.cisco.com/go/sba/. 

Reader Tip

Step 1:  Navigate to Applications	>	Script	Management and click Upload	
Scripts.
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Step 2:  Click Browse, find the location of the script (scripts have the file 
extension .aef), and then click Upload. 

Step 3:  After the script is successfully uploaded, click Return	to	Script	
Management.

Step 4:  Navigate to Applications	>	Application	Management	and click Add	
New.

Step 5:  On the Add	A	New	Application screen, select Cisco	Script	
Application, and then click Next.

Step 6:  On the Cisco	Script	Application screen, enter the following infor-
mation, and then click Add.

•	 Name—Help	Desk

•	 ID—[automatic	setting]	(do not change this value)

•	 Maximum Number of Sessions—4

•	 Script—SCRIPT[SBAHelpdesk.aef]

•	 Description—Help	desk	for	IT	and	HR

•	 Enabled—Yes

•	 Default Script—System	Default
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Procedure 9 Add a trigger

The trigger for an application is the phone number the users will dial when 
they want to speak with someone in the help desk.  

Step 1:  In the upper-left of the Cisco	Script	Application screen, click Add	
New	Trigger.

Step 2:  In the Trigger Type drop-down list, choose Unified	CM	Telephony	
Trigger, and then click Next.

Step 3:  On the Cisco	Unified	CM	Telephony	Trigger	Configuration	screen, 
enter the following information:

•	 Directory Number—8009940 (CTI Route Point that will be automatically 
created in Unified CM to direct calls to this application)

•	 Language—English	(United	States)	[en_US]

•	 Device Name—InternalHelp

•	 Description—Trigger	for	Internal	Help	Desk

•	 Call Control Group—Unified	CM	Telephony	Group(1) 

Step 4:  Click Show	More, enter the following information, and then click 
Add:

•	 Enabled—Yes

•	 Maximum Number of Sessions—Default

•	 Idle Timeout (in ms)—5000

•	 Override Media Termination—No

•	 Alerting Name ASCII—Help	Desk	Pilot

•	 Device Pool—DP_HQ1_1 (headquarters default)

•	 Location—Hub_None	(headquarters default)

•	 Partition—PAR_Base	(phone default)

•	 Voice Mail Profile—None

•	 Calling Search Space—CSS_Base

Leave the rest of the fields at their defaults.
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Procedure 10 Associate application user with CTI

This set of steps associates the CCX application user with the phones, CTI 
Route Point, and CTI Ports in Unified CM.

Step 1:  From a new browser window, access the Cisco Unified CM 
Administration interface.

Step 2:  In the center of the page, click the Cisco	Unified	CM	
Administration link. 

Step 3:  Enter the administrator username and password for Unified CM and 
then click Login.

Step 4:  Navigate to User	Management	>	Application	User.  

Step 5:  On the Application	User	search page, click Find, and then select 
CCX_rmjtapi.

Step 6:  On the Application	User	Configuration screen, in the Device	
Information section under Available	Devices, select the agent and supervi-
sor phones, the CTI ports, and the CTI route point, click the down-facing	
arrow, and then click Save. 

Procedure 11 Create and upload the prompts

Prompts are played to the callers when they are in the application. You must 
record the prompts as .wav files and save them in a location reachable by 
the PC accessing the Cisco Unified CCX Administration page.

This guide uses the example script and prompts from a zip file 
that is included with the document. The zip file can be found here: 
http://www.cisco.com/go/sba/ 

Reader Tip

Step 1:  Return to the Cisco	Unified	CCX	Administration main page.

Step 2:  Navigate to Applications	>	Prompt	Management, and then click 
the en_US folder.

Step 3:  After the folder opens, click Upload	Prompts.

Step 4:  Browse to the prompt WAV file, select it, and then click Upload.

Step 5:  For each of the prompts file needed, repeat Step 3 and Step 4, and 
then click Return	to	Prompt	Management.

Step 6:  Navigate to Applications	>	Application	Management, and click 
the application that you created in Procedure 8, “Create scripts and 
applications.”  
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Step 7:  (Optional) If you need to change the names of the default prompts 
or use different prompts, select the check box next to each prompt, click 
Show	Prompts, and then choose the appropriate prompt file. After they are 
all chosen, click Update.

In order to make custom prompts you must be sure to format the 
WAV files correctly before uploading them to the server.

Bit Rate: 64 kbps

Audio sample size: 8 bit

Channels: 1 (mono)

Audio sample rate: 8 kHz

Audio format: CCITT u-Law 

Tech Tip

Procedure 12 Verify Unified CCX Engine status

Check the status of the server to ensure the integration with CUCM is work-
ing properly and is ready to receive calls.

Step 1:  Using the Navigation drop down menu in the top right select Cisco	
Unified	CCX	Serviceability and click Go.

Step 2:  Navigate to Tools	>	Control	Center-Network	Services.

Step 3:  On the Cisco	Unified	CCX	Engine line, the Status should read In	
Service; if this is the case configuration of the server is complete and you 
can skip ahead to Configuring the Client Desktop Software. If the Status is 
Partial	Service, continue to the next step to attempt to fix the problem.

Step 4:   Using the Navigation drop down menu in the top right select Cisco	
Unified	CCX	Administration and click Go.

Step 5:  Navigate to Subsystems	>	Cisco	Unified	CM	Telephony	>	Data	
Synchronization.

Step 6:  Select	Call	Control	Group(s), Trigger(s), and CM	Telephony	
User(s) and click Data	Resync.

Step 7:  Repeat Step 1 thru Step 3 to recheck if Unified CCX Engine has 
come back into service.
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Configuring the Client Desktop Software

1. Download the client

2. Configure reason codes

3. Set up caution and warning levels

Process

In this process, you download Cisco Agent Desktop, Cisco Supervisor 
Desktop, and Cisco Desktop Administrator clients from the server to a user’s 
PC. You can download these applications to any PC that has network access 
to the server through the Cisco Unified CCX Administration page.

Procedure 1 Download the client

Step 1:  Navigate to Tools	>	Plug-ins, and then click Cisco	Unified	CCX	
Desktop	Suites.

Because this is the first time you’re downloading the desktop 
applications, you must run the Cisco Unified CCX Client 
Configuration Tool. You only have to do this once per installation 
or upgrade. 

Depending on the operating system and browser on your PC, you 
will have to answer and acknowledge several security-related 
prompts to download and run the tool. 

Tech Tip

Step 2:  Click Cisco	Unified	CCX	Client	Configuration	Tool. 

Step 3:  On the CAD	Client	Configuration screen, which may be hidden 
behind other windows on your PC, enter 10.4.48.126, and then click Next.

The Client Configuration wizard configures the desktop applications into 
a format that can be downloaded by users of the system. After the wizard 
is finished, it returns to the download page of Unified CCX Administration.  
Depending on the speed of your connection to the server, this process can 
take up to 20 minutes to complete.  

Step 4:  Under Cisco Unified CCX Desktop Product Suite, click Cisco	
Unified	CCX	Desktop	Administrator, and then follow the installation 
prompts.
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Step 5:  After installing Desktop Administrator, click the link for the type 
of desktop that is appropriate for this end user’s role, and then follow the 
installation prompts.  

Install either the supervisor or agent desktop on a particular PC, 
but not both. The Supervisor Desktop installation includes both 
the agent and supervisor applications. The Agent Desktop instal-
lation includes only the agent application. 

Tech Tip

Procedure 2 Configure reason codes

Reason codes are used to identify the different tasks an agent may be doing 
before and after taking a call.

Step 1:  Navigate to Start	>	Programs	>	Cisco	>	Desktop	>	Admin, and 
then click Cisco	Desktop	Administrator.

The default path to the application on your hard drive is as follows: 
C:\Program	Files\Cisco\Desktop\bin\SplkView.exe

Tech Tip

Step 2:  Navigate to Call	Center	1	>	Work	Flow	Configuration	>	Reason	
Codes	and click	Edit	Master	List.

Step 3:  On the Master	Reason	Code	Editor page, enter the following 
information, and then click Add:

•	 Code—0 to 999 (Each reason must have a unique number.)

•	 Description—Describe the reason code.

Step 4:  To add more reasons, repeat Step 3, and then click Done. 
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Step 5:  After you have created the master reason list, on the Logout tab, 
select the appropriate reasons for logging out, and then click the right arrow 
to make them available. 

Step 6:  On the Not	Ready tab, select the appropriate reasons that an agent 
might not be ready, and then click the left arrow to make them available. 

Step 7:  After the Logout and Not Ready tabs are completed, click Apply.

Procedure 3 Set up caution and warning levels 

Caution and warning levels are thresholds set up by the administrator to let 
call center agents know when the call is going on longer than what is ideal 
for the given call center. You set the thresholds by using Cisco Desktop 
Workflow Administrator. 

Step 1:  Navigate to Call	Center	1	>	Work	Flow	Configuration	>	Work	Flow	
Groups	>	default	>	Enterprise	Data. 
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Step 2:  On the Call	Activity tab, specify the time thresholds for the CSQ 
(time the caller was in queue) and agent (time the caller has been speaking 
to the agent), and then click Apply.

The baseline help desk configuration is now complete.
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Appendix A: Product List

Data Center or Server Room

Functional Area Product Description Part Numbers Software

Contact Center Cisco Media Convergence Server 7845-I3 for Unified Contact Center 
Express up to 400 agents

MCS-7845-I3-CCXB1 8.5.1 SU3

Cisco Media Convergence Server 7835-I3 for Unified Contact Center 
Express up to 100 agents

MCS-7835-I3-CCXB1

Call Control Cisco Media Convergence Server 7845-I3 for Unified Communications 
Manager up to 10,000 users

MCS7845I3-K9-CMD3A 8.6(2a)SU1

Cisco Media Convergence Server 7835-I3 for Unified Communications 
Manager up to 2500 users

MCS7835I3-K9-CMD3A

Business Edition Virtual 
Server

Unified CMBE6K UCS C200M2 for Unified Communications Manager up to 
500 users

UCS-C200M2-BE6K 8.6(2a)SU1 
ESXi 4.1 

Call Control Virtual Servers Cisco UCS C210 M2 General-Purpose Rack-Mount Server for unified com-
munications applications

UCS-C210M2-VCD2 8.6(2a)SU1 
ESXi 4.1 

Cisco UCS C200 M2 High-Density Rack-Mount Server for unified communi-
cations applications

UCS-C200M2-VCD2

Contact Center Virtual 
Servers

Cisco UCS C210 M2 General-Purpose Rack-Mount Server for unified com-
munications applications

UCS-C210M2-VCD2 8.5.1 SU3 
ESXi 4.1

Cisco UCS C200 M2 High-Density Rack-Mount Server for unified communi-
cations applications

UCS-C200M2-VCD2
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Appendix B: Changes

This appendix summarizes the changes to this guide since the previous 
Cisco SBA series.

•	 We added server scaling information for customers who need to support 
up to 400 agents, 42 supervisors, 150 agent groups and skill groups.  

•	 We changed the dial plan information, to align it with new telephony 
integration guides. This change ensures the voice guides use a common 
set of extension numbers and dialing rules.

•	 We updated the software on the voice infrastructure equipment and the 
endpoints to the latest shipping versions.
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