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C H A P T E R 10

Managing Performance

This chapter includes the following information:

• 10.1 What Is Performance Management?, page 10-1

• 10.2 What Performance Data Is Available?, page 10-2

• 10.3 How Is Performance Data Collected?, page 10-3

• 10.4 How Do I Query, View, Filter, and Graph PM Data?, page 10-17

Note Appendix E, “Performance Data” contains field descriptions for each PM table.

10.1 What Is Performance Management?
Performance management (PM) in a network is the configuration and measurement of network traffic 
for the purpose of providing a consistent and predictable level of service. PM involves monitoring the 
network activity and adjusting the design or the configuration of the network to improve its performance 
and traffic handling. PM provides network and system performance reporting for determining acute and 
chronic problems, service level reporting, and performance optimization.

Measuring performance can identify:

• Normal baseline network performance, which can then be compared to abnormal network behavior

• Current or potential utilization problems

• Slow response time

• Application, server, and network availability

• Optimum data transfer times

Performance data is useful for capacity reporting when drafting budgets or considering network 
redesigns. It can be used to identify congestion and trouble areas in the network that need to be relieved, 
either through additional equipment or through network reconfiguration. It can also be used to identify 
devices that are being underutilized or have available chassis slots.

Performance measurement includes:

• Performance monitoring—The collection of performance-related data from network devices. This 
data is useful for fine-tuning the performance of the device and for monitoring potentially 
service-affecting problems.
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• Performance reporting—The presentation of the collected data, which can then be used to analyze 
faults, growth, and capacity of the network.

You can set thresholds on the reported performance data. These thresholds generate events that can be 
used in performance and fault management.

The PM process is as follows:

1. Gather network data and statistics

2. Analyze network performance and identify critical issues

3. Optimize network performance

4. Plan customer capacity

5. Plan network capacity

10.2 What Performance Data Is Available?
The following areas of performance are useful for measurement:

• Availability—The amount of time for which a network system or application is available to the user. 
From a network perspective, availability is the reliability of the individual components in the 
network. Accurately measuring availability of a distributed network is difficult and not very 
practical.

• Response time—The time required for traffic to travel between two points, typically measured for a 
round trip; the time it takes a packet to reach its destination and for a response to return to the sender. 
Response time is the best measure of how users perceive the network’s performance.

• Accuracy—The amount of interface traffic that does not result in error. Accuracy can be expressed 
in terms of a percentage that compares the success rate to the total packet rate over a period of time. 
A decreased accuracy rate should be used to trigger a closer investigation of the network.

• Utilization—Measures the use of a particular resource over time. Utilization is usually expressed as 
a percentage of a resource’s maximum operational capacity. It can be used to identify congestion or 
potential congestion throughout the network, as well as underutilized resources. Sudden jumps in 
resource utilization can indicate a fault condition.

Cisco Prime Optical provides the following wizards to query PM data:

• PM Query by NE Model (for non-CTC-based NE models only)

• PM Query by Category

Note PM data collection is not available for the ONS 15216.

Note Make sure that the NE and the Prime Optical server are synchronized. The NE generates PM statistics 
at 15-minute or 1-day intervals. The server collects 1-day PM data at 00:00 Greenwich Mean Time 
(GMT), regardless of the NE time or its time zone.

Note When configuring PM data collection, enable it for an NE on only one Prime Optical server. CTC-based 
NEs do not support simultaneous sessions on HTTP for bulk PM data collection. If you enable PM data 
collection on multiple Prime Optical servers, one of the servers might time out with the following error 
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messages:
Server Error: 503 Service Unavailable

Operating System Error Nr:3997698: S_objLib_OBJ_UNAVAILABLE

Too many concurrent PM downloads

Note An alarm is generated for every piece of lost PM data for CTC-based NEs. A PM lost alarm (15 minutes 
or 1 day) is generated when Prime Optical cannot collect PM data for 15 minutes or for 1 day when the 
NE’s PM data collection is set to either 15 Min Robust or 1 Day Robust. If there are outstanding PM 
Retrieval Fail alarms, these alarms are cleared and the PM lost alarm is generated.

10.3 How Is Performance Data Collected?
Performance data collection is the process of collecting performance-related data from network devices 
and storing them in a database or data file. This information can then be used for locating, diagnosing, 
and correcting network problems to increase network reliability and effectiveness, and to ensure that 
fault management can be more than just handling emergencies. The data can also be used to increase the 
productivity of network users. There are two methods of collecting performance data:

• Active polling—Involves actively obtaining specific management data from network devices. The 
collected data is then stored in a database and used later for reporting. The advantage of active 
polling is that as long as a managed device is accessible, data is collected and stored at regular 
intervals. A disadvantage is that collecting large amounts of data can impact the performance of the 
managed device or the network. Also, reports might take a long time to generate.

• Event reporting—A managed device or agent generates a trap or event that is received and logged. 
This method requires that events be generated based only on thresholds, and the EMS assumes that 
the lack of an event indicates that the item being measured is performing within acceptable ranges. 
The advantage here is that the potential impact to the network is lessened. The disadvantages of 
event reporting are that traps are unreliable and you might not be able to determine the start or stop 
of an event. It can also be difficult to determine the duration and frequency of an event.

This section includes the following information:

• 10.3.1 Viewing Performance Monitoring for an NE, page 10-4

• 10.3.2 Enabling Performance Monitoring, page 10-4

• 10.3.3 Understanding the PM Service Pane, page 10-4

• 10.3.4 Understanding the Individual PM Service Panes, page 10-5

• 10.3.5 Activating or Deactivating Performance Monitoring, page 10-12

• 10.3.6 Enabling or Disabling PM Data Collection on an Individual NE, page 10-12

• 10.3.7 Enabling or Disabling PM Data Collection by PM Category for CTC-Based NEs, page 10-13

• 10.3.8 Enabling PM Data Collection for the ONS 15530 and ONS 15540, page 10-14

• 10.3.9 Enabling or Disabling PM Retrieval Fail Alarms for CTC-Based NEs, page 10-14

• 10.3.10 Specifying the PM Data Display, page 10-15

• 10.3.11 Viewing the Robust PM Collection Queue, page 10-15

• 10.3.12 Using the Self Monitor Table, page 10-15

• 10.3.13 Filtering the Self Monitor Table, page 10-16
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10.3.1 Viewing Performance Monitoring for an NE
To view PM data for an NE, you must first collect the data. To collect the PM data, you need to activate 
the PM service for your NE and then enable PM collection on that NE. The PM service can be activated 
either before or after the PM collection is enabled on the NE(s). The PM data is not available until both 
operations are completed and the first PM collection occurs.

10.3.2 Enabling Performance Monitoring
Performance monitoring is optional, but you must enable it if you want to monitor threshold alarms and 
performance parameters.

Performance monitoring can be enabled on NEs by using the device CLI. For information about using 
the CLI, see the relevant hardware documentation.

Note PM data collection is resource intensive in terms of CPU, disk space, and DCN utilization, so you should 
exercise proper planning and resource monitoring for PM data collection.

10.3.3 Understanding the PM Service Pane
Use the PM Service pane (Administration > Control Panel) to activate or deactivate global PM data 
collection and change NE PM data collection parameters. When you click Save to save your change, the 
change takes effect immediately.

Table 10-1 Field Descriptions for the PM Service Pane

Field Description

PM Data Storage PM data storage status. If set to Normal, all performance data collected is displayed in the PM data 
tables. If set to Optimized, performance data with all zero values and performance data with all 
invalid flags are not displayed and are not stored in the database.

Robust PM Collection 
Queue

Number of 15-minute and 1-day outstanding robust PM registers. Click Clear Robust PM Queue 
to clear the queue.

PM 15-Min Retrieval 
Fail Alarm

Enable or disable a retrieval fail alarm for 15-minute PM data. Check the Enable check box; then, 
enter the number of seconds between each retry, and enter the number of retries to attempt before the 
alarm is generated.
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10.3.4 Understanding the Individual PM Service Panes
The PM Service properties pane (Administration > Control Panel > PM Service) displays information 
about the status of performance monitoring for the selected NE. You can also stop or start an individual 
PM service instance. The individual PM service panes are broken down by NE:

• ONS 15305

• ONS 15310 CL/ONS 15310 MA/ONS 15327/ONS 15454/CPT 600/CPT 200

• ONS 15310 MA SDH/ONS 15454 SDH/CPT 600 SDH/CPT 200 SDH

• ONS 155xx

• ONS 15600

• ONS 15600 SDH

10.3.4.1 ONS 15305

The ONS 15305 PM Service pane displays ONS 15305 NE PM service information. Table 10-2 provides 
the descriptions.

PM 1-Day Retrieval 
Fail Alarm

Enable or disable a retrieval fail alarm for 1-day PM data. Check the Enable check box; then, enter 
the number of minutes between each retry, and enter the number of retries to attempt before the alarm 
is generated.

Real-Time PM 
Performance 
Parameters

When a real-time PM session is running, it polls the NE for x number of attributes every 10 to 900 
seconds. The data it returns is stored entirely in transient memory. Use the following fields to limit 
the scope of the real-time PM session:

• Maximum number of concurrent real-time PM sessions—Specify the maximum number of 
concurrent real-time PM sessions allowed per client. The range is from 1 to 5 sessions; the Cisco 
default is 5.

• Maximum number of polled real-time PM objects—Specify the maximum number of objects 
that can be polled in a single real-time PM session. The range is from 1 to 100 objects; the Cisco 
default is 100.

• Maximum number of rows held in cache—Specify the maximum number of rows that can be 
held in the real-time memory buffer per session. When this limit is reached, the oldest rows are 
removed from the buffer to make room for new rows. The range is from 100 to 5000 rows; the 
Cisco default is 1000.

Note Depending on the PM table launch selection criteria, the number of rows displayed might be 
less than the maximum number of rows specified.

Table 10-1 Field Descriptions for the PM Service Pane (continued)

Field Description
10-5
Cisco Prime Optical 9.6 User Guide

OL-27078-01



Chapter 10      Managing Performance
How Is Performance Data Collected?
10.3.4.2 ONS 15310 CL/ONS 15310 MA/ONS 15327/ONS 15454/CPT 600/CPT 200

The ONS 15310 CL/ONS 15310 MA/ONS 15327/ONS 15454/CPT 600/CPT 200 PM Service pane 
displays PM service information for the ONS 15310 CL, ONS 15310 MA SONET, ONS 15327, ONS 
15454 SONET, CPT 200, and CPT 600 NEs. The following table provides descriptions.

Table 10-2 Field Descriptions for the ONS 15305 PM Service Pane

Field Description

Status Tab

Service Status Current status of the service: Active or Not Active.

Service Action Stops or starts a process. Notice that the Service Action button toggles between Activate and Deactivate, 
and that the Service Status field changes accordingly.

Threshold Number of NEs that will be serviced by one instance of the PM service.

Debug Tab

Overall Logging Click the Enable radio button to enable overall debugging and to select debug modules for the PM 
service. Click the Disable radio button to disable overall debugging.

Debug Modules If overall logging is enabled, lists the modules that can be used for debugging. Select a module from the 
Available list; then, click the Add button to add the module to the Selected list. Use the Remove button 
to return the module to the Available list. Debug logging will be performed on the modules in the 
Selected list.

PM Service Instance

Start Service 
Instance, Stop 
Service Instance

Allows you to stop or start an individual PM service instance. If you click Start Service Instance, the 
service status changes to Running. If you click Stop Service Instance, the status changes to Stopped.

Dump Cache Click the Dump Cache button to export the PM service cache to the log file related to the selected PM 
service instance.

Debug Table Click the Debug Table button to open the Prime Optical NE Module Level Debug Table window, which 
displays the debug state of the selected NEs and lists the modules for which debugging is active.

Overall Logging 
for the Instance

Click the Disable button to disable overall logging for the PM service instance.

Managed NEs The list of managed NEs shows which NEs are currently being managed by the selected service instance. 
If you stop the specified service instance, the NEs in the list are no longer managed.

Table 10-3 Field Descriptions for the ONS 15310 CL/ONS 15310 MA/ONS 15327/ONS 15454 PM/CPT 600/CPT 200 

Service Pane  

Field Description

PM Collection Parameters Tab

DS1 PM Collection Enable or disable DS1 PM data collection.

DS3 PM Collection Enable or disable DS3 PM data collection.

Physical/Section/Line PM 
Collection

Enable or disable physical, section, and line PM data collection on OC-N cards.

STS PM Collection Enable or disable SONET STS Path PM data collection.

VT PM Collection Enable or disable SONET VT Path PM data collection.
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Data PM Collection Enable or disable data (Ethernet, POS, SAN, 8B10B) PM data collection.

Physical/OTN PM 
Collection

Enable or disable physical, OTN G.709 Section, OTN G.709 Path, and OTN FEC PM data 
collection on DWDM cards.

SNMP PM Collection Enable or disable CoS PM data collection.

E1 PM Collection Enable or disable E1 PM data collection.

Status Tab

Service Status Current status of the service: Active or Not Active.

Service Action Stops or starts a process. Notice that the Service Action button toggles between Activate and 
Deactivate, and that the Service Status field changes accordingly.

Threshold Number of NEs that will be serviced by one instance of the PM service.

Note Starting with CTM R9.2, one instance of the PM service can handle up to 2000 NEs.

BLSR-Ring Switch 
Interval

Allows you to set the BLSR switch interval, in seconds. The Cisco default is 60 seconds. 

TL1 Tunnel Connection 
Timeout

Allows you to set the time it takes to set up a TL1 tunnel connection between the Prime Optical 
server and the tunneled NE (TNE). When a new NE is added using the Add NE wizard, you can 
connect to the new NE using a TL1 tunnel. The Prime Optical server establishes a TCP/IP 
connection to a non-Cisco GNE (NGNE), and the NGNE establishes an OSI connection to the 
TNE. If the Prime Optical server cannot set up the TL1 tunnel connection before the specified 
TL1 tunnel connection timeout, the Add NE operation fails and the TNE connection state 
becomes unavailable. 

Audit Trail Collection 
Interval

Allows you to set the audit trail collection interval, in minutes. 

L2 Service Resync Delay Allows you to configure the delay after which Prime Optical performs a Cisco IOS configuration 
synchronization on ML cards to keep the NE and the Prime Optical Data Provisioning Service 
synchronized. This operation synchronizes the L2 topology.

Full Cisco IOS configuration synchronization is performed automatically by Prime Optical to 
keep the NE and the Prime Optical Data Provisioning Service synchronized. Full configuration 
resynchronization might be delayed depending on Prime Optical server usage. For the 
Prime Optical server deployed as a monitoring server, the recommended value for the delay 
parameter is 2 minutes (120 seconds). For the Prime Optical server deployed as a provisioning 
server, the recommended value for the delay parameter is 10 minutes (600 seconds). 

ENEs List Poll Interval Time interval in which all CTC-based GNEs in Prime Optical need to refresh their list of ENEs. 
The list of ENEs for each GNE is obtained and compared with the existing ENE list. If there are 
any changes to the ENE list, topology changes are carried out so that the Domain Explorer will 
reflect the current topology with correct GNE and ENE icons. 

Debug Tab

Overall Logging Click the Enable radio button to enable overall debugging and to select debug modules for the 
PM service. Click the Disable radio button to disable overall debugging.

Debug Modules If overall logging is enabled, lists the modules that can be used for debugging. Select a module 
from the Available list; then, click the Add button to add the module to the Selected list. Use the 
Remove button to return the module to the Available list. Debug logging will be performed on 
the modules in the Selected list.

Table 10-3 Field Descriptions for the ONS 15310 CL/ONS 15310 MA/ONS 15327/ONS 15454 PM/CPT 600/CPT 200 

Service Pane (continued) 

Field Description
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10.3.4.3 ONS 15310 MA SDH/ONS 15454 SDH/CPT 600 SDH/CPT 200 SDH

The ONS 15310 MA SDH/ONS 15454 SDH PM/CPT 600 SDH/CPT 200 SDH Service pane displays 
PM service information for the ONS 15310 MA SDH, ONS 15454 SDH, CPT 200 SDH, and CPT 600 
SDH NEs. The following table provides descriptions.

PM Service Instance

Start Service Instance, 
Stop Service Instance

Allows you to stop or start an individual PM service instance. If you click Start Service 
Instance, the service status changes to Running. If you click Stop Service Instance, the status 
changes to Stopped.

The list of managed NEs shows which NEs are currently being managed by the selected service 
instance. If you stop the specified service instance, the NEs in the list are no longer managed.

Dump Cache Click the Dump Cache button to export the PM service cache to the log file related to the 
selected PM service instance.

Debug Table Click the Debug Table button to open the Prime Optical NE Module Level Debug Table window, 
which displays the debug state of the selected NEs and lists the modules for which debugging is 
active.

Overall Logging for the 
Instance

Click the Disable button to disable overall logging for the PM service instance.

Managed NEs The list of managed NEs shows which NEs are currently being managed by the selected service 
instance. If you stop the specified service instance, the NEs in the list are no longer managed.

Table 10-3 Field Descriptions for the ONS 15310 CL/ONS 15310 MA/ONS 15327/ONS 15454 PM/CPT 600/CPT 200 

Service Pane (continued) 

Field Description

Table 10-4 Field Descriptions for the ONS 15310 MA SDH/ONS 15454 SDH/CPT 600 SDH/CPT 200 SDH PM Service 

Pane

Field Description

PM Collection Parameters Tab

E1 PM Collection Enable or disable E1 PM data collection.

E3 PM Collection Enable or disable E3 PM data collection.

E4 PM Collection Enable or disable E4 PM data collection.

DS3I PM Collection Enable or disable DS3I PM data collection.

High Order PM Collection Enable or disable high order PM data collection.

Low Order PM Collection Enable or disable low order (VC-3, VC-11, and VC-12) PM data collection. 

Data PM Collection Enable or disable data (Ethernet, POS, SAN, and 8B10B) PM data collection.

Physical/Section PM 
Collection

Enable or disable physical or section (regenerator section [RS] and multiplex section [MS]) 
PM data collection on STM-N cards.

Physical/OTN PM Collection Enable or disable physical, OTN G.709 Section, OTN G.709 Path, and OTN FEC PM data 
collection on DWDM cards.

SNMP PM Collection Enable or disable CoS PM data collection.

DS1 PM Collection Enable or disable DS1 PM data collection.

DS3 PM Collection Enable or disable DS3 PM data collection.
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10.3.4.4 ONS 155xx

The ONS 155xx PM Service pane displays PM service information for the ONS 155xx NE. The 
following table provides descriptions.

Status Tab

Service Status Current status of the service: Active or Not Active.

Service Action Stops or starts a process. Notice that the Service Action button toggles between Activate and 
Deactivate, and that the Service Status field changes accordingly.

Threshold Number of NEs that will be serviced by one instance of the PM service.

Note Starting from CTM R9.2, one instance of the PM service can handle up to 2000 NEs.

Debug Tab

Overall Logging Click the Enable radio button to enable overall debugging and to select debug modules for 
the PM service. Click the Disable radio button to disable overall debugging.

Debug Modules If overall logging is enabled, lists the modules that can be used for debugging. Select a 
module from the Available list; then, click the Add button to add the module to the Selected 
list. Use the Remove button to return the module to the Available list. Debug logging will 
be performed on the modules in the Selected list.

PM Service Instance

Start Service Instance, Stop 
Service Instance

Allows you to stop or start an individual PM service instance. If you click Start Service 
Instance, the service status changes to Running. If you click Stop Service Instance, the 
status changes to Stopped.

Dump Cache Click the Dump Cache button to export the PM service cache to the log file related to the 
selected PM service instance.

Debug Table Click the Debug Table button to open the Prime Optical NE Module Level Debug Table 
window, which displays the debug state of the selected NEs and lists the modules for which 
debugging is active.

Overall Logging for the 
Instance

Click the Disable button to disable overall logging for the PM service instance.

Managed NEs The list of managed NEs shows which NEs are currently being managed by the selected 
service instance. If you stop the specified service instance, the NEs in the list are no longer 
managed.

Table 10-4 Field Descriptions for the ONS 15310 MA SDH/ONS 15454 SDH/CPT 600 SDH/CPT 200 SDH PM Service 

Pane (continued)

Field Description

Table 10-5 Field Descriptions for the ONS 155xx PM Service Pane

Field Description

Status Tab

Service Status Current status of the service: Active or Not Active.

Service Action Stops or starts a process. Notice that the Service Action button toggles between Activate and Deactivate, 
and that the Service Status field changes accordingly.

Threshold Number of NEs that will be serviced by one instance of the PM service.

Debug Tab
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10.3.4.5 ONS 15600 

The ONS 15600 PM Service pane displays PM service information for the ONS 15600 SONET NEs. 
The following table provides descriptions.

Overall Logging Click the Enable radio button to enable overall debugging and to select debug modules for the PM 
service. Click the Disable radio button to disable overall debugging.

Debug Modules If overall logging is enabled, lists the modules that can be used for debugging. Select a module from the 
Available list; then, click the Add button to add the module to the Selected list. Use the Remove button 
to return the module to the Available list. Debug logging will be performed on the modules in the 
Selected list.

PM Service Instance

Start Service 
Instance, Stop 
Service Instance

Allows you to stop or start an individual PM service instance. If you click Start Service Instance, the 
service status changes to Running. If you click Stop Service Instance, the status changes to Stopped.

Dump Cache Click the Dump Cache button to export the PM service cache to the log file related to the selected PM 
service instance.

Debug Table Click the Debug Table button to open the Prime Optical NE Module Level Debug Table window, which 
displays the debug state of the selected NEs and lists the modules for which debugging is active.

Overall Logging 
for the Instance

Click the Disable button to disable overall logging for the PM service instance.

Managed NEs The list of managed NEs shows which NEs are currently being managed by the selected service instance. 
If you stop the specified service instance, the NEs in the list are no longer managed.

Table 10-5 Field Descriptions for the ONS 155xx PM Service Pane (continued)

Field Description

Table 10-6 Field Descriptions for the ONS 15600 PM Service Pane

Field Description

PM Collection Parameters Tab

Physical/Section/Line PM 
Collection

Enable or disable physical, section, and line PM data collection. 

STS PM Collection Enable or disable SONET STS Path PM data collection.

Data PM Collection Enable or disable data (Ethernet and POS) PM data collection.

Status Tab

Service Status Current status of the service: Active or Not Active.

Service Action Stops or starts a process. Notice that the Service Action button toggles between Activate and 
Deactivate, and that the Service Status field changes accordingly.

Threshold Number of NEs that will be serviced by one instance of the PM service.

Debug Tab

Overall Logging Click the Enable radio button to enable overall debugging and to select debug modules for the 
PM service. Click the Disable radio button to disable overall debugging.
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10.3.4.6 ONS 15600 SDH

The ONS 15600 SDH PM Service pane displays PM service information for the ONS 15600 SDH NEs. 
The following table provides descriptions.

Debug Modules If overall logging is enabled, lists the modules that can be used for debugging. Select a module 
from the Available list; then, click the Add button to add the module to the Selected list. Use 
the Remove button to return the module to the Available list. Debug logging will be performed 
on the modules in the Selected list.

PM Service Instance

Start Service Instance, Stop 
Service Instance

Allows you to stop or start an individual PM service instance. If you click Start Service 
Instance, the service status changes to Running. If you click Stop Service Instance, the status 
changes to Stopped.

The list of managed NEs shows which NEs are currently being managed by the selected service 
instance. If you stop the specified service instance, the NEs in the list are no longer managed.

Table 10-6 Field Descriptions for the ONS 15600 PM Service Pane (continued)

Field Description

Table 10-7 Field Descriptions for the ONS 15600 SDH PM Service Pane 

Field Description

PM Collection Parameters Tab

Physical/RS/MS PM 
Collection

Enable or disable physical, RS, and MS PM data collection.

High Order PM Collection Enable or disable high-order PM data collection.

Data PM Collection Enable or disable data PM data collection.

Status Tab

Service Status Current status of the service: Active or Not Active.

Service Action Stops or starts a process. Notice that the Service Action button toggles between Activate and 
Deactivate, and that the Service Status field changes accordingly.

Threshold Number of NEs that will be serviced by one instance of the PM service.

Debug Tab

Overall Logging Click the Enable radio button to enable overall debugging and to select debug modules for the 
PM service. Click the Disable radio button to disable overall debugging.

Debug Modules If overall logging is enabled, lists the modules that can be used for debugging. Select a module 
from the Available list; then, click the Add button to add the module to the Selected list. Use 
the Remove button to return the module to the Available list. Debug logging will be performed 
on the modules in the Selected list.

PM Service Instance

Start Service Instance, Stop 
Service Instance

Allows you to stop or start an individual PM service instance. If you click Start Service 
Instance, the service status changes to Running. If you click Stop Service Instance, the status 
changes to Stopped.

The list of managed NEs shows which NEs are currently being managed by the selected service 
instance. If you stop the specified service instance, the NEs in the list are no longer managed.
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10.3.5 Activating or Deactivating Performance Monitoring

Step 1 In the Domain Explorer window, choose Administration > Control Panel.

Step 2 In the Control Panel window, expand PM Service.

Step 3 Select an NE type.

Step 4 All the NEs monitored by the server stop collecting PM data if you click the Deactivate button in the 
PM Configuration tab or Status tab > Service Action field. (Notice that the service status toggles to 
Not Active.) Click Activate to resume PM data collection.

Note If you need to activate or deactivate the PM Service again, go to the Service Monitor table 
(Administration > Service Monitor in the Domain Explorer) to verify that the service has 
stopped or started before clicking the Activate or Deactivate button again.

Step 5 Ensure that the PM Service has started. In the Domain Explorer, choose Administration > 
Service Monitor. The Service Monitor table should include an entry for the relevant PM Service.

Note If the PM Service is active and the NE time is changed so that the difference between the 
Prime Optical server time and the NE time is 30 minutes, the existing PM buckets (for the time 
stamps corresponding to the next collection interval on the NE, after the time change) collected 
by Prime Optical are marked as In Maintenance. Prime Optical collects PM buckets again for the 
same time stamps.

10.3.6 Enabling or Disabling PM Data Collection on an Individual NE

Note See 2.6.1 Selectable Collection of PM Data Parameters, page 2-12 for information on setting PM data 
collection.

Step 1 In the Domain Explorer or Subnetwork Explorer tree, select the NE node for which to stop or start PM 
data collection. The Network Element Properties pane opens.

Step 2 In the Status tab > PM Collection area, set the PM data collection state. Options vary by NE type:

• 15 Min—Check this box to enable collection of PM data every 15 minutes. Uncheck to disable PM 
data collection.

• 1 Day—Check this box to enable collection of PM data every 24 hours. Uncheck to disable PM data 
collection.

• 15 Min Robust—Check this box to enable collection of PM data every 15 minutes and attempt to fill 
in gaps in PM data collection should they occur.

• 1 Day Robust—Check this box to enable collection of PM data every 24 hours and attempt to fill in 
gaps in PM data collection should they occur.
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Caution If robust PM data collection is enabled, do not set PM data storage to Optimized.

Note • You cannot collect robust PM data until at least one 15-minute or one 1-day interval has been 
collected in normal operation.

• Robust PM data collection applies only to CTC-based NEs and to the ONS 15305, ONS 15530, and 
ONS 15540. Robust PM data collection is not supported for the ONS 15216.

Step 3 Click Save to save changes to the database.

Step 4 In the confirmation dialog box, click Yes. The changes take effect immediately.

Note The maximum number of ONS 15305 NEs that can have PM data collection enabled is 10 for a small 
network, 30 for a medium network, and 50 for a large or high-end network.

10.3.7 Enabling or Disabling PM Data Collection by PM Category for CTC-Based 
NEs

Note See 2.6.1 Selectable Collection of PM Data Parameters, page 2-12 for information on setting PM data 
collection.

Step 1 In the Domain Explorer window, choose Administration > Control Panel.

Step 2 In the Control Panel window, expand PM Service.

Step 3 Complete one of the following options:

• For the ONS 15305 R3.0, choose ONS 15305.

• For the ONS 15310 CL, ONS 15310 MA SONET, ONS 15327, or ONS 15454 SONET, choose 
ONS 15310 CL/ONS 15310 MA/ONS 15327/ONS 15454.

• For the ONS 15310 MA SDH or ONS 15454 SDH, choose ONS 15310 MA SDH/ONS 15454 SDH.

• For the ONS 15600 SONET, choose ONS 15600.

• For the ONS 15600 SDH, choose ONS 15600 SDH.

Step 4 Click the PM Collection Parameters tab, and enable or disable the various PM parameters. The 
following tables describe each parameter in detail:

• For the ONS 15305 R3.0, see Table 10-2.

• For the ONS 15310 CL, ONS 15310 MA SONET, ONS 15327, and ONS 15454 SONET, see 
Table 10-3.

• For the ONS 15310 MA SDH and ONS 15454 SDH, see Table 10-4.
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• For the ONS 15600 SONET, see Table 10-6.

• For the ONS 15600 SDH, see Table 10-7.

Step 5 After making your selections, click Save.

10.3.8 Enabling PM Data Collection for the ONS 15530 and ONS 15540
Before viewing performance data for an ONS 15530 or ONS 15540, enable performance monitoring on 
the NE in the Domain Explorer or by using the CLI.

Caution If robust PM data collection is enabled, do not set PM data storage to Optimized.

• To enable PM in the Domain Explorer, select an ONS 155xx NE in the Domain Explorer tree; then, 
set the PM data collection in the Network Element Properties pane to 15 Min, 1 Day, 15 Min Robust, 
or 1 Day Robust.

• To enable PM through the CLI, log into the NE and enter the monitor enable command. For more 
information, refer to the relevant hardware documentation.

10.3.9 Enabling or Disabling PM Retrieval Fail Alarms for CTC-Based NEs
Enabling the PM retrieval fail alarm allows Prime Optical to monitor failed collection of PM data when 
PM collection is set to either 15 Min Robust or 1 Day Robust. It lets you set the number of times for 
Prime Optical to collect PM data before declaring PM data retrieval failure.

Step 1 In the Domain Explorer window, choose Administration > Control Panel.

Step 2 Click PM Service. The PM Service pane opens.

Step 3 To enable 15-minute PM retrieval fail alarms, click Enable in the PM 15-min Retrieval Fail Alarm area; 
then, specify the following:

• Seconds between Retries—Wait time between attempts to retrieve PM data. The range is from 5 to 
15 seconds; the Cisco default is 5 seconds.

• Number of Retries—Number of times to retrieve PM data. The range is from 1 to 6 retries; the Cisco 
default is 6 retries.

Step 4 To enable 1-day PM retrieval fail alarms, click Enable in the PM 1-day Retrieval Fail Alarm area; then, 
specify the following:

• Minutes between Retries—Wait time between attempts to retrieve PM data. The range is from 15 to 
60 minutes; the Cisco default is 15 minutes.

• Number of Retries—Number of times to retrieve PM data. The range is from 1 to 6 retries; the Cisco 
default is 6 retries.

Step 5 Click Save.
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10.3.10 Specifying the PM Data Display
For CTC-based and ONS 155xx NEs, the display of PM data is affected by the PM Data Storage setting 
in the Control Panel. To specify whether to display PM data in normal or optimized mode for CTC-based 
and ONS 155xx NEs:

Step 1 In the Domain Explorer window, choose Administration > Control Panel.

Step 2 Click PM Service. The PM Service pane opens.

Step 3 In the PM Data Storage area, specify the PM data storage from the drop-down list:

• Normal—All performance data is collected and displayed in the PM data tables.

• Optimized—Performance data with all zero values and performance data with all invalid flags are 
not displayed and are not stored in the database.

Caution If robust PM data collection is enabled, do not set PM data storage to Optimized.

Step 4 Click Save.

10.3.11 Viewing the Robust PM Collection Queue

Step 1 In the Domain Explorer window, choose Administration > Control Panel.

Step 2 Click PM Service. The PM Service pane opens.

Step 3 In the Robust PM Collection Queue area are the following display-only fields:

• Number of 15-Min Registers Outstanding—Number of performance data collections carried out 
every 15 minutes that are not yet scheduled for collection.

• Number of 1-Day Registers Outstanding—Number of performance data collections carried out 
every 24 hours that are not yet scheduled for collection.

Step 4 (Optional) Click Clear Robust PM Queue to clear the queue. Then, click Save.

10.3.12 Using the Self Monitor Table
When Prime Optical comes close to or exceeds the limits of its performance, it might result in a 
reduction in the response time of the system. In this case, error messages are displayed to tell you to 
restore normal operation. The Self Monitor table allows you to monitor parameters that help in 
determining when Prime Optical is close to the limit of its performance.

The Self Monitor table displays information about Prime Optical threshold parameters. These 
parameters are collected and evaluated based on the NE model types. Self-monitoring can be used for 
CPU usage, memory usage, and disk usage. You can filter the Self Monitor table on the collection time, 
the model type, and the parameter name. 
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To view the Self Monitor table, choose Administration > Self Monitor in the Domain Explorer. The 
following table provides descriptions.

10.3.13 Filtering the Self Monitor Table

Step 1 In the Domain Explorer window, choose Administration > Self Monitor.

Step 2 In the Self Monitor table, choose File > Filter (or click the Filter Data tool). The Filter dialog box 
opens.

Step 3 Specify the filter parameters described in the following table.

Step 4 After making your selections, click OK.

Table 10-8 Field Descriptions for the Self Monitor Table

Column Name Description

Alias ID Alias name of the NE.

Parameter Name Name of the parameter. See the Alarm Configuration pane in the Control Panel for a list of monitored 
parameters.

Model Type NE model type. When NE model types are not applicable, “System” is displayed as the model type.

Collection Time 
(time zone)

Time when Prime Optical collected the parameter data.

Value Total number of seconds to retrieve the information for the name of the parameter.

NE ID Name of the selected NE. If you open the Self Monitor table without selecting an NE, the NE ID is CTM.

Table 10-9 Field Descriptions for the Self Monitor Table Filter Dialog Box

Tab Description

Collection Time 
(time zone)

You can filter data for a specified time period, ranging from the past hour to the past 180 days. 
Additionally, you can click the User Specified radio button to specify exact filter start and end times 
by date and hour. The time zone can be GMT, a user-defined offset from GMT, or local time, 
depending on what is specified in the User Preferences dialog box. Use the calendar tool to choose 
the year, month, and day:

• Year—Click the year combo box or the double arrow (<<, >>) at the bottom of the calendar.

• Month—Click the month combo box or the single arrow (<, >) at the bottom of the calendar.

• Day—Click the day number on the calendar. The current date is shown in blue.

If you want to filter data and the time period is not important, click No Time Specified.

Model Type You can move NE model types back and forth between the list of available model types and selected 
model types. The filter runs on the model types in the Selected Model Type list.

Parameter Name You can move parameters back and forth between the list of available parameter names and selected 
parameter names. The filter runs on the parameters in the Selected Parameter Names list.
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10.4 How Do I Query, View, Filter, and Graph PM Data?
This section describes the tools you use to query, view, filter, and graph the data displayed in PM tables.

10.4.1 Using the PM Table Query
The PM table query opens when you select an NE, group, or domain node in the Domain Explorer and 
choose Performance > PM Query by Category or PM Query by NE Model.

• Use the PM Query by Category wizard to filter PM data based on the PM category.

• Use the PM Query by NE Model wizard to filter PM data by NE model. 

10.4.1.1 Using the PM Query by Category Wizard

Use the PM Query by Category wizard to view PM data by PM category.

Note The PM Query by Category wizard is not supported for the ONS 155xx.

Note The CPT 200 and CPT 600 NEs support only the Ethernet, SONET, OTN, and Optical categories.

Step 1 In the Domain Explorer tree, select the management domain, group, or NE node for which to view 
historical performance data, and choose Performance > PM Query by Category. Table 10-10 provides 
descriptions. Fields shown depend on the PM category selected.

Step 2 In the Category area, select the category and type from the drop-down lists.

Step 3 Select the PM data collection interval (15 Minute, 1 Day, or Real-Time).

Note The Real-Time option is disabled if you select a management domain or group node. The 
Real-Time option is enabled only if you select a single NE in the Domain Explorer tree.

Step 4 (Optional) Click Next.

Note Depending on the NE type selected, some of the following screens might not appear. If a screen 
does not appear, skip the step and move on to the next one.

Step 5 In the Near End/Far End Selection screen, select whether to filter for near- or far-end PM data; then, 
click Next.

Step 6 In the Module Category screen, select the module category from the list; then, click Next.

Step 7 In the RPR Type Selection screen, select the type of RPR 802.17 data to display; then, click Next.

Step 8 In the Physical Location screen, depending on the NE type, select the rack, subrack (shelf), slot, subslot, 
and port from the list; then, click Next.

Step 9 In the Module Type Selection screen, add or remove module types from the lists; then, click Next.
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Note For real-time PM data collection, the Module Type Selection screen lists only the module that 
corresponds to the slot selected in the Physical Location screen.

Historical data might have been collected on a module that is no longer present at the selected 
physical location. Therefore, for historical PM data collection, the modules are not filtered by 
physical location.

Step 10 Click Finish. The PM table opens. See Appendix E, “Performance Data” for field descriptions for each 
PM table.

Table 10-10 Field Descriptions for the PM Query by Category Wizard 

Field Description

Category Selection Screen

Category Select a PM category from the list. Available categories vary by selected NE.

Type Select a PM query type for the NE. PM types vary by selected category.

15 Minute Filters for PM data received in the last 15 minutes. 15-minute PM data can be queried for a range 
of time from the past hour to the past 30 days.

1 Day Filters for PM data received in the last day. 1-day PM data can be queried for a range of time from 
the past 7 days to the past 180 days.

Real-Time (CTC-based 
NEs)

Launches a real-time PM report, which allows you to examine the current value of a PM parameter 
in granularities finer than the standard 15-minute or 1-day interval. You can view and modify the 
polling interval for the real-time PM reporting session. You can end a real-time PM session at any 
time and export the data.

Note You can also launch a real-time PM session from a selected row in a PM table. This is useful 
if you want to query on a single physical location (for example, Slot 1, Port 1).

User Specified Specify exact filter start and end times by date and hour. Use the calendar tool to choose the year, 
month, and day:

• Year—Click the year combo box or the double arrow (<<, >>) at the bottom of the calendar.

• Month—Click the month combo box or the single arrow (<, >) at the bottom of the calendar.

• Day—Click the day number on the calendar. The current date is shown in blue.

Near End/Far End Selection Screen

Near End Filters for near-end PM data.

Far End Filters for far-end PM data.

Module Category Screen

Module Category Select a module category from the list. Available categories vary by selected NE. This screen 
appears only if you select Ethernet as both the category and type in the Category Selection screen.

RPR Type Selection Screen
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The following table shows which PM tables are available for each category.

RPR Type Selection Filters RPR 802.17 PM data by MIB group:

• Span Stats In

• Span Stats Out

• Client Stats In

• Client Stats Out

• Error Stats

Physical Location Screen

Physical Location Filters PM data by slot, subslot, or port. Use the lists to select the slot, subslot, or port for which 
you want to display PM data. If you select a CTC-based NE, you can filter fault and performance 
data by shelf, slot, and port.

Module Type Selection Screen

Available Modules List of modules that are available for PM filtering. Select a module and click Add to move it to the 
Selected Modules list.

Selected Modules List of modules that are selected for PM filtering. Select a module and click Remove to remove it 
from filtering consideration.

Table 10-10 Field Descriptions for the PM Query by Category Wizard  (continued)

Field Description

Table 10-11 PM Tables by Category

Category PM Tables

SONET SONET Section PM table

SONET Line PM table

SONET STS Path PM table

SONET VT1.5 Path PM table

SONET VT2 Path PM table

SDH SDH Regenerator Section PM table

SDH Multiplex Section PM table

SDH Higher Order Virtual Container PM table

SDH Lower Order VC3 PM table

SDH Lower Order VC12 PM table

SDH Lower Order VC11 PM table

DSn DS1 PM table

DS3 PM table

DS3I PM table
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10.4.1.2 PM Query by NE Model Wizard

Use the PM Query by NE Model wizard to view PM data by non-CTC-based NE model.

Step 1 Make sure that performance monitoring is enabled on the NE. See 10.3.5 Activating or Deactivating 
Performance Monitoring, page 10-12.

Step 2 In the Domain Explorer tree, select the management domain, group, or NE node for which to view 
historical performance data and choose Performance > PM Query by NE Model. Table 10-12 provides 
descriptions. Fields depend on the type of NE and PM selected.

DWDM B1 Counters PM table

FEC Counters PM table

B1 and FEC Counters PM table

Ethernet Parameters PM table

Edge SDH Edge SDH Regeneration Section PM table

Edge SDH Multiplex Section PM table

Edge SDH Higher Order VC4 PM table

Edge SDH Lower Order PM table

Edge Statistics Edge Statistics DCC PM table

Edge Statistics LAN PM table

Edge Statistics WAN PM table

En E1 PM table

E3 PM table

Ethernet Ethernet PM table

Ethernet POS PM table

Ethernet CoS PM table

Ethernet GFP PM table

Ethernet LEX PM table

IP SLA IP SLA PM table

OTN OTN G.709 Section PM table

OTN G.709 Path PM table

OTN FEC PM table

Optical Optical Physical PM table

SAN SAN PM table

8B10B 8B10B PM table

RPR RPR 802.17 PM table

Table 10-11 PM Tables by Category (continued)

Category PM Tables
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Step 3 In the NE Model area, select the NE model and NE type from the drop-down lists.

Note You can only select non-CTC-based NEs.

Step 4 Select the PM data collection interval (15 Minute, 1 Day, or Real-Time).

Note The Real-Time option is disabled if you select a management domain or group node. The 
Real-Time option is enabled only if you select a single NE in the Domain Explorer tree.

Step 5 (Optional) Click Next.

Note Depending on the NE type selected, some of the following screens might not appear. If a screen 
does not appear, skip the step and move on to the next one.

Step 6 In the Near End/Far End Selection screen, select whether to filter for near- or far-end PM data; then, 
click Next.

Step 7 In the Module Category screen, select the module category from the list; then, click Next.

Step 8 In the RPR Type Selection screen, select the type of RPR 802.17 data to display; then, click Next.

Step 9 In the Physical Location screen, depending on the NE type, select the rack, subrack (shelf), slot, subslot, 
and port from the list; then, click Next.

Step 10 In the Module Type Selection screen, add or remove module types from the lists; then, click Next.

Note For real-time PM data collection, the Module Type Selection screen lists only the module that 
corresponds to the slot selected in the Physical Location screen.

Historical data might have been collected on a module that is no longer present at the selected 
physical location. Therefore, for historical PM data collection, the modules are not filtered by 
physical location.

Step 11 Click Finish. The PM table opens. See Appendix E, “Performance Data” for field descriptions for each 
PM table.

Table 10-12 Field Descriptions for the PM Query by NE Model Wizard 

Field Description

NE Model Selection Screen

NE Model Select a non-CTC-based NE model from the list.

Type Select a PM query type for the NE. The PM types vary by selected NE model.

15 Minute Filters for PM data received in the last 15 minutes. 15-minute PM data can be queried for a 
range of time from the past hour to the past 30 days.

1 Day Filters for PM data received in the last day. 1-day PM data can be queried for a range of time 
from the past 7 days to the past 180 days.
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User Specified Specify exact filter start and end times by date and hour. Use the calendar tool to choose the 
year, month, and day:

• Year—Click the year combo box or the double arrow (<<, >>) at the bottom of the 
calendar.

• Month—Click the month combo box or the single arrow (<, >) at the bottom of the 
calendar.

• Day—Click the day number on the calendar. The current date is shown in blue.

Near End/Far End Selection Screen

Near End Filters for near-end PM data.

Far End Filters for far-end PM data.

RPR Type Selection Screen

RPR Type Selection Filters RPR 802.17 PM data by MIB group:

• Span Stats In

• Span Stats Out

• Client Stats In

• Client Stats Out

• Error Stats

Physical Location Screen

Slot Filters PM data by slot.

Port Filters PM data by port.

Shelf Filters PM data by shelf.

Subslot (ONS 15530 and 
ONS 15540 only)

Filters PM data by subslot.

Module Type Selection Screen

Available Modules List of modules that are available for PM filtering. Select a module and click Add to move it 
to the Selected Module list.

Selected Modules List of modules that are selected for PM filtering. Select a module and click Remove to 
remove it from filtering consideration.

Real-Time PM Attribute Selection Screen

Interface Name (also Card, 
Physical Location, and so on)

Select the type of entity to monitor from this list. The label changes depending on the type 
of PM selected.

Available PM Attributes List of real-time attributes that are available for PM filtering. Select an attribute and click 
Add to move it to the Selected PM Attributes list.

Selected PM Attributes List of real-time attributes that are selected for PM filtering. Select an attribute and click 
Remove to remove it from filtering consideration.

Table 10-12 Field Descriptions for the PM Query by NE Model Wizard  (continued)

Field Description
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The following table shows which PM tables are available for each NE.

Table 10-13 PM Tables by NE Type

NE Available PM Tables

ONS 15216 —

ONS 15305 —

Note See Table 10-11, “PM Tables by Category.”

ONS 15310 CL Physical PM table

SONET Section PM table

SONET Line PM table

SONET STS Path PM table

SONET VT1.5 Path PM table

DS3 PM table

DS1 PM table

POS PM table

CoS PM table

Ethernet PM table

GFP PM table

ONS 15310 MA SONET Physical PM table

SONET Section PM table

SONET Line PM table

SONET STS Path PM table

SONET VT1.5 Path PM table

DS1 PM table

DS3 PM table

CoS PM table

POS PM table

Ethernet PM table

GFP PM table
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10.4.2 Configuring PM Collection Settings
Use the PM Collection Settings wizard to configure PM collection settings by NE type.

Step 1 Make sure that performance monitoring is enabled on the NE. See 10.3.5 Activating or Deactivating 
Performance Monitoring, page 10-12.

Step 2 In the Domain Explorer tree, select the management domain, group, or NE node for which to configure 
PM collection settings and choose Performance > PM Collection Settings. The following table 
provides descriptions. Fields depend on the type of NE selected.

Step 3 In the NE Selection screen, complete the following substeps:

a. In the NE Model area, select the NE model for PM collection settings from the drop-down list.

b. In the Network Elements area, click the Add and Remove buttons to move NEs of the selected type 
to the Selected NEs list. (Use the Remove button to remove NEs from the list.) By default, the 
Selected NEs list contains all of the NEs of the selected type in the Domain Explorer or Subnetwork 
Explorer when the wizard was launched.

c. Click Next.

Step 4 Depending on the NEs selected in the previous step, select the PM data collection intervals in one of the 
following screens:

ONS 15310 MA SDH Physical PM table

DS3 PM table

CoS PM table

POS PM table

Ethernet PM table

GFP PM table

Lower Order VC12 PM table

Lower Order VC3 PM table

SDH E1 PM table

SDH E3 PM table

SDH RS PM table

SDH MS PM table

SDH HO PM table

ONS 15530 SONET Section PM table

Line PM table

CDL PM table

Physical PM table

FC Port Errors PM table

Ether History PM table

Table 10-13 PM Tables by NE Type (continued)

NE Available PM Tables
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• PM Collection Selection (15 Min, 1 Day)—NEs that support 15-minute, 15-minute robust, 1-day, 
and 1-day robust PM collection (CTC-based NEs, ONS 15310, and ONS 15305).

• PM Collection Selection (15 Min Only)—NEs that support only 15-minute PM collection 
(ONS 155xx).

Step 5 Click Finish. 

The PM data collection settings are applied to all of the NEs in the Selected NEs list.

10.4.3 Launching the PM Table for Layer 3 Links from the Network Map

Step 1 In the Domain Explorer or Subnetwork Explorer tree, click a node and choose File > Network Map (or 
click the Open Network Map tool).

Step 2 Right-click a Layer 3 link in the Network Map and choose Link PM Data from the right-click menu.

Table 10-14 Field Descriptions for the PM Collection Settings Wizard 

Field Description

NE Selection Screen

NE Model Select the NE type for which you want to configure PM collection settings. The type you select 
determines the NEs that are displayed in the Network Elements area.

Network Elements Use the Add and Remove buttons to move the NEs for which you want to configure PM collection 
settings to the Selected NEs list, or to remove NEs from the list. 

PM Collection Selection (15 Min, 1 Day) Screen

15 Min If checked, 15-minute PM data collection is configured for the NEs you selected in the NE Selection 
screen.

1 Day If checked, 1-day PM data collection is configured for the NEs you selected in the NE Selection 
screen.

15 Min Robust (Available only if 15 Min is checked) If checked, 15-minute robust PM data collection is configured 
for the NEs you selected in the NE Selection screen.

1 Day Robust (Available only if 1 Day is checked) If checked, 1-day robust PM data collection is configured for 
the NEs you selected in the NE Selection screen.

PM Collection Selection (15 Min Only) Screen

15 Min If checked, 15-minute PM data collection is configured for the NEs you selected in the NE Selection 
screen.
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10.4.4 Managing Real-Time PM Data
Prime Optical supports the ability to launch a real-time PM report from the PM Query wizard or from a 
single row in a PM table. This feature allows you to examine the current value of a PM parameter in 
granularities finer than the standard 15-minute or 1-day interval. You can view and modify the polling 
interval for the real-time PM reporting session.

Note Real-time PM reporting applies only to CTC-based NEs.

The following real-time PM selection options are available:

• Polling—When selected, Prime Optical periodically polls the selected PM parameter(s) on the 
selected NE. The polling intervals are 10 to 900 seconds—For CTC-based NEs

Note You can specify the real-time polling interval in the Real-Time Polling dialog box. See 
10.4.4.1 Changing the Real-Time Polling Interval, page 10-27.

• Refresh—Allows you to start polling of real-time attributes if real-time polling is disabled in the 
Real-Time Polling dialog box.

• Baseline—When selected, the most recently collected data set is saved into a buffer. All new values 
are recalculated as they arrive based on the saved baseline values.

Note Not all values can be saved as a baseline. For example, null and string values cannot be saved 
as baseline values.

• Clear Baseline—Sets the baseline values to zero.

• Clear—Clears the current real-time PM buffer of all values.

Each 15-minute or 1-day PM table has a corresponding real-time PM table. However, not all of the fields 
in the historical PM tables are shown in the real-time PM tables. The first fields in real-time PM tables 
are:

• Alias ID—Alias name of the selected NE.

• Module Name—Module for which PM data is displayed.

• Physical Location—Slot and port number for which PM data is displayed.

• Interface—Interface name of the selected NE.

• Time Stamp—Time when the performance statistics were collected.

• Maintenance—Whether the NE was under maintenance when the performance data was collected.

The remaining fields are the actual real-time attributes being polled.

When a real-time PM session is running, it polls CTC-based NEs for x number of attributes every 10 to 
900 seconds. The data it returns is stored entirely in transient memory. You can use the PM Service 
properties pane in the Control Panel window to limit the scope of the real-time PM session. See 
10.3.3 Understanding the PM Service Pane, page 10-4.

• To launch a real-time PM report from the PM Query wizard, see 10.4.1.1 Using the PM Query by 
Category Wizard, page 10-17 or 10.4.1.2 PM Query by NE Model Wizard, page 10-20. In the NE 
Model Selection screen, click the Real-Time radio button.
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• To launch a real-time PM report from a single row in a PM table, select a row and choose View > 
Launch Real-Time Performance Session (or click the Launch Real-Time Performance Session 
tool).

• To clear the real-time PM counters on the NE, choose View > Clear PM Counters on NE (or click 
the Clear PM Counters on NE tool).

Note Use the toolbar icons to manage the real-time display. See Appendix A, “Icons and Menus 
Displayed in Prime Optical” for an explanation of the icons.

10.4.4.1 Changing the Real-Time Polling Interval

By default, the real-time PM session polls the attributes every 10 seconds for CTC-based NEs. You can 
configure the polling interval from 10 to 900 seconds.

Step 1 Launch a real-time PM table.

Step 2 Choose View > Specify Real-Time Polling Interval (or click the Specify the Real-Time Polling 
Interval tool). The Real-Time Polling dialog box opens.

Step 3 In the Specify Real-Time Polling Interval field, enter a number from 10 to 900 seconds.

Step 4 Complete one of the following options:

• To save the change, click Apply.

• To save the most recently collected data set into a buffer, click Baseline. All new values are 
recalculated as they arrive based on the saved baseline values.

• To set the baseline values to zero, click Clear Baseline. This disables the baseline set.

• To discard changes and close the dialog box, click Cancel.

10.4.4.2 Enabling or Disabling Real-Time Polling

Step 1 Launch a real-time PM table.

Step 2 Choose View > Specify Real-Time Polling Interval (or click the Specify the Real-Time Polling 
Interval tool).

Step 3 To disable real-time polling, uncheck the Enable Real-Time Polling check box. To enable real-time 
polling, leave this check box checked. When automatic polling is enabled, you do not need to manually 
refresh the real-time PM table.

Step 4 Click Apply.
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10.4.5 Filtering PM Data
Use the Filter dialog box (File > Filter) to filter data according to criteria that you select, and then 
display the results in a table. The following table provides descriptions.

Note The Filter dialog box is not available for real-time PM data.

10.4.6 Using PM Data Graphs
PM tables contain a Plot tab that allows you to plot historical or real-time PM data in a graphical view 
that is stored in the Prime Optical database. You can plot a maximum of three PM parameters at a time 
per graph. You can select a line or bar graph type and you can display multiple traces on the same set of 
axes for comparison. Prime Optical automatically scales the graph’s Y-axis to best show the values of 
the measured parameters. You can launch a graph of PM data for the following data types:

• One PM parameter on one board

• Multiple PM parameters on one board

Note Parameters must have similarly scaled ranges, such as errored seconds and severely errored 
seconds. For example, you cannot plot bit errored rate and errored seconds on the same 
graph. Instead, these parameters are plotted on separate graphs.

Table 10-15 Field Descriptions for the PM Table Filter

Tab Description

Time Stamp (also Time 
Period)

Filters PM data for a specified time period, ranging from the past hour to the past 6 months. 
Additionally, you can click the User Specified radio button to specify exact filter start and end 
times by date and hour. The time zone used can be GMT, an offset from GMT, or local time, 
depending on what you specified in the User Preferences dialog box. Use the calendar tool to 
choose the year, month, and day:

• Year—Click the year combo box or the double arrow (<<, >>) at the bottom of the calendar.

• Month—Click the month combo box or the single arrow (<, >) at the bottom of the calendar.

• Day—Click the day number on the calendar. The current date is shown in blue.

If you want to filter events and the time period is not important, click No Time Specified.

NE ID (also Network 
Elements)

Filters PM data by NE. PM data will display for NEs in the Selected list. Use the Add and Remove 
buttons to select the NEs for which you want to display PM data.

Module Name (also 
Managed Entities; not 
available for all NEs)

Filters PM data by module. PM data will display for modules in the Selected list. Use the Add and 
Remove buttons to select the modules for which you want to display PM data.

Physical Location Filters PM data by rack, subrack (shelf), slot, subslot, card, or port. (Options depend on the type 
of NE selected.) Use the drop-down lists to select the entity for which you want to display PM data.
10-28
Cisco Prime Optical 9.6 User Guide

OL-27078-01



Chapter 10      Managing Performance
How Do I Query, View, Filter, and Graph PM Data?
• One PM parameter on multiple boards

Note Boards must all support the selected PM parameter.

Complete the following steps to use PM data graphs:

Step 1 View PM data by PM category (see 10.4.1.1 Using the PM Query by Category Wizard, page 10-17) or 
non-CTC-based NE Model (see 10.4.1.2 PM Query by NE Model Wizard, page 10-20).

Step 2 From the PM table, select the row of the NE, port, or slot for which you want to view the PM data on a 
graph.

Step 3 Choose View > Plot (or click the Plot tool).

Note To plot the graph, you must choose View > Plot or click the Plot tool. If you simply click the 
Plot tab (without choosing View > Plot or clicking the Plot tool), the graph is not filled out.

In the Plot tab, the graph is displayed. The graph can plot a maximum of three PM parameters. The 
graph’s status bar displays the selection context in the following format:

<NE_ID>:<Module>:<Physical_location>:<Interface>:<Time_stamp [Time_zone]>

Note Physical-location includes shelf, slot, and port information; for example, Shelf: 1, Slot: 14, 
Port: 0.

Step 4 Use the plot-specific toolbar buttons to manage the graphical display. Choose View > Zoom In, Zoom 
Out, or Fit in Window to adjust the zoom level. You can also click the Zoom In, Zoom Out, or Fit in 
Window tools.

Note If Prime Optical cannot complete samples retrieval in a certain time frame (for example, due to a 
temporary loss of communication), the PM graph interpolation will be traced from the last sample that 
was retrieved before the malfunction occurred to the first sample that was retrieved after normal behavior 
was restored.

10.4.6.1 Configuring a Graph

Use the Graph Parameters Selection dialog box to modify the parameters that are plotted in a graph.

Step 1 From the PM table, select the row for which you want to view the PM data on a graph.

Step 2 Choose View > Graph Configure (or click the Configure Graphing Parameters tool). The Graph 
Parameters Selection dialog box opens.

Step 3 For historical PM graphs, select the start and end times in the Time Panel area. Select the date, hour, and 
minute from the corresponding drop-down lists.
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Note Real-time PM graphs do not have a Time Panel area, because a time range does not apply to 
real-time data.

Step 4 In the Parameter Selection area, select the parameters from the Available Parameters list that you want 
to plot in the graph. You can generate a maximum of three graphs and each graph can plot a maximum 
of three parameters.

Step 5 Click the Add button that corresponds to the graph where the parameter will be plotted. Selected 
parameters are listed in the Selected Parameters: Graph number list.

Step 6 To remove parameters from the Selected Parameters: Graph number list, select parameters and click 
Remove.

Step 7 Click OK. The graph is displayed in the Plot tab. The status bar displays the module name, physical 
location, interface, date range, and time stamp range.

Step 8 You can adjust the zoom level for each graph. Click a graph and choose View > Zoom In, Zoom Out, 
or Fit in Window. You can also click the Zoom In, Zoom Out, or Fit in Window tools.

Step 9 You can normalize or restore the Y axes values in historical PM graphs. Choose View > Normalize Y 
Axes or Restore Y Axes (or click the Normalize Y Axes or Restore Y Axes tools). The Normalize 
option allows you to normalize axes values and compare data of the same type (for example, receive 
versus transmit packets). The Restore option restores axes values to the previous graph visualization.

Note The Normalize and Restore options do not apply to real-time PM graphs.

10.4.6.2 Printing a Graph

Step 1 After viewing PM data on a graph or configuring a graph, choose File > Print Graph (or click the Print 
Graph tool). The Print dialog box opens.

Step 2 Select your printer and configure the page setup options, as necessary.

Step 3 Click OK.

Note PM graphs might not print completely on some printers with the default page setup settings. In 
this case, you need to change the printer setup. To do this, click Properties in the Print dialog 
box. Click Advanced. Change the scaling to a value that prints the complete graph; for example, 
10% or 20%. Click OK.
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10.4.7 Understanding How Prime Optical Displays the Interface Field
Prime Optical displays the Interface field in PM tables as follows:

• ONS 15305

Prime Optical representation:

Interface-type#Interface-type-numberAUG4-AUG4-number/AUG1-AUG1-number/TUG3-TUG3-n
umber/TUG2-TUG2-number/TU12-TU12-number

where:

– Interface-type is the affected interface object

– Interface-type-number is the interface number

– AUG4-number is the AUG4 number (applies to VC-4, VC3, and VC12)

– AUG1-number is the AUG1 number (applies to VC-4, VC3, and VC12)

– TUG3-number is the TUG3 number (applies only to VC3 and VC12 interfaces)

– TUG2-number is the TUG2 number (applies only to VC12 interfaces)

– TU12-number is the TU2 number (applies only to VC12 interfaces)

• SDH

Prime Optical representation:

Interface-type#VC4-number/VC3-VC3-number/TUG2-TUG2-number/VC12-VC12-number

where:

– Interface-type is the affected interface object (for example, VC4, VC4-2c, VC3, VC12, and so 
on)

– VC4-number is the VC4 number in that interface (applies only to VC4, VC3, and VC12 
interfaces)

– VC3-number is the VC3 number in that VC4 (applies only to VC3 interfaces)

– TUG2-number is the TUG2 number in that VC3 (applies only to VC12 interfaces)

– VC12-number is the VC12 number in that TUG2 (applies only to VC12 interfaces)

For example, for alarms on a VC12 interface with VC4-number = 1, VC3-number = 2, 
TUG2-number = 1, and VC12-number = 2, Prime Optical displays VC12 
#1/VC3-2/TUG2-1/VC12-2, where the first field is the affected interface and VC4 number 
(#VC4-number). This example indicates that the alarm is on the VC12 interface with the VC4 
number equal to 1 (VC12 #1).

• SONET

Prime Optical representation: 

Interface-type#STS-number/VT-group-number-VT-number-in-group

where:

– Interface-type is the affected interface object (for example, STS1, STS3c, VT-1, and so on)

– STS-number is the STS number on that interface (applies only to STS and VT interfaces)

– VT-group-number is the VT group number for that STS number (applies only to VT interfaces)

– VT-number-in-group is the VT number in that VT group (applies only to VT interfaces)

For example:
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– For a VT path-level alarm with STS-number = 1, VT-group-number = 2, and 
VT-number-in-group = 1, Prime Optical displays VT-1 #1/2-1, where the first field is the 
affected interface and STS number (#STS-number). This example indicates that the alarm is a 
VT path-level alarm with STS-number = 1 (VT-1 #1).

– For an STS path-level alarm with STS-number = 1, Prime Optical displays STS3c #1, where the 
first field is the affected interface and STS number (#STS-number). This example indicates that 
the alarm is an STS path-level alarm with STS-number = 1 (STS3c #1).
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