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Maintaining an Efficient Network

This topic contains the following information to help you maintain an efficient network:

• 4.1 Overview, page 4-1

• 4.2 How Do I Manage the Database?, page 4-2

• 4.3 How Do I Manage the Network Software?, page 4-27

• 4.4 How Do I Modify the Network?, page 4-42

• 4.5 How Do I Manage Redundancy and Failover?, page 4-58

• 4.6 How Do I Monitor the Network?, page 4-87

• 4.7 How Do I Manage CTC Operations?, page 4-96

Note For information about configuring users and user-related parameters, creating and modifying advisory 
messages, and accessing logs, see Chapter 8, “Managing Security.”

4.1 Overview
Maintaining your network focuses on tasks that will keep your network running smoothly. Examples 
include:

• Backing up and restoring memory and the database

• Creating and maintaining protection groups

• Restoring default settings when necessary

• Monitoring tasks and jobs

• Modifying basic server and NE information

• Finding modules or boards

• Updating software images and versions

• Exporting data and generating reports

• Performing administrative database operations
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4.2 How Do I Manage the Database?
This section describes procedures for managing the Oracle database and deals specifically with Cisco 
Prime Optical data stored in the database. For a complete description, refer to the Oracle documentation.

A useful tool for managing the database is the Oracle Enterprise Manager, part of the Oracle 10g Client 
CD. The Oracle Enterprise Manager provides an integrated solution for managing heterogeneous 
environments and combines a graphical console, agents, common services, and tools to provide a 
comprehensive systems-management platform for managing Oracle products.

4.2.1 Viewing and Modifying Database Properties
The Database Properties pane in the Control Panel shows and defines database pruning parameters and 
the configuration that the Prime Optical server uses to connect to the Oracle database. The pane contains 
the following tabs:

• Configuration—Defines the values used by the Prime Optical server to log into the Oracle database. 
Fields are grouped into two columns: Activated After Restart and Active. The Activated After 
Restart column shows the values that the Prime Optical server uses after the server is restarted. The 
Active column displays the values currently used by the Prime Optical server.

• Pruning—Defines the Prime Optical database pruning frequency. Database pruning is enabled by 
default. You can configure the performance monitoring (PM) pruning interval for 5-minute, 
10-minute, 15-minute, and 1-day data collection, giving you a finer level of control over the pruning 
of performance data from the system. Pruning frequency changes take effect as soon as you save 
them; you do not need to reboot the Prime Optical server.

• Database Operations—Allows you to start a database backup or export from the Control Panel. After 
entering the password, click Start to begin the database backup or export. The backup section is 
disabled if the database is not installed in ARCHIVELOG mode. The ARCHIVELOG mode is 
stored in the CTM_config_table by the server installer.

Complete the following steps to view and modify the database properties:

Step 1 In the Domain Explorer window, choose Administration > Control Panel.

Step 2 Click Database Properties to open the Database Properties pane. The following table provides 
descriptions.

Step 3 (Optional) Modify the values in the Configuration, Pruning, or Database Operations tabs.

Step 4 Click Save.

Table 4-1 Field Descriptions for the Database Properties Pane

Field Description

Configuration Tab

Database Server 
Configuration

Display only. Displays the size of the database server.
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Enable 
ARCHIVELOG 
Mode

If checked, the ARCHIVELOG mode is enabled. When the database is in ARCHIVELOG mode, 
Prime Optical supports automatic pruning of the /db05 partition.

Note When you check the Enable ARCHIVELOG Mode check box, the Archive Log Pruning 
Parameters check box (located in the Database Operations tab) is checked automatically.

Caution To change the ARCHIVELOG mode in a high availability (HA) configuration, you must 
freeze the ctmgrp service group before making the change, and unfreeze the ctmgrp service 
group when the change is complete.

Enter the following commands on all of the clusters to freeze the ctmgrp service group:

haconf -makerw

hagrp -freeze ctmgrp -persistent

haconf -dump -makero

After the Prime Optical server restarts, enter the following commands on all of the clusters 
to unfreeze the ctmgrp service group:

haconf -makerw

hagrp -unfreeze ctmgrp -persistent

haconf -dump -makero

Configuration Mode Configuration Mode tells the Prime Optical server the values to use to log into the Oracle database. 
When set to Auto, the Prime Optical server uses the configuration that was set when Prime Optical was 
installed. When set to Manual, the Password field can be changed, and the Prime Optical server uses 
the new password after the server is rebooted.

Note If you change the configuration mode to Manual, enter the following commands to set the 
ORACLE_HOME and ORACLE_SID environment variables before logging into Prime Optical 
again. (The C-shell is assumed for all UNIX commands.)

setenv ORACLE_HOME Oracle-home-directory
setenv ORACLE_SID CTM
setenv LD_LIBRARY_PATH $ORACLE_HOME/lib
setenv PATH $PATH:$ORACLE_HOME/bin

Restart the Prime Optical server after setting these environment variables. To do this, enter the 
opticalctl stop command to shut down the Prime Optical server. Then, enter the opticalctl 
start command to restart it.

Caution If you set the configuration mode to Auto and restart the Prime Optical server, the 
CTMServer.cfg file does not change; the parameters retain their previous values.

Username Display only. Displays the username that the Prime Optical server uses to access the Oracle database.

Table 4-1 Field Descriptions for the Database Properties Pane (continued)

Field Description
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Password Displays the password that gives the username access to the Oracle database. You can change the 
database password only if the database is not embedded and if the configuration mode is set to Manual. 
If the configuration mode is set to Auto, the password is display only.

Note The database password cannot contain the characters @, ", and /, because SQL*PLUS 
interprets them as special characters.

Note After a Prime Optical server restart, the Prime Optical client attempts to log in automatically 
for 6 minutes before exiting. If the Prime Optical server initialization requires additional time 
to complete, you might need to restart the Prime Optical client.

Caution The default password is Ctm123! and any changes are saved in the CTMServer.cfg file. If 
you change the default password, the following caution is displayed: “Changing the database 
password will restart the Prime Optical server. Are you sure you want to continue?” Click 
Yes to confirm the action. The password is validated and the following message is broadcast: 
“Caution: The database password has been changed by a user. The Prime Optical server will 
restart in 15 seconds.”

Caution To change the Oracle database password in an HA configuration, see “Changing the Oracle 
Database Password from the Prime Optical Client in an HA Configuration” in Cisco Prime 
Optical Release 9.6 High Availability Installation Guide.

Confirm Password (Available when the configuration mode is set to Manual) Re-enter the database password to confirm it.

Location Display only. Displays the IP address that the Prime Optical server uses to connect to the database.

Port Display only. Displays the port number that is used to connect to the database.

System ID Display only. Displays the Oracle system ID. The ORACLE_SID specifies the system identifier (SID) 
value of the database instance that you create with the Prime Optical installer. For a single-instance 
database, the SID value should be the same as the name of the database it manipulates (initialization 
parameter DB_NAME), and no more than four characters.

Note During Prime Optical installation, the default system ID is CTM.

SQL Network Alias Display only. Displays the SQL*Net listener alias set in the system listener.ora file. When the listener 
is running, entering the ps command displays the following output (not all systems display 
listener_alias):

tnslsnr [listener_alias] [-inherit]

Shadow processes (dedicated servers) spawned by the SQL*Net listener have the following syntax: 
oracleSID [(LOCAL=NO)]

Pruning Tab

PM Data (5, 10, 
15 min)

Specifies the number of days to save 5-, 10-, or 15-minute PM data before Prime Optical runs the 
database pruning script. You can save from 1 to 1000 days of data. The default value is 30 days. You 
can also specify the time of day when the PM data will be saved by choosing the hour and minute from 
the Hour, Minutes, and AM/PM fields. Minutes are listed in 5-minute intervals. Check the Enable 
check box to activate the PM data pruning.

Table 4-1 Field Descriptions for the Database Properties Pane (continued)

Field Description
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PM Data (1 day) Specifies the number of days to save 1-day PM data before Prime Optical runs the database pruning 
script. You can save from 1 to 1000 days of data. The default value is 30 days. You can also specify the 
time of day when the PM data will be saved by choosing the hour and minute from the Hour, Minutes, 
and AM/PM fields. Minutes are listed in 5-minute intervals. Check the Enable check box to activate 
the PM data pruning.

FM Data Specifies the number of days to save cleared and acknowledged alarms in the Alarm Log before 
Prime Optical prunes alarms from it. You can save from 1 to 1000 days of data. The default value is 
7 days. You can also specify the time of day when alarms will be pruned by choosing the hour and 
minute from the Hour, Minutes, and AM/PM fields. Minutes are listed in 5-minute intervals. Check the 
Enable check box to activate alarm pruning.

Note Alarms shown in the Alarm Browser are not pruned. They are saved to the Alarm Log when 
they are cleared and acknowledged. Alarms can be acknowledged manually by a user, or 
acknowledged automatically if the automatic acknowledgement feature is enabled in the 
Control Panel > UI Properties pane > Fault Management area.

Audit Log Data Specifies the number of days to save Audit Log data before Prime Optical runs the database pruning 
script. You can save from 1 to 1000 days of data. The default value is 7 days. You can also specify the 
time of day when the Audit Log data will be saved by choosing the hour and minute from the Hour, 
Minutes, and AM/PM fields. Minutes are listed in 5-minute intervals. Check the Enable check box to 
activate the Audit Log data pruning.

Error Log Data Specifies the number of days to save Error Log data before Prime Optical runs the database pruning 
script. You can save from 1 to 1000 days of data. The default value is 7 days. You can also specify the 
time of day when the Error Log data will be saved by choosing the hour and minute from the Hour, 
Minutes, and AM/PM fields. Minutes are listed in 5-minute intervals. Check the Enable check box to 
activate the Error Log data pruning.

Audit Trail Data (for 
CTC-based NEs)

Specifies the number of days to save audit trail data before Prime Optical runs the database pruning 
script. You can save from 1 to 1000 days of data. The default value is 7 days. You can also specify the 
time of day when the audit trail data will be saved by choosing the hour and minute from the Hour, 
Minutes, and AM/PM fields. Minutes are listed in 5-minute intervals. Check the Enable check box to 
activate the audit trail data pruning.

Self Monitor Data Specifies the number of days to save self-monitoring data before Prime Optical runs the database 
pruning script. You can save from 1 to 1000 days of data. The default value is 7 days. You can also 
specify the time of day when the self-monitoring data will be saved by choosing the hour and minute 
from the Hour, Minutes, and AM/PM fields. Minutes are listed in 5-minute intervals. Check the Enable 
check box to activate the self-monitoring data pruning.

Job Monitor Data Specifies the number of days to save job monitoring data before Prime Optical runs the database 
pruning script. You can save from 1 to 1000 days of data. The default value is 7 days. You can also 
specify the time of day when the job monitoring data will be saved by choosing the hour and minute 
from the Hour, Minutes, and AM/PM fields. Minutes are listed in 5-minute intervals. Check the Enable 
check box to activate the job monitoring data pruning.

Database Operations Tab > Backup Area

‘sys’ Password The password for the sys user. The default Oracle password for the sys user is change_on_install.

Backup Status The status of the database hot backup. The default is Unknown.

Oracle Installation Check this check box to back up the entire Oracle installation directory.

Solaris 
Configuration

Check this check box to back up the common Solaris configuration files used by the Oracle installation.

Table 4-1 Field Descriptions for the Database Properties Pane (continued)

Field Description
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Database 
Configuration

Check this check box to back up the operating system configuration files.

All Check this check box to back up all of the database components (Oracle installation, Solaris 
configuration, and database configuration).

Start button Click the Start button to back up the selected database component(s).

Database Operations Tab > Archive Log Pruning Parameters Area

Enable Allows you to enable (default) or disable archive log pruning.

Caution If ARCHIVELOG mode is enabled, the archive log pruning should never be disabled. If the 
archive log pruning is disabled, the /db05 partition might fill up and the Prime Optical 
database might shut down.

Threshold Enter the pruning threshold. By default, when the archive log reaches 70 percent of capacity, pruning 
begins.

Caution Do not set this threshold to a high value (such as 90 percent). If the threshold is too high, the 
/db05 partition could fill up before the archive log pruning makes space available.

Archive Log Backup 
Directory

Specify the location for the archive log backup files. The default directory is /ctm_backup.

Caution Make sure that the archive log backup directory exists and has enough space to store the 
compressed archive log files. Check periodically to make sure that this directory is not full.

Database Operations Tab > Export Area

Export Status The status of the database export process. The default is Unknown. 

Oracle Installation Check this check box to export the entire Oracle installation directory.

Caution This option requires a large amount of disk space (about 2.5 GB) in the /ctm_backup 
directory.

Solaris 
Configuration

Check this check box to export the common Solaris configuration files used by the Oracle installation.

Database 
Configuration

Check this check box to export the operating system configuration files.

All Check this check box to export all of the database components (Oracle installation, Solaris 
configuration, and database configuration).

Start button Click the Start button to export the selected database component(s).

Table 4-1 Field Descriptions for the Database Properties Pane (continued)

Field Description
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4.2.2 Changing the Prime Optical Database Password
Complete the following procedure to change the password that gives the username access to the Oracle 
database. You can perform this operation only if the database is not embedded.

The following procedure applies to changing the Oracle database password in a non-HA environment. 
To change the database password in an HA configuration, see “Changing the Oracle Database Password 
from the Prime Optical Client in an HA Configuration” in Cisco Prime Optical Release 9.6 High 
Availability Installation Guide.

Step 1 In the Domain Explorer window, choose Administration > Control Panel.

Step 2 Click Database Properties to open the Database Properties pane.

Step 3 Click the Configuration tab.

Step 4 Change the password in the Password field. The default password is Ctm123! and any changes are saved 
in the CTMServer.cfg file. You can change the database password if the configuration mode is set to 
Manual. If the configuration mode is set to Auto, the password is display only.

Note The database password cannot contain the characters @, ", and /, because SQL*PLUS interprets 
them as special characters.

Step 5 In the Confirm Password field, re-enter the database password to confirm it.

Step 6 After you change the default password, the following caution is displayed: “Changing the database 
password will restart the Prime Optical server. Are you sure you want to continue?” Click Yes to confirm 
the action. The password is validated and the following message is broadcast: “Caution: The database 
password has been changed by a user. The Prime Optical server will restart in 15 seconds.”

Step 7 Click Save.

The Audit Log records the history of the database password change.

• If the Prime Optical server stops, the database password change procedure executes and all 
Prime Optical clients are shut down.

To check whether the password change succeeded, view the Alarm Browser, which should not 
indicate a failure with the database password change. The CTMServer.cfg file in the 
/opt/CiscoTransportManagerServer/cfg directory should report CHANGED in the 
db-password-change-status section of the file. You can view the file with a system editor or with the 
command cat CTMServer.cfg.

If the Alarm Browser reports a password-related alarm, view the following report logs in the /temp 
directory:

– change_db_password_execute.log (the logger file)

– change_db_password_execute.err (the file that contains the error)

– change_db_password.out (the output of the opticalctl stop and opticalctl start scripts)

• If the Prime Optical server does not stop, a prerequisite check failed. View the Alarm Browser for 
an alarm that explains the failure. Also view the preceding log files to understand the error.
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4.2.3 Overview of Backing Up the Prime Optical Database
This section provides guidelines for backing up the Prime Optical database. Various factors affect the 
database backup, including the type of installation and the Prime Optical system performance. 
Ultimately, your database administrator (DBA) must determine the best method of backing up the 
Prime Optical database.

Consider the following definitions:

• Backing up the database means safely storing the data in the Prime Optical database.

• Restoring the database means taking a specific image of a previous database backup and applying 
it to re-establish an earlier situation.

• Recovering the database means taking a specific image of a previous database backup and applying 
it to recover from data corruption or loss of data.

You can back up the Prime Optical database using the following methods, which are described in 
Table 4-2 and in the subsequent sections:

• Hot backup

• Cold backup

• Export

4.2.3.1 Understanding Hot Backup, ARCHIVELOG Mode, and the /db05 Directory

You can perform a hot backup while the Prime Optical server is running. A hot backup requires no 
downtime, but your Prime Optical database must be running in ARCHIVELOG mode.

In ARCHIVELOG mode, the database saves a redo log whenever a log switch occurs in /db05/*.arc files. 
Redo logs are composed of a group of special files that are filled cyclically. Before rewriting an existing 
redo log, the archive process makes a copy of the log and produces the archive (.arc) files.

Oracle registers in the redo logs every activity that occurs in the database.

Table 4-2 Methods for Backing Up the Prime Optical Database

Method Description Prime Optical Status
Available from 
the GUI?

Available from 
the CLI?

Hot backup A physical copy of 
the database

The Prime Optical server can be running; the 
Prime Optical database (Oracle) must be running.

Yes Yes

Cold backup A physical copy of 
the database

The Prime Optical server and the Prime Optical 
database (Oracle) must be shut down.

No Yes1

1. You can perform a cold backup manually by using Telnet or an SSH session (CLI) on the Prime Optical database server; however, there are no 
Prime Optical scripts available for this operation.

Export A logical copy of the 
database

If the database is exported from the CLI, the 
Prime Optical server must be shut down and the 
Prime Optical database (Oracle) must be running.

If the database is exported from the GUI, both the 
Prime Optical server and database must be 
running. In this case, all NE and PM services must 
be shut down, and only one Prime Optical client 
can be connected.

Yes2

2. The exported image might contain inconsistencies when exporting from the GUI, because the Prime Optical server is running during the export.

Yes
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It is not possible to estimate the rate of production of archive files, because the rate depends on the 
number of log switches in the system. The number of log switches relates to the Prime Optical server 
workload: During an intensive session with multiple commits of active transactions, the number of log 
switches increases.

The archive files, in addition to the initial backup of the database, are part of the backup itself and must 
be kept in a safe place, such as on tape or on a similar storage device. Prime Optical uses the /db05 
partition to store the archive files.

During normal system operation, the /db05 directory fills up. You can configure automatic pruning of 
the /db05 directory in the Control Panel. If automatic pruning is enabled, the archive files are zipped and 
moved to the /ctm_backup directory.

Prime Optical checks the /db05 partition once every 5 minutes. When archive log pruning for the /db05 
partition exceeds the configured threshold, all archive files except for the most recent one are 
compressed and moved to the /ctm_backup directory. Therefore, make sure that /db05 is in its own 
partition and not under the root directory.

Set the archive log pruning threshold to a medium value, such as 60 or 70 percent. If you set the threshold 
to a very high value (such as 90 percent), you risk filling up the /db05 partition. If the /db05 partition 
fills while ARCHIVELOG mode is enabled, Oracle stops and Prime Optical hangs.

If you set the threshold to a very low value (such as 10 percent), the /db05 partition is pruned 
continuously, which slows down the system unnecessarily.

To view or change the archive log pruning threshold:

Step 1 In the Domain Explorer window, choose Administration > Control Panel.

Step 2 Click Database Properties to open the Database Properties pane.

Step 3 Click the Database Operations tab. The Archive Log Pruning Parameters area shows the configured 
threshold.

Step 4 After modifying the Threshold value, click Save.

A database backup comprises two main groups of files:

• The files produced under the /ctm_backup directory, which contains a compressed dump of all of 
the data in the database, including the actual read logs.

• The archive (.arc) files produced during and after the backup.

You can perform a hot backup from the GUI (see 4.2.4 Backing Up the Prime Optical Database from 
the Prime Optical GUI, page 4-12). You can also perform a hot backup from the CLI, using the 
backupdb.sh script (see 4.2.6 Backing Up or Exporting the Prime Optical Database from the CLI, 
page 4-14).

The Prime Optical restore procedure manages all of the information required to restore the database; you 
provide only the location of the backup and archive files.

A hot backup has the following advantages:

• You can recover the database contents up to the last transaction that occurred before a crash, 
returning the lowest amount of lost data.

• There is no Oracle downtime.

• You can use Oracle’s RMAN product to configure the backup. 
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A hot backup has the following disadvantages:

• It requires more disk space, because depending on database activity, the archive log function 
produces many snapshots.

• It requires planning to avoid filling up the archive log and the /db05 partition.

Use the following guidelines for performing a hot backup:

• By default, the files created by the hot backup are saved in the /ctm_backup directory. Make sure 
that the /ctm_backup directory exists and has the correct permissions and adequate space.

• Make sure that /ctm_backup is not under the root partition, because it could fill up.

• For optimal results, the Prime Optical server should perform limited activity on the database while 
the hot backup is running. Therefore, launch the hot backup when users are not working on the 
system.

• All of the changes performed by the Prime Optical server after the backup starts are logged to the 
archive files under /db05. These archive files contain required copies of redo logs that are 
overwritten by Oracle along with the backup files under /ctm_backup.

• Perform a hot backup regularly, especially after completing a significant amount of work. Regular 
backups reduce the number of archive files to save.

• In a stable network, it is recommended that you perform both a hot backup and a full export. Before 
the first backup, remove all nonessential files from the /ctm_backup and /db05 directories.

• After a hot backup, save all files in the /db05 and /ctm_backup directories in a safe place.

Use the following guidelines for restoring the database:

• After using a hot backup to restore or recover the database, all previous backups become obsolete. 
It is recommended that you perform a hot backup after a restore, when all previous backups can be 
safely removed.

• Restore the database on the same workstation where the backup was performed. This is particularly 
important in high availability configurations.

Use the following guidelines for managing the archive log:

• It is important to store safely the archive files that are produced after a hot backup.

• To avoid generating many archive files that must be saved on disk or tape, perform a hot backup on 
a regular basis. Regular backups facilitate the restore/recovery operation by reducing the number of 
archive files to save.

4.2.3.2 Monitoring the Growth of the /ctm_backup Directory

Because it is not possible to estimate the rate of production of archive files, the /ctm_backup directory 
might exhaust the available disk space. Without disk space, the Oracle archive process cannot archive 
the redo logs to be overwritten, and the database freezes. The archive redo logs, which are vital to restore 
and recover a database, should be saved in a safe place. You might want to create a cron job to save your 
data.

4.2.3.3 Understanding Cold Backup

A cold backup is the safest way to take a snapshot of the database. In a cold backup, the Prime Optical 
server is stopped; then, the Oracle database is shut down. The database contents and the directories 
/db01, /db02, /db03, /db04, and /db05 are copied to a tape or storage device.
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A cold backup has the following advantages:

• Thorough, safe physical backup of the database.

• Simple to complete using basic operating system (OS) commands and by copying all of the files and 
the directory structure of /db01, /db02, /db03, /db04, and /db05.

A cold backup has the following disadvantages:

• Because you take a physical copy of the entire database at a specific time while Prime Optical and 
Oracle are down, the database image is not updated with subsequent modifications.

• A cold backup requires you to shut down Prime Optical, during which time network monitoring is 
unavailable.

There is no recommended procedure to perform a cold backup; instead, your database administrator 
determines the exact steps. Use the following guidelines:

• Take a cold backup before any activities that could cause problems with Prime Optical or your OS 
(for example, before installing an Oracle patch or upgrading your Prime Optical version).

• Take a cold backup after important changes.

• Create a .tar file of all of the structures in $ORACLE_HOME and include it with the cold backup 
files.

4.2.3.4 Understanding Export

An export is a logical copy of the database objects on a single *.dmp file. You can export the database 
from the GUI (see 4.2.5 Exporting the Prime Optical Database from the Prime Optical GUI, page 4-13). 
You can also export the database from the CLI, using the export_full_db.sh script (see 4.2.6 Backing Up 
or Exporting the Prime Optical Database from the CLI, page 4-14).

When exporting the database, all of the constraints are removed; then, the objects and constraints are 
recreated. It is recommended that the Prime Optical server be shut down during the export operation.

An export has the following advantages: 

• It is relatively easy to take a logical snapshot of the database contents at a specific time. 

• There is no Oracle downtime.

• The restore operation is simple and can be applied on different servers (with the correct database 
schema).

An export has the following disadvantages:

• It is not a complete backup. If you have database corruption that you cannot recover from, you must 
recreate the database and then repopulate it with a full export.

• To avoid inconsistencies, you must stop the Prime Optical server.

Use the following general guidelines when exporting the database:

• An export is useful to re-establish the previous contents of the database. Use an export when you 
plan a critical modification or to eliminate fragmentation.

For example, export the database before migrating from a single-server Prime Optical configuration 
(where the Prime Optical server and database are on the same workstation) to a dual-server 
Prime Optical configuration (where the Prime Optical server and database are on separate 
workstations).
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• If you want to restore a database backup that was exported before you migrated to a later 
Prime Optical version, you must reinstall the earlier Prime Optical version in order to maintain the 
earlier Prime Optical database schema. Whenever you restore a database, you must restore it on the 
same Prime Optical version from which it was created. Otherwise, the restored data does not match 
the current database schema and Oracle cannot interpret the data.

• Export the database only after the Prime Optical server is stable; for example, after the first network 
discovery is complete. Doing so ensure that you have an accurate snapshot of your entire network 
configuration.

4.2.4 Backing Up the Prime Optical Database from the Prime Optical GUI
If your database is in ARCHIVELOG mode, you can perform a hot database backup or a database export. 
If your database is not installed in ARCHIVELOG mode, you can only perform a database export.

Prime Optical uses the /ctm_backup directory as the default backup directory.

To perform a hot database backup, complete the following steps:

Step 1 In the Domain Explorer window, choose Administration > Control Panel.

Step 2 Click Database Properties to open the Database Properties pane. Table 4-1 provides descriptions.

Step 3 Click the Database Operations tab.

Step 4 In the Backup area, enter the sys password in the ‘sys’ Password field.

Step 5 (Optional) To back up additional database components, check any of the following check boxes in the 
Backup area:

• Oracle Installation—Backs up the entire Oracle installation directory.

• Solaris Configuration—Backs up the common Solaris configuration files used by the Oracle 
installation.

• Database Configuration—Backs up the operating system configuration files.

• All—Backs up all of the database components.

Note If you do not check any of the preceding check boxes, only the Prime Optical database is backed 
up.

Step 6 In the Backup area, click Start.

The backup log file is saved to /oracle/admin/ORACLE-SID/udump/backup_db.log. The log file contains 
all of the files that have been backed up.

Note If the backup is interrupted, you cannot start a new backup from a Prime Optical client; you must use 
the CLI. Launch the script /setDbBackupStatus.sh from the server as root where the database is installed, 
at the following location:

cd/opt/CiscoTransportManagerServer/bin
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Note It is recommended that you protect your data by backing it up regularly. Backups can be stored on a local 
or network-mounted, disk-based file system; on a local tape drive; or on a remote tape drive. 
Commercially available tools for Oracle and system-level backup include: 

• Legato Networker (or “Solstice Backup” when purchased from Sun Microsystems) 

• VERITAS NetBackup 

• BMC Software SQL Backtrack 

• GNU Oraback.sh

4.2.5 Exporting the Prime Optical Database from the Prime Optical GUI

Caution Using the Prime Optical GUI to export the database could result in invalid or inconsistent data when 
other operations are performed on the database (for example, NEs are in service, alarms are being 
reported, or PM data is being collected). Whenever possible, use the CLI to export the database. If you 
use the GUI to export the database, verify the following before exporting the database:
— Only one Prime Optical client is connected to the Prime Optical server
— All NE and PM services are stopped

To perform a database export, complete the following steps:

Step 1 In the Domain Explorer window, choose Administration > Control Panel.

Step 2 Click Database Properties to open the Database Properties pane. Table 4-1 provides descriptions.

Step 3 Click the Database Operations tab.

Step 4 Check any of the following check boxes in the Export area:

• Oracle Installation—Exports the entire Oracle installation directory.

• Solaris Configuration—Exports the common Solaris configuration files used by the Oracle 
installation.

• Database Configuration—Exports the operating system configuration files.

• All—Exports all of the database components.

Note If you do not check any of the preceding check boxes, only the Prime Optical database is 
exported.

Step 5 In the Export area, click Start.

The file is exported to the /ctm_backup/export_dir directory using the filename 
export_CTMtime-stamp.dmp. The log file is named export_CTM.log.
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4.2.6 Backing Up or Exporting the Prime Optical Database from the CLI
Prime Optical uses the /ctm_backup directory as the default backup directory.

Step 1 To perform a logical database backup (export) from the CLI, enter the following commands as the root 
user:

Note You can perform a logical database backup whether your database is running in ARCHIVELOG 
mode or in non-ARCHIVELOG mode.

Performing an export_full_db operation from the CLI requires you to shut down the 
Prime Optical server.

cd /opt/CiscoTransportManagerServer/bin
./export_full_db.sh

The file is exported to the /ctm_backup/export_dir directory using the filename 
export_CTMtime-stamp.dmp. The log file is named export_CTM.log.

Step 2 To export the database and back up selected components, enter any of the following commands as the 
root user:

• export_full_db.sh ORA_INST—Exports the database and backs up the entire Oracle installation.

• export_full_db.sh ORA_CFG_FILE—Exports the database and backs up the configuration files, 
including init.ora, tnsnames.ora, listener.ora, and sqlnet.ora.

• export_full_db.sh OS_CFG_FILE—Exports the database and backs up the OS configuration files, 
including /etc/passwd, /etc/group, /etc/system, and /var/opt/oracle/oratab.

• export_full_db.sh ALL—Exports the database and backs up all of the preceding configuration 
files.

Step 3 To perform a full database hot backup, enter the following commands as the root user:

Note You can perform a hot database backup only if your database is running in ARCHIVELOG 
mode.

cd /opt/CiscoTransportManagerServer/bin
./backupdb.sh

The backup log file is saved to /oracle/admin/ORACLE-SID/udump/backup_db.log. The log file contains 
all of the files that have been backed up. Detailed logs of the export operation are located in the 
/ctm_backup/export_dir directory.

Step 4 To back up selected components, enter any of the following commands as the root user:

• backupdb.sh ORA_INST—Backs up the entire Oracle installation.

• backupdb.sh ORA_CFG_FILE—Backs up the configuration files, including init.ora, 
tnsnames.ora, listener.ora, and sqlnet.ora.

• backupdb.sh OS_CFG_FILE—Backs up the OS configuration files, including /etc/passwd, 
/etc/group, /etc/system, and /var/opt/oracle/oratab.
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• backupdb.sh ALL—Backs up the database and all of the preceding configuration files.

4.2.7 Restoring the Prime Optical Database from the Previous Backup
Complete the following steps to restore the Prime Optical database from a hot database backup set or 
from an export.

Note The revert procedure will result in loss of local database information stored after the upgrade. In other 
words, a reverse database migration is not supported; rather, a backup copy of the original database is 
used.

Step 1 (For HA configurations only; for non-HA configurations, begin at Step 2) Enter the following commands 
on all of the clusters to freeze the ctmgrp service group:

haconf -makerw
hagrp -freeze ctmgrp -persistent
haconf -dump -makero

Step 2 Disconnect all of the Prime Optical clients and enter the following command to shut down the 
Prime Optical server, if it is running:

opticalctl stop

Step 3 To restore the database from a hot backup, log into the Prime Optical database workstation as the root 
user and enter the following commands:

cd /opt/CiscoTransportManagerServer/bin
./restore_db.sh backup-file-location backup-configuration-file log-directory 

Note The default backup-configuration-file location is /ctm_backup/backup_conf.cfg. The 
restore_db.sh script uses the latest backup to restore the database.

Step 4 Enter the following command to manually restart the Prime Optical server:

opticalctl start

Note The Prime Optical server does not restart automatically after restoring the database.

Step 5 (For HA configurations only; for non-HA configurations, skip this step) After the Prime Optical server 
restarts, enter the following commands on all of the clusters to unfreeze the ctmgrp service group:

haconf -makerw
hagrp -unfreeze ctmgrp -persistent
haconf -dump -makero

Step 6 To restore from an export dump file, enter the following commands to import the database:

Caution Be sure to disable ARCHIVELOG mode before you import the database. If you do not disable 
ARCHIVELOG mode, the /db05 directory could fill up.
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cd /opt/CiscoTransportManagerServer/bin
./import_full_db.sh export-file-location export-configuration-file log-directory

The default location of the configuration file is /ctm_backup/export_conf.cfg.

4.2.8 Pruning the Prime Optical Database
Database pruning is critical to Oracle server performance. If the Prime Optical database files grow too 
large, it creates extra work for Oracle to insert or remove records from the middle of the database. This 
section describes how to set the time and date for automatic database pruning and how to use pruning 
scripts.

4.2.8.1 Setting the Time and Date for Automatic Pruning

Choosing to prune the database automatically prunes daily all PM, FM, Audit Log, Error Log, audit trail, 
self monitor, and job monitor data older than the specified retention period.

Step 1 In the Domain Explorer window, choose Administration > Control Panel.

Step 2 Click Database Properties to open the Database Properties pane.

Step 3 Click the Pruning tab.

Step 4 Check the Enable check box for each field as desired, and set the number of days and time of pruning.

Consider scheduling database pruning for the middle of the night, when Prime Optical is least busy. It is 
helpful to schedule each pruning activity to start separately, with some time between each pruning script. 
For example, you might start pruning at midnight and allow 30 to 45 minutes for each pruning activity 
before starting the next one.

Note that the start time for pruning activities is set according to Greenwich Mean Time (GMT), not local 
time.

Step 5 After making the selections, click Save. Changes take effect immediately.

4.2.8.2 Using Pruning Scripts

Aside from automatic pruning, you can also prune Prime Optical data from the Oracle database at any 
given time by running database pruning scripts. Pruning scripts allow you to prune the following types 
of data:

• Audit Log data

• Audit trail data

• Error Log data

• FM data

• All PM data

• NEs and all related information

• Self Monitor table data
4-16
Cisco Prime Optical 9.6 User Guide

OL-27078-01



Chapter 4      Maintaining an Efficient Network
How Do I Manage the Database?
Complete the following steps to prune Prime Optical data using pruning scripts:

Step 1 Log in as the root user on the Sun Solaris workstation where the Prime Optical server is installed.

Step 2 Enter the following command to change directories to the Prime Optical server bin directory:

cd /opt/CiscoTransportManagerServer/bin

Step 3 Enter the following command to see a list of pruning scripts:

ls -al prune*

Step 4 Select a script and a parameter (based on database pruning) and enter the corresponding command on 
the UNIX shell.

For example, to prune Error Log data older than 25 days, enter:

./prune_errlog.sh 25

The following table lists parameters that can be passed to the following scripts, and the tables that are 
affected:

• Prune Audit Log data

• Prune Error Log data

• Prune FM data

• Prune audit trail data

• Prune Job Monitor table data

• Prune Self Monitor table data

Table 4-3 Parameters for Database Pruning: Multiple Scripts

Tables Affected Input Parameters Remarks

Prune Audit Log Data Script (prune_auditlog.sh)

transaction_log_table No. of days (1 to 1000) Removes all Transaction Log entries that were 
created before n days.

Prune Error Log Data Script (prune_errlog.sh)

error_log_table No. of days (1 to 1000) Removes all Error Log entries that were 
created before n days.

Prune FM Data Script (prune_fm.sh)

alarm_event_table No. of days (1 to 1000) Removes all alarm and event entries that were 
created before n days.active_alarm_table No. of days (1 to 1000)

Prune Audit Trail Data Script (prune_audittrail.sh)

ne_audit_trail_table No. of days (1 to 1000) Removes all NE audit trail entries that were 
created before n days.

PruneJob Monitor Table Script (prune_admin_job_table.sh)

admin_job_table No. of days (1 to 1000) Removes all job monitor entries that were 
created before n days.
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Table 4-4 lists parameters that can be passed to the prune_pm.sh script, and the tables that are affected. 
The prune_PM.sh script removes all PM entries that were created before n days.

Note Based on the value of “Is 24 flag,” Prime Optical prunes 15-minute data, 1-day data, or both 15-minute 
and 1-day data. If the “Is 24 flag” value is blank, Prime Optical prunes both 15-minute and 1-day data.

Prune Self Monitor Table Script (prune_server_monitor.sh)

server_monitor_table No. of days (1 to 1000) Removes all self monitor entries that were 
created before n days.

Table 4-3 Parameters for Database Pruning: Multiple Scripts (continued)

Tables Affected Input Parameters Remarks
4-18
Cisco Prime Optical 9.6 User Guide

OL-27078-01



Chapter 4      Maintaining an Efficient Network
How Do I Manage the Database?
Table 4-4 Parameters for Database Pruning: Prune PM Data Script (prune_pm.sh)

Tables Affected Input Parameters

ONS15454_DS3_PM_TABLE • No. of days (1 to 1000)

• Is 24 flag (where 0 = 15 min, 1 = 1 day, and 2 = both 15 min and 
1 day)

ONS15454_SONET_PATH_PM_TABLE

ONS15454_SONET_LINE_PM_TABLE

ONS15454_SONET_SEC_PM_TABLE

ONS15454_ENET_PM_TABLE

ONS15454_DS1_PM_TABLE

ONS15454_Sonet_VT_PM_Table

ONS15454SDH_RS_PM_Table

ONS15454SDH_MS_PM_Table

ONS15454SDH_HO_PM_Table

ONS15454SDH_LO_PM_Table

ONS15454SDH_E1_PM_Table

ONS15454SDH_E3_PM_Table

ONS15454SDH_E4_PM_Table

ONS155XX_SONET_SEC_PM_TABLE

ONS155xx_Phy_PM_Table

ONS155xx_Opt_Power_PM_Table

ONS155xx_CDL_PM_Table

ONS155xx_Ether_Hist_PM_Table

ONS155xx_FCM_PE_PM_Table

ONS15600_Sonet_Sec_PM_TABLE

ONS15600_Sonet_Line_PM_Table

ONS15600_Sonet_Path_PM_Table

ONS15454_PHY_LAYER_PM_Table

ONS15454_POS_PM_Table

ONS15454_OTN_SEC_PM_Table

ONS15454_OTN_PATH_PM_Table

ONS15454_OTN_FEC_PM_Table

ONS15600SDH_RS_PM_Table

ONS15600SDH_MS_PM_Table

ONS15600SDH_HO_PM_Table

ONS1530x_RS_PM_TABLE

ONS1530x_MS_PM_TABLE

ONS1530x_HO_PM_TABLE

ONS1530x_LO_PM_TABLE

ONS1530x_IP_PM_TABLE
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Table 4-5 lists parameters that can be passed to the prune_ne.sh script, and the tables that are affected. 
The prune_ne.sh script removes all information about the NE from the database. Use this script with 
extreme caution.

Caution Before running the script, shut down all Prime Optical clients and the Prime Optical server.

Table 4-5 Parameters for Database Pruning: Remove an NE Script (prune_ne.sh)

Tables Affected Input Parameter

ACTIVE_ALARM_TABLE NE SYS ID

ADDITIONAL_DEVICE_INFO NE SYS ID

ADMIN_JOB_TABLE NE SYS ID

ALARM_COUNT_TABLE NE SYS ID

ALARM_EVENT_TABLE NE SYS ID

APS_GROUP_TABLE NE SYS ID

AUDIT_LOG_TABLE NE SYS ID

CERENT_NE_GROUP_TABLE NE SYS ID

CIRCUIT_DEST_TBL NE SYS ID

CIRCUIT_SPAN_TBL NE SYS ID

CIRCUIT_TBL NE SYS ID

CIRCUIT_VCG_TBL NE SYS ID

CIRCUIT_VLAN_TBL NE SYS ID

DOMAIN_TABLE NE SYS ID

EQPT_INFO_TABLE NE SYS ID

EQPT_RELATIONSHIP_TABLE NE SYS ID

IF_CROSS_CONNECT NE SYS ID

IF_DWDM_CHANNEL_GROUP NE SYS ID

IF_OPTICAL_PHY_CONFIG_TABLE NE SYS ID

INTERFACE_APS_INFO NE SYS ID

INTERFACE_DWDM_FREQUENCY NE SYS ID

INTERFACE_STACK_TABLE NE SYS ID

LINK_TABLE NE SYS ID

MANAGED_ET_TAB NE SYS ID

MAP_CUST_TABLE NE SYS ID

MIB2_INTERFACE_TABLE NE SYS ID

NE_AUDIT_TRAIL_TABLE NE SYS ID

NE_INFO_TABLE NE SYS ID

NE_INVENTORY_TABLE NE SYS ID

NE_PORT_STATUS_TABLE NE SYS ID

NE_SWIMAGE_TABLE NE SYS ID
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ONS15216_ACTIVE_USER_TABLE NE SYS ID

ONS15216_NE_INVENTORY_TABLE NE SYS ID

ONS15216_USER_TABLE NE SYS ID

ONS1530X_HO_PM_TABLE NE SYS ID

ONS1530X_IP_PM_TABLE NE SYS ID

ONS1530X_LO_PM_TABLE NE SYS ID

ONS1530X_MS_PM_TABLE NE SYS ID

ONS1530X_NE_INVENTORY_TABLE NE SYS ID

ONS1530X_RS_PM_TABLE NE SYS ID

ONS15454SDH_E1_PM_TABLE NE SYS ID

ONS15454SDH_E3_PM_TABLE NE SYS ID

ONS15454SDH_E4_PM_TABLE NE SYS ID

ONS15454SDH_HO_PM_TABLE NE SYS ID

ONS15454SDH_LO_PM_TABLE NE SYS ID

ONS15454SDH_MS_PM_TABLE NE SYS ID

ONS15454SDH_RS_PM_TABLE NE SYS ID

ONS15454_327_NE_TABLE NE SYS ID

ONS15454_8B10B_PM_TABLE NE SYS ID

ONS15454_ACTIVE_USER_TABLE NE SYS ID

ONS15454_CBQOS_INFO_TABLE NE SYS ID

ONS15454_CLASSMAP_PM_TABLE NE SYS ID

ONS15454_COS_PM_TABLE NE SYS ID

ONS15454_DS1_PM_TABLE NE SYS ID

ONS15454_DS3_PM_TABLE NE SYS ID

ONS15454_ENET_PM_TABLE NE SYS ID

ONS15454_FC_PM_TABLE NE SYS ID

ONS15454_IFX_PM_TABLE NE SYS ID

ONS15454_MATCH_STMT_PM_TABLE NE SYS ID

ONS15454_NE_INVENTORY_TABLE NE SYS ID

ONS15454_OTN_FEC_PM_TABLE NE SYS ID

ONS15454_OTN_PATH_PM_TABLE NE SYS ID

ONS15454_OTN_SEC_PM_TABLE NE SYS ID

ONS15454_PHY_LAYER_PM_TABLE NE SYS ID

ONS15454_POLICE_PM_TABLE NE SYS ID

ONS15454_POS_PM_TABLE NE SYS ID

ONS15454_SONET_LINE_PM_TABLE NE SYS ID

Table 4-5 Parameters for Database Pruning: Remove an NE Script (prune_ne.sh) (continued)

Tables Affected Input Parameter
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ONS15454_SONET_PATH_PM_TABLE NE SYS ID

ONS15454_SONET_SEC_PM_TABLE NE SYS ID

ONS15454_SONET_VT_PM_TABLE NE SYS ID

ONS15454_USER_TABLE NE SYS ID

ONS155XX_CDL_FLOW_CONFIG NE SYS ID

ONS155XX_CDL_IF_CONFIG NE SYS ID

ONS155XX_CDL_PM_TABLE NE SYS ID

ONS155XX_CIRCUIT_CC_TBL NE SYS ID

ONS155XX_CIRCUIT_PATH_TBL NE SYS ID

ONS155XX_DCRP_TABLE NE SYS ID

ONS155XX_DCRP_TABLE NE SYS ID

ONS155XX_DISCOVERY_INFO_TABLE NE SYS ID

ONS155XX_ETHER_HIST_PM_TABLE NE SYS ID

ONS155XX_FCM_PE_PM_TABLE NE SYS ID

ONS155XX_FLASH_DEVICE_TABLE NE SYS ID

ONS155XX_GRANULAR_CC_TBL NE SYS ID

ONS155XX_IF_CIRCUIT_PARAMS_TBL NE SYS ID

ONS155XX_IF_OPTICAL_POWER NE SYS ID

ONS155XX_IF_PHY_INFO_TABLE NE SYS ID

ONS155XX_NE_INFO_TABLE NE SYS ID

ONS155XX_OPT_POWER_PM_TABLE NE SYS ID

ONS155XX_PATH_TBL NE SYS ID

ONS155XX_PHY_PM_TABLE NE SYS ID

ONS155XX_SONET_SEC_PM_TABLE NE SYS ID

ONS15600SDH_HO_PM_TABLE NE SYS ID

ONS15600SDH_MS_PM_TABLE NE SYS ID

ONS15600SDH_RS_PM_TABLE NE SYS ID

ONS15600_ENET_PM_TABLE NE SYS ID

ONS15600_POS_PM_TABLE NE SYS ID

ONS15600_SONET_LINE_PM_TABLE NE SYS ID

ONS15600_SONET_PATH_PM_TABLE NE SYS ID

ONS15600_SONET_SEC_PM_TABLE NE SYS ID

OSS_ALARM_FLTR_TID_DENY_TBL NE SYS ID

PM_HISTORICAL_APPOINTMENTS NE SYS ID

PROXY_SERVER_TABLE NE SYS ID

ROUTER_SONETAPS NE SYS ID

Table 4-5 Parameters for Database Pruning: Remove an NE Script (prune_ne.sh) (continued)

Tables Affected Input Parameter
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4.2.9 Using the SQL*PLUS Client to Manage the Database
To access the database and Prime Optical schema objects, use the SQL*PLUS client that ships with 
Oracle products. The SQL*PLUS client is available for Microsoft Windows 2000 or NT 4.0 PCs or 
Sun Solaris workstations. Refer to the Oracle documentation to install and run the SQL*PLUS client on 
a Windows 2000 or NT 4.0 PC.

On a Sun Solaris workstation, the SQL*PLUS client is installed as part of the Oracle server installation. 
The following guidelines are for logging into SQL*PLUS as a Prime Optical user and managing 
Prime Optical schema objects and data. Refer to Oracle’s SQL*PLUS User’s Guide and Reference for a 
complete description.

Step 1 On the Sun Solaris workstation running Oracle, log in as the Oracle owner user. Use the username that 
was used when installing Oracle 10g.

Note To verify the username, enter the id command on the shell.

Step 2 Verify that the following UNIX environment variables for the Oracle user are set correctly:

• ORACLE_HOME

• ORACLE_SID

• PATH variable has $ORACLE_HOME/bin in the path

• LD_LIBRARY_PATH

Step 3 On the command line, enter the following command:

sqlplus ctmanager/password

Caution The default password is Ctm123! and any changes are saved in the CTMServer.cfg file. If you 
change the default password, the following caution is displayed: “Changing the database 
password will restart the Prime Optical server. Are you sure you want to continue?” Click Yes 
to confirm the action. The password is validated and the following message is broadcast: 
“Caution: The database password has been changed by a user. The Prime Optical server will 
restart in 15 seconds.”

ROUTER_SONETAPS_CHANNEL NE SYS ID

SERVER_MONITOR_TABLE NE SYS ID

SWAY_USER_PORT_TABLE NE SYS ID

TCA_EVENT_TABLE NE SYS ID

TRANSACTION_LOG_TABLE NE SYS ID

UNMANAGED_NE_INVENTORY_TABLE NE SYS ID

USER_MAP_TABLE NE SYS ID

USER_MAP_TABLE_TEMP NE SYS ID

Table 4-5 Parameters for Database Pruning: Remove an NE Script (prune_ne.sh) (continued)

Tables Affected Input Parameter
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The message “Connected to: Oracle10g...” and the SQL> prompt should appear. If not, enter the 
username and password again.

Step 4 Upon connection to SQL*PLUS, enter any SQL command supported by Oracle. For a list of SQL 
commands supported by Oracle, refer to the SQL*PLUS User Guide.

4.2.10 Understanding Basic SQL Commands for Prime Optical Schema Objects
The following table lists commands that display, update, or modify Prime Optical schema objects. Run 
each command in SQL*PLUS by entering the command at the SQL> prompt.

Table 4-6 SQL Commands for Prime Optical Schema Objects

SQL Command Description

select * from user_tables; Returns a list of all table names owned by the ctmanager 
user.

select * from user_views; Returns a list of all views owned by the Prime Optical user.

describe ; Takes a table-name as a parameter (valid table names are 
those returned by the first two commands) and lists the 
name, type, and size of columns in the table.

describe ; Takes a view-name as a parameter (valid view names are 
those returned by the first two commands) and lists the 
name, type, and size of columns in the view.

select col1, col2… coln from table-name; Takes col1….coln and table-name as parameters and 
displays data for all the columns listed. To display data for 
all columns, use an asterisk (*) instead of col1, col2, and 
so on.

select col1, col2... coln from table-name where col1 = 
value1 and col2 = value2...

Takes col1...coln and table-name as parameters and 
displays data for all the columns listed that meet the 
condition specified in the “where” clause. For example, the 
command:

select nedbaccessid from ne_info_table where 
nesysid = 'ANGEL'; 

returns the value of column nedbaccessid from table 
ne_info_table for all rows for which nesysid = ANGEL.

select col1, col2... coln from view-name where col1 = 
value1 and col2 = value2...

Takes col1...coln and view-name as parameters and 
displays data for all the columns listed that meet the 
condition specified in the “where” clause.

delete table-name; Takes table-name as a parameter and deletes the entire 
contents of the table. To make the change permanent, enter 
commit; at the SQL> prompt.
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4.2.11 Using the Prime Optical Interactive Database Console to Manage the 
Database

To access the database and Prime Optical schema objects, use the Prime Optical Interactive Database 
Console. The database console is used when the server is installed with an embedded database.

Get the Prime Optical Interactive Database Console from the Prime Optical Client service folder at one 
of the following locations (where xxx is the build number):

• Under the Windows folder at C:\Cisco\PrimeOptical_9.6_xxx\DB_Console

• Under the Solaris/Linux folder at C:\Cisco\PrimeOptical_9.6_xxx/DB_Console

4.2.11.1 Executing the Prime Optical Interactive Database Console

The Prime Optical Interactive Database Console tool is a Java application that you execute by running 
runme.bat (Windows) or runme.sh (Solaris/Linux). JRE 1.6 or higher is required to execute DB Console. 
Go to the Java website to obtain the latest version of Java Runtime Environment for your operating 
system.

4.2.11.2 Connecting to the Database

Complete the following steps to connect to the database:

Step 1 Choose Session > Connect.

Step 2 In the Hostname field, enter the hostname of the server or the IP address.

Step 3 Click Connect.

Note You must connect to the database through a special database user login. Using this login, you will only 
be able to view tables and other objects in the embedded database. You will not have read/write access.

4.2.11.3 Managing the Database Using the Prime Optical Interactive Database Console

Interactive Database Console is a command-line interface (CLI) that allows you to browse the database 
tables. 

To get a list of allowed commands, execute the following command in the CLI:

help

To get the detailed synopsis and description of a specific command, execute the following command in 
the CLI:

help <command>

The following example shows output for the import command:

ctmreadonly@oracle:jeeg#1> help import
SYNOPSIS
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import from <filename> into <tablename> columns (col1[:type][,col2[:type]]) 
[column-delim "\t"] [row-delim "\n"] [encoding <encoding>] [start-row <number>] 
[row-count|end-row <number>]

col could be a column name or '-' if the column is to be ignored
the optional type can be one of [string,number,date]

DESCRIPTION
Import the content of the file into table according to the format
If the filename ends with '.gz', the
content is unzipped automatically

Table 4-44 lists the aliases that already exist to enable you to check the status of the Prime Optical 
database:

The Database Interactive Console supports automatic command completion (Tab key), and command 
history (up/down arrow). To clear command history, choose Edit > Clear History.

4.2.11.4 Launching Batch Scripts

To launch automatic scripts, choose File > Load Script.

A batch script can contain any number of allowed commands. DB_Console includes an example script 
named report.txt that collects information on the status of the Prime Optical database.

4.2.11.5 Setting Preferences for the Prime Optical Interactive Database Console

Complete the following steps to set the preferences for the Interactive Database Console:

Step 1 Choose Edit > Preferences.

Step 2 In the General tab, set preference for the following:

• Default Hostname or IP Address

• Database Schema ID (SID)

Table 4-7 Aliases for Checking the Prime Optical Database

Alias Description

export <table> Export the contents of a given table.

list_indexes List all the indexes that Prime Optical DB uses.

list_jobs List all the Prime Optical scheduled jobs with scheduling details.

list_nes List all the NEs present in Prime Optical DB.

list_objects List all the DB objects (tables, views, indexes, and so on.)

list_sequences List all the DB sequences.

list_tasks List all the DB tasks.

ls List all the DB table names.

search_invalid_indexes Search the DB for invalid indexes.

search_invalid_objects Search the DB for invalid objects.

search_property Search the CTM_CONFIG_TABLE.

size <table> Count the number of rows in a given table.
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• Screen Buffer Size

Step 3 In the Font and Color tab, set preferences for the following:

• Font color

• Background color

• Foreground color

Step 4 Click Apply. For some changes (for example, default host or screen buffer) to take effect, you must 
restart the application.

4.2.12 Regenerating Statistics in the Database
Internal Oracle statistics allow Oracle to work efficiently, especially during data query operations. If 
there is Prime Optical system performance degradation during normal database activities, the database 
might be using stale statistics. The database statistics should be regenerated to improve system 
performance, either before or after a significant system workload.

In Oracle 10g, the statistics are automatically regenerated every night. The Prime Optical installation 
uses the default settings of Oracle 10g. If you need to change the statistics regeneration schedule, refer 
to the official Oracle 10g documentation for instructions on how to change the settings.

4.2.13 Cleaning Up the Disk and Maintaining Disk Space on the Prime Optical 
Server

It is important to clean up the disk and maintain disk space on the Prime Optical server. To maintain an 
efficient server and maximize performance, you must delete unnecessary files and retain only the 
minimum number of files. For detailed information, see Clean Up the Disk and Maintain Disk Space on 
the CTM Server.

4.3 How Do I Manage the Network Software?
Follow the procedures described in this section to upgrade the Cisco Transport Controller (CTC) binary 
file and download new or modified images to supported NEs.

4.3.1 Transferring Images
You can transfer NE binary software images from the client file system into an appropriate NE software 
repository in the Prime Optical server, to make the images available for selection when requesting a 
software download. 

Use the Image Transfer dialog box to transfer software images to the following NEs:

• ONS 15216 EDFA

• ONS 15216 EDFA2

• ONS 15216 EDFA3

• ONS 15305 (including the CTC-based ONS 15305 R3.0)
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• ONS 15310 CL

• ONS 15310 MA SONET

• ONS 15310 MA SDH

• ONS 15327

• ONS 15454 SONET

• ONS 15454 SDH

• ONS 15530

• ONS 15540 ESP and ESPx

• ONS 15600 SONET

• ONS 15600 SDH

To transfer images into an appropriate NE software repository:

Step 1 In the Domain Explorer, select an NE and choose Administration > Image Transfer. The Image 
Transfer dialog box opens.

Step 2 Select the source files from the Local File Selection list. 

Step 3 Click Browse to locate files that are not visible in the field. You can select multiple files from the local 
machine for the upload process.

Step 4 To remove a file from the Local File Selection list, select the file from the list and click Delete.

Step 5 Select the NE-specific folder from the Prime Optical server drop-down list to choose where to transfer 
the image.

Step 6 To remove a file that is already present on the Prime Optical server, select the file from the list and click 
Delete.

Step 7 Click Upload.

Note If you cancel the image transfer process while it is in progress, only the files that have already 
been transferred at the time of cancellation are retained. The current file being transferred and 
other pending files are canceled.

   

4.3.2 Software Management
Use the Software Management wizard to download software images to the following NEs:

• ONS 15216 EDFA2 (R2.3.0 and later)

• ONS 15216 EDFA3

• ONS 15305 (not supported for the ONS 15305 R3.0)

• ONS 15310 CL

• ONS 15310 MA SONET

• ONS 15310 MA SDH
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• ONS 15327

• ONS 15454 SONET

• ONS 15454 SDH

• ONS 15530

• ONS 15540 ESP

• ONS 15540 ESPx

• ONS 15600 SONET

• ONS 15600 SDH

Follow the procedures described in this section to download new or modified images to NEs.

Usage Notes:

• Refer to the appropriate NE documentation for precautions and guidelines before performing an NE 
software upgrade.

• Before updating the software image on an NE, check the Prime Optical release notes to verify 
whether the NE software release is supported by Prime Optical. See the “Prime Optical-Supported 
NE Software Releases” table in the release notes at 
http://www.cisco.com/en/US/products/ps11670/tsd_products_support_series_home.html.

• If a software download has a status of Queued, and if it has a task in the running list, the download 
cannot be canceled.

• If you mark an NE as an Out of Service while a software download is in progress on that NE, the 
software download might not complete successfully.

• To download software images to NEs, it is recommended that the data communications network 
(DCN) bandwidth be 56 kb/s or higher. If DCN bandwidth is less than 56 kb/s, software download 
might take an extended period of time. For example, a typical ONS 15327 software image is 
approximately 2.5 MB. If a 2.5-MB file is downloaded to a single NE over a 19.2-kb/s link, it will 
take 15 to 30 minutes depending on the volume of traffic. Performing software downloads in parallel 
increases the length of time by a multiple of the number of NEs targeted.

• The latest ONS 15216 EDFA2 R2.4 hardware does not support software download to a software 
release other than 2.4.0. The ONS 15216 EDFA2 R2.3 hardware supports software download for NE 
software releases 2.3 and 2.4.

   

4.3.2.1 Downloading Software Images to ONS 15216, ONS 153xx, ONS 15454, and ONS 15600 NEs

Step 1 In the Domain Explorer tree, select a management domain or group that contains NEs that are assigned 
an In Service or Under Maintenance operational state. Alternatively, select an NE that is assigned an In 
Service or Under Maintenance state.

Note Only one software download can occur on a specific NE at any given time.

Step 2 Choose Administration > Software Management > Optical. The Software Management wizard opens. 
Table 4-8 provides descriptions.

Step 3 Enter the following information:

• NE model
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• NEs

• Source

• Job comments

• Time

Caution If the Prime Optical client and server run on the same machine and thus the local source 
directory is the same as the default destination directory, an error message is generated. To 
retrieve the software image selected from the local source directory, navigate to the 
appropriate path and restore it from the software-image-name.old file.

Step 4 Click Finish to initiate the software download to the standby memory on the NE.

Step 5 To activate the new image automatically, select Reboot and Activate. If Reboot and Activate is selected, 
the NE is rebooted with the newly downloaded image. If Reboot and Activate is not selected, you can 
activate the image later from the Flash File table.

Step 6 Select the following information:

• NEs

• Flash banks

Note To view information about the files stored in the flash bank of the NE, click Flash File Table 
at the bottom of the wizard. The Flash File table shows the flash bank names and the name 
and status for each stored file.

Note The currently active flash bank is unavailable; users cannot download to the active flash 
bank.

Step 7 Click Finish. The image will be downloaded to all of the NEs in the Selected Downloads list.

Prime Optical stores two software versions: active and standby. When you download software, it is saved 
as the standby version.

Step 8 To check the status of the download job or verify that the download job was successful:

a. Check the Job Monitor table (Administration > Job Monitor). 

b. Select the NE and check the Software Version field of the Equipment Inventory table 
(Configuration > NE-model > Equipment Inventory Table).

c. Select the NE and check the Active Software Filename field in the NE Software table 
(Administration > NE Software Table) for the software image version.

Note To download software to an ONS 15216 EDFA3 NE using the Server option, first choose 
Administration > Image Transfer. The Image Transfer dialog box opens. The image will be copied 
from the local file system in the directory specified in the Prime Optical Server area. Choose Cisco ONS 
15216 EDFA3 from the drop-down list; then, click Upload. Then, choose Administration > Software 
Management > Optical. The Software Management wizard opens with the Server radio button enabled.
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Table 4-8 Field Descriptions for the Software Management Wizard

Field Description

NE Model Select the NE type to which you want to download software. The type you select determines the NEs 
that are displayed under Network Elements.

Network Elements Use the Add and Remove buttons to move NEs to the Selected NEs list or remove NEs from the list. 
Software will be downloaded to NEs in the Selected NEs list.

Source Specify the location of the software:

• Local allows you to select an image on the current client system.

• Server allows you to select an image on the Prime Optical server to which your client is connected. 
The Server radio button is not active unless an image file exists on the server.

• Remote allows you to select an image on another network server that has TFTP or FTP configured 
and running. Specify the IP address of the server and the fully qualified pathname of the image, 
relative to the tftpboot directory. Remote is the only selectable source option for the ONS 15305 
(earlier than R3.0).

Note If the Remote TFTP Server option is selected for ONS 15216 EDFA2, the software image that 
you are downloading must have been saved in the default directory, such as the tftpboot 
directory on the remote TFTP server.

Note The tftpboot directory must have read-write access, or the software download will fail. See 
Chapter 3, “Building the Network” for information about how to configure the TFTP directory 
with read-write access.

Job Comments Enter comments about the software download.

Time (time zone) Set a time for the download. Click Now to begin downloading immediately, or click At Time and 
specify when to begin downloading, in 5-minute increments.

Note The time zone can be GMT, a user-defined offset from GMT, or local time, depending on what 
is specified in the User Preferences dialog box.

Software Download Pane 2 for ONS 15530 and ONS 15540 NEs

Image File Size The size of the image file. If you are downloading from a remote TFTP server, the size of the image 
file is not available.

Cancel job if CPU 
state changes 

Allows you to cancel the job if the CPU state changes between the time the job is scheduled and the 
time the job is executed.

Activate image on 
next reload

Activates the image the next time the NE is rebooted.

Reload Reboots the NE right after activation so the new image takes effect immediately. If an active CPU is 
reloaded, this option will cause a switchover if a standby CPU is present. Otherwise, service might be 
disrupted until the CPU reboots.

Switchover after 
downloading and 
reloading standby 

(Available only when you choose the “Activate image on next reload” and “Reload” options.) This 
option applies only when downloading to the standby CPU. Switchover to standby occurs after 
downloading to and reloading the standby CPU; the standby CPU becomes active and runs the newly 
downloaded image.

Selected NEs NEs that will receive downloaded software. When you select an NE from this list, information about 
the available flash partitions on the NE is displayed in the Flash Partition Data area, and you can select 
a partition.
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4.3.2.2 Downloading Software Images for ONS 15530 and ONS 15540 NEs

This section contains procedures for:

• Downloading software images on single-CPU NEs

• Downloading software images for dual-CPU NEs

Note Before downloading software on an ONS 155xx NE, verify that a read-write community string is 
available for the NE in the ONS 155xx SNMP Settings table. If there is no read-write community string 
available, the software download fails with a “No write access” or “Request timed out” error message.

4.3.2.2.1 Downloading Software Images on Single-CPU NEs

Step 1 In the Domain Explorer tree, select one of the following:

• A management domain or group that contains ONS 15530 or ONS 15540 NEs that are in service or 
under maintenance.

• An ONS 15530 or ONS 15540 NE that is in service or under maintenance.

Step 2 Choose Administration > Software Management > Optical. The Software Management wizard opens 
(see Table 4-8). Enter the following information:

• NE model

• NEs 

• Source

• Job comments 

• Time

Note The Server radio button is not active unless the relevant subdirectory in the 
/$CTMHOME/images/ directory contains an image file. The subdirectories are named 
Cisco_ONS15530, Cisco_ONS_15540_ESP, and Cisco_ONS_15540ESPx.

Flash Partition Data The flash partitions available for storing the downloaded image on the selected NE:

• CPU Slot No.—Slot number of the CPU that contains the flash device.

• Status—Status of the CPU (active or standby).

• Name—Name of the flash partition; partitions on the standby CPU are indicated by sby.

• Total Size—Total size of the partition, in bytes.

• Available—Number of free bytes in the partition. If you select a partition that does not have 
enough space to store the image, a warning message is displayed.

Selected 
Downloads

The NEs selected for image download and the flash bank you selected for each NE.

To see details about flash memory, select an NE and click Flash File Table.

To remove an NE from the Selected Downloads list, select the NE and click Drop.

Table 4-8 Field Descriptions for the Software Management Wizard (continued)

Field Description
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Caution If the Prime Optical client and server run on the same machine and thus the local source 
directory is the same as the default destination directory, an error message is generated. To 
retrieve the software image selected from the local source directory, navigate to the 
appropriate path and restore it from the software-image-name.old file.

Step 3 Click Next.

Step 4 Use the Image File Size field to determine which flash partition has enough free space to hold the image. 

Step 5 Select desired image download options.

Step 6 Select the following information:

• NEs

• Flash partitions

Note If a flash partition is selected before displaying the Flash File table, information is shown 
about the files on that partition only.

Step 7 Click Finish. Downloads will be performed for all the NEs in the Selected Downloads list. 

Note If a partition that has insufficient space is selected, a warning message appears when the Finish 
button is clicked. Decide whether or not to proceed with the download. This check for free space 
is not performed for the remote server option.

After validating the image, the Prime Optical server transfers the image to the selected flash partition 
through TFTP. When the transfer is completed, the configuration register value is set to 0x02 for 
automatic booting and the boot command is modified to put the downloaded image first on the list.

If the reload option is selected, the NE is rebooted with the newly downloaded image.

If the image option is activated, the new software image is activated. If this option is not selected, 
activate the image from the Flash File table. (See 4.3.4 Using the Flash File Table, page 4-36.)

Step 8 To check the status of the download job or verify that the download job was successful:

a. Check the Job Monitor table (Administration > Job Monitor). 

b. Select the NE and check the Software Version field of the Equipment Inventory table 
(Configuration > ONS 155XX > Equipment Inventory Table).

c. Select the NE and check the Active Software Filename field in the NE Software table 
(Administration > NE Software Table) for the software image version.

4.3.2.2.2 Downloading Software Images for Dual-CPU NEs

Consider the following recommendations when downloading software images for dual CPUs:

• Update the standby CPU first and choose the switchover option. This ensures that the new image 
will run on an active CPU with minimum system interruption.

• Either update the second CPU immediately after updating the first one, or schedule the second CPU 
for downloading after the image has run successfully for some time on the first CPU. 
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Complete the following steps to download software images for dual CPUs:

Step 1 In the Domain Explorer tree, select one of the following:

• A management domain or group that contains ONS 15530 or ONS 15540 NEs that are in service or 
under maintenance.

• An NE that is in service or under maintenance.

Step 2 Select Administration > Software Management > Optical. The Software Management wizard opens. 
Enter the following information:

• NE model

• NEs 

• Job comments 

• Source

• Time

Note The Server radio button is not active unless the relevant subdirectory in the 
/$CTMHOME/images/ directory contains an image file. The subdirectories are named 
Cisco_ONS15530, Cisco_ONS_15540_ESP, and Cisco_ONS_15540ESPx.

Caution If the Prime Optical client and server run on the same machine and thus the local source 
directory is the same as the default destination directory, an error message is generated. To 
retrieve the software image selected from the local source directory, navigate to the 
appropriate path and restore it from the software-image-name.old file.

Step 3 Click Next.

Step 4 Check the Image File Size field against the list of flash partitions to determine which flash partition has 
enough free space to hold the image.

Step 5 Select desired image download options.

Note Before the image is activated, the Prime Optical server checks the state of the standby CPU. If 
the standby CPU is not in hot standby mode, the update operation is aborted after the image is 
downloaded. For more information, refer to the hardware documentation for information about 
updating with system images that are not hot-standby compatible.

Note If the “Switchover after downloading and reloading standby” option is selected, the image will 
always be downloaded to the selected CPU slot number. For example, assume that slot 6 is 
standby and the sby-bootflash (standby) partition is chosen. If a switchover occurs between job 
scheduling and job execution and slot 6 becomes active, the image will be downloaded to the 
slot 6 bootflash partition.

Step 6 Select the following information:

• NEs

• Flash partitions
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Note If a flash partition is selected before displaying the Flash File table, information is shown 
about the files on that partition only.

Step 7 Click Finish. Downloads will be performed for all the NEs in the Selected Downloads list.

Note If a partition that has insufficient free space is selected, a warning message appears. Decide 
whether or not to proceed with the download. This check for free space is not performed for the 
remote server option.

After validating the image, the Prime Optical server transfers the image to the selected flash partition 
through TFTP. When the transfer is completed and the standby CPU is in hot standby mode, the 
configuration register value is set to 0x02 for automatic booting and the boot command is modified to 
put the downloaded image first on the list. If the reload option is chosen, the standby CPU is reloaded.

If the switchover option is selected, a switchover from the active CPU to the standby CPU is performed 
after reloading the standby CPU. The former standby CPU, which is now the active CPU, will run the 
newly downloaded image.

If the Activate option is not selected, activate the new image from the Flash File table. (See 4.3.4 Using 
the Flash File Table, page 4-36.)

Step 8 After updating the standby CPU (which is now the active CPU), use the same procedure to update the 
formerly active CPU (which is now the standby CPU), with one difference: there is no need to select the 
switchover option because the current active CPU is already running the new image.

Step 9 To check the status of the download job or verify that the download job was successful:

a. Check the Job Monitor table (Administration > Job Monitor).

b. Select the NE and check the Software Version field of the Equipment Inventory table 
(Configuration > ONS 155XX > Equipment Inventory Table).

c. Select the NE and check the Active Software Filename field in the NE Software table 
(Administration > NE Software Table) for the software image version.

   

4.3.3 Scheduling Bulk Software Activation
Use the Bulk Software Activation dialog box to schedule software activation for multiple NEs 
simultaneously. Bulk software activation is supported on NEs that support the Revert/Switch operation: 
ONS 15216 EDFA2, ONS 15216 EDFA3, ONS 15305, ONS 15310 CL, ONS 15310 MA SONET, 
ONS 15310 MA SDH, ONS 15327, ONS 15454 SONET, ONS 15454 SDH, ONS 15600 SONET, 
ONS 15600 SDH. 

Step 1 In the Domain Explorer tree, select a management domain or group that contains NEs that are assigned 
an In Service or Under Maintenance operational state. Alternatively, select one or more NEs that are 
assigned an In Service or Under Maintenance state.

Step 2 Choose Administration > Bulk Software Activation. The Bulk Software Activation dialog box opens. 
The following table provides descriptions.
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Note You can also launch the dialog box by selecting one or more rows in the NE Software table and 
choosing Edit > Commit.

Step 3 In the dialog box, select the NEs for which you want to activate software, enter any comments about the 
job, and specify the time for the software activation to occur.

Caution If you try to activate a software version that Prime Optical does not support, the following caution is 
displayed: “Caution: You are about to revert to an unsupported software version for the following NEs: 
NE-versions. Do you want to continue?”

If you activate an unsupported NE software version, the Prime Optical server might not communicate 
with one or more NEs in the domain, causing erroneous behavior. 

Step 4 Click OK.

To view the results of the bulk software activation, check the Job Monitor table (Administration > Job 
Monitor).

   

4.3.4 Using the Flash File Table
Use the Flash File table to activate a downloaded image and manipulate the files in the ONS 155xx NE 
flash memory. 

Step 1 From the Domain Explorer, select an NE; then, select Administration > ONS 155XX > 
Flash File Table. The following table describes the fields in the Flash File table.

Step 2 Perform any of the functions listed in Table 4-11.

Table 4-9 Field Descriptions for the Bulk Software Activation Dialog Box

Field Description

Network Elements Use the Add and Remove buttons to move the NEs for which you want to activate software to the 
Selected NEs list, or to remove NEs from the list.

Job Comments Enter comments about the software activation, if needed.

Time (time zone) Set a time for the bulk software activation. Click Now to begin software activation immediately, 
or click At Time and specify when to begin software activation, in 5-minute increments.

Note The time zone can be GMT, a user-defined offset from GMT, or local time, depending on 
what is specified in the User Preferences dialog box. 
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4.3.5 Viewing Software Versions and Restarting the NE with a New Software 
Image

The NE Software table lists the software that is installed on an NE. Use the Edit menu options to restart 
an NE with a new software image.

Tip Back up the NE database before activating or reverting to the standby software image on the NE.

Table 4-10 Field Descriptions for the Flash File Table

Field Description

Flash Partition Name Name of the flash partition that contains the flash file.

Filename Name of the flash file.

File Status Status of the flash file: 

• Deleted—The file is marked as deleted.

• Invalid Checksum—The file has an invalid checksum.

• Valid—The file is valid.

File Size Size of the file, in bytes.

File Checksum File checksum stored in the file header. The checksum is computed and stored when the file is 
written into the flash partition and serves to validate the data in the file. A file is marked as having 
an invalid checksum if any checksum mismatch was detected while writing or reading the file.

Incomplete files (files truncated because of either a lack of free space or a network download 
failure) are also written with a bad checksum and marked as invalid.

Table 4-11 Flash File Table Functions and Supported ONS 15530 and ONS 15540 NEs

Function Procedure
Supported on 
ONS 15530?

Supported on 
ONS 15540 ESP and 
ONS 15540 ESPx?

Activate an image Select the file and choose Edit > Activate. The image is 
activated, and the NE reboots.

Yes Yes

Verify file checksum Select the file and choose Edit > Verify. Yes Yes

Mark a file as deleted Select the file and choose Edit > Delete. The status of the 
file changes to Deleted. The file is not actually deleted 
until the Squeeze function is used.

Yes Yes

Mark a file as undeleted Select a file that is marked Deleted and choose Edit > 
Undelete.

Yes Yes

Physically remove a file Select a file that is marked Deleted and choose Edit > 
Squeeze.

Yes Yes
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Caution If you try to activate, revert, or switch to a software version that Prime Optical does not support, the 
following caution is displayed: “Caution: You are about to revert to an unsupported software version: 
version-number. Do you want to continue?”

If you activate, revert, or switch to an unsupported NE software version, the Prime Optical server might 
not communicate with one or more NEs in the domain, causing erroneous behavior.

Step 1 In the Domain Explorer tree, select an NE and choose Administration > NE Software Table. 
Table 4-12 provides descriptions.

• For NEs other than the ONS 15216 EDFA, the NE Software table displays the active and standby 
software versions for the NE. 

• For ONS 15216 EDFA NEs, the NE Software table displays the active, standby, and running 
software versions.

Note The NE Software table can also be launched from the Job Monitor table. From the Job 
Monitor table, choose Edit > NE Software Table (or click the NE Software Table tool).

Step 2 To activate new software on an NE, select the NE in the table and choose Edit > Commit (or click the 
Commit tool). At the confirmation prompt, click OK.

For the ONS 15305 (non-CTC-based) and CTC-based NEs, this makes the standby software version the 
active version (if the standby version is newer than the active version) and restarts the NE with the newer 
version.

Note The Commit feature is not available for ONS 15216 EDFA NEs.

Step 3 To revert to the standby software version on an NE, select the NE and choose Edit > Revert/Switch (or 
click the Revert/Switch tool). At the confirmation prompt, click OK.

• For the ONS 15216 EDFA, ONS 15310 CL, ONS 15310 MA SONET, ONS 15310 MA SDH, 
ONS 15327, ONS 15454 SONET, and ONS 15454 SDH, this reverts the active software version 
back to the standby version (if the standby version is older than the active version) and restarts the 
NE with the newer version.

• For the ONS 15600 SONET and ONS 15600 SDH, the Revert operation opens the Memory Restore 
dialog box, and you will need to provide a compatible database. For example, if the NE is running 
software release 1.1 and you want to download a release 1.0 package, you must provide a release 1.0 
database after downloading the software release 1.0 package.

Step 4 To accept the software version of an NE, select the NE and choose Edit > Accept (or click the Accept 
tool). The Accept command copies the downloaded software onto the standby Timing & Shelf Controller 
(TSC) and activates it.

Note The Accept feature is only available for the ONS 15600 SONET and ONS 15600 SDH.
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4.3.6 Activating a New NE Software Version on One or More ML-Series Cards
When an ONS 15310 CL, ONS 15454 SONET, or ONS 15454 SDH NE is partially upgraded to a new 
software version, you can choose to activate the new NE software version on one or more ML-series 
cards.

Note If the Partial Upgrade field in the NE Software Table is set to False, it means that the NE and all its cards 
are upgraded to the new NE software version. If set to True, it means that one or more cards are still 
running an older software version.

Step 1 In the Domain Explorer, select a group or an ONS 15310 CL, ONS 15454 SONET, or ONS 15454 SDH 
NE that contains ML-series cards, and choose Administration > NE Software Table.

Step 2 In the NE Software Table, select one or more NEs that are in Partial Upgrade mode and choose Edit > 
Reset ML Cards (or click the Reset specific ML Cards tool). 

Table 4-12 Field Descriptions for the NE Software Table

Field Description

NE Model Name Displays the model of the selected NE.

Alias ID Displays the alias name of the NE.

Physical Location Displays the location where the software is running.

NE Type For ONS 15454 NEs, displays the NE type. Values are:

• DWDM—For ONS 15454 MSTP R9.2 or later NEs.

• TDM—For ONS 15454 MSPP R9.2 or later NEs.

• Not Available—For all other NE versions.

Active Software 
Filename

Displays the active software version. For the ONS 15530 and ONS 15540, displays the software 
version on the active CPU.

Standby Software 
Filename

Displays the standby software version. For the ONS 15305 (non-CTC-based), it is the NE software 
version that has been downloaded. For the ONS 15530 and ONS 15540, displays the software version 
on the standby processor if a standby processor is present.

Note The standby software version is not available for the ONS 15305 R3.0.

Running Software 
Filename

For the ONS 15216 EDFA, displays the running software version.

Busy Flag Indicates whether the NE is rebooting to perform a software commit or revert. While the NE is 
rebooting, the value is True; when the NE has finished rebooting, the value is False.

Partial Upgrade Possible values are:

• True

• False

• N/A

NE ID Displays the ID name of the selected NE.
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Step 3 In the Reset ML Cards dialog box, select the ML-series cards on which to activate the new software. Use 
the Add button to move the ML-series cards to the Selected list. Use the Remove button to move the 
ML-series cards to the Available list.

Step 4 Click OK.

4.3.7 Delaying Software Activation on the ML-Series Cards
You can delay software activation on an ONS 15310 CL, ONS 15310 MA SONET, ONS 15310 MA 
SDH, ONS 15454 SONET, or ONS 15454 SDH NE’s ML-series cards when the NE is partially upgraded 
to a new software version and the NODE.software.AllowDelayedUpgrades parameter is set to TRUE.

Note You can change the value of the NODE.software.AllowDelayedUpgrades parameter in the NE Defaults 
tab of the NE Explorer. 

Step 1 In the Domain Explorer, select a group or an ONS 15310 CL, ONS 15310 MA SONET, ONS 15310 MA 
SDH, ONS 15454 SONET, or ONS 15454 SDH NE that contains ML-series cards, and choose 
Administration > NE Software Table.

Step 2 In the NE Software table, select an NE that is in Partial Upgrade mode and choose Edit > Commit (or 
click the Commit tool). The Bulk Software Activation wizard opens.

Step 3 Do the following:

a. Select the NE for which you want to activate software

b. Enter any comments about the job.

c. Specify the time for the software activation to occur.

Step 4 Click OK. The Software Activation dialog box opens.

Step 5 Check the Delay automatic activation on the ML cards check box to delay software activation. 
Uncheck the check box if you do not want to delay software activation. 

Note The Delay automatic activation on ML cards check box is checked by default if the 
NODE.software.DefaultDelayedUpgrades parameter is set to TRUE.

Step 6 Click OK in the Software Activation dialog box.

Step 7 Click OK in the Confirm commit message box.

Step 8 Click OK in the Prime Optical Progress message box.

   

4.3.8 Adding a New NE Software Version to the Prime Optical Domain
The Supported NE table provides information about the software version that is currently supported on 
a selected NE.
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Use this procedure only to apply a minor upgrade to the default, Prime Optical-supported software on 
the supported NE. Major upgrades to NE software might require you to update Prime Optical.

Caution It is recommended that this feature be used only at the advice of a Cisco technical support engineer. If 
incorrect modifications to data in the Supported NE table are made, the Prime Optical server might not 
communicate with one or more NEs in the domain.

Complete the following steps to add a new NE software version to the Prime Optical domain:

Step 1 In the Domain Explorer window, choose Administration > Supported NE Table. Table 4-13 provides 
descriptions.

Step 2 Select an NE.

Caution Make sure to select the correct NE row in the Supported NE table before proceeding. If the 
new software version is added to the wrong NE, the updated NE in the Prime Optical domain 
will show erroneous behavior.

Step 3 Choose Edit > Add (or click the Add Device Maintenance Version tool). 

The Add Device Maintenance Version dialog box opens.

Step 4 From the NE Model drop-down list, select the NE model.

Step 5 In the Software Version field, enter the software version.

Step 6 Click Submit.

Note You cannot customize the Version Name field. Prime Optical retrieves the version name from 
the Version Name field of the base version.

A message appears, displaying the version name.

Step 7 Click OK.

The new NE is added and the newly added NE displays an icon in the Software Version column.

Table 4-13 Field Descriptions for the Supported NE Table

Field Description

NE Model Displays the model of the selected NE.

Note The Supported NE table includes passive NEs, such as the ONS 15216 DCU and OSC. Passive 
NEs are shown in the Supported NE table for informational purposes only. The Prime Optical 
server does not check the software validity of passive NEs. 
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4.3.9 Deleting an NE Software Version from the Prime Optical Domain

Step 1 In the Domain Explorer window, choose Administration > Supported NE Table.

Step 2 Select the NE for which you want to delete the software version; then, choose Edit > Delete (or click 
the Delete Supported NE Version tool).

Note NE images that were manually added can be deleted. Default NE images cannot be deleted.

Step 3 Click OK in the confirmation dialog box.

4.4 How Do I Modify the Network?
Follow the procedures described in this section to change IP, subnet, and network addresses; configure 
proxy settings; change the operational state of an NE; set the date, time, and location on CTC-based NEs; 
and configure SNTP and application-specific parameters.

Note For information about setting up routing protocols, see 5.3 Configuring Routing Protocols on Optical 
NEs, page 5-2.

4.4.1 Changing IP Addresses for NEs
Prime Optical displays the active IP address of the selected NE. The active IP address field for end NEs 
(ENEs) is the IP address of the gateway NE (GNE) that the NE is using. This information is calculated 
on a theoretical projection, which does not necessarily equate to a real network situation.

4.4.1.1 Changing the NE IP Address on CTC-Based NEs

Step 1 In the Domain Explorer window, click the NE and choose Configuration > NE Explorer (or click the 
Open NE Explorer tool).

Software Version Specifies the software version that is supported on the selected NE.

Note You cannot delete the default NE software version. The default software version rows are created 
when the Prime Optical server is installed. These rows are the factory-default settings and cannot 
be deleted.

Version Name Specifies the software version name. For example, “15454 7.00” represents ONS 15454 SONET R7.0.

Note If the software version is manually added, the version name displays the value used by Prime 
Optical to manage the software version. 

Table 4-13 Field Descriptions for the Supported NE Table (continued)

Field Description
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Step 2 In the property sheet of the NE Explorer, click the Network tab > Address subtab.

Step 3 Change the IP address in the IP Address field. (For an IPv6 node, change the address in the IPv6 Config > 
IPv6 Address field.)

Note If you enter an IP address that is already in use, you receive the error message “A network 
element with this IP address already exists in the database, or this is a secure IP address.” You 
must enter a unique IP address.

Step 4 If necessary, change the following fields:

• Default Router (for an IPv4 node)

• Subnet Mask (for an IPv4 node)

• IPv6 Config > Default IPv6 Router (for an IPv6 node)

• IPv6 Config > IPv6 Subnet Mask (for an IPv6 node)

Step 5 Click Apply.

Step 6 A confirmation dialog box informs you that the NE will reboot. Click Yes. Prime Optical will lose 
connectivity to the NE. After several minutes, the NE will be back in service with the new IP address.

4.4.1.2 Changing the NE IP Address in a GNE/ENE Environment

When changing NE IP addresses in a GNE/ENE environment, change the IP address on the ENE node 
first; then, change the IP address on the GNE node. You do not need to remove NEs from Prime Optical.

Note This procedure applies only to NE releases 5.0 and later.

To change the IP address of a GNE and then convert all GNE/ENE settings to LAN-connected NE (LNE) 
in Prime Optical:

Step 1 Remove the ENE settings on the ENE. In the Network Explorer, click the Network tab > Firewall/Proxy 
subtab; then, uncheck the Enable Proxy Server on Port check box.

Step 2 Launch the NE Explorer for the ENE and click the Network tab > Address subtab. Change the IP 
address of the ENE. The NE reboots and does not come back up until the cable connections are correct 
in the network.

Step 3 Make the necessary cable connections to all NEs in the topology. (In this case, make all the NEs 
LAN-cable connected.)

Step 4 Remove the GNE settings on the GNE. In the Network Explorer, click the Network tab > 
Firewall/Proxy subtab; then, uncheck the Enable Proxy Server on Port check box.

The GNE becomes unavailable in Prime Optical. After some time, the GNE comes up as an LNE in 
Prime Optical.

Step 5 Wait until all the NEs come up as LNEs in Prime Optical.
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4.4.1.3 Switching Connectivity from IPv4 to IPv6

Prime Optical provides IPv6 support for the following NE releases: ONS 15310 MA SDH R9.3, ONS 
15310 MA SONET R9.3, ONS 15454 SDH R9.3, and ONS 15454 SONET R9.3.

Note IPv6 loopback address must be configured on the server in order for Prime Optical to work with 
IPv6.

Prime Optical tries to connect to an NE using its preferred IP address: IPv4 or IPv6, depending on how 
the NE was added or discovered by Prime Optical.

• For a user-added NE, the preferred IP address is the one that was entered when the NE was added.

• For a discovered NE, the preferred IP address depends on the IP connectivity of the GNE that 
discovered it.

If the preferred IP address is not reachable, Prime Optical tries to connect to the NE with the other IP 
address.

To enable IPv6 on an NE that supports this feature, complete the following steps:

Step 1 In the Domain Explorer tree, select the NE and choose Configuration > NE Explorer (or click the Open 
NE Explorer tool).

Step 2 In the property sheet of the NE Explorer, click the Network tab > Address subtab. 

Step 3 In the IPv6 Config area, check the Enable IPv6 check box and configure the following fields:

• IPv6 Address

• Default IPv6 Router 

• IPv6 Subnet Mask

Step 4 Click Apply.

Note If the IPv4 address is unavailable or disabled on the NE, Prime Optical uses the IPv6 address. If 
the NE is reachable through its IPv4 address, Prime Optical uses that address.

4.4.1.4 Changing the NE IP Address in Prime Optical Only

Note If the IP address is changed in Prime Optical, the change is made only in Prime Optical. Use the CLI if 
changes in the IP address need to be applied to the ONS 155xx NEs. In the Domain Explorer, choose 
Configuration > ONS 155XX > Launch CLI.

Complete the following steps to change the IP address in Prime Optical only:

Step 1 In the Domain Explorer tree, select the NE that will be changed.

Step 2 Click the Address tab. In the Active IP Address field, enter the new IP address. 
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Step 3 Click Save.

4.4.2 Changing the Internal Subnet Address—ONS 15600 SONET and 
ONS 15600 SDH

To avoid IP address conflicts, change the class B subnet address if your internal network uses the same 
address range as the default subnet address. To change class B subnet address for the TSC cards, 
complete the following steps.

Caution All network changes should be approved by your network administrator.

Complete the following steps to change the internal subnet address:

Step 1 In the Domain Explorer tree, select an ONS 15600 SONET or ONS 15600 SDH NE. 

Step 2 Choose Configuration > NE Explorer (or click the Open NE Explorer tool).

Step 3 In the node properties pane of the NE Explorer, click the Network tab > Internal Subnet subtab.

Step 4 Specify the following values in the TSC section:

• TSC1—Class B subnet address for the first TSC.

• TSC2—If there are two TSCs are installed, enter the class B subnet address for the second TSC.

Step 5 Click Apply.

4.4.3 Viewing and Changing the Network Address—CTC-Based NEs

Step 1 In the Domain Explorer tree, select a CTC-based NE and choose Configuration > NE Explorer (or 
click the Open NE Explorer tool).

Step 2 In the node properties pane of the NE Explorer, click the Network tab > Address subtab.

Step 3 Complete the following information:

• IP Address—IP address of the NE.

• Default Router—IP address of the default router.

• Subnet Mask—Subnetwork mask ID of the NE.

• MAC Address—Display only. Address as identified in the IEEE 802 MAC layer.

• LCD IP Setting—(ONS 15454 SONET and SDH only) Select one of the following:

– Allow Configuration—Allows users to change the shelf IP address from the LCD screen.

– Display Only—Displays the shelf IP address in the LCD screen and does not allow any 
configuration.

– Suppress Display—Shelf IP address is not displayed in, and cannot be configured from, the 
LCD screen.
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• Forward DHCP Requests—When checked, forwards the Dynamic Host Configuration Protocol 
(DHCP) requests to the IP address.

• DHCP Server—IP address of the DHCP server.

Step 4 In the node properties pane of the NE Explorer, click the Security tab > Access subtab. 

Step 5 In the CORBA (IIOP) Listener Port field, select one of the following values to allow communication with 
the NE through firewalls:

• Default-Fixed

• Standard Constant (683)

• Other Constant

Step 6 Click Apply.

4.4.4 Configuring Proxy Server Settings—CTC-Based NEs
CTC-based NEs have a proxy server feature set that allows networking these NEs in environments where 
visibility and accessibility are restricted. In the proxy server environment, CTC-based NEs are 
designated as either GNEs, ENEs, or tunnel NEs (TNEs). The GNE is LAN-connected to the DCN, while 
the ENE is accessed through the proxy server feature on the GNE over the SDCC. The ENE is not 
directly accessible through the IP address, while the GNE has an IP address that is valid for the DCN 
LAN. Prime Optical connects to TNEs that belong to an OSI network behind a non-Cisco GNE. Also, if 
an NE is LAN-connected and its proxy is disabled, the NE is shown as a LAN-connected NE (LNE).

4.4.4.1 Enabling Proxy

Step 1 In the Domain Explorer tree, select a CTC-based NE and choose Configuration > NE Explorer (or 
click the Open NE Explorer tool).

Step 2 In the Properties pane of the NE Explorer, select the Network tab > Firewall/Proxy subtab.

Step 3 Check the Enable Proxy Server on Port check box. When enabled, the NE serves as a proxy for 
connections between CTC clients and the NEs that are DCC-connected to proxy NEs. Uncheck the check 
box to disable the proxy. The on port field has a default value of 1080.

Step 4 You can enable the proxy on one of the following:

• ENE

• GNE

• Proxy-only

If the ENE and GNE are in different IP subnets, or if the ENE and GNE are in different Ethernet 
segments, the proxy should be enabled on the GNE. If the firewall is enabled on the GNE, it prevents 
communication between the laptop connected to the LAN port of the ENE and the network operations 
center (NOC), even if the proxy is enabled on both the ENE and GNE. Whenever the firewall is enabled 
on a GNE, the proxy should be enabled on the GNE as well.

Step 5 Click Apply.
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4.4.4.2 Notes on Configuring Proxy Server Settings

Note the following when configuring proxy server settings:

• In a proxy environment, you can launch CTC from Prime Optical for a proxy GNE if you are 
launching CTC for an ENE. CTC cannot be launched for a non-GNE if the proxy GNE is marked as 
Out of Service or is not reachable from Prime Optical. Launching CTC for NEs that are not 
reachable before Prime Optical can determine whether they are reachable displays the error 
messages “Error in launching CTC node view for NE” and “Initializing Class Loaders 
Failed–Timeout opening NE IP:Port.”

• In a proxy environment, you cannot launch a TL1 Telnet session directly for an NE. You can launch 
the Telnet window for the GNE and then enter the ACT-USER command, specifying the ENE as the 
TID.

• Prime Optical can configure multiple GNEs but it can only associate a single GNE for a given ENE. 
If the GNE becomes inaccessible, Prime Optical can automatically use one of the other available 
GNEs to reach the ENE.

• When a proxy-enabled GNE (named GNE1) is first added to Prime Optical, Prime Optical 
automatically discovers all associated NEs (through the topology discovery feature) and identifies 
them as ENEs associated with GNE1. If there are other proxy-enabled GNEs that are discovered 
from GNE1, Prime Optical will mark them as GNEs. When proxy is enabled on any GNE, all ENEs 
lose connectivity and eventually regain it. In a multiple DCC-connected GNE scenario, NEs that do 
not regain connectivity should be marked as Out of Service, then marked as In Service again.

• If both LAN and DCC connections exist between the GNE and ENEs, the DCC connection takes 
precedence.

4.4.4.3 Configuring Proxy Server Settings for NEs Equipped with ML-Series Cards

Prime Optical supports only the following configurations for NEs that are equipped with ML-series 
cards:

• GNE with SNMPv1, v2, and v3.

Note Prime Optical considers an NE to be a GNE if proxy-only is enabled, or if proxy with 
firewall is enabled.

• ENE with SNMPv1, v2, and v3.

Note Prime Optical considers an NE to be an ENE if proxy is not enabled, or if proxy/firewall and 
craft access are enabled.

For NE release 4.6 and earlier, see Table 4-14. For NE release 5.0 and later, see Table 4-15. In order for 
Prime Optical to support a proxy/firewall scenario, the scenario must have a “Yes” in all four columns 
of the table, and CLI launch must be supported.

For an explanation of proxy server settings on the NEs, refer to the NE hardware documentation.
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The following table describes the proxy server settings for release 4.6 and earlier NEs.

Table 4-14 Proxy Server Settings for R4.6 and Earlier NEs

Proxy Scenario FM CM PM RMON Threshold

Proxy only, GNE (CLI launch is supported)1

1. In this scenario, the NE is set up as a GNE with proxy enabled. The internal firewall is not turned on and there is no external firewall between the server 
and the NEs.

SNMPv1 No Yes Yes Yes

SNMPv2 Yes Yes Yes Yes

Proxy only, ENE (CLI launch is not supported)2

2. In this scenario, the NE is set up as an ENE with proxy enabled. The internal firewall is not turned on and there is no external firewall between the server 
and the NEs.

SNMPv1 No Yes Yes No

SNMPv2 No Yes Yes No

Proxy and internal firewall, GNE (CLI launch is supported)3

3. In this scenario, the NE is set up as a GNE with proxy and internal firewall enabled. There is no external firewall between the server and the NEs.

SNMPv1 No Yes Yes Yes

SNMPv2 Yes Yes Yes Yes

Proxy and internal firewall, ENE (CLI launch is not supported)4

4. In this scenario, the NE is set up as an ENE with proxy and internal firewall enabled. There is no external firewall between the server and the NEs.

SNMPv1 No Yes Yes No

SNMPv2 No Yes Yes No

Proxy only, GNE, with external firewall and NAT (CLI launch is not supported)5

5. In this scenario, the NE is set up as a GNE with proxy enabled. The internal firewall is not turned on. There is an external firewall between the server 
and the NEs that is using NAT.

SNMPv1 No Yes Yes No

SNMPv2 Yes Yes Yes No

Proxy only, GNE, with internal firewall, external firewall, and NAT (CLI launch is not supported)6

6. In this scenario, the NE is set up as a GNE with proxy and internal firewall enabled. There is an external firewall between the server and the NEs that is 
using NAT.

SNMPv1 No Yes Yes No

SNMPv2 No Yes Yes No

Proxy only, ENE, with internal firewall, external firewall, and NAT (CLI launch is not supported)7

7. In this scenario, the NE is set up as an ENE with proxy and internal firewall enabled. There is an external firewall between the server and the NEs that 
is using NAT.

SNMPv1 No Yes Yes No

SNMPv2 No Yes Yes No

External firewall and PAT8 (CLI launch is not supported)9

8. PAT = Port Address Translation.

9. There is an external firewall between the server and the NEs that is using PAT. The NE and Prime Optical do not support this configuration.

SNMPv1 No No No No

SNMPv2 No No No No
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The following table describes the proxy server settings for release 5.0 and later NEs.

Table 4-15 Proxy Server Settings for R5.0 and Later NEs

Proxy Scenario FM CM PM RMON Threshold

Proxy only, GNE (CLI launch is supported)1

1. In this scenario, the NE is set up as a GNE with proxy enabled. The internal firewall is not turned on and there is no external firewall between the 
server and the NEs.

SNMPv1 Yes Yes Yes Yes

SNMPv2/v3 Yes Yes Yes Yes

Proxy only, ENE (CLI launch is not supported)2

2. In this scenario, the NE is set up as an ENE with proxy enabled. The internal firewall is not turned on and there is no external firewall between the 
server and the NEs.

SNMPv1 Yes Yes Yes Yes

SNMPv2/v3 No Yes Yes Yes

Proxy and internal firewall, GNE (CLI launch is supported)3

3. In this scenario, the NE is set up as a GNE with proxy and internal firewall enabled. There is no external firewall between the server and the NEs.

SNMPv1 Yes Yes Yes Yes

SNMPv2/v3 Yes Yes Yes Yes

Proxy and internal firewall, ENE (CLI launch is not supported)4

4. In this scenario, the NE is set up as an ENE with proxy and internal firewall enabled. There is no external firewall between the server and the NEs.

SNMPv1 Yes Yes Yes Yes

SNMPv2/v3 No Yes Yes Yes

Proxy only, GNE, with external firewall and NAT (CLI launch is not supported)5

5. In this scenario, the NE is set up as a GNE with proxy enabled. The internal firewall is not turned on. There is an external firewall between the server 
and the NEs that is using NAT.

SNMPv1 Yes Yes Yes Yes

SNMPv2/v3 Yes Yes Yes Yes

Proxy only, GNE, with internal firewall, external firewall, and NAT (CLI launch is not supported)6

6. In this scenario, the NE is set up as a GNE with proxy and internal firewall enabled. There is an external firewall between the server and the NEs 
that is using NAT.

SNMPv1 Yes Yes Yes Yes

SNMPv2/v3 Yes Yes Yes Yes

Proxy only, ENE, with internal firewall, external firewall, and NAT (CLI launch is not supported)7

7. In this scenario, the NE is set up as an ENE with proxy and internal firewall enabled. There is an external firewall between the server and the NEs 
that is using NAT.

SNMPv1 Yes Yes Yes Yes

SNMPv2/v3 No Yes Yes Yes

External firewall and PAT (CLI launch is not supported)8

8. There is an external firewall between the server and the NEs that is using PAT. The NE and Prime Optical do not support this configuration.

SNMPv1 No No No No

SNMPv2/v3 No No No No
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4.4.4.4 Conditions Under Which Prime Optical Recognizes an NE as an LNE, a GNE, a TNE, or an ENE

An NE in Prime Optical can show up as an LNE, a GNE, a TNE, or an ENE. The type is denoted in a 
small rectangle next to the corresponding NE in the Domain Explorer tree. The following tables 
document how Prime Optical determines whether an NE in the network is considered an LNE, GNE, 
TNE, or ENE.

NE terminology:

• LAN Connected denotes whether the NE is connected directly to the LAN.

• Proxy Enabled denotes whether the “Enable Proxy” option is checked for the NE (in the 
NE Explorer > Network > Firewall/Proxy subtab).

• Firewall Enabled denotes whether the “Enable Firewall” option is checked for the NE (in the 
NE Explorer > Network > Firewall/Proxy subtab).

• Craft Access Enabled denotes whether the “Craft-Access Only” option is checked for the NE (in the 
NE Explorer > Network > Firewall/Proxy subtab).

• GNE denotes whether the “Gateway Network Element (GNE)” option is selected for the NE (in the 
NE Explorer > Network > Firewall/Proxy subtab).

• ENE denotes whether the “External Network Element (ENE)” option is selected for the NE (in the 
NE Explorer > Network > Firewall/Proxy subtab).

• Proxy-only denotes whether the “Proxy-only” option is selected for the NE (in the NE Explorer > 
Network > Firewall/Proxy subtab).

• A value of N/A indicates that the setting for that column is irrelevant to the end result.

Prime Optical terminology:

• Prime Optical GNE—Gateway network element. A GNE is an NE that is LAN-connected and 
provides access to and proxies for other NEs that are otherwise unreachable.

• Prime Optical ENE—External network element. An ENE is an NE that is not directly reachable. 
These NEs can only be accessed via (proxied by) a GNE.

• Prime Optical LNE—LAN-connected NE. An LNE is connected on the LAN and does not proxy for 
and is not proxied by other NEs.

• Prime Optical TNE—Tunnel NE. Prime Optical can connect to a TNE that belongs to an OSI 
network behind a non-Cisco GNE. You can open a new TL1 tunnel on a selected TNE, close an 
existing TL1 tunnel, or modify the TL1 tunnel settings. TNEs do not support SNMP. The following 
NE models support TL1 tunnels: ONS 15310 CL, ONS 15310 MA SONET, ONS 15310 MA SDH, 
ONS 15327, ONS 15454 SONET, and ONS 15454 SDH. 

Note the following configuration restrictions:

• For all cases where the NE type is denoted as ENE, per current Prime Optical design, an ENE will 
not have connectivity in Prime Optical unless there is at least one GNE in the same ring as the ENE.

• All NEs on the same Ethernet segment must have the same value for craft access. Mixed values 
might leave some nodes unreachable through the shared Ethernet segment.

• All NEs on the same Ethernet segment must have the same value for the firewall. Mixed values might 
leave some nodes unreachable.

• All NEs in the same SDCC area must have the same value for the firewall. Mixed values might leave 
some nodes unreachable.

• If the firewall is enabled on an NE, the proxy server must also be enabled. If the proxy server is not 
enabled, CTC cannot see nodes on the DCC side of the NE.
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• If Craft Access Only is enabled on an NE, the proxy server must also be enabled. If the proxy server 
is not enabled, CTC cannot see nodes on the DCC side of the NE.

• Only those NEs that have no LAN connectivity to the Prime Optical server can have Craft Access 
Only enabled or be set as an ENE.

Table 4-16 ONS 15327, ONS 15454 SONET/SDH R4.1.x

NE State Type Proxy Enabled? Craft Access Only? Firewall Enabled? LAN Connected? DCC Connected?

GNE Yes No Yes Yes N/A

GNE Yes No No Yes N/A

ENE Yes N/A N/A No Yes1

1. Prime Optical discovers this NE as an ENE if there is at least one GNE on the same DCC domain with proxy server enabled. 

ENE No N/A N/A No Yes1

ENE No N/A N/A Yes Yes1

LNE No No N/A Yes No

LNE No No N/A Yes Yes2

2. Prime Optical discovers this NE as an LNE if all the NEs on the same DCC domain have proxy server disabled.

Table 4-17 ONS 15310, ONS 15327, ONS 15454 SONET/SDH R4.6 and Later

NE State Type
Proxy Enabled? (GNE, ENE, or 
Proxy-only Enabled on the NE) LAN Connected? DCC Connected?

GNE Yes Yes Yes

GNE Yes Yes No

ENE Yes No Yes1

1. Prime Optical discovers this NE as an ENE if there is at least one GNE on the same DCC domain with proxy server enabled. 

ENE No No Yes1

ENE No Yes Yes1

LNE No Yes No

LNE No Yes Yes2

2. Prime Optical discovers this NE as an LNE if all the NEs on the same DCC domain have proxy server disabled.

Table 4-18 ONS 15310 CL, ONS 15327, ONS 15454 SONET/SDH R6.0 and Later; ONS 15310 MA SONET R7.0 and Later; 

ONS 15310 MA SDH R9.1, R9.2, R9.3

NE State Type Proxy Enabled? Craft Access Only? Firewall Enabled? LAN Connected? DCC Connected?

TNE Yes No Yes No N/A

TNE Yes No No No N/A
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4.4.4.5 Creating a New Proxy Tunnel

Step 1 In the Domain Explorer tree, select a CTC-based NE and choose Configuration > NE Explorer (or click 
the Open NE Explorer tool).

Step 2 In the node properties pane, click the Network tab.

Step 3 Click the Proxy Tunnels subtab.

Step 4 Click Create. The Create New Proxy Tunnel dialog box opens. The following table provides 
descriptions.

Step 5 After making your selections, click OK.

   

Table 4-19 ONS 15600 SONET R1.1.2, 1.1.3, 1.3.1; ONS 15600 SDH R1.4

NE State Type Proxy Enabled? Firewall Enabled? LAN Connected? DCC Connected?

GNE Yes Yes Yes N/A

GNE Yes No Yes N/A

ENE Yes N/A No Yes1

1. Prime Optical discovers this NE as an ENE if there is at least one GNE on the same DCC domain with proxy server enabled. 

ENE No N/A No Yes1

ENE No N/A Yes Yes1

LNE No N/A Yes No

LNE No N/A Yes Yes2

2. Prime Optical discovers this NE as an LNE if all the NEs on the same DCC domain have proxy server disabled.

Table 4-20 Field Descriptions for the Create New Proxy Tunnel Dialog Box

Field Description

Source Address Enter the source IP address in the source-destination pair for the tunnel that will be routed 
through the proxy server.

Source Mask Length Specify the length of the source mask (from 0 to 32).

Source Mask Enter the source subnetwork mask in the source-destination pair for the tunnel that will be 
routed through the proxy server.

Destination Address Enter the destination IP address in the source-destination pair for the tunnel that will be routed 
through the proxy server.

Destination Mask Length Specify the length of the destination mask (from 0 to 32).

Destination Mask Enter the destination subnetwork mask in the source-destination pair for the tunnel that will 
be routed through the proxy server.
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4.4.4.6 Creating a New Firewall Tunnel

Step 1 In the Domain Explorer tree, select a CTC-based NE and choose Configuration > NE Explorer (or click 
the Open NE Explorer tool).

Step 2 In the node properties pane, click the Network tab.

Step 3 Click the Firewall Tunnels subtab.

Step 4 Click Create. The Create New Firewall Tunnel dialog box opens. The following table provides 
descriptions.

Step 5 After making your selections, click OK.

   

4.4.5 Changing the Operational State of an NE

Step 1 In the Domain Explorer tree, select the NE that will be changed.

Step 2 In the Network Element Properties pane > Status tab > Operational State field, choose one of the 
following values:

• Preprovisioned—(Not available if already provisioned) The NE has been added to the database for 
provisioning but is not yet in service. Prime Optical does not manage preprovisioned NEs.

• In Service—The NE is deployed and requires monitoring. Prime Optical collects polling, fault 
management (FM), configuration management (CM), and PM data from in-service NEs and stores 
the data in the database.

• Out of Service—The NE has been marked Out of Service by a network administrator and does not 
require monitoring. The Prime Optical database records the last known state of the NE when it was 
in service.

• Under Maintenance—The NE is temporarily under maintenance but requires monitoring. This state 
is the same as In Service except that Prime Optical does not report alarms or events for 
under-maintenance NEs.

Table 4-21 Field Descriptions for the Create New Firewall Tunnel Dialog Box

Field Description

Source Address Enter the source IP address in the source-destination pair for the tunnel that will be routed 
through the firewall.

Source Mask Length Specify the length of the source mask (from 0 to 32).

Source Mask Enter the source subnetwork mask in the source-destination pair for the tunnel that will be 
routed through the firewall.

Destination Address Enter the destination IP address in the source-destination pair for the tunnel that will be routed 
through the firewall.

Destination Mask Length Specify the length of the destination mask (from 0 to 32).

Destination Mask Enter the destination subnetwork mask in the source-destination pair for the tunnel that will 
be routed through the firewall.
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Tip You can also right-click an NE in the Domain Explorer tree or Subnetwork Explorer tree and 
choose Mark Under Maintenance, Mark In Service, or Mark Out of Service from the 
shortcut menu.

There are two additional states that you cannot choose. These operational states are changed by 
Prime Optical based on the initialization tasks that are completed:

• In Service–Initializing—The NE is marked as In Service–Initializing when Prime Optical reaches 
connectivity of the NE (Communication State is marked as Available) and the discovery process 
starts. The initialization process is completed when fault and inventory have been synchronized. The 
operational state changes from In Service–Initializing to In–Service Synch Configuration.

• In-Service Synch Configuration—The NE is marked as In–Service Synch Configuration when 
Prime Optical uploads a configuration for that NE. You can change the operational state of an NE 
from In-Service Synch Configuration to Out of Service.

Step 3 Click Save.

Step 4 Click Yes in the confirmation dialog box.

Timesaver If an NE is brought down, mark it as Out of Service to prevent unnecessary polling traffic on the DCN.

Note When you mark an NE as Out of Service and then mark it as In Service, the Prime Optical alarm time 
stamp in the Alarm Browser window is resynchronized with the time stamp when the NE is put back in 
service.

4.4.6 Setting Date, Time, and Location on CTC-Based NEs

Step 1 In the Domain Explorer, select an NE and choose Configuration > NE Explorer (or click the Open NE 
Explorer tool).

Step 2 In the node properties pane, click the General tab > Identification subtab.

Step 3 In the Location area:

• Set the latitude of the NE by selecting North or South from the Latitude drop-down list; then, enter 
the degrees and minutes (or click the up or down arrow to increase or decrease each by 1 unit).

• Set the longitude of the NE by selecting East or West from the Longitude drop-down list; then, enter 
the degrees and minutes (or click the up or down arrow to increase or decrease each by 1 unit).

Step 4 In the Date and Time area:

• Time—Enter the date and time.

• Time Zone—From the drop-down list, select the time zone where the NE is located.

• Use Daylight Savings Time—When checked, Daylight Savings Time is observed.

Step 5 Click Apply.
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4.4.6.1 Using the SNTP Server to Set the Date and Time

Simple Network Time Protocol (SNTP) is an internet protocol used to synchronize the clocks of 
computers to a time reference. Using the SNTP server ensures that all NEs use the same date and time 
reference. The server synchronizes the node’s time after power outages or software upgrades. To use the 
SNTP server to set the date and time for CTC-based NEs, complete the following steps.

Note SNTP is not supported on the CTC-based ONS 15305 R3.0.

Step 1 In the Domain Explorer, select an NE and choose Configuration > NE Explorer.

Step 2 In the node properties pane, click the General tab > Identification subtab.

Step 3 In the SNTP Settings area, do one of the following:

• Set up the SNTP server and optional backup SNTP server, to set the date and time of the node:

– Check the Use NTP/SNTP Server check box.

– In the SNTP Server field, enter the SNTP server’s IP address.

– (Optional) In the Backup SNTP Server field, enter the backup SNTP server’s IP address.

• If you do not use the SNTP server, in the Date and Time area, enter the date and time in the Time 
field (for more information, see 4.4.6 Setting Date, Time, and Location on CTC-Based NEs, 
page 4-54).

Step 4 Click Apply.

   

4.4.7 Configuring SNTP for Multiple NEs
Use the SNTP Configuration dialog box to provision a set of SNTP parameters on multiple NEs at the 
same time. You can provision primary and secondary NTP and SNTP server addresses. Both the primary 
and secondary NTP/SNTP address can have IPv4 or IPv6 format.

When the SNTP address setting on an NE fails, the reason for the failure is logged in the Error Log table. 
As part of a bulk SNTP operation, if the setting on an NE fails, Prime Optical continues to set the SNTP 
server address on the remaining NEs that are part of the operation.

Note SNTP configuration is not available for ONS 15216 NEs.

Step 1 In the Domain Explorer, choose Administration > SNTP Configuration. The SNTP Configuration 
dialog box opens. Table 4-22 provides descriptions.

Step 2 Enter the following information:

• NEs

• Job comments

• SNTP 

• Time (time zone)
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Step 3 Click Finish.

A job is scheduled for each NE that was assigned the SNTP server IP address. The job status is listed in 
the Job Monitor table. (For more details, see 4.6.1.1 Viewing the Job Monitor Table, page 4-88.) The 
status of each SNTP set operation is updated as the job progresses. Job status can be one of the following:

• Queued—The job has been scheduled but has not yet been processed.

• Running—The job is being processed.

• Succeeded—The SNTP server IP address is set on the NE.

• Failed—The SNTP server IP address was not set on the NE. The reason for the failure is logged in 
the Error Log table.

• Waiting—The job is waiting for the NE to be in service.

   

Table 4-22 Field Descriptions for the SNTP Configuration Dialog Box

Field Description

Network 
Elements

Use the Add and Remove buttons to move NEs to the Selected NEs list, or to remove NEs from the list. 
The SNTP server address is set on the NE(s) in the Selected NEs list.

Job Comments Enter comments about the SNTP server address setting, if needed.

SNTP Use the Resync Time (min; ONS 15305 only) field if you want the ONS 15305 NE to use the SNTP server 
to synchronize time information. The Resync Time field is the time passed between two synchronization 
operations. The NE uses this information to know when to synchronize with the SNTP server.

If you check the Use NTP/SNTP Server check box, Prime Optical uses the NTP or SNTP server to set 
the date and time of the node. Using the NTP or SNTP server ensures that all NEs use the same date and 
time reference. After checking the check box, enter the server IP address in the SNTP IP Address field. 
If you want to include a backup SNTP server, enter the backup SNTP server IP address in the Backup 
SNTP Server field. If you do not check the Use NTP/SNTP Server check box, the NE stores the NTP or 
SNTP address but does not use it to synchronize time information.

Note In the SNTP IP Address field, enter the IP address of your active SNTP server. Do not enter the 
IP address of your Prime Optical server. The Prime Optical server is not an NTP/SNTP server. If 
you do not know your SNTP server IP address, contact your system administrator.

Time (time zone) Set a time for the SNTP address setting. Click Now to begin immediately, or click At Time and specify 
when to begin the SNTP set, specifying the date, hour, and minute in 5-minute increments.

Use the calendar tool to choose the year, month, and day:

• Year—Click the year combo box or the double arrow (<<, >>) at the bottom of the calendar.

• Month—Click the month combo box or the single arrow (<, >) at the bottom of the calendar.

• Day—Click the day number on the calendar. The current date is shown in blue.

Note The time zone can be GMT, a user-defined offset from GMT, or local time, depending on what is 
specified in the User Preferences dialog box.
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4.4.8 Configuring Application-Specific Parameters
The UI Properties pane allows you to configure application-specific parameters.

Step 1 In the Domain Explorer window, choose Administration > Control Panel.

Step 2 In the Control Panel window, click UI Properties to open the UI Properties pane. The following table 
provides descriptions.

Step 3 After making your selections, click Save.

Table 4-23 Field Descriptions for the UI Properties Pane

Field Description

Fault Management • Alarm Acknowledgement—Allows you to specify automatic or manual alarm 
acknowledgement in the Alarm Browser window. If you choose manual alarm 
acknowledgment, you must manually acknowledge alarms. Cleared alarms move from the 
Alarm Browser to the Alarm Log. If you choose automatic alarm acknowledgment, the 
Prime Optical server automatically acknowledges alarms when they are cleared and moves 
them from the Alarm Browser to the Alarm Log. Before alarms move to the Alarm Log, they 
must be both cleared and acknowledged.

Note You can still manually acknowledge alarms in automatic acknowledgement mode.

• Overwrite Alarm Notes—Enables or disables the ability to overwrite alarm notes created by 
another user.

• Alarm Unacknowledgement—Enables or disables the ability to unacknowledge alarms that 
have been acknowledged.

Circuit Management • Overwrite Circuit Notes—Enables or disables the ability to overwrite circuit notes created by 
another user.

• Automatically Route Internode Circuits—Enables or disables the ability to automatically route 
internode circuits. The default state is Enabled (that is, automatic routing is allowed).

Note The Route Automatically option (located in the Routing Preferences pane in the Circuit 
Creation wizard) is disabled when the Automatically Route Internode Circuits radio button 
is set to Disable.

Note When the Automatically Route Internode Circuits option is set to Enable/Disable, it is set 
for all client sessions logged into that Prime Optical server.

Job Management Overwrite Job Notes: Enables or disables the ability to overwrite job notes created by another user. 

Domain Management Allows you to specify how node names longer than 25 characters are truncated in the Network Map. 
If a string is longer than 25 characters, the first 22 characters display followed by an ellipsis (...). 
You can choose to truncate the first or last characters of the node name.
4-57
Cisco Prime Optical 9.6 User Guide

OL-27078-01



Chapter 4      Maintaining an Efficient Network
How Do I Manage Redundancy and Failover?
4.5 How Do I Manage Redundancy and Failover?
Follow the procedures described in this section to back up and restore memory; modify NE service 
properties; back up client files; restore server configuration files; initialize a node resynchronization; 
manage protection groups; restore NE defaults; and configure card redundancy.

4.5.1 Backing Up NE Memory
Prime Optical allows you to back up and restore memory for selected NEs. For example, if you want to 
save your settings for a particular NE, you can back up the memory for only that NE.

Prime Optical backs up configuration and provisioning information residing in the flash memory of an 
NE. Prime Optical provides three methods by which to perform the configuration backup operation:

• Manually on demand

Subnetwork Grouping Enables or disables the ability to automatically group NEs in subnetworks. If you check the 
Automatically Group NEs in Subnetworks check box, you cannot change the subnetwork of an 
NE, meaning:

• The option of selecting a subnetwork in the Add New NE wizard is disabled and shows <System 
Default>.

• The add NE process applies all automatic grouping rules.

• Drag-and-drop functionality is disabled on the Subnetwork Explorer.

• You cannot change the subnetwork assignment from the NE Properties pane.

Note During the transient period when this option is changed, any current operations (such as 
dropping an NE in a subnetwork) are completed.

Network Discovery Using the Allow Provisioning check box, you can allow or disallow the discovery mode that you 
have set to be changed later. 

• To allow a change of the mode later—Check the Allow Provisioning check box, and select a 
mode of discovery from the Default Discovery Mode drop-down list below. This lets you 
change the mode of discovery while creating a new NE service. 

• To disallow a change of the mode later—Uncheck the Allow Provisioning check box, and select 
a mode of discovery from the Default Discovery Mode drop-down list below.

Using the Default Discovery Mode option, you can set the mode of discovery of the NEs; the mode 
of discovery can be manual or automatic. Set the discovery mode to one of the following:

• Automatic—When a new NE is added, Prime Optical automatically discovers the NE and adds 
it to the network partition.

• Manual—When a new NE is added to Prime Optical, the NE remains in the Undiscovered 
Network Elements group in the Domain Explorer. You can add the NE to the desired network 
partition. click Add Undiscovered NEs to add the NEs to a network partition.

Note This option is available only for CTC-based NEs.

Audit Trail State Allows you to enable or disable audit trails. NEs that are added or discovered will be assigned this 
setting.

Table 4-23 Field Descriptions for the UI Properties Pane (continued)

Field Description
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• Scheduling (one time only)

• Periodic, automatic scheduling based on a configurable time set by the operator 

You can specify the number of backup configurations that should be kept at any given time. The default 
number is seven.

Note The maximum number of copies that can be saved is dictated by the amount of disk space available.

The oldest configuration that was backed up is replaced by the current backup depending on the 
configured number of copies you want to retain at any given time. The memory restore function in 
Prime Optical can then be used to roll back to any one of the previous configurations that was saved. 
Once the configuration is downloaded, you will need to enter CLI commands to activate the new 
configuration.

Note The restore operation is service affecting, because the node is rebooted to reflect the restored 
configuration.

Follow the procedures described in these sections to back up and restore memory (configuration data) 
on NEs. Prime Optical allows you to back up memory for the following NEs:

• ONS 15216 EDFA2 (R2.3.0 and later)

• ONS 15216 EDFA3

• ONS 15310 CL

• ONS 15310 MA SONET

• ONS 15310 MA SDH

• ONS 15327

• ONS 15454 SONET

• ONS 15454 SDH

• ONS 15530

• ONS 15540 ESP and ESPx

• ONS 15600 SONET

• ONS 15600 SDH

• CPT 200

• CPT 200 SDH

• CPT 600

• CPT 600 SDH

Usage Notes:

• The latest ONS 15216 EDFA2 R2.4 hardware does not support memory backup to a software release 
other than 2.4.0. The ONS 15216 EDFA2 R2.3 hardware supports memory backup for NE software 
releases 2.3 and 2.4.

• For the ONS 15530 and ONS 15540, the SNMP Community String table must have a valid write 
community string for the NE before memory can be backed up or restored. For more information, 
see Chapter 3, “Building the Network.”
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• Prime Optical does not support memory backup for the ONS 15305 or Not Managed/Other Vendor 
NEs.

The Memory Backup procedure backs up configuration and provisioning information residing in the 
flash memory of an NE. By default, the Prime Optical server automatically backs up memory for NEs 
once a day for seven days and stores the backup files on the Prime Optical server. After seven days, the 
oldest backup file is replaced by the current backup. For more information, see 4.5.3.4 Configuring 
Automatic NE Backup Parameters, page 4-74.

Step 1 In the Domain Explorer tree, select a management domain or group that contains an NE that is assigned 
an In Service or Under Maintenance operational state. Alternatively, select an NE that is assigned an In 
Service or Under Maintenance state.

Note Memory backup is not allowed for preprovisioned or out-of-service NEs.

Step 2 Choose Administration > Memory Backup.

Step 3 The Memory Backup dialog box opens. Enter the following information (see Table 4-24 for details):

• NE model

• Selected NEs

• Job comments

• Tag name

• Time (time zone)

Note For the ONS 15216 EDFA2, the backup file must be saved in the default directory, such as 
the tftpboot directory on the remote TFTP server, in case the file will be restored from the 
remote TFTP server. The tftpboot directory must have read-write access, or the backup job 
will fail. See Chapter 3, “Building the Network” for information about configuring the tftp 
directory with read-write access.

Note The time zone can be GMT, a user-defined offset from GMT, or local time, depending on 
what is specified in the User Preferences dialog box.

Step 4 Depending on the type of NE, do one of the following:

• For ONS 15530 and ONS 15540 NEs, proceed to Step 5.

• For ONS 15600 NEs, proceed to Step 6.

• For ONS 15216, ONS 15310 CL, ONS 15310 MA SONET, ONS 15310 MA SDH, ONS 15327, 
ONS 15454 SONET, or ONS 15454 SDH NEs, click Finish to initiate the memory backup 
procedure.

• For the ONS 15216, the configuration file is copied to the 
$CTMHOME/admin/NE-system-ID/15216-tag-name-time-stamp-backup.cfg file.

• For the ONS 15310 CL, ONS 15310 MA SONET, or ONS 15310 MA SDH, the configuration file is 
copied to the $CTMHOME/admin/NE-system-ID/15310-tag-name-time-stamp-backup.cfg file.

• For the ONS 15327, the configuration file is copied to the 
$CTMHOME/admin/NE-system-ID/15327-tag-name-time-stamp-backup.cfg file.
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• For the ONS 15454 SONET or ONS 15454 SDH, the configuration file is copied to the 
$CTMHOME/admin/NE-system-ID/15454-tag-name-time-stamp-backup.cfg file.

Note If System Default is chosen for the tag name, the tag is left blank and the filename is, for 
example, 15454--backup.cfg. If User Specified is chosen and hello is entered for the tag 
name, the filename is 15454-hello-YYYYMMDDHHMM-backup.cfg, where 
YYYYMMDDHHMM is the backup date, consisting of:

YYYY—Four-digit year
MM—Two-digit month
DD—Two-digit day
HH—Two-digit hour (in 24-hour format)
MM—Two-digit minute

Step 5 For ONS 15530 and ONS 15540 NEs:

a. Click Next to display memory backup options. Select an option (see Table 4-24 for details):

• Running Configuration

• Startup Configuration

• Save Running Config as Startup Config on NE

b. Click Finish to initiate the memory backup procedure.

The configuration file for each NE is copied to the $CTMHOME/admin/NE-system-ID/ 
155xx-tag-time-stamp-slot-number-of-active-CPU-[ running | startup ].cfg file, where:

• $CTMHOME is the installation directory (by default, the installation directory is 
/opt/CiscoTransportManagerServer).

• NE-system-ID is the hostname of the ONS 15530 or ONS 15540.

• tag-time-stamp is the user-defined tag name and includes the time stamp. If System Default is 
selected, the tag is left blank and the filename is, for example, 
15540-time-stamp-slot6-startup-backup.cfg. If User Specified is selected and hello is entered 
as the tag name, the filename is 15540-hello YYYYMMDDHHMM-slot6-startup.cfg, where 
YYYYMMDDHHMM is the time stamp.

The tag time stamp is ignored when the running configuration is saved as the startup configuration, 
because this operation is done on the NE itself and no backup file is saved on the Prime Optical 
server.

• slot-number-of-active-CPU is the slot number of the active CPU at the time of job execution. If 
the slot number cannot be obtained, the filename is 
15540-tag-time-stamp-[ running | startup ].cfg.

• running or startup is the memory backup option chosen.

Note For the ONS 15530 and ONS 15540 NEs, the automatic backup files are named 
155xx-time-stamp-slot-number-[ running | startup ].cfg.

Step 6 For ONS 15600 SONET and ONS 15600 SDH NEs:

a. Click Next to display memory backup options. Select the category of data to back up (see Table 4-24 
for details):

• Provisioning data (is selected by default and is display only)
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• Alarm data

• PM data

b. Click Finish to initiate the memory backup procedure.

The configuration file is copied to the 
$CTMHOME/admin/NE-system-ID/15600-tag-name-time-stamp-backup.cfg file.

After scheduling the backup, look at the Job Monitor table (Administration > Job Monitor) to see the 
job status. If the job fails, the Additional Information field in the Job Monitor table provides more 
information.

If a memory backup job fails, the EMS raises an alarm. All prior memory backup failure EMS-generated 
alarms on an NE are cleared under the following conditions:

• After a successful memory backup operation on the NE

• When the operational state of the NE changes to Out of Service

Table 4-24 Field Descriptions for the Memory Backup Dialog Box

Field Description

NE Model Select the NE type that you want to back up. The type you select determines the NEs that are 
displayed in the Network Elements area.

Network Elements Use the Add and Remove buttons to move the NEs that you want to back up to the Selected NEs 
list, or to remove NEs from the list.

Job Comments Enter comments about the backup, if needed.

Tag Name Add a tag to the system-generated filename. If you select System Default, no tag name is added. 
If you select User Specified, you can enter a tag name.

Time (time zone) Set a time for the backup. Click Now to begin backup immediately, or click At Time and specify 
when to begin backup, in 5-minute increments.

Note The time zone can be GMT, a user-defined offset from GMT, or local time, depending on 
what is specified in the User Preferences dialog box. 

Memory Backup Dialog Box 2 for ONS 15530 and ONS 15540 NEs

Running Configuration Copies the running configuration of the active CPU to the backup file. The backup file is saved in 
the $CTMHOME/admin/NE-system-ID directory. The CPU slot number is included in the 
filename. If you selected a tag name, the tag and time stamp are included in the filename. For 
example, if the active CPU is in slot 6, the filename is 
15540-tag-time-stamp-slot6-running-backup.cfg.

Startup Configuration Copies the startup configuration of the active CPU to the backup file. The startup configuration 
is stored in NVRAM and used when the NE reboots. The backup file is saved in the 
$CTMHOME/admin/NE-system-ID directory. The CPU slot number is included in the filename. 
If you selected a tag name, the tag and time stamp are included in the filename. For example, if 
the active CPU is in slot 6, the filename is 15540-tag-time-stamp-slot6-startup-backup.cfg.

Save Running Config as 
Startup Config on NE

Saves the running configuration as the startup configuration on the NE itself. The user-defined tag 
name is ignored. This is the equivalent of the write mem CLI command.

Memory Backup Dialog Box 2 for ONS 15600 SONET and ONS 15600 SDH NEs

Provisioning Data Display only. Backs up the ONS 15600 provisioning data. 
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4.5.2 Restoring NE Memory
Use the Memory Restore dialog box to restore provisioning and configuration information stored in the 
flash memory of the following NEs. (This information is backed up by using the Memory Backup dialog 
box.)

• ONS 15216 EDFA2 (EDFA2 R2.3.0 and later)

• ONS 15216 EDFA3

• ONS 15310 CL

• ONS 15310 MA SONET

• ONS 15310 MA SDH

• ONS 15327

• ONS 15454 SONET

• ONS 15454 SDH

• ONS 15530

• ONS 15540 ESP and ESPx

• ONS 15600 SONET

• ONS 15600 SDH

Usage Notes:

• The latest ONS 15216 EDFA2 R2.4 hardware does not support memory restore to a software release 
other than 2.4.0. The ONS 15216 EDFA2 R2.3 hardware supports memory restore for NE software 
releases 2.3 and 2.4.

• For the ONS 15530 and ONS 15540, the SNMP Community String table must have a valid write 
community string for the NE before memory can be restored. For more information, see Chapter 3, 
“Building the Network.”

• Prime Optical does not support memory restore for the ONS 15305 or Not Managed/Other Vendor 
NEs.

Complete the following steps to restore NE memory:

Step 1 In the Domain Explorer tree, select an NE that is assigned an In Service or Under Maintenance 
operational state.

Note Run the Memory Restore procedure for one NE at a time. You cannot restore memory for 
preprovisioned or out-of-service NEs.

Alarm Data If checked, the ONS 15600 alarm data is backed up.

PM Data If checked, the 15-minute and 1-day PM data for the ONS 15600 is backed up.

Table 4-24 Field Descriptions for the Memory Backup Dialog Box (continued)

Field Description
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Step 2 Choose Administration > Memory Restore. The Memory Restore dialog box opens.

Step 3 Enter the following information (see Table 4-26 for details):

• NE model

• NEs (select only one)

• Source

• Job comments

• Memory restore options (available only for CTC-based NEs)

• Time

Step 4 Depending on the type of NE, do one of the following:

• For the ONS 15310 CL, ONS 15310 MA SONET, ONS 15310 MA SDH, ONS 15327, ONS 15454 
SONET, or ONS 15454 SDH, proceed to Step 5.

• For the ONS 15530 or ONS 15540, proceed to Step 6.

• For the ONS 15600 SONET or ONS 15600 SDH, proceed to Step 7.

• For the ONS 15216 EDFA2 or ONS 15216 EDFA3 NEs, click Finish.

Step 5 For the ONS 15310 CL, ONS 15310 MA SONET, ONS 15310 MA SDH, ONS 15327, ONS 15454 
SONET, or ONS 15454 SDH, click Next to verify the following file properties:

• Node description

• Node name

• Node type

• IP address

• Software version

Prime Optical performs a compatibility check. The following table lists the compatibility factors and the 
corresponding action. The restore operation is not allowed if the NEs are of different types or if the 
software version is incompatible.

Caution Restoring the memory of an NE using an incompatible or corrupted file might cause loss of 
traffic or loss of connectivity.

Table 4-25 Compatibility Factors for Memory Restore

Compatibility Factor Action

Different NE type Finish button is disabled; click Cancel.

Incompatible software version Finish button is disabled; click Cancel.

Different node name Prime Optical displays a warning message. You can click Finish to 
proceed with the restore operation or Cancel to cancel the 
operation.

Different software version Prime Optical displays a warning message. You can click Finish to 
proceed with the restore operation or Cancel to cancel the 
operation.
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Step 6 For an ONS 15530 or ONS 15540:

a. Click Next to display the memory restore options. Select an option (see Table 4-26 for details):

• Running configuration 

• Startup configuration

b. Click Finish to initiate the memory restore procedure.

Step 7 For the ONS 15600 SONET or ONS 15600 SDH:

a. Click Next to display the memory restore options. Select the category of data to restore (see 
Table 4-26 for details):

• Provisioning data (is selected by default and is display only)

• Alarm data

• PM data

b. Click Finish to initiate the memory restore procedure.

To view the results of the memory restore operation, open the Job Monitor table (Administration > Job 
Monitor). For information about the Job Monitor table, see 4.6.1 Monitoring Scheduled Tasks, 
page 4-87.

Table 4-26 Field Descriptions for the Memory Restore Dialog Box

Field Description

NE Model Select the NE model that you want to restore. The model you select determines the NEs that are 
displayed in the Network Elements field.

Network Elements Use the Add and Remove buttons to move the NE that you want to restore to the Selected NE list. 
You can run the Memory Restore procedure for only one NE at a time.
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Source Specify the location of the backup file that you want to use to restore the NE: 

• Click Local to browse a local client directory for the backup file.

• Click Server to restore the file from the Prime Optical server. The files shown are in the 
/opt/CiscoTransportManagerServer/admin/NE-system-ID directory in chronological order, with 
the most recent backup file displayed at the top of the list. The backup file uses the naming 
convention NE-model-date time-backup.cfg, where:

– date has the format YYYYMMDD (that is, 20080206 is February 6, 2008)

– time has the format hhmmss (that is, 144911 is 2:49:11 p.m.)

For example, a valid backup filename is Cisco_ONS_15454-20080201144911-backup.cfg.

Note The Server radio button is not active unless a file exists in that directory.

• Click Remote TFTP Server Address to restore from another network server. (The Remote 
option is not supported for CTC-based NEs.) In the TFTP Server Address field, enter the IP 
address of the TFTP server. In the Relative TFTP File Path field, enter the fully qualified 
pathname of the backup file to be restored, relative to the tftpboot directory. TFTP must be 
configured and running on the network server. The Remote option is supported for the ONS 
15216 EDFA2 R2.3.0 and later.

Note If the Remote option is selected for the ONS 15216 EDFA, the backup file that you are 
restoring must have been saved in the default directory, such as the tftpboot directory on the 
remote TFTP server.

Note The tftpboot directory must have read-write access, or the restore job will fail. See Chapter 3, 
“Building the Network” for information about how to configure the tftp directory with 
read-write access.

• Click Remote FTP Server Address to restore from any UNIX workstation that is running FTP. 
This option requires authentication. In the FTP Server Address field, enter the IP address of the 
FTP server. In the FTP File Path field, enter the fully qualified pathname of the backup file to be 
restored, relative to the FTP directory. In the FTP Username field, enter the FTP username. In the 
FTP User Password field, enter the FTP user password. The Remote FTP Server option is 
supported only for the ONS 15216 EDFA3.

Job Comments Enter comments about the restore procedure, if needed.

Memory Restore 
Options 
(available only for 
CTC-based NEs)

For CTC-based NEs, specify whether you want to partially or completely restore memory. This 
feature is available only to users with SuperUser or NetworkAdmin privileges.

• Click Partial Restore to restore only the provisioning database, which includes information 
about links, circuits, and information contained in the NE Explorer. Partial Restore is selected by 
default.

• Click Complete Restore to restore both the provisioning database and the system database. The 
system database parameters include software version, version name, NE node name, and so on.

Time (time zone) Set a time for memory restore. Click Now to begin memory restore immediately, or click At Time 
and specify when to begin memory restore, in 5-minute increments.

Note The time zone can be GMT, a user-defined offset from GMT, or local time, depending on what 
is specified in the User Preferences dialog box.

Table 4-26 Field Descriptions for the Memory Restore Dialog Box (continued)

Field Description
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4.5.3 Viewing and Modifying NE Service Properties
The NE Service pane in the Control Panel window allows you to view and update Prime Optical server 
configuration information, which includes timing parameters and NE backup parameters. You can also 
stop or start an individual NE service instance.

All server configuration changes take effect when you save them. The NE Service pane contains the 
following tabs, which are described in Table 4-27:

• NE Poller—Allows you to change timing parameters and CTC IIOP port information.

• NE Auto Backup—Allows you to configure automatic NE backup parameters.

• NE Manual Backup—Allows you to configure manual NE backup parameters.

Note The NE service is not started as a process until you activate an NE for that particular service.

When you add a network partition, the NE service is not started automatically. It starts only when you 
add an NE to the network partition. When the last NE is removed from the network partition, the NE 
service is not stopped automatically. The NE service stops only when the network partition is deleted.

Note Prime Optical is limited to running a maximum number of 23 Java processes. Enter the opticalctl status 
command to view the current number of running processes.

4.5.3.1 Understanding the Unmanaged NE Service

Unmanaged NEs have their own NE service. This Unmanaged NE Service allows Prime Optical to 
support unmanaged NE devices that are not in the Supported NE table. Unmanaged NEs can be Cisco or 
non-Cisco devices. The Unmanaged NE Service is required for operations such as:

• Creating manual links between managed and unmanaged NEs

• Creating manual links between unmanaged NEs

Memory Restore Dialog Box 2 for ONS 15530 and ONS 15540 NEs

Running 
Configuration

Restores the currently running configuration of the NE.

Note Configuration file commands are added to the current running configuration on the NE. The 
running configuration is not replaced by the configuration file.

Startup 
Configuration

Restores the startup configuration of the NE. This operation replaces the entire startup configuration 
file.

Memory Restore Dialog Box 2 for ONS 15600 SONET and ONS 15600 SDH NEs

Provisioning Data Display only. Restores the ONS 15600 provisioning data.

Alarm Data If checked, the ONS 15600 alarm data is restored.

PM Data If checked, the 15-minute and 1-day PM data for the ONS 15600 is restored.

Table 4-26 Field Descriptions for the Memory Restore Dialog Box (continued)

Field Description
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• Changing the operational state of unmanaged NEs

The Unmanaged NE Service also supports DWDM topology with IP Address along with the optical 
configuration.The following features are supported:

• Assign the type of the NE (CRS-1, CRS-3, ASR9K) and the IP address.

• Ability to cross-launch Prime Network from the unmanaged device.

• Create manual links between ONS and unmanaged NEs.

• Create patchcords that connects any CRS port to the ROADM device.

Note Passive NEs such as the ONS 15216 EDFA1 are not considered unmanaged NEs.

4.5.3.2 Changing Timing Parameters

Use the NE Service pane to tune timing parameters and accommodate different Prime Optical 
server-to-NE connectivity scenarios. When timing parameters are tuned, network utilization and 
Prime Optical server load are optimized. As a rule, timing parameters increase as the network slows.

Step 1 In the Domain Explorer window, choose Administration > Control Panel.

Step 2 In the Control Panel window, click NE Service to open the NE Service pane. Table 4-27 describes the 
fields in the NE Service pane.

Step 3 Click the NE Poller tab and enter the NE health poll interval.

Step 4 In the Control Panel window, expand the NE Service and click an NE. Table 4-28 describes the fields in 
the individual NE Service panes.

Step 5 In the Resync Scheduling area of the individual NE Service pane, enter the interval at which the 
configuration is retrieved and processed. This field is not available for all NEs.

Note The default values are adequate for most network configurations. Decreasing the values of the 
parameters could adversely impact server performance.

Step 6 Click Save. Changes take effect immediately.

Table 4-27 Field Descriptions for the NE Service Pane

Field Subfield Description

NE Poller Tab

Timing Parameters NE Health Poll 
Interval

Displays the NE polling interval (in seconds). The default is 240 seconds 
(4 minutes).
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CTC IIOP Port 
Configuration

CTC IIOP Port 
Range

Displays CTC IIOP ports or a range of ports for CTC-based network services that 
have been selected to be configured. When all ports have been removed in the CTC 
IIOP Selection dialog box, the CTC IIOP Port Range field displays a zero.

Edit CTC IIOP 
Port Range 
button

Click the Edit CTC IIOP Port Range button to open the CTC IIOP Port Selection 
dialog box, which allows you to configure CTC IIOP ports or a range of ports for 
CTC-based network services.

Note Table 4-29 describes the fields in the CTC IIOP Port Selection dialog box.

NE Auto Backup Tab

Select Modify Mode All NE Models, 
NE Model

Allows you to specify whether the automatic backup should apply to a specific NE 
model (ONS 15216 EDFA2 [R2.3.0 and later], ONS 15216 EDFA3, ONS 15310 
CL, ONS 15310 MA SONET, ONS 15310 MA SDH, ONS 15327, ONS 15454, 
ONS 15454 SDH, ONS 15530, ONS 15540 ESP, ONS 15540 ESPx, ONS 15600, 
ONS 15600 SDH, CPT 200, CPT 200 SDH, CPT 600, or CPT 600 SDH) or to all 
applicable NE models.

Apply All 
Changes

If checked and All NE Models is selected, all of the values on this tab will be 
applied to all of the NE models. The applied changes also include the values that 
have not been modified currently.

If unchecked, only the current changes will be applied to all of the NE models.

Table 4-27 Field Descriptions for the NE Service Pane (continued)

Field Subfield Description
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Configuration 
Parameters

NE Model If NE Model is selected under Select Modify Mode, this field allows you to specify 
the NE model that will be backed up automatically.

Enable Auto 
Backup

If checked, the system automatically backs up all NE models, or a specific NE 
model. When NE Auto Backup State is set to Enabled, an entry is added to the Job 
Monitor table with a new job ID and a new task ID for each NE. Scheduled Time is 
set to the selected autobackup time and Task Status is set to Queued. When the 
autobackup time is reached and the task begins, Task Status is set to Running. After 
the backup is complete, Task Status is set back to Queued and Scheduled Time is 
reset to the time and date of the next scheduled backup time. When NE Auto 
Backup State is set to Disabled, Task Status is set to Cancelled. The default state is 
Disabled.

When you first enable Memory Auto Backup, the job runs the same day if the 
scheduled time has not already passed. If the time has passed, the job runs the next 
day. However, if you later modify the Memory Auto Backup schedule, the job 
always runs the next day, regardless of whether or not the scheduled time has 
passed.

Number of 
Backup Copies 
Retained

Allows you to specify the number of backup copies to keep. The valid range is from 
1 to 50 backup copies; the default is 7. Only automatic backup copies count toward 
the total number of backup copies saved; manual backup copies do not count toward 
the total.

For ONS 15530 and ONS 15540 NEs, the total number of backup copies includes 
both running and startup configuration files. For example, if you want to keep 7 
copies of each configuration file, you should set the number of copies to 14.

Each time Prime Optical creates a new backup file, it checks the existing number of 
backup copies. Prime Optical deletes files as needed, beginning with the oldest file, 
so as not to exceed the specified number of backup copies to keep.

Backup Time Allows you to set the time when the automatic backup will be performed.

NE Manual Backup Tab

Select Modify Mode — Allows you to specify whether the manual backup should apply to a specific NE 
model (ONS 15216 EDFA2 [R2.3.0 and later], ONS 15216 EDFA3, ONS 15310 
CL, ONS 15310 MA SONET, ONS 15310 MA SDH, ONS 15327, ONS 15454, 
ONS 15454 SDH, ONS 15530, ONS 15540 ESP, ONS 15540 ESPx, ONS 15600, 
ONS 15600 SDH, CPT 200, CPT 200 SDH, CPT 600, or CPT 600 SDH) or to all 
applicable NE models.

Configuration 
Parameters

NE Model If NE Model is selected under Select Modify Mode, this field allows you to specify 
the NE model that will be backed up manually.

Number of 
Backup Copies 
Retained

Allows you to specify the number of backup copies to keep. The default is 7.

Each time Prime Optical creates a new backup file, it checks the existing number of 
backup copies. Prime Optical deletes files as needed, beginning with the oldest file, 
so as not to exceed the specified number of backup copies to keep.

Table 4-27 Field Descriptions for the NE Service Pane (continued)

Field Subfield Description
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4.5.3.3 Viewing the Individual NE Service Panes

The individual NE Service panes in the Control Panel window allow you to stop, start, or configure an 
individual NE service instance.

Table 4-28 Field Descriptions for the Individual NE Service Panes

Field Description

Status Tab

Service Status (This field is 
called Network Service 
Status for CTC-based 
SONET and CTC-based 
SDH NEs)

Displays the current status of the service: Active or Not Active. By default, the status is Not 
Active.

Note The NE service can take up to 60 seconds to initialize after the GUI status has changed 
to indicate that the service is up. The status is an indication of the successful initiation 
of the service startup, not successful initialization.

Service Action Allows you to stop or start a process. Notice that the Service Action button toggles between 
Activate and Deactivate, and that the Service Status field changes accordingly.

Threshold Displays the maximum number of NEs that each NE service instance can manage. The 
threshold depends on the NE type, as follows:

• ONS 15216 NE Service can manage up to 1000 ONS 15216 NEs.

• ONS 15305 NE Service can manage up to 1000 ONS 15305 NEs.

• ONS 155xx NE Service can manage up to 1000 ONS 155xx NEs.

• ONS 15310 CL, ONS 15310 MA SONET, ONS 15310 MA SDH, ONS 15327, ONS 15454 
SONET, or ONS 15600 SONET NE Service can manage up to 400 ONS 15310 CL, 
ONS 15310 MA SONET, ONS 15327, ONS 15454 SONET, or ONS 15600 SONET NEs 
(for NE releases earlier than R5.0).

Note For NE release 5.0 or later in a large or high-end configuration, the NE service can 
manage up to 500 NEs.

• ONS 15454 SDH and ONS 15600 SDH NE Service can manage up to 600 ONS 15454 SDH 
or ONS 15600 SDH NEs.

• Unmanaged NE Service can manage up to 500 unmanaged NEs.
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Resync Scheduling (not 
applicable to unmanaged 
or ONS 155xx NEs)

Allows you to specify a schedule for database resynchronization for each NE model. A schedule 
consists of the following configurable parameters:

• Days of the week to run: All, Sunday, Monday, Tuesday, Wednesday, Thursday, Friday, 
Saturday. Check the check box next to the day(s) to run the configuration 
resynchronization.

• Time of day to initiate the resynchronization, in HH:MM AM/PM format (specific format 
based on locale).

• Interval between synchronizations, in HH:MM format. The maximum interval is 24:00; the 
minimum is 5:00. The resynchronization interval is calculated only until the end of the day. 
The schedule for the next day takes effect after the end of the current day. For example, if 
you choose Wednesday with a start time of 10:00 a.m. and an interval of 6 hours, the 
resynchronization occurs at 10:00 a.m., 4:00 p.m., and 10:00 p.m. on Wednesdays.

After you set the time interval between synchronizations, the Prime Optical server 
resynchronizes the database with the configuration changes from the last resynchronization 
time. This synchronizes the database with NE, card, and line configuration information.

Note The Last Resync field shows when the NE was last synchronized.

• Enable Resync Alarms check box—This check box is available after you select the days of 
the week for database resynchronization. When checked, the Config Resync operation 
starts and Prime Optical resynchronizes with all the active alarms that are present on the 
NE.

Bandwidth Utilization 
Report (applicable to 
CTC-based SONET and 
CTC-based SDH NEs)

Check the Enable Bandwidth Data Service Provisioning (DSP) check box to enable the 
bandwidth check during L2 service provisioning. The bandwidth utilization report shows 
available and used bandwidth for each L2 topology. This report can be used during L2 service 
provisioning to verify whether the requested Committed Information Rate (CIR) is available on 
the topology. Based on the report, a warning is returned if there is not enough bandwidth 
available for a drop port. Be careful not to oversubscribe the bandwidth.

Designated Socks Server 
(applicable to CTC-based 
SONET and CTC-based 
SDH NEs)

Check the Enable Designated Socks Server check box to allow the CTC-based SONET or 
CTC-based SDH NEs to serve as a designated SOCKS server (DSS). If the NE is a DSS, it 
manages connectivity among other NEs through network firewalls. 

Threshold Crossing Alerts 
(applicable to CTC-based 
SONET and CTC-based 
SDH NEs)

Check the Enable Threshold Crossing Alerts Receiver check box to forward events to other 
services (for example, from network service to other services) for CTC-based SONET or 
CTC-based SDH NEs. If the Enable Threshold Crossing Alerts Receiver check box is 
unchecked, events are not forwarded to other services and TCA information is not saved on the 
database.

Robust Fault 
Synchronization 
(applicable to CTC-based 
SONET and CTC-based 
SDH NEs)

Allows you to enable or disable the robust fault synchronization for the ONS 15310 CL, 
ONS 15310 MA SONET, ONS 15310 MA SDH, ONS 15327, ONS 15454 SONET, ONS 15454 
SDH, ONS 15600 SONET, ONS 15600 SDH, CPT 200, and CPT 600.

BLSR-Ring/MS-SPRing 
Switch Interval (applicable 
to CTC-based SONET and 
CTC-based SDH NEs)

Allows you to set the BLSR or MS-SPRing switch interval, in seconds. The default is 
60 seconds.

Table 4-28 Field Descriptions for the Individual NE Service Panes (continued)

Field Description
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TL1 Tunnel Connection 
Timeout (applicable to 
CTC-based SONET and 
CTC-based SDH NEs)

Allows you to set the time it takes to set up a TL1 tunnel connection between the Prime Optical 
server and the tunneled NE (TNE). When a new NE is added using the Add NE wizard, you can 
connect to the new NE using a TL1 tunnel. The Prime Optical server establishes a TCP/IP 
connection to a non-Cisco GNE (NGNE) and the NGNE establishes an OSI connection to the 
TNE. If the Prime Optical server cannot set up the TL1 tunnel connection before the specified 
TL1 tunnel connection timeout, the Add NE operation fails and the TNE connection state 
becomes unavailable.

Audit Trail Collection 
Interval (applicable to 
CTC-based SONET and 
CTC-based SDH NEs)

Allows you to set the audit trail collection interval, in minutes.

Note For NE releases earlier than release 6.0, the audit trail records are not cleared 
automatically. Instead, you must clear the alarms manually by archiving the audit 
records from CTC. In NE release 6.0 and later, the CTC API clears the audit trail 
records automatically, and the alarms are cleared automatically in Prime Optical. 

To manually clear audit trail records for NE releases earlier than 6.0, launch CTC and 
choose Maintenance > Audit > Archive.

L2 Service Resync Delay 
(applicable to CTC-based 
SONET and CTC-based 
SDH NEs)

Allows you to configure the delay after which Prime Optical performs a Cisco IOS 
configuration synchronization on ML cards to keep the NE and the Prime Optical Data 
Provisioning Service synchronized. This operation synchronizes the L2 topology.

Full Cisco IOS configuration synchronization is performed automatically by Prime Optical to 
keep the NE and the Prime Optical Data Provisioning Service synchronized. Full configuration 
resynchronization might be delayed depending on Prime Optical server usage. For the 
Prime Optical server deployed as a monitoring server, the recommended value for the delay 
parameter is 120 seconds. For the Prime Optical server deployed as a provisioning server, the 
recommended value for the delay parameter is 10 minutes (600 seconds).

ENEs List Poll Interval 
(applicable to CTC-based 
SONET and CTC-based 
SDH NEs)

Time interval in which all CTC-based GNEs in Prime Optical need to refresh their list of ENEs. 
The list of ENEs for each GNE is obtained and compared with the existing ENE list. If there 
are any changes to the ENE list, topology changes are carried out so that the Domain Explorer 
will reflect the current topology with correct GNE and ENE icons.

Debug Tab (This tab is called NET Service Debug for CTC-based SONET and CTC-based SDH NEs)

Overall Logging Enable—Choose the Enable radio button to enable logging. When you choose the Enable radio 
button, the debug modules in the Available list become selectable.

Disable—Choose the Disable radio button to disable logging. When you choose the Disable 
radio button, the debug modules in the Available list become dimmed and you cannot make any 
selections.

Debug Modules Available—Select one or more debug modules in the Available list and click Add to move them 
to the Selected list.

Tip Hold down the Shift key to select more than one debug module sequentially. To select 
multiple debug modules nonsequentially, hold down the Ctrl key on your keyboard 
while using your mouse to select multiple debug modules.

Selected—Select one or more debug modules in the Selected list and click Remove to move 
them to the Available list.

Save button After making your selections, click Save. Changes take effect immediately.

Table 4-28 Field Descriptions for the Individual NE Service Panes (continued)

Field Description
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4.5.3.4 Configuring Automatic NE Backup Parameters

Prime Optical can be configured to automatically back up ONS 15216 EDFA2, ONS 15216 EDFA3, 
ONS 15310 CL, ONS 15310 MA SONET, ONS 15310 MA SDH, ONS 15327, ONS 15454 SONET, 
ONS 15454 SDH, ONS 15530, ONS 15540 ESP, ONS 15540 ESPx, ONS 15600 SONET, and ONS 
15600 SDH NEs once a day.

Automatic backup files are saved in the following locations and have the following names:

• $CTMHOME/admin/NE-system-ID/15216-YYYYMMDDHHMM-auto.cfg

• $CTMHOME/admin/NE-system-ID/[15530 | 15540]-YYYYMMDDHHMM-
Active-CPU-slot-number-[running | startup]-auto.cfg

• $CTMHOME/admin/NE-system-ID/15310-YYYYMMDDHHMM-auto.cfg

• $CTMHOME/admin/NE-system-ID/Cisco_ONS_15327-YYYYMMDDHHMM-auto.cfg

• $CTMHOME/admin/NE-system-ID/15454-YYYYMMDDHHMM-auto.cfg

• $CTMHOME/admin/NE-system-ID/15600-YYYYMMDDHHMM-auto.cfg

• $CTMHOME/admin/NE-system-ID/CTM-YYYYMMDDHHMM-auto.cfg

where:

• YYYYMMDDHHMM is the date of the backup:

– YYYY is the four-digit year

– MM is the two-digit month

– DD is the two-digit day

– HH is the two-digit hour (in 24-hour format)

– MM is the two-digit minute

For example, 4:01 p.m. on September 29, 2006 is represented as 200609291601.

• Active-CPU-slot-number is the slot number of the active CPU at the time of job creation.

• [ running | startup ] indicates whether the backup is of the NE’s running configuration or startup 
configuration.

Note Automatic backup is not available for all NEs.

Use the NE Service pane to set automatic NE backup parameters.

Step 1 In the Domain Explorer window, choose Administration > Control Panel.

Step 2 In the Control Panel window, click NE Service to open the NE Service pane. Click the NE Auto Backup 
tab. Table 4-27 provides descriptions.

Step 3 Enter the following information:

• Select Modify Mode

• NE Model

• Enable Auto Backup

• Number of Backup Copies Retained
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• Backup Time

• Backup Data (available only if ONS 15600 SONET or ONS 15600 SDH is selected as the NE model)

Step 4 Click Save. Changes take effect immediately; however, the backup already scheduled for the next 
24 hours remains in effect. A backup with the new parameters will occur after the previously scheduled 
backup runs.

If the time you scheduled for the backup is prior to the current time of the current day, a backup for the 
current day will be scheduled for immediate execution. Otherwise, backups for the current day and 
subsequent days will occur at the specified time.

To verify whether Prime Optical is automatically backing up the NE, go to the Job Monitor table 
(Administration > Job Monitor), verify that the task is listed, and check its task status. If automatic 
backup for an NE failed, the task status will be “Failed.” This failure is logged in the Audit Log and an 
alarm is generated.

Note If the Prime Optical server restarts after the scheduled automatic backup time for that day, Prime Optical 
automatically schedules a backup for all ONS 15327, ONS 15454 SONET, ONS 15530, and ONS 15540 
NEs to take place 5 to 10 minutes after the restart. Conversely, if the server restarts before the scheduled 
backup time for that day, the backup occurs at the regularly scheduled time. This behavior ensures that 
a backup is performed for each NE at least once a day.

For example, if the automatic backup time is set for 2:00 a.m. and the Prime Optical server restarts at 
8:00 p.m., the server schedules a backup 5 to 10 minutes after the restart because the backup time is 
earlier than the restart time on the same day. As another example, if the automatic backup time is set for 
11:00 p.m. and the Prime Optical server restarts at 8:00 p.m., the server waits until 11:00 p.m. to run the 
backup because the backup time is later than the restart time.

An entry is added to the Audit Log for each successful completion or failed NE autobackup task.

4.5.3.5 Configuring Manual NE Backup Parameters

Use the NE Service pane to set manual NE backup parameters.

Step 1 In the Domain Explorer window, choose Administration > Control Panel.

Step 2 In the Control Panel window, click NE Service to open the NE Service pane. Click the NE Manual 
Backup tab. Table 4-27 provides descriptions.

Step 3 Enter the following information:

• Select Modify Mode

• NE Model

• Number of Backup Copies Retained

Step 4 Click Save. Changes take effect immediately; however, the backup already scheduled for the next 
24 hours remains in effect. A backup with the new parameters will occur after the previously scheduled 
backup runs.
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4.5.3.6 CTC IIOP Port Configuration

The CTC IIOP Port Selection dialog box allows you to configure individual CTC IIOP ports, or a range 
of ports, for the CTC-based NE service.

Typically you would configure a specific CTC IIOP port (or a range of ports) if you have a firewall 
between the Prime Optical server and the NE.

The number of ports configured must equal the number of CTC-based NE services, unless you have 
SSLIOP configured on the NE. If you have SSLIOP configured on the NE, each NE service requires two 
ports (instead of one port): one for IIOP and one for SSLIOP.

Step 1 In the Domain Explorer window, choose Administration > Control Panel.

Step 2 In the Control Panel window, click NE Service to open the NE Service pane.

Step 3 Click the NE Poller tab.

Step 4 Click the Edit CTC IIOP Port Range button to open the CTC IIOP Port Selection dialog box, which 
allows you to select CTC IIOP ports or a range of ports for the CTC-based NE service. Table 4-29 
provides descriptions.

Step 5 Enter the port values.

Note You can specify a single port (leaving the To text field blank) or a port range by specifying the 
initial value (From text field) and the end value (To text field).

Step 6 Click the Add Port button to add the ports you entered. The ports are added to the Selected Port list in 
ascending order.

Tip You can remove ports from the Selected Port list by selecting the port you want to remove and 
clicking the Remove button. The port moves to the Deleted Port list.

Step 7 Click OK to close the CTC IIOP Port Selection dialog box. At the confirmation prompt, click OK. The 
values displayed in the Selected Port list are formatted and displayed in the CTC IIOP Port Range field.

Caution The NE service will not start if the ports you select are already in use by the server. Verify that the port 
values you select in the CTC IIOP Port Selection dialog box are not already in use by the server before 
saving your changes.

Table 4-29 Field Descriptions for the CTC IIOP Port Selection Dialog Box

Field Description

Specify CTC IIOP Port Range

From/To fields Enter a port range by specifying the initial value in the From field and the end value in the To field. You 
can specify a single port by entering the port value in the From field, leaving the To field blank. The valid 
range for the From/To fields is from 0 to 65,535.

Add Port button Click the Add Port button to add the ports specified in the From/To fields to the Selected Port list. Ports 
listed in the Selected Port list will appear in the CTC IIOP Port Range field.
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4.5.4 Viewing and Modifying Service Instance Properties
The NE Service Instance pane in the Control Panel window allows you to view a list of NEs managed 
by the service instance. You can also activate or deactivate debug logging on selected NEs.

Step 1 In the Domain Explorer window, choose Administration > Control Panel.

Step 2 In the Control Panel window, expand NE Service.

Step 3 Expand an individual NE service and click NE Service Instance. The following table provides 
descriptions.

Port Selection

Deleted Port Displays the list of ports to be deleted from the CTC IIOP Port Range.

Selected Port Displays the list of ports to be added to the CTC IIOP Port Range.

Add button Select a port in the Deleted Port list and click the Add button to move the port to the Selected Port list. 
Ports listed in the Selected Port list will appear in the CTC IIOP Port Range field.

Remove button Select a port in the Selected Port list and click the Remove button to move the port to the Deleted Port 
list. Ports listed in the Deleted Port list will not appear in the CTC IIOP Port Range field.

Table 4-29 Field Descriptions for the CTC IIOP Port Selection Dialog Box (continued)

Field Description

Table 4-30 Field Descriptions for the NE Service Instance Pane

Field Description

Status

Network Partition Displays the name of the associated Network Partition. This is a read-only field.

Service Status Displays the current status of the service: Running or Stopped.

The network service can take up to 60 seconds to initialize after the GUI status has 
changed to indicate that the service is up. The status is an indication of the successful 
initiation of the service startup, not successful initialization.

Start Service Instance, Stop Service 
Instance

Allows you to stop or start an individual network service instance. If you click Start 
Service Instance, the service status changes to Running. If you click Stop Service 
Instance, the status changes to Stopped.

The list of managed NEs shows which NEs are being managed by the selected service 
instance. If you stop the specified service instance, the NEs in the list are no longer 
managed.

Dump Cache button Click the Dump Cache button to export the cache (memory) information of the 
selected service instance to a log file. This feature applies only to CTC-based NE 
service instances.
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4.5.4.1 Viewing the Prime Optical NE Module Level Debug Table

The Prime Optical NE Module Level Debug table displays the debug state of the selected NEs, and it 
lists the modules for which debugging is active.

Step 1 In the Domain Explorer window, choose Administration > Control Panel.

Step 2 In the Control Panel window, expand NE Service or PM Service then do one of the following:

• Expand one of the following under NE Service:

– CTC-Based SONET NEs

– CTC-Based SDH NEs

• Expand one of the following under the PM Service:

Debug Table button Click the Debug Table button to open the Prime Optical NE Module Level Debug 
table. See 4.5.4.1 Viewing the Prime Optical NE Module Level Debug Table, 
page 4-78.

Discovery Mode Lets you set the mode of discovery of NEs; the mode of discovery can be manual or 
automatic. Set the discovery mode to one of the following:

• Automatic—When a new NE is added, Prime Optical automatically discovers the 
NE and adds it to the network partition.

• Manual—When a new NE is added to Prime Optical, the NE remains in the 
Undiscovered Network Elements group in the Domain Explorer. You can later 
add the NE to the desired network partition; click Add Undiscovered NEs to add 
the NEs to a network partition.

Note This option is available only for CTC-based NEs.

Overall Logging for the Instance Enable—Click the Enable radio button to enable logging. When you click the Enable 
radio button, the debug modules in the Available list become selectable.

Disable—Click the Disable radio button to disable logging. When you click the 
Disable radio button, the debug modules in the Available list become dimmed and you 
cannot make any selections from the Available list.

Managed NEs

Filter button Click the Filter button to filter the data displayed in the table.

NE ID Displays the ID name of the selected NE.

IP Address Displays the IP address of the selected NE.

NE State Displays the state of the selected NE.

Communication State Displays the current connectivity state between Prime Optical and the selected NE. 
Values are Available or Unavailable.

Subnet ID Displays the name of the subnetwork associated with the selected NE.

Debug Option Displays whether the debug option is enabled or disabled for the selected NE.

Table 4-30 Field Descriptions for the NE Service Instance Pane (continued)

Field Description
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– ONS 15305/ONS 15305 CTC

– ONS 15310 CL/ONS15310 MA/ONS 15327/ONS 15454

– ONS 15310 MA SDH/ONS 15454 SDH

– ONS 15600

– ONS 15600 SDH

Step 3 Click Network Service Instance or PM Service Instance.

Step 4 Select one or more managed NEs from the Managed NEs table.

Step 5 Click the Debug Table button. The Prime Optical NE Module Level Debug table opens. The following 
table provides descriptions.

   

4.5.4.2 Configuring the NE Logging Options

The Network Element Logging Options dialog box allows you to modify the debug state for selected 
NEs.

Step 1 In the Domain Explorer window, choose Administration > Control Panel.

Step 2 In the Control Panel window, expand NE Service.

Step 3 Expand CTC-Based SONET NEs or CTC-Based SDH NEs and click Network Service Instance. 

Step 4 Select one or more managed NEs from the managed NEs table.

Step 5 Click the Debug Table button. The Prime Optical NE Module Level Debug table opens.

Step 6 Click the Open Debug Dialog tool to open the Network Element Logging Options dialog box. The 
following table provides descriptions.

Step 7 Click Save to save the NE logging options.

Table 4-31 Field Descriptions for the Prime Optical NE Module Level Debug Table

Field Description

NE ID Displays the ID name of the selected NE.

Debug State Displays the debug state (enabled or disabled).

Debug Modules Displays a list of debug modules active on the selected node.

Table 4-32 Field Descriptions for the Network Element Logging Options Dialog Box

Field Description

Overall Logging

Enable Choose the Enable radio button to enable logging. When you choose the Enable radio button, the 
debug modules in the Available list become selectable.
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4.5.5 Backing Up Client Files
Use the Backup File dialog box to view a list of NE configuration files that were created during routine 
backups and saved on the Prime Optical server from the NEs. You can select one or more files from the 
list and save them to a local client workstation.

Step 1 In the Domain Explorer window, choose Administration > Memory Backup Upload. The Backup File 
dialog box opens. The following table provides descriptions.

Step 2 In the Files area, select backup files from the list. To select multiple files, hold down the Ctrl key on 
your keyboard while using your mouse to click files. Click Select All to select all files in the list.

Step 3 In the Upload Location text box, specify where you want to save the backup files on the client. Click 
Browse to choose a client location different from the default.

Step 4 Click Upload to upload the selected backup files to the specified client workstation.

   

Disable Choose the Disable radio button to disable logging. When you choose the Disable radio button, the 
debug modules in the Available list become dimmed and you cannot make any selections from the 
Available list.

Apply to All NEs Check the Apply to All NEs check box to apply all the modules to the NEs selected in the 
Prime Optical NE Module Level Debug table.

Debug Modules

Available Displays the modules available for debugging.

Selected Displays the modules selected for debugging.

Table 4-32 Field Descriptions for the Network Element Logging Options Dialog Box (continued)

Field Description

Table 4-33 Field Descriptions for the Backup File Dialog Box

Field Description

Files Lists the backup files that are available on the server.

Upload Location Allows you to specify where you want to save the backup files on the client. The default location is 
Prime Optical-client-installation-directory\admin\ or 
Prime Optical-client-installation-directory/admin/. Click Browse to choose a different location.

Upload button Uploads the selected backup files to the specified client location.

Select All button Selects all of the backup files in the list.

Cancel button Replaces any changes to user-defined fields with the previous values and closes the dialog box.

Help button Launches the online help for the Backup File dialog box.
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4.5.6 Restoring Server Configuration Files

Step 1 Log into the server workstation as the root user.

Step 2 On the command line, enter the following commands:

cd/opt/CiscoTransportManagerServer/bin
./restore_config.sh backup-file-location log-directory ISHA

Note The ISHA value is 0.

   

4.5.7 Configuring Nodes for Database Restore—ONS 15600
Use the Configure Node dialog box to configure the selected ONS 15600 SONET or ONS 15600 SDH 
node. This feature is essentially a database restore without the check for a matching node ID, software 
version, and IP address. Additionally, you can specify that a new IP address overrides the IP address in 
the database. When the node reboots after the database has been downloaded, it uses the new IP address 
you specified. Only the provisioning database is restored from the ONS 15600 database file, which can 
contain provisioning, alarm, PM, and audit databases.

Step 1 In the Domain Explorer tree, select an ONS 15600 SONET or ONS 15600 SDH NE that is assigned an 
In Service or Under Maintenance operational state. You cannot configure nodes for preprovisioned or 
out-of-service NEs.

Step 2 Choose Configuration > CTC-Based SONET NEs or CTC-Based SDH NEs > Configure Node. The 
Configure Node dialog box opens. The following table provides descriptions.

Step 3 Enter the following information:

• NE model

• Selected NE

• Source

• Job comments

• Time 

Step 4 Click Next.

Step 5 Verify the configuration. If necessary, change the IP address with which the new node will be configured.

Step 6 Click Finish.

To view the results of the node configuration, check the Job Monitor table (Administration > Job 
Monitor).
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4.5.8 Managing Protection Groups
A protection group allows you to group modules together, so that if one module goes down for some 
reason, the other modules will be protected and will not go down as well. The following sections describe 
how to create, enable, edit, and delete protection groups.

4.5.8.1 Creating Protection Groups

Step 1 Select a CTC-based NE and choose Configuration > NE Explorer.

Step 2 In the NE Explorer window, click the Protection tab.

Step 3 In the Protection Groups subtab, click Create. The Create Protection Group dialog box opens. 
Table 4-35 provides descriptions. Fields shown depend on the type of NE that is selected.

Step 4 Specify the following information:

• Name

Table 4-34 Field Descriptions for the Configure Node Dialog Box

Field Description

NE Model Select the NE type that you want to configure. The type you select determines the NEs that are 
displayed in the Network Elements field.

Note You can only select ONS 15600 SONET or ONS 15600 SDH.

Network Elements Use the Add and Remove buttons to move the NE that you want to configure to the Selected NE 
list. You can run the node configuration procedure for only one NE at a time.

Source Specify the location of the backup file that you want to use to configure the NE:

• Click Local to browse to a local client directory for the backup file.

• Click Server to configure the file from the Prime Optical server. The files shown are in the 
directory /opt/CiscoTransportManagerServer/admin/NE-system-ID. The Server radio button 
is not active unless a file exists in that directory.

Note The Remote options are disabled and do not apply.

Job Comments Enter comments about the node configuration procedure, if needed.

Time (time zone) Set a time for the node configuration. Click Now to begin node configuration immediately, or click 
At Time and specify when to begin node configuration, in 5-minute increments.

Note The time zone can be GMT, a user-defined offset from GMT, or local time, depending on 
what is specified in the User Preferences dialog box.

Current Node 
Configuration

Display only. Displays the NE software version and IP address of the current node.

Memory Configuration Display only. Displays the NE software version and IP address in the database file provided for 
configuring the node. The check box shows that only provisioning data will be considered for 
restoration.

New Node 
Configuration

Displays the NE software version and IP address with which the new node will be configured. By 
default, the IP address is the same as that of the current node. You can modify the IP address.
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• Type

• Protect module

Caution If you are using Prime Optical GateWay/CORBA, make sure that you do not create multiple 
protection groups with the same name. Prime Optical GateWay/CORBA cannot distinguish 
between multiple protection groups with the same name while executing a delete protection 
group command or a perform protection switch command.

Note 1:N protection is not supported for the ONS 15327.

The Layer 2 1+1 protection group is created only between client ports on GE_XP or 
10GE_XP cards (in L2 over DWDM mode), and only if Layer 2 trunk-to-trunk internal 
patchcords are created between the cards’ trunk ports.

Based on these selections, a list of available working cards or ports is displayed.

Step 5 From the Available Entities list, choose the card or port that will be the working card or port. Click the 
arrow button to move each card or port to the Working Entities list.

Step 6 Complete the remaining information:

• Bidirectional switching

• Revertive

• Reversion time

• Recovery guard time

• Verification guard time

• Detection guard time

Step 7 Click OK.

Caution Before running traffic on a protected card within a protection group, enable the ports of all 
protection group cards.

Note After creating a protection group on DS3XM-6 cards, wait for 2 minutes while Prime Optical 
receives updates for all of the ports supported by the DS3XM-6 cards. The protection group is 
not visible in Prime Optical until the 2-minute update period is complete.

Note The ONS 15600 SONET must have cards carrying live traffic in order to switch protection. Even 
a forced switch will be overridden by a failed signal. You cannot perform manual and forced 
switches on an ONS 15600 using preprovisioned cards. If you try to perform a switch using 
preprovisioned cards, the NE returns an error, and the protection operation does not switch from 
Active to Protect. An APS_CLEAR is generated, which can be cleared.
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4.5.8.2 Enabling Ports of Protection Group Cards

Step 1 Select a CTC-based NE and choose Configuration > NE Explorer.

Step 2 In the tree view of the NE Explorer window, select the card.

Step 3 In the card slot properties pane, click the Line tab.

Step 4 In the Line Config subtab, under the Admin State column, select IS (in service).

Table 4-35 Field Descriptions for the Create Protection Group Dialog Box

Field Description

Name Enter a name for the protection group. The name can have up to 32 alphanumeric characters.

Note You cannot set the protection group name for ONS 15305 CTC protection groups.

Type Choose the protection type from the drop-down list:

• 1:1 (card)

• 1:N (card)

• Y Cable (port)

• 1+1 (port)

• 1+1 Optimized (port)

• Layer 2 1+1

The protection selected determines the cards that are available to serve as protect and working 
cards. For example, if you choose 1:N protection, only DS-1N-14 and DS-3N-12E cards are 
displayed. If you choose Layer 2 1+1, only the 10GE_XP and GE_XP cards are displayed.

Protect Module Choose the protect module if using 1:1, 1:N, or Layer 2 1+1.

Available Entities Displays a list of available entities. You can toggle between available and working entities.

Working Entities Displays a list of working entities. You can toggle between working and available entities.

Bidirectional 
Switching

(Optical cards only) If checked, both the transmit and the receive channels switch if a failure occurs 
on one. This option is only available if you select 1+1 (port) type.

Revertive If checked, the node reverts traffic to the working card or port after failure conditions remain 
corrected for the amount of time entered in the Reversion Time field. This option is not available 
if the 1:N (card) type has been selected.

Reversion Time If Revertive is checked, choose the amount of time following failure condition correction that the 
node should switch back to the working card or port. Values are listed in half-minute increments.

Recovery Guard Time Prevents rapid switches due to signal degrade (SD) or signal failure (SF) conditions. After the SD 
or SF condition is cleared on a facility protected by Optimized 1+1 protection, no switches are 
performed for the duration of the recovery guard timer. 

Verification Guard 
Time

Specifies the amount of time that a user command has to complete. If a user command cannot be 
completed within the duration set by the verification guard timer, the command is cleared and an 
APS_CLEAR event is sent.

Detection Guard Time Specifies the amount of time after a failure that the system has to complete a switch. After detecting 
an SD, SF, loss of signal (LOS), loss of frame (LOF), or alarm indication signal line (AISL) failure, 
the detection guard timer is started. If the detection guard timer is set to zero, the system completes 
a switch within 60 ms for failure events.
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Step 5 Click Apply.

4.5.8.3 Editing Protection Groups

Step 1 Select a CTC-based NE and choose Configuration > NE Explorer.

Step 2 In the node properties pane, click the Protection tab > Protection Groups subtab.

Step 3 In the Protection Groups area, choose a protection group.

Step 4 In the Selected Protection Group area, edit the fields as appropriate.

Step 5 In the Protection tab, click the Operations subtab.

Step 6 In the Protection Groups area, choose a protection group.

Step 7 In the Protection Group Details area, select a protection group port; then, choose from among the 
following:

• Clear—Clears a traffic switch on protection group port.

• Manual—Initiates a manual switch on the selected port. This command switches traffic only if the 
path has an error rate less than the signal degrade (SD) bit error rate (BER) threshold.

• Force—Initiates a forced switch on the selected port. This command switches traffic even if the path 
has SD or signal fail (SF) conditions. A Force switch has a higher priority than a Manual switch.

• Unlock—Unlocks the protection group. This button is enabled only after you click the Lock Out 
button.

• Lock Out—For NE software release 8.5 and later, this button sends the lockout command to the ports 
of the protection group. There are two types of lockout commands:

– Lockout of protection—If you select the Protect/Standby port of an unlocked protection group, 
the LOCKOUT OF PROTECTION command is sent to CTC. This prevents the Working/Active 
port from automatically switching to the protected state. This command also prevents events 
that force the Protect/Standby port to switch.

– Lockout of working—If you select the Working/Active port of an unlocked protection group, 
the LOCKOUT OF WORKING command is sent to CTC. This prevents the Protect/Standby 
port from automatically switching to the working state. This command also prevents events that 
force the Working/Active port to switch.

• Lock On—For NE software release 8.5 and later, this button is dimmed and not used.

Step 8 In the confirmation dialog box, click OK.

Step 9 Click Apply.

4.5.8.4 Deleting Protection Groups

Step 1 Select a CTC-based NE and choose Configuration > NE Explorer.

Step 2 In the node properties pane, click the Protection tab.

Step 3 In the Operations subtab, make sure that the protect card is in standby mode and the working card is in 
active mode. If the protect card is still active, do not continue. 
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Step 4 In the Protection Groups subtab, select the protection group.

Step 5 Click Delete.

Step 6 In the confirmation dialog box, click OK.

   

4.5.9 Restoring NE Defaults
The NE Defaults Management wizard allows you to choose an NE from which an NE defaults file can 
be loaded. Alternatively, you can load the file from your local (client) disk. The wizard then provides 
you a list of NEs where you can download the file. When you click Finish, Prime Optical schedules a 
job for this action. The NE defaults file downloaded to each selected NE is tracked as a separate task on 
the Job Monitor table.

Note • If you are applying NE defaults from one NE to another, the NE versions must be identical. For 
example, you cannot apply NE defaults from an ONS 15454 SONET R7.5 to an ONS 15454 SONET 
R8.5.

• This feature is available for R3.4 NEs and later.

If you want to revert back to the default settings for an NE, you can download and apply a defaults 
override file to one or more selected NEs, as follows:

Step 1 In the Domain Explorer window, choose Configuration > CTC-Based SONET NEs or CTC-Based 
SDH NEs > NE Defaults Management. The NE Defaults Management wizard opens. The following 
table provides descriptions.

Step 2 Choose an NE from which a defaults override file can be loaded. The following options are available:

• From NE

• From File

Step 3 Click Next. A display-only list of NE defaults is shown.

Step 4 Click Next.

Step 5 Select the NE(s) to which you want to download the default-override file. The following options are 
available:

• Save to NE

• Save to File

Step 6 Click Finish.
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4.6 How Do I Monitor the Network?
Follow the procedures in this section to manage scheduled tasks, view NE discrepancies, and monitor 
client and server configuration details.

4.6.1 Monitoring Scheduled Tasks
The Job Monitor table provides information about scheduled administrative tasks—memory backup, 
memory restore, and software download. For example, you can see the system username of the person 
who entered a specific task, the time when the task began, and the time when the task ended.

Note A job consists of multiple tasks.

Table 4-36 Field Descriptions for the NE Defaults Management WIzard

Field Description

Select an NE to View the Defaults 

From NE Select From NE if the NE defaults file is on an NE. If you select From NE, the From File options are 
dimmed.

Select NE Select the NE where the NE defaults file exists.

From File Select From File if the NE defaults file is on your client workstation or a server. If you select From File, 
the From NE options are dimmed.

Local Select Local if the file is on your local client workstation. Enter the path for the file, or click Browse to 
search for it.

Server Select Server if the file is located on a server. Use the drop-down list to select a server.

NE Defaults

Display only. Use this screen to view the selected NE defaults.

Save the NE Defaults

Save to NE(s) To save the defaults to one or more NEs, select Save to NE(s). If you select Save to NE(s), the Save to 
File options are dimmed.

Available NE(s) Select one or more NEs in the Available NE(s) field and click Add to move them to the Selected NE(s) 
field.

Selected NE(s) Select one or more NEs in the Selected NE(s) field and click Remove to move them to the Available 
NE(s) field.

Save to File To save the defaults to a file on your client workstation or a server, select Save to File. If you select Save 
to File, the Save to NE(s) options are dimmed.

Local Select Local to save the file on your local client workstation. Enter the path for the file, or click Browse 
to search for it.

Server Select Server to save the file on a server. Enter a server path in the field.
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The Job Monitor table also monitors bulk operations: adding multiple users to multiple NEs, modifying 
a user on multiple NEs, and deleting multiple users on multiple NEs. (See 8.4.3 Managing NE User 
Access, page 8-48 for more information about bulk operations.) When a request is made to the 
Prime Optical server to add, modify, or delete NE users, multiple entries are made in the Job Monitor 
table. Each entry consists of the following:

• Task Owner—User ID used during login.

• NE ID—NE ID on which the operation is executed.

• Task Creation Time—Server time when the request was made.

After these requests are executed, the job’s status is updated accordingly in the Job Monitor table.

Note Sometimes, when a node is busy, a job request may fail. In such a scenario, Prime Optical automatically 
creates a new similar job and resends the request using the job retry functionality. The new job is 
triggered anytime within the first 10 minutes of detection of the failure. Prime Optical attempts to resend 
the request a maximum of five times. Rescheduled jobs can be monitored in the Job Monitor table.

Another task that is monitored is the BLSR/MS-SPRing switch scheduling. (See 7.3.7 Switching 
BLSRs, page 7-196 or 7.4.9 Switching MS-SPRings, page 7-207.) When the switch ring is scheduled, 
two tasks are created: the BLSR/MS-SPRing switch job in the west port and the BLSR/MS-SPRing 
switch job in the east port. The schedule time difference between these two tasks is specified in the 
Control Panel. (See 7.4.10 Changing the MS-SPRing Switch Interval, page 7-208.)

If you schedule a BLSR/MS-SPRing switch successfully, the corresponding task and its status are 
monitored in the Job Monitor table. If more than one BLSR switch is scheduled at a certain time on the 
same ring, only one BLSR switch will be successfully completed. Tasks are marked Succeeded when the 
switch command is accepted by the NE. If the switch fails due to the unavailability of the NE or if the 
switch command is rejected by the NE, an alarm is reported in the Alarm Browser and is cleared on the 
next successful switch or when the cross-connect is reset.

   

4.6.1.1 Viewing the Job Monitor Table

To view the Job Monitor table, choose Administration > Job Monitor in the Domain Explorer window. 
The following table provides descriptions.

Note Some fields in the Job Monitor table apply only to certain tasks, NEs, or NE versions.

Table 4-37 Field Descriptions for the Job Monitor Table

Field Description

Job ID ID number corresponding to the selected job.

Task ID ID number corresponding to the task. If a job includes more than one NE, each NE has a separate 
task ID for the job.

Task Type Type of task. Tasks include adding users, applying alarm profiles, creating BLSR/MS-SPRings, 
configuring nodes, creating alarm profiles, deleting users, logging out users, automatically 
backing up memory, manually backing up memory, restoring memory, modifying users, setting up 
SNTP, setting NE defaults, setting security advisory messages, activating software, downloading 
software, reverting software, and cloning ML cards.
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4.6.1.2 Viewing the Job Monitor Filter Dialog Box

Use the Job Monitor Filter dialog box to filter job data according to criteria that you select and to display 
the results in the Job Monitor table. The following table provides descriptions.

Task Owner System username of the person who entered the task.

Alias ID Alias name of the NE.

Task Status Current status of the task:

• Queued—The task is scheduled but has not yet begun.

• Running—The task is in progress.

• Canceled—The task has been canceled. 

• Succeeded—The task succeeded.

• Failed—The task failed.

• Waiting—The node manager must be initialized before a task can begin. If the node manager 
is not initialized, the status of the task is Waiting. After the node manager becomes initialized, 
the task status changes to Queued.

Note A job can be canceled only when its task status is either Queued or Waiting.

Task Creation Time Date and time when the task was entered into the system.

Task Scheduled Time Date and time when the task is scheduled to begin.

Task Start Time Date and time when the task began.

Task End Time Date and time when the task ended.

Display Information Information related to the Task Type column.

Note Any user-entered comments relating to the task.

Additional Information Any additional information.

NE ID Name of the NE on which the task is scheduled to run.

Table 4-37 Field Descriptions for the Job Monitor Table (continued)

Field Description
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4.6.1.3 Canceling a Scheduled Job or Task

Step 1 In the Domain Explorer window, choose Administration > Job Monitor.

Step 2 Select a task to cancel; then, choose Edit > Cancel Task or Cancel Job (or click the Cancel Task or 
Cancel Job tools).

Table 4-38 Field Descriptions for the Job Monitor Filter Dialog Box

Tab Description

Creation Time 
(time zone)

Allows you to filter job monitor data for a specified time period, ranging from the past hour to the past 
180 days. Additionally, you can click the User Specified radio button to specify exact filter start and end 
times by date and hour. The time zone can be GMT, a user-defined offset from GMT, or local time, 
depending on what is specified in the User Preferences dialog box. Click No Time Specified if you want 
to filter events and the time period is not important.

Use the calendar tool to choose the year, month, and day:

• Year—Click the year combo box or the double arrow (<<, >>) at the bottom of the calendar.

• Month—Click the month combo box or the single arrow (<, >) at the bottom of the calendar.

• Day—Click the day number on the calendar. The current date is shown in blue.

NE ID Allows you to move NEs back and forth between the list of available NE IDs and selected NE IDs. The 
filter runs on the NEs in the Selected NE ID list.

Task Owner Allows you to move owners back and forth between the list of available owners and selected owners. The 
filter runs on the owners in the Selected Task Owner list.

Job/Task ID Allows you to filter jobs by job and task IDs. Jobs consist of multiple tasks. For example, if you perform 
a memory backup for multiple NEs, the backup operation is a job, and each NE is a task.

• If you specify a start and end ID range in the Job ID field but leave the Task ID field blank, the filter 
runs on the job ID range.

• If you specify a start and end ID range in the Task ID field but leave the Job ID field blank, the filter 
runs on the task ID range.

• If you specify a start and end ID range in both the Job ID and Task ID fields, the filter first applies 
the values in the Job ID field, then narrows the filter according to the values in the Task ID field. For 
example, if you specify that Job ID Start = 1, Job ID End = 3, Task ID Start = 1, and Task ID End = 2, 
the returned value is all entries with a Job ID of 1, 2, or 3 and a Task ID of 1 or 2.

Task Type Allows you to move task types back and forth between the list of available task types and selected task 
types. The filter runs on the tasks in the Selected Task Types list.

Task Status Allows you to filter tasks by status:

• Queued—The task is scheduled but has not yet begun.

• Running—The task is in progress.

• Canceled—The task has been canceled.

• Failed—The task failed.

• Succeeded—The task succeeded.

• Waiting—The node manager must be initialized before a task can begin. If the node manager is not 
initialized, the status of the task is Waiting. After the node manager becomes initialized, the task 
status changes to Queued.
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Note Cancel is enabled only for jobs and tasks with a Queued status. When a job contains more than 
one task in a Queued status, choosing Cancel Job cancels all tasks with the same job ID.

Step 3 Click OK in the confirmation dialog box.

   

4.6.1.4 Adding Job Monitor Notes

The Job Monitor Note dialog box allows you to view and add notes to jobs displayed in the Job Monitor 
table. If a job has a note, a Job Monitor Note tool appears under the User Comments column.

Step 1 In the Domain Explorer window, choose Administration > Job Monitor.

Step 2 Select a task and choose Edit > User Note. The following table describes the fields in the Job Monitor 
Note dialog box.

Comments are visible to all users.

   

4.6.2 Monitoring Service Status
The Service Monitor table shows the status of the services that are running on the Prime Optical server. 
To view the Service Monitor table, choose Administration > Service Monitor in the Domain Explorer 
window. The following table provides descriptions.

Table 4-39 Field Descriptions for the Job Monitor Note Dialog Box

Field Description

Note Provides space for you to type your comments about the selected job. The maximum length of this field is 
2048 characters. To add comments to the previous comments, click the Append radio button. To overwrite 
the previous comments, click Replace. To delete the comments, click Delete.

History Displays comments entered by previous users.

Table 4-40 Field Descriptions for the Service Monitor Table

Field Description

Service Name Displays the name of the selected service.

Logged In At Displays the last time the service logged into the main Prime Optical server 
process.

IP Address Displays the IP address of the selected service.

Session ID Displays the unique session ID.
4-91
Cisco Prime Optical 9.6 User Guide

OL-27078-01



Chapter 4      Maintaining an Efficient Network
How Do I Monitor the Network?
Note The opticalctl status command shows the processes that are running on the Prime Optical server. 
Because some of these processes implement Prime Optical services, the opticalctl status command is 
an alternate way of viewing services that are running on the Prime Optical server. The command also 
shows processes—such as the Apache web server—that are not Prime Optical services. Do not run 
multiple opticalctl status commands concurrently.

   

4.6.3 Monitoring Service Availability
You can view current and historical information about NE and PM services.

• The Service Availability table allows you to monitor the status of currently active services. See 
4.6.3.1 Viewing the Service Availability Table, page 4-92.

• The Service Uptime Log allows you to view historical uptime data for services that were previously 
activated, but are currently deactivated. See 4.6.3.2 Viewing the Service Availability Log, 
page 4-93.

4.6.3.1 Viewing the Service Availability Table

The Service Availability table shows the services that are connected to the SM service, which is a process 
internal to the Prime Optical server. The Service Availability table differs from the Service Monitor table 
in that the Service Availability table does not show the SM service itself, whereas the Service Monitor 
table shows the SM service. Another difference is that Service Availability table displays and monitors 
service uptime, whereas the Service Monitor table shows only those services that are currently running.

To view the Service Availability table, choose Administration > Service Uptime in the Domain 
Explorer window. (See Table 4-41 for field descriptions.) The following events trigger an update to the 
Service Availability table:

• A service instance is started—For NE services, this occurs when you use the Add New NE wizard 
to add a new NE, and then you activate the corresponding NE service in the Control Panel. For PM 
services, this occurs when you activate a PM service in the Control Panel.

• A service instance is stopped—For NE services, this occurs when you deactivate an NE service in 
the Control Panel, or when there are no NEs added to that NE service in the Control Panel. For PM 
services, this occurs when you deactivate a PM service in the Control Panel.

• A service instance crashes—This occurs when a service stops running but is still active.

• A service instance is restarted after a crash.

If the Prime Optical server is shut down with the opticalctl stop or opticalctl abort command, all of the 
services are stopped. All service instances that were running when the Prime Optical server was shut 
down are marked as stopped and moved to the Service Uptime Log. When the Prime Optical server 
restarts, the new service instances are added to the Service Availability table.
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4.6.3.2 Viewing the Service Availability Log

The SM service sends an event to the Prime Optical client whenever a service instance is stopped. The 
Service Availability Log table refreshes to show a new row for each stopped service.

To view the Service Availability Log table, choose Administration > Service Uptime Log in the 
Domain Explorer window. The following table provides descriptions.

   

Table 4-41 Field Descriptions for the Service Availability Table

Field Description

Service Name Name of the service instance.

Status Current status of the service. Values are:

• Running—The service is running.

• Not Running—The service is not running.

Started At Date and time when the service was started.

Last Crash Date and time when the most recent service crash occurred. If the service has not crashed, this field 
displays a value of N/A.

Uptime Amount of time that has elapsed since the most recent startup; or, if the service has not crashed, shows 
the amount of time that has elapsed since the service was started.

Total Time Sum of all uptimes since the service was started.

Uptime Percentage Percentage of time during which the service has been up. This value is the ratio between the total 
uptime and the amount of time that has elapsed since the service was started.

Table 4-42 Field Descriptions for the Service Availability Log Table

Field Description

Service Name Name of the stopped service instance.

Started At Date and time when the service was started.

Stopped At Date and time when the service was stopped.

Status Current status of the service. The value is always Not Active, meaning the service has been stopped 
in the Control Panel, or, for NE services, no NEs of that type have been added to the Domain Explorer.

Last Crash Amount of time that has elapsed since the most recent crash.

Total Uptime Sum of all uptimes before the service was stopped.

Uptime Percentage Percentage of time during which the service was up before it was stopped.
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4.6.4 Viewing the NE Discrepancy Table
The NE Discrepancy table shows all ONS 155xx misconfigurations detected by Prime Optical.

Step 1 In the Domain Explorer or Subnetwork Explorer tree, select the ONS 155xx NE, group, or subnetwork 
for which to view misconfiguration data.

Step 2 Choose Configuration > ONS 155XX > NE Discrepancy Table. The NE Discrepancy table opens. The 
following table provides descriptions.

   

4.6.5 Monitoring Prime Optical Client and Server Configuration Details
The Prime Optical Properties pane in the Control Panel window displays information about the 
Prime Optical server and client configuration.

Table 4-43 Field Descriptions for the NE Discrepancy Table

Field Description

Name Type of discrepancy:

• Wavelength Mismatch—Wavelengths cannot be added to a MUX/DEMUX card while the same 
wavelengths that were added by another MUX/DEMUX card on the network are passing through 
this MUX/DEMUX card passively.

• Protection Mode Mismatch—The protection mode is configured differently at each end of a 
circuit or connection.

• Protocol Mismatch—The protocol type is misconfigured at the ends of a circuit or connection.

• Link Mismatch—A link has been configured to connect more than one device to the same port 
on a third device.

Description Description of the discrepancy.

Perceived Severity Severity level of the discrepancy:

• CR—Critical

• MJ—Major

• MN—Minor

• WN—Warning

Time Stamp Date and time when the discrepancy was discovered.

Node 1 The first ONS 155xx involved in the discrepancy.

Node 2 The other ONS 155xx involved in the discrepancy. Discrepancies usually involve two devices.

Details Details on the discrepancy, including its cause. If the text extends beyond the width of the field, use 
the pull-down arrow to the right of the field to read the remaining text. Alternatively, choose File > 
Show Discrepancy Details to read the full text.
4-94
Cisco Prime Optical 9.6 User Guide

OL-27078-01



Chapter 4      Maintaining an Efficient Network
How Do I Monitor the Network?
Step 1 In the Domain Explorer window, choose Administration > Control Panel.

Step 2 In the Control Panel window, click Cisco Prime Optical to open the Prime Optical Properties pane. The 
following table provides descriptions.

   

4.6.6 Viewing the Prime Optical Server and Client Version
You can view the Prime Optical server and client version in the Control Panel and in the About Cisco 
Prime Optical dialog box. You can also view the server version in the Management Domain Properties 
pane.

Step 1 To view the Prime Optical server and client version in the Control Panel, complete the following 
substeps:

a. In the Domain Explorer window, choose Administration > Control Panel.

b. In the Control Panel window, click Cisco Prime Optical to open the Prime Optical Properties pane.

c. Click the Server Configuration tab. The Prime Optical server version is shown in the Software 
Version field.

d. Click the Client Configuration tab. The Prime Optical client version is shown in the Version field.

Table 4-44 Field Descriptions for the Cisco Prime Optical Properties Pane

Field Description

Server Configuration Tab

Server Name Workstation name where the Prime Optical server application resides.

IP Address IP address of the Prime Optical server.

Software Version Prime Optical software version that is running.

Server Size Size of the Prime Optical server installation. Values are small, medium, large, or high 
end.

Port Information Area

Server JMOCO Port JMOCO port number of the Prime Optical server. The Active field displays the current 
port; the Activated After Restart field displays the port that is active after the server is 
rebooted.

Service Manager IIOP Port Service manager port number.

Client Configuration Tab

Hostname Workstation name where the Prime Optical client application resides.

IP Address IP address of the Prime Optical client.

Version Prime Optical software version that is running.

Username Name that was used to log into the Prime Optical client.

Client Size Size of the network configuration where the Prime Optical client is installed. Values are 
small, medium, large, or high end.
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Step 2 To view the Prime Optical server and client version in the About dialog box, choose Help > About Cisco 
Prime Optical in any window.

Step 3 To view the Prime Optical server version in the Management Domain Properties pane, complete the 
following substeps:

a. In the Domain Explorer tree, click the management domain node to open the Management Domain 
Properties pane.

b. Click the Identification tab. The Prime Optical server version is shown in the Software Version 
field.

4.7 How Do I Manage CTC Operations?
CTC is the software interface that provides provisioning and administrative functionality for the 
following NEs:

• ONS 15305 R3.0

• ONS 15310 CL

• ONS 15310 MA SONET

• ONS 15310 MA SDH

• ONS 15327

• ONS 15454 SONET

• ONS 15454 SDH

• ONS 15600 SONET

• ONS 15600 SDH

4.7.1 Functionality Provided in CTC that Is Not Available in Prime Optical
The following table lists the CTC functions that are not supported in Prime Optical through generic 
Prime Optical features (such as PM, software download, or memory backup) or through the native NE 
Explorer (equipment provisioning) for CTC-based NEs. The table provides a brief description of each 
function and a reference to the location within CTC where the function is provided.

Table 4-45 CTC Functions that Are Not Supported in Prime Optical

CTC Function CTC Reference

Network Level

Prime Optical does not support management of overhead circuits. Network View > Provisioning > Overhead Circuits

Node Level

Prime Optical does not support access to the EtherBridge MAC 
table (and related operations) or trunk utilization.

Node View > Maintenance > EtherBridge > MAC table

Node View > Maintenance > EtherBridge > Trunk 
Utilization

Prime Optical does not support management of Unified Control 
Plane (UCP) parameters.

Node View > Provisioning > UCP
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4.7.2 Specifying CTC Partitions for CTC-Based NEs
CTC-based NEs that are added to the Prime Optical domain to access other CTC-based NEs are called 
GNEs, or topology hosts. When starting CTC for a particular CTC-based NE, the GNE for that NE is 
specified in CTC. CTC can take more than one GNE as input and discover the nodes behind those GNEs.

In a stable network, if CTC is started with a particular set of GNEs, the CTC view looks the same every 
time it is started with that set of GNEs. Prime Optical tries to copy this behavior when starting CTC for 
a given NE.

The Prime Optical client smart-link feature maintains an association between the CTC instance and the 
list of CTC-based NEs that it can manage. You can navigate through NEs within the same CTC partition 
without relaunching CTC. This feature conserves memory resources and ensures a fast response time.

Prime Optical does not support retrieval of the diagnostics file or 
operation of the lamp test.

Node View > Maintenance > Diagnostics

Prime Optical does not support test access. Node View > Maintenance > Test Access

Prime Optical does not support a Routing Information Protocol 
(RIP) table for BLSRs.

Node View > BLSR > RIP Table

Card Level

Prime Optical does not support the ability to clear or reset PM 
register statistics on the NE.

Card View > Performance

Prime Optical does not support the ability to provision the user data 
channels (UDCs) or line DCC, or perform virtual wire maintenance 
operations.

AIC Card View > Maintenance > Virtual Wires

AIC Card View > Maintenance > Overhead 
Termination

Prime Optical does not support the ability to upgrade automatically 
the OC-n cards and spans.

Network View > Span Upgrade

Prime Optical does not support the ability to provision passive 
cards.

Node View > Provisioning > WDM-ANS > Passive 
Cards

Prime Optical does not support the ability to provision any objects 
in the Rack View.

—

Circuit Management

Prime Optical does not support the ability to create TL1-like 
cross-connections. Prime Optical does not support specification of 
the interdomain SLA.

Circuit Creation wizard

Prime Optical does not support the ability to edit path selector 
attributes of an existing circuit.

Tools > Circuits > Set Path Selector Attributes

Prime Optical does not support the ability to provision internal 
patchcords that include passive cards.

Node View > Provisioning > WDM-ANS > Internal 
Patchcords

Prime Optical does not support the Spanning Tree Map for E-series 
Ethernet cards.

—

Prime Optical does not support in-service topology upgrades. Tools > Topology Upgrade > Convert UPSR to BLSR

Tools > Topology Upgrade > Convert Unprotected to 
BLSR

Table 4-45 CTC Functions that Are Not Supported in Prime Optical (continued)

CTC Function CTC Reference
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If you launch and exit one instance of CTC and then launch a second CTC instance from the same 
partition, the second CTC launch goes through a 1-minute timeout period to ensure that the previous 
instance has exited. The 1-minute timeout occurs even if you launched and exited the previous CTC 
instance for a different NE. After the timeout, CTC initializes and a new window is launched. There is 
a delay of 10 to 20 seconds while the CTC launch initializes.

Caution ONS 15454 SONET and ONS 15454 SDH NEs propagate VLANs whenever a node appears in the same 
network view as another node, regardless of whether or not the nodes are DCC-connected. When there 
is more than one CTC management domain in Prime Optical, nodes that are not connected through DCC 
often appear in the same CTC view that is launched for that domain. The ONS 15454 NEs propagate 
VLAN information to these DCC-disconnected nodes. To prevent VLAN propagation, make sure that 
DCC-disconnected nodes do not appear in the same CTC view.
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