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C H A P T E R 3

Building the Network

After you have planned your network, you can begin building the network components: groups, network 
partitions, subnetworks, NEs, links, and network maps.

This chapter contains the following sections:

• 3.1 Overview, page 3-1

• 3.2 How Do I Build Groups?, page 3-2

• 3.3 How Do I Build Network Partitions?, page 3-4

• 3.4 How Do I Build Subnetworks?, page 3-5

• 3.5 How Do I Build NEs?, page 3-7

• 3.6 How Do I Build Links?, page 3-28

• 3.7 How Do I Build Server Trails?, page 3-53

• 3.8 How Do I Use Network Maps?, page 3-55

• 3.9 How Do I Discover the Network for Optical Devices?, page 3-63

• 3.10 How Do I Manually Discover NEs and Add Them to Specific Network Partitions?

• 3.11 How Do I Test Connectivity for Optical and Routing Devices?, page 3-73

3.1 Overview
The Cisco Prime Optical management domain is the top-level root node in the Domain Explorer tree. 
The management domain contains NEs and the following network components:

• Groups—Collection of groups or collection of NEs. NEs are often grouped geographically or by 
domain. 

• Network Partitions—Logical segment of NEs (grouped in subnetworks) in which NEs of the same 
model type are managed by a single NE service.

• Subnetworks—Sets of NEs interconnected at a specific network layer (such as physical, section, 
line, and so on). Subnetworks are contained within network partitions. NEs must belong to the same 
subnetwork to create circuits between them.

• Links—Physical or logical entities (for example, a fiber) between two physical points (for example, 
ports). Circuits are provisioned through links. 

• Network Maps—Geographic representation of the NEs in the domain, the circuits and links between 
NEs, and the number of alarms associated with NEs.
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3.2 How Do I Build Groups?
NEs in the Domain Explorer are organized into groups, which consist of NEs or other groups. NEs are 
often grouped geographically or by domain. The same NE or group can be assigned to different groups. 
The following sections describe how to add, copy, move, and delete groups.

3.2.1 Adding Groups

Step 1 Select a node or group in the Domain Explorer tree.

Note You cannot add a new group to the Discovered Network Elements or Deleted Network Elements 
groups.

Step 2 Choose File > New Group (or click the Add a New Group tool). The New Group dialog box opens.

Step 3 Enter the following information in the New Group dialog box.

Step 4 Click OK. The new group appears in the Domain Explorer tree.

3.2.2 Copying Groups
You can easily create domains for multiple users in Prime Optical. Just copy the same groups in different 
domains, so that users who work different shifts can use the same group. 

Step 1 In the Domain Explorer tree, select the group to be copied.

Step 2 Choose Edit > Copy (or click the Copy tool).

Step 3 Select the group where the group will be pasted and choose Edit > Paste (or click the Paste tool). This 
pastes the group under the selected group.

Note You cannot paste a group into the Discovered Network Elements or Deleted Network Elements 
groups.

Table 3-1 Field Descriptions for the New Group Dialog Box

Field Description

Group ID Unique name for the group.

Location Name Geographic location of the group.

Description Description of the group.
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Tip The drag-and-drop feature can also be used to copy groups. Use the mouse to drag and drop the group 
to a new location.

Since they cannot see the entire domain, users with the Assign NEs property (Provisioner, Operator, and 
some custom user profiles) are not allowed to modify the topology using copy, cut, paste, or drag and 
drop. See Chapter 8, “Managing Security” for information about the Assign NEs property.

3.2.3 Moving Groups
Prime Optical provides drag-and-drop capabilities to easily move groups in the Domain Explorer tree.

Step 1 In the Domain Explorer tree, select the group to be moved.

Step 2 Use the mouse to drag and drop the selected group to a new location.

Note You cannot move groups into the Discovered Network Elements or Deleted Network Elements 
groups.

3.2.4 Deleting Groups
Prime Optical allows you to delete a single group or multiple groups.

3.2.4.1 Deleting a Single Group

Step 1 In the Domain Explorer tree, select the group to be deleted.

Step 2 You can delete either the selected instance of the group or all instances of the group:

• To remove the selected instance of the group, choose Edit > Delete; then, click Yes in the 
confirmation dialog box.

• To remove all instances of the selected group, choose Edit > Delete All; then, click Yes in the 
confirmation dialog box.

Note Before deleting the last instance of a group, the group must be empty. Move all of the NEs 
and groups that the group contains to a different group.

3.2.4.2 Deleting Multiple Groups

Step 1 In the Domain Explorer tree, select the group to be deleted. Select multiple groups by pressing the Ctrl 
key, then click each group that will be deleted.
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Step 2 You can delete either the selected instance of the groups or all instances of the groups:

• To remove the selected instance of the groups, choose Edit > Delete; then, click Yes in the 
confirmation dialog box.

• To remove all instances of the selected groups, choose Edit > Delete All; then, click Yes in the 
confirmation dialog box.

Note Before deleting the last instance of a group, the group must be empty. Move all of the NEs 
and groups that the group contains to a different group.

3.3 How Do I Build Network Partitions?
Network partitions are groups of subnetworks or groups of NEs that are managed by the same NE 
service. Different network partitions mean different NE services. You can add, modify, or delete network 
partitions in the Subnetwork Explorer window.

Note Prime Optical contains one network partition by default.

Note A single network partition should contain fewer than 500 CTC-based NEs. Multiple network partitions 
must be used if your NE counts exceed these limits or if you are managing ANSI and ETSI devices in 
the same Prime Optical domain.

Note When automatic subnetwork grouping is enabled while performing operations on a network partition, 
NE visibility might be affected. Wait for a few minutes while Prime Optical arranges the NEs and 
subnetworks in the correct network partition. For more information on automatic subnetwork grouping, 
see 3.5.6 Automatically Grouping NEs in Subnetworks, page 3-23.

3.3.1 Adding Network Partitions

Step 1 In the Domain Explorer window, choose File > Subnetwork Explorer.

Step 2 In the Subnetwork Explorer window, choose File > Add New Network Partition (or click the Add a 
New Network Partition tool). The Add New Network Partition dialog box opens.

Step 3 Enter the following information.

Table 3-2 Field Descriptions for the Add New Network Partition Dialog Box

Field Description

Network Partition ID ID of the network partition. The range is from 1 to 128 alphanumeric or 
special characters.

Description Network partition description.
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Step 4 Click OK. The new network partition appears in the Subnetwork Explorer tree.

3.3.2 Modifying Network Partitions

Step 1 In the Domain Explorer window, choose File > Subnetwork Explorer. The Subnetwork Explorer opens.

Step 2 In the Subnetwork Explorer tree, select a network partition to modify.

Step 3 In the Network Partition Properties pane, click the Identification tab.

Step 4 Modify the following information as needed.

Step 5 Click Save. 

Step 6 In the confirmation dialog box, click Yes. The modifications are visible in the Subnetwork Explorer tree 
and Network Partition Properties pane.

3.3.3 Deleting Network Partitions

Step 1 In the Domain Explorer window, choose File > Subnetwork Explorer. The Subnetwork Explorer opens.

Step 2 In the Subnetwork Explorer tree, select the network partition that you want to delete; then, choose Edit > 
Delete.

Note A network partition cannot be deleted if it is associated with any subnetwork in the domain, or 
if it is the last network partition in the domain. When the network partition is deleted, any 
running instances of the NE Service that were associated with the partition stop running.

Step 3 In the confirmation dialog box, click Yes. The network partition is removed from the Subnetwork 
Explorer tree.

3.4 How Do I Build Subnetworks?
Subnetworks are sets of NEs interconnected at a specific network layer (such as physical, section, line, 
and so on). Subnetworks are contained within network partitions. NEs must belong to the same 
subnetwork to create circuits between them.

Table 3-3 Field Descriptions for the Network Partition Properties Pane

Field Description

Network Partition ID ID of the network partition. The range is from 1 to 128 alphanumeric or 
special characters.

Description Network partition description.
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The following sections describe how to add, move, and delete subnetworks. Users with the Assign NEs 
property (Provisioner, Operator, and some custom user profiles) can see only the subnetworks of the NEs 
that are assigned to them.

Note When automatic subnetwork grouping is enabled while performing operations on a subnetwork, NE 
visibility might be affected. Wait for a few minutes while Prime Optical arranges the NEs in the correct 
subnetwork. For information on automatic subnetwork grouping, see 3.5.6 Automatically Grouping 
NEs in Subnetworks, page 3-23.

3.4.1 Adding Subnetworks

Step 1 In the Domain Explorer window, choose File > Subnetwork Explorer.

Note To open the Subnetwork Explorer, the domain must contain at least one NE. If the domain does 
not contain any NEs, the Subnetwork Explorer menu option is unavailable.

Step 2 In the Subnetwork Explorer tree, select the network partition where you will add the subnetwork and 
choose File > Add New Subnetwork (or click the Add a New Subnetwork tool). The Add New 
Subnetwork dialog box opens.

Step 3 Enter the following information in the Add New Subnetwork dialog box.

Step 4 Click OK. The new subnetwork appears in the Subnetwork Explorer tree.

Note The Add New Subnetwork feature is not available for users with the Assign NEs property (Provisioner, 
Operator, and custom user profiles) because they cannot see the entire domain.

Table 3-4 Field Descriptions for the Add New Subnetwork Dialog Box

Field Description

Subnetwork ID Unique name for the subnetwork. The name can contain up to 32 
alphanumeric or special characters.

Subnetwork Type Type of subnetwork (SONET, SDH, other, or unknown).

Subnetwork Topology Subnetwork topology.

Description Description of the subnetwork.
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3.4.2 Moving Subnetworks
A subnetwork can be moved from one network partition to another if there are no routable links among 
the NEs that belong to that subnetwork and if automatic subnetwork grouping is disabled. (For 
information about automatic subnetwork grouping, see 3.5.6 Automatically Grouping NEs in 
Subnetworks, page 3-23.)

Step 1 In the Domain Explorer window, choose File > Subnetwork Explorer.

Step 2 In the Subnetwork Explorer tree, select the subnetwork to be moved.

Step 3 Use the mouse to drag and drop the selected subnetwork to a new network partition.

3.4.3 Deleting Subnetworks

Step 1 In the Domain Explorer window, choose File > Subnetwork Explorer.

Step 2 In the Subnetwork Explorer tree, click the subnetwork that will be deleted.

Note Only an empty subnetwork can be deleted. An empty subnetwork is one that does not contain 
any NEs or deleted NEs. Trying to delete a subnetwork that contains deleted NEs will generate 
the error message: “Selected subnetwork has some deleted NEs. Prune those NEs to delete the 
subnetwork.” Before deleting the subnetwork, remove the deleted NEs from the Prime Optical 
database. For more information, see 3.5.7.4 Removing a Deleted NE, page 3-27.

Step 3 Choose Edit > Delete.

Step 4 In the confirmation dialog box, click Yes to remove the subnetwork from the tree.

3.5 How Do I Build NEs?
When you add a new NE, you select the subnetwork to which you will add it. Consequently, the NE is 
added to the network partition that contains the selected subnetwork. This allows you to create circuits 
between NEs.

You can also add a new NE without selecting a subnetwork. A new subnetwork will be created for each 
new NE.

3.5.1 Prerequisites for Adding NEs
Before adding a new NE, enable the NE service for that NE. (You can, however, add the NE even if the 
NE service is disabled.) The NE service is enabled by default, but the service is not started as a process 
unless you activate an NE for that particular service. You must also meet certain other specific 
prerequisites depending on the type of NE you are adding.
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Note There are no prerequisites for adding ONS 15327, ONS 15600 SONET, or ONS 15600 SDH NEs.

3.5.1.1 Prerequisites for Adding ONS 15216 EDFA2 and EDFA3 NEs

Before adding ONS 15216 EDFA2 and EDFA3 NEs to Prime Optical, you must do the following:

• Configure the Prime Optical SNMP community string with read-write access on the ONS 15216 
EDFA2 or EDFA3. Refer to the NE documentation for more information.

• Ensure that the Prime Optical SNMP community string value and the CommTrapEntry community 
string value on the ONS 15216 EDFA2 or EDFA3 match. To ensure that these values match, enter 
the value from the CommTrapEntry in the ONS 15216 EDFA2 or EDFA3 into the SNMP 
Community String field in the Domain Explorer.

• (For the ONS 15216 EDFA3 only) Start the FTP service. To verify that the FTP service has started, 
enter the ftp 0 command and enter the username and password specified during installation.

• (For the ONS 15216 EDFA2 only) Configure the TFTP service on the Prime Optical server to 
publish the TFTP directory and start the TFTP service. The directory to be published as a TFTP 
directory should have read-write access. 

To configure the default tftpboot directory:

Step 1 Start the TFTP service on the Prime Optical server by uncommenting the TFTP service entry from the 
/etc/inetd.conf file, and update the name of the directory to be published as a TFTP directory. For 
example:

tftp dgram udp6 wait root /usr/sbin/in.tftpd in.tftpd -s /tftpboot

Step 2 Stop and restart the inetd process.

The name of the ONS 15216 EDFA3 NE must be unique and cannot be a null value. To set the name of 
the ONS 15216 EDFA3 NE:

Step 1 Log into TL1 for that particular NE. For example, enter: 

telnet IP-address 3083

Step 2 Enter the username and password. For example, enter:

ACT-USER::username:123::password;

Step 3 Enter the following command to set the new name on the ONS 15216 EDFA3 NE:

ED-NE-GEN:::123:::NAME=new-name;

Step 4 Enter the following command to verify that the name is correct:

RTRV-NE-GEN:::123;

Step 5 Enter the following command to log out:

CANC-USER::username:123;
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Note For passive ONS 15216 NEs, there is no communication between Prime Optical and the NE itself, and 
all the information is user-defined. For example, you can add inventory information in the Domain 
Explorer and add specific information (such as a serial number) in the NE Explorer. For passive ONS 
15216 NEs with multiple slots, you can use the NE Explorer to specify the content of each slot. The 
information you define is maintained in the database and propagated to an external OSS by using 
Prime Optical GateWay/CORBA.

3.5.1.2 Prerequisites for Adding ONS 15305 NEs

Before adding ONS 15305 NEs to Prime Optical, be sure that a valid SNMP community string is set up 
on the ONS 15305 to allow performance monitoring and fault management data collection from the NE.

Note To enable you to add an ONS 15305 NE to Prime Optical, its SNMP Users table must contain the row 
0.0.0.0 public true, where public is the community string. In addition, to obtain trap events from the NE, 
the Prime Optical server IP address must be added to the NE. See the Cisco Edge Craft user 
documentation for more information.

3.5.1.2.1 Important Note About Upgrading from ONS 15305 R2.0.2, R2.0.3, or R2.0.4 to ONS 15305 R3.0

When upgrading from ONS 15305 R2.0.2, R2.0.3, or R2.04 to ONS 15305 R3.0, note the following 
constraints:

• After you upgrade the NE to ONS 15305 R3.0, you must delete the R2.0 NE (with NE model 
“ONS 15305”) from Prime Optical and add it again with the correct NE model attribute (“ONS 
15305 CTC”).

• All PM data that was collected before the upgrade will be lost.

These constraints exist because the NE service that manages the ONS 15305 R2.0.2, R2.0.3, and R2.0.4 
is different from the NE service that manages the ONS 15305 R3.0.

3.5.1.3 Prerequisites for Adding ONS 15310 CL, ONS 15310 MA SONET, ONS 15310 MA SDH, 
ONS 15454 SONET, and ONS 15454 SDH NEs

Before adding ONS 15310 CL, ONS 15310 MA SONET, ONS 15310 MA SDH, ONS 15454 SONET, 
and ONS 15454 SDH NEs with ML-series cards to Prime Optical, be sure the NEs are set up as follows:

• Because Prime Optical does not support duplicate IP addresses, be sure that your ONS network does 
not contain duplicate IP addresses before adding ONS 15310 CL, ONS 15310 MA SONET, ONS 
15310 MA SDH, ONS 15454 SONET, and ONS 15454 SDH NEs.

• A valid SNMP community string must be given when adding an NE with ML-series cards to 
resynchronize Syslog and Configuration events. Audit log messages will be added in case of a 
resynchronization failure.

Note For SNMPv3 node configuration, see 8.4.6 Managing SNMPv3—CTC-Based Release 9.6 
NEs, page 8-64.
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• A trap destination with IP address equal to the Prime Optical server IP address, UDP port 162, 
SNMP version as SNMPv2c, maximum traps per second set to 0, and SNMP community string must 
be created and must allow SNMP sets to receive traps from ML-series cards.

• The Cisco IOS startup-config file must have the snmp-server enable traps command to receive 
traps from ML-series cards.

• Whenever the user changes the trap destination for NE IP address and port=162/391 in either CTC 
or Prime Optical, NEs must be out of service to resynchronize the ML-series card events and be 
registered for traps. Change the operational state of the NE to In Service after making the changes.

• CTC SuperUser credentials (NE username and password) are required to exploit full Prime Optical 
functionalities.

• If your network contains ML cards, SNMPv1/SNMPv2c uses the following configurations on GNEs 
and ENEs for traps:

– GNE trap destination: Prime Optical server IP address

– GNE trap port: 162

– GNE community string: public

– GNE version: v1 or v2c

– ENE trap destination: GNE IP address

– ENE trap port: 391

– ENE community string: Same as on GNE

– ENE version: v1 or v2c

Note Keep the SNMP version consistent across all the GNEs/ENEs in the ring.

3.5.1.3.1 Adding a DWDM Node to an Existing Multi-Service Transport Platform (MSTP) Network

Step 1 Mark the two NEs of the DWDM span (where you want to insert the new node) as Out of Service.

Step 2 Delete all invalid DWDM links between the two NEs from Prime Optical.

Step 3 Complete the steps in the NTP-G129 Add a DWDM Node section, described in the Cisco ONS 15454 
DWDM Procedure Guide.

Step 4 Mark the two NEs as In Service. The newly added NE will be automatically discovered when the new 
links are running.

3.5.1.4 Prerequisites for Adding ONS 15530 and ONS 15540 NEs

Before adding ONS 15530 and ONS 15540 NEs to Prime Optical, verify that the NEs are set up 
correctly. You can perform most of the setup by using the NE CLI.

When adding NEs to the network, first add information to the SNMP Community String table; then, add 
one NE (in the Add New NE wizard) for each group of interconnected ONS 155xx NEs. This NE 
becomes the starting point for automatically discovering the other NEs. Immediately after you add this 
NE, the information in the SNMP Community String table is used to discover all other ONS 155xx NEs 
in the group.
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The examples given in this section are provided as examples only. Refer to the relevant hardware 
documentation for detailed command information.

3.5.1.4.1 Hostnames and IP Addresses (Required)

All NEs must be configured with unique hostnames and IP addresses.

 

3.5.1.4.2 SNMP Community Strings (Required)

NEs must be reachable through SNMP. Use the snmp-server host command to add the Prime Optical 
server to the list of SNMP trap destinations on each NE. Use the snmp-server enable traps command 
to enable trap generation for events and alarms.

Note Only SNMP version 2c traps are supported.

Each NE must have an entry in the SNMP Community String table, which is the basis for ONS 155xx 
autodiscovery and must contain valid community strings for each ONS 155xx in the network. 
Autodiscovery relies on Cisco Discovery Protocol (CDP) or on the configuring topology on the device.

There is one default entry in this table, which provides SNMP access to all ONS 155xx NEs in the 
network, provided you are using the default community strings.

You can add, modify, and delete entries in this table. All fields in an entry must be filled in; blank fields 
are not permitted.

To add entries to the SNMP Community String table:

Step 1 In the Domain Explorer window, choose Administration > ONS 155XX > 
ONS 155XX SNMP Settings Table. The SNMP Community String table opens. Table 3-5 provides 
descriptions.

Step 2 If the IP address of the NE is not already in the table, choose Edit > Add. The Add SNMP Parameters 
dialog box opens.

Note The SNMP Community String table contains a default entry for all ONS 15530 and ONS 15540 
NEs that are configured with the default community string.

Step 3 Add the IP address in the Target field; the IP addresses for all ONS 15530 and ONS 15540 NEs must be 
specified in this table. 

Step 4 Be sure that the correct community strings for each ONS 15530 and ONS 15540 are in the table under 
the Read/Write field.

Step 5 (Optional) Configure the timeout and retry values. 

Step 6 Click OK.
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Note • You can change SNMP Community String table entries at any time to match the community strings 
set on NEs. Routine community string changes take effect after the next health poll cycle or after a 
rediscovery. For information about the health poll or about discovery, see Chapter 4, “Maintaining 
an Efficient Network.”

• You can modify SNMP parameters. In the SNMP Community String table, choose Edit > Modify 
to modify the SNMP parameters in the Modify SNMP Parameters window.

• You can delete SNMP parameters. In the SNMP Community String table, choose Edit > Delete to 
delete SNMP parameters.

3.5.1.4.3 Topology Setup

Appropriate topology information must be configured on ONS 15530 and ONS 15540 NEs for automatic 
discovery of neighbors and discovery of physical links. For the ONS 15530 and ONS 15540, the 
topology can be configured in two ways: by using CDP learning or through IP using Ethernet. 

CDP neighbor information exchanged between the Optical Supervisory Channel (OSC) ports of two 
adjacent NEs, or between the wavelength division multiplexing (WDM) ports of two NEs that are 
directly connected, usually reflects the actual physical topology. CDP neighbor information can be used 
to populate the physical topology in these cases. To enable topology learning through CDP, you must 
first enable CDP on the corresponding OSC ports, and then enable topology learning via CDP. For 
example, assume that two ONS 15540 NEs are connected through the wdm0/0 port on each side, with 
OSC port Wave0 present on both sides: 

1. The cdp enable CLI command, when entered in the interface configuration mode of interface Wave0 
of both NEs, enables CDP on the two Wave0 interfaces.

2. The topology neighbor cdp proxy Wave0 CLI command, when entered in the interface 
configuration mode of interface wdm0/0 of both NEs, enables physical topology learning via CDP 
information exchanged between the Wave0 ports of the two NEs.

For NEs without OSC, manually configure the appropriate topology neighbors between all of the 
connected inter-NE links by using topology neighbor commands, as in the following examples: 

Table 3-5 Field Descriptions for the SNMP Community String Table

Field Description

Target IP address of the NE or range of NEs to which you are assigning the community strings in this entry. You 
can enter a specific IP address, wildcard characters (*) in any portion of the address, and ranges. For 
example: 

• 172.*.*.* 

• 172.20.[4-55].*

You can add a combination of general and specific entries, but the community strings are read from most 
specific to least specific. Wildcard characters cannot appear in ranges.

Read/Write Community string that allows read/write access to the NEs in the entry.

Retry Number of times the server attempts to communicate with the device before reporting that the device has 
timed out. By default, the server makes one retry. You can specify from 0 to 5 retries.

Timeout Length of time the server waits for a response from the device before performing the first retry. The Cisco 
default timeout is 15 seconds. You can specify from 0 to 60 seconds.
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• For the ONS 15530 and ONS 15540, if wdm0/0 of NE1 (IP address 1.1.1.1) is connected to wdm1/0 
of NE2 (IP address 2.2.2.2) in a point-to-point topology, add the following commands to the 
configuration for interface wdm0/0 of NE1:

topology neighbor name NE2 port name Wdm1/0
topology neighbor agent ip-address 2.2.2.2

Add the following topology commands to the configuration for interface wdm1/0 of NE2:

topology neighbor name NE1 port name Wdm0/0
topology neighbor agent ip-address 1.1.1.1

3.5.1.4.4 Patch Setup

Optical patches must be set up on all NEs between through interfaces, WDM interfaces, and so on.

For NEs with OSC, additional configuration is required. Add patches between the Wave and OSC filter 
interfaces. For example, if the Wave 0 interface is connected physically to the OSC filter 0/0 interface, 
add a patch using the following command:

patch Wave 0 Oscfilter 0/0

3.5.1.4.5 Performance Monitoring (Optional)

Performance monitoring is optional, but you must enable it if you want to monitor threshold alarms and 
performance parameters.

You can enable performance monitoring by using the device CLI. For information about using the CLI, 
see the relevant hardware documentation.

 

3.5.1.5 Prerequisites for Adding CPT 200 and CPT 600 NEs

If a CPT 200 or CPT 600 NE is connected to an ONS 15454 NE, the CPT NE model must match the ONS 
15454 NE model. For example, if the ONS 15454 NE is added as a SONET NE, the CPT 200 or CPT 
600 NE must be added as a SONET NE.

If the CPT 200 or CPT 600 NE is a standalone NE, the NE model is irrelevant.

 

3.5.2 Adding NEs
From the Domain Explorer or Subnetwork Explorer tree, you can use the Add New NE wizard to add a 
single NE or multiple NEs.

Note Prime Optical does not support duplicate IP addresses. Before adding NEs, be sure that your network 
does not contain duplicate IP addresses.
3-13
Cisco Prime Optical 9.6.3 User Guide

OL-28059-01



 

Chapter 3      Building the Network
How Do I Build NEs?
3.5.2.1 Adding a Single NE

Note If you are adding an ONS 155xx NE, first verify that the NE is covered by an entry in the SNMP 
Community String table.

Step 1 Select a node in the Domain Explorer or Subnetwork Explorer tree; then, choose File > Add Network 
Element(s) (or click the Add Network Element(s) tool). The Add New NE wizard opens. Table 3-6 
provides descriptions.

Note You cannot add a new NE to the Discovered Network Elements or Deleted Network Elements 
groups.

Step 2 Enter the following information:

• NE model

• NE type

Step 3 Click one of the following radio buttons in the NE Addition area:

• Single NE Addition—To add only one NE. 

• Single NE Addition (Use TL1 Tunnel)—To add only one tunnel NE (TNE). Prime Optical can 
connect to a TNE that belongs to an OSI network behind a non-Cisco GNE.

Step 4 Complete the following substeps if you are adding a single NE:

a. Click one of the following radio buttons in the IP Address area:

– IP

– Hostname

b. Enter the IP address or hostname; then, click Add.

Note You can enter an IP address in IPv4 or IPv6 format.

To enable you to add an NE using its hostname, the hostname must be resolved inside the 
Domain Name Service (DNS).

Step 5 Complete the following substeps if you are adding a single TNE:

a. Enter the gateway NE.

b. Click one of the following radio buttons:

– Use Default TL1 Port.

– Use Other TL1 Port—If selected, enter the TL1 port number.

c. Choose a TL1 encoding mode from the drop-down list.

d. Check the GNE Login Required check box if GNE login is required.

e. Enter the GNE TID (available if the GNE Login Required check box is checked)

Step 6 Click Next.
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Note If you click Finish in this window, Cisco default values are assigned to the remaining fields. In 
addition, the NE is placed in a preprovisioned state, and discovery does not start automatically. 
If you want to add the NE in a nonpreprovisioned state, click Next and proceed to the next 
window; then, in the Operational State field, select a state other than Preprovisioned.

Step 7 Enter the following information. Fields shown depend on the NE type.

a. NE ID

Note • Do not use “Prime Optical” as an NE ID because the Alarm Browser might contain Prime Optical 
alarms with the source ID “Prime Optical.” It will be difficult to distinguish between NE alarms and 
Prime Optical alarms if they both have the same source ID. For the same reason, do not cause Prime 
Optical to automatically populate an NE whose NE ID is “Prime Optical.”

• If you are using Prime Optical with Prime Central, do not use “None” or “All” as the NE ID, because 
those names have internal meaning to Prime Central.

• If the NE ID field is left blank, it will default to the IP address. After communication is established, 
Prime Optical discovers the NE ID from the NE.

b. Alias

c. Operational state

d. Description

e. Location name

f. Subnetwork ID 

Note This field is dimmed when the Automatically Group NEs in Subnetworks check box is 
checked in the UI Properties pane of the Control Panel.

g. Network partition ID.

Step 8 Click the icon to view the parameters.

Step 9 Click OK to change the discovery mode of the network partition.

Note You can also create new network partitions by clicking the ellipsis (...) icon. Specify a name 
and description for the new network partition.

Step 10 To view the threshold of the new network partition, the number of NEs (which will be 0), and the option 
to change the discovery mode, select either Manual or Automatic (the default) from the drop-down list.

If you choose Automatic, Prime Optical automatically discovers all NEs and adds them to the 
network partition. If you choose Manual, the NE is added and remains in the Undiscovered Network 
Elements folder (Administration > Control Panel).

Note If you have no NEs in a network partition but are still unable to change the discovery mode, 
check if the Allow Provisioning (Administration > Control Panel > UI Properties) check 
box is unchecked. Also, check the value of the Discovery Mode drop-down list.
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Caution Be sure to specify the correct partition. If you specify the wrong partition, the new NE will 
not be added, and you will get an error message.

Step 11 Click Next if you are adding an ONS 15305, ONS 15327, ONS 15454 SONET, ONS 15454 SDH, 
ONS 15530, ONS 15540, or ONS 15600 SONET NE.

Note If you click Finish in this window, Cisco default values will be assigned to the remaining fields.

Step 12 Click Finish if you are adding an ONS 15216, ONS 15310 CL, ONS 15310 MA SONET, ONS 15310 
MA SDH, ONS 15600 SDH, or Not Managed/Other Vendor NE.

Step 13 Select the grouping option for the NE.

Step 14 Click Finish to add the new NE to the domain.

Wait 2 to 5 minutes while the Prime Optical server completes the node discovery. (Not applicable if the 
operational state is Preprovisioned.)

Step 15 Check to see if the communication state is correct. If Prime Optical cannot connect to the NE, the NE 
displays an unavailable communication state icon in the tree.

Step 16 Verify that the NE software version is listed in the Supported NE table (Domain Explorer > 
Administration > Supported NE table). If it is not listed, see 4.3.8 Adding a New NE Software Version 
to the Prime Optical Domain, page 4-40.

3.5.2.2 Adding Multiple NEs

Step 1 Select a node in the Domain Explorer or Subnetwork Explorer tree; then, choose File > Add Network 
Element(s) (or click the Add Network Element(s) tool). The Add New NE wizard opens. Table 3-6 
provides descriptions.

Note You cannot add a new NE to the Discovered Network Elements or Deleted Network Elements 
group.

Step 2 Enter the following information:

• NE model.

• NE type.

• NE addition—Click the Bulk NE Addition radio button.

Note Bulk NE addition does not apply to passive ONS 15216 NEs or Not Managed/Other Vendor 
NEs.

• IP address range—Enter the IP addresses in the From and To fields; then, click Add.
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Note The IP addresses must be from the same subnetwork.

You can enter IP addresses in IPv4 or IPv6 format. You can only enter IPv6 addresses if all 
of the selected NE models support IPv6. Prime Optical provides IPv6 support for the 
following NE releases: ONS 15310 MA SDH R9.3, ONS 15310 MA SONET R9.3, ONS 
15454 SDH R9.3, and ONS 15454 SONET R9.3. 

• IP address selection—Add or remove IP addresses using the Add or Remove button.

Step 3 Click Next.

Note If you click Finish in this window, Cisco default values are assigned to the remaining fields.

Step 4 Enter the following information. Fields shown depend on the NE type.

a. NE ID—Display only.

b. Alias—Display only.

c. Operational state.

d. Description.

e. Location name.

f. Subnetwork ID.

Note This field is dimmed when the Automatically Group NEs in Subnetworks check box is 
checked in the UI Properties pane of the Control Panel.

g. Network partition ID.

Step 5 Click the icon to view the parameters.

Step 6 Click OK to change the discovery mode of the network partition.

Note You can also create new network partitions by clicking the ellipsis (...) icon. Specify a name 
and description for the new network partition.

Step 7 To view the threshold of the new network partition, the number of NEs (which will be 0), and the option 
to change the discovery mode, select either Manual or Automatic (the default) from the drop-down list.

If you choose Automatic, Prime Optical automatically discovers all NEs and adds them to the 
network partition. If you choose Manual, the NE is added and remains in the Undiscovered Network 
Elements folder (Administration > Control Panel).

Note If you have no NEs in a network partition but are still unable to change the discovery mode, 
check if the Allow Provisioning (Administration > Control Panel > UI Properties) check 
box is unchecked. Also, check the value of the Discovery Mode drop-down list.
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Caution Be sure to specify the correct partition. If you specify the wrong partition, the new NE will 
not be added, and you will get an error message.

Step 8 Click Next if you are adding an ONS 15305, ONS 15327, ONS 15454 SONET, ONS 15454 SDH, 
ONS 15530, ONS 15540, or ONS 15600 SONET NE.

Note If you click Finish in this window, Cisco default values are assigned to the remaining fields.

Step 9 Click Finish if you are adding an ONS 15310 CL, ONS 15310 MA SONET, ONS 15310 MA SDH, or 
ONS 15600 SDH NE.

Step 10 Select the grouping option for the NE.

Step 11 Click Finish to add the NEs to the domain.

Wait 2 to 5 minutes while the Prime Optical server completes the node discovery. (Not applicable if the 
operational state is Preprovisioned.)

Step 12 Check to see if the communication state is correct. If Prime Optical cannot connect to the NE, the NE 
displays an unavailable communication state icon in the tree.

Step 13 Verify that the NE software version is listed in the Supported NE table (Domain Explorer > 
Administration > Supported NE table). If it is not listed, see 4.3.8 Adding a New NE Software Version 
to the Prime Optical Domain, page 4-40.

Table 3-6 Field Descriptions for the Add New NE Wizard  

Field Description

NE Addition Panel

NE Model Select the NE model (Carrier Packet Transport 200, Carrier Packet Transport 200 SDH, Carrier 
Packet Transport 600, Carrier Packet Transport 600 SDH, Cisco ONS 15216 [all types], Cisco ONS 
15305, Cisco ONS 15305 CTC, Cisco ONS 15310 CL, Cisco ONS 15310 MA SONET, Cisco ONS 
15310 MA SDH, Cisco ONS 15327, Cisco ONS 15454 SONET, Cisco ONS 15454 SDH, Cisco 
ONS 15530, Cisco ONS 15540 ESP, Cisco ONS 15540 ESPx, Cisco ONS 15600 SONET, Cisco 
ONS 15600 SDH, or Not Managed/Other Vendor).

NE Type Select the type of NE. Available types depend on the selected NE model.

NE Addition Click one of the following radio buttons. The available fields change, depending on which option 
you select:

• Single NE Addition—To add only one NE.

• Bulk NE Addition—To add several NEs simultaneously.

• Single NE Addition (Use TL1 Tunnel)—To add only one TNE.

IP Address Click one of the following radio buttons:

• IP—To enter an IP address in IPv4 or IPv6 format.

• Hostname—To enter a hostname.
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IP/Hostname (for single 
NE additions)

Enter a unique IP address or hostname for the NE. You can enter an IP address in IPv4 or IPv6 
format. The IPv4 address must be in the form ddd.ddd.ddd.ddd, where ddd is a decimal octet 
expressed as an integer between 0 and 255. The first octet cannot be a zero. The IPv6 address is a 
128-bit address (hhhh:hhhh:hhhh:hhhh:hhhh:hhhh:hhhh:hhhh) that is divided into 16-bit blocks, 
where each block is converted to a 4-digit hexadecimal number and separated by a colon (:). An 
IPv6 address is valid only if the NE model that you selected supports IPv6 addresses.

Note Prior to the NE ID discovery, Prime Optical uses the NE IP address as a temporary NE ID.

To enable you to add an NE using its hostname, the hostname must be resolved inside the 
DNS.

The IP/Hostname field is unavailable when adding passive NEs and Not Managed/Other 
Vendor NEs.

From IP Address (for 
bulk NE additions)

Enter the beginning IP address for the range of NEs you want to add.

Note You can enter an IP address in IPv4 or IPv6 format.

To IP Address (for bulk 
NE additions) 

(Optional) Enter the ending IP address for the range of NEs you want to add. Click Add to add the 
range to the Selected IP field.

IP Address Selection 
(for bulk NE additions)

Select one or more IP addresses in the Deleted IP field and click Add to add them to the Selected 
IP field. Select one or more IP addresses in the Selected IP field and click Remove to remove them. 
Only the IP addresses in the Selected IP field are affected by clicking Next.

Note You can add IPv6 addresses only if the selected NE model supports IPv6. Prime Optical 
provides IPv6 support for the following NE releases: ONS 15310 MA SDH R9.3, ONS 
15310 MA SONET R9.3, ONS 15454 SDH R9.3, and ONS 15454 SONET R9.3. 

Gateway NE (for single 
TNE additions)

If you selected Single NE Addition (Use TL1 Tunnel) in the NE Addition area, the Gateway NE 
area becomes visible. Fill in the following fields to add a TNE to the Prime Optical domain. The 
following NE models support TL1 tunnels: ONS 15310 CL, ONS 15310 MA SONET, ONS 15310 
MA SDH, ONS 15327, ONS 15454 SONET, and ONS 15454 SDH.

• GNE IP Address—IP address of the non-Cisco GNE that supports the TL1 tunnel. This field is 
mandatory.

• Use Default TL1 Port—If selected, the default value for the TL1 port is used.

• Use Other TL1 Port—If selected, specify the TL1 port number in the text field.

• TL1 Encoding Mode—Specify the TL1 encoding mode:

– LV + Base64 Payload: (Default) If selected, and if Use Default TL1 Port is selected, TL1 
port 3081 is used.

– LV + Binary Payload: If selected, and if Use Default TL1 Port is selected, TL1 port 3081 
is used.

– Raw: If selected, and if Use Default TL1 Port is selected, TL1 port 3082 is used.

• GNE Login Required—If checked, a login is required on the non-Cisco GNE. The GNE login 
uses the following settings:

– GNE TID: The value specified in the GNE TID field.

– Username and password: The values specified in the Control Panel > Security Properties 
pane > CTC-Based SDH or CTC-Based SONET tab > Server - GNE Connection (TL1 
Tunnel) area.

Table 3-6 Field Descriptions for the Add New NE Wizard (continued) 

Field Description
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NE Properties Panel

NE ID Enter a unique name for the NE in the form of an ASCII text string. Apostrophes (’) and quotation 
marks (“) are not accepted. The NE ID you enter should be the same as the NE ID that is configured 
on the NE itself. If it is not the same, this field will be updated with the NE hostname.

Note Do not use “Prime Optical” as an NE ID because the Alarm Browser might contain 
Prime Optical alarms with the source ID “Prime Optical.” It will be difficult to distinguish 
between NE alarms and Prime Optical alarms if they both have the same source ID. For the 
same reason, do not cause Prime Optical to automatically populate an NE whose NE ID is 
“Prime Optical.”

Note If the NE ID field is blank, it will default to the IP address. After communication is 
established, Prime Optical autodiscovers the NE ID from the NE.

Alias Enter a unique alias name for the NE. The alias name can contain alphanumeric characters. It can 
also contain characters from international character sets.

Operational State Specify the operational state of the NE. There are four states:

• Preprovisioned—The NE has been added to the database for provisioning but is not yet in 
service.

• Under Maintenance—The NE is temporarily under maintenance but requires monitoring.

• In Service—The NE is currently deployed and requires monitoring.

• Out of Service—The NE has been marked Out of Service and does not require monitoring.

SNMP Community 
String

Enter the SNMP community string for the NE. The Cisco default is public.

Note The SNMP community string applies only to the ONS 15216 EDFA2, ONS 15216 EDFA3, 
ONS 15305, ONS 15310 CL, ONS 15310 MA SONET, ONS 15310 MA SDH, ONS 15327, 
ONS 15454 SONET, and ONS 15454 SDH NEs.

Note When adding ONS 155xx NEs, this field is unavailable. You must enter the community 
strings in the SNMP Community String table before adding the NE.

Description Enter a description of the NE.

Location Name Enter the NE geographic location.

Subnetwork ID 
(not selectable if 
automatic subnetwork 
grouping is enabled)

Select the subnetwork ID associated with the NE.

Network Partition ID Select the network partition associated with the NE.

To add a CTC-based NE that was discovered manually, do the following:

• To view the NE partition details, click the icon next to the NE partition ID. 

• Click OK to change the discovery mode. The discovery mode can be changed only if the 
network partition is empty.

• You can also create new network partitions by clicking the ellipsis (...) icon. Specify a name 
and description for the network partition.

Note When you are adding manually discovered NEs to a network partition, only the partitions 
that are compatible with the selected NE model are listed.

Table 3-6 Field Descriptions for the Add New NE Wizard (continued) 

Field Description
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Note • For Prime Optical to communicate with certain NE types, you must set the username and password 
that the Prime Optical server uses to establish a session with the NE. To enter user information, 
choose Administration > Control Panel > Security Properties tab; then, enter the username and 
password on the ONS 15216 EDFA2, ONS 15216 EDFA3, ONS 15216 OADM, ONS 15305 CTC, 
ONS 15327, ONS 15454, ONS 15454 SDH, ONS 155XX, ONS 15600 SDH, or ONS 15600 tab. 

• Regardless of the actual length of the password, the Password and Confirm Password fields display 
only a fixed-length string of 15 asterisks (*).

• For more information, see 8.3.3.13 Configuring Prime Optical Security Parameters, page 8-29. For 
NEs that do not use SNMP, you can set the username and password in the NE Authentication tab of 
the Domain Explorer. For more information, see 8.4.1 Setting NE Authentication, page 8-41.

• When adding more than one data communications channel (DCC)-connected, CTC-based NE, add 
one NE to a subnetwork and allow the other NEs to be automatically discovered and placed in the 
same subnetwork. When moving NEs from one subnetwork to another, move all DCC-connected 
NEs to the same subnetwork. Move the entire subnetwork instead of splitting DCC-connected NEs 
between subnetworks.

• Errors encountered while adding NEs are listed in the Error Log.

3.5.3 Copying an NE from One Group to Another
Groups for multiple users can easily be created in Prime Optical. Just copy the same NE into different 
groups. 

Step 1 In the Domain Explorer tree, select the NE to be copied.

Step 2 Choose Edit > Copy (or click the Copy tool).

Step 3 Select the group or management domain node where the NE will be pasted and choose Edit > Paste (or 
click the Paste tool). This pastes the NE under the selected node.

Group Properties Panel

Grouping Option for 
Discovered NEs

Select one of the following grouping options for the discovered NEs:

• Group discovered NEs in the Discovered Network Elements group

• Group NEs with the NE that discovered them (Cisco default)

• Group NEs by subnet

Note If you are adding manually discovered NEs, the first option is preselected, and the other 
options are dimmed. To move an NE, cut and paste it into the desired group.

Table 3-6 Field Descriptions for the Add New NE Wizard (continued) 

Field Description
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Note You cannot paste an NE in the Discovered Network Elements or Deleted Network Elements 
groups. Also, you cannot paste an NE in a group where the same instance of the NE already 
exists.

Tip The drag-and-drop feature can also be used to copy NEs. Use the mouse to drag and drop the NE to a 
new location.

Note Since they cannot see the entire domain, users with the Assign NEs property (Provisioner, Operator, and 
some custom user profiles) are not allowed to modify the topology using copy, cut, paste, or drag and 
drop.

3.5.4 Moving an NE from One Group to Another
Prime Optical provides drag-and-drop capabilities to allow you to easily move NEs from one group to 
another. 

Step 1 In the Domain Explorer tree, select the NE to be moved.

Step 2 Choose Edit > Cut, then Edit > Paste. You can also use the mouse to drag and drop the selected NE to 
a new location.

Note You cannot copy or move NEs into the Discovered Network Elements group.

Note Since they cannot see the entire domain, users with the Assign NEs property (Provisioner, Operator, and 
some custom user profiles) are not allowed to modify the topology using copy, cut, paste, or drag and 
drop.

3.5.5 Moving an NE from One Network Partition to Another

Caution Prime Optical cannot manage circuits across network partitions. Be sure that all connected NEs are 
managed under the same network partition.

Note Do not add SONET and SDH NEs in the same network partition.
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Step 1 In the Domain Explorer tree, select File > Subnetwork Explorer. The Subnetwork Explorer opens.

Step 2 Identify the network partition ID:

a. In the Subnetwork Explorer tree, click the new network partition where you will move the NE.

b. In the Network Partition Properties pane, click the Identification tab.

Step 3 Identify the subnetwork(s) assigned to the new network partition.

Note A subnetwork can only be assigned to one network partition.

Step 4 In the Domain Explorer, click the NE to be moved. In the Network Element Properties pane, click the 
Address tab.

Step 5 Change the subnetwork ID to a subnetwork ID assigned to the new network partition. Choose from the 
list of subnetwork IDs; then, click OK.

Step 6 Click Save.

3.5.6 Automatically Grouping NEs in Subnetworks

Note An NE can be assigned to only one subnetwork.

Prime Optical allows you to automatically group NEs in a subnetwork. When this feature is enabled, 
Prime Optical automatically creates the subnetwork, which consists of NEs that are connected by 
topological links; you cannot change the subnetwork of the NE. This means that:

• When adding a new NE, the option to select the subnetwork ID is disabled. The Subnetwork ID field 
displays System Default.

• In the Address tab of the Domain Explorer > Network Element Properties pane, you cannot change 
the subnetwork ID.

• You cannot drag and drop NEs in the Subnetwork Explorer tree.

Complete the following steps to automatically group NEs in a subnetwork:

Step 1 In the Domain Explorer window, choose Administration > Control Panel and click UI Properties. 

Step 2 In the Subnetwork Grouping area, check the Automatically Group NEs in Subnetworks check box.

Step 3 Click Save.

Note If a topological link is deleted while NEs are automatically grouped in subnetworks, Prime Optical 
deletes isolated NEs, creates a new subnetwork, and moves the deleted NEs to the new subnetwork.

If a topological link is discovered or added manually, it will result in a network that contains disjointed 
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subnetworks. Prime Optical deletes the NEs from the disjointed subnetwork that contains fewer NEs, 
deletes the disjointed subnetwork, and adds the deleted NEs to the subnetwork where the topological link 
was added manually.

3.5.7 Deleting NEs
From the Domain Explorer tree, you can delete a single NE, multiple NEs, or out-of-service NEs.

Note All links from the NE are deleted automatically from the database during the purge phase of NE deletion. 
The purge process does not start if there are valid links on the NEs scheduled for permanent deletion. 
You must wait until all links on the NE become invalid and then try again.

3.5.7.1 Deleting a Single NE

Only out-of-service or preprovisioned NEs can be placed in the Deleted Network Elements group.

If a CTC-based NE is deleted and then DCC connectivity to the deleted NE is removed, Prime Optical 
rediscovers the deleted NE. If DCC connectivity is removed before deleting the NE, Prime Optical does 
not rediscover the NE. Therefore, remove DCC connectivity to the NE before deleting the NE from 
Prime Optical.

Step 1 In the Domain Explorer tree, select the NE that will be deleted.

Step 2 In the Status tab of the Network Element Properties pane, set the Operational State field to 
Out of Service; then, click Save. Click Yes in the confirmation dialog box.

Note If there is more than one instance of an NE (that is, if the NE was copied so two versions exist), 
you do not need to move the NE to Out of Service before deleting it.

Step 3 You can delete either a selected instance of the NE or all instances of the NE:

• Deleting the selected instance of the NE—Only the specific NE that you selected in the Domain 
Explorer tree is deleted. To delete the selected instance of the NE, choose Edit > Delete; then, click 
Yes. If this is the last instance of the NE, the NE is placed in the Deleted Network Elements group.

Note A GNE that has associated subtending NEs cannot be deleted. A subtending NE can be 
disassociated from the GNE by removing the NE from the Prime Optical domain or by 
assigning it to a different GNE.

• Deleting all instances of the NE—All NEs in the user domain that have the same NE ID are deleted. 
To delete all instances of the selected NE, choose Edit > Delete All; then, click Yes in the 
confirmation dialog box. The NE is placed in the Deleted Network Elements group.

Note Check the Audit Log to confirm that the selected NE has been successfully deleted from the 
database. The deletion is not complete until the following message is displayed in the Audit Log: 
AUD-5015 NE ID has been successfully purged. See 8.5.1 Viewing the Audit Log, page 8-73 
for information on how to view the Audit Log.
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No client views for an NE can be opened in the Deleted Network Elements group. Also, no properties 
of a deleted NE can be modified. The deleted NE and its associated data are removed from all client 
views except the Domain Explorer.

Step 4 To purge the NEs in the Deleted Network Elements group, see 3.5.7.4 Removing a Deleted NE, 
page 3-27.

3.5.7.2 Deleting Multiple NEs

Step 1 For each NE that will be deleted:

a. In the Domain Explorer tree, select the NE that will be deleted.

b. In the Status tab of the Network Element Properties pane, set the Operational State field to 
Out of Service; then, click Save.

Step 2 In the Domain Explorer tree, select again all the NEs that will be deleted. To select multiple NEs, press 
and hold down the Ctrl button; then, click each NE that will be deleted.

Step 3 You can delete the selected instance of the NEs or all instances of the NEs:

• Deleting the selected instance of the NE—Only the specific NEs that you selected in the Domain 
Explorer tree will be deleted. To delete the selected instance of the NEs, choose Edit > Delete; then, 
click Yes in the confirmation dialog box. If the selected NEs are the last instance of the NE, the NEs 
are placed in the Deleted Network Elements group.

Note A GNE that has associated subtending NEs cannot be deleted. A subtending NE can be 
disassociated from the GNE by removing the NE from the Prime Optical domain or by 
assigning it to a different GNE.

• Deleting all instances of the NEs—All NEs in the user domain that have the same NE ID as the NE 
being deleted will be deleted. To delete all instances of the selected NEs, choose Edit > Delete All; 
then, click Yes in the confirmation dialog box. The NEs are placed in the Deleted Network Elements 
group.

Note Both the Delete and Delete All menu options are enabled if at least one of the selected NEs 
can be deleted. The confirmation dialog box lists the NEs that can and cannot be deleted.

Note Check the Audit Log to confirm that the selected nodes have been successfully deleted from 
the database. The deletion is not complete until the following message is displayed in the 
Audit Log: AUD-5015 NE ID has been successfully purged. See 8.5.1 Viewing the Audit 
Log, page 8-73 for information on how to view the Audit Log.

Note You can use the mouse to drag and drop the selected NEs to the Deleted Network Elements 
group only if all the selected NEs can be deleted.
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Step 4 To purge the NEs in the Deleted Network Elements group, see 3.5.7.4 Removing a Deleted NE, 
page 3-27.

3.5.7.3 Using the prune_ne.sh Script to Remove an Out-of-Service NE from the Database

Note It is recommended that you delete an out-of-service NE from the Prime Optical client (see 
3.5.7.1 Deleting a Single NE, page 3-24 or 3.5.7.2 Deleting Multiple NEs, page 3-25), because doing 
so does not involve stopping and starting the Prime Optical server.

Aside from using the Domain Explorer to remove an out-of-service NE from the database, you can also 
use the prune_ne.sh script.

Note Shut down the Prime Optical server and all Prime Optical clients before running the prune_ne.sh script.

Step 1 In the Domain Explorer tree, select the NE that will be removed.

Step 2 In the Status tab of the Network Element Properties pane, set the Operational State field to 
Out of Service; then, click Save.

Step 3 Close the Prime Optical client.

Step 4 Log into the Prime Optical server as the root user and enter the following command to stop the server:

opticalctl stop

Step 5 Enter the following command to verify that all Prime Optical processes have stopped:

opticalctl status

a. If any processes are still running, enter the following command:

kill -9 process-id

b. Re-enter the following command to verify that the processes have stopped:

opticalctl status

Step 6 Change the directory to /opt/CiscoTransportManagerServer/bin and enter the following command:

prune_ne.sh NE-name

Step 7 Enter the following command to start the Prime Optical server:

opticalctl start
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3.5.7.4 Removing a Deleted NE

Complete the following steps to remove an NE from the client view and delete all records associated 
with the NE from the database:

Step 1 In the Domain Explorer tree, click the Deleted Network Elements group.

Step 2 Click the NE that will be removed from the Prime Optical domain.

Step 3 Choose Edit > Delete; then, click Yes.

One of the following happens:

• The NE purge begins for NEs without any valid links.

• If the NEs that are scheduled for permanent deletion contain any valid links, the purge process does 
not start. You must wait until all links become invalid; then, then try again. 

While the purge is in progress, the following icon is displayed in the Domain Explorer tree.

Figure 3-1 Domain Explorer Icon—NE Purge In Progress

If the NE purge fails, the following icon is displayed in the Domain Explorer tree. The Audit Log reports 
the purge failure. You can repeat the purge and view the progress.

Figure 3-2 Domain Explorer Icon—NE Purge Failed

Step 4 When the NE purge completes successfully, the NE is removed from the Deleted Network Elements 
group.

The following figure shows the different purge states, where:

• 15454-ansi-65-102—NE has been deleted but not yet purged.

• 15454-ETSI-65-142—Purge is in progress.

• 15454-ETSI-65-140—Purge failed.
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Figure 3-3 Sample Purge States: Deleted, In Progress, Failed

Note • Wait until all records associated with the NE are deleted from the database before adding the NE 
back again.

• The amount of time it takes to prune NEs depends on the amount of data that needs to be removed, 
the amount of data in the database, the system performance, and so on. The Deleted Network 
Elements group is visible to users who have the add_delete_NE_group permission. You can purge 
or undelete an NE that is in the Deleted Network Elements group only if that NE was assigned to 
you.

3.5.8 Restoring a Deleted NE

Step 1 In the Domain Explorer tree, click the Deleted Network Elements group.

Step 2 Click the NE to restore.

Step 3 Choose Edit > Undelete.

Prime Optical restores the selected NE under the management domain node.

3.5.9 Searching for an NE
Prime Optical allows you to search for a specific NE in the network. See 1.6.5.1 Finding Data in the 
Domain Explorer, page 1-38.

3.6 How Do I Build Links?
A link is a connection between two termination points (TPs). Prime Optical represents the physical 
connectivity between NEs in the domain by defining the physical links between NEs. It is through these 
links that circuits (if supported on the NE) are provisioned. Links can be viewed, modified, created, and 
3-28
Cisco Prime Optical 9.6.3 User Guide

OL-28059-01



 

Chapter 3      Building the Network
How Do I Build Links?
deleted. Prime Optical automatically discovers links between CTC-based (including the ONS 15305 
R3.0) and ONS 155xx NEs. For CTC-based NEs, links are autodiscovered only when the DCCs are 
created on both ends of the link. Autodiscovery requires configuration on ONS 15530 and ONS 15540 
NEs. For the ONS 15216, links are manually added.

Note An autodiscovered link between two TPs will override previously autodiscovered links and any manual 
links on any of the TPs.

3.6.1 Setting Up ONS 15530 and ONS 15540 NEs for Link Discovery
Links between ONS 15530 and ONS 15540 NEs are automatically discovered and displayed, provided 
that physical topology is configured correctly on all ONS 15530 and ONS 15540 NEs in the network. 
Each physical topology neighbor of an NE represents a physical link between the NE and its neighbor 
NE. The ONS 15530 and ONS 15540 discovery service collects physical topology information and 
converts it into physical links displayed by Prime Optical.

Links between ONS 15530 and ONS 15540 devices can be bidirectional or unidirectional. A 
unidirectional link operates in the context of the transmit or receive side of a fiber connection and is 
represented by an arrowhead link in the Network Map. 

Be sure that have you have set up the topology on all of the ONS 15530 and ONS 15540 NEs in your 
network, as described in 3.5.1.4 Prerequisites for Adding ONS 15530 and ONS 15540 NEs, page 3-10.

3.6.2 Overview of Supported Links
Links can be created at different layer rates depending on the card type. See Table 3-7 for the links 
supported between NEs at compatible layer rates. See Table 3-8 for the supported links per layer rate.

Note Links can be created for a Not Managed/Other Vendor NE only if the NE is in service or under 
maintenance. Links created for CTC-based NEs are for circuit routing purposes only. Links created for 
Not Managed/Other Vendor NEs are not used for circuit routing.

Note Physical nonroutable links can be created between NEs that are in the same or a different network 
partition(s).

Links between TXP_MR_2.5G, TXPP_MR_2.5G, MXP_2.5G_10G, TXP_MR_10G, 2.5G_DM, 
2.5G_DMP, TXP_MR_10E, or MXP_MR_10E cards are automatically discovered and cannot be 
manually created. They can exist if:

• The layer rate is Optical Channel Layer (OCH).

• Both cards support the same wavelength.

• The links are bidirectional.

Links between TXP_MR_2.5G, TXPP_MR_2.5G, MXP_2.5G_10G, TXP_MR_10G, 2.5G_DM, 
2.5G_DMP, TXP_MR_10E, MXP_MR_10E cards or DWDM cards are manually created and cannot be 
automatically discovered. They can be created if:

• The layer rate is Physical.
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• The link is unidirectional.

• The link rate is 10G ITU if a MXP_2.5G_10G, TXP_MR_10G, TXP_MR_10E or MXP_MR_10E 
card is used at one end of the link, or 2.5 G ITU if a TXP_MR_2.5G, TXPP_MR_2.5G, 2.5G_DM 
or 2.5G_DMP card is used at one end of the link.

• The link is unprotected.

• The link is created between TXP_MR_2.5G, TXPP_MR_2.5G, MXP_2.5G_10G, TXP_MR_10G, 
2.5G_DM, 2.5G_DMP, TXP_MR_10E, or MXP_MR_10E trunk ports and DWDM channel ports.

• DWDM channel ports are unidirectional and can only be used as the link source if they are transmit 
ports and as the link destination if they are receive ports.

• The working wavelength of TXP_MR_2.5G, TXPP_MR_2.5G, MXP_2.5G_10G, TXP_MR_10G, 
2.5G_DM, 2.5G_DMP, TXP_MR_10E, and MXP_MR_10E cards is equal to the expected 
wavelength set on the DWDM channel port on the other end of the link.

Prime Optical discovers links that are created in CTC as L2 trunk-to-trunk links and displays them with 
a layer rate of L2. Only 10GE_XP and GE_XP cards in L2 mode support L2 trunk-to-trunk links.

When a DWDM transponder card (including a DWDM line card) is used as the destination of a manual 
link with a channel port, the wavelength is not calculated, because the physical connection works 
correctly. Therefore, verify that you want to create a manual link between a given channel (for example, 
a demux card) and a TXP card whose trunk port is set to a different wavelength.

Table 3-7 Links Supported Between NEs at Compatible Layer Rates

NE Model Supports Links with These NEs at Compatible Layer Rates

ONS 15216 ONS 15216

ONS 15327

ONS 15454 SONET/SDH

ONS 15600 SONET

ONS 15305 (R2.x) ONS 15305

ONS 15327

ONS 15454 SONET/SDH

ONS 15600 SONET/SDH

ONS 15305 (R3.0) ONS 15305

ONS 15327

ONS 15454 SONET/SDH

ONS 15600 SONET/SDH

Unmanaged NEs

ONS 15310 CL ONS 15310 CL

ONS 15310 MA SONET/SDH

ONS 15327

ONS 15454 SONET/SDH

ONS 15600 SONET/SDH
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ONS 15310 MA SONET ONS 15310 CL

ONS 15310 MA SONET/SDH

ONS 15327

ONS 15454 SONET/SDH

ONS 15600 SONET/SDH

ONS 15310 MA SDH ONS 15310 CL

ONS 15310 MA SONET/SDH

ONS 15327

ONS 15454 SONET/SDH

ONS 15600 SONET/SDH

ONS 15327

ONS 15454 SONET

ONS 15454 SDH

ONS 15216

—

ONS 15305

ONS 15310 CL

ONS 15310 MA SONET/SDH

ONS 15327

ONS 15454 SONET/SDH

ONS 15600 SONET/SDH

Unmanaged NEs

ONS 15530

ONS 15540 (ESP/ESPx)

ONS 15530

ONS 15540 (ESP/ESPx)

ONS 15600 SONET

ONS 15600 SDH

ONS 15216

ONS 15305

ONS 15310 CL

ONS 15310 MA SONET/SDH

ONS 15327

ONS 15454 SONET/SDH

ONS 15600 SONET/SDH

Unmanaged NEs ONS 15305 (R3.0)

ONS 15327

ONS 15454 SONET/SDH

Unmanaged NEs

Table 3-7 Links Supported Between NEs at Compatible Layer Rates (continued)

NE Model Supports Links with These NEs at Compatible Layer Rates
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Table 3-8 Supported NE Links

NE Model NE Card Physical OTS OMS OCH SONET/SDH Layer 2

ONS 15216 100-GHz Filter X X

100-GHz OADM 1/2/4 X X

200-GHz Filter X X

200-GHz OADM 1/2 X X

DCU X

EDFA 1 X X

EDFA2 X X

EDFA3 X X

FlexLayer X X

OSC X X

ONS 15305 STM-1 X X

STM-4 X X

STM-16 X X

ONS 15310 CL CTX-CL600 (OC-3 port) X X

CTX-CL600 (OC-12 port) X X

PoS X

ONS 15310 MA SONET CE-MR-6 X

CTX-2500 (OC-3 port) X X

CTX-2500 (OC-12 port) X X

CTX-2500 (OC-48 port) X X

PoS X

ONS 15310 MA SDH CE-MR-6 X

CTX-2500 (STM-1 port) X X

CTX-2500 (STM-4 port) X X

CTX-2500 (STM-16 port) X X

PoS X

ONS 15327 E10/100-4 X

G1000-2 X

OC-3/STM-1 X X

OC-12/STM-4 X X

OC-48/STM-16 X X
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ONS 15454 SONET and 
ONS 15454 SDH

10GE_XP and GE_XP X X

32MUX-O X

32DMX-O X

4MD-xx.x X

AD-1C-xx.x X

AD-2C-xx.x X

AD-4C-xx.x X

CE-MR-10 X

E100T-12 X

E100T-12-G X

E1000-2 X

E1000-2-G X

ML100-12 X

ML1000-2 X

MXP_2.5G_10G X X

OC-3/STM-1 X X

OC-12/STM-4 X X

OC-48/STM-16 X X

OC-48/STM-16 ITU X X

OC-192/STM-64 X X

OC-192/STM-64 ITU X X

OPT-AMP-C X X

OPT-BST X X

OPT-RAMP-C X X

OSC-CSM X X

OTU2-XP X X

TXP_MR_2.5G and 
TXPP_MR_2.5G

X X

TXP_MR_10G X X

ONS 15530 10 Gb/s Uplink X

OADM X X

Nonsplitter 2.5 Gb/s ITU 
Trunk

X X

Nonsplitter 10 Gb/s ITU Trunk X X

Splitter 10 Gb/s ITU Trunk X X

Table 3-8 Supported NE Links (continued)

NE Model NE Card Physical OTS OMS OCH SONET/SDH Layer 2
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3.6.3 Viewing the Link Table
The Link table shows information about each link attribute. Use the Link table to view, modify, and 
delete links. You can open the Link table for the Prime Optical domain, network partition, subnetwork, 
group, or NE.

• If you select the Prime Optical domain, network partition, subnetwork, or group, the Link table 
shows all links that terminate on any of the NEs contained in the Prime Optical domain, subnetwork, 
or group.

• If you select an NE, the Link table shows all links that terminate on that particular NE. 

Use one of the following methods to open the Link table:

• From the Network Map—In the Domain Explorer or Subnetwork Explorer, choose File > 
Network Map. In the Network Map, select a network partition, subnetwork, group, or NE; then, 
choose Configuration > Link Table.

• From the Network Map—Right-click a link or server trail and choose Link Table from the shortcut 
menu.

• From the Domain Explorer—Select the Prime Optical domain, group, or NE; then choose 
Configuration > Link Table.

• From the Subnetwork Explorer—Select the Prime Optical domain, network partition, subnetwork, 
or NE; then, choose Configuration > Link Table.

ONS 15540 10 GE Transponder xx.x X X

32-channel Mux/Demux X X

OADM xx.x X X

Type 1 single-mode 
Transponder xx.x

X X

Type 1 multi-mode 
Transponder xx.x

X X

Type 2 extended range 
Transponder xx.x

X X

ONS 15600 SONET ASAP (OC-3 port) X X

ASAP (OC-12 port) X X

ASAP (OC-48 port) X X

OC-48 X X

OC-192 X X

ONS 15600 SDH STM-16 X X

STM-64 X X

Table 3-8 Supported NE Links (continued)

NE Model NE Card Physical OTS OMS OCH SONET/SDH Layer 2
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Note • A link is visible in the Link table even if the source or destination NE has been deleted, but this same 
link is not visible in the Network Map. If the NE is deleted from the Deleted Network Elements 
group, the references to that NE are removed from the Link table.

• When launching the Link table in a large or high-end network setup and on a larger scope (for 
example, for the Domain Explorer), a database timeout can occur due to the large volume of data 
that needs to be retrieved. As a workaround, launch the Link table on a smaller scope.

Note the following constraints for OCH unidirectional and bidirectional patchcord links, Optical 
Transmission Section (OTS) links, Y-cable patchcord links, server trail links, and autodiscovered links:

• An invalid patchcord link is a link that has been deleted from the Network Control Protocol (NCP) 
layer but is still present in the Prime Optical database. The resources allocated for the patchcord link 
are freed up and made available for a new link.

• Invalid links are shown in strikethrough font.

• An invalid patchcord link is removed from the Prime Optical database and disappears from the Link 
table only if a Prime Optical user deletes that link. All logical and physical resources are released 
from the deleted link.

• If the Link table contains an invalid patchcord link and you create a new patchcord link using the 
same termination points and attributes as the invalid link, the invalid patchcord link becomes valid 
and is shown in the Link table as a valid link.

• When an invalid patchcord link becomes valid, the link name changes. Prime Optical uses link 
identification numbers to create the patchcord link name. The NCP layer associates identification 
numbers to both terminations during the link creation phase. These numbers are used to identify the 
patchcord link inside the NCP layer and are required to delete the patchcord link. To change the 
patchcord link name:

1. Use the Create Link wizard to create a new patchcord link.

2. Force the patchcord link validity to change to INVALID (for example, by marking the NE as 
Out of Service or deleting the patchcord link).

3. Create a new patchcord link that uses the same termination points and attributes as the invalid 
link.

4. View the patchcord link name in the Link table. The link name has changed.

The following table describes the fields in the Link table.

Table 3-9 Field Descriptions for the Link Table

Field Description

Link Alarm Severity Highest severity alarm associated with the selected link.

Link Source ID ID of the link source.

Link Source 
Termination Point

PTP of the link source.

Link Destination ID ID of the link destination.

Link Destination 
Termination Point

PTP of the link destination. Because a link can have up to two destinations on the same NE, a 
“DST1” or “DST2” label is affixed to the destination to indicate the destination number.
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Layer Rate Layer rate, defined as per ITU-T standard G.872 for multilayered optical networks. Values are 
Physical, Transmission Section, Optical Multiplex Section (OMS), OCH, SONET/SDH, Layer 2, 
Composite, and OTU.

Layer Detail Bandwidth of the link as per the layer rate:

• For SONET links, the link rate is OC-3, OC-12, OC-48, OC-192, or Layer 2, depending on the 
NE configuration.

• For SDH links, the link rate is STM1, STM-4, STM-16, STM-64, or Layer 2.

• For DWDM links, the link rate is 40G ITU, 10G ITU, 2.5G ITU, or OTS.

• For OCH links, the link rate is 10G ITU or 2.5G ITU.

• For patchcord links on Layer 2, the link rate is 10G ITU, 1G ITU, or Fast Ethernet.

• For links between Not Managed/Other Vendor NEs, the link rate is Not Applicable.

• For links between Not Managed/Other Vendor NEs and a CTC-based NE, the rate is that of the 
CTC-based NE. Links between a SONET/SDH link and a Not Managed/Other Vendor NE 
depend on the link source. If the link source is the Not Managed/Other Vendor NE, the layer 
rate is Not Applicable. If the link source is the SONET/SDH link, the layer rate is that of the 
SONET/SDH link.

For server trails, this field displays the server trail type and the number of server trails.

Link Direction Whether the link is unidirectional or bidirectional.

Link Provision Type Whether the selected link is automatically discovered by an NE. Values are:

• Manual—For manual links.

• Auto—For automatically discovered links.

• PatchCord—For patchcord links.

For server trails, the value displayed is Server Trail.

Note Autodiscovered links between transponder or muxponder cards on release 4.6 NEs are 
always reported with a constant size, regardless of payload type.

Table 3-9 Field Descriptions for the Link Table (continued)

Field Description
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Is Link Valid Validity of the link. Values are Valid or Invalid. For autodiscovered links, the value is Valid if both 
the terminating NEs are in service and the NEs are able to confirm the presence of the link. An 
autodiscovered link is invalid if (1) the DCC is disabled on either PTP; (2) either PTP is marked as 
Out of Service (OOS); (3) there is a fiber cut or transmitter/receiver failure; or (4) either NE is 
marked as OOS.

The following rules apply to link validity:

• All invalid links are shown as gray in the Network Map.

• Valid links are shown in the Network Map with a color corresponding to alarm severity, with 
green for no alarm, yellow for minor alarms, orange for major alarms, and red for critical 
alarms.

• Manual and unmanaged links can be valid or invalid.

• A link between an unmanaged NE and a managed NE can be valid or invalid. If the link is 
valid, it is shown with the same color as the PTP alarm on the managed NE.

• The delete link operation is available for all links except for valid, autodiscovered links. You 
can delete links of the following type:

– Manual (valid and invalid)

– Virtual (valid and invalid)

– Unmanaged (valid and invalid)

– Invalid autodiscovered

Link Connection Type Whether the link connection is inter-NE or intra-NE.

An inter-NE link represents an external fiber connection between PTPs on different NEs. An 
intra-NE link represents a fiber connection between two PTPs on the same NE.

Link Protection Type Whether the link protection is unprotected, 1+1, 1+1 with Y-cable protection, 2-fiber 
BLSR/MS-SPRing, 4-fiber BLSR/MS-SPRing, or not applicable.

For ONS 155xx NEs, protection types are Y-cable/line card protection, trunk protection, splitter 
protection, or no protection. The Y-cable protection type also applies to ONS 15454 SONET and 
ONS 15454 SDH NEs.

Used for Routing Whether the selected link is used for routing. Values are Yes or No.

Link Name Name of the selected link.

Note The names of bidirectional links are prone to change when they are rediscovered as a result 
of a system restart. Prime Optical assigns names to the links, combining their source and 
destination points. Because the links are bidirectional, the order of the source and 
destination points could change when the links are rediscovered.

Link Description User-entered description of the selected link. If you do not modify the System Default string in the 
Create Link wizard, the description is a string built from the endpoint information.

Alarm Counts Total number of critical, major, minor, and warning alarms associated with the selected link.

Note This field does not apply to ONS 155xx NEs.

Link Cost Numeric cost associated with the selected link. The link cost is used while routing a circuit. The 
lowest link cost is preferred in circuit routing. The Cisco default value is 1024. This attribute is 
editable for manual links in the SONET or SDH layer.

Table 3-9 Field Descriptions for the Link Table (continued)

Field Description
3-37
Cisco Prime Optical 9.6.3 User Guide

OL-28059-01



 

Chapter 3      Building the Network
How Do I Build Links?
 

3.6.4 Filtering the Link Table

Step 1 In the Link table, choose File > Filter. The Filter dialog box opens.

Step 2 Specify the filter parameters described in the following table.

Step 3 Click OK to run the filter.

 

3.6.5 Creating Links

Step 1 Open the Create Link wizard by using one of the following methods:

Shared Risk Link 
Groups

(SONET/SDH layer rates only) Free-format string that represents the shared risk link group 
(SRLG), or a group of links that share a common risk. For example, a set of links that originate at 
a node share the node as the common risk.

SRLGs allow you to classify links into logical groups. By grouping the links, you can specify 
diverse link routing for a circuit. That is, if the circuit is fully protected, it is routed on the working 
and protect paths with a diverse SRLG attribute.

The Shared Risk Link Groups field supports up to 5 comma-separated values, with 32 characters 
per value.

Link Utilization Link utilization information for Layer 3, SONET/SDH, and OTS links. For non-Layer 3, 
non-SONET/SDH, non-OTS links, this field shows Not Applicable. For detailed information about 
link utilization, see 3.6.9 Viewing Link Utilization, page 3-47.

Link Alias Name Alias name of the link.

Table 3-9 Field Descriptions for the Link Table (continued)

Field Description

Table 3-10 Field Descriptions for the Link Table Filter Dialog Box

Field Description

Source/Destination 
ID

Filters by source/destination IDs of the available NEs. Click Add and Remove to move NEs to and 
from the Selected NEs list.

Connection Type Filters out inter-NE or intra-NE links. By default, all links are shown. Only the ONS 15530 and 
ONS 15540 have intra-NE connections. You can also filter on server trails.

Link Layer Filters by layer combination. You can select any subset of the following layers: Physical, OTS, OMS, 
OCH, SONET/SDH, Layer 2, Layer 3, and OTU.
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• From the Network Map—Select the source NE and choose Configuration > Create Link (or 
right-click the NE and choose Create Link). Connect the line to the destination NE or click the map. 
The Create Link wizard opens. The Link Destination panel displays a list of NEs that support 
compatible layer rates with the source NE.

• From the Domain Explorer or Subnetwork Explorer—Select the source NE and choose 
Configuration > Create Link (or right-click the NE and choose Create Link). The pointer changes 
to a plus sign; select the destination NE or group. The Create Link wizard opens.

Note If you press the Esc key while the plus sign is enabled, the operation is canceled and the plus 
sign returns to a pointer.

Note Table 3-11 describes the fields in the Create Link wizard. Fields shown depend on the NE 
selected.

Step 2 Create the link, as follows:

a. Enter the following information in the Link Attributes panel: 

• Name

• Link alias

• Description

• Provision type

• Layer 

• Layer detail

Note Links from a Not Managed/Other Vendor NE to a CTC-based or Not Managed/Other 
Vendor NE will have a link rate of Not Applicable. Links from a CTC-based NE to a 
Not Managed/Other Vendor NE will have the link rate allowed for the CTC-based NE.

Note The layer details displayed in the Create Link wizard are based on the NE selected as 
the link source. For example, when you attempt to create a link from NE A to NE B, the 
link sizes displayed are based on the supported sizes and inventory of NE A. If the link 
is attempted in the reverse direction, from NE B to NE A, the link sizes displayed are 
based on the inventory and sizes for NE B. As a result, the link sizes displayed could 
differ when the operation is attempted differently. An error message is displayed in the 
Link Destination panel when the size displayed is not applicable for the destination NE.

• Wavelength (available only if the layer is Optical Channel, the provisioning type is Patchcord, 
and the direction is Unidirectional)

• Protection

• Direction 
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Note Prime Optical allows creation of bidirectional SONET/SDH links as well as 
unidirectional and bidirectional physical links.

If the layer rate is SONET/SDH or Layer 2, only bidirectional links are available. For 
other layer rates, both unidirectional and bidirectional links are available.

• Cost

• Shared risk link groups

b. Click Next.

c. Enter the following information in the Link Source panel: 

• Node

• PTP slot

• PTP port

• PTP value

• Name

d. Click Next.

e. Enter the following information in the Link Destination panel:

• Node

• PTP slot

• PTP port

• PTP value

• Name

Note A PTP can be associated with only one bidirectional link or two unidirectional links at 
a particular layer rate for all NEs except Not Managed/Other Vendor NEs. For Not 
Managed/Other Vendor NEs, a PTP can terminate in only one link.

Note If you are creating a SONET/SDH-layer manual link between two CTC-based NEs, 
verify that no DCC exists on the endpoints that are selected for the link termination.

Note You can create a provisional patch cord (PPC), a virtual link, between 15600 and 15454 
NEs destination points.

f. Click Next.

Step 3 The Link Summary panel summarizes the attributes of the new link. To change the link summary 
information, click Back and change the selections as needed.

Step 4 Click Finish.
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Table 3-11 Field Descriptions for the Create Link Wizard

Field Description

Link Attributes Panel

Name Enter a unique name for the new link. The link name is a free-format string, up to 256 characters.

Link Alias Enter a unique alias name for the new link. The alias name can contain alphanumeric characters. It also 
supports international character sets.

Description Enter a description of the new link. The link description is a free-format string, up to 256 characters.

Provision Type Specify the type of link provisioning. Values are:

• Manual—The link is manually provisioned.

• Patchcord—(Applicable only to links involving transponders and DWDM modules) The link is an 
internode or intranode termination provisioned between homogeneous ports. A patchcord link 
represents the connection between a line card and a transponder, or the connection between a 
transponder and a DWDM card. Patchcord links can be provisioned by Prime Optical or CTC users 
and are maintained by the NEs.

Note Protection groups are not recognized when creating patchcord or manual links.

Layer Choose the link layer rate, defined as per ITU-T standard G.872 for multilayered optical networks. Values 
are:

• Physical

• Transmission Section

• OMS

• OCH

• SONET/SDH

• Layer 2

Note Patchcord links on Layer 2 can be created between NNI ports on GE-XP or 10GE-XP cards if the 
card modes are set to L2 over DWDM. 

Layer Detail Choose the bandwidth of the link as per the layer rate.

• For SONET links, the link rate is OC-3, OC-12, OC-48, OC-192, or Layer 2, depending on the NE 
configuration.

• For SDH links, the link rate is STM1, STM-4, STM-16, STM-64, or Layer 2.

• For DWDM links, the link rate is 100G ITU, 40G ITU, 10G ITU, 2.5G ITU, or OTS.

• For OCH links, the link rate is 10G ITU or 2.5G ITU.

• For patchcord links on Layer 2, the link rate is 10G ITU,1G ITU, or Fast Ethernet.

• For links between Not Managed/Other Vendor NEs, the link rate is Not Applicable. 

• For links between Not Managed/Other Vendor NEs and CTC-based NEs, the rate is that of the 
CTC-based NE. Links between a SONET/SDH link and a Not Managed/Other Vendor NE depend on 
the link source. If the link source is the Not Managed/Other Vendor NE, the layer rate is Not 
Applicable. If the link source is the SONET/SDH link, the layer rate is that of the SONET/SDH link.
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Wavelength Filter the wavelength in the first drop-down list. In the second drop-down list, select the appropriate 
wavelength value according to the selected filter.

The Wavelength drop-down lists are available only if the layer is Optical Channel, the provisioning type 
is Patchcord, and the direction is Unidirectional.

Note When the layer is Optical Channel, the provisioning type is Patchcord, and the direction is 
Bidirectional, the Wavelength drop-down lists are disabled, but Prime Optical executes an 
automatic wavelength check on the endpoints before creating the link. If the link endpoints do not 
have the same wavelength value, the link is not created and a wavelength error is generated.

Protection Specify the link protection: Unprotected, 1+1, Y-Cable (meaning 1+1 with Y-cable protection), 2-Fiber 
BLSR/MS-SPRing, 4-Fiber BLSR/MS-SPRing, or Not Applicable. For CTC-based NEs, select 
Unprotected, 1+1, or Y-Cable. For links between Not Managed/Other Vendor NEs, the link protection is 
Not Applicable. For links between Not Managed/Other Vendor NEs and CTC-based NEs, the link 
protection is that of the CTC-based NE.

Direction Specify whether the link is unidirectional or bidirectional.

Cost Specify a numeric cost associated with the SONET or SDH layer link. The cost range is 0 to 999999. This 
field applies only to links in the SONET or SDH layer between CTC-based NEs. For all other links, the 
Cisco default value is 1024. All autodiscovered links have the Cisco default cost 1024.

Shared Risk 
Link Groups

(SONET/SDH layer rates only) Enter a free-format string that represents the SRLG, or a group of links 
that share a common risk. For example, links that originate at a node share the node as the common risk.

The Shared Risk Link Groups field supports up to 5 comma-separated values, with 32 characters per 
value.

Link Source Panel

Node Identify which NE serves as the source of the link.

Physical 
Termination 
Point

Identify the physical side, shelf, slot, subslot (if applicable), and port in the source NE. For the ONS 
15216, identify the name of the PTP. 

Note The card type is shown adjacent to the slot number; for example, “1 (OC3_8)” represents the 
OC3_8 card in slot 1.

Note If the port name is available, it is shown adjacent to the port number.

PTP Value (Not Managed/Other Vendor NEs only) Specify the PTP value. The maximum length is 30 characters; the 
minimum length is 1 character.

Name For the ONS 15530 and ONS 15540, identify the PTP as a single name, which includes a port type and 
slot number and might also include a subslot number and port number.

Link Destination Panel

Node This is a display-only field if you selected an NE as the destination of the link. If you selected a group as 
the destination of the link, select from the drop-down list a specific NE that will be the destination of the 
link.

Physical 
Termination 
Point

Identify the physical side, shelf, slot, subslot (if applicable), and port in the destination NE. For the 
ONS 15216, identify the name of the PTP. 

Note The card type is shown adjacent to the slot number; for example, “1 (OC3_8)” represents the 
OC3_8 card in slot 1.

Note If the port name is available, it is shown adjacent to the port number.

Table 3-11 Field Descriptions for the Create Link Wizard (continued)

Field Description
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Note • After the links are created, each link has a different color notation depending on the alarm status of 
the PTP on which the link is created. Links between Not Managed/Other Vendor NEs are always 
black. The color of the link between a Not Managed/Other Vendor NE and a CTC-based NE is the 
color of the TP of the CTC-based NE. The colors are green for no alarm, yellow for minor alarms, 
orange for major alarms, and red for critical alarms. Invalid links (as reflected in the Is Link Valid 
field) are gray. An autodiscovered link can become invalid if (1) the DCC is disabled on either PTP; 
(2) either PTP is marked as Out of Service (OOS); (3) there is a fiber cut or transmitter/receiver 
failure; or (4) either NE is marked as OOS. Manual links are colored to match the highest alarm 
severity on either PTP. L2 links are always gray.

• Links that are supported in different layer rates can be created only if the link endpoints are 
compatible with the specified layer rate.

• If Prime Optical discovers a link, it automatically assigns layer rates based on its endpoint.

The following table summarizes link color as it relates to link type and the involved NEs. 

 

PTP Value (Not Managed/Other Vendor NEs only) Specify the PTP value. The maximum length is 30 characters; the 
minimum length is 1 character.

Name For the ONS 15530 and ONS 15540, identify the PTP as a single name, which includes a port type and 
slot number and might also include a subslot number and port number.

Link Summary Panel

Link Summary Summarizes the selections you made. To change the Link Summary, click Back and change your 
selection(s).

Table 3-11 Field Descriptions for the Create Link Wizard (continued)

Field Description

Table 3-12 Summary of Link Color

Link Type Link Validity Link Color
Can the Link 
Be Deleted?

Manual Valid Color of the highest severity alarm on the PTP. Yes

Manual Invalid Gray. Yes

Virtual Valid Color of the highest severity alarm on the PTP. Yes

Virtual Invalid Gray. Yes

Unmanaged Valid Black, if the link is between two unmanaged NEs. Otherwise, the color 
corresponds to the highest severity alarm on the PTP.

Yes

Unmanaged Invalid Gray. Yes

Autodiscoverd Valid Color of the highest severity alarm on the PTP. No

Autodiscovered Invalid Gray. Yes
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3.6.6 Modifying Links
Use the Modify Link wizard to modify the name, alias, description, cost, or SRLG (if applicable) of links 
displayed in the Link table. You can modify a link in the Link table or in the Network Map.

Note You cannot modify patchcord links.

Step 1 Open the Modify Link wizard (see Table 3-13) by using one of the following methods:

• In the Link table, select a link and choose Edit > Modify Link (or click the Modify Selected Link 
tool).

• In the Network Map, select a link and choose Configuration > Modify Link (or click the Modify 
Selected Link tool).

Step 2 In the Link Attributes panel, modify the following information, as needed:

• Name

• Link alias

• Description

• Direction

• Cost

• Shared risk link groups

Note If you modify the SRLG value, you receive the warning popup “There might be circuits 
routed with diverse SRLG constraints on this link. Changing risk link groups might affect 
the diversity constraint.” Click OK; then, verify the SRLG value that you entered.

Step 3 Click Next until you reach the Finish panel.

Step 4 Verify the link summary and click Finish.

Note After certain topology reconfigurations that involve removing fiber, the Network Map might not 
report the correct links. This problem occurs because the Prime Optical server is not 
synchronized with the new network topology and cannot retrieve network or link updates. This 
problem applies only to CTC-based NEs. The workaround is to remove the links completely by 
deleting the SDCC termination on the ports, rather than by simply unplugging the fiber cable.

Table 3-13 Field Descriptions for the Modify Link Wizard

Field Description

Link Attributes Panel

Name Modify the name of the selected link. The link name is a free-format string, up to 256 characters. The link 
name must be unique.

Link Alias Modify the alias name of the selected link. The alias name can contain alphanumeric characters. It also 
supports international character sets.
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3.6.7 Deleting Links
You can delete one or multiple links from the Link table. You can delete a single link from the Network 
Map.

Step 1 In the Link table, select one or multiple links and choose Edit > Delete Link (or click the Delete 
Selected Link tool). In the Network Map, select a single link and choose Configuration > Delete Link.

Step 2 Click OK in the confirmation dialog box. 

Step 3 For multiple link deletion, complete the following substeps:

a. The Deleting Links dialog box tracks the progress of the deletion. If you selected links that cannot 
be deleted, you receive the message: “Some of the links can’t be deleted, proceed anyway?” Review 
the links that you selected for deletion; then, click OK.

b. The Multiple Link Deletion Summary dialog box opens, summarizing the results of the deletion. 
Click the Details button to see which links were deleted, and which links could not be deleted.

The following rules apply to single and multiple link deletion:

• User-created links or invalid autodiscovered links can be deleted.

• Valid autodiscovered links cannot be deleted. 

• An autodiscovered link is marked Invalid when Prime Optical can no longer verify the link from 
either of the NEs at the ends of the link.

• To remove a valid autodiscovered link from Prime Optical, you must remove the topology neighbors 
from both NEs at the end of the link. 

• Prime Optical can delete physical links even if there is an autodiscovered SONET/SDH link.

Description Modify the link description. The link description is a free-format string, up to 256 characters.

Provision Type Display only. View the type of link provisioning (Manual or Patchcord).

Layer Display only. View the link layer.

Layer Detail Display only. View the link size.

Wavelength Display only. View the link wavelength value.

Protection Display only. View the link protection.

Direction Modify whether the link is unidirectional or bidirectional.

Cost Modify the numeric cost associated with the SONET or SDH layer link. The cost range is 0 to 999999. 
This field is editable only for links in the SONET or SDH layer. For all other links, the Cisco default value 
is 1024. All autodiscovered links have the Cisco default cost 1024.

Shared Risk 
Link Groups

(SONET/SDH layer rates only) Modify the strings that represent the SRLG. The SRLG attribute supports 
up to 5 comma-separated values, with 32 characters per value.

Link Summary Panel

Link Summary Summarizes the changes you made to the editable fields. To change the Link Summary, click Back and 
change your selection(s).

Table 3-13 Field Descriptions for the Modify Link Wizard (continued)

Field Description
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• If you use Prime Optical to delete invalid autodiscovered links, verify that the DCCs are deleted on 
both ends of the link. If you delete a partial link with a DCC up on one end, it might cause problems 
later with the creation of phantom links.

• When you delete an OSC termination, any autodiscovered links become invalid. If you then delete 
the invalid links and recreate the OSC termination, an update event is generated. But because 
Prime Optical cannot find a link to update, it discards the event and does not discover the link. This 
is normal Prime Optical behavior in response to the deletion of invalid links. The workaround is to 
mark the NE(s) as Out of Service and then In Service.

 

3.6.8 Viewing the Link Maintenance Report
The following new functionality is supported on the OCHCC, OCHNC and OCH Trail circuits: 

• Protection groups related to the circuits sharing a selection of OTS links. 

• Perform bulk protection operations on those circuits

The information is available in the Link Maintenance Report.

You can launch the Link Maintenance Report only from the network map by right clicking the multiple 
links selection.

Table 3-14 Field Descriptions for the Link Maintenance Report

Field Description

Circuit Name Displays the name of the selected circuit.

Note If there are multiple circuits with the same name displayed in the Circuit table, the 
label Duplicate appears in this column. 

Circuit Type Displays the type of circuit selected. SONET circuit types are STS, VT, VT Aggregation, 
VT Tunnel, VT VCAT (shown as VT-v), STS VCAT (shown as STS-v), DWDM optical 
channel network connection (OCHNC), DWDM optical channel client connection 
(OCHCC), optical channel trail (OCHTRAIL), and OCHNC DCN.

SDH circuit types are HOP, LOP, LOPA, LOPT, HOV (HO VCAT), LOV (LO VCAT), 
OCHNC, OCHCC, OCHTRAIL, and OCHNC DCN. 

Customer ID Optional text field that displays the customer ID of the circuit. 

Service ID Optional text field that displays the service ID of the selected circuit. 

Operation on Source The current operation on the protection group on circuit source. 

Operation on Destination The current operation on the protection group on circuit destination. 

Link on Active Path Displays the link on the active path. Values are:

• Yes—If the links are on the active path of the protection group

• No—If the links are on the standby path of the protection group

• N/A—If no protection group is available

Protection Group Type Displays the type of protection group. 
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3.6.8.1 Performing Switch Operations

You can perform protection operations on single and multiple circuits only if the following conditions 
are met:

• A protection group is present. 

• Current protection operations on sources and destinations are the same.

From the Link Maintenance Report, click the Perform Protection Switch Operations button. An 
Operations dialog box containing the protection operations available for Y-Cable and Splitter protection 
groups is displayed.

Once the operation is completed, a protection operation report with the result is displayed.

3.6.9 Viewing Link Utilization
The Link Utilization table displays utilization information for the selected links. Link utilization, shown 
as a percentage, displays the overall consumption of bandwidth. All bandwidths are in megabits per 
second (Mb/s).

Circuit Source NE Circuit source Network Element

Circuit Destination NE Circuit destination Network Element

Table 3-14 Field Descriptions for the Link Maintenance Report

Field Description

Table 3-15 Field Descriptions for Operations Dialog_Box

Field Descriptions

Switch Commands

Clear Clears a traffic switch on the card or port highlighted under Selected Group

Manual (1+1, splitter, and Y-cable protection groups only) Initiates a manual switch on the 
selected port. This command switches traffic only if the path has an error rate less than 
the signal degrade (SD) bit error rate threshold.

Force (1+1, splitter, and Y-cable protection groups only) Initiates a forced switch on the 
selected port. This command switches traffic even if the path has SD or signal fail (SF) 
conditions. A Force switch has a higher priority than a Manual switch.

Lockout Commands

Unlock Clears a lockout.

Lock Out Prevents traffic from being switched to the card. Lockouts can only be applied to protect 
cards (in 1+1, splitter, and Y-cable configurations) and prevent traffic from switching 
to the protect port under any circumstance. Lockouts have the highest priority.

Lock On Locks traffic on to the working card, that is, prevents a traffic switch from occurring. 
In a 1+1 configuration you can also apply a lock-on to the working port. A working port 
with a lock-on applied cannot switch traffic to the protect port in the protection group 
(pair). For splitter and Y-cable protection groups, Prime Optical allows Lock On for a 
protect port if other switch conditions (Manual, Force) exist. Lock On is not available 
if the protect port already has a Lock Out or Lock On present.
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% Link utilization = ([Bandwidth consumed] / [Total bandwidth of link]) x 100

Example: In SONET, for an OC12 link, the total bandwidth is (12 x 51.84) Mb/s, where STS-1/OC12 = 
51.84 Mb/s.

Depending on the number of provisioned circuits, the consumed bandwidth is totaled. Circuits such as 
VAP/LAP and virtual tributary (VT) tunnel are preprovisioned and are not included in the calculation. 
This is applicable to SONET and SDH. 

Example: In SDH, for an STM4 link, the total bandwidth is (4 x 155) Mb/s, where STM-1 = 155 Mb/s.

Note • Link utilization does not apply to server trails. An error message is displayed if you attempt to 
launch the Link Utilization table from a server trail.

• The customize table view function is not available for the Link Utilization table.

To view the Link Utilization table:

Step 1 In the Domain Explorer window, choose Configuration > Link Table. The Link table opens.

Step 2 In the Link table, choose Configuration > Link Utilization Table (or click the Open Link Utilization 
Table tool). The following table provides descriptions.

Note You can launch the Circuit Trace window from a selected circuit in the Link Utilization table. 
Select a circuit in the Link Utilization table and then choose View > Circuit Trace. See 
7.2.20 Tracing Circuits, page 7-159.

Table 3-16 Field Descriptions for the Link Utilization Table

Column Description

STS ID (SONET only) Displays the STS ID.

VT1.5 ID (SONET only) Displays the VT 1.5 ID.

VT2 ID (SONET only) Displays the VT2 ID.

VC4 ID (SDH only) Displays the VC4 ID.

VC3/TUG3 ID (SDH only) Displays the VC3/TUG3 ID.

TUG2 ID (SDH only) Displays the TUG2 ID.

VC12 ID (SDH only) Displays the VC12 ID.

VC11 ID (SDH only) Displays the VC11 ID.

Circuit Name Displays the name of any circuits passing through the link. When Unused appears in the 
Circuit Name field there is unused bandwidth available, and the Circuit Type, Circuit 
Protection Type, Customer ID, and Service ID fields are blank.

Circuit Alias Displays a unique alias name for the new circuit. The alias name can contain alphanumeric 
characters. It also supports international character sets.

Circuit Type Displays the circuit type.

Circuit Protection Type Displays the circuit protection type.
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3.6.9.1 Launching the Link Utilization Table for SONET/SDH or OTS Links from the Network Map

Step 1 In the Domain Explorer or Subnetwork Explorer tree, click a node and choose File > Network Map (or 
click the Open Network Map tool).

Step 2 Right-click a SONET/SDH or OTS link in the Network Map and choose Link Utilization from the 
right-click menu.

3.6.9.2 Configuring the Span Switch State on a UPSR Protected Circuit

Note The span switch is applicable to all UPSR circuits in the Link Utilization table. The selection context 
has no impact on the switching. When you perform protection switching after selecting an unprotected 
circuit, the protection switch applies to only UPSR-protected circuits.

Step 1 In the Domain Explorer window, choose Configuration > Link Table. The Link table opens.

Step 2 In the Link table, choose Configuration > Link Utilization Table (or click the Open Link Utilization 
Table tool).

Step 3 In the Link Utilization table, choose Configuration > Span Switch > CLEAR, MANUAL, FORCE, or 
LOCKOUT_OF_PROTECTION.

Note Switch states that cannot be applied are dimmed.

Switch State Displays the switch state for UPSR protected circuits only. Values are:

• CLEAR—Removes a previously set switch command.

• MANUAL—A manual switch is active on the span.

• FORCE—A force switch is active on the span.

• LOCKOUT_OF_PROTECTION—A protection lockout is active on the span; traffic 
cannot be switched to the span.

Note A force switch always overrides a manual switch. A protection lockout always 
overrides both a force switch and a manual switch.

To configure the span switch state, see 3.6.9.2 Configuring the Span Switch State on a UPSR 
Protected Circuit, page 3-49.

Note N/A is displayed for non-UPSR-protected circuits.

Customer ID Displays the user-defined customer ID.

Service ID Displays the user-defined service ID number.

Table 3-16 Field Descriptions for the Link Utilization Table (continued)

Column Description
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The possible switch state that can be applied to the circuits in the Link Utilization table is decided by 
switch priority. The switch priority order is:

1. MANUAL

2. FORCE

3. LOCKOUT_OF_PROTECTION

4. CLEAR

Note The CLEAR switch state overrides all other switch states.

Example 3-1 Unprotected OC-48 Link

1 - In Use
2 - In Use
3 - In Use
4 - VT Mapped (VTs 1-4 in use)
5 - Available
...
48 - Available

STS Utilization = 4/48 = 8.3%
VT Utilization = (3x28 + 4)/(28 x 48) = 6.5%
STS PCA Utilization = N/A
VT1.5 PCA Utilization = N/A

Example 3-2 2-Fiber BLSR OC-48 Link

1 - In Use
2 - In Use
3 - In Use
4 - VT Mapped (VTs 1-4 in use)
5 - Available
...
24 - Available
25 - STS PCA Circuit In Use
26 - 8 VT1.5 PCA circuits In Use
27 - Protection
...
48 - Protection

STS Utilization = 4/24 = 16.7%
VT-1.5 Utilization = (3x28 + 4)/(28 x 24) = 13.1%
STS PCA Utilization = 2/24 = 8.2%
VT-1.5 PCA Utilization = (1x28 + 8)/(28 x 24) = 5.4%

 

3.6.10 Filtering the Link Utilization Table

Step 1 In the Link Utilization table, choose File > Filter (or click the Filter Data tool). The Filter dialog box 
opens.
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Step 2 Specify the filter parameters described in the following table.

Step 3 Click OK to run the filter.

3.6.11 Setting OTS Link Capacity
You can set the maximum number of wavelengths on one or more OTS links.

Step 1 In the Link table, select a single OTS link or multiple OTS links, and choose Configuration > Set OTS 
Link Capacity (or click the OTS Link Capacity window icon).

Step 2 Enter the maximum number of wavelengths for the selected OTS links.

Step 3 Click Apply. A Link Capacity Set Result window appears and summarizes the number of links that were 
configured or have failed.

Note A warning message appears when you select links of different layers.

Step 4 Click on the OTS success link to launch the report. The results can be printed in a text report.

3.6.12 Viewing OTS Link Utilization and Circuits
The OTS Link Utilization Report displays utilization information for the selected OTS links. OTS link 
utilization, shown as a percentage, displays the resources used. You can also view associated circuit 
names, types and wavelengths.

To view the Link Utilization and Circuit reports:

Step 1 In the Domain Explorer window, choose Configuration > Link Table. The Link table opens.

Step 2 Select the OTS links that you want to view utilization for.

Step 3 In the Link table, choose Configuration > OTS Link Utilization Report (or click the Open Link 
Utilization Report icon).

Step 4 From the OTS Link Utilization Report, select the link that you want to view associated circuit names, 
types, and wavelengths for.

Table 3-17 Field Descriptions for the Link Utilization Table Filter Dialog Box

Payload Type Description

SONET You can filter on the STS ID to see circuits going through that STS only. Select All 
to see all the tributaries on that link.

SDH You can filter on specific VC4, VC3/TUG3, and TUG2 IDs. The ALL option shows 
all tributaries. The None option is available on VC3/TUG3 and TUG2. Using None, 
you can select VC4 circuits (including VC LO Path Tunnel and LAP).
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Step 5 Click the Open Circuit Report icon.

If the Auto-Refresh check box is checked in the OTS Link Utilization Report window, the respective 
rows are automatically highlighted when a circuit undergoes a change. When the Auto-Refresh check 
box is not unchecked, a notification bar appears at the top of the window, stating that the reported data 
has changed. To refresh the report, click the Refresh tool.

If the report consists of more than one page, the Previous Page and Next Page arrows at the top-right 
corner of the Circuit Report window are enabled. The Pagination Settings tool allows you to select the 
number of records per page to display.

The status bar at the bottom of the OTS Link Utilization Report window displays:

• Current page number

• Total number of pages in the report

• Number of records displayed

• Number of records selected

To move to a specific page, enter the page number in the Page text box and press Enter.

3.6.13 Exporting the OTS Link Utilization Report
To export the OTS Link Utilization Report, complete the following steps:

Step 1 In the OTS Link Utilization Report window, choose File > Export to CSV (or click the Export to CSV 
tool). The Export to CSV dialog box appears.

Step 2 Specify the filter parameters described in the following table.

Step 3 Click OK to export.

Table 3-18 Field Descriptions for the Export to CSV Dialog Box

Field Description

Separator Character Allows you to select a separator character. Values are Comma, Tab, and Other.

Note If you select Other, enter a value in the text box next to the Separator 
Character drop-down list.

Data to Export Allows you to define the rows to be exported. 

Values are:

• All {0} Selected Records

• All Records at Page {0}

• Entire Table

Note The first option is available only if at least one record is selected. The 
second option is available only if there is more than one page.

Export File Click Browse to select the location to which you want to export the file.
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3.7 How Do I Build Server Trails?
A server trail is a subnetwork connection within a network that interconnects ONS 155xx edge 
connection termination points (CTPs). Some limitations of server trails are:

• A server trail connection should not cross the port boundary. For an NxVC4 server trail connection, 
all N-VC4 terminations must be on the same port.

• Users with permissions to manage links can also manage server trails. Link preferences and not 
circuit preferences are applied for server trail operations, even though the server trails terminate on 
CTPs. A user might therefore be allowed to create an STS-1 server trail but not able to create STS-1 
circuits (if that circuit size is not allowed for the user).

• Server trail connections cannot be provisioned on DCC-enabled ports. If DCC is enabled on a port, 
you cannot use the port as the source or destination for the server trail.

• You cannot change the size of an existing server trail.

• Multiple server trails can start from the same PTP. On a given PTP, the server trail can be of different 
connection types.

• Only one server trail can start from a CTP. CTPs of multiple server trail connections should be of 
the same type.

• Server trail connections cannot overlap each other.

• The sum of server trail sizes for an existing port cannot exceed the size of the port.

• Any alarm on a physical port affects all links that have an endpoint on that port, including all server 
trail links. For example, an alarm that has a port as its physical location affects all server trails, even 
if the affected object is a specific VC within that port.

Following are the differences between manual links and server trails:

• Manual links occupy an entire port while server trails occupy parts of a port. This means that a single 
port can terminate only one link but several server trails.

• Manual links can terminate on optical cards. Server trails can terminate on optical and electrical 
cards.

• Manual links can be created on DCC-enabled ports, while you cannot create server trails using 
DCC-enabled ports.

• The endpoints of manual links should be the same size. The endpoints of server trails can be 
different sizes and types.

3.7.1 Creating Server Trails

Step 1 Select the source NE in the Domain Explorer or Subnetwork Explorer and choose Configuration > 
Create Server Trail (or right-click the NE and choose Create Server Trail). The pointer changes to a 
plus (+) symbol; select the destination NE. The Create Server Trail wizard opens.

Step 2 In the Server Trail Attributes pane, specify the following:

• Type—Select the type of server trail to create.

• Size—Select the size of the server trail. The options displayed depend on the type selected.

• Protection—Select the server trail protection type. 

• Number of Trails—Enter the number of trails.
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• Shared Risk Link Groups—Enter a free-format string that represents the shared risk link group or a 
group of links that share a common risk.

• Cost—Specify the numeric cost associated with the server trail.

Step 3 Click Next.

Step 4 In the Source pane, set the server trail source. The options displayed depend on the server trail type 
selected in the Server Trail Attributes pane.

Step 5 Click Next.

Step 6 In the Destination pane, set the server trail destination. The options displayed depend on the server trail 
type selected in the Server Trail Attributes pane.

Step 7 Click Finish. The server trail is listed in the Link table. You can also view the server trail in the Network 
Map.

Note Server trails that were created in Prime Optical or CTC are listed in the Link table. Open the Link table, 
and you will see that the value of the Link Provision Type field for server trails is Server Trail. See 
3.6.3 Viewing the Link Table, page 3-34 for more information.

3.7.2 Modifying Server Trails

Step 1 Open the Modify Link wizard using one of the following methods:

• In the Link table, select a server trail and choose Edit > Modify Link (or click the Modify Selected 
Link tool).

• In the Network Map, select a server trail and choose Configuration > Modify Link (or click the 
Modify Selected Link tool).

Step 2 In the Link Attributes panel, modify the following information, as needed:

• Name

• Alias

• Description

• Cost

• Shared risk link groups

Note If you modify the SRLG value, you receive the warning popup “There might be circuits 
routed with diverse SRLG constraints on this link. Changing risk link groups might affect 
the diversity constraint.” Click OK; then, verify the SRLG value that you entered.

Step 3 Click Next.

Step 4 Verify the link summary and click Finish.
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3.7.3 Deleting Server Trails

Step 1 In the Link table, select a server trail and choose Edit > Delete Link (or click the Delete Selected Link 
tool). In the Network Map, select a server trail and choose Configuration > Delete Link.

Step 2 Click OK in the confirmation dialog box. 

3.8 How Do I Use Network Maps?
The Network Map is organized into a multilevel hierarchy that corresponds to the structure of the 
Domain Explorer tree. The Network Map hierarchy consists of management domains, groups, and NEs 
that are displayed graphically.

Network Map backgrounds are provided by default as part of Prime Optical and are used to display a 
geographical layout of the network.

By default, the Network Map consists of the following areas:

• Center pane—Displays the map with individual groups, NEs, and link icons.

• Explorer pane—Displays a Search text box and Domain Explorer tree.

• Overview pane—Shows the position of the displayed map with respect to a larger world map.

• Properties pane—Displays the domain or group properties, including the number of alarms and the 
ID. It also displays the properties of selected links.

The Explorer pane in the Network Map contains a Search text box and the Domain Explorer tree. The 
Search text box allows you to search for NEs based on one or all of the following parameters:

• NE ID

• NE Alias ID

• NE IP Address

• NE Version

• NE Description

• NE Location Name

• Group Name

• NE Operational State

• NE Communication State

• NE Model

From the Search drop-down list, choose the parameter to search by, and enter appropriate data in the text 
box.

You can select one node or multiple nodes from the Domain Explorer tree in the Topology pane.

Tip Hold down the Shift key to select more than one node sequentially, or hold down the Ctrl key 
to select more than one node nonsequentially.
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When you right-click a node in the Topology pane or on the map, a popup menu is displayed, from which 
you can select one of the following options: 

• NE Explorer—Displays the NE Explorer for the selected node.

• Equipment Inventory Table—Displays the Equipment Inventory Table of the NE.

• Alarm Browser—Displays the Alarm Browser for the NE.

• Alarm Log—Displays the Alarm Log for the NE.

• Delete Map Element—Allows you to delete the selected node from the map.

• Create Link—Allows you to create a link between NEs.

• Create Server Trail—Allows you to create a server trail for the selected NE.

• Create Circuit—Allows you to create a circuit.

• Search Circuits—Displays the Circuit Search window.

• Circuit Report—Displays the Circuit Table for the NE.

• Link Table—Displays the Link Table for the NE.

• Test NE Connectivity—Tests connectivity to the NE.

• Change State—Allows you to change the state of the NE by selecting one of the following options:

– Mark In Service

– Mark Out of Service

– Mark Under Maintenance

• Network—Allows you to view details of the NE selected on the map.

Note The popup menu is also displayed when you select and right-click multiple nodes of the same type. 
However, the following options are disabled: NE Explorer, Equipment Inventory Table, and Test NE 
Connectivity.

Unplaced NEs, or NEs for which the coordinates on the related Network Map are initially null, are 
represented in italics in the Domain Explorer tree of the Explorer pane. Checking the Unplaced check 
box in the Explorer pane filters the tree view to show only the unplaced NEs.

The Properties pane in the Network Map window displays domain or group properties and allows you to 
perform certain actions.

The following links are available at the bottom of the Properties pane:

• NE Explorer—Displays the NE Explorer for the selected node.

• Equipment Inventory Table—Displays the Equipment Inventory Table of the NE.

• Alarm Browser—Displays the Alarm Browser for the NE.

• Test NE Connectivity—Tests connectivity to the NE.

• Circuit Table—Displays the Circuit Table for the NE.

• Link Table—Displays the Link Table for the NE.

In the Overview pane, you can view the position of the displayed Network Map with respect to a larger 
world map and adjust the pan position of the Network Map.
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Note The Explorer, Properties, and Overview panes can be docked, floated, or auto-hidden. These panes can 
also be grouped into a single tabbed pane by dragging and dropping one pane into another. In this case, 
each pane appears as a tab within a panel. From the Customize icon at the top-right corner, you can also 
select which of these panes to display.

3.8.1 Customizing a Network Map
Use the Edit menu and toolbar buttons to customize your network map.

Step 1 In the Domain Explorer tree, click a node and choose File > Network Map (or click the Open Network 
Map tool).

Note There is no Network Map for the Discovered Network Elements or Deleted Network Elements 
groups.

Step 2 Use the Edit menu in the Network Map window to customize the Network Map. Edit menu options 
include:

• Toggle Selection—Selects elements that you click on the map.

• Filter—Filters the network map by NEs, groups, or links.

• Toggle Panning—Pans across the map.

• Set Background—Allows you to set the map background.

• Zoom Magnify—Magnifies the area on the map where the pointer is placed when the left mouse 
button is held down.

• Zoom In—Zooms in on an object in the map view.

• Zoom Out—Zooms out on the map view. 

• Zoom to Fit—Adjusts the view of the map to fit the window.

• Zoom Area—Lets you pan and zoom the view to a different region of the map.

• Zoom Magnify—Magnifies the area under the lens.

• Expand/Collapse Group—Shows or hides NEs contained in a group selected on the map.

Note A group on the map can be expanded if all of its nodes have a coordinate set at the given level. 
When a group is expanded, all nodes and subgroups are displayed around the expanded group. 

• Collapse All Groups—Hides NEs contained in all groups on the map.

• Expand All Links—Shows links contained in an aggregate link.

• Collapse All Links—Hides links contained in an aggregate link.

• Grid Layout—Arranges nodes in a grid pattern.

• Explorer Mesh Layout—Arranges nodes in planar or nonplanar cyclic patterns.

• Uniform Length Edges Layout—Arranges nodes in patterns with edges of uniform length.
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• User Preferences—Opens the User Preferences dialog box to set user preferences for options such 
as event notification and time.

Note Users with SuperUser privileges can configure labels for various nodes and device icons.

3.8.2 Viewing a Node on the Network Map
Icons on the Network Map are displayed based on the nodes you select in the Domain Explorer. Nodes 
on the Network Map do not have a default position unless one has been configured in a Network Partition 
Map or a SuperUser has configured one in the current map.

Launching the Network Map from the following nodes displays varying results:

• From the Prime Optical domain in the Domain Explorer—Displays all the groups and individual 
nodes in the Prime Optical domain.

• From a specific group in the Domain Explorer—Displays all NEs that belong to that group.

• From a specific NE in the Domain Explorer—Displays the parent group that the selected NE belongs 
to.

• From a specific network partition in the Subnetwork Explorer—Displays all the NEs in that network 
partition.

3.8.3 Adjusting the Zoom Level or Pan Position
When the Network Map is launched from the Prime Optical domain, it displays a world map with the 
individual groups, network partitions, and NE icons. To view a particular region or icon, you adjust the 
zoom level or pan position.

Step 1 In the Domain Explorer or Subnetwork Explorer tree, click a node and choose File > Network Map (or 
click the Open Network Map tool). The Network Map opens with the node preselected.

Step 2 Do any of the following:

• To adjust the zoom level, do either of the following:

– On the Network Map, choose Edit > Zoom In, Zoom Out, Zoom to Fit, or Zoom Area. 

– Click the Zoom In, Zoom Out, Zoom to Fit, or Zoom Area tool.

• To adjust the pan position, choose Edit >Toggle Panning and use the mouse to pan across to the 
desired region on the map.

• View or hide the links contained in each link bundle (aggregate link):

– To view links, click a link bundle and choose Edit > Expand All Links (or double-click a link 
bundle to show all the links)

– To hide links from view in the Network Map, click a link bundle and choose Edit > Collapse 
All Links.

The following table describes how the zoom tools at the right of the Network Map work.
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Note When the network map is zoomed in to show the entire node icon, the related device icons and labels are 
displayed. When the zoom level is low, only the Alarm Severity icon for each node is displayed. When 
zoom magnify is applied to the Alarm Severity icon, the entire node icon is visible, along with the related 
device icons and labels.

3.8.4 Modifying a Map Background Image
Network map backgrounds are provided by default as part of Prime Optical, and are used to display a 
geographical layout of the network. The icons in the Network Map can be customized. See Appendix A, 
“Icons and Menus Displayed in Prime Optical” for details of all the icons displayed in the Network Map 
window.

Prime Optical supports nonanimated GIF, JPG/JPEG, PNG, and shapefile format icons and maps. 
Shapefile is a universal standard for data files and allows users to zoom in and zoom out without losing 
details.

To modify a map background:

Step 1 In the Domain Explorer tree, click a node and choose File > Network Map (or click the Open Network 
Map tool).

Step 2 In the Network Map window, choose Edit > Select Background. The Select Background dialog box 
opens.

Zoom Tool Description

Zoom In Zoom in on an object in the map view. 

This tool increases the size of all of the graphic objects on the map.

Zoom Out Zoom out on the map view. 

This tool decreases the size of all of the graphic objects on the map.

Zoom Slider Adjust the zoom level of the map by moving the slider up or down between the 
Zoom In and Zoom Out icons.

Toggle Selection Select elements on the map.

Toggle Panning Pan across the map. 

You can move your view of the map up and down as well as left and right.

Zoom Area Pan and zoom the view to a different region of the map. 

Hold down the left mouse button and use the Zoom Area box to highlight an area 
on the map. When you release the left mouse button, the zoom is applied to the 
selected area of the map.

Zoom to Fit Click to adjust the view of the map to fit the window.

Zoom Magnify Magnify the area under the lens. 

Click the zoom magnify icon, point to the map region that you want to magnify, 
and hold down the left mouse button. The area is magnified until the left mouse 
button is held down.
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Step 3 Select a background image from the list of existing background images. The selected image appears in 
the Preview area.

Note If you want to add a new background image to the list, click the Add tool at the top of the list, browse, 
and select the file to be added. In the Data area on the right, you can provide the name, description, and 
additional files if any, for the newly added background image. Clicking the Save tool in the Data area 
will save the attributes you entered for the background image.

Step 4 After choosing a map background, click Apply. The new map background appears in the network map.

Step 5 Select the No Background check box if you do not want a background image displayed for the network 
map.

Step 6 Choose File > Save Map Settings to save your settings.

Note You can edit the name and description, and change or upload new files for an existing background image, 
by selecting the row and editing the fields in the Data area. You can delete files for a selected background 
image by clicking the Remove tool in the Data area.

You can also delete an existing background image by selecting it from the list and clicking the Remove 
tool at the top of the list.

3.8.5 Configuring the Network Map View
Prime Optical allows you to configure the appearance of the graphical components on the network map. 
You can set how nodes, groups, and links appear.

To configure the network map view:

Table 3-19 Field Descriptions for the Select Background Dialog Box

Field Description

Current Background Read-only. Displays the name of the current map background.

Name Read-only. Lists the names of the map background images.

Type Read-only. Displays the format of the corresponding map background image. Values include 
jpeg, shape, gif, and png.

Size Read-only. Displays the size of the map background image in KB or MB.

Added By Read-only. Displays the name of the user who added the image, and the time stamp.

No Background Check this check box if you do not want a background image for the network map.

Data Area

Name Enter the name of the map background image that you are uploading.

Description Enter a description for the map background image that you are uploading.

Files Displays the files added for the selected background image.
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Step 1 In the Network Map window, choose Edit > Global Network Map Configuration.

Step 2 On the Node tab:

• In the Badges area, from the list of badges, drag and drop the badges to be displayed on the nodes 
in the map. The badges available are:

– Multishelf

– WSON State

– Node Role

– Admin State

– Alarm

– Discovery State

– Connection State

• From the Labels area, drag and drop the labels to be displayed for each node. The labels to choose 
from include:

– Alias

– Model Type

– IP Address

– Software Version

• If you want the alarm to be highlighted on the map, check the Highlight on Alarm check box.

Step 3 On the Group tab, check one or both check boxes (Alarm or Connection State) to display the Alarm or 
Connection State badge for the group on the network map.

Step 4 On the Link tab:

• Enter the desired values for the following:

– Width of the link

– Distance between links

– Width of the links for a bundle

– Minimum number of links for a bundle

• If you want to hide all links in a bundle on the network map, select the Bundle Collapsed by Default 
check box.

• If you want the DWDM side for the links displayed on the map, select the Show DWDM Side check 
box in the Link Attributes section.

• Specify how frequently you want the links refreshed on the map, by selecting the Refresh Interval 
in the Link Refresh Interval section.

Note The default value for the Refresh Interval is 15 minutes.

Step 5 Click OK.
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3.8.6 Saving Changes to the Network Map

Step 1 In the Domain Explorer or Subnetwork Explorer tree, click a node and choose File > Network Map (or 
click the Open Network Map tool).

Step 2 After making the necessary changes to the map background, map position, zoom level, node icon, or 
node coordinates in the Network Map window, Choose File > Save Map Settings to save your settings.

Depending on the user type and the settings saved, one of the following happens:

• SuperUser saves background and coordinates for:

– Network partition map—Settings are saved as Absolute settings for the map.

– Domain map—Settings are saved as System settings for the map.

• Operator or Provisioner saves settings for domain map—Settings are saved as Custom settings for 
the user.

3.8.7 Searching for Circuits
Prime Optical 9.6.3 allows you to search for circuits from the Network Map window by selecting one or 
multiple NEs. 

You can search for circuits using the Network Map in the following ways:

• Right-click an NE on the map and choose Circuit Search.

• Right-click a link on the map and choose Circuit Search.

• Use the Enter Search Query text box available at the top of the network map.

The circuits associated with the selected NEs are displayed in a dockable Circuit Search window at the 
bottom of the Network Map window. If you select another NE in the network map, and want to refresh 
search results, click the Sync tool at the top of the Circuit Search window.

The Circuit Search window allows you to view the links on the map for a selected circuit. When you 
click the Toggle Path Trace tool at the top of the Circuit Search window, the links that contain the 
selected circuits are highlighted in yellow on the map.

You can launch the Circuit Report from the Circuit Search window, by clicking the Circuit Report tool 
at the top. You can also filter, and export the search results by choosing the appropriate tools.

Note See Appendix A, “Icons and Menus Displayed in Prime Optical” for an explanation of the icons in the 
Circuit Search window.

The Enter Search Query text box in the Network Map window allows you to search for circuits by the 
following attributes:

• Alias

• Customer

• Description

• Name

• Service
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• Type

Press Ctrl-Space to display attributes and select from the list; then type a keyword to search by. You can 
use multiple keywords for the same attribute, and also select more than one attribute. All circuits with 
either of the attributes mentioned are displayed in the search results.

Note Clicking the Help icon within the Enter Search Query field displays hints and examples to help 
you search for circuits effectively.

3.9 How Do I Discover the Network for Optical Devices?
The Prime Optical discovery service collects information from individual CTC-based and ONS 155xx 
NEs; discovers new NEs added to the network; updates network-level information (such as physical 
topology, logical circuits, and discrepancies); and updates device-level information (such as inventory 
and alarms).

When you add a new NE to Prime Optical, the discovery process starts. When the process finishes, all 
of the NE information (such as inventory, configuration, physical topology, and discrepancies) is 
collected and Prime Optical is updated.

Note The Discovered Network Elements group can be viewed only by users who have all NEs assigned to 
them. Therefore, in the Add New NE wizard, the grouping option “Group discovered NEs in the 
Discovered Network Elements Group” is not available.

3.9.1 Discovering CTC-Based NEs
When a CTC-based NE is added as a GNE, the following NEs are discovered automatically:

• All NEs that are DCC-connected to the GNE

• All NEs that are connected to the GNE by any link other than a manual link

The discovered NEs are added automatically to Prime Optical. The location of new NEs depends on the 
location you specified in the discovery wizard.

Alternatively, for CTC-based NEs, you can choose to manually discover NEs and add them to a specific 
network partition. You can disable discovery when the NEs are being added to the network partition. To 
choose the discovery mode:

Step 1 Choose Administration > Control Panel.

Step 2 From the left panel, expand the CTC-based SDH or CTC-based SONET service and choose a network 
service instance. The property sheet is displayed.

Step 3 Choose a discovery mode (Manual or Automatic).
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3.9.2 Discovering ONS 155xx NEs
When you add a new ONS 155xx NE to Prime Optical, the discovery process starts. When the process 
finishes, all of the NE information (such as inventory, configuration, physical topology, logical circuits, 
and discrepancies) is collected and Prime Optical is updated. In addition, neighbors of the added NE are 
discovered. To discover new neighbors, the discovery service relies on CDP neighbor information and 
topology neighbor information obtained from the NEs.

The ONS 155xx discovery service uses the following measures to keep the NE and network information 
in Prime Optical synchronized with the NEs themselves:

• Periodic rediscovery based on the resynchronization interval. Periodic rediscovery brings the 
information in Prime Optical up to date for all ONS 155xx NEs in the network and rediscovers any 
new neighbors. You can view and reset the synchronization interval in the Control Panel. (For 
information about resetting the resynchronization interval, see 3.9.5 Resetting the Resync Interval, 
page 3-68.) If at least one ONS 155xx is already in the system, the first periodic rediscovery starts 
when the ONS 155xx NE service starts. The NE service usually starts when the Prime Optical server 
is restarted. If no ONS 155xx NEs are in the system when Prime Optical restarts, the first periodic 
discovery starts when the first ONS 155xx is added.

• Event-triggered rediscovery launched by certain changes to ONS 155xx NEs. Event-triggered 
discovery incrementally updates Prime Optical with the new information. New neighbors of the 
affected NE are discovered. The device changes that trigger rediscovery include, but are not limited 
to, the following: reboot, CPU switchover, patch and topology changes, and insertion and removal 
of physical components.

• User-requested rediscovery. Users can request rediscovery of selected ONS 155xx NEs or the entire 
ONS 155xx network at any time. This updates Prime Optical with information about the NEs. For 
more information about using rediscovery commands, see 3.9.3 Rediscovering ONS 155xx NEs, 
page 3-65.

Note Only active NEs (NEs that are in the In Service or Under Maintenance states) can participate in the 
rediscovery process.

 

3.9.2.1 Discovery Information Table

The Discovery Information table displays discovery information for individual devices and for main 
discovery. The main discovery includes the discovery of individual devices plus network-level 
computations for topology, discrepancies, and logical circuits. The Discovery Information table shows 
all types of discovery: periodic rediscovery, user-requested rediscovery, and update-triggered discovery. 
To view the table, choose Configuration > ONS 155XX > Discovery Info Table in the Domain 
Explorer.
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The following table describes the fields in the Discovery Information table.

 

3.9.3 Rediscovering ONS 155xx NEs
The Rediscover and Rediscover All commands perform a rediscovery of selected ONS 155xx NEs or 
of the entire ONS 155xx network. Rediscovery updates Prime Optical with current network-level 
information (such as physical topology, logical circuits, and discrepancies) and device-level information 
(such as inventory and alarms).

Note Periodic rediscovery occurs every 24 hours, and certain changes on the device can trigger incremental 
rediscovery.

Start rediscovery from any of the following windows:

• Domain Explorer

• Subnetwork Explorer

• Network Map

Note Only users with the appropriate privileges can use the Rediscover All command.

Step 1 To rediscover selected NEs, select NEs or groups of NEs and choose Configuration > ONS 155XX > 
Rediscover.

Table 3-20 Field Descriptions for the Discovery Information Table

Field Description

Discovered NE NE system ID of the NE selected for discovery, or Main for the main discovery.

Start Time 
(time stamp)

Discovery start time. When the element name is an NE system ID, the elapsed time between start time and 
end time represents the amount of time required to discover the individual device. When the element name 
is Main, the elapsed time between the start time and end time includes: 

• The time required to discover all of the individual NEs that participated in the current discovery cycle

• The time required for the network-level computations for topology, discrepancy, and logical circuits

End Time 
(time stamp)

Discovery end time (if the discovery has completed).

Status Status of the discovery (whether it succeeded, failed, or is in progress). The status “idle” means that no 
discovery has ever occurred on the NE.

Start Mode How the discovery was started (periodic rediscovery, user-requested discovery, or discovery triggered by 
an update).

Description Type of discovery that was performed. If the discovery fails, this column includes a description of the 
cause of the failure.
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Note This command is unavailable unless at least one NE in the selection is in the In Service or Under 
Maintenance states.

Step 2 To rediscover all ONS 155xx NEs in the network, choose Configuration > ONS 155XX > 
Rediscover All.

Note This command is unavailable unless at least one NE in the network is in the In Service or Under 
Maintenance states.

Step 3 Click Yes in the confirmation dialog box to initiate rediscovery.

Rediscover and Rediscover All operations are available only for in-service or under-maintenance NEs. 
If you try to initiate rediscovery for NE(s) that are not in service or under maintenance, the Error Log 
records the following minor error:

Skipping rediscover for: NE-IP-address as its state is neither In Service nor Under 
Maintenance.

Note If a Rediscover process is already in progress on a single NE and you choose Rediscover again, the 
request will be accepted but not executed. Similarly, if a Rediscover All process is already in progress 
and you choose Rediscover All again, the request will be accepted but not executed.

. 

3.9.4 Viewing Manually Discovered NEs
Use the Orchestration Service pane to view the details of a discovery service and manage discovery 
processes. This page displays the status of a discovery service, which can be Running or Not Running. 
To view the Orchestration Service pane, choose Administration > Control Panel > Orchestration 
Service. 

Table 3-21 Field Descriptions for the Orchestration Service Pane

Field Description

Status Tab

Service Status Displays the status of the process associated with the discovery service. The status can be Running or Not 
Running. The Not Running status occurs only in the case of an unexpected system error.
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Discovery Properties Area

Select link types 
to evaluate 
during discovery 
of adjacent 
nodes

To complete the discovery process, you must select at least one of the following link types:

• Physical Links (including virtual links)—During the discovery process, all nodes that are connected 
by physical links are discovered. However, if the nodes are connected by virtual links, only the 
immediately adjacent node is discovered.

• Server Trails.

If you try to proceed without selecting a link type, the following message appears:

You must select at least one link type for evaluation during the discovery.

Select details to 
retrieve 

Check the details of the node you wish to retrieve during the discovery process. The details which you can 
retrieve are:

• NE model

• Software version

• NE role

The NE Model option is selected by default. If you deselect the option, the node is marked as Undefined 
NE in the Discovery Overview area (Domain Explorer > Undiscovered Network Elements). 

If you choose to discover additional details (Software Version and Connection Type), the discovery 
process will be slower. The following message appears:

The selected option(s) will slow down the discovery process.

By default, the node’s IP address is retrieved.

Maximum 
Timeout in 
Seconds

Enter a maximum timeout, after which the discovery is interrupted. The minimum timeout you can define 
is 30 seconds.

Debug Tab

Overall Logging Enable—Choose the Enable radio button to enable logging. When you choose the Enable radio button, the 
debug modules in the Available list become selectable.

Disable—Choose the Disable radio button to disable logging. When you choose the Disable radio button, 
the debug modules in the Available list become dimmed and you cannot make any selections.

Debug Modules Available—Select one or more debug modules in the Available list and click Add to move them to the 
Selected list.

Tip Hold down the Shift key to select more than one debug module sequentially. To select multiple 
debug modules nonsequentially, hold down the Ctrl key on your keyboard while using your mouse 
to select multiple debug modules.

Selected—Select one or more debug modules in the Selected list and click Remove to move them to the 
Available list.

Save button After making your selections, click Save. Changes take effect immediately.

Table 3-21 Field Descriptions for the Orchestration Service Pane (continued)

Field Description
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3.9.5 Resetting the Resync Interval
The Resync Interval setting displays the frequency at which the configuration is rediscovered, retrieved, 
and processed for the NEs. The following information is retrieved:

• General system information including node name, system time zone, SNTP configuration, and 
power monitoring information

• NE’s network information including IP address, static routes, OSPF, and RIP configuration

• Card provisioning data

• DCC configuration

• Timing synchronization

• Protection group configuration

• Ethernet Spanning Tree configuration

• Alarm profiles

• Security configuration

• NE defaults

• Routing table and protocol information

Complete the following steps to reset the resync interval:

Step 1 In the Domain Explorer window, choose Administration > Control Panel.

Step 2 Expand NE Service.

Step 3 Select an NE and change the Resync Interval field in the Resync Scheduling area.

Step 4 Click Save.

3.9.6 Discovering CRS-1 and CRS-3, NEs
Using Prime Optical, you can discover CRS-1, CRS-3 R4.2.3 and CRS-3 R4.3.0 NEs that are connected 
to a DWDM ONS 15454 NE using a virtual transponder. You can also manage the IP traffic that is 
exchanged in the CRS-1 and CRS-3 networks using the optical DWDM transport network. This is 
possible because of the presence of virtual transponders and DWDM colorless cards. Prime Optical does 
the following:

• Discovers the links that connect the ONS 15454 cards to the CRS-1 and CRS-3 virtual transponder 
cards. 

• Discovers and manages CRS-1 and CRS-3 NEs. 

• Discovers and manages OCH trail circuits between the CRS-1 and CRS-3 virtual transponder cards 
and the DWDM optical network. The following cards support OCH trail circuits:

– Cisco CRS-1 1 x OC768 DPSK+ (C-band) DWDM PLIM 

– Cisco CRS-1 1 x OC768 (C-band) DWDM PLIM 

– Cisco CRS-1 4 x 10GE (C-band) DWDM PLIM

– DWDM PLIM LINE card 10 GE

– DWDM PLIM LINE card 100 GE
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Note A virtual transponder is a virtual entity of the transponder cards. Prime Optical does not manage this 
type of equipment.

You cannot add a CRS-1 or CRS-3 NE directly to Prime Optical. For a CRS-1 or CRS-3 NE to be 
discovered and managed, it must be connected to Prime Optical through one of the following channels: 

• An ONS 15454 DWDM NE through a link management protocol (LMP) link

• An ONS 15454 SDH DWDM NE through a link management protocol (LMP) link

Using the APIs available in the CTC library, Prime Optical discovers CRS-1 or CRS-3 NEs using the 
ONS 15454 or the ONS 15454 SDH NE service.

In the Domain Explorer window, select the CRS-1 or CRS-3 NE that you want to view. The property 
sheet is displayed. To discover a CRS-1 NE, you must log in with the credentials of the ONS 15454 NE 
to which it is connected; the NE Authentication tab, therefore, is unavailable for CRS-1 NEs.

Note In order to manage the CRS-1 and CRS-3 nodes, you must be logged in as a root user.

The following limitations apply to the discovery of CRS-1 or CRS-3 NEs:

• A CRS-1 or CRS-3 NE cannot be directly added to Prime Optical as can other NEs. It is discovered 
only if it is connected to an ONS 15454 NE. 

• To discover a CRS-1 or CRS-3 NE, you must log in with the credentials of the ONS 15454 NE to 
which it is connected.

• You must use CTC to set up the physical connection between the ONS 15454 NE and CRS-1 NE or 
CRS-3. 

• You cannot create an LMP link between the CRS-1 or CRS-3 NEs and 15454 ONS NEs using Prime 
Optical. Prime Optical automatically discovers CRS-1 or CRS-3 NEs through an existing LMP link. 
Also, you cannot manually discover CRS-1 or CRS-3 NEs. For information on creating LMP links 
through CTC, see NTP-G164 Configure Link Management Protocol.

• The NE Explorer is not supported on CRS-1 or CRS-3 NEs.

Once discovered, the Link table represents the CRS-1 or CRS-3 NE as autodiscovered; for more 
information, see 3.6.3 Viewing the Link Table, page 3-34. The type of link is Unidirectional.

You can use CTC to create OCH trail circuits between two PLIM cards on CRS-1 or CRS-3 NEs. For 
more information, see NTP-G178 Create, Delete, and Manage Optical Channel Trails. To use 
Prime Optical to enable the OCH trail circuit, you must enable a specific trunk protection called 
proactive protection, which applies to all supported cards involved in circuit routing. To define the 
proactive protection parameters, choose Create Circuit Wizard > Trunk Filtering. For more 
information on populating the Proactive Protection panel, see Table 7-6.

3.10 How Do I Manually Discover NEs and Add Them to Specific 
Network Partitions?

Using the manual mode of discovery of NEs, you can decide the NEs and the adjacencies you want 
Prime Optical to discover; once enabled, the respective NE service no longer discovers and manages NEs 
automatically. This feature lets you take more control over the method in which the network partitions 
are populated. The following are the advantages of enabling this feature:
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• You can decide which NE needs to be added to which network partition. This is particularly useful 
if the partition reaches its threshold limit.

• You can partition a managed network into several network partitions without having to turn off the 
physical links connecting two NEs. 

• You can effectively delete the NEs that you choose to not be managed. Unless you explicitly add it 
to a network partition, the NEs remain unmanaged by the network service, even after subsequent 
discoveries.

Prime Optical discovers NEs through the manual mode in two phases:

1. Enabling the manual mode of discovery at the NE service level—Once you enable the manual mode 
of discovery at the service level, all nodes that are connected to a managed NE are not automatically 
added to the service unless specifically added by the user.

2. Managing the discovered nodes—Once the unmanaged NEs are discovered through the manual 
mode of discovery, you can specify the network partition to manage the discovered NEs.

Limitations of Manual Mode of Discovery

• This feature lets you choose the network partition that will be manage the specified NE. Because of 
this, the NEs that are not managed yet are identified as missing. These missing NEs can lead to 
incomplete discovery of services such as links, circuits, BLSR, and L2 topologies. 

• If you added NEs belonging to the same physical network (such as a DCN domain) to different 
network partitions, you have one of the following consequences:

– The links between the NEs that belong to different network partitions are not discovered.

– The services topologies (such as circuits, BLSR, L2, VLAN, and SVLAN—which consist of 
NEs that belong to different partitions) are partially discovered. Also, some of them might 
remain undiscovered.

– L1 circuits that are partially discovered are labeled Split in the Circuits table. This occurs when 
the source and destination nodes of the circuit belong to different partitions. In such a scenario, 
the circuit is marked Split, and is present in the partition to which its source is attached to. 

Note Services that are split are supported and provisioned only in case of manual mode of 
discovery.

3.10.1 Frequently Asked Questions

3.10.1.1 Mode of Discovery

Q. Can I change the mode of discovery for an existing service?

A. Yes. If you are a user with administrative privileges, you can change the mode of discovery of a 
CTC-based NE at any time. See 3.9.1 Discovering CTC-Based NEs, page 3-63.

Q. Can I change the mode of discovery from manual to automatic?

A. Yes; however, this is not recommended. Prime Optical considers the changed mode of discovery of 
NEs only during the first network topology change, such as change of a link state. If you need to 
change the mode, you must force the change by restarting the discovery of NEs, particularly those 
that are connected to devices that are not currently managed by the NE service.
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Q. Can I change the mode of discovery from automatic to manual?

A. Yes. By changing the mode of discovery to Manual, you stop the automatic discovery of NEs, thus 
limiting the number of devices managed by an NE service. This is particularly useful when the NE 
service is about to reach its threshold. This allows you to selectively discover and manage the NEs.

Q. Can I define the mode of discovery while adding a new NE?

A. Defining the mode of discovery applies more at the NE service level than at the NE level. You can 
set the mode of discovery while adding the first NE to an NE service. You cannot set the mode of 
discovery for NE services that have already been initiated. For more information, see 3.5.2 Adding 
NEs, page 3-13.

Note You cannot set the mode of discovery to manual for CRS-1 NEs. All connected CRS-1 NEs are 
added automatically to the partition to which the peer ONS 15454 NE belongs. 

3.10.1.2 Administrative Options

Q. What is the recommended link type setting for manual discovery?

A. Using the Control Panel > Orchestration Service pane, you can configure the initial set of options 
to be considered for the discovery process, one of which is the link type between the NEs. You can 
choose either Physical Links or Server Trails. Physical links include virtual links. With physical and 
virtual links, the information is cached locally. The information can be retrieved by querying a 
limited set of NEs. With server trails, the information is retrieved by contacting each NE. 

Choosing Server Trails as the link type has an inherent risk of high response time. Therefore, this is 
not recommended as the default setting. However, if server trail links are present in your network, 
you must select this link type to be able to complete the discovery process. For more information, 
see 3.9.4 Viewing Manually Discovered NEs, page 3-66.

Q. How do I set a default mode of discovery for all network partitions?

A. Using the Control Panel > UI Properties pane, you can choose a default option to be applied for 
all network partitions. 

– To set a default mode of discovery, and to disallow a change of the mode later, choose Control 
Panel > UI Properties. Uncheck the Allow Provisioning check box, and select a mode of 
discovery from the Default Discovery Mode drop-down list.

– To set a default mode of discovery, and to also allow a change of the mode later, check the Allow 
Provisioning check box. Select a mode of discovery from the Default Discovery Mode 
drop-down list. This lets you change the mode of discovery while creating a new NE service.

3.10.1.3 Discovery of Nodes

Q. How does the discovery of nodes work?
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A. Once you set the parameters to be considered for the discovery process in the Orchestration Service 
pane, the NE service starts discovering NEs in its managed network based on the parameters 
specified. For more information on setting the parameters for mode of discovery, see 3.9.4 Viewing 
Manually Discovered NEs, page 3-66. The following events occur during the discovery process:

1. The NE service begins to analyze the network topology without actually communicating with 
NEs. Following the physical links and the server trails existing between the nodes, it determines 
the NEs that are currently not discovered and managed. Only NEs that are either in In Service 
state or in In Service - Initializing state are considered for discovery.

2. Once the undiscovered NEs are identified, the Orchestration Service starts retrieving from the 
remote devices the additional information that you specified.

3. After retrieving the required information, the Orchestration Service makes the data available to 
all the GUIs.

Q. How can I track the status and execution of discovery?

A. The main stages of discovery are tracked in the Audit Log. You can filter the messages from the log 
table based on an NE service. 

To view the status of a discovery process, choose Domain Explorer > Undiscovered Network 
Elements. For information on undiscovered NEs, see 1.5.2.4 Undiscovered Network Elements, 
page 1-21.

Q. Can I limit the scope of discovery to reduce the waiting time?

A. When more than one NE service is configured in manual mode of discovery, you can choose the 
service for which you want the discovery process to begin first. Choose Domain Explorer > 
Undiscovered Network Elements; then, click Start Discovery. A table listing the available 
network partitions appears. Select the desired partitions.

Q. Should I wait for the discovery process to finish before I initiate the process for other nodes?

A. You can initiate the discovery process at any time. However, for a successful discovery, ensure that 
the following conditions are met:

– At least one NE present in the OSPF topology area must have been discovered—either in In 
Service state or in In Service - Initializing state.

– If you set the link type as Server Trails, all the NEs connected through server trails must have 
been fully discovered.

3.10.1.4 TMF CORBA Interface

Q. Is TMF CORBA supported?

A. The discovery mode does not support TMF CORBA. This feature is available only for GUI users. 
TMF CORBA users must interact with the Prime Optical GUI to define the discovery mode.
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3.11 How Do I Test Connectivity for Optical and Routing 
Devices?

The following sections describe how to test server connectivity to an NE. The following table explains 
the difference between pinging an NE and testing NE connectivity.

3.11.1 Pinging an NE

Step 1 In the Domain Explorer tree, select the NE to ping.

Step 2 Choose Fault > Ping NE. The ping results include round-trip time and packet loss statistics.

Step 3 Click OK in the dialog box.

Note This function is enabled if the operational state of the NE is In Service or Under Maintenance. It is 
disabled if the operational state of the NE is Out of Service or Preprovisioned.

Note A link to the ping utility must be present in your PATH variable on the Prime Optical server. The default 
location is /usr/sbin/ping. If a link to the ping utility is not present in your PATH variable, configure your 
PATH settings to include it.

3.11.2 Testing NE Connectivity

Step 1 In the Domain Explorer tree, select an NE.

Step 2 Choose Fault > Test NE Connectivity. The Test NE Connectivity operation runs the ping command to 
check the NE communication state. The results show whether the NE is available or unavailable:

Table 3-22 Testing NE Connectivity

Method Description

Ping NE Pinging the NE uses the standard UNIX ping command to verify IP connectivity between the Prime Optical 
server and an NE. If successful, the ping results include the NE’s IP address, round-trip time, and packet 
loss statistics. A response of “Request timed out” means there was no response to the ping attempt. If the 
ping is unsuccessful, verify that the NE’s IP address and SNMP settings are configured correctly.

Test NE 
connectivity 

The Test NE Connectivity operation uses the appropriate management protocol (SNMP, TL1, or CORBA) 
to run the ping command to verify the server’s IP connectivity to an NE. If the ping is successful, the Test 
NE Connectivity operation verifies that the management protocol is configured correctly. The results show 
whether the connection state of the NE is Available or Unavailable. If Available, the connection state of an 
NE is updated to Available in the Prime Optical database. If the connection state of an NE is listed as 
Unavailable, a connectivity or configuration problem exists. Complete the steps in G.5.5 NE Connection 
State Is Listed as Unavailable, page G-11 to resolve the problem and retest NE connectivity.
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• Available—If the Prime Optical client can reach the NE through its management protocol, the 
communication state of the NE in the database is checked. If the NE communication state is 
Unavailable, it is changed to Available and an event is sent to the Prime Optical client, stating that 
the communication state was changed. If the NE communication state is Available, there are no 
changes.

• Unavailable—If the Prime Optical client cannot reach the NE through its management protocol, the 
communication state of the NE in the database is checked. If the NE communication state is 
Available, it is changed to Unavailable and an event is sent to the Prime Optical client, stating that 
the communication state was changed. If the NE communication state is Unavailable, there are no 
changes.

Step 3 Click OK in the dialog box.
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