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Working with Prime Network Vision Maps

The topological map is the main tool used by Cisco Prime Network Vision (Prime Network Vision) to 
display the links and relationships between the network elements and aggregations. The following topics 
describe how to work with the topological maps displayed in the content pane of the Prime Network 
Vision window:

• User Roles Required for Working with Prime Network Vision Maps, page 4-2

• Using Chinese Characters, page 4-5

• Opening and Closing Maps, page 4-5 

• Creating a New Map, page 4-8

• Working with Elements in a Map, page 4-9

• Managing Maps, page 4-16

• Finding Items in a Map, page 4-26

• Working with Aggregations, page 4-28

• Working with Overlays, page 4-33

• Filtering Links in a Map, page 4-38

• Opening the CPU Usage Graph, page 4-40

• Communicating with Devices Using Ping and Telnet, page 4-41

You can also perform the following functions from the map and list views if they are configured for your 
client:

• Launch external applications or tools, such as an SSH client. 

• Launch available activation and configuration scripts. This can include the commands documented 
in Commands part of the Cisco Prime Network 3.9 Reference Guide, and those you create using 
Command Builder. These scripts can be launched against multiple network elements at the same 
time.

For more information on these functions, see the Cisco Prime Network 3.9 Customization User Guide.
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User Roles Required for Working with Prime Network Vision 
Maps

This topic identifies the roles that are required to work with Prime Network Vision maps. Prime Network 
determines whether you are authorized to perform a task as follows: 

• For GUI-based tasks (tasks that do not affect elements), authorization is based on the default 
permission that is assigned to your user account. 

• For element-based tasks (tasks that do affect elements), authorization is based on the default 
permission that is assigned to your account. That is, whether the element is in one of your assigned 
scopes and whether you meet the minimum security level for that scope. 

For more information on user authorization, see the Cisco Prime Network 3.9 Administrator Guide.

The following tables identify the tasks that you can perform:

• Table 4-1 identifies the tasks that you can perform if a selected element is not in one of your 
assigned scopes. 

• Table 4-2 identifies the tasks that you can perform if a selected element is in one of your assigned 
scopes. 

By default, users with the Administrator role have access to all managed elements. To change the 
Administrator user scope, see the topic on device scopes in the Cisco Prime Network 3.9 Administrator 
Guide.

Table 4-1 Default Permission/Security Level Required for Working with Prime Network Vision 

Maps - Element Not in User’s Scope

Task Viewer Operator OperatorPlus Configurator Administrator

Map-Related Tasks

Apply a background 
image

— — — X X

Create maps — — X X X

Define a map layout X X X X X

Delete maps — — X X X

Open maps X X X X X

Preview and print maps X X X X X

Rename maps — — X X X

Save as a new map — — X X X

Save as an image X X X X X

Save map appearance — — X X X

Select viewing options X X X X X

Use Overview window X X X X X

View maps X X X X X
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Element-Related Tasks

Add elements to a map — — X X X

Remove elements from 
a map

— — X X X

Resize elements in a 
map

X X X X X

Aggregation-Related Tasks

Group and ungroup 
aggregations

— — X X X

Rename aggregations X X X X X

View aggregation 
thumbnails

X X X X X

Finding Items in Maps

Find affected elements — — — — X

Find an element or 
service

X X X X X

Find and select a link in 
a map1

X X X X X

Link-Related Task

Filter links X X X X X

Overlay-Related Tasks

Apply an overlay X X X X X

Hide or view an overlay X X X X X

Remove an overlay X X X X X

Other Tasks

Open the CPU Usage 
Graph

— — — — X

Use Ping and Telnet to 
communicate with 
elements

— — — — X

1. This applies to links within the selected context, and not links identified as network links.

Table 4-1 Default Permission/Security Level Required for Working with Prime Network Vision 

Maps - Element Not in User’s Scope (continued)

Task Viewer Operator OperatorPlus Configurator Administrator
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Table 4-2 Default Permission/Security Level Required for Working with Prime Network Vision 

Maps - Element in User’s Scope

Task Viewer Operator OperatorPlus Configurator Administrator

Map-Related Tasks

Apply a background 
image

— — — X X

Create maps — — X X X

Define a map layout X X X X X

Delete maps — — X X X

Open maps X X X X X

Preview and print maps X X X X X

Rename maps — — X X X

Save as a new map — — X X X

Save as an image X X X X X

Save map appearance — — X X X

Select viewing options X X X X X

Use Overview window X X X X X

View maps X X X X X

Element-Related Tasks

Add elements to a map — — X X X

Remove elements from 
a map

— — X X X

Resize elements in a 
map

X X X X X

Aggregation-Related Tasks

Group and ungroup 
aggregations

— — X X X

Rename aggregations X X X X X

View aggregation 
thumbnails

X X X X X

Finding Items in Maps

Find affected elements X X X X X

Find an element or 
service

X X X X X

Find and select a link in 
a map1

X X X X X
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Using Chinese Characters
Prime Network Vision supports Chinese characters in map and aggregation names, enabling you to name 
or rename maps or aggregations using Chinese characters. For information on setting up Prime Network 
to use Chinese characters, see the Cisco Prime Network 3.9 Installation Guide. 

Opening and Closing Maps
Prime Network Vision provides two methods for opening maps:

• You can open previously viewed maps (if you left the maps open when you last exited Prime 
Network Vision). See Opening Previously Viewed Maps, page 4-6.

• You can list all existing maps and choose the ones you want to open. See Opening a Map from the 
Open Map Dialog Box, page 4-6.

For information on how to close a map, see Closing a Map, page 4-8.

When you open a map, the network information is automatically refreshed. For example, if a device was 
up the last time that the map was saved and closed, and then the device is moved to maintenance, the 
next time you open the map the management status of the device is updated accordingly and the device 
displays a maintenance status.

Link-Related Task

Filter links X X X X X

Overlay-Related Tasks

Apply an overlay X X X X X

Hide or view an overlay X X X X X

Remove an overlay X X X X X

Other Tasks

Open the CPU Usage 
Graph

— — X X X

Use Ping and Telnet to 
communicate with 
devices

— — — X X

1. This applies to links within the selected context, and not links identified as network links.

Table 4-2 Default Permission/Security Level Required for Working with Prime Network Vision 

Maps - Element in User’s Scope (continued)

Task Viewer Operator OperatorPlus Configurator Administrator
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Opening Previously Viewed Maps
When you launch Prime Network Vision, it lists the maps you recently viewed but did not close when 
you exited the client session. This list of recently viewed maps prevents you from having to view the 
complete list of available maps, which can be lengthy.

Note This list is not available to first-time users or users who closed their maps before closing the application.

To open a map that you viewed previously but did not close when you last logged out:

Step 1 Launch Prime Network Vision as described in Launching Prime Network Vision, page 2-2. The Prime 
Network Vision window opens, and the Last Open Maps dialog box is displayed.

Step 2 Check the check boxes for the maps you want to open, and uncheck the check boxes for the maps you 
do not want to open. 

Step 3 Click OK. 

Opening a Map from the Open Map Dialog Box
You can open any map that is displayed in the Open Map dialog box, even if you have never accessed it 
before. 

To open a map using the Open Map dialog box: 

Step 1 Display the Open Map dialog box by doing one of the following:

• Click Open Map in the main toolbar. 

• Choose File > Open. 

The Open Map dialog box lists the existing maps, and indicates which maps are currently open in your 
view. 

The Find field enables you to search for a map containing the string that you enter. For more information, 
see Finding Text in a Table, page 2-51.
4-6
Cisco Prime Network 3.9 User Guide

OL-26486-01



 

Chapter 4      Working with Prime Network Vision Maps
  Opening and Closing Maps
You can use the tools described in Table 4-3 to manage maps in the Open Map dialog box. 

Step 2 Select the maps you want to open using one of the following methods. You can select multiple maps by 
pressing Ctrl while you select individual maps. 

• Select the maps in which you are interested, and then click Open.

• Right-click the required maps and choose Open.

• Double-click the required maps.

Note By default, you can view and work on a maximum of five maps at any given time (per client 
instance) in the Prime Network Vision window. To change this default setting, contact your 
Cisco account representative. To create a new map or select a new map, close the required 
number of maps.

Table 4-3 Open Map Dialog Box Options

Tool Name Description

Export to CSV Exports the information displayed in the table. For more 
information, see Exporting Tables to a File, page 2-55.

Delete Map Deletes the selected map from the Open Map dialog box, the Prime 
Network Vision window, and the database. If a map that is opened 
is deleted, the map closes. For more information, see Deleting a 
Map from the Prime Network Vision Database, page 4-25.

Rename Map Renames the selected map in the Open Map dialog box and Prime 
Network Vision window. For more information, see Renaming a 
Map, page 4-20.

Sort Table Values Sorts the information displayed in the table. For more information, 
see Sorting a Table, page 2-51.

Filter Defines a filter for the information displayed in the table. For more 
information, see Filtering Table Contents, page 2-53.

Note When a filter is applied, the Clear Filter button is activated.

Clear Filter Clears the existing filter. 

Show All Rows Displays all table rows that meet the current filtering criteria.

Show Only Selected 
Rows

Displays only the rows that you select. 

For more information, see Viewing Selected Rows, page 2-54.
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Closing a Map
When you close a map, Prime Network Vision saves basic map information whether or not you manually 
save the map. This default information includes device and link additions, device and link removals, 
aggregations, and disaggregations. However, you must use the Save Map option if you want to retain the 
following information in the database:

• The location of the devices on the map

• Thumbnails

• The size of the devices

To close a map:

Step 1 (Optional) To save more than the default map information, use one of the following methods:

• Click Save Map Appearance in the main toolbar.

• Choose File > Save Map from the main menu.

Step 2 Do one of the following:

• Choose File > Close.

• Click  in the upper right corner of the content pane. 

If changes have been made to the map, an information message is displayed.

Step 3 Click Yes. The map is saved and closed. An empty Prime Network Vision window is displayed, or the 
map that was last opened is displayed.

Creating a New Map 
Prime Network Vision enables you to create multiple network maps to represent specific network views. 
Maps can cover specific network segments, customer networks, or any other mix of network elements 
required. When you create a map, it is available to other users if they have sufficient access and security 
privileges.

Network maps provide a graphic display of active faults and alarms, and serve as access points for 
activating services.

Note You cannot specify the same name for two or more maps.
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To create a new map:

Step 1 Do one of the following:

• Click New Map in the main toolbar.

• Choose File > New Map in the main menu.

The Create Map dialog box is displayed. 

The Advanced button enables you to filter the links displayed in the map pane. For more information, 
see Filtering Links in a Map, page 4-38.

Step 2 Enter a name for the new map and click OK.

A new empty map is displayed in the navigation pane and map pane. 

Step 3 Add elements to your new map as described in Adding Elements to a Map, page 4-9. 

For information on removing elements from a map, see Removing Elements from a Map, page 4-15.

Working with Elements in a Map
The following topics describe how to work with elements in a map:

• Adding Elements to a Map, page 4-9

• Resizing Map Elements, page 4-14

• Removing Elements from a Map, page 4-15

Adding Elements to a Map
When you add an element to a map, the map is automatically saved in the Prime Network Vision 
database.

Note Based on the security level and access permissions assigned, this option might not be available to all 
users.

To add an element to a map: 

Step 1 Do one of the following:

• Click Add to Map in the main toolbar, and choose the required element.

• Choose File > Add to Map > element.
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You can add the following types of elements to maps, as shown in Figure 4-1: 

• EFP cross-connects

• Ethernet services

• MPLS-TP tunnels

• Network elements

• Pseudowires

• Unassociated bridges

• VLANs

• VPLS instances

• Existing or new VPNs

Figure 4-1 Available Elements to Add to Maps

If you choose to add a new VPN, the Create VPN dialog box is displayed. For information on creating 
a VPN, see Creating a VPN, page 17-21

In all other instances, the Add element to map dialog box is displayed, as shown in Figure 4-2.
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Figure 4-2 Add Element Dialog Box

Step 2 In the Add element dialog box, do one of the following: 

Note If the element you want to add is outside of your scope, it is not displayed if you enter a search 
string. Choose Show All to view all available elements, both in and out of your scope.

• To view elements that meet specific criteria: 

a. In the Search field, choose a search category. Table 4-4 identifies the search categories available 
for each element type.

Table 4-4 Network Elements to Add to Maps

Name Available Search Criteria

Cross-Connect Name

Ethernet Service • EVC Terminating EFPs

• Name

• System Name

MPLS-TP Tunnel • Description

• Name

• System Name
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b. Enter a search string to narrow the display to a range of elements or to a specific element. 

c. Click Go. 

For example, if you add a network element, choose IP Address, and enter 254, the network elements 
with IP addresses containing the string 254 are displayed. If you choose Vendor and enter Cisco, 
only Cisco network elements are displayed.

Network Element • Element Category

• Element Type

• IP Address

• Name

• System Name

• Vendor

Pseudowire • Description

• Is Multisegment Pseudowire

• Name

• Pseudowire Role

• Pseudowire Type

• System Name

Unassociated Bridge Name

VLAN • EFD Name

• EFD System Name

• ID

• Name

• System Name

VPLS • Name

• System Defined Name

• VPN ID

VPN > Existing • Description

• Name

Table 4-4 Network Elements to Add to Maps (continued)

Name Available Search Criteria
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• To view all available elements, choose Show All. 

The following conditions apply when working with large numbers of elements: 

– If the number of elements to be displayed is large, it can take a while for all elements to appear. 

– If the retrieval time for displaying all elements is expected to take a significant amount of time, 
the Show All button is disabled and the following message is displayed: 

The Show All option is disabled because the retrieval time is expected to be 
excessive.
Please define a search that is as specific as possible to minimize the data 
retrieval time. 

As recommended, use the Search option to specify search criteria and thereby limit the number 
of elements displayed.

The number of elements that can be displayed in the Add element dialog box is configured in 
the registry. 

Note Changes to the registry should only be carried out with the support of Cisco. For details, 
contact your Cisco account representative. 

The available elements are displayed in the Add element dialog box in table format. The dialog box also 
displays the date and time at which the list was generated. To update the list, click Refresh.

If a network element is not included in your scope, it is displayed with the locked device icon. 

For information about sorting and filtering the table contents, see Working with Prime Network Tables, 
page 2-49.

Step 3 In the Add element dialog box, select the elements that you want to add. You can select and add multiple 
elements by pressing Ctrl while selecting individual network elements or by pressing Ctrl + Shift to 
select a group of elements.

Step 4 Click OK. 

If you select more than 25 business elements (such as VLANs or VPLS instances) to add, a message is 
displayed, stating that the action can take a while to complete and asking if you want to continue. Click 
OK to continue or Cancel to change your selection.

The elements are displayed in the navigation pane and content area. In addition, any associated tickets 
are displayed in the ticket pane.

The network element information is saved with the map in the Prime Network Vision database.
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Resizing Map Elements
Prime Network Vision can display network element icons in four sizes. The size that is used when you 
add elements to a map depends on the number of elements in the map, the map layout, and the size of 
the content pane. 

Icons at the top level of a map have a solid gray border when selected whereas element icons within an 
aggregation thumbnail have a dashed gray border when they are selected. However, if you double-click 
the thumbnail frame so that the aggregation fills the map pane and then select an element in the 
aggregation, the selected element displays a solid gray border.

You can resize element icons in the following ways:

• Using Your Mouse, page 4-14

• Using the Resize Option, page 4-14 

Using Your Mouse

To resize a single icon in a map using your mouse: 

Step 1 Click the icon you want to resize. 

The icon displays a gray border to indicate that it is selected. 

Step 2 Position your mouse cursor on the gray border and click and drag the border until the icon is the required 
size. 

Using the Resize Option

Note The Resize option is enabled only when element icons are selected. Links cannot be resized.

To resize icons with the Resize option:

Step 1 In the map, select the icons you want to resize. 

Step 2 Do one of the following:

• Choose Edit > Resize from the main menu.

• Right-click the required icons in the map, and choose Resize.

Step 3 In the Resize Nodes dialog box, set the size of the selected icons in one of the following ways:

• In the By Percentage field, choose the required percentage for resizing the icons from the drop-down 
list. The available values are 10, 20, 50, 150, and 200. 

• In the By Size Category field, choose the required size from the drop-down list. The available sizes 
are Tiny, Normal, Large, and Huge. To see examples of these sizes, see Table 2-3. 

Step 4 Click OK. The selected icons are resized.
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For more information about the information that is displayed in the element icons, see Information 
Available in Element Icons, page 3-3.

Using Zoom
Prime Network Vision enables you zoom in or out of maps so that you can use the viewing level that 
meets your needs. Zooming differs from resizing in that zooming does not change the size of the icon 
itself. 

You can zoom in or out on a map by using either of the following methods: 

• Position your mouse cursor in the map pane and use your mouse scroll wheel, as follows:

– Roll the wheel forward to zoom in on the map.

– Roll the wheel backward to zoom out on the map. 

• Click Zoom Selection Mode in the  and zoom in and out, as follows: 

– To zoom in, press and hold the mouse button while selecting the area that you want to view in 
greater detail. Prime Network Vision zooms in on the selected area and centers it in the map 
pane.

– To zoom out, click Normal Selection Mode in the  and do either of the following:

- Position your mouse cursor in the map pane and use the mouse scroll wheel to zoom out.

- Click Fit in Window to view the entire map in the map pane. 

Removing Elements from a Map
When you delete an element or aggregation from a map, it is removed from the map in the database, but 
the elements are still managed by Prime Network Vision.

Note Based on the security level and access permissions assigned, this option might not be available to all 
users.

To remove a network element or aggregation from a map:

Step 1 In the navigation pane or map, select the element or aggregation that you want to delete. 

Step 2 Right-click to display the right-click menu and choose Remove from Map. The selected element or 
aggregation is removed from the map.

The element is removed from the map in the database, but is still managed by Prime Network Vision and 
can be added again.
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Managing Maps
The following topics describe how to manage maps in Prime Network Vision:

• Selecting Map Viewing Options, page 4-16

• Defining a Map Layout, page 4-17

• Applying a Background Image, page 4-17

• Using the Overview Window, page 4-19

• Renaming a Map, page 4-20

• Saving Maps, page 4-20

• Previewing and Printing a Map, page 4-23

• Deleting a Map from the Prime Network Vision Database, page 4-25

Selecting Map Viewing Options
Table 4-5 describes the tools that you can use to view and manipulate maps in the Prime Network Vision 
map pane.

To select a tool, do one of the following:

• From the View menu, choose the required selection tool. 

• In the toolbar, click the required tool icon.

Table 4-5 Prime Network Vision Map Viewing Options

Button Name Function

Layout Map Defines the way in which the map is displayed in the map pane of 
the Prime Network Vision window: Circular, hierarchical, 
orthogonal, or symmetric. 

Fit in Window Fits an entire aggregation or map in the map pane.

Normal Selection 
Mode

Activates the normal selection mode. 

Zoom Selection Mode Activates the zoom selection mode, which enables you to select an 
area in the map pane to enlarge by clicking and dragging the zoom 
mode cursor. 

Pan Mode Activates the pan mode, which enables you to move around in the 
map pane by clicking and dragging the pan mode cursor.
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Defining a Map Layout
Prime Network Vision enables you to select the way in which the network object topology is displayed 
with the following options: Circular, hierarchical, orthogonal, or symmetric.

Select the map layout by using either of the following methods:

• In the toolbar, click the Layout Map drop-down button, and choose one of the options.

• Choose View > Layout from the main menu and select one of the layout options. 

When you choose a map layout, the elements align accordingly, using animation by default. Related 
characteristics, such as the speed of the animation and whether an expanded node causes sibling nodes 
to move aside, are also configured by settings in the registry. 

Note Changes to the registry should only be carried out with the support of Cisco. For details, contact 
your Cisco account representative. 

By default, Prime Network Vision uses the circular layout for maps. If you click Layout Map in the main 
toolbar, Prime Network Vision displays the map according to the option last selected. 

Applying a Background Image
Prime Network Vision allows you to apply a background image to the map view. You can also choose 
the same background image or different images for other subordinate windows, such as detailed views 
of aggregations, VLANs, and VPNs. 

The supported file formats are GIF, JPG/JPEG, and PNG. 

Note Background images are not supported in thumbnail views.

To apply a background image to a map: 

Step 1 Navigate to the required map in Prime Network Vision. The map can reside at the top level or in a 
subordinate window. 

Step 2 Right-click the map background and choose Set Map Background. 

The Manage Map Background dialog box is displayed, as shown in Figure 4-3. 
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Figure 4-3 Manage Map Background Dialog Box 

Step 3 Enter the required information as described in Table 4-6. 

Step 4 Click OK. The current map background is updated as specified. 

Step 5 To retain the background image for subsequent logins, do one of the following:

• Click Save in the toolbar.

• Choose File > Save. 

Table 4-6 Manage Map Background Options

Field Description

Select Image Applies the selected image to the current map background: 

1. Choose Select Image. 

2. Click Browse. 

3. In the Open dialog box, select the desired image and click OK. 

The name of the selected image is displayed in the Manage Map 
Background dialog box. 

4. Click OK. The selected image is displayed as the map 
background.

Use Image From Upper Level Indicates whether the selected subordinate map should use the same 
image as the parent map or a different image: 

• To use the same image that is used by the parent map, choose 
Use Image from Upper Level. The name of the image used by 
the parent map is displayed by default.

• To use a different image than that used by the parent map, 
choose Select Image and complete the steps described for that 
option. 

Remove Image Removes the current image from the map background. 

To remove an image from the current map, click Remove Image. 
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Using the Overview Window
The Prime Network Vision Overview window enables you to display the entire network map or any part 
of the map that you require in the map pane. The Overview window also enables you to see all the 
changes and alarms taking place in the network. 

To open the network Overview window do either of the following: 

• Click Overview in the main toolbar.

• Choose View > Overview from the main menu.

Figure 4-4 shows an example of the Overview window. 

Figure 4-4 Overview Window

The Overview window can contain the following components:

• Dot—Indicates an element. The dot color indicates the severity of an associated alarm.

• Line—Indicates a link. The line color indicates the severity of an associated alarm. 

• Blue rectangle—Indicates the selection area. The area within the rectangle is displayed in the map 
pane. Handles on the corners enable you to resize the selection area. 

• Pan mode cursor—Displayed within the selection area. Use this cursor to move the selection area, 
and thereby view different elements in the map pane. 

• Zoom mode cursor—Displayed outside the selection area. Use this cursor to define a new selection 
area or to zoom in on an existing selection area. 

Click the upper right corner to close the Overview window.
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Renaming a Map
Prime Network Vision enables you to rename a map that is displayed in the Prime Network Vision 
window. The name change affects all users of the map and the new name is displayed in the Prime 
Network Vision window of all users.

To rename a map:

Step 1 Do one of the following:

• Click Open Map in the main toolbar.

• Choose File > Open from the main menu.

Step 2 In the Open Map dialog box, select the map that you want to rename.

Step 3 Click Rename Map in the toolbar.

Step 4 Enter the new map name.

Step 5 Click OK. The selected map is renamed in the Open Map dialog box, in the Prime Network Vision 
window, and in the database.

Step 6 Click Cancel to close the Open Map dialog box.

Saving Maps
Prime Network Vision provides three options for saving maps: 

• To save more map information than Prime Network Vision saves by default, see Saving a Map with 
Information, page 4-20.

• To save a copy of a map so that you can use it as a template for another map, see Saving a Map as a 
New Map, page 4-21.

• To save a map as an image, see Saving a Map as an Image, page 4-21.

Saving a Map with Information

By default, Prime Network Vision saves basic map information whether or not you manually save the 
map. This default information includes element additions and removals, link additions and removals, 
aggregations, and disaggregations. However, you must use the Save Map option if you want to retain the 
following information in the database:

• Device location on the map

• Thumbnails

• Icon size

To save these changes, do one of the following:

• Click Save Map Appearance in the main toolbar.

• Choose File > Save Map.
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Saving a Map as a New Map

You can save a copy of an entire map or parts of a map (such as specific elements and aggregations) while 
leaving the original map intact.

To save a map or part of a map as a new map:

Step 1 Make sure that the map that you want to save is displayed in the Prime Network Vision content pane. 

Step 2 Select the required map, elements, or aggregations in the navigation tree or the map. 

Step 3 Right-click in the navigation pane or one of the selected items in the map pane, and choose Save as New 
Map. 

Step 4 In the Create Map dialog box, enter a new name for the map.

Step 5 Click OK. The new map is created.

For information about opening the new map, see Opening a Map from the Open Map Dialog Box, 
page 4-6.

Saving a Map as an Image

To save a map as an image:

Step 1 Display the required map in Prime Network Vision. 

Step 2 Choose File > Save As Image from the main menu.

Step 3 In the Save as Image dialog box, define the image characteristics as described in Table 4-7.

Figure 4-5 Save as Image Dialog Box
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Step 4 Click OK. The map is saved as an image in the directory you specified.

Table 4-7 Save as Image Dialog Box Options

Attribute Description

Image Specify the image type and filename: 

• Type—In the drop-down list, select one of the following file types: 

– GIF Image (*.gif)

– JPEG Image (*.jpg)

– PDF Document (*.pdf)

– Portable Network Graphics (*.png) 

– Scalable Vector Graphics (*.svg) 

• File Name—Browse to the required location and enter a filename for the 
image.

Image Content Check the appropriate check box for the content to be included in the image: 

• Visible Window Only—Saves the currently selected map as an image, 
even if the content area displays the list view or the links view.

The option is enabled only if Current Zoom Level is selected for the Size 
attribute. 

• Selected Objects Only—Saves the selected network objects as an image.

This option is enabled only if network objects are selected in the content 
pane. 

Image Quality Select the required image quality level: 

• High

• Medium

• Low

Size Specify the required zoom level for the image:

• Current Zoom Level—Saves the image at the currently selected zoom 
level. Selecting this option enables the Visible Window Only check box. 

• Actual Size—Saves the image at the actual size.

• Fit in Canvas—Saves the image so that it fits in the canvas.

• Custom—Saves the image at an enlarged or reduced size. Selecting this 
option enables the Width and Height options, so that you can enter the 
required size in pixels. 
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Previewing and Printing a Map
To print a map, choose File > Print. If you would like to preview a map before printing it, or define the 
print setup for a map, see the following topics:

• Previewing a Map Before Printing It, page 4-23

• Defining the Print Setup for a Map, page 4-23

Previewing a Map Before Printing It

Using Prime Network Vision, you can preview a map before printing it.

To preview a map:

Step 1 In Prime Network Vision, display the map that you want to print.

Step 2 From the main menu, choose File > Print Preview. The Print Preview window is displayed with the 
active map.

The following buttons are displayed in the Print Preview window:

Step 3 Click Print. The required map is printed to the selected printer.

Defining the Print Setup for a Map

Prime Network Vision enables you to define the print setup of a map before it is printed.

To define the print setup:

Step 1 From the main menu, choose File > Print Preview to open the Print Preview dialog box.

Step 2 Click Print Setup. The Print Setup dialog box is displayed.

Button Name Description

Print Setup Opens the Printer Setup dialog box so you can specify your print settings.

Print Opens the Print dialog box so you can print the displayed network or map 
to the required printer.

Zoom In Zooms in on the network or map.

Zoom Out Zooms out of the network or map.

Fit Displays the entire network or map in the Print Preview window.
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Figure 4-6 Print Setup Dialog Box

Step 3 Define the print setup, using the information in Table 4-8. 

Table 4-8 Print Setup Dialog Box Options

Option Description

Print Selection 

Print Entire Drawing Prints the currently displayed map, including aggregations.

Print Current Window Prints the currently displayed map, excluding aggregations.

Print Current Selection Prints the area selected in the currently displayed map.

Scale By

Pages Prints the currently displayed map according to the numbers 
specified in the Page Columns and Page Rows fields.

Actual Size Prints the currently displayed map at the actual size.

Zoom Level Prints the currently displayed map according to the selected zoom 
level.

Caption

Print Caption Adds the specified caption to the printed map.

Font Specifies the font to use for the caption.

Caption Prints the text entered in this field as the caption.

Position Defines the position of the caption in the printed map.
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Step 4 Click OK to save your settings, or Default to restore the default settings. 

The Print Preview dialog box is refreshed with the current settings.

Step 5 If you are satisfied with your settings, click Print. Otherwise, click Print Setup and revise your settings.

Deleting a Map from the Prime Network Vision Database
Prime Network Vision enables you to delete a map from all the views in the Prime Network Vision 
window.

If another client is using a map that you are deleting, Prime Network Vision displays a message to those 
clients advising them that the map is being closed and deleted from the database.

To delete a map from Prime Network Vision and the Prime Network Vision database:

Step 1 Open the Open Map dialog box in one of the following ways:

• Click Open Map in the main toolbar.

• Choose File > Open from the File menu.

Step 2 In the Open Map dialog box, complete the following steps:

a. Select the map you want to delete.

b. In the toolbar, click Delete Map. A confirmation message is displayed.

c. Click Yes. The selected map is deleted from the Open Map dialog box, the Prime Network Vision 
window, and the database. If the map is open when you click Yes, a message is displayed, stating 
that the map will be closed. 

d. Click OK to acknowledge that the map can be closed. 

e. Click Cancel to close the Open Map dialog box.

Multipage Printing

Print Page Numbers Prints the map with page numbers.

Print Crop Marks Prints the map with crop marks.

Other

Print Border Prints a border around the printed map.

Color Displays the Choose Color dialog box so you can select the border 
color. 

Print Background Prints the background of the currently displayed map.

Page Setup

Page Setup Offers standard printer options, such as printing in portrait or 
landscape mode and setting margin widths.

Table 4-8 Print Setup Dialog Box Options (continued)

Option Description
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Finding Items in a Map
The following topics describe how to find network elements, services, links, or elements affected by a 
ticket in Prime Network Vision maps:

• Finding a Network Element or Service, page 4-26

• Finding and Selecting Links in Maps, page 4-27

• Finding Elements Affected by a Ticket, page 4-27

Finding a Network Element or Service
Prime Network Vision enables you to find an element or service (such as a VPN or VLAN) in the map 
by entering the element or service name, the device IP address, or any part of the name or IP address.

To find an element or service in a map:

Step 1 Do one of the following:

• Click Find in the main toolbar.

• Choose Edit > Find in Map from the main menu.

Step 2 In the Find in Map dialog box, enter the device name or the IP address. 

Note You can enter a partial name (case insensitive) or IP address. For example, entering XY finds 
elements or services with names containing the string xy, such as Axy, Xy, xY, or xyZ.

The Search all map levels check box enables you to search for an element, name, or IP address at all 
levels of the map. When disabled, this option searches for the element or service, but excludes 
aggregations from the search. This option is disabled by default.

Step 3 Check or uncheck the Search all map levels check box, as required.

Step 4 Click OK. An element or service matching the search criteria is selected in the map.

Step 5 Continue searching using the following methods:

• To view the next element or service that matches the search criteria, click Find Next in the  or press 
F3.

• To view the previous element or service that matches the search criteria, click Find Previous in the  
or press Shift + F3. 
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Finding and Selecting Links in Maps
Prime Network Vision enables you to find a specific link and select it in a map. If more than one edge 
device contains the same link in the same map or context, all related edge devices are selected in the map. 

To find and select a link:

Step 1 In the Links view, right-click the required link and choose Select Link in Map. 

The link is highlighted in the map pane.

Step 2 If two or more lines represent the same link (such as a VRF link), the Select Link Context dialog box is 
displayed. Select the required link context from the drop-down list and click OK. The link is highlighted 
in the map pane. 

Step 3 Click in the map background to remove the highlight from the selected link.

For more information about links in Prime Network Vision, see Chapter 5, “Working with Links.”

Finding Elements Affected by a Ticket
Prime Network Vision enables you to find the elements that might be affected by a ticket displayed in 
the ticket pane. 

To find elements affected by a ticket: 

Step 1 In the ticket pane, right-click the required ticket and choose Find Affected Elements. Depending on the 
number of affected elements, the information is displayed in one of the following ways: 

• If only one element is affected, the affected element is selected in the navigation pane and the 
content area.

• If a link is affected, the affected link is selected in the links view. 

• If two or more elements are affected, the affected elements are displayed in the Affected Elements 
window as shown in Figure 4-7. 
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Figure 4-7 Affected Elements Window

Step 2 In the Affected Elements window, select the required element, then click OK. The selected element is 
selected in the Prime Network Vision map or links view. 

Step 3 Click in the navigation pane or the map pane to remove the highlight from the selected device or link.

Working with Aggregations
Prime Network Vision enables you to group network elements and display them as an aggregation. 
Aggregations can contain network elements, services, other aggregations, and so forth.

Note You cannot aggregate service entities that exist within a service. For example, you cannot aggregate 
VRFs that exist within a VLAN. 
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For more information on working with aggregations, see the following topics: 

• Grouping Network Elements into Aggregations, page 4-29

• Adding Elements to an Existing Aggregation, page 4-30

• Viewing an Aggregation Thumbnail, page 4-30

• Ungrouping Aggregations, page 4-33

• Renaming Aggregations, page 4-32

Grouping Network Elements into Aggregations
To aggregate network elements:

Step 1 Select the network elements using one of the following methods:

• Select a single item in the map pane or navigation tree.

• Select multiple items in the map pane or navigation tree while pressing Ctrl.

Step 2 Aggregate the network elements using one of the following methods:

• In the menu bar, choose Node > Aggregate.

• Right-click the navigation pane and choose Aggregate. 

• In the map pane, right-click one of the selected items and choose Aggregate. 

Step 3 In the Aggregation dialog box, enter a unique name for the aggregation and click OK. The aggregation 
is displayed in the navigation pane and the map pane. Aggregations are displayed as a single entity with 
the Aggregation icon and a plus sign, as in the following examples:

The aggregation icon changes color according to the alarm severity. For more information about severity 
colors, see Alarm Indicators, page 2-17.
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Adding Elements to an Existing Aggregation
You can add elements to an existing aggregation at any time. When adding elements to an aggregation, 
keep in mind that certain restrictions exist. For example, you cannot add an EVC to a VLAN. 

To add elements to an existing aggregation: 

Step 1 Select the existing aggregation in the map pane. 

Step 2 Navigate to the required aggregation thumbnail in either of the following ways: 

• Click the plus sign in the upper right corner of the aggregation icon. 

• Right-click the aggregation, and choose Show Thumbnail.

Step 3 When the required aggregation thumbnail is open, double-click the thumbnail frame to view the 
aggregation at the map level. 

Step 4 Click Add to Map to add the required element to the aggregation.

Step 5 To return to the map, do one of the following: 

• Double-click the map background. 

• Right-click the cursor in the map background, and choose Go to Root.

• Click Go to Parent in the toolbar. Depending on the number of nested aggregations, you might need 
to do this more than once. 

Viewing an Aggregation Thumbnail 
You can view a thumbnail of a selected aggregation in the map pane, including all aggregated elements 
and any nested aggregations. 

To display an aggregation thumbnail:

Step 1 Open the thumbnail in either of the following ways:

• Click the plus sign in the upper right corner of the aggregation icon.

• Right-click an aggregation, and choose Show Thumbnail. 

The thumbnail is displayed in the map pane as shown in Figure 4-8.
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Figure 4-8 Aggregation Thumbnail

When a thumbnail is opened, neighboring nodes are moved aside by default to allow room for the 
thumbnail to expand. Similarly, when a thumbnail is closed, the neighboring nodes usually return to their 
original locations. This behavior of the neighboring nodes when a thumbnail is opened and closed is 
configured in the registry, and can be disabled, if required. 

Note Changes to the registry should only be carried out with the support of Cisco. For details, 
contact your Cisco account representative. 

A dashed gray border around an icon indicates that the element resides within a thumbnail and not at the 
current map level. 
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Table 4-9 describes the options available when working with aggregation thumbnails. 

Step 2 To close the aggregation thumbnail, do either of the following: 

• Click the minus sign in the upper right corner of the thumbnail frame.

• Right-click the thumbnail frame and choose Show As Aggregation.

Renaming Aggregations
You can rename aggregations that are displayed in Prime Network Vision. The name change affects all 
users of the map, and the new name is displayed in the Prime Network Vision window of all users.

To rename an aggregation:

Step 1 Select the aggregation that you want to rename in the navigation tree or the map.

Step 2 Right-click the aggregation icon and choose Rename. 

Step 3 In the Rename Node dialog box, enter a new name for the aggregation and click OK. The selected 
aggregation is renamed in the navigation tree, map pane, and database.

Table 4-9 Aggregation Thumbnail Options

If you want to... Do this...

Rearrange the icons in the thumbnail Click and drag the required icons to arrange them as 
needed. 

Resize an icon Select the icon to be resized, and then either click and 
drag the gray border or right-click a selected icon and 
choose Resize.

The right-click Resize option allows you to resize 
multiple selected icons at the same time.

Resize the thumbnail frame Click and drag one or more icons. If you drag an icon 
beyond the thumbnail frame, Prime Network Vision 
adjusts the thumbnail size automatically.

View a nested aggregation Click the nested aggregation plus sign.

View only the aggregation in the map pane Double-click the thumbnail frame.

View the next higher level in the map pane Double-click the current map background.

Zoom in or out in the thumbnail Position your mouse cursor in the map and use the mouse 
scroll wheel to zoom in or out.
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Ungrouping Aggregations
Aggregations can be ungrouped. If the aggregation that you ungroup contains nested aggregations, the 
nested aggregations move up one level, and the original aggregation is removed. 

If an element in the aggregation that you ungroup also exists at the parent level, the element is 
represented only once after the aggregation is ungrouped. As a result, no elements are represented twice 
at the same level.

To ungroup an aggregation:

Step 1 Select the required aggregation in Prime Network Vision. 

Step 2 Ungroup the node in one of the following ways: 

• Select the aggregation in the map pane, and choose Node > Disaggregate.

• Right-click the aggregation in the navigation tree or map pane, and choose Disaggregate. 

• If the aggregation is shown in the thumbnail view, right-click the thumbnail frame and choose 
Disaggregate. 

If the aggregation contains elements that already exist at the parent level, a confirmation message is 
displayed, stating that any duplicate elements will be removed. 

Step 3 Confirm the disaggregation. 

The node is disaggregated. Any aggregations in the selected node move up one level, and the original 
aggregation is removed. 

For more information about resizing aggregation icons, see Resizing Map Elements, page 4-14.

Working with Overlays
Prime Network Vision enables you to apply overlays to a map and thus isolate the parts of a network that 
are being used by a specific service. 

The following topics discuss the overlay options in more detail:

• Applying an Overlay, page 4-34

• Hiding or Viewing an Overlay, page 4-37

• Removing an Overlay, page 4-37
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Applying an Overlay
To apply an overlay:

Step 1 In Prime Network Vision, choose the map in which you want to apply an overlay.

Step 2 From the toolbar, choose Choose Overlay Type > overlay-type where overlay-type is one of the 
following options: 

With the exception of the None option, a dialog box is displayed that allows you to select the specific 
overlay to apply. 

Figure 4-9 shows an example of the Select Pseudowire Overlay dialog box. 

Overlay Option Description

Ethernet Service Applies an Ethernet service overlay to the map.

MPLS-TP Tunnel Applies and MPLS-TP tunnel overlay to the map.

Network Clock Applies a network clock overlay to the map. 

None Removes any existing overlays on the map.

Pseudowire Applies a pseudowire overlay to the map.

VLAN Applies a VLAN overlay to the map.

VPLS Applies a VPLS instance overlay to the map.

VPN Applies a VPN overlay to the map. 
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Figure 4-9 Select Overlay Dialog Box

Each overlay type allows you to search for specific overlays. Table 4-10 identifies the search fields 
available for each overlay type.

Table 4-10 Overlay Type Search Fields

Overlay Type Search Fields

Ethernet Service • EVC Terminating EFPs

• Name

• System Name

MPLS-TP Tunnel • Description 

• Name 

• System Name

Network Clock • Name

Pseudowire • Description

• Is Multisegment Pseudowire

• Name

• Pseudowire Role

• Pseudowire Type

• System Name
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Step 3 In the Select Overlay dialog box, do either of the following: 

• To search for specific overlays: 

a. Choose Search. 

b. In the Search field, choose a search category. 

c. Enter a search string to narrow the display to a range of overlays or to a specific overlay. 
Table 4-10 identifies the search categories available for each type of overlay.

d. Click Go. 

Search strings are case-insensitive. If you choose Name and enter NET, the overlays that contain 
“net” in their names are displayed. If you choose System Name and enter System123, only the 
overlay with the system named System123 is displayed.

• To view all available overlays, choose Show All. 

The available overlays that meet the specified search criteria are displayed in the Select Overlay dialog 
box in table format. The dialog box also displays the date and time at which the list was generated. To 
update the list, click Refresh.

Step 4 Select the overlay that you want to apply to the map. 

The elements and links that are used by the overlay are displayed in the map, and the overlay name and 
date are displayed in the toolbar, as shown in Figure 4-10. 

VLAN • EFD Name

• EFD System Name

• ID

• Name

• System Name

VPLS • Name

• System Defined Name

• VPN ID

VPN • Description

• Name

Table 4-10 Overlay Type Search Fields (continued)

Overlay Type Search Fields
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Figure 4-10 Overlay Example

Note The overlay is a snapshot taken at a specific point in time and does not reflect changes that occur in the 
service. As a result, the information in an overlay can become stale. To update the overlay, click Refresh 
Overlay in the toolbar.

Hiding or Viewing an Overlay
When an overlay is applied to a map, the Show Overlay/Hide Overlay button becomes active in the 
toolbar. 

To hide and view the overlay, click Hide Overlay/Show Overlay in the toolbar. The button toggles 
depending on whether the overlay is currently displayed or hidden.

Removing an Overlay
To remove an overlay, choose Choose Overlay Type > None. The overlay is removed from the map.
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Filtering Links in a Map
The links filter enables you to filter the links displayed in the map view and the links view.

You can quickly select the types of links to be filtered by selecting from a predefined set of link types in 
the list, or by manually configuring a customized set of link types. 

To filter links, do either of the following:

• Create a new map, select a filter, and then add the devices to the map. This filter is applied to the 
new map and only the required link types are visible in the map view and the links view. For more 
information, see Filtering Links During Map Creation, page 4-38. 

• Create a map and add the devices with all links enabled and visible in the map view and links view. 
You can then filter (display or hide) the different types of links as required. For more information, 
see Filtering Links in an Existing Map, page 4-40.

The links filter applies to all aspects of Prime Network Vision: the map view, links view, ticket pane, 
severity calculation, and other items, such as memory consumption and thresholds. Prime Network 
Vision holds only the links that are relevant to the filter and synchronizes the links with the gateway 
according to that filter.

For more information about links in Prime Network Vision, see Chapter 5, “Working with Links.”

Filtering Links During Map Creation
To filter links while creating a map:

Step 1 Open the Create Map dialog box using one of the following methods:

• Click New Map in the main toolbar.

• Choose File > New Map from the main menu.

The Create Map dialog box is displayed. For more information, see Creating a New Map, page 4-8.

Step 2 Click Advanced. The Link Filter dialog box is displayed.
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Figure 4-11 Link Filter Dialog Box 

The Link Filter dialog box displays a list of all the types of links that you can filter in the map view and 
links view. 

Note By default all link types are selected in the Link Filter dialog box. That is, all links are displayed 
in the map view and links view.

Step 3 Select the required option from the Group drop-down list:

• All—All the links are displayed in the map view and links view.

• Custom—Only the links defined for the customized filter are displayed in the map view and links 
view.

• Data Link—The data link layer class of links (ATM and Frame Relay) is displayed in the map view 
and links view.

• None—None of the links are displayed in the map view and links view.

• Physical—Only the physical links are displayed in the map view and links view.

• VPN—Only VPN-related links (GRE, Pseudowire, VPN, and VPN IPv6) are displayed in the map 
view and links view.

Note You can customize the Group drop-down list options by selecting an option and adding or 
removing the required link types. The next time the Link Filter dialog box is opened, the Custom 
option is displayed with the specified link types.

Step 4 Check the check boxes for the links that you want to display in the map view and links view. Uncheck 
the check boxes for the links you do not want to display in the map view and links view. 

Step 5 Click Apply to apply the defined link filter settings and continue with more selections.
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Step 6 Click OK when you have completed your selections. 

Step 7 In the Create Map dialog box, enter a name for the new map and click OK. An empty new map is 
displayed in the navigation pane and content area, and the Link Filter Applied button is displayed in the  
to indicate that the links have been filtered. 

Step 8 Add the required elements to the map. For more information, see Creating a New Map, page 4-8.

The links are displayed in the map view and links view according to your selections.

Filtering Links in an Existing Map
You can also create a map, add elements with all links enabled and visible in the map view and links 
view, and then filter (display or hide) the different types of links as required.

To filter links in an existing map: 

Step 1 Click Link Filter in the main toolbar. 

Step 2 In the Link Filter dialog box, uncheck the check boxes for the links that you do not want to display in 
the map view and links view.

Step 3 Click Apply to apply the defined link filter settings and continue with more selections.

Step 4 Click OK when you have completed your selections. 

The links are displayed in the map view and links view according to the defined filter, and the Link Filter 
Applied button is displayed in the  to indicate that the links are filtered.

Opening the CPU Usage Graph 
Prime Network Vision enables you to display memory and CPU usage information for a device or 
network element, including its history.

To open the CPU usage graph:

Step 1 Right-click a network element in the navigation tree and choose Tools > CPU Usage. 

The CPU Usage dialog box displays the following information: 

• CPU Usage—The CPU usage rate as a percentage.

• CPU Usage History—The CPU usage rate history is graphically displayed.

• Memory Usage—The memory usage rate as a percentage.

• Memory Usage History—The memory usage rate history is graphically displayed.

Step 2 If desired, click Save to CSV File to export the displayed data. For more information, see Exporting 
Tables to a File, page 2-55.

Step 3 Click the upper right corner to close the CPU Usage dialog box.
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Communicating with Devices Using Ping and Telnet
Prime Network Vision enables you to communicate with devices in the following ways:

• Pinging a Device, page 4-41

• Telneting a Device, page 4-41

Pinging a Device

Prime Network Vision enables you to ping a device to verify that the device is responding.

The ping is performed from the client to the device, and not from the Prime Network Vision unit hosting 
the VNE to the device.

To ping a device, right-click a device in the navigation tree or map, and choose Tools > Ping.

The results are displayed in a new window. 

Telneting a Device

Prime Network Vision enables you to communicate with a device using the Telnet window.

The Telnet session is performed from the client to the device, and not from the Prime Network Vision 
unit hosting the VNE to the device.

Note If you are using a Windows 7 system, you must enable the Windows Telnet Client before you can use 
the Prime Network Telnet option.

- For Windows 7 32-bit systems, enable the Windows Telnet Client to use the Prime Network Telnet 
option. 

- For Windows 7 64-bit systems, a solution is available on the Cisco Developer Network at 
http://developer.cisco.com/web/prime-network/forums/-/message_boards/view_message/2780108/max
imized?p_p_auth=jmRaG4QY. 

To telnet a device:

Step 1 Right-click a device in the navigation tree or map, and choose Tools > Telnet. A terminal window opens.

Step 2 Log in and use the Telnet window as needed.
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