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C H A P T E R 7

Working with the Prime Network Events Client

These topics describe the Cisco Prime Network Events (Prime Network Events) application and the 
options you can use to view system events and tickets that are generated within the Prime Network 
system:

• User Roles Required to Work with Prime Network Events, page 7-1

• Launching Prime Network Events, page 7-2

• Prime Network Events Window, page 7-4

• Prime Network Events Right-Click Options, page 7-9

• Selecting Prime Network Events Viewing Options, page 7-10

User Roles Required to Work with Prime Network Events
This topic identifies the roles that are required to work with Prime Network Events. Prime Network 
determines whether you are authorized to perform a task as follows: 

• For GUI-based tasks (tasks that do not affect elements), authorization is based on the default 
permission that is assigned to your user account. 

• For element-based tasks (tasks that do affect elements), authorization is based on the default 
permission that is assigned to your account. That is, whether the element is in one of your assigned 
scopes and whether you meet the minimum security level for that scope. 

For more information on user authorization, see the topic on device scopes in the Cisco Prime Network 
3.8 Administrator Guide.
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Only users with the Administrator role can log into Prime Network Events (see Table 7-1). 

Related Topics

• Launching Prime Network Events, page 7-2

• Selecting Prime Network Events Viewing Options, page 7-10

Launching Prime Network Events
Prime Network provides two methods for launching Prime Network Events:

• From the Cisco Prime Central portal 

• As a standalone application

Prime Network Events is password protected to ensure security. Before you start working with Prime 
Network Events, make sure you know your username and password. If you use the standalone 
application, you also need to know the Prime Network Events gateway IP address or hostname.

Note If you do not log into Prime Network Administration, Prime Network Vision, or Prime Network Events 
during a specified period of time (the default is one month) from the standalone application, your 
account is automatically locked. The default period can be changed per user in Prime Network 
Administration. The period of time is measured from the time you last logged out of any of the Prime 
Network client applications. For more information about changing the default period and unlocking an 
account, see the Cisco Prime Network 3.8 Administrator Guide.

The following conditions apply when working with Prime Network Events:

• Prime Network Events shows events only from the fault database and not from the event archive. 
Use Report Manager to view events from the event archive. For more information, see Chapter 10, 
“Working with Reports.”

• Only users with the Administrator role can log into Prime Network Events. 

The following topics describe how to launch Prime Network Events: 

• Launching Prime Network Events from Prime Central, page 7-3

• Launching Prime Network Events as a Standalone Application, page 7-3

Table 7-1 Default Permission/Security Level Required for Prime Network Events

Task Viewer Operator OperatorPlus Configurator Administrator

Opening Prime 
Network Events

— — — — X

Selecting Prime 
Network Events 
viewing options

— — — — X
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Launching Prime Network Events from Prime Central
If Prime Central is available in your environment, you can launch Prime Network applications from the 
main Prime Central page. 

To launch Prime Network Events from Prime Central, choose Assure > Prime Network > Events in the 
menu bar.

The Prime Network Events application is opened in a separate window.

For more information about using Prime Network Events with the Prime Central suite of products, see: 

• Cisco Prime Central 1.0 User Guide 

• Prime Network Events Right-Click Options, page 7-9

Related Topics

• User Roles Required to Work with Prime Network Events, page 7-1

• Launching Prime Network Events, page 7-2

• Prime Network Events Window, page 7-4

Launching Prime Network Events as a Standalone Application
To launch Prime Network Events as a standalone application:

Step 1 Choose Start > Programs > Cisco Prime Network > gateway hostname/IP address >Cisco Prime 
Network Events.

Note The hostname/IP address corresponds to the gateway on which Prime Network was configured.

The Cisco Prime Network Events login dialog box is displayed.

Step 2 Enter your username and password. 

The Server field should already be populated with the hostname/IP address of the Prime Network 
gateway.

Step 3 Click OK. 

When you launch Prime Network Events, messages are displayed if the server and client have different 
versions of the application that launches the client. For more information about these messages, see the 
Cisco Prime Network 3.8 Installation Guide. 

The first time you log in, the Ticket tab is displayed in the Cisco Prime Network Events window.

When you log in again, the tab and filter that were visible when you last logged out of the application 
are displayed.

Related Topics

• Prime Network Events Window, page 7-4

• Selecting Prime Network Events Viewing Options, page 7-10
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Prime Network Events Window
The Prime Network Events window displays the events generated in the system. Figure 7-1 shows an 
example of the Prime Network Events window.

Figure 7-1 Prime Network Events Window 

Prime Network Events displays events for the last two days by default. To modify the default number of 
days for which events are displayed, see Selecting Prime Network Events Viewing Options, page 7-10. 
Increasing the number of days can affect how long it takes for the events to be displayed.

You can display the events table with or without the properties pane, and select the specific type of 
information to display, such as provisioning events or SNMPv3 traps. For details on the information that 
is displayed in each tab, see Viewing Events and Tickets in Cisco Prime Network Events, page 8-2. 

1 Menu bar 4 Details or properties pane

2 Toolbar 5 Status bar

3 Table pane 6 Prime Network Events tabs
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You can also use the Prime Network Events window and menu options to:

• Filter results so that events meeting your criteria are displayed. See Filtering Events, page 8-24.

• View selected event properties in a separate window. See Viewing Event Properties, page 8-16.

Event Status Indicators

The Severity column contains color-coded icons that reflect the severity of the event. An icon appears 
for each ticket or event in the Prime Network Events tabs (based on its severity) as shown in Table 7-2. 

Event Types and Categories

Every event that occurs in the Prime Network system and the Prime Network gateway is logged. This 
includes events that are performed as part of the normal operation of the Prime Network system, as well 
as events that might need further attention. Events are categorized, and any of the log entries can be 
viewed in the Prime Network Events tabs as described in Table 7-3. 

Table 7-2 Severity Indicators

Icon Color Severity

Red Critical 

Orange Major

Yellow Minor

Light Blue Warning

Green Cleared, Normal, or OK

Medium Blue Information 

Dark blue Indeterminate

Table 7-3 Event Categories in Prime Network Events

Tab Description

Audit Events related to commands running in the Prime Network gateway.

Provisioning Events related to configuration and provisioning activities, 
including activations from Prime Network Activation. 

Security Events related to client login and user activity when managing the 
system and the environment.

Service Events related to the alarms that are generated by the Prime 
Network system.
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Related Topics

• Prime Network Events Toolbar, page 7-7

• Selecting Prime Network Events Viewing Options, page 7-10

• Chapter 8, “Tracking Faults Using Prime Network Events”

Syslog Events related to the predefined set of syslogs received from the 
devices by the VNEs, which are used to generate the syslog events.

System Events related to the everyday working of the internal system and 
its components. These events may be related to Prime Network and 
Prime Network gateway resources, representing the system log.

Ticket Tickets that were opened in Prime Network.

V1 Trap SNMPv1 traps that are generated by a network element and received 
by Prime Network; Prime Network uses these traps to generate the 
trap events.

V2 Trap SNMPv2 traps that are generated by a network element and received 
by Prime Network; Prime Network uses these traps to generate the 
trap events.

V3 Trap SNMPv3 traps that are generated by a network element and received 
by Prime Network; Prime Network uses these traps to generate the 
trap events.

All A flat list of all events and tickets, sorted by time. 

Displayed when you choose File > Open All Tab. 

3.6.x Type Five tabs where Type represents one of the following: 

• Ticket

• Service

• Syslog

• V1 Trap

• V2-V3 Trap

These tabs are:

• Available only if Prime Network was upgraded from 
Cisco ANA 3.6.x to the current Prime Network version. 

• Displayed when you choose File > Open 3.6.x Tabs. 

Table 7-3 Event Categories in Prime Network Events (continued)

Tab Description
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Prime Network Events Toolbar
Table 7-4 describes the tools that are displayed in the Prime Network Events toolbar.

Related Topics

• Prime Network Events Window, page 7-4

• Prime Network Events Menu Bar, page 7-8

• Chapter 8, “Tracking Faults Using Prime Network Events”

Table 7-4 Prime Network Events Toolbar Tools

Button Function

Displays the previous page of events in the Prime Network Events window.

Displays the next page of events in the Prime Network Events window.

Refreshes the events displayed in the log by querying the database. If a filter is active, the 
refresh is done according to the filter. The log returns to the beginning of the list, 
displaying the events in ascending or descending order depending on the order of the 
current list. Descending order means that the last event is displayed first. For more 
information, see Refreshing Cisco Prime Network Events Information, page 8-23.

Displays the Filter Events dialog box, which enables you to define a filter for the events 
displayed in the Prime Network Events log. For more information, see Filtering Events, 
page 8-24.

Clears the existing filter. 

Displays the Find Events dialog box so that you can view events matching specific 
criteria. When finished selecting your criteria, click OK. The Prime Network Events 
window updates and displays the matching events. Note the following:

• You can select multiple criteria here, as needed.

• The Find Events dialog box returns every matching event in the database unless you 
specify a specific timeframe. This differs from the Filter Events dialog box, which 
returns events from the past 2 days (by default).

For a description of the items in the Find Events dialog box, see Table 8-23 on page 8-26.

Toggles automatic refresh of event data on and off. You define the refresh-time period (in 
seconds) in the Prime Network Events Options dialog box. The default is 60 seconds. If a 
filter is active, the refresh is done according to the filter. For more information, see 
Selecting Prime Network Events Viewing Options, page 7-10.

Displays the properties of the selected event or ticket in the Properties pane.
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Prime Network Events Menu Bar 
Table 7-5 describes the options available in the Prime Network Events main menus. In addition to these 
options, Prime Network Events displays a Properties option when you right-click an event or ticket (see 
Viewing Event Properties, page 8-16). 

Table 7-5 Prime Network Events Menu Options

Menu Option Description

File Menu

Export Exports the log event information displayed in the Prime Network Events 
window according to the criteria defined in the Prime Network Events Options 
dialog box.

Open 3.6.x Tabs Displays the following tabs:

• 3.6.x Ticket

• 3.6.x Service

• 3.6.x Syslog

• 3.6.x V1 Trap

• 3.6.x V2-V3 Trap

This option is available only if Prime Network was upgraded from Cisco ANA 
3.6.x to the current version of Prime Network.

Open All Tab Displays the All tab so you can view a flat list of all events and tickets sorted only 
by time.

Exit Exits Prime Network Events. 

Edit Menu

Filter Defines a filter for the events displayed in the Prime Network Events window 
according to the tab selected. See Filtering Events, page 8-24.

Purge This option is unavailable.

View Menu

Refresh Refreshes the information displayed in the Prime Network Events window.

Go To Navigates through the pages of the Prime Network Events window. 

Properties Displays the properties of the selected event, such as the root cause and source, 
in a separate window. For more information, see Viewing Event Properties, 
page 8-16.

Details Pane Displays or hides the Details pane. If an event is selected, the properties of the 
selected event are displayed in the Details pane.

Tools Menu

Change User 
Password

Allows you to change the password used when logging into the Prime Network 
Events client application suite. The change takes effect the next time you log into 
the application.

Options Defines the display options for the Prime Network Events window. For more 
information, see Selecting Prime Network Events Viewing Options, page 7-10
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Related Topics

• Prime Network Events Window, page 7-4

• Prime Network Events Right-Click Options, page 7-9

• Chapter 8, “Tracking Faults Using Prime Network Events”

Prime Network Events Right-Click Options
Prime Network Events offers the following right-click options in its tabs. Not all options are available 
in all tabs.

• Show Only Selected Rows—Displays only the rows that you choose.

• Show All Rows—Displays all rows that meet the current filter criteria.

• Launch external applications or tools—Enables you to launch any external application or tool for 
any event in Prime Network Events. For more information, see the Cisco Prime Network 3.8 
Customization User Guide. 

• Properties—Displays the properties window for the selected event or ticket. 

Related Topics

• Selecting Prime Network Events Viewing Options, page 7-10

• Prime Network Events Toolbar, page 7-7

• Chapter 8, “Tracking Faults Using Prime Network Events”

Reports Menu

Report Manager Opens the Reports Manager dialog box so you can create, run, and manage 
reports.

Run Report Enables you to run standard event, inventory, and network service reports on 
demand.

Help Menu

Cisco Prime 
Network Events 
Help

Opens the online help for Prime Network Events and Prime Network Vision.

Cisco.com This option is unavailable.

About Cisco Prime 
Network Events

Displays application information, such as the version number.

Table 7-5 Prime Network Events Menu Options (continued)

Menu Option Description
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Selecting Prime Network Events Viewing Options
The Prime Network Events Options dialog box enables you to define the options for displaying events 
in the Prime Network Events window.

To define Prime Network Events options:

Step 1 From the main menu, choose Tools > Options. 

The Prime Network Events Options dialog box is displayed, as shown in Figure 7-2. 

Figure 7-2 Prime Network Events Options Dialog Box

Step 2 Set the options, using the information in Table 7-6.

Table 7-6 Prime Network Events Options Dialog Box

Option Description

Save last filter Saves the filter criteria defined per event type in the Filter Events dialog box. The 
filter criteria are available the next time you log into Prime Network Events. 

Note Events are not filtered automatically when you next log into Prime 
Network Events unless the Open Events with saved filter option is also 
selected.

Open Events with 
saved filter

When enabled, applies the previously defined filter to the events as soon as you 
log into Prime Network Events. The events are continuously filtered according 
to the defined settings, even after you close the application.

Show n events 
per page

Specifies the number of events to be displayed per page.

Export n events 
in total

Sets the maximum number of events to be exported to a file.
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Step 3 Click OK.

Related Topics

• Prime Network Events Toolbar, page 7-7

• Prime Network Events Menu Bar, page 7-8

• Chapter 8, “Tracking Faults Using Prime Network Events”

Run auto refresh 
every n secs

Automatically refreshes the Prime Network Events display after the specified 
number of seconds. 

Note This option uses rapid refresh from the database, which can affect the 
performance of other vital database options.

Display events for 
the last n days

Displays past events from the specified number of days. Values range from 1 to 
14 days, with a default of 2 days.

If you increase the number of days, it can take longer for the events to be 
displayed.

Table 7-6 Prime Network Events Options Dialog Box (continued)

Option Description
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