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C H A P T E R 8

Working with the Prime Network Events Client

These topics describe the Cisco Prime Network Events (Prime Network Events) application and the 
options you can use to view system events and tickets that are generated within the Prime Network 
system:

• User Roles Required to Work with Prime Network Events, page 8-1

• Launching Prime Network Events, page 8-2

• Prime Network Events Window, page 8-2

• Prime Network Events Right-Click Options, page 8-7

• Adjusting the Prime Network Events GUI Client Settings, page 8-8

User Roles Required to Work with Prime Network Events
This topic identifies the roles that are required to work with Prime Network Events. Prime Network 
determines whether you are authorized to perform a task as follows: 

• For GUI-based tasks (tasks that do not affect elements), authorization is based on the default 
permission that is assigned to your user account. 

• For element-based tasks (tasks that do affect elements), authorization is based on the default 
permission that is assigned to your account. That is, whether the element is in one of your assigned 
scopes and whether you meet the minimum security level for that scope. 

For more information on user authorization, see the topic on device scopes in the Cisco Prime Network 
3.10 Administrator Guide.
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  Launching Prime Network Events
Only users with the Administrator role can log into Prime Network Events (see Table 8-1). 

Launching Prime Network Events
Prime Network Vision is password protected to ensure security. Before you start working with Prime 
Network Events, make sure you know your username and password. If you use the standalone 
application, you also need to know the Prime Network Events gateway IP address or hostname.

• Launch Prime Network Events from Prime Central—Choose Assure > Prime Network > Events in 
the menu bar. The Prime Network Events application is opened in a separate window. For 
information on Prime Central, see the Cisco Prime Central User Guide.

• Launch Prime Network Events as a Standalone Application—Choose 
Start > Programs > Cisco Prime Network > gateway IP address > Cisco Prime Network Events, 
and enter your username and password. If any client updates are available, Prime Network 
automatically installs them. 

If you see messages that say the server and client have different versions of the application, you need 
to updated your client as described in the Cisco Prime Network 3.10 Installation Guide.

The following conditions apply when working with Prime Network Events:

• Prime Network Events shows events only from the fault database and not from the event archive. 
Use Report Manager to view events from the event archive. For more information, see Chapter 11, 
“Working with Reports.”

• Only users with the Administrator role can log into Prime Network Events. 

Prime Network Events Window
The Prime Network Events window displays the events generated in the system. Figure 8-1 shows an 
example of the Prime Network Events window.

Table 8-1 Default Permission/Security Level Required for Prime Network Events

Task Viewer Operator OperatorPlus Configurator Administrator

Opening Prime 
Network Events

— — — — X

Selecting Prime 
Network Events 
viewing options

— — — — X
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  Prime Network Events Window
Figure 8-1 Prime Network Events Window 

Prime Network Events displays events for the last two hours by default. To modify the default number 
of hours for which events are displayed, see Adjusting the Prime Network Events GUI Client Settings, 
page 8-8. Increasing the number of hours can affect how long it takes for the events to be displayed. 
Also, if you want to find specific events and you are not interested in browsing all the available events, 
you can set Prime Network Events to operate in Find mode. To enable and use Find mode, see Adjusting 
the Prime Network Events GUI Client Settings, page 8-8.

You can display the events table with or without the properties pane, and select the specific type of 
information to display, such as provisioning events or SNMPv3 traps. For details on the information that 
is displayed in each tab, see Viewing Events and Tickets in Cisco Prime Network Events, page 9-2. 

1 Menu bar 4 Details or properties pane

2 Toolbar 5 Status bar

3 Table pane 6 Prime Network Events tabs
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  Prime Network Events Window
You can also use the Prime Network Events window and menu options to:

• Filter results so that events meeting your criteria are displayed. See Filtering Events, page 9-22.

• View selected event properties in a separate window. See Viewing Event Properties, page 9-14.

Event Status Indicators

The Severity column contains color-coded icons that reflect the severity of the event. An icon appears 
for each ticket or event in the Prime Network Events tabs (based on its severity) as shown in Table 8-2. 

Event Types and Categories

Every event that occurs in the Prime Network system and the Prime Network gateway is logged. This 
includes events that are performed as part of the normal operation of the Prime Network system, as well 
as events that might need further attention. Events are categorized, and any of the log entries can be 
viewed in the Prime Network Events tabs as described in Table 8-3. 

Table 8-2 Severity Indicators

Icon Color Severity Icon Color Severity

Red Critical Light Blue Warning

Orange Major Medium Blue Information 

Yellow Minor Dark blue Indeterminate

Green Cleared, Normal, or 
OK

Table 8-3 Event Categories in Prime Network Events

Tab Description

Audit Events related to commands running in the Prime Network gateway.

Provisioning Events related to configuration and provisioning activities, 
including activations from Prime Network Activation. 

Security Events related to client login and user activity when managing the 
system and the environment.

Service Events related to the alarms that are generated by the Prime 
Network system.

Syslog Events related to the predefined set of syslogs received from the 
devices by the VNEs, which are used to generate the syslog events.

System Events related to the everyday working of the internal system and 
its components. These events may be related to Prime Network and 
Prime Network gateway resources, representing the system log.

Ticket Tickets that were opened in Prime Network.
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  Prime Network Events Window
Prime Network Events Toolbar
Table 8-4 describes the tools that are displayed in the Prime Network Events toolbar.

V1 Trap SNMPv1 traps that are generated by a network element and received 
by Prime Network; Prime Network uses these traps to generate the 
trap events.

V2 Trap SNMPv2 traps that are generated by a network element and received 
by Prime Network; Prime Network uses these traps to generate the 
trap events.

V3 Trap SNMPv3 traps that are generated by a network element and received 
by Prime Network; Prime Network uses these traps to generate the 
trap events.

All A flat list of all events and tickets, sorted by time. 

Displayed when you choose File > Open All Tab. 

3.6.x Type Five tabs where Type represents one of the following: 

• Ticket

• Service

• Syslog

• V1 Trap

• V2-V3 Trap

These tabs are:

• Available only if Prime Network was upgraded from 
Cisco ANA 3.6.x to the current Prime Network version. 

• Displayed when you choose File > Open 3.6.x Tabs. 

Table 8-3 Event Categories in Prime Network Events (continued)

Tab Description

Table 8-4 Prime Network Events Toolbar Tools

Button Function

Displays the previous page of events in the Prime Network Events window.

Displays the next page of events in the Prime Network Events window.

Refreshes the events displayed in the log by querying the database. If a filter is active, the 
refresh is done according to the filter. The log returns to the beginning of the list, 
displaying the events in ascending or descending order depending on the order of the 
current list. Descending order means that the last event is displayed first. For more 
information, see Refreshing Cisco Prime Network Events Information, page 9-21.

Displays the Filter Events dialog box, which enables you to define a filter for the events 
displayed in the Prime Network Events log. For more information, see Filtering Events, 
page 9-22.
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  Prime Network Events Window
Prime Network Events Menu Bar 
Table 8-5 describes the options available in the Prime Network Events main menus. In addition to these 
options, Prime Network Events displays a Properties option when you right-click an event or ticket (see 
Viewing Event Properties, page 9-14). 

Clears the existing filter. 

Displays the Find Events dialog box so that you can view events matching specific 
criteria. When finished selecting your criteria, click OK. The Prime Network Events 
window updates and displays the matching events. Note the following:

• You can select multiple criteria here, as needed.

• The Find Events dialog box returns every matching event in the database unless you 
specify a specific timeframe. This differs from the Filter Events dialog box, which 
returns events from the past 2 days (by default).

For a description of the items in the Find Events dialog box, see Table 9-23.

Toggles automatic refresh of event data on and off. You define the refresh-time period (in 
seconds) in the Prime Network Events Options dialog box. The default is 60 seconds. If 
a filter is active, the refresh is done according to the filter. For more information, see 
Adjusting the Prime Network Events GUI Client Settings, page 8-8.

Displays the properties of the selected event or ticket in the Properties pane.

Table 8-4 Prime Network Events Toolbar Tools (continued)

Button Function

Table 8-5 Prime Network Events Menu Options

Menu Option Description

File Menu

Export Exports the log event information displayed in the Prime Network Events 
window according to the criteria defined in the Prime Network Events Options 
dialog box.

Open 3.6.x Tabs Displays the following tabs:

• 3.6.x Ticket

• 3.6.x Service

• 3.6.x Syslog

• 3.6.x V1 Trap

• 3.6.x V2-V3 Trap

This option is available only if Prime Network was upgraded from Cisco ANA 
3.6.x to the current version of Prime Network.

Open All Tab Displays the All tab so you can view a flat list of all events and tickets sorted only 
by time.

Exit Exits Prime Network Events. 
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Chapter 8      Working with the Prime Network Events Client
  Prime Network Events Right-Click Options
Prime Network Events Right-Click Options
Prime Network Events offers the following right-click options in its tabs. Not all options are available 
in all tabs.

• Show Only Selected Rows—Displays only the rows that you choose.

• Show All Rows—Displays all rows that meet the current filter criteria.

Edit Menu

Filter Defines a filter for the events displayed in the Prime Network Events window 
according to the tab selected. See Filtering Events, page 9-22.

Purge This option is unavailable.

View Menu

Refresh Refreshes the information displayed in the Prime Network Events window.

Go To Navigates through the pages of the Prime Network Events window. 

Properties Displays the properties of the selected event, such as the root cause and source, 
in a separate window. For more information, see Viewing Event Properties, 
page 9-14.

Details Pane Displays or hides the Details pane. If an event is selected, the properties of the 
selected event are displayed in the Details pane.

Tools Menu

Change User 
Password

Allows you to change the password used when logging into the Prime Network 
Events client application suite. The change takes effect the next time you log into 
the application.

Options Defines the display options for the Prime Network Events window. For more 
information, see Adjusting the Prime Network Events GUI Client Settings, 
page 8-8

Reports Menu

Report Manager Opens the Reports Manager dialog box so you can create, run, and manage 
reports.

Run Report Enables you to run standard event, inventory, and network service reports on 
demand.

Help Menu

Cisco Prime 
Network Events 
Help

Opens the online help for Prime Network Events and Prime Network Vision.

Cisco.com This option is unavailable.

About Cisco Prime 
Network Events

Displays application information, such as the version number.

Table 8-5 Prime Network Events Menu Options (continued)

Menu Option Description
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Chapter 8      Working with the Prime Network Events Client
  Adjusting the Prime Network Events GUI Client Settings
• Launch external applications or tools—Enables you to launch any external application or tool for 
any event in Prime Network Events. For more information, see the Cisco Prime Network 3.10 
Customization Guide. 

• Properties—Displays the properties window for the selected event or ticket. 

Adjusting the Prime Network Events GUI Client Settings
The Prime Network Events Options dialog box enables you to define the options for displaying events 
in the Prime Network Events window. To view these settings, choose Tools > Options from the main 
menu. The options are displayed in Table 8-6.

Table 8-6 Options for Changing Prime Network Events GUI Client

Option Description

Save last filter Saves the filter criteria defined per event type in the Filter Events dialog box. The 
filter criteria are available the next time you log into Prime Network Events. 

Note Events are not filtered automatically when you next log into Prime 
Network Events unless the Open Events with saved filter option is also 
selected.

Open 
Prime Network 
Events with saved 
filter

When enabled, applies the previously defined filter to the events as soon as you 
log into Prime Network Events. The events are continuously filtered according 
to the defined settings, even after you close the application.

Display n records 
per page

Specifies the number of events to be displayed per page.

Export n records 
in total

Sets the maximum number of events to be exported to a file.

Run auto refresh 
every n secs

Automatically refreshes the Prime Network Events display after the specified 
number of seconds. 

Note This option uses rapid refresh from the database, which can affect the 
performance of other vital database options.

Display data for the 
last n hours

Displays past events from the specified number of hours. Values range from 1 to 
336 hours (14 days), with a default of 2 hours.

If you increase the number of hours, it can take longer for the events to be 
displayed.

Find mode (No 
automatic data 
retrieval)

Operates the Prime Network Events window in Find mode. In this mode, no 
events will be retrieved from the database when you open the application or 
switch between tabs. You can click the Find button in the toolbar to search for 
the events you need.

When in Find mode, the status bar in the Prime Network Events window shows 
“Find Mode (no automatic data retrieval).”
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