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Basic Operations

This chapter provides information about basic operations that you can perform in the Cisco Mobile 
Wireless Transport Manager (MWTM), and contains:

• Changing Client and Web Preference Settings, page 5-1

• Viewing Online Help, page 5-22

• Finding Information in a Window, page 5-23

• Navigating Table Columns, page 5-24

• Printing Windows, page 5-25

• Managing and Deploying ITP Files, page 5-25

• Exporting Data, page 5-38

• Integrating the MWTM with Other Products, page 5-39

• Running Simultaneous Client Sessions, page 5-43

• Performing Basic Server Operations, page 5-43

• Using the Command Line Interface, page 5-47

Note The default directory for installing the MWTM is /opt. In commands that call for the default directory, 
if you installed the MWTM in a different directory, you must specify that directory instead of /opt.

Changing Client and Web Preference Settings
This section contains this information:

• Changing Client Preference Settings, page 5-2

• Changing Web Preference Settings, page 5-20

• Changing Real-Time Poller and Counter Settings, page 5-21
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Changing Client Preference Settings
When a user changes some aspect of the MWTM client, such as the size of a window, or the order of 
columns in a window, the MWTM makes note of the user’s preferences on the MWTM client and server. 
The MWTM saves the user’s preferences to the MWTM server when the MWTM client exits.

Thereafter, whenever the user launches the MWTM client, the MWTM searches for the user’s 
preferences. If the MWTM finds the user’s preferences on the MWTM server, the MWTM launches the 
MWTM client with those preferences. Otherwise, the MWTM launches the MWTM client with the 
default preferences file.

In addition to the user preferences that the MWTM automatically saves, you use the MWTM to change 
many GUI, data, topology, and table settings that affect the way the MWTM presents its information.

Note Anyone who uses the MWTM client can change its preference settings, and the changes affect all views 
running on this client.

To change overall MWTM preference settings, choose Edit > Preferences from the MWTM client main 
menu. The MWTM displays the Preferences window.

Figure 5-1 Preferences Window (Client)
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In the Preferences window, you can:

• Displaying the Preferences Menu, page 5-3

• Changing General GUI Settings, page 5-4

• Changing Alarm and Event Settings, page 5-8

• Changing Charts Settings, page 5-11

• Changing Status Settings, page 5-12

• Changing CiscoWorks Server Settings, page 5-13

• Changing Topology Settings, page 5-14

• Changing Deploy Settings, page 5-16

• Customizing Colors, page 5-18

• Restoring Default Preference Settings, page 5-19

Displaying the Preferences Menu

The menu on the Preferences window contains:

Option Description

File > Load System 
Default Prefs

Restores all preference settings to the original system default settings.

File > Save
(Ctrl-S)

Saves the preference changes.

File > Close
(Ctrl-W)

Closes the Preferences window.

To close the Preferences window at any time, choose File > Close. If you have 
changed any preferences, the MWTM asks if you want to apply the changes 
before leaving the window:

• Click Yes to apply the changes and close the prompt window and the 
Preferences window.

• Click No to close the prompt window and the Preferences window without 
applying or saving any changes.

• Click Cancel to close the prompt window without applying any changes. 
The Preferences window remains open.

Help > Topics
(F1)

Displays the table of contents for the MWTM online help.

Help > Window
(Shift-F1)

Displays online help for the current window.

Help > About
(F3)

Displays build date, version, SSL support, and copyright information about the 
MWTM application.
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Changing General GUI Settings

You use the General GUI settings in the Preferences window to change general display settings for the 
MWTM, including which window to display first when starting the MWTM, and whether to display 
values in bits or bytes.

To display the General GUI settings, choose General GUI in the left pane of the Preferences window.

In the General GUI area you can change:

• Startup/Exit Settings, page 5-4

• General Display Settings, page 5-4

• Node Name Settings, page 5-5

• Poller Settings, page 5-6

• Troubleshooting, page 5-6

• Connection Settings, page 5-7

• Repaint Priority, page 5-7

Startup/Exit Settings

Use the Startup/Exit Settings pane of the General GUI settings to specify whether you want to display 
the topology window when you launch the MWTM client, and whether you want the MWTM to prompt 
you for confirmation when you exit the MWTM client.

The Startup/Exit Settings pane contains:

General Display Settings

Use the General Display pane of the General GUI settings to specify whether the MWTM should:

• Display node domain names.

• Show details in bits instead of bytes.

• Show receive and send utilizations as percentages.

• Show the point code mask in bits instead of dotted notation.

Check Box Description

MWTM: Topology Window If checked, causes the topology window to appear when you start the 
MWTM. The default setting for this check box is unchecked.

Confirm Exit If checked, the MWTM prompts you for confirmation when you exit 
the MWTM client. The default setting for this check box is checked.

Confirm Deletes If checked, the MWTM prompts you for confirmation when you 
delete an object. The default setting for this check box is checked.

Note If you check the Do not show this again check box in a 
Confirm Deletion dialog box, and you later decide that you do 
want the MWTM to display the Confirm Deletion dialog box, 
you must check the Confirm Deletions check box.

Confirm In Band Polls If checked, the MWTM prompts you for confirmation when you 
access a function that requires the MWTM to perform in-band polling 
of the object. 
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The General Display pane contains:

Node Name Settings

Use the Node Name pane of the General GUI settings to specify how the MWTM should display node 
names.

The Node Name pane contains these radio buttons:

Check Box Description

Show Node Domain Names If checked, the MWTM shows node domain names in its displays. 
The default setting for this check box is unchecked (do not show 
node domain names).

Show Details in Bits Instead of 
Bytes

If checked, the MWTM displays data and data rates in bits instead 
of bytes:

• Check if you want the MWTM to display data in bits, and data 
rates in bits per second. This is the default setting.

• Uncheck if you want the MWTM to display data in bytes, and 
data rates in bytes per second.

Show Utilization as Percentage If checked, the MWTM displays receive and send utilization for 
linksets and links as a percentage:

• Check if you want the MWTM to display utilization as a 
percentage. This is the default setting.

• Uncheck if you want the MWTM to display utilization in 
Erlangs.

Show Point Code Mask in Bits 
(ITP only)

If checked, the MWTM displays point code masks as a number of 
bits instead of dotted-decimal format. The MWTM applies this 
setting to all point code masks in the MWTM client, including 
those in the Route Table dialog box, in messages, and so on.

• Uncheck if you want the MWTM to display point code masks 
in dotted-decimal format (octets separated by periods). This is 
the default setting.

• Check if you want the MWTM to display point code masks as 
a number of bits.

For more information about point code masks, see Route Table, 
page 13-8.

Radio Buttons Description

Show DNS or User Defined 
Names

Indicates whether the MWTM should identify nodes by their DNS or 
user-defined names. The default setting for this radio button is 
clicked.

Show IP Address in Name 
Field

Radio button used to indicate whether the MWTM should identify 
nodes by their IP addresses. The default setting for this radio button is 
unclicked.
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Poller Settings

Use the Poller pane of the General GUI settings to change the MWTM poller and counter settings.

The Poller pane contains:

Troubleshooting

Use the Troubleshooting pane of the General GUI settings to specify whether the MWTM clears the 
display window upon command execution.

The Troubleshooting pane contains:

Field or Radio Button Description

Fast Poller Default (secs) Default interval, in seconds, for the fast poller. The valid range is 
5  to 60 seconds. The default setting is 15 seconds.

The fast poller appears in these MWTM client windows:

• MWTM Real-Time Statistics: CPU Statistics window

• (ITP only) Details window for an Application Server

• (ITP only) Details window for a Linkset

• (ITP only) Details window for a Signaling Gateway Mated 
Pair

You can change the valid range and default setting in the 
Server.properties file. For more information, see Changing 
MWTM Server Poller Settings, page 3-2.

Slow Poller Default (secs) Default interval, in seconds, for the slow poller. The valid range 
is 60 seconds to 300 seconds. The default setting is 60 seconds.

The slow poller is used in all the MWTM client windows except 
those listed previously that use the fast poller.

Note You can change the valid range and default setting in the 
Server.properties file. For more information, see 
Changing MWTM Server Poller Settings, page 3-2.

Show Counters Since Reboot Radio button used to configure the MWTM client to clear all 
counters in MWTM web pages whenever the node reboots. The 
default setting for this radio button is clicked.

Show Counters Since Last Poll Radio button used to configure the MWTM client to clear all 
counters whenever an MWTM web page is polled. The default 
setting for this radio button is unclicked.

Show Counters Since User Reset Radio button used to configure the MWTM client to clear all 
MWTM counters whenever the user resets the counters on an 
MWTM web page. The default setting for this radio button is 
unclicked.

Field Description

Clear Display upon Execution Clears the output display each time you execute a command.
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Connection Settings

Use the Connection Settings pane of the General GUI settings to set the Telnet or SSH path and 
arguments for accessing nodes using one of these methods.

Note To connect to a node using SSH, the key size on the node must be configured to a minimum of 768 bits 
and a maximum of 2048 bits.

The Connection Settings pane contains:

Repaint Priority

Use the Repaint Priority pane of the General GUI settings to balance the responsiveness versus efficiency 
of the MWTM client. This setting controls how quickly the MWTM client repaints its displays.

The Repaint Priority pane contains a sliding control:

Field Description

Telnet path Use to modify the default MWTM Telnet path to an executable file (for example, 
putty.exe). Click Find to choose a Telnet path on your local machine. 

Note Choosing a non-GUI file might not yield the expected results.

Telnet arguments Optional arguments that the MWTM passes to the Telnet executable when the 
MWTM invokes it. For example, to set the host name and port number for the 
connection, specify -telnet $host $port. 1

1. When you right-click a node in the navigation tree and choose Connect To, the variables $host and $port are replaced with 
the host name and port number of the node. 

SSH path Use to modify the default MWTM SSH path to an executable file (for example, 
putty.exe). Click Find to choose an SSH path on your local machine.

Note Choosing a non-GUI file may not yield the expected results.

SSH arguments Optional arguments that the MWTM passes to the SSH executable when the 
MWTM invokes it. For example, to set the host name and port number for the 
connection, specify -ssh $host $port. 1

Field Description

Repaint Priority Balances the MWTM client’s responsiveness versus efficiency. The valid range is 
0 through 10, with 0 representing a high repaint priority (high responsiveness, low 
efficiency) and 10 representing a high communication priority (high efficiency, 
low responsiveness):

• To maximize repainting (responsiveness) over communication (efficiency), 
slide the selector toward High Repaint Priority.

• To maximize communication (efficiency) over repainting (responsiveness), 
slide the selector toward High Comm. Priority.

• The default setting is 2 (the third mark from the left).
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Changing Alarm and Event Settings

Use the Alarms / Events settings in the Preferences window to:

• Change the default background color for each type of alarm or event

• Specify whether to display acknowledged alarms or events

• Specify the types of events the MWTM should display in the alarms and events tables, including the:

– Category and severity

– Whether the event is acknowledged

– Other properties

To display the preference settings for alarms and events, select Alarms / Events in the left pane of the 
Preferences window.

In the right pane you can change:

• Colors, page 5-8

• Alarm-specific Colors, page 5-8

• Time Format, page 5-9

• Date Format, page 5-9

• Categories, page 5-9

• Severities, page 5-10

• Other, page 5-11

Colors

The Alarm / Event Colors pane contains:

Alarm-specific Colors

The Alarm-specific Colors pane contains:

Field Description

Change Color Opens the Select Event Color dialog box from which you select a color for an alarm 
or event type. For more details, see Customizing Colors, page 5-18.

Critical Indicates the background color for Critical alarms or events. The default is red.

Major Indicates the background color for Major alarms or events. The default is orange.

Minor Indicates the background color for Minor alarms or events. The default is yellow.

Warning Indicates the background color for Warning alarms or events. The default is blue.

Informational Indicates the background color for Informational alarms or events. The default is 
white.

Indeterminate Indicates the background color for Indeterminate alarms or events. The default is 
cyan.

Normal Indicates the background color for Normal alarms or events. The default is light 
green.
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Time Format

The Time Format pane contains:

Date Format

The Date Format pane contains:

Categories

In the Categories pane, you specify which event categories to display in the Event History window.

The Categories pane contains:

Field Description

Change Color Opens the Select Event Color dialog box from which you select a color for alarms 
and events of unmanaged objects. For more details, see Customizing Colors, 
page 5-18.

Unmanaged Indicates the background color for unmanaged alarms or events. The default is gray.

Button Description

12 Hour Click this radio button to configure alarm or event time stamps to use 12-hour format (for 
example, 07:10:09).

24 Hour Click this radio button to configure alarm or event time stamps to use 24-hour format (for 
example, 19:10:09).

Button Description

Month-First Click this radio button to configure alarm or event date stamps with the month 
appearing first (for example, 8/16/05).

Day-First Click this radio button to configure alarm or event date stamps with the day appearing 
first (for example, 16/8/05).

Field or 
Button Description

Status Indicates whether Status events should appear in the Event History window. The 
default is checked.

Trap Indicates whether Trap events should appear in the Event History window. The default 
is checked.

Create Indicates whether Create events should appear in the Event History window. The 
default is checked.

Delete Indicates whether Delete events should appear in the Event History window. The 
default is checked.

Discover Indicates whether Discover events should appear in the Event History window. The 
default is checked.
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Note The fields in the previous table are default categories; however, the MWTM system administrator might 
define additional categories. For information about custom categories, see Changing Event Categories, 
page 9-41.

Severities

In the Severities pane, you specify which alarm or event severities to display in the Event History and 
Active Alarms windows.

The Severities pane contains these default fields:

Edit Indicates whether Edit events should appear in the Event History window. The default 
is checked.

Ignore Indicates whether Ignore events should appear in the Event History window. The 
default is checked.

Login Indicates whether Login events should appear in the Event History window. The 
default is checked.

LoginDisable Indicates whether LoginDisable events should appear in the Event History window. 
The default is checked.

LoginFail Indicates whether LoginFail events should appear in the Event History window. The 
default is checked.

Logout Indicates whether Logout events should appear in the Event History window. The 
default is checked.

OverWrite Indicates whether OverWrite events should appear in the Event History window. The 
default is checked.

Poll Indicates whether Poll events should appear in the Event History window. The default 
is checked.

Purge Indicates whether Purge events should appear in the Event History window. The default 
is checked.

Select All Checks all event category check boxes.

Deselect All Unchecks all event category check boxes.

Field or 
Button Description

Field Description

Critical Indicates whether alarms and events of severity Critical should appear in the window. 
The default is checked.

Major Indicates whether alarms and events of severity Major should appear in the window. 
The default is checked.

Minor Indicates whether alarms and events of severity Minor should appear in the window. 
The default is checked.

Warning Indicates whether alarms and events of severity Warning should appear in the 
window. The default is checked.
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Other

Use the Other pane to further define the filter for the Event History and Active Alarms windows. These 
settings apply to all event displays in the current view.

The Other pane contains:

Changing Charts Settings

Use the Charts pane in the Preferences window to change default settings for the elements in real-time 
data charts for application servers, application server process associations, links, and linksets.

To display the Charts pane, click Charts in the left pane of the Preferences window.

Informational Indicates whether alarms and events of severity Informational should appear in the 
window. The default is checked.

Indeterminate Indicates whether alarms and events of severity Indeterminate should appear in the 
window. The default is checked.

Normal Indicates whether alarms and events of severity Normal should appear in the window. 
The default is checked.

Field Description

Check Box or Field Description

Acknowledged Indicates whether only acknowledged alarms and events should appear in the 
window. The default is checked.

Unacknowledged Indicates whether only unacknowledged alarms and events should appear in the 
window. The default is checked.

Time Before Indicates whether only alarms and events that the MWTM logs prior to a 
specified date and time should appear in the window. The default is checked.

Time Before Field Specifies the date and time prior to which alarms and events that the MWTM 
logs should appear in the window. This field is dimmed unless the Time Before 
check box is checked.

Time After Indicates whether only alarms and events that the MWTM logs after a specified 
date and time should appear in the window. The default is checked.

Time After Field Specifies the date and time after which alarms and events that the MWTM logs 
should appear in the window. This field is dimmed unless the Time After check 
box is checked.

Message Contains Indicates whether only alarms and events that contain the specified message text 
should appear in the window. The default is checked.

Match Case Indicates whether only alarms and events that match the case of the text in the 
Message Contains field should appear in the window. This field is dimmed 
unless the Message Contains check box is checked. If the Message Contains 
check box is checked, the default setting for this check box is checked.

Suppress Events for 
unmanaged nodes

Suppresses all alarms and events from nodes that are unmanaged. The default 
setting for this check box is unchecked.
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The Charts pane contains:

Changing Status Settings

You use the MWTM to customize the sort order for status settings, as well as the color of each status 
setting.

When you change the sort order or the color of a status setting, most MWTM client windows reflect the 
new sort order or color immediately. All other windows reflect the new sort order or color at the next 
poll.

Field or Button Description

Series Indicates the time series being defined. A time series is a set of data collected 
sequentially at a fixed interval of time.

The default values for series are:

• Series 0: Dot, Solid, Red

• Series 1: Box, Solid, Green

• Series 2: Triangle, Solid, Blue

• Series 3: Diamond, Solid, Black

• Series 4: Star, Solid, Pink

• Series 5: Cross, Solid, Orange

• Series 6: Circle, Solid, Gray

• Series 7: Square, Solid, Light Green

• Series 8: Vertical Line, Solid, Red

• Series 9: Horizontal Line, Solid, Green

• Series 10: Dot, Solid, Blue

• Series 11: Box, Solid, Black

• Series 12: Triangle, Solid, Pink

• Series 13: Diamond, Solid, Orange

• Series 14: Star, Solid, Gray

• Series 15: Cross, Solid, Light Green

• Series 16: Circle, Solid, Red

Symbol Style Drop-down list box used to define the symbol associated with a series. To change the 
symbol for a series, select a new value: Dot, Box, Triangle, Diamond, Star, Vertical 
Bar, Horizontal Line, Cross, or Circle.

Line Style Drop-down list box that you use to define the style of line that connects data points in 
the chart. To change the line style for a series, select a new value: Solid, Long Dash, 
Long-Short-Long (LSL) Dash, Short Dash, Dash Dot, or None.

Color Indicates the current color for the series.

Change Color Opens the Select Series Color dialog box in which you select a color for a series. For 
more details, see Customizing Colors, page 5-18.
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When you change the color of a status, most MWTM client windows reflect the new color immediately. 
All other windows reflect the new color at the next poll.

To display the Status settings, click Status in the left pane of the Preferences window.

The Status pane contains:

Changing CiscoWorks Server Settings

You can configure the CiscoWorks server name and port numbers for all connected MWTM clients: 

• During MWTM installation. See the Installation Guide for the Cisco Mobile Wireless Transport 
Manager 6.1.

• After installation by running the mwtm cwsetup command. See mwtm cwsetup, page B-21.

Field or Button Description

Status Sort Order Indicates the status setting being defined. The default status sort order and colors 
are:

• None: Black

• Unknown: Red

• Unavailable: Red

• Inactive: Red

• Failed: Red

• Down: Red

• Blocked: Red

• Pending: Red

• Warning: Yellow

• Shutdown: Blue

• Inhibited: Blue

• InhibitLoc: Blue

• InhibitRem: Blue

Status Sort Order

(continued)

• Discovering: Cyan

• Polling: Cyan

• Waiting: Gray

• Unmanaged: Gray

• Active: Green

Move Up Moves the chosen status setting up in the Status Sort Order list.

Change Color Opens the Select Status Color dialog box in which you select a color for a status. 
For more details, see Customizing Colors, page 5-18.

Move Down Moves the chosen status setting down in the Status Sort Order list.

Reset Order Restores the status settings to the default sort order.

Reset Colors Restores the status settings to the default colors.
5-13
User Guide for the Cisco Mobile Wireless Transport Manager 6.1

OL-9118-01



 

Chapter 5      Basic Operations
  Changing Client and Web Preference Settings
All clients connected to the MWTM server retain the CiscoWorks settings that were made during 
installation or the last time you ran the mwtm cwsetup command. However, you can overwrite the 
CiscoWorks settings for a particular client by using the preferences window. 

To change the CiscoWorks server settings for a particular client:

Step 1 From the main window, choose Edit > Preferences > CiscoWorks. 

Step 2 Click CiscoWorks in the left pane of the Preferences window.

The CiscoWorks server settings contain:

Step 3 From the Preferences window menu bar, choose File > Save.

Note To do this procedure from the MWTM web interface, see Changing Web Preference Settings, page 5-20.

Changing Topology Settings

Use the Topology pane in the Preferences window to change default settings for the topology window. 

To display the topology settings, select Topology in the left pane of the Preferences window.

The Topology pane contains:

Check Box or Field Description

IP Address or DNS Host Name1

1. Changing this setting affects only the MWTM client you are using. All other MWTM clients retain the CiscoWorks settings 
that were made during installation or the last time you ran the mwtm cwsetup command.

The IP address or the DNS host name of the CiscoWorks server.

Port1 The access port on the CiscoWorks server. The default setting is 1741.

Secure Port1 The port number on the CiscoWorks server that is used for secure 
access, for example, SSL access. The default setting is 443.

Secure Connection Indicates if the connection to the CiscoWorks server is secure.

Check Box or Field Description

Spring Layout Spacing 
Factor (1-10)

Indicates how far to space nodes when the MWTM draws the Spring 
Layout topology map. Valid values are 1 through 10, with 1 being closer 
together and 10 being farther apart. The default spacing factor is 5.

Even if you apply preferences and close the Preferences window, the 
topology map does not show the new spacing factor until you choose 
Topology Tools > Layout > Spring, or click the Spring Layout button.

Show Mouse Overs Specifies whether tooltips are enabled in topology maps. Checked is the 
default.
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Draw Connections When 
Dragging a Node

Specifies whether the MWTM draws connection lines in the topology 
map as you move nodes:

• Check if you want the MWTM to draw the associated connection 
lines dynamically as you move a node.

• Uncheck if you do not want the MWTM to draw the associated 
connection lines until after you have finished moving a node. 
Unchecked is the default.

Show Small SS7 Icons (ITP 
only)

Specifies the size of the SS7 icons in the topology map:

• Uncheck if you want the MWTM to display large SS7 icons. 
Unchecked is the default.

• Check if you want the MWTM to display small SS7 icons. This 
setting can save space in the topology map, making it easier to read.

Show Non-ITP Nodes (ITP 
only)

Specifies whether the MWTM should display non-ITP nodes and 
linksets in the topology map:

• Check if you want the MWTM to display non-ITP nodes and 
linksets in the topology map. Checked is the default.

• Uncheck if you want the MWTM to hide non-ITP nodes and linksets 
in the topology map. (The navigation tree still shows the hidden 
signaling points and linksets.)

Show Point Code and Node 
Name (ITP only)

Specifies whether the MWTM should display point codes as well as 
node names in the topology map:

• Uncheck if you want the MWTM to display point codes but not node 
names. Unchecked is the default.

• Check if you want the MWTM to display both point codes and node 
names.

X Performance Enhancer 
(AntiAliasing Off)

Specifies whether antialiasing is turned on in the topology map. 
Antialiasing, which is on by default, improves the appearance of the 
icons and connections in the map.

However, antialiasing can impact the performance of the MWTM client 
on a remote workstation (that is, a Solaris or Linux workstation by using 
xhost, or a Windows workstation using an X-Window system emulator 
such as eXceed or Reflection X).

• Uncheck if you want to turn on antialiasing in the topology map. 
Unchecked is the default.

• Check if you want to turn off antialiasing.

Remember that performance is always better if you access the MWTM 
by installing the MWTM client on the remote workstation.

Check Box or Field Description
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Changing Deploy Settings

Note Deploy settings are only for ITP networks. If you configure the MWTM to manage ITP networks, the 
deploy settings will appear in the Preferences window. You customize the MWTM to manage ITP 
networks during installation. You can also do this later by command (see mwtm manage, page B-40).

Use the Deploy settings to change the way the Deployment Wizard works.

To display the Deploy settings, select Deploy in the left pane of the Preferences window.

The Deploy settings contain:

Check Box or Field Description

Turn On Term 
Monitor During 
File Activation

Indicates whether the MWTM should turn on the terminal monitor before 
activating a route table file or GTT file on the ITP, and turn it off after activation 
(whether or not the activation was successful).

If you turn on the terminal monitor during activation, detailed activation error 
messages appear in the connection log. These messages can be useful if activation 
fails. However, all node console logging messages also appear in the connection 
log; so, many nonactivation messages might also appear.

The default is checked.

Turn Off All Debug 
Output Before 
Turning On Term 
Monitor

Indicates whether debug messages should appear in the connection log. The 
default is checked.

If you check the Turn On Term Monitor During File Activation check box, all 
node console logging messages appear, including all debug messages that are 
currently enabled on the node.

Turn Off All Debug 
Output Before 
Turning On Term 
Monitor

(continued)

You can then check the Turn Off All Debug Output Before Turning On Term 
Monitor check box to turn off all debug messages. This setting can reduce the 
number of nonactivation messages in the connection log. The default is checked.

Note The MWTM does not turn the debug messages back on after activation. 
Ensure that other users are not debugging on the node before checking 
this check box.

This check box is dimmed unless you check the Turn On Term Monitor During 
File Activation check box.

Synchronize Active 
and Standby 
Storage If Node Is 
Configured as 
Redundancy Mode

Cisco 7507, 7513, and 7600 series routers support redundancy, which requires 
synchronization of the active and all standby storage devices.

If you want the MWTM to use a node’s configured redundancy mode to determine 
whether the MWTM should replicate storage operations (such as creating files, 
uploading, deleting, and so on) among the active and all standby storage devices, 
click this radio button.

Note This radio button is mutually exclusive with the Synchronize Active and 
Standby Storage If Node Is Operating in Redundancy Mode and Do Not 
Synchronize Active and Standby Storage radio buttons.
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Synchronize Active 
and Standby 
Storage If Node Is 
Operating in 
Redundancy Mode

If you want the MWTM to use a node’s operating redundancy mode to determine 
whether the MWTM should replicate storage operations (such as creating files, 
uploading, deleting, and so on) among the active and all standby storage devices, 
in the right pane click this radio button. The default is clicked.

Note This radio button is mutually exclusive with the Synchronize Active and 
Standby Storage If Node Is Configured as Redundancy Mode and Do Not 
Synchronize Active and Standby Storage radio buttons.

Do Not 
Synchronize Active 
and Standby 
Storage

If you want the MWTM to perform storage operations only on the active storage 
device (that is, no automatic synchronization of active and standby storage 
devices), click this radio button.

Clicking this radio button requires you to manually synchronize the active and 
standby storage devices.

This radio button is mutually exclusive with these radio buttons:

• Synchronize Active and Standby Storage If ITP Is Configured as 
Redundancy Mode 

• Synchronize Active and Standby Storage If ITP Is Operating in Redundancy 
Mode

Enable Auto 
Refresh Node 
Storage In Node 
File Management 
Dialog

Indicates whether the Node File Management dialog box should refresh storage 
device content automatically at user-defined intervals. Clicking this check box 
enables the Node File Management dialog box to detect any updates made to the 
file system.

In addition, you can configure the node to disconnect idle connection sessions. If 
you check this check box, the MWTM automatically generates node operations 
at the user-defined interval, which prevents disconnection of the session by the 
node.

The default is unchecked.

To enable the automatic refresh, check this check box, then specify a Refresh 
Interval. The valid range is 1 seconds to an unlimited number of seconds. The 
default interval is 60 seconds.

Always Overwrite 
Existing File In 
Deployment 
Wizard

Indicates whether the Deployment Wizard should overwrite an existing file with 
the same filename automatically, without prompting the user. The default is 
unchecked.

Always Skip 
Archive Comments

Indicates whether the Deployment Wizard should skip archive comments. The 
default is unchecked.

This check box appears only if deploy comments are set to optional. For details, 
see mwtm deploycomments, page B-95. If deploy comments are set to required, 
this check box does not appear.

Check Box or Field Description
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Customizing Colors

You use the MWTM to customize the colors for these settings:

The Select Color dialog box contains:

• Swatches Tab (Recommended), page 5-18

• HSB Tab, page 5-19

• RGB Tab, page 5-19

• Select Color Field and Buttons, page 5-19

Related Topics:

• Changing Alarm and Event Settings, page 5-8

• Changing Charts Settings, page 5-11

• Changing Status Settings, page 5-12

Swatches Tab (Recommended)

You use the Swatches tab of the Select Color dialog box to select a color from a set of color swatches. 
This is the recommended method for selecting a color.

To display the Swatches tab, click the Swatches tab in the Select Color dialog box.

To select a color, select a swatch. The chosen color appears in the Preview field. When you are satisfied 
with the color, click OK.

Always Activate 
Deployed File In 
Deployment 
Wizard

Indicates whether the Deployment Wizard should activate the deployed file 
automatically, without prompting the user. The default is unchecked.

Command Timeout 
in Seconds

Indicates how long, in seconds, an MWTM client with a session to a node should 
wait for a response from the node before closing the session.

The valid range is 1 second to an unlimited number of seconds. The default is 
90 seconds.

Check Box or Field Description

Setting Menu Selection Color Dialog 

Alarm or event 
severity

Click Alarms / Events in the left pane of the Preferences 
window (Figure 5-1), then click Change Color in the Alarm 
/ Event Colors section.

Select Event Color

Series in 
real-time charts

Click Charts in the left pane of the Preferences window 
(Figure 5-1), then click Change Color in the Series Colors 
section.

Select Series Color

Status Click Status in the left pane of the Preferences window 
(Figure 5-1), select a status setting, then click Change Color. 

Select Status Color 
5-18
User Guide for the Cisco Mobile Wireless Transport Manager 6.1

OL-9118-01



 

Chapter 5      Basic Operations
  Changing Client and Web Preference Settings
HSB Tab

You must also choose hue, saturation, and brightness (HSB) variables to select a color.

To display the HSB tab, click the HSB tab in the Select Color dialog box.

To select a color, you can either:

• Select a color range on the vertical color bar, then select a specific color by moving the cursor around 
on the color square.

• Enter specific values in the (hue), S (saturation), and B (brightness) fields.

The chosen color appears in the Preview field. When you are satisfied with the color, click OK.

RGB Tab

You then select the red, green, and blue (RGB) content of the color. 

To display the RGB tab, click the RGB tab in the Select Color dialog box.

To select a color, select values for the Red, Green, and Blue fields. The chosen color appears in the 
Preview field. When you are satisfied with the color, click OK.

Select Color Field and Buttons

The Select Color dialog box contains:

Restoring Default Preference Settings

If you decide you do not like your modified preference settings, you can use the MWTM to restore all 
preference settings to the original system default settings. To do so:

Step 1 Display the Preferences window, as described in Changing Client Preference Settings, page 5-2.

Step 2 Choose the File > Load System Default Prefs menu option. 

The MWTM restores the default settings.

Field or Button Description

Preview Displays a preview of the current chosen color.

Whichever method you choose to select a color, the chosen color appears in the 
Preview field. When you are satisfied with the color, click OK.

OK Sets the color as shown in the Preview field, and closes the Color dialog box.

Cancel Closes the Color dialog box without selecting a color.

Reset Resets the color to its initial setting.
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Changing Web Preference Settings
Access the web preference settings by clicking the Preferences link in the title bar of any web interface 
window. Web preferences include a subset of the preferences that are available in the client interface.

To change web preferences settings:

Step 1 Click Preferences in the title bar of any MWTM web page.

Step 2 In the Preferences window, to display the:

a. General GUI settings, click the General GUI tab. 

b. CiscoWorks server settings, click the CiscoWorks tab.

Step 3 Change the settings you want to modify (refer to the table following this procedure for descriptions of 
the settings). If you enter a new value in a text field, press Enter or Tab to activate the change.

Note For any user, common preferences between the web and client interfaces are shared. However, if the web 
and client interfaces are active at the same time, and you exit the client interface, any changes you made 
to the web preferences are overwritten by the client preferences.

You can now exit the web preferences window.

The Web Preferences window contains:

Check Box, Radio Button, or Field Description

General GUI tab

Show DNS or User-Defined 
Names

Indicates whether the MWTM should identify nodes by their DNS 
or user-defined names. The default setting for this radio button is 
clicked.

Show IP Address in Name Field Indicates whether the MWTM should identify nodes by their IP 
addresses. The default setting for this radio button is unclicked.

Show Node Domain Names If checked, the MWTM shows node domain names in its displays. 
The default setting for this check box is unchecked (do not show 
node domain names).

Clear Display upon Execution Clears the output display each time you execute a command.

Slow Poller Interval (secs) Default interval, in seconds, for the slow poller. The valid range is 
60 seconds to 300 seconds. The default setting is 60 seconds.

Note You can change the valid range and default setting in the 
Server.properties file. For more information, see Changing 
MWTM Server Poller Settings, page 3-2.

Status Refresh Interval (secs) Specifies the default setting for how frequently the MWTM 
refreshes the web pages on the web interface.

The valid range is 180 seconds to 900 seconds. The default setting 
is 180 seconds. (You can change the valid range and default setting 
in the Server.properties file. For more information, see Changing 
MWTM Server Poller Settings, page 3-2.)
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Changing Real-Time Poller and Counter Settings
The MWTM provides three pollers for use in the MWTM client GUI and web pages: a fast, a slow, and 
a status refresh. You use the MWTM to change settings for those pollers, and also to specify how you 
want to aggregate the visible counter values.

To change the MWTM poller refresh and counter display settings, use one of these methods:

• The Server.properties file specifies minimum, maximum, and default settings for the fast, slow, and 
status refresh pollers. To change those settings, see Changing MWTM Server Poller Settings, 
page 3-2.

• To change the MWTM poller refresh and counter display settings for the GUI in the MWTM 
Preferences window, see Poller Settings, page 5-6.

• To change the MWTM poller refresh and counter display settings for the MWTM web pages by 
using the MWTM Web Preferences web page, see Link Reports, page 12-17.

• To change the MWTM counter display settings for the GUI from any Real-Time Data and Charts 
window in the GUI, click Reset Counters in any of these MWTM windows:

– Poll Settings dialog box in any network object’s MWTM Details window

– Node Details: MTP3 Errors table

– Signaling Point Details: GTT MAP Status table

– Signaling Point Details: GTT Statistics table

– Signaling Point Details: MLR Details table

The MWTM displays the MWTM Reset Counters dialog box.

The MWTM Reset Counters dialog box contains:

CiscoWorks tab1

IP Address or DNS Host Name The IP address or the DNS host name of the CiscoWorks server.

Port The access port on the CiscoWorks server. The default setting is 
1741.

Secure Port The port number on the CiscoWorks server that is used for secure 
access, for example, SSL access. The default setting is 443.

Secure Connection Indicates if the connection to the CiscoWorks server is secure.

1. Changing these settings affects only the MWTM client you are using. All other MWTM clients retain the CiscoWorks settings 
that were made during installation or the last time you ran the mwtm cwsetup command.

Check Box, Radio Button, or Field Description

Field or Button Description

Show Counters 
Since Reboot

Click to configure the MWTM client to clear all counters in MWTM web pages 
whenever the node reboots. The default is clicked.

Show Counters 
Since Last Poll

Click to configure the MWTM client to clear all counters whenever an MWTM 
web page is polled. The default is unclicked.

Show Counters 
Since User Reset

Click to configure the MWTM client to clear all MWTM counters whenever the 
user resets the counters on an MWTM web page. The default setting for this radio 
button is cleared.
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Viewing Online Help
The MWTM client provides links to web-based online help. To display:

The MWTM online help is searchable and supports bookmarking of favorite topics:

Apply Applies any changes you made to the counter settings, reflects the changes 
throughout the MWTM GUI, and closes the MWTM Reset Counters dialog box.

Cancel Closes the MWTM Reset Counters dialog box.

Help Displays online help for the current window.

Field or Button Description

Content In the MWTM client, choose:

Table of contents Help > Topics

Context-sensitive online help for the current 
window

Help > Window

MWTM information (build date, version, SSL 
support, copyright content)

Help > About

Feature In the MWTM web interface, choose:

Search

Favorites
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Finding Information in a Window
Sometimes, finding information, such as a node name or event text, in a long list can be difficult. You 
can use the MWTM client to search for a specific character string in windows that contain lots of 
information.

Note To find a specific object in the topology window, see Finding an Object, page 10-16.

To find a character string, choose Edit > Find from the MWTM main menu. This menu option is 
available when you select from the navigation tree:

• Active Alarms

• Event History

• Any object under Summary Lists

The MWTM displays the Find dialog box.

Note The Find dialog box also appears when you choose File > Find from the Route Table Editor dialog box 
(Chapter 13, “Editing an ITP Route Table File”).

The Find dialog box contains:

Field or Button Description

What Character string for which the MWTM should search in the window. This can be 
any character string: all or part of a node name, event text, status, and so on.

Match Case Check box used to indicate whether the MWTM should search for only character 
strings that match the case of the text in the What field. To search with:

• Case-matching on, select this check box.

• Case-matching off, clear this check box. This is the default setting.

Search Forward Indicates whether the MWTM should search forward (down and to the right) in 
the window. This radio button is mutually exclusive with the Search Backward 
button. The default is checked.

Search Backward Indicates whether the MWTM should search backward (up and to the left) in the 
window. This radio button is mutually exclusive with the Search Forward button. 
The default is unchecked.
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Navigating Table Columns
You can resize, sort, or hide the columns in some tables in the MWTM to meet your specific needs. The 
MWTM client automatically saves your new settings and, thereafter, launches the client with the new 
settings. 

Note Hiding table columns is possible in the MWTM client and web interfaces. Resizing table columns is 
possible only in the client interface. In the web interface, you can search for specific information and 
page through long tables by using its search and paging features (see MWTM Web Interface Content 
Area, page 11-4).

• To view a tooltip for each column in the table, place the cursor over a column heading. If a cell is 
too small to show all of its text, place the cursor over the cell to see the full text of the tooltip.

• To make a column wider or narrower in the MWTM client interface, click the column divider in the 
heading and move the divider to the right or left while holding down the left or right mouse button.

All Components or Recent Events tables in the MWTM main window reflect changes that you make 
to any object's Components or Recent events table. The Show in New window or Real-Time Data 
and Charts windows do not reflect the changes, however.

Depending on your system, as well as other factors, MWTM windows can sometimes appear so 
small that text is illegible, and columns and text entry fields too narrow to be usable. If this happens, 
resize the window and widen the individual columns until the information is again legible and the 
columns and text entry fields are usable.

• By default, the MWTM displays most of the columns in tables, but some columns may be hidden. 
To:

– Display hidden columns, right-click in the table heading and select the check boxes for the 
columns you want to display. If you are using the web interface, click the Apply button.

– Hide columns, right-click in the table heading and clear the check boxes for the columns you 
want to hide. If you are using the web interface, click the Apply button.

All Components or Recent Events tables in the MWTM main window reflect changes that you make 
to any object's Components or Recent events table. The Show in New window or Real-Time Data 
and Charts windows do not reflect the changes, however.

Find Launches the search. If:

• It finds a matching character string in the window, the MWTM highlights the 
first line that contains the string.

To find the next occurrence of the string, click Find again.

You can continue to click Find until you find no more matches in the window. 
At that time, the MWTM displays an appropriate message in the dialog box, 
such as:

Bottom of table reached.

• No matching character string is found, the MWTM displays an appropriate 
message in the dialog box.

Close Closes the Find dialog box when you finish searching.

Field or Button Description
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• To sort a table based on the data in a column, left-click in the column heading. The MWTM 
alpha-numerically sorts the table from top to bottom, based on the data in the chosen column. To 
sort the table in reverse order, left-click in the column heading a second time. If two entries in the 
chosen column are identical, the MWTM sorts those rows based on the data in the remaining table 
columns, moving left to right.

• The tables in the web interface display an icon in the column heading to indicate the column on 
which the table is sorted, and the direction of the sort. The icon displays a triangle( ) if the sort 
order is ascending (1-9, A-Z), and an inverted triangle ( ) if the sort order is descending (Z-A, 
9-1).

• If you sort a table in the web interface based on the Nodes column, the MWTM sorts the table based 
on the DNS names of the nodes, as the MWTM discovers nodes. However, if you modified your 
preferences to identify nodes by their user-defined names, then the MWTM sorts the table based on 
the user-defined names of the nodes. For more information, see Node Name Settings, page 5-5.

• To customize the sort order for status settings in the Status column of tables, use the Status settings 
section of the Preferences window. For more information, see Changing Status Settings, page 5-12.

• (ITP only) To sort a route table, click Sort Table. The MWTM sorts the entries in the route table 
field-by-field, beginning with Dest. Point Code, then Mask, Cost, Dest.Linkset, and finally QoS.

Printing Windows
You can print most MWTM windows, as well as the topology map, for those times when you need 
hardcopy.

To print an MWTM window, choose File > Print from most MWTM windows (for example, the MWTM 
main window or topology window).

The MWTM displays the Print dialog box.

You use the Print dialog box to specify print settings, such as which printer to print to, whether to send 
output to a file (the default location for the print file is your home directory), and whether to print duplex.

Note You can send output to a file only in the file formats that your printer drivers support. Sending output to 
files can result in large file sizes that you will need to monitor and manage.

When you are satisfied with your print settings, click Print. The MWTM prints the window or map.

To exit the Print dialog box at any time without printing, click Cancel.

Managing and Deploying ITP Files
You use the MWTM to manage GTT files, route table files, and MLR address table files. The MWTM 
provides a Node File Management dialog box and a Node Archive Management dialog box:

• Node File Management, page 5-26

• Node Archive Management, page 5-33

• Deploying ITP Files, page 5-36
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Node File Management
You use the Node File Management dialog box to:

• View:

– GTT files

– Route table files

– MLR address table files

• Check these files for semantics and syntax

• Delete, rename, and upload the files to a remote node

• Activate the files 

The Node File Management dialog box can handle GTT and route table files up to 512 KB in size (the 
maximum size supported by the MWTM and ITP) and up to 100,000 MLR address table entries.

To launch the Node File Management dialog box, choose Network > Node File Management from the 
MWTM main menu. The MWTM displays the Node File Management dialog box.

Note If you have implemented MWTM User-Based Access, this option is available to users with 
authentication level Network Administrator (level 4) and higher.

The Node File Management dialog box contains:

• Node File Management Menu, page 5-27

• Node File Management MWTM Pane, page 5-30

• Node File Management Node Pane, page 5-31
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Node File Management Menu

The menu on the Node File Management dialog box contains:

Command Description

File > Connect
(Ctrl-N)

Opens the Pick Node dialog box in which you select a node and connect 
to that remote node.

Note The remote node might be configured to disconnect idle 
sessions. To prevent disconnection of sessions by the node, 
enable the MWTM to refresh storage device content 
automatically by selecting the Enable Auto Refresh Node 
Storage In Node File Management Dialog check box in the 
Deploy settings section of the Preferences window, then specify 
a Refresh Interval. For more information, see Changing Deploy 
Settings, page 5-16.

To avoid entering username and password information each 
time, you can set up credentials (see Configuring Login 
Credentials, page 3-20).

File > Disconnect
(Ctrl-D)

Disconnects from the node.

This option is dimmed if you are not connected to a remote node.

File > Close
(Ctrl-W)

Closes the Node File Management dialog box.

Local > Open File Opens the chosen route table file in the Route Table dialog box 
(Figure 13-2) or the GTT file in the GTT Editor window (Figure 14-1) 
or the MLR address table file in the Address Table Editor (Figure 15-1).

Local > Check File Checks the semantics and syntax of the chosen file on the MWTM 
client.

Local > Cut Cuts the chosen local file from the MWTM client.

Local > Copy Copies the chosen local file from the MWTM client.

Local > Paste Pastes a cut or copied local file into the MWTM client.

Local > Delete Deletes the chosen file from the MWTM client.

Note If you try to delete a file, and you do not have permission to 
delete the file, the MWTM issues an appropriate error message.

Local > Rename Renames the chosen file on the MWTM client.

You can use any letters, numbers, or characters in the new name that 
your operating system allows. However, if you include any spaces in the 
new name, the MWTM converts those spaces to dashes. For example, 
the MWTM saves file a b c as a-b-c.

Local > Refresh Refreshes the list of files in the MWTM pane.

If you have added or modified route table files, GTT files, or MLR files 
on the MWTM client since you launched the Node File Management 
dialog box, the MWTM pane reflects those changes.
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Local > Go Up Displays the subdirectories and files that are in the directory that is up 
one level from the currently visible directory on the MWTM client.

This option is dimmed if this is the highest directory level.

Local > Create Directory Creates a new subdirectory in the directory that the MWTM client 
currently is displaying.

Remote > Activate Activates the chosen route table file, GTT file, or MLR file on the 
remote node. That is, the MWTM replaces the currently running route 
table file, GTT file, or MLR file on the remote node with the chosen 
file.

Note You cannot activate the MWTM-LAST-ACTIVE-filename.rou, 
MWTM-LAST-ACTIVE_filename.gtt, 
MWTM-LAST-ACTIVE-filename.mlr,
or MWTM-LAST-ACTIVE-filename.sms files. These are backup 
files. If you need to revert to one of these files, copy it, rename 
it, and upload and activate the renamed file on the remote node.

This option is dimmed if you are not connected to a remote node.

Remote > Cut Cuts the chosen remote file from the remote node.

Remote > Copy Copies the chosen remote file from the remote node.

Remote > Paste Pastes a cut or copied remote file into the remote node.

Remote > Delete Deletes the chosen file from the remote node.

If you try to delete a file, and you do not have permission to delete the 
file, the MWTM issues an appropriate error message.

Some Cisco routers support redundancy, which requires 
synchronization of the active and all standby storage devices. If you 
delete a file in the node pane from an active storage device, and you then 
try to undelete the file before the standby storage devices have been 
synchronized, the file will have different IDs on the active and standby 
storage devices. If this occurs, the MWTM issues this error message 
and cancels the undelete: 

Invalid ID

You must then undelete the file on the standby storage devices.

This synchronization problem does not occur in the MWTM pane.

This option is dimmed if you are not connected to a remote node.

Remote > Rename Renames the chosen file on the remote node.

Note You can rename files on the remote node for only Class C 
devices on the disk drives.

You can use any letters, numbers, or characters in the new name that 
your operating system allows. However, if you include any spaces in the 
new name, the MWTM converts those spaces to dashes. For example, 
the MWTM saves file a b c as a-b-c.

This option is dimmed if you are not connected to a remote node.

Command Description
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Remote > Undelete Recovers the chosen file on the remote node.

This option is dimmed if you are not connected to a remote node.

Remote > Refresh Refreshes the list of files in the node pane.

If route table files, GTT files, or MLR files have been added or modified 
on the remote node since you launched the Node File Management 
dialog box, those changes appear in the node pane.

This option is dimmed if you are not connected to a remote node.

Remote > Go Up Displays the subdirectories and files that are in the directory that is up 
one level from the directory that is currently visible on the remote node.

This option is dimmed if this is the highest directory level or if you are 
not connected to a remote node.

Remote > Create Directory Creates a new subdirectory in the directory that the remote node 
currently is displaying.

Note You can create folders on the remote node for only Class C 
devices on the disk drives.

This option is dimmed if you are not connected to a remote node.

Remote > Squeeze Node Optimizes Flash memory on the remote node so that the space used by 
the files marked as deleted or error can be reclaimed. For more 
information, see the description of the squeeze command in the Cisco 
IOS Release 12.2 Configuration Fundamentals Command Reference.

Note After performing the squeeze process you cannot recover 
deleted files using Undelete.

This option is dimmed if you are not connected to a remote node.

Remote > Format Node Formats the Flash memory file system on the remote node. For more 
information, see the description of the format command in the Cisco 
IOS Release 12.2 Configuration Fundamentals Command Reference.

This option is dimmed if you are not connected to a remote node.

Help > Topics
(F1)

Displays the table of contents for the MWTM online help.

Help > Window
(Shift-F1)

Displays online help for the current window.

Help > About
(F3)

Displays build date, version, SSL support, and copyright information 
about the MWTM application.

Command Description
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Node File Management MWTM Pane

The MWTM pane on the left side of the Node File Management dialog box displays all of the files that 
the MWTM currently defines on the MWTM client. To populate the MWTM pane with all of the:

• Route table files currently defined on the MWTM client, select Route Tables from the drop-down 
list box.

• GTT files currently defined on the MWTM client, select GTT Files from the drop-down list box.

• MLR address table files currently defined on the MWTM client, select MLR Address Tables from 
the drop-down list box. 

You can resize each column, or sort the table based on the information in one of the columns. By default, 
the MWTM sorts this table by Name, and displays all of the columns in the MWTM pane.

See Navigating Table Columns, page 5-24 for more information about resizing, sorting, displaying, or 
hiding columns.

The MWTM pane contains:

The MWTM pane provides these right-click menu options for files:

Column Description

Type Indicates whether the chosen name is a directory or a file.

Name Name of the route table, GTT, or MLR file.

Size Size of the file in bytes.

Modified Date and time the file was last modified.

Command Description

Open File Opens the chosen route table file in the Route Table dialog box (Figure 13-2) or 
the chosen GTT file in the GTT Editor window (Figure 14-1) or the chosen MLR 
address table file in the Address Table Editor window (Figure 15-1).

Check File Checks the semantics and syntax of the chosen file on the MWTM client.

Cut Cuts the chosen file from the MWTM client.

Copy Copies the chosen file from the MWTM client.

Paste Pastes a cut or copied file into the MWTM client.

Delete Deletes the chosen file from the MWTM client.

Note If you try to delete a file, and you do not have permission to delete the file, 
the MWTM issues an appropriate error message.

Rename Renames the chosen file on the MWTM client.

You can use any letters, numbers, or characters in the new name that your 
operating system allows. However, if you include any spaces in the new name, the 
MWTM converts those spaces to dashes. For example, the MWTM saves file 
a b c as a-b-c.
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Node File Management Node Pane

The node pane on the right side of the Node File Management dialog box displays all of the files that the 
MWTM currently defines on the remote node. To populate the node pane with all of the:

• Route table files currently defined on the remote node, select Route Tables from the drop-down list 
box.

• GTT files currently defined on the remote node, select GTT Files from the drop-down list box.

• MLR address table files currently defined on the remote node, select MLR Address Tables from 
the drop-down list box. 

You can resize each column, or sort the table based on the information in one of the columns. By default, 
the MWTM sorts this table by Name, and displays all of the columns in the node pane.

See Navigating Table Columns, page 5-24 for more information about resizing, sorting, displaying, or 
hiding columns.

The node pane contains:

Refresh Refreshes the list of files in the MWTM pane.

If you have added or modified route table, GTT, or MLR files on the MWTM client 
since you launched the Node File Management dialog box, the MWTM pane 
reflects those changes.

Go Up Displays the subdirectories and files that are in the directory that is up one level 
from the currently visible directory on the MWTM client.

This option is dimmed if this is the highest directory level.

Create Directory Creates a new subdirectory in the currently visible directory on the MWTM client.

Upload Uploads the chosen file from the MWTM client to the remote node.

You can also upload a file by selecting it in the MWTM pane and clicking the 
arrow pointing to the node pane.

This option, and the arrow, is dimmed if you are not connected to a remote node.

Command Description

Column Description

Type Indicates whether the chosen name is a directory or a file.

Name Name of the route table, GTT, or MLR file.

Size Size of the file in bytes.

Modified Date and time the file was last modified.
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The node pane provides these right-click menu options for files:

Right-click Option Description

Activate Activates the chosen route table file, GTT file, or MLR file on the remote node. 
That is, the MWTM replaces the currently running route table file, GTT file, or 
MLR file on the remote node with the chosen file.

Note You cannot activate the MWTM-LAST-ACTIVE-filename.rou, 
MWTM-LAST-ACTIVE_filename.gtt, MWTM-LAST-ACTIVE-filename.mlr, 
or MWTM-LAST-ACTIVE-filename.sms files. These are backup files. If 
you need to revert to one of these files, copy it, rename it, and upload and 
activate the renamed file on the remote node.

This option is dimmed if you are not connected to a remote node.

Cut Cuts the chosen file from the remote node.

Copy Copies the chosen file from the remote node.

Paste Pastes a cut or copied file into the remote node.

Delete Deletes the chosen file from the remote node.

If you try to delete a file, and you do not have permission to delete the file, the 
MWTM issues an appropriate error message.

Some Cisco routers support redundancy, which requires synchronization of the 
active and all standby storage devices. If you delete a file in the node pane from an 
active storage device, and you then try to undelete the file before the standby 
storage devices have been synchronized, the file will have different IDs on the 
active and standby storage devices. If this occurs, the MWTM issues the following 
error message and cancels the undelete:

Invalid ID

You must then undelete the file on the standby storage devices.

This synchronization problem does not occur in the MWTM pane.

Rename  Renames the chosen file on the remote node.

Note You can rename files on the remote node for only Class C devices on the 
disk drives.

You can use any letters, numbers, or characters in the new name that your 
operating system allows. However, if you include any spaces in the new name, the 
MWTM converts those spaces to dashes. For example, the MWTM saves file a b 
c as a-b-c.

Undelete Recovers the chosen file on the remote node.

Refresh Refreshes the list of files in the node pane.

If route table files, GTT files, or MLR files have been added or modified on the 
remote node since you launched the Node File Management dialog box, those 
changes appear in the node pane.

This option is dimmed if you are not connected to a remote ITP.
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Node Archive Management
You use the Archive Management dialog box to view the contents of the archive, open a version with its 
corresponding editor, and delete all versions of a file.

To launch the Archive Management dialog box, choose Edit > Node Archive Management from the 
MWTM main menu. The MWTM displays the Archive Management dialog box.

Note If you have implemented MWTM User-Based Access, this option is available to users with 
authentication level Network Administrator (level 4) and higher.

Go Up Displays the subdirectories and files that are in the directory that is up one level 
from the currently visible directory on the remote node.

This option is dimmed if this is the highest directory level.

Create Directory Creates a new subdirectory in the currently visible directory on the remote node.

Note You can create folders on the remote node for only Class C devices on the 
disk drives.

Squeeze Node Optimizes Flash memory on the remote node so that the space used by the files 
marked as deleted or error can be reclaimed. For more information, see the 
description of the squeeze command in the Cisco IOS Release 12.2 Configuration 
Fundamentals Command Reference.

Note After performing the squeeze process you cannot recover deleted files 
using Undelete.

Format Node Formats the Flash memory file system on the remote node. For more information, 
see the description of the format command in the Cisco IOS Release 12.2 
Configuration Fundamentals Command Reference.

Download Downloads the chosen file from the remote node to the MWTM client.

You can also download a file by selecting it in the node pane and clicking the arrow 
pointing to the MWTM pane.
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The Archive Management dialog box contains:

• Node Archive Management Menu, page 5-34

• Node Archive Management Selector Pane, page 5-34

• Node Archive Management Display Pane, page 5-35

Node Archive Management Menu

The menu on the Archive Management dialog box contains:

Node Archive Management Selector Pane

The selector pane on the left side of the Archive Management dialog box displays all of the files that the 
MWTM currently defines on the MWTM client. To populate the selector pane with all of the:

• Route table files currently defined on the MWTM client, select Route Tables from the drop-down 
list box.

• GTT files currently defined on the MWTM client, select GTT Files from the drop-down list box.

• MLR address table files currently defined on the MWTM client, select MLR Address Tables from 
the drop-down list box. 

To see the tooltip for each button in the selector pane, place the cursor over the button.

Command Description

File > Open File Opens the chosen route table file in the Route Table dialog box (Figure 13-2) or 
the chosen GTT file in the GTT Editor window (Figure 14-1) or the chosen MLR 
address table file in the Address Table Editor window (Figure 15-1).

File > Delete Deletes all versions of the chosen file from the MWTM client. 

Note If you try to delete a file, and you do not have permission to delete the file, 
the MWTM issues an appropriate error message.

File > Refresh Updates data for the currently visible entries.

File > Close
(Ctrl-W)

Closes the Archive Management dialog box.

Help > Topics
(F1)

Displays the table of contents for the MWTM online help.

Help > Window
(Shift-F1)

Displays online help for the current window.

Help > About
(F3)

Displays build date, version, SSL support, and copyright information about the 
MWTM application.
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The selector pane contains:

The selector pane provides these right-click menu options for files:

Node Archive Management Display Pane

The Archive Management pane displays all of the versions that currently exist on the chosen file in a 
table. To navigate to a chosen file, click the turner  beside Nodes or Signaling Points in the selector 
pane (in the left pane), and click on the file. All versions appear in the right pane.

If a cell is too small to show all of its comments, place the cursor over the cell to see the full text in a 
tooltip.

You can resize each column, or sort the table based on the information in one of the columns. By default, 
the MWTM sorts this table by Rev and displays all of the columns in the display pane. 

See Navigating Table Columns, page 5-24 for more information about resizing, sorting, displaying, or 
hiding columns.

The display pane contains:

Button or Object Description

Open File Opens the chosen route table file in the Route Table dialog box (Figure 13-2) or the 
chosen GTT file in the GTT Editor window (Figure 14-1) or the chosen MLR 
address table file in the Address Table Editor window (Figure 15-1).

Delete Deletes all versions of the chosen file from the MWTM client.

Note If you try to delete a file, and you do not have permission to delete the file, 
the MWTM issues an appropriate error message.

Refresh Updates data for the currently visible files.

Nodes To see the nodes, signaling points, and archived files associated with a specific 
node, click the turner  beside the node or signaling point. Clicking on an 
archived file displays the file in the right pane.

Signaling Points To see the signaling points and archived files associated with a specific signaling 
point, click the turner  beside the signaling point. Clicking on an archived file 
displays the file in the right pane.

Command Description

Open File Opens the chosen route table file in the Route Table dialog box (Figure 13-2) or the 
chosen GTT file in the GTT Editor window (Figure 14-1) or the chosen MLR 
address table file in the Address Table Editor window (Figure 15-1).

Delete Deletes all versions of the chosen file from the MWTM client.

Note If you try to delete a file, and you do not have permission to delete the file, 
the MWTM issues an appropriate error message.

Column or Button Description

Rev Revision number.

Date Date of archival.
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The display pane provides this right-click menu option for files:

Deploying ITP Files

Tip Before you can use the Deployment Wizard, you must set up TFTP (for details, see Setting Up TFTP on 
Your Server (ITP Only), page 3-12).

You use the Deployment Wizard to validate a route table file, GTT file, or MLR address table file, upload 
it to an ITP, archive the file, and activate it on the ITP. The Deployment Wizard can handle route table 
and GTT files up to 512 KB in size (the maximum size the MWTM and ITP support) and up to 100,000 
MLR address table entries.

To launch the Deployment Wizard, choose File > Deploy from the route table menu, GTT menu, or 
Address Table Editor menu. The MWTM displays the Deployment Wizard for the currently visible file.

Figure 5-2 Deployment Wizard for a GTT File

** Illustration to be supplied **

The left pane of the Deployment Wizard contains:

Comments Archival comments.

Author User or client hostname or IP address from which the deployment or archiving 
occurred.

Adjust row height You can adjust the row height to make comments readable.

Column or Button Description

Command Description

Open File Opens the chosen route table file in the Route Table dialog box (Figure 13-2) or the 
chosen GTT file in the GTT Editor window (Figure 14-1) or the chosen MLR 
address table file in the Address Table Editor window (Figure 15-1).

Step Description

Select File Indicates that the file is chosen for deployment. The name of the file to deploy 
appears in the Deployment Wizard title bar.

Select Node/SP If you are deploying a GTT file or address table file, you use this option to select the 
signaling point to deploy the file. You can optionally check the Filter by Node check 
box, which limits signaling point selection to a specific node.

Select a signaling point and node (optional) from the drop-down list boxes in the 
right pane, then click Next >.

If you are deploying a route table file, the MWTM proceeds directly to the Validate 
step.

Validate Validates the file for deployment. Validation messages and error messages, if any, 
appear in the right pane.
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Login You can log in to the signaling point. If required, enter the:

• Login username, if required.

• Login password, if required.

• Enable username, if required.

• Enable password, if required.

Note To avoid entering username and password information each time, you can set 
up credentials (see Configuring Login Credentials, page 3-20).

Upload Uploads the file to the signaling point.

If the file uploads with no errors, the MWTM proceeds to the Activate step.

If the specified file already exists on the ITP, the MWTM displays the name of the 
duplicate file and the Overwrite and Always Overwrite check boxes. Check the:

• Overwrite check box to overwrite the file on the ITP with the file being 
deployed. This is the default setting.

• Always Overwrite check box if you want the MWTM to always overwrite the 
file on the ITP with the file being deployed, without prompting you for 
confirmation. The default setting for this check box is unchecked (prompt for 
confirmation).

If you have set your preferences so that the MWTM client identifies nodes by their 
DNS names (the default setting) instead of by their IP addresses, then the ITP must 
be able to resolve the DNS names. Otherwise, the MWTM issues an appropriate error 
message and does not deploy the file.

To enable the ITP to resolve DNS names, enter the ip domain-lookup command on 
the ITP. For more information about this command, see the Cisco IOS IP Command 
Reference, Volume 1 of 4: Addressing and Services, Release 12.3 or later.

For more information about the Show DNS or User-Defined Names and Show IP 
Address in Name Field preference settings, see Node Name Settings, page 5-5.

Archive You use to enter archive comments, if required. If archive comments are not required, 
the MWTM displays the Always Skip Archive Comments check box. 

For details on setting archive comments to required or optional, see mwtm 
deployarchive, page B-94.

Activate Activates the file on the signaling point (replaces the currently running route table 
file, GTT file, or address table file with the deployed file).

The MWTM displays the Activate File and Always Activate File check boxes. You 
can:

• Check the Activate File check box to activate the deployed file on the ITP. This 
is the default setting.

• Uncheck the Activate File check box if you do not want to activate the deployed 
file on the ITP yet.

• Check the Always Activate File check box if you want the MWTM to always 
activate the deployed file on the ITP, without prompting you for confirmation. 
The default setting for this check box is cleared (prompt for confirmation).

Done Displays any status messages, such as errors or successful completion.

Step Description
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The bottom line of the Deployment Wizard contains:

Exporting Data
You use the MWTM to export its data for use by other products, such as CiscoWorks or Microsoft Excel. 
This section includes:

• Exporting Current Data for Network Objects, page 5-38

• Exporting Current Node Names and SNMP Community Names, page 5-39

Exporting Current Data for Network Objects
You can use the MWTM CLI to export all MWTM data, or to export only chosen MWTM data.

To export all current MWTM data, with fields separated by vertical bars (|; this is the default setting), 
enter the mwtm export all command with the -d bar keywords:

mwtm export all -d bar

To export all MWTM data with fields separated by commas (,), specify the -d comma keywords:

mwtm export all -d comma

To export all MWTM data with fields separated by tabs, specify the -d tab keywords:

mwtm export all -d tab

To export only object-specific MWTM data, specify one of these keywords:

• as—(ITP only) Export only application server data.

• asp—(ITP only) Export only application server process data.

• aspa—(ITP only) Export only application server process association data.

• links—(ITP only) Export only link data.

• linksets—(ITP only) Export only linkset data.

• nodes—Export only node data.

• sgmp—(ITP only) Export only signaling gateway-mated pair data.

• sps—(ITP only) Export only signaling point data.

Field or Button Description

Progress Bar Indicates that the MWTM is validating or uploading the file.

Show Log/Hide Log Displays or hides the log file for the Deployment Wizard.

Next > Advances to the next step in the Deployment Wizard.

Finish Closes the Deployment Wizard. The Finish button appears when deployment 
ends successfully, or when the MWTM encounters errors and cancels the 
process.

Cancel Closes the Deployment Wizard without deploying the file.

Help Displays online help for the Deployment Wizard.
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You can also specify the -d comma or -d tab keywords on any of these object-specific mwtm export 
commands.

Here is sample output for the mwtm export nodes command:

# ./mwtm export nodes
# v6.1.0.15
# t1168093931311|Sat Jan 06 09:32:11 EST 2007
#
# Total 2 nodes
# name|displayname|sgmid|old_description|cllicode|ipaddress|old_pointcode|old_se
condary|old_capability|state|statetimestamp|ioslevel|devicetype|usericonname|sys
descr|lastpolltimestamp|lastpolltime|avgpolltime|old_lasterrormsg|old_lasterrort
ime|notesexist|old_variant|sysuptime|rebootreason|statereason|discoveredtime|eve
ntRcvd|connectTo|ignore|customName|processTraps|nsoconfig|mtp3offload|rfpeerstat
e|trapPollingEnabled|reportPollingEnabled|sysName|nodeType

ems1941ka.cisco.com|ems1941ka.cisco.com|1253|not_used|not_used|[172.18.156.20][2
0.1.1.105]|not_used|not_used|not_used|Warning|1168092733287|7|CiscoMWR-1941-DC|n
ull|sysDescr|1168093830179|328|634|not_used|not_used|false|not_used|248128063|re
load|62|1168092732082|false|null|false|null|true|not_used|not_used|not_used|true
|true|ems1941ka|RAN-O

sgm-26-91c-2.cisco.com|null|1350|not_used|clli_2691c|[172.18.17.132,172.18.17.4]
[]|not_used|not_used|not_used|Unmanaged|1168093760605|31|Cisco2651XM|null|sysDes
cr|1168092856198|12984|18729|not_used|not_used|false|not_used|731561022|reload|1
|1168092734928|false|null|false|null|true|1|1|2|false|false|sgm-26-91c.cisco.com
|ITP

For more information about the use of the mwtm export command, see mwtm export, page B-30.

Exporting Current Node Names and SNMP Community Names
To export current MWTM node names and read and write SNMP community names, in CiscoWorks 
import format, with fields separated by commas (,), specify the cw keyword:

mwtm export cw

You can export this data to a file, then use the file to import the nodes into the CiscoWorks database.

For more information about the use of the mwtm export cw command, see mwtm export cw, page B-31.

Integrating the MWTM with Other Products
The MWTM does not require CiscoWorks or the Cisco Info Center (CIC), but the MWTM does integrate 
with those products to provide added value. See these sections for more information:

• Integrating the MWTM with CiscoWorks, page 5-39

• Forwarding Traps to Other Hosts (Server Only), page 5-42

Integrating the MWTM with CiscoWorks
The MWTM can integrate with CiscoWorks during installation, registering with CiscoWorks as an 
installed application. In this scenario, CiscoWorks and MWTM are running on the same server. See the 
“Installing the MWTM on Solaris” and “Installing the MWTM on Windows” chapters of the Installation 
Guide for the Cisco Mobile Wireless Transport Manager 6.1 for more information.
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You can also integrate the MWTM with CiscoWorks after installation by using:

• Preference settings. See Changing CiscoWorks Server Settings, page 5-13.

• The mwtm cwsetup command. See mwtm cwsetup, page B-21, for more information.

Once you have integrated the MWTM with CiscoWorks, you can:

• Launch CiscoWorks Applications from the MWTM Client, page 5-40

• Launch Integrated Applications from the MWTM Web Interface, page 5-41

• Launch the MWTM Web Interface from the CiscoWorks Dashboard, page 5-42

Launch CiscoWorks Applications from the MWTM Client

When you integrate the MWTM with CiscoWorks, you can launch, from the MWTM client Tools > 
Launch menu, the: 

• CiscoView

• CiscoWorks LMS Portal

• Content Services Gateway (CSG) Service Manager

• CiscoWorks Device Center

• GPRS Gateway Support Node (GGSN) Service Manager 

To launch CiscoWorks applications from the MWTM client:

Step 1 Ensure that CiscoWorks is installed in the network.

Step 2 To launch the appropriate CiscoWorks application:

CiscoWorks Application Description Steps to Launch from MWTM

CiscoView Provides a real-time, color-coded, 
graphical representation of Cisco 
devices. You can use CiscoView to 
quickly identify an incorrect status 
on a port or interface. If you are 
running CiscoWorks on UNIX or 
Windows, you can access 
CiscoView through the link to the 
web version of CiscoWorks.

Choose Tools > Launch > CiscoView 
from the MWTM main menu.

Or, right-click a node in the navigation 
tree and choose Launch > CiscoView.

CiscoWorks LMS Portal Provides a dashboard of 
CiscoWorks tools and utilities such 
as Resource Manager Essentials.

Choose Tools > Launch > 
CiscoWorks LMS Portal from the 
MWTM main menu.

CSG Service Manager Provides a wizard-based workflow 
to provision CSG1 and CSG2 
features in the network.

Choose Tools > Launch > CSG 
Service Manager from the MWTM 
main menu.1
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Step 3 At the prompt, enter a CiscoWorks user ID and password. 

Depending on your selection in Step 2, the MWTM links to the:

• Device Center dashboard, which displays information about the chosen node.

• CiscoView, which shows a graphical representation of the chosen node.

• CSG Service Manager

• GGSN Service Manager

Launch Integrated Applications from the MWTM Web Interface

To launch integrated applications from the MWTM web interface:

Step 1 From the MWTM web interface, click the Tools link in the navigation tree (left pane).

Note If CiscoWorks does not appear in the navigation tree of the MWTM web interface, CiscoWorks 
is not integrated with the MWTM. Use the mwtm cwsetup, page B-21, to integrate CiscoWorks 
with the MWTM.

Step 2 In the right pane, in the Launch pane, click:

• CiscoView (server_name)

• CiscoWorks LMS Portal (server_name)

• CSG Service Manager (server_name)

• Device Center (server_name)

• GGSN Service Manager (server_name) 

The chosen application launches. 

Device Center Provides useful web-based 
device-monitoring functions, 
including reachability trends, 
response time trends, interface 
status, Syslog browsing, and a 
detailed inventory.

Choose Tools > Launch > Device 
Center from the MWTM main menu.

Or, right-click a node in the navigation 
tree and choose Launch > Device 
Center.

GGSN Service Manager Provides a wizard-based workflow 
to provision GGSN devices.

Choose Tools > Launch > GGSN 
Service Manager from the MWTM 
main menu.1

1. The MWTM attempts to launch the URL of the service manager that resides on the LMS server. If the service manager is not 
installed on the LMS server, you will receive an HTTP 404 error. To prevent this error, ensure that the service managers are 
installed on the LMS server, or remove the CSG or GGSN network setting with the mwtm manage command.

CiscoWorks Application Description Steps to Launch from MWTM
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Note The MWTM attempts to launch the URL of the service manager that resides on the LMS server. If the 
service manager is not installed on the LMS server, you will receive an HTTP 404 error. To prevent this 
error, ensure that the service managers are installed on the LMS server, or remove the CSG or GGSN 
network setting with the mwtm manage command.

Launch the MWTM Web Interface from the CiscoWorks Dashboard

To launch the MWTM web interface from the CiscoWorks dashboard: 

Step 1 Log in to your CiscoWorks dashboard.

Step 2 In the Mobile Wireless Transport Manager box, click the MWTM Server Home Page link.

Note If the Mobile Wireless Transport Manager box does not appear, CiscoWorks is not integrated 
with the MWTM. Use the mwtm cwsetup, page B-21, to integrate CiscoWorks with the MWTM.

The MWTM web interface opens to the home page.

Forwarding Traps to Other Hosts (Server Only)
You use the MWTM to forward SNMP traps to other SNMP servers, or hosts. The MWTM can then 
function as a trap multiplexer, integrating with high-level event- and alarm-monitoring systems such as 
the Cisco Info Center and Micromuse's Netcool suite of products. These systems can provide a single 
high-level view of all alarm monitoring in your network, making it easier to detect and resolve problems.

To enable the MWTM to forward SNMP traps to other hosts, specify the list of hosts in the 
TrapForwarder.properties file. The default file resides in the MWTM /properties directory. If you 
installed the MWTM in:

• The default directory, /opt, then the default file resides in 
/opt/CSCOsgm/properties/TrapForwarder.properties.

• A different directory, then the default file resides in that directory.

In the TrapForwarder.properties file, begin all comment lines with a pound sign (#).

All other lines in the file are host definition lines using this format:

SERVERxx=dest-address[:portno]

where:

• xx is the user-defined server number.

• dest-address is the hostname, or the IP address in dotted-decimal format.

• portno is the optional port number. The default port number is 162.

For example, this host definition line:
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SERVER02=64.102.86.104:162

enables the MWTM to forward traps to Server 02, with IP address 64.102.86.104, on port 162.

Any changes you make to the TrapForwarder.properties file take effect when you restart the MWTM 
server. Thereafter, the MWTM forwards all traps from the listed hosts except traps:

• That the MWTM cannot parse.

• From hosts listed in the trapaccess.conf file. For more information, see Limiting Traps by IP 
Address, page 3-9.

The MWTM modifies Version 2c traps that do not have the agent IP address already specified in the 
varbind list by including the agent IP address in the varbind list.

You can also forward MWTM events to other hosts, in the form of SNMP traps. For more information, 
see Forwarding Events as Traps to Other Hosts, page 9-48.

Running Simultaneous Client Sessions
You can run multiple sessions of the MWTM client simultaneously because the MWTM uses a 
client-server architecture. The MWTM server provides central services and database functions and 
communicates with multiple MWTM clients. You can install the MWTM client software on the same 
system as the MWTM server, or on a different system on the same network as the MWTM server.

Note Running more than one MWTM client on the same workstation can degrade the workstation 
performance.

The MWTM recommends a maximum of 20 clients per MWTM server. If you connect more than 20 
clients to a single server, the server requires additional memory and a more powerful CPU.

Performing Basic Server Operations
This section contains this information:

• Connecting to a New Server, page 5-43

• Viewing Server Status Information, page 5-44

Connecting to a New Server
You use the MWTM to connect the client to a new MWTM server. For example, you can monitor two or 
more networks from the same MWTM client, simply by switching servers. Or, if you have two MWTM 
servers monitoring the same network, and one server fails, the MWTM client automatically switches to 
the secondary server.

If you want to determine the default hostname before you connect to the new server, it appears in the 
SERVER_NAME entry in the System.properties file. If you installed the MWTM in:

• The MWTM in the default directory, /opt, then the location of the System.properties file is 
/opt/CSCOsgm/properties/System.properties.

• A different directory, then the System.properties file resides in that directory.
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To connect the client to a new server, choose File > Connect to New Server from the MWTM main 
menu. The MWTM displays the Connect to New Server dialog box.

The Connect to New Server dialog box contains:

Viewing Server Status Information
You use the MWTM to view detailed information about the processes, pollers, tasks, and clients for the 
server to which you are connected.

To display server status information, choose View > MWTM Server > Status in the MWTM main 
menu. The MWTM displays the Server Status Information window.

Figure 5-3 Server Status Information Window

** Illustration to be supplied ** 

The Server Status Information window contains:

• Server Status Information: Fields and Buttons, page 5-44

• Server Status Information: Processes, page 5-45

• Server Status Information:Pollers, page 5-45

• Server Status Information:Tasks, page 5-46

• Server Status Information: Clients, page 5-46

Server Status Information: Fields and Buttons

The Server Status Information window contains:

Field or Button Description

Server Name or IP Address Name or IP address of the new server. Enter the name of the new server, 
or its IP address, in the Server Name or IP Address field.

Name Server Port UDP port number for the new server. Enter the MWTM Naming Server 
UDP port number for the new server in the Name Server Port field.

The default value is 44742.

OK Stops the MWTM client, then restarts the client connected to the 
specified server.

When you have entered the name of the new server, or its IP address, 
and its UDP port number, click OK. The MWTM stops the client, then 
restarts the client connected to the new server.

Cancel Closes the Connect to New Server dialog box without connecting to the 
new server.

Help Displays online help for the Connect to New Server dialog box.
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Server Status Information: Processes

The Server Status Information: Processes section lists the processes that make up the MWTM server, 
and contains:

Server Status Information:Pollers

The Server Status Information: Pollers table lists the detail and demand pollers that the MWTM server 
is currently processing, and contains:

Command Description

Poll Interval Poll interval used to collect data for the table.

Last Poll Time the last poll was run.

This field initially displays a message that the MWTM is polling the device. After 
the first polling cycle, the MWTM populates this field with the actual time of the 
last poll.

Update Forces an immediate poll, and refreshes the Server Status Information window with 
the latest data.

Close Closes the Server Status Information window.

Help Accesses the online help for this window.

Field Description

Name Name of the process, such as sgmNameServer.

Process ID Number to uniquely identify the process.

Is Running Indicates whether the process is running (true) or not (false).

Field Description

Poller ID Number to uniquely identify each MWTM detail poller that is currently active.

MWTM detail pollers collect detailed data (such as real-time data, statistics, route 
detail, and so on) that the regular MWTM poller did not collect.

Client Host Name of the MWTM client that started the detail poller.

Interval Poll interval for the detail poller, in hours, minutes, and seconds.

Iteration Number of times the detail poller should poll. If this field displays Forever, the detail 
poller will never stop polling, until the MWTM client requests that it stops.

Next Poll Time until the next poll, in hours, minutes, and seconds.

Time Limit Time remaining, in hours, minutes, and seconds, until the poller times out. When the 
poller times out, the MWTM automatically stops the poller to prevent unnecessary 
traffic on the network and sends an appropriate error message to the client.

By default, the MWTM allows pollers to run up to 8 hours. To change that setting, see 
the description of the mwtm pollertimeout command in mwtm pollertimeout, 
page B-49.

Description Description of the detail poller.
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Server Status Information:Tasks

The Server Status Information: Tasks table lists long-running services that the MWTM server performs, 
and contains:

Server Status Information: Clients

The Server Status Information: Clients table contains:

Field Description

Task ID Number to uniquely identify the task.

Interval Time between runs for the task, in hours, minutes, and seconds.

Iteration Number of times the task should run. If this field displays Forever, the task will 
never stop polling.

Next Execution Time until the next run for the task, in hours, minutes, and seconds.

State Current state of the task. Valid values are:

• None—Task is stopped.

• Waiting—Task is waiting to transition to Ready or Running state.

• Ready—Task is ready to execute but is not yet in Running state.

• Running—Task is started and is currently executing.

• Pending—Task was in Ready state when a user canceled it. The task is pending 
final removal from the scheduler.

• Error—Task encountered an error.

• Dying—Task was in Running state when it was canceled by a user. The task 
continues to run in Dying state until it ends. The server then removes the task 
from the scheduler.

Description Description of the task.

Field Description

Process Name Name of an MWTM client that is currently connected to the server.

User Name If you have implemented MWTM User-Based Access, this field displays the name of 
an MWTM client user who is currently logged in and connected to the server.

If you have not implemented MWTM User-Based Access, this field displays the 
name of the node that the user is using.

Message Mask Mask that indicates which messages can be sent to the client. 

Sleeping? Indicates whether the thread that is responsible for delivering messages is sleeping 
(yes) or not (no). The normal setting for this field is no.

Sleep Time Time in seconds the thread that is responsible for delivering messages has been 
sleeping. The normal setting for this field is 0.

Queue Size Number of messages waiting to be sent to the MWTM client. The normal setting for 
this field is 0, but it could be higher if the MWTM server or client is very busy, as 
during Discovery.
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Using the Command Line Interface
The MWTM provides a command line interface that you use to interact with the MWTM and with the 
Cisco IOS software operating system by entering commands and optional arguments. For more 
information, see Appendix B, “Command Reference.”
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