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Getting Started

This chapter provides information about starting and stopping the Cisco Mobile Wireless Transport 
Manager (MWTM), and an overview of how to use the MWTM to manage your network.

This chapter contains:

• Starting the MWTM Server, page 4-cix

Starting the MWTM Client, page 4-cxi

Discovering Your Network, page 4-cxii

Displaying the MWTM Main Window, page 4-cxxiii

Using the MWTM Toolbar, page 4-cxxxii

Using the MWTM Main Menu, page 4-cxxvii

Accessing the MWTM Through a Web Browser, page 4-cxxxiii 

Loading and Saving MWTM Files, page 4-cxxxiv

Using the Windows Start Menu, page 4-cxxxv

Using the Windows Start Menu, page 4-cxxxv

Locating Technology Specific Information, page 4-cxxxvii

Exiting the MWTM Client, page 4-cxxxix

For detailed information about the MWTM-supported platforms, and hardware and software 
requirements, see the Installation Guide for the Cisco Mobile Wireless Transport Manager 6.1.2

Note /opt
/opt

Starting the MWTM Server

• Each node uses a supported IOS image

• The MWTM server has IP connectivity to each node

SNMP is enabled on each node

(Optional, but recommended) Traps are enabled on each node
4-cix
the Cisco Mobile Wireless Transport Manager 6.1.2
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•

Tip hat Is ITP?, page 1-6, What Is IPRAN?, page 1-7, and What Is 
mSEF?, page 1-9.

Because the MWTM application comprises a server component and a client component, you must start 
both components to run the application.

To start the MWTM server on a Solaris or Linux system:

Step 1

Note
page 2-18. 

Step 2 Enter:

# cd /opt/CSCOsgm/bin

# ./mwtm start

Becoming the Root User (Server Only)

Caution
of the commands that you use. If you are a relatively inexperienced UNIX user, limit your activities as 
the root user to the tasks described in this manual.

If you are not logged in, log in as the root user:

> login: 
> Password: root-password 

su

# su
User Guide for the Cisco Mobile Wireless Transport Manager 6.1.2
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Starting the MWTM Client

•

•

•

•

Before Starting the MWTM Client

Setting the DISPLAY Variable for Solaris or Linux Clients

Could not launch client: Can't connect to X11 window server using <x> as the value of the 
DISPLAY variable.

The DISPLAY variable is set as part of your login environment on Solaris or Linux. However, if you use 
Telnet or SSH to access a workstation, you must set the DISPLAY variable to local display by using this 
command:

# setenv DISPLAY local_ws:0.0

local_ws

setenv

# export DISPLAY= :0.0

Starting the MWTM Client on Solaris or Linux

./mwtm client

cd /opt/CSCOsgmClient/bin
./mwtm client
User Guide for the Cisco Mobile Wireless Transport Manager 6.1.2
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server_name_or_ip_address

server_name_or_ip_address 

Access the Node

, page 3-cv).

To access the node, right-click a node in a window, then choose Node Connect 

Starting the MWTM Client on Windows
Start > Programs > Cisco MWTM Client > 

Launch MWTM Client

You can change the amount of memory used by the Windows MWTM client, GTT Editor, and Address 
Table Editor by adding the following entries to the C:\Program Files\Cisco Systems\MWTM 
Client\properties\System.properties file
JVM_CLIENT_HEAP=1200
JVM_ATBL_HEAP=1200
JVM_GTT_HEAP=1200
JVM_CLIENT_HEAP=1200
JVM_ATBL_HEAP=1200
JVM_GTT_HEAP=1200

This reserves 1,200 megabytes (MB) of memory for each application. The default is 768 MB.

Discovering Your Network

•

•

•

•

•

User Guide for the Cisco Mobile Wireless Transport Manager 6.1.2
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Discovery Overview
The MWTM uses a Discovery process to populate the MWTM database, discovering the objects in your 
network.

You can run Discovery if MWTM User-Based Access is disabled; or, if it is enabled, and you are a 
Network Administrator or System Administrator. (For more information about user authorization levels 
in the MWTM, see Configuring MWTM User Account Levels (Server Only), page 2-6.)

To discover your network:

Start the MWTM client, as described in Starting the MWTM Client, page 4-cxi.

If you want to change SNMP settings, do so  running Discovery. See Configuring SNMP Settings, 
page 3-xcix for more information.

Step 3 If you want to discover ONS nodes and did not choose the option to discover your network during 
installation, you must add the ONS nodes and set the credentials before running discovery (see Adding 
Nodes, page 3-cvi for more information.)

Step 4 Network > Network Discovery 

Step 5 Seed Settings

Step 6 Next

Entire Network

Delete Existing Data 

Max. Hops

Step 7 Discover Network

When the “Discovery In Progress” message disappears, discovery is running. The Discovered Nodes 
table in the Discovery tab lists all nodes that the MWTM discovered (all nodes, including new and 
excluded nodes, not just the nodes in the current view). See Discovered Nodes, page 4-cxxiii for more 
information.

Event processing in the MWTM might experience congestion when discovering very large 
networks. If the number of events exceeds the capacity of the event queue, the event congestion 
icon  appears in the lower left of the MWTM client and web windows. If the icon appears, 
the presentation of event information in the MWTM will lag behind the actual state of the 
network objects until the congestion clears. No user action is necessary.
User Guide for the Cisco Mobile Wireless Transport Manager 6.1.2
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Step 8

Step 9

Note

Related Topics

•

•

•

Launching the Discovery Dialog

•

•

Discovery Dialog Menu

Menu Command Description

File > Load Seeds
(Ctrl-L)

Opens the Load File Dialog: Seed File List, enabling you to load a seed file into the MWTM:

• Enter the name of the seed file, and click OK

Cancel
4-cxiv



Discovery Dialog Tabs

Loading Seed Nodes and Seed Files

•

•

•

•

•

•

Loading a Seed Node

Add Node Enter

Note

Menu Command Description

Tab Description
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Loading a Seed File

File > Load Seeds 

Saving a Seed File

Field or Button Description

OK Loads the chosen seed file, saves any changes you made to the list of files, and closes the 
dialog box.

To load a seed file, double-click it in the list, select it in the list and click , or enter 
the name of the file and click .

The MWTM saves any changes you made to the list of files, closes the Load File Dialog: 
Seed File List dialog box, loads the seed file, and returns to the Discovery dialog box. 
The MWTM lists all of the seed nodes in the seed file in the Seed Nodes pane, and 
displays details of the SNMP settings for the seed nodes in the Seed Details pane.

Delete Deletes the chosen file from the seed file list. The MWTM issues an informational 
message containing the name and location of the deleted file.

Cancel Closes the dialog box without loading a seed file or saving any changes to the seed file 
list.

Help Displays online help for the dialog box.
User Guide for the Cisco Mobile Wireless Transport Manager 6.1.2
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• To save the changes you made to the seed file without changing the name of the file, choose 
from the Discovery Dialog menu.

• To save the changes you have made to the seed file with a new name, choose from 
the Discovery Dialog menu. The MWTM displays the Save File Dialog: Seed File List dialog box.

The MWTM stores the seed file in the seed file directory on the MWTM server:

• If you installed the MWTM in the default directory, , then the MWTM seed file directory is 
/opt/CSCOsgm/seeds

want to overwrite that user’s changes. If you choose to do so, the other user’s changes are overwritten 
and lost. If you choose not to do so, your changes are lost, unless you save the seed file to a different 
filename.

The Save File Dialog: Seed File List contains:

Type Icon indicating whether the item in the table is a file or a folder.

Name Name of the seed file or folder.

Last Modified Date and time the seed file or folder was last modified.

Size (bytes) Size of the seed file or folder, in bytes.

Filename Name by which you want to save the seed file.

If you create a new seed filename, you can use any letters, numbers, or characters in the 
name that are allowed by your operating system. However, if you include any spaces in 
the new name, the MWTM converts those spaces to hyphens. For example, the MWTM 
saves file  as a-b-c
User Guide for the Cisco Mobile Wireless Transport Manager 6.1.2
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Creating a New Seed File

•

•

•

•

•

•

Field or Button Description

Field or Button Description

IP address of the seed node. The default value is *.*.*.*.

Follow the guidelines for IP addresses in SNMP Configuration Table, page 3-c.

Retries Number of times the MWTM attempts to connect to the seed node. The valid range is 0 to 99. The 
default value is 2.

Timeout (sec) Time, in seconds, the MWTM waits for a response from the seed node. The valid range is 0 (no timeout) 
to 9999. The default value is 1 second.

Read Community SNMP community name for read access to the information maintained by the SNMP agent on the node. 
This value can be up to 32 characters in length. Do not include special characters such as the opening 
single quote ('), at symbol (@), dollar sign ($), caret (^), closing single quote ('), double quote ("), 
ampersand (&), or pipe (|). This value is usually set to public (the default).

Poll Interval (mins) Time, in minutes, between polls. The valid range is 0 to 9999. The default value is 15 minutes.



Changing an Existing Seed File

Step 1

Step 2

Step 3

Step 4

Creating and Changing Seed Files Using a Text Editor

new-york-a
new-york-b
chicago-c

Subnet, CIDR: 1.2.3.0/24, 1.2.3.0/255.255.255.0

DNS Hostname: mwtm.cisco.com

The MWTM displays details of the SNMP settings for the seed node in the Seed Details pane. 

Continue to add as many seed nodes as necessary to discover your entire network.

When you are ready to save the list of seed nodes in a new seed file, choose from the 
Discovery Dialog menu. The MWTM displays the Save File Dialog: Seed File List dialog box. See 
Saving a Seed File, page 4-cxvi, for more information about saving seed files.

Add Node Adds a new seed node to the MWTM.

Delete Deletes the chosen seed node. The MWTM deletes the seed node without asking for confirmation.

Next Displays the Discovery tab in the Discovery dialog box.

If you enter a seed node IP address or name in the IP Address, Address range, Subnet, CIDR, or DNS 
Hostname field, then click , MWTM automatically adds the seed node before displaying the 
Discovery tab.



The MWTM saves the seed file in the MWTM server’s seed file directory, :

–

–

new-york-a<space>
<space>new-york-b
zzzzzzzzzzzz
<blank line>
<tab>chicago-c<tab>

new-york-a
new-york-b
chicago-c





Discovery In Progress



Displaying the MWTM Main Window
Discovered Nodes

•

•

•

•

Verifying Discovery

•

•

•

•

•

•

•

Displaying the MWTM Main Window



Element Description

MWTM main window title bar that displays: MWTM main window <(networks) server name

Information Description
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MWTM Client Navigation Tree

Note

•

•

View Saved

Node does not have a note
User Guide for the Cisco Mobile Wireless Transport Manager 6.1.2
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Note

MWTM Client Content Area

Displaying Summary Lists Alarms

Note

Note

Object Description
User Guide for the Cisco Mobile Wireless Transport Manager 6.1.2
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Note

Right-Click Menu for the Summary Lists

Using the MWTM Main Menu

Column Description

Menu Command Description
User Guide for the Cisco Mobile Wireless Transport Manager 6.1.2
OL-20466-01



Chapter 4      Getting Started
  Using the MWTM Main Menu
Menu Command Description

•

•

•

•

•

•

•

(Ctrl-Q)
Exits the MWTM application, after prompting you for confirmation.

If you are working in a custom view (that is, not the DEFAULT view), the MWTM 
automatically saves any changes you made to the view.

Edit > Views
(Ctrl-M)

Opens the View Editor window to allow you to edit any views that you have created.

Edit > Clear All Events
(Ctrl-E)

Deletes the event icon (orange triangle) from MWTM displays for all known objects. The 
actual events are not deleted from the MWTM, only the event icon for all known objects.

Note During Discovery, the MWTM might flag most objects with an event icon. If the 
event icons are too distracting, use the menu option to 
remove them.
User Guide for the Cisco Mobile Wireless Transport Manager 6.1.2
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Edit > Find
(Ctrl-F)

Opens the Find dialog box, in which you find a specific object, event, or text in the window.

If you select an object in the navigation tree in the MWTM main window, this option is 
dimmed and cannot be chosen.

Edit > Delete
(Delete)

Deletes the currently chosen element or elements from the MWTM database. The MWTM 
displays the Confirm Deletion dialog box. To:

• Delete the chosen elements, click Yes

No

Do not 
show this again

Do not show this again

mwtm purgedb

Unknown
User Guide for the Cisco Mobile Wireless Transport Manager 6.1.2
OL-20466-01



(Ctrl+Shift-T)

Opens a Telnet window to the server.

View > MWTM Server > 
Connect via SSH
(Ctrl+Shift-S)

Opens a Secure Shell (SSH) window to the server.

The key size on the SSH server must be a minimum of 512 bits and a maximum of 
2048 bits.

View > MWTM Server > 
Server Status

Displays the MWTM web status page in a web browser.

View > MWTM Web Links > 
Home

Displays the MWTM web interface home page in a web browser.

View > MWTM Web Links > 
Administrative

Displays the MWTM web administrative page in a web browser.

View > MWTM Web Links > 
Groups

Displays the MWTM web groups page in a web browser.

View > MWTM Web Links > 
Tools

Displays the MWTM web tools page in a web browser.

View > MWTM Web Links > 
Reports

Displays the MWTM web reports main page in a web browser. 

View > MWTM Web Links > 
CSV File Archive

Displays the MWTM web file archive page in a web browser.

View > MWTM Web Links > 
Archived Event Logs > Status 
Changes

Displays the archived status changes in a web browser.

View > MWTM Web Links > 
Archived Event Logs > SNMP 
Traps 

Displays the archived SNMP traps in a web browser.

View > MWTM Web Links > 
Archived Event Logs > Status 
Changes and SNMP Traps

Displays both the archived status changes and archived SNMP traps in a web browser.

View > MWTM Web Links > 
Software Version Inventory

Displays the MWTM software versions for the server you are connected to, and which is 
currently running the MWTM server, in a web browser.

View > MWTM Web Links > 
Point Code Inventory

Displays the point codes inventory reports page which shows all point codes that are currently 
being used by all nodes that the MWTM detected, in a web browser. 

View > MWTM Web Links > 
IP Address Inventory

Displays the report of IP addresses of the nodes that the MWTM manages, in a web browser. 

View > Message of the Day Opens the Message of the Day dialog box.

View > Cisco.com Displays the Cisco.com Home Page in a web browser.

Go > Back
(Alt-Left Arrow) 1

Navigates back to the last window viewed in this session.

Go > Forward
(Alt-Right Arrow) 1

Navigates forward to the last window viewed in this session.



Go > Back > List of Windows

List of 
Windows



Using the MWTM Toolbar
The MWTM toolbar appears under the menu bar in the MWTM client windows, and above the 
navigation tree in the MWTM web interface.

Launch > CiscoView
< >

Launches CiscoView, which provides a real-time, color-coded, graphical representation of 
Cisco objects. You can use CiscoView to quickly identify an incorrect status on a port or 
interface.

This option is dimmed if the chosen node is: not a recognized node; in Unmanaged status; 
or has a Device Type of Unknown. (CiscoWorks cannot monitor Unmanaged, Unknown, or 
unrecognized nodes.)

This option is not visible if you did not specify a CiscoWorks server during installation. See 
the “Installing MWTM on Solaris” and “Installing MWTM on Windows” chapters of the 

for more 
information.

Launch > CiscoWorks LMS 
Portal
< >

Launches CiscoWorks LMS Portal, which provides a dashboard of tools and utilities such as 
CiscoView, Resource Manager Essentials, and Device Center.

Launch > Device Center 
< >

Launches the CiscoWorks Device Center, which provides a number of web-based functions, 
including reachability trends, response time trends, interface status, syslog browsing, and 
detailed inventory. The MWTM prompts you for a CiscoWorks user ID and password before 
linking to CiscoWorks.

The link to CiscoWorks has these prerequisites. CiscoWorks must:

• Be installed somewhere in the network.

• Monitor the specific device.

This option is dimmed if the chosen node is: not an recognized node; in Unmanaged status; 
or has a Device Type of Unknown. (CiscoWorks cannot monitor Unmanaged, Unknown, or 
unrecognized nodes.)

This option is not visible if you did not specify a CiscoWorks server during installation. See 
the “Installing MWTM on Solaris” and “Installing MWTM on Windows” chapters of the 

for more 
information.

Help > Topics
(F1)

Displays the table of contents for the MWTM online help.

Help > Window
(Shift-F1)

Displays online help for the current window.

Help > About
(F3)

Displays build date, version, SSL support, and copyright information about the MWTM 
application.

1. In the UNIX environment (Solaris or Linux), this key combination can be mapped to a different function based on the Common Desktop Environment 
(CDE) that a user might have. For example, in Solaris CDE, Alt-Left Arrow and Alt-Right Arrow combinations are typically mapped to move back and 
forward through the different desktops. To remap the keys for use with the MWTM, see your UNIX Desktop Environment guide.

http://preview.cisco.com/en/US/docs/net_mgmt/mobile_wireless_transport_manager/6.1.2/installation/guide/mwtm612ig.html
http://preview.cisco.com/en/US/docs/net_mgmt/mobile_wireless_transport_manager/6.1.2/installation/guide/mwtm612ig.html
http://preview.cisco.com/en/US/docs/net_mgmt/mobile_wireless_transport_manager/6.1.2/installation/guide/mwtm612ig.html
http://preview.cisco.com/en/US/docs/net_mgmt/mobile_wireless_transport_manager/6.1.2/installation/guide/mwtm612ig.html


Accessing the MWTM Through a Web Browser
Accessing the MWTM Through a Web Browser

• MWTM client interface—The standard interface for accessing MWTM data. (This interface is 
described in Displaying the MWTM Main Window, page 4-cxxiii.)

—A browser interface for accessing MWTM data. (This interface is 
introduced here and fully described in Chapter 11, “Accessing Data from the Web Interface.”)

A comparison of the GUI features supported in each interface is shown in this matrix:

Sort tree by name 

Sorts all content in the navigation tree alphabetically by name. 

Sort tree by status

Sorts all content in the navigation tree by status, from the highest alarms to 
the lowest.

Go back or forward one navigation change

(Only in MWTM client) Click to browse forward or backward in your 
navigation changes. In the MWTM web interface, click the browser’s back 
and forward buttons.

Location

Shows your current location in MWTM. Some locations are clickable links 
to which you can navigate directly.

GUI Features Web Interface Client Interface Notes
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• http:// :1774

View > MWTM Web Links > Home

Loading and Saving MWTM Files

•

•

•

•

GUI Features Web Interface Client Interface Notes

Launched From Choose Window Launched Notes
User Guide for the Cisco Mobile Wireless Transport Manager 6.1.2
OL-20466-01



Chapter 4      Getting Started
  Using the Windows Start Menu
Note

Using the Windows Start Menu

•

•

•

•

•

•

•

Changing the Default MWTM Server Name

Step 1

Step 2

Launched From Choose Window Launched Notes
User Guide for the Cisco Mobile Wireless Transport Manager 6.1.2
OL-20466-01



Chapter 4      Getting Started
  Using the Windows Start Menu
Step 3

Tip

Launching the MWTM Client

Launching the MWTM DOS Prompt

. The MWTM opens a DOS window, starting in the \  
directory:

• If you installed the MWTM client in the default directory, , then the DOS prompt 
starts at .

• If you installed the MWTM client in a different directory, then the \  directory is located in that 
directory.

Launching the MWTM Event Editor

Note

Launching the MWTM SSL Certificate Tool

Displaying the MWTM README File

Start > Programs > Cisco MWTM Client > Readme
User Guide for the Cisco Mobile Wireless Transport Manager 6.1.2
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Locating Technology Specific Information
Uninstalling the MWTM

Locating Technology Specific Information

http://preview.cisco.com/en/US/docs/net_mgmt/mobile_wireless_transport_manager/6.1.2/installation/guide/mwtm612ig.html
http://preview.cisco.com/en/US/docs/net_mgmt/mobile_wireless_transport_manager/6.1.2/installation/guide/mwtm612ig.html
http://preview.cisco.com/en/US/docs/net_mgmt/mobile_wireless_transport_manager/6.1.2/installation/guide/mwtm612ig.html
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Technology Topic and Location

• User Guide for the Cisco Mobile Wireless Transport Manager 6.1.2:

• OSS Integration Guide for the Cisco Mobile Wireless Transport Manager 6.1.2:

• Alarm Guide for the Cisco Mobile Wireless Transport Manager 6.1.2:

User Guide for the Cisco Mobile Wireless Transport Manager 6.1.2:

OSS Integration Guide for the Cisco Mobile Wireless Transport Manager 6.1.2:

Alarm Guide for the Cisco Mobile Wireless Transport Manager 6.1.2:
User Guide for the Cisco Mobile Wireless Transport Manager 6.1.2
OL-20466-01



Exiting the MWTM Client
Exiting the MWTM Client

Step 1

Step 2

•

•

•

•

Technology Topic and Location
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4-cxl
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