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Editing ITP MLR Address Table Files

You use the Cisco Mobile Wireless Transport Manager (MWTM) to configure Multi-Layer Routing
(MLR) address table files by using the MWTM Address Table Editor. You can:

e Create new address table files.

e Load existing address table files.

e Edit address table files.

e Perform semantic checks on address table files.
e Deploy address table files to an ITP.

e Save address table files.

If you implement MWTM User-Based Access, the Address Table Editor is available to users with
authentication level Network Operator (level 3) and higher.

For more detailed information about address tables, including configuration procedures and scenarios,
see the IP Transfer Point (ITP) feature module for Cisco IOS software release 12.2(25)SW3 or later.

This chapter contains:
e Launching the Address Table Editor, page 15-2
¢ Creating a New Address Table File, page 15-6
¢ Loading an Existing Address Table File, page 15-8
e Loading an Address Table File from a Node, page 15-10
e Loading an Address Table File from the Archive, page 15-12
e Working Within Address Table Files, page 15-14
e Editing Address Table Properties, page 15-16
¢ Checking the Semantics of an Address Table File, page 15-17
e Deploying an Address Table File, page 15-18
e Displaying Basic Information About an Address Table File, page 15-19
e Listing Archived Address Tables, page 15-20
¢ Creating Network Name Mapping Files, page 15-20
e Saving an Address Table File, page 15-23
e Reverting to the Last Saved Address Table File, page 15-25
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Launching the Address Table Editor

Launching the Address Table Editor

The Address Table Editor runs as a separate application in the MWTM, so it requires a separate log in,
just like the MWTM client.

If you implement MWTM User-Based Access, the Address Table Editor is available to users with
authentication level Network Operator (level 3) and higher.

To launch the Address Table Editor, use one of these procedures:
e Choose Tools > Address Table Editor from the MWTM main menu.
¢ Enter the mwtm atblclient command (see mwtm atblclient, page B-77).

The Startup Options dialog box appears, which you use to load a specific address-table file or create a
new address table file.

The Startup Options dialog box contains options for loading or creating the address table data from:

Field or Button Description

New File Opens the Address Table Properties dialog box, which you use to create a
new address table file (see Creating a New Address Table File, page 15-6).
Create the new address table file.

If you implement MWTM User-Based Access, this option is available to
users with authentication level Network Administrator (level 4) and higher.

From File Opens the Load File Dialog: Address Table File list, which you use to load
a specific address table file and change the list of address table files (see
Loading an Existing Address Table File, page 15-8). Select an address table
file to load.

From ITP Opens the Load Address Table from ITP wizard, which you use to select the
ITP release 12.2(25)SW3 or later signaling point whose address table file
you want to edit (see Loading an Address Table File from a Node, page
15-10). Select a signaling point.

If you implement MWTM User-Based Access, this option is available to
users with authentication level Network Operator (level 3) and higher.

From Archive Opens the Load Address Table from Archive wizard, which you use to select
the ITP release 12.2(25)SW3 or later node and signaling point whose address
table file you want to edit (see Loading an Address Table File from the
Archive, page 15-12). Select a signaling point and table type.

If you implement MWTM User-Based Access, this option is available to
users with authentication level Network Operator (level 3) and higher.

Once you close the Startup Options dialog box by creating a new address table file or loading an existing
address table file, the Address Table Editor window appears. If you have created a new address table file,
the table will be blank. If you have opened an existing address table file, the table will be populated.
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Launching the Address Table Editor

Figure 15-1 Address Table Editor Window
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Address Table Menu

The menu on the Address Table Editor window contains:

Menu Command Description
File > New Table Opens the Address Table Properties dialog box. The MWTM
(Ctrl-N) prompts you to:

e Enter the table name, variant, instance number, and network
name, then click OK to create the address table file.

¢ Click Cancel to close the prompt window without creating an
address table file.

For more information, see Creating a New Address Table File, page
15-6.

If you implement MWTM User-Based Access, this option is
available to users with authentication level Network Administrator
(level 4) and higher.

File > Load > Load From File Opens the Load File dialog box, allowing you to load an already
(Ctrl-L) existing address table file. The MWTM prompts you to:

e Select the file from the list, then click OK to load the address
table file.

¢ Click Cancel to close the prompt window without loading an
address table file.

For more information, see Loading an Existing Address Table File,
page 15-8.
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Launching the Address Table Editor

Menu Command

Description

File > Load > Load From Node
(Ctrl-T)

Opens the Load Address Table from ITP Wizard, which you use to
select the ITP release 12.2(25)SW3 or later signaling point whose
address table file you want to edit, as well as the table type.

Tip Click Show Log at any time to view the process details.

To load the address table from a node:

1. Select a node and signaling point from the drop-down list
boxes, then click Next to load the address table list.

2. Select an address table list from the drop-down list box, then
click Next to enter your passwords.

3. Enter the login password, then click Next.
4. Enter the enable password, then click Next.
5. Click Finish to complete the loading process.

If you have implemented MWTM User-Based Access, this option is
available to users with authentication level Network Operator (level
3) and higher.

For more information, see Loading an Address Table File from a
Node, page 15-10.

File > Load > Load From
Archive
(Ctrl-H)

Opens the Load Address Table from Archive Wizard, which you use
to select the ITP release 12.2(25)SW3 or later node and signaling
point whose address table file you want to edit.

To load the address from archive:

1. Select a node and signaling point from the drop-down list
boxes, then click Next to load the address table list.

2. Select the address table list from the drop-down list box, then
click Next to enter your passwords.

3. Select the version from the table by clicking on it, then click
Next.

4. Click Finish to complete the loading process.

If you have implemented MWTM User-Based Access, this option is
available to users with authentication level Network Operator (level
3) and higher.

For more information, see Loading an Address Table File from the
Archive, page 15-12

File > Revert
(Ctrl-R)

Reverts to the last saved version of the address table file.

File > Save
(Ctrl-S)

Saves the changes that you make to the address table file.

File > Save As

Opens the Save File Dialog: Address Table File list, which you use
to save the address table file with a new name or overwrite an
existing address table file.
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Menu Command

Description

File > Semantic Check
(Ctrl-K)

Opens the Semantic Check address table dialog box, which you use
to check the semantics of an address table file against a specific ITP
(see Checking the Semantics of an Address Table File, page 15-17).

File > Deploy
(Ctrl-Y)

Opens the Deployment wizard, which you use to validate an address
table file, upload it to an ITP, and activate it on the ITP.

Note If you have not saved the current address table file, the Save
File Dialog: Address Table File List appears, prompting you
to save the file before continuing.

For more information, see Deploying an Address Table File, page
15-18.

File > Exit
(Ctrl-Q)

Closes the Address Table Editor window. The MWTM prompts you
to confirm this action. Ensure that you save any changes before
exiting, if necessary. Click:

¢ Yes to exit.

¢ No to close the window.

Edit > Address Table Properties
(Ctrl-P)

Opens the Edit Address Table Properties dialog box, which you use
to change the name, variant, version, instance ID, and network name
associated with an address table file (see Editing Address Table
Properties, page 15-16).

Edit > Add
(Ctrl-E)

Adds a row to the address table.

Edit > Delete
(Ctrl-Delete)

Deletes one or more selected rows from an address table. The
Confirm Delete dialog box appears. To:

e Delete the selected rows, click Yes. The rows disappear from
the table and the Confirm Delete dialog box closes.

e Retain the selected rows, click No. The rows remain in the table
and the Confirm Delete dialog box closes.

Edit > Node Archive
Management

Opens the Node Archive Management dialog box, which you use to
view the contents of the archive, open a version with its
corresponding editor, and delete all versions of a file (see Node
Archive Management, page 5-32).

If you implement MWTM User-Based Access, this option is
available to users with authentication level Network Administrator
(level 4) and higher.

Edit > Node File Management

Opens the Node File Management dialog box, which you use to
transfer address table files to and from the ITP (see Node File
Management, page 5-25).

If you implement MWTM User-Based Access, this option is
available to users with authentication level Network Administrator
(level 4) and higher.

View > Address Table Info
(Ctrl-I)

Opens the Address Table Information dialog box, which shows
basic information about the currently visible address table file.

[ oL-9118-03
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B Creating a New Address Table File

Menu Command Description

View > Network Name Opens the Network Name Configuration dialog box, which maps
Configuration network names to variants and network indicators, in support of
(Ctrl-F) cross-instance address table files.

Help > Topics Shows the table of contents for the MWTM online help.

(F1)

Help > Window Shows online help for the current window.

(Shift-F1)

Help > About Shows build date, version, SSL support, and copyright information
(F3) about the MWTM application.

Creating a New Address Table File

You use the MWTM to create a new address table file. If you:
e Launch the Address Table Editor from the Startup Options window, click New File.

e Are already in the Address Table Editor, choose File > New Table from the Address Table Editor
menu. You are prompted to save changes if you are currently working on an unsaved file.

Note  If you implement MWTM User-Based Access, this option is available to users with authentication level
Network Administrator (level 4) and higher.

The Address Table Properties dialog box appears.

Figure 15-2 Address Table Properties Dialog
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Creating a New Address Table File

Field or Button

Description

Table Name

User-defined unique table name.

Variant

SS7 protocol variant. Select a variant from the drop-down list box. Valid variants
are:

e ANSI
e China
e ITU

e NTT
e TTC

Version

Version of the file format that the address table uses. You cannot edit this field.

Instance Number

Number of the instance that the address table uses. Select an instance number from
the drop-down list box. Valid numbers are 0 to 7. The default instance number is 0.

Network Name

Network name that the address table uses. Select a network name from the
drop-down list box. When you select the network name, the MWTM automatically
sets the corresponding variant in the Variant field.

If you change the network name for an existing address table file, the new network
name must use the same variant.

OK

Creates the new address table file and closes the Address Table Properties dialog
box.

Enter or select values for the new address table file, then click OK. The MWTM
creates the new address table file and closes the Address Table Properties dialog
box.

Cancel

Closes the Address Table Properties dialog box without creating a new address
table file.

To close the Address Table Properties dialog box without creating a new address
table file, click Cancel.

Help

Shows online help for the current window.

Related Topics:

e Loading an Existing Address Table File, page 15-8

e Loading an Address Table File from a Node, page 15-10

[ oL-9118-03
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W Loading an Existing Address Table File

Loading an Existing Address Table File

You use the MWTM to load a specific address table file and change the list of address table files. If you:

e Launch the Address Table Editor from the Startup Options window, click From File.

e Are already in the Address Table Editor, choose File > Load > Load From File from the Address
Table Editor menu. You are prompted to save changes if you are currently working on an unsaved

file.

Note When you load an address table file, the name of the server that is associated with the address table client
and the filename, as well as the table type and mode (can be edit or view only), appear in the window

name:

MWTM: Address Table Editor -- mwtm-sun8 -- address table.File.l (MLR edit mode)

If you have not yet loaded or saved an address table file, the message No File Loaded appears in

place of the address-table filename.

The Load File Dialog: Address Table File List appears.

Figure 15-3

Load File Dialog: Address Table File List

Z MWTH: Load File Dialog

Address Table File List
File Types: = =
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Cancel | | Help | —
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Jo Files| =
Field or Button Description

File Types

Drop-down list only includes MLR.

Type

Icon indicating whether the item in the table is a file or a
folder.

Name

Name of the address table file or folder.

Last Modified

Date and time the address table file or folder was last
modified.

Size (bytes)

Size of the address table file or folder, in bytes.
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Field or Button

Description

Number of Files
(in lower-left corner)

Total number of address table files and folders.

OK

When you click this button, it:
e Loads the selected address table file.
e Saves any changes you made to the list of files.
¢ Closes the Load File Dialog: Address Table File list.
e Opens the Progress dialog box
¢ Begins loading the address table file.
To load an address table file:
e Double-click it in the list
e Select it in the list and click OK.
— Or, enter the name of the file and click OK.

The MWTM closes the Load File Dialog: Address
Table File list and the Progress dialog box appears,
which shows the progress of the address table file
load, as well as any messages that appear while
loading the file.

¢  When the file has been loaded, click OK.

The MWTM closes the Progress dialog box, loads the
address table file, and returns to the Address Table Editor
window.

Delete

Deletes the selected file from the address table file list. The
MWTM issues an informational message containing the
name and location of the deleted file.

Cancel

Closes the dialog box without loading an address table file or
saving any changes to the address table file list.

Help

Shows online help for the dialog box.

Related Topics:

e Launching the Address Table Editor, page 15-2

e Loading an Address Table File from a Node, page 15-10

[ oL-9118-03
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M Loading an Address Table File from a Node

Loading an Address Table File from a Node

N

Note

Before using the Load Address Table From ITP wizard to load address table files, you must enable TFTP
file transfer for the address table staging directory by using the mwtm atbldir command (see mwtm
atbldir, page B-78).

You use the Load Address Table From ITP wizard to load an existing address table file from a node. If
you:

e Launch the Address Table Editor from the Startup Options window, click From Node.

e Are already in the Address Table Editor, choose File > Load > Load From Node from the Address
Table Editor menu.

If you implement MWTM User-Based Access, this option is available to users with authentication level
Network Operator (level 3) and higher.

The Load Address Table From ITP wizard appears.

Figure 15-4 Load Address Table From ITP wizard
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Loading an Address Table File from a Node 1l

The left pane of the Load Address Table From ITP wizard contains:

Step Description

Select Node/SP | You can select the signaling point from which the address table should be loaded.
You can optionally check the Filter by Node check box, which limits signaling
point selection to a specific node.

Select a signaling point and node (optional) from the drop-down list boxes, then
click Next . The MWTM retrieves address table names from the selected signaling
point.

If no address table names are available, the process ends with errors. If address
table names are available, the MWTM proceeds directly to the Select Table step.

Login You can log in to the ITP. Enter the:
e Log in password, if required.
¢ Enable password, if required.

Note To avoid entering username and password information each time, you can
set up credentials (see Configuring Login Credentials, page 3-19).

Load Uploads the address table file to the MWTM.

If the file upload ends with no errors, the process is successful. Click Finish.

The bottom line of the Load Address Table From ITP wizard contains:

Field or Button Description

Progress Bar Indicates that the address table file is being uploaded.
Show Log/Hide Log Shows or hides the log file for the Load Address Table From ITP wizard.

Next > Advances to the next step in the Load Address Table From ITP wizard.

Finish Closes the Load Address Table From ITP wizard. The Finish button appears
when loading ends successfully or the wizard detects errors and the process
is cancelled.

Cancel Closes the Load Address Table From ITP wizard without loading the file.
Help Shows online help for the Load Address Table From ITP wizard.

Related Topics:
e Launching the Address Table Editor, page 15-2

e Loading an Existing Address Table File, page 15-8
e Editing Address Table Properties, page 15-16
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Loading an Address Table File from the Archive

N

Note

Before using the Load Address Table From Archive wizard to load address table files, you must use the
mwtm atbldir command to enable TFTP file transfer for the address table staging directory (see mwtm
atbldir, page B-78).

You can use the Load Address Table From Archive wizard to load an existing address table file from the
archive. If you:

e Launch the Address Table Editor, from the Startup Options window, click From Archive.

e Are already in the Address Table Editor, choose File > Load > Load From Archive from the
Address Table Editor menu.

If you implement MWTM User-Based Access, this option is available to users with authentication level
Network Operator (level 3) and higher.

The Load Address Table From Archive wizard appears.

Figure 15-5 Load Address Table From Archive wizard
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The left pane of the Load Address Table From Archive wizard contains:
Step Description
Select Node/SP | You can select the signaling point from which to load the address table. You can
optionally check the Filter by Node check box, which limits signaling point
selection to a specific node.
Select a signaling point and node (optional) from the drop-down list boxes, then
click Next . The MWTM retrieves address table names from the selected signaling
point.
If no address table names are available, the process completes with errors. If
address table names are available, the MWTM proceeds directly to the Select Table
step.
Select Version You can select the version you want to load. Click on a version to highlight it, then
click Next. The table contains:
e Rev—Revision number.
e Date—Date and time the version was created.
e Comments—Provided at the time of creation, if applicable.
¢ Author—Initiator of the comments.
Load Uploads the address table file to the MWTM.
If the file upload ends with no errors, the process is successful. Click Finish.
The bottom line of the Load Address Table From Archive wizard contains:
Field or Button Description
Progress Bar Indicates that the address table file is being uploaded.
Next > Advances to the next step in the Load Address Table From ITP wizard.
Finish Closes the Load Address Table From ITP wizard. The Finish button appears
when loading completes successfully or it detects errors and the process is
cancelled.
Cancel Closes the Load Address Table From ITP wizard without loading the file.
Help Shows online help for the Load Address Table From ITP wizard.
Related Topics:
e Launching the Address Table Editor, page 15-2
e Loading an Existing Address Table File, page 15-8
e Loading an Address Table File from a Node, page 15-10
e Editing Address Table Properties, page 15-16
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Working Within Address Table Files

Once you create a new address table file or load an existing address table file, you can manage the
address table entries.

If you implement MWTM User-Based Access, these options are available to users with authentication
level Network Administrator (level 4) and higher. To:

e Add arow to a table, select the table and choose Edit > Add from the address table menu; or, Add
from the right-click menu.

e Delete one or more rows from a table, select the rows and choose Edit > Delete from the address
table menu; or, Delete from the right-click menu.

¢ Edit the values in each row in each table, type over the current value or select a new value from a
drop-down list box. If you are editing a row, you cannot move on until all fields in the row are
completed.

e Reset a cell to its previous value. Press Esc. Press Esc twice to reset the entire row.

¢ Commit your changes, click outside the row or press Enter.

N

Note  Once you commit your changes, pressing Esc does not reset the cells in the row.

The Address Table Editor window contains:

Heading Description

Address Digits Address digits for the address table. Enter a 1- to 20-digit hexadecimal string.
The value must be unique in an address table.

Exact Match Considers the address an exact match.

Result Type Type of action to perform on a match.

Result Value Values to use with the matching action.
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Working Within Address Table Files

Result Types and Values

This table defines the list of result types from which to choose when you click in the Result Types
column and the drop-down arrow that appears, and the corresponding result values that you enter for
MLR address tables:

Result Type Result Value Description

asname Route to the specified Message is routed to a particular destination M3UA
application server. or SUA application server.

block none Indicates that you should discard the short message.

continue none Message that the normal SCCP routing will process

the message.

group Specify the name of the result |Indicates that a result group is used for routing.
group to which to route.

gt <SCCP address> tt <number> |Indicates that the message is routed by using SCCP
gti <number> global title. Places the specified address in the SCCP
Called Party Address. The routing indicator changes
to RI=GT. Then routed based on the locally
provisioned global-title translation table. When you
select this parameter and click on the corresponding
space in the Result Value column, the Edit GTT
dialog box appears and contains:

¢ SCCP Address—An address string of 1-15
hexadecimal characters. The string is not input
in BCD-String format, butin normal form.

e Translation Type—Identifies the translation
type that the address specifies. Valid values are
0-255.

¢ Global Title Indicator—Identifies the global
title indicator value for the specified address.
This value is always 2 for an ANSI variant and
might be 2 or 4 for other variant types.

e Numbering Plan—Identifies the numbering
plan of the specified address. This value is only
specified when the gti parameter value is 4.
Valid values are 0-15.

e Nature of Address Indicator—Identifies the
nature of the specified address. This value is
only specified when the gti parameter value is 4.
Valid values are 0-127.

¢ Add—Adds the current values.
¢ Close—Closes the dialog box.

e Help—Launches the online help window for the
current dialog box.
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M Editing Address Table Properties

Result Type Result Value

Description

none none

A result is not specified.

pc <point code> ssn <number>

Indicates that pe or pe/ssn routing is used. When you
select this parameter and click on the corresponding
space in the Result Value column, the Edit Point
Code dialog box appears and displays these fields
and buttons:

Point Code—Point code to route the message.

SSN —Specify a subsystem number. Valid
values are 2-255.

Add—Adds the current values.
Close—Closes the dialog box.

Help—Launches the online help window for the
current dialog box.

Editing Address Table Properties

You can use the MWTM to edit the address table properties associated with an address table file. Choose
Edit > Address Table Properties from the Address Table Editor menu. The Edit Address Table

Properties dialog box appears.

Figure 15-6 Edit Address Table Properties Dialog

Wariant |

Version |

Instance Mumber [0 | ¥

Metwork Name IanSiﬂEﬂ |:|

| oK | | cancel | | Help | "
Field or Button Description
Table Name User-defined unique table name.
Variant SS7 protocol variant. You cannot edit this field.
Version Version of the file format that the address table uses. You cannot edit this field.
Instance Number |Number of the instance that the address table uses. Valid numbers are 0 to 7; the
default instance number is 0.
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Checking the Semantics of an Address Table File

Field or Button

Description

Network Name

Network name that the address table uses.

If you change the network name for an existing address table file, the new network
name must use the same variant.

OK

Saves the changes to the address table file.

Enter or select values, then click OK. The MWTM saves your changes to the
address table file.

Cancel

Closes the Edit Address Table Properties dialog box without saving any changes to
the address table file.

To close the Edit Address Table Properties dialog box at any time without saving
any changes to the address table file, click Cancel.

Help

Shows online help for the current window.

Checking the Semantics of an Address Table File

In using the MWTM, Cisco strongly recommends that you check the semantics of an address table file
against a specific ITP, validating these data in the address table file:

Group Name—In the Address Table entries, when the result type is group the result value is a group
name. You must configure the group name in the address entry on the ITP prior to the deployment of the
address table. During the validation process, if the group name in the address entry does not have a
corresponding match on the ITP, the MWTM generates an error.

To check the semantics of an address table file, choose File > Semantic Check from the Address Table
Editor menu. The Semantic Check address table dialog box appears.

Figure 15-7 Semantic Check Address Table Dialog

%]

ITP Mame or IP Address
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| Deploying an Address Table File

Field or Button Description

ITP Name or IP Address Name or IP address of the ITP against which to check the address table
file.

OK Closes the Semantic Check Address Table dialog box and opens the

Progress dialog box, which shows the progress of the semantic check
for the address table file.

Enter the name or IP address of an ITP, and click OK. The the
Semantic Check Address Table dialog box closes and the Progress
dialog box opens, which shows the progress of the semantic check for

the address table file and any messages that appear while checking the
file.

When the check ends, click OK. The Progress dialog box closes and
returns to the Semantic Check Address Table dialog box.

Cancel Closes the Semantic Check Address Table dialog Box without
checking the semantics of the address table file.

S

Fte You can also use the mwtm checkmlr command to check the semantics of an MLR address table file
(see mwtm checkmlr, page B-79).

Deploying an Address Table File

You use the Deployment wizard to validate an address table file, upload it to an ITP, archive the file, and
activate it on the ITP. To launch the Deployment wizard for an address table file, use one of these
procedures:

e Choose File > Deploy from the Address Table Editor menu (see Deploying ITP Files, page 5-35).

e Enter the mwtm pushmlr command (see mwtm pushmlr, page B-97).
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Displaying Basic Information About an Address Table File

Displaying Basic Information About an Address Table File

You use the MWTM to view basic information about the current address table file. Choose View >
Address Table Info from the address table menu. The Address Table Information dialog box appears.

Figure 15-8
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The Address Table Information dialog box is read-only.

Field or Button Description

Table Name User-defined unique table name.

Filename Name of the address table file.

Version Version of the file format that the address table uses.
Variant SS7 protocol variant. Valid variants are:

ANSI
China
ITU
NTT
TTC

Network Name

Network name that the address table file uses.

Instance Number

Number of the instance that the address table uses. Valid numbers are O to 7.
The default instance number is 0.

Last Modified Date and time that someone last modified the address table file.
Total Entries Total number of entries in the address table file.
OK Closes the address table Table Info dialog box.

User Guide for the Cisco Mobile Wireless Transport Manager 6.0 g



Chapter 15 Editing ITP MLR Address Table Files |

M Listing Archived Address Tables

Listing Archived Address Tables

To view a list of deployed and archived MLR address tables, do one of the following:
e Enter the mwtm listarchive command (see mwtm listarchive, page B-91).

e Inthe MWTM Address Table Editor, choose Edit > Node Archive Management (see Node Archive
Management, page 5-32).

For a list of current MLR address table files in the address table staging directory, enter the mwtm
listmlr command (see mwtm listmlr, page B-92).

Creating Network Name Mapping Files

When the MWTM discovers your network, it automatically creates and populates the network
name-mapping file; therefore, in most cases, you do not need to manually create the network
name-mapping file. For more information about running Discovery, see Discovering Your Network, page
4-4.

In some cases, you might want to manually create the network name-mapping file; for example, you
might not have run Discovery yet, but you want to prepare for a future address table configuration. Also,
while you cannot change or delete entries that have been populated automatically by the MWTM, you
can add entries manually; and, you can change or delete those manual entries.

To create the network name-mapping file manually; or, add, change, or delete manual entries, choose
View > Network Name Configuration from the address table menu. If you implement MWTM
User-Based Access, this option is available to users with authentication level System Administrator
(level 5). The Network Name Configuration dialog box appears.

Figure 15-9 Network Name Configuration Dialog
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The Network Name Configuration dialog box contains:
e Network Name Configuration Dialog Menu, page 15-21
e Network Name Configuration Dialog Table, page 15-22
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Network Name Configuration Dialog Menu

The menu on the Network Name Configuration dialog box contains:

Menu Command

Description

File > Revert
(Ctrl-R)

Loads the most recent network name-mapping file from the MWTM server.

If the MWTM discovers new entries for the network name-mapping file while
you are editing an address table file (for example, if a new network instance is
added, or a new network is discovered), the Address Table Editor does not
detect the new entries and they do not appear in the Network Name
Configuration dialog box. To see the new entries in the dialog box, choose File
> Revert. (You can also restart the Address Table Editor to automatically load
the most recent network name-mapping file from the MWTM server.)

File > Save
(Ctrl-S)

Saves the changes that you make to the network name-mapping file.

After you add, change, or delete entries and save the file, the MWTM uses the
file the next time it discovers the network. However, if the MWTM discovers
entries that conflict with manual entries in the file, the MWTM uses (and
shows in the Network Name Configuration dialog box) the discovered entries;
not the manual entries.

File > Print

Prints the contents of the network name-mapping file.

(Ctrl-P)

File > Close Closes the network name-mapping file without saving any additions, changes,
(Ctrl-W) or deletions.

Edit > Add Adds an entry to the network name-mapping file.

(Alt-A)

Edit > Delete Deletes the selected entry from the network name-mapping file.

(Delete)

Help > Topics
(F1)

Shows the table of contents for the MWTM online help.

Help > Window
(Shift-F1)

Shows online help for the current window.

Help > About
(F3)

Shows build date, version, SSL support, and copyright information about the
MWTM application.

[ oL-9118-03
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Network Name Configuration Dialog Table

The Network Name Configuration Dialog table contains:

Field Description

Network Name Network name that the address table file uses.

If you change the network name for an existing address table file, the new
network name must use the same variant.

Variant SS7 protocol variant. Valid variants are:
e ANSI
e China
e ITU
e NTT
e TTC
Network Indicator Type of call that a user places. Valid values are:

¢ National—National-bound call. The MWTM routes national calls
through the national network.

e NationalSpare—National-bound call, used in countries in which more
than one carrier can share a point code. In those countries, the Network
Indicator differentiates networks.

e International—International-bound call. The MWTM forwards
international-bound calls to an STP pair that acts as an international
gateway.

¢ InternationalSpare—International-bound call, used in countries in
which more than one carrier can share a point code. In those countries,
networks are differentiated by the Network Indicator.

Discovered Indicates whether the:

e MWTM (Yes) discovered the entry.

e A user entered it manually (No).
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Saving an Address Table File

You use the MWTM to save a specific address table file and change the list of address table files.

If you implement MWTM User-Based Access, this option is available to users with authentication level
Network Administrator (level 4) and higher.

To save the changes that you make to an address table file or change the list of address table files, use
one of these procedures. To save the changes that you make to the address table file:

e Without changing the name of the file, choose File > Save from the address table menu.

e With a new name, choose File > Save As from the address table menu. The Save File Dialog:
Address Table File List appears.

Figure 15-10

P;ﬁ*m- x|

Save File Dialog: Address Table File List

Address Table File List ]
=
Type Marne Last Modified Size (bytes)
0y mlr Jan 12, 03:42:27 . 23
0y trp1 9847 Jan 12, 03:39:31 .. 0
Filename: | |
Cancel | | Help | "
i
|2 Files| g
Field or Button or Icon Description
Type Icon indicating whether the item in the table is a file or a
folder.
Name Name of the address table file or folder.
Last Modified Date and time a user last modified the address table file or

folder.

Size (bytes)

Size of the address table file or folder, in bytes.

Filename

Name by which you want to save the address table file.

If you create a new address table filename, you can use any
letters, numbers, or characters in the name that your
operating system allows. However, if you include spaces in
the new name, the MWTM converts those spaces to hyphens
(-); for example, the MWTM saves file a b ¢ as a-b-c.

Number of Files
(visible in bottom left corner)

Total number of address table files and folders.

User Guide for the Cisco Mobile Wireless Transport Manager 6.0 g



Chapter15  Editing ITP MLR Address Table Files |

B Saving an Address Table File

Field or Button or Icon Description

OK Saves the address table file or any changes you made to the
list of files and closes the dialog box.

To save the address table file with a new name, use one of
these procedures. To save the file with:

e A completely new name, enter the new name and click
OK.

e An existing name, overwriting an old address table file,
select the name in the list and click OK.

The MWTM closes the Save File Dialog: Address Table File
List and the Progress dialog box appears, which shows the
progress of the address table file save, as well as any
messages that appear while saving the file.

When the file is saved, click OK. The MWTM:
¢ Closes the Progress dialog box.
e Saves the address table file with the new name
e Returns to the Address Table Editor window.

Note If another user modifies and saves the address table
file before you save your changes, the MWTM asks if
you want to overwrite that user’s changes. If you do,
the other user’s changes are overwritten and lost. If
you choose not to, your changes are lost; unless you
save the address table file to a different filename.

Delete Deletes the selected file from the address table file list. The
MWTM issues an informational message containing the
name and location of the deleted file.

Cancel Closes the dialog box without saving the address table file or
any changes to the address table file list.

Help Shows online help for the dialog box.

When you are ready to exit the Address Table Editor window, choose File > Exit from the address table
menu.

If you made any changes to the address table file, the MWTM asks if you want to save the changes before
leaving the window. Click:

¢ Yes to save the changes.

The MWTM opens the Save File Dialog: Address Table File List, which you use to save the address
table file with a new name, or overwrite an existing address table file.

¢ No to close the prompt window.

The MWTM closes the Address Table Editor window without saving any changes to the address
table file.
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Reverting to the Last Saved Address Table File

By default, address table files reside in the MWTM installation directory. If you installed the MWTM in:
e The default directory, /opt, then the default directory is /opt/CSCOsgm/atbl.
e A different directory, then the default directory resides in that directory.

To change the directory in which the MWTM stores address table files, use the mwtm atbldir command
(see mwtm atbldir, page B-78).

Reverting to the Last Saved Address Table File

To revert to the last saved version of the address table file, choose File > Revert from the address table
menu. The MWTM shows the last saved version of the file.

If you implement MWTM User-Based Access, this option is available to users with authentication level
Network Administrator (level 4) and higher.
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I Reverting to the Last Saved Address Table File
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