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Working with Views

When MWTM discovers your network, all discovered objects are placed in a DEFAULT configuration 
view, which is stored on the MWTM server and shared by all MWTM clients. The DEFAULT view that 
is stored on the MWTM server cannot be modified by the clients. It is always available, for users who 
need to view the entire network.

Initially, all clients use the DEFAULT view. However, MWTM enables you to create your own, 
client-specific views, which are subsets of the DEFAULT view, to meet your individual needs.

You can choose the nodes you are interested in managing, remove all other nodes from your view, and 
change the layout of the topology map in the Topology Window. You can save all of this customized 
information in a view, set that view as the default view for the MWTM client, and use the MWTM client 
from then on to manage only the part of the network you are interested in, with the settings you prefer. 
As soon as you modify the DEFAULT view in any way (except modifying the layout of the topology map 
in the Topology Window), MWTM prompts you to name the new, custom view.

You can also create many different views on a given MWTM client, with each view devoted to a different 
aspect of the network. You can then switch between views to manage different parts of the network, or 
switch to the DEFAULT view to see the entire network. For details on creating views, see Creating a New 
View, page 4-31.

If a given MWTM client is used by more than one person, each user can create his or her own personal 
view.
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To help you keep track of which view you are currently using, as well as other important information, 
most MWTM windows display the following information:

• In the title bar, the name of the system on which the MWTM server is running.

• Across the bottom of the window:

– A “locked padlock” symbol if the MWTM server has a security certificate. To see the certificate, 
click the symbol.

An “unlocked padlock” symbol if the MWTM server does not have a security certificate.

– The number of objects currently displayed in the window, if any.

– The number of files currently displayed in the load or save files dialog, if any.

– Status messages, as appropriate.

Informational messages, such as “Discovery running”, are displayed in black.

Messages that indicate successful actions, such as “View Saved”, are displayed in green.

Error messages, such as “Node does not have a note”, are displayed in red.

There are many fields in MWTM that enable you to enter information, such as a new node name 
or IP address. If you enter an incorrect value in the field, such as an IP address that contains 
letters or is too long, MWTM beeps and retains the current value of the field. Check the message 
bar at the bottom of the window for information and assistance.

– The text (Modified), if the view has been modified but not yet saved. You must save the view 
if you want to save your changes. See the “Working with Views” section on page 4-1 for more 
details.
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– A “New!” icon, if there is at least one newly discovered node in the network that has not been 
added to your current view. To add the node to your current view, see the “Viewing the Topology 
of the Network” section on page 8-1. To exclude the node from your current view, see the 
“Working with Views” section on page 4-1.

Clicking the “New!” icon in the Topology Window opens the New Objects panel in the left pane. 
Clicking the “New!” icon in any other window opens the Edit View tab of the View Editor 
Window.

– The name of the current view.

– The name of the current user, or the name of the device the user is using.

– If you have implemented MWTM User-Based Access, the authentication level of the user.

If your personal default view has been deleted, then the next time you launch the client MWTM informs 
you that your default view has been deleted and that your view has been reset to the DEFAULT view. To 
choose another view as your default view, use the Load File Dialog: View List. See the “Loading a 
Client-Specific View” section on page 4-40 for details.

This section includes the following information:

• Viewing Basic Information for Views, page 4-4

• Viewing Detailed Information for a View, page 4-9

• Editing a View, page 4-25

• Saving a View, page 4-27

• Viewing Notes for a View, page 4-30

• Creating a New View, page 4-31

• Loading the DEFAULT View, page 4-39

• Loading a Client-Specific View, page 4-40

• Ignoring a View, page 4-41

• Viewing Ignored Views, page 4-42
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  Viewing Basic Information for Views
Related Topics:

• Discovery Overview, page 2-1

• Changing MWTM Client Preference Settings, page 11-2

• Changing the Message Display, page 11-27

• Viewing the Topology of the Network, page 8-1

Viewing Basic Information for Views
To view basic information for views, select Views in the left pane of the MWTM Main Window. MWTM 
displays the View Statistics Window.

The View Statistics Window provides information about all views that have been defined for this MWTM 
client, including their status and other important information.

The View Statistics Window is composed of the following sections:

• Right-Click Menu for All Views, page 4-4

• Right-Click Menu for a Specific View, page 4-5

• View Table, page 4-6

Related Topics:

• Viewing Detailed Information for a View, page 4-9

• Changing MWTM Client Preference Settings, page 11-2

• Resizing, Sorting, and Hiding Table Columns, page 3-30

• Using the MWTM Main Menu, page 3-7

• Viewing Notes for a View, page 4-30

Right-Click Menu for All Views
To see the right-click menu for all views, select Views in the left pane and click the right mouse button. 
The views right-click menu provides the following options:

Menu Command Description

Show In New Window Opens the View Statistics Window in a new window.

Sort Tree By Status Sorts the entire tree in the left pane by the status of each object.

Sort Tree By Name Sorts the entire tree in the left pane by the name of each object.

Back > List of Windows Navigates back to a window viewed in this session.

MWTM maintains a list of up to 10 Back windows.

Forward > List of 
Windows

Navigates forward to a window viewed in this session.

MWTM maintains a list of up to 10 Forward windows.
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  Viewing Basic Information for Views
Right-Click Menu for a Specific View
The View Statistics Window provides a subset of the MWTM Main Menu as a right-click menu. To see 
this menu, select a view and click the right mouse button. The view right-click menu provides the 
following options:

Menu Command Description

Show In New Window Opens the View Details Window for the selected view in a new window.

Edit > Properties Opens the Edit Properties Dialog for the selected view.

If you have implemented MWTM User-Based Access, this option is 
available to users with authentication level Power User (Level 2) and 
higher.

Edit > Notes Opens the Edit Notes Dialog for the selected view.

If you have implemented MWTM User-Based Access, this option is 
available to users with authentication level Power User (Level 2) and 
higher.

Clear Event Icon Deletes the event icon (orange triangle) from MWTM displays for the 
selected view, for this MWTM client only. The actual events are not 
deleted from MWTM, only the event icon for the selected view for this 
MWTM client.

This option is grayed-out if the selected view has no associated event icon.

Delete Deletes the currently selected view from the MWTM database. MWTM 
displays the Confirm Deletion dialog:

• To delete the selected view, click Yes. The view is deleted from the 
MWTM database and the Confirm Deletion dialog is closed.

• To retain the selected view, click No. The view is kept in the MWTM 
database and the Confirm Deletion dialog is closed.

• To prevent MWTM from displaying the Confirm Deletion dialog, 
select the Do not show this again checkbox.

Note If you select the Do not show this again checkbox, and you later 
decide you want MWTM to begin displaying the Confirm Deletion 
dialog again, you must select the Confirm Deletions checkbox in 
the General GUI settings in the Preferences window. For more 
information, see the description of the Confirm Deletions 
checkbox in the “Startup/Exit Settings” section on page 11-6.

If you have implemented MWTM User-Based Access, this option is 
available to users with authentication level Network Administrator (Level 
4) and higher.

Back > List of Windows Navigates back to a window viewed in this session.

MWTM maintains a list of up to 10 Back windows.

Forward > List of 
Windows

Navigates forward to a window viewed in this session.

MWTM maintains a list of up to 10 Forward windows.
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  Viewing Basic Information for Views
View Table
The view table displays information about the views that have been defined for this MWTM client.

To see mouse over help popup for each column in the table, place the cursor over a column header.

If a cell is too small to show all of its data, place the cursor over the cell to see the full data in a mouse 
over help popup.

You can resize each column, or sort the table based on the information in one of the columns. By default, 
this table is sorted by Status, and MWTM displays all of the columns in the view table except Internal 
ID and Last Status Change.

• To display hidden columns, right-click in the table header and select the checkboxes for the columns 
you want to display.

• To hide columns, right-click in the table header and clear the checkboxes for the columns you want 
to hide.

See the “Resizing, Sorting, and Hiding Table Columns” section on page 3-30 for more information about 
resizing, sorting, displaying, or hiding columns.

The view table contains the following columns:

View > Components Displays the Components panel for the selected view.

If there are no components associated with the selected view, this option 
is grayed-out.

View > Configuration 
Details

Displays the Configuration Data panel for the selected view.

View > Notes Displays the Notes panel for the selected view.

If there are no notes associated with the selected view, this option is 
grayed-out.

View > Events Displays the Recent Events panel for the selected application server 
process and its associated linksets and links.

View > Center in Topo Opens the Topology Window, with the display zoomed to center on the 
selected view.

If more than one view contains the selected view, MWTM prompts you to 
choose one of the views.

View > Open in Topo Opens the selected view in the Topology Window.

Ignore Ignores the selected view at the next polling cycle.

If you have implemented MWTM User-Based Access, this option is 
available to users with authentication level Power User (Level 2) and 
higher.

Unignore Stops ignoring the selected view at the next polling cycle.

If you have implemented MWTM User-Based Access, this option is 
available to users with authentication level Power User (Level 2) and 
higher.

Menu Command Description
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  Viewing Basic Information for Views
Column Description

Internal ID Internal ID of the view. The internal ID is a unique ID for every object, 
assigned by MWTM for its own internal use. It can also be useful when the 
TAC is debugging problems.

Name Name of the view.

Subviews Number of subviews in the view.

Nodes Number of nodes in the view.

Ignored Indicates whether the view is to be included when aggregating and 
displaying MWTM status information:

• Clear the checkbox to include the view. This is the default setting.

• Select the checkbox to exclude the view.

This field can be edited by users with authentication level Power User 
(Level 2) and higher.

Notes Indicates whether there is a note associated with the view.

Events Indicates whether there is a recent event associated with a network object in 
the view. (Even if the server purges all of the events associated with objects 
in the view, MWTM continues to display the event icon in this field.)

• To delete the event icon (orange triangle) from MWTM displays for a 
specific view, select the view and click the icon.

• To delete the event icon from MWTM displays for all views, select Edit 
> Clear All Events from the MWTM Main Menu.

Note During Discovery, MWTM might flag most views with an event 
icon. If the event icons are too distracting, use the Edit > Clear All 
Events menu option to remove them.

Changing a view (for example, by ignoring it or attaching a note to 
it) does not generate an event, and therefore does not cause an event 
icon to be displayed in this field.

Deleting an application server process, node, or signaling point with 
the Delete menu option does not generate an event, and therefore 
does not cause an event icon to be displayed in this field. However, 
if MWTM rediscovers a deleted application server process, node, or 
signaling point, events are generated and logged for both the deletion 
and the rediscovery, and the event icon is then displayed in this field.

Last Status Change Date and time that the status of the view last changed.
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  Viewing Basic Information for Views
Status Current status of the view. Possible values are:

Active

Unmanaged

Warning

For detailed definitions of each status, see the “Status Definitions for Views” 
section on page A-4.

Status Reason Reason for the current status of the view.

For a full list of possible reasons, see the stateReasons.html file:

• If you installed MWTM in the default directory, /opt, then the file is 
located at /opt/CSCOsgm/apache/share/htdocs/eventHelp directory.

• If you installed MWTM in a different directory, then the help directory 
and file are located in that directory.

If the cell is too small to show all of the status reason, place the cursor over 
the cell to see the full status reason in a mouse over help popup.

The status reasons are listed in order of decreasing magnitude. If two or more 
reasons apply, the reason of greatest magnitude is displayed.

If the status reason is Unsupported Configuration, correct the 
configuration and enter the mwtm cleandiscover command to delete all 
current network data and begin a clean discovery of the RAN-O network. If 
the status reason is still Unsupported Configuration, enter the mwtm clean 
command to restore the MWTM server to a “clean” state, such as would exist 
after a new installation of MWTM. For more information on the use of these 
commands, see the “MWTM Command Reference” section on page C-1.

Column Description
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  Viewing Detailed Information for a View
Viewing Detailed Information for a View
MWTM can display detailed information about a selected view, including its associated objects, status, 
and other information.

Updates for the view that are received from the MWTM server are reflected automatically in this 
window.

To display detailed information for a view, use one of the following procedures:

• Select Views in the left pane of the MWTM Main Window, right-click a view in the right pane, then 
select View > Configuration Details in the right-click menu.

• Select the turner beside Views in the left pane of the MWTM Main Window, then select a view.

MWTM displays the View Details Window.

The View Details Window is composed of the following sections:

• View Details: Right-Click Menu, page 4-10

• View Details: Components, page 4-12

• View Details: Configuration Data, page 4-17

• View Details: Notes, page 4-19
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  Viewing Detailed Information for a View
• View Details: Recent Events, page 4-19

• View Details: Alarms, page 4-22

Related Topics:

• Viewing Basic Information for Views, page 4-4

View Details: Right-Click Menu
The View Details Window provides a right-click menu. To see this menu for a view, select a view in the 
left pane and click the right mouse button. The node details right-click menu provides the following 
options:

Menu Command Description

Show In New Window Opens the View Details Window for the selected view in a 
new window.

Edit > Properties Opens the Edit Properties Dialog for the selected view.

If you have implemented MWTM User-Based Access, this 
option is available to users with authentication level Power 
User (Level 2) and higher.

Edit > Notes Opens the Edit Notes Dialog for the selected view.

If you have implemented MWTM User-Based Access, this 
option is available to users with authentication level Power 
User (Level 2) and higher.

Clear Event Icon Deletes the event icon (orange triangle) from MWTM 
displays for the selected view, for this MWTM client only. 
The actual events are not deleted from MWTM, only the 
event icon for the selected view for this MWTM client.

This option is grayed-out if the selected view has no 
associated event icon.
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  Viewing Detailed Information for a View
Delete Deletes the currently selected view from the MWTM 
database. MWTM displays the Confirm Deletion dialog:

• To delete the selected view, click Yes. The view is 
deleted from the MWTM database and the Confirm 
Deletion dialog is closed.

• To retain the selected view, click No. The view is kept 
in the MWTM database and the Confirm Deletion 
dialog is closed.

• To prevent MWTM from displaying the Confirm 
Deletion dialog, select the Do not show this again 
checkbox.

Note If you select the Do not show this again checkbox, 
and you later decide you want MWTM to begin 
displaying the Confirm Deletion dialog again, you 
must select the Confirm Deletions checkbox in the 
General GUI settings in the Preferences window. 
For more information, see the description of the 
Confirm Deletions checkbox in the “Startup/Exit 
Settings” section on page 11-6.

If you have implemented MWTM User-Based Access, this 
option is available to users with authentication level 
Network Administrator (Level 4) and higher.

Back > List of Windows Navigates back to a window viewed in this session.

MWTM maintains a list of up to 10 Back windows.

Forward > List of Windows Navigates forward to a window viewed in this session.

MWTM maintains a list of up to 10 Forward windows.

View > Components Displays the Components panel for the selected view.

If there are no components associated with the selected 
view, this option is grayed-out.

View > Configuration Details Displays the Configuration Data panel for the selected 
view.

View > Notes Displays the Notes panel for the selected view.

If there are no notes associated with the selected view, this 
option is grayed-out.

View > Events Displays the Recent Events panel for the selected 
application server process and its associated linksets and 
links.

View > Center in Topo Opens the Topology Window, with the display zoomed to 
center on the selected view.

If more than one view contains the selected view, MWTM 
prompts you to choose one of the views.

View > Open in Topo Opens the selected view in the Topology Window.

Menu Command Description
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  Viewing Detailed Information for a View
View Details: Components
The View Details: Components section is composed of the following sub-sections:

• Subviews, page 4-12

• Nodes, page 4-14

Note If the view does not contain any objects of a given type, MWTM does not display that tab. 

Subviews

The subview table displays information about the subviews that have been defined for this MWTM 
client. 

Note Subviews are created within the View Editor window, using the Edit > Create Subview menu option 
(for details, see Creating a New View, page 4-31). 

To see mouse over help popup for each column in the table, place the cursor over a column header.

If a cell is too small to show all of its data, place the cursor over the cell to see the full data in a mouse 
over help popup.

You can resize each column, or sort the table based on the information in one of the columns. By default, 
this table is sorted by Status, and MWTM displays all of the columns in the subview table.

• To display hidden columns, right-click in the table header and select the checkboxes for the columns 
you want to display.

• To hide columns, right-click in the table header and clear the checkboxes for the columns you want 
to hide.

See the “Resizing, Sorting, and Hiding Table Columns” section on page 3-30 for more information about 
resizing, sorting, displaying, or hiding columns.

The subview table contains the following columns:

Ignore Ignores the selected view at the next polling cycle.

If you have implemented MWTM User-Based Access, this 
option is available to users with authentication level Power 
User (Level 2) and higher.

Unignore Stops ignoring the selected view at the next polling cycle.

If you have implemented MWTM User-Based Access, this 
option is available to users with authentication level Power 
User (Level 2) and higher.

Menu Command Description
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Column Description

Internal ID Internal ID of the subview. The internal ID is a unique ID for every object, 
assigned by MWTM for its own internal use. It can also be useful when the 
TAC is debugging problems.

Name Name of the subview.

Subviews Number of subviews in the subview.

Nodes Number of nodes in the subview.

Ignored Indicates whether the subview is to be included when aggregating and 
displaying MWTM status information:

• Clear the checkbox to include the subview. This is the default setting.

• Select the checkbox to exclude the subview.

This field can be edited by users with authentication level Power User 
(Level 2) and higher.

Notes Indicates whether there is a note associated with the subview.

Events Indicates whether there is a recent event associated with a network object in 
the subview. (Even if the server purges all of the events associated with 
objects in the subview, MWTM continues to display the event icon in this 
field.)

• To delete the event icon (orange triangle) from MWTM displays for a 
specific subview, select the subview and click the icon.

• To delete the event icon from MWTM displays for all subviews, select 
Edit > Clear All Events from the MWTM Main Menu.

Note During Discovery, MWTM might flag most subviews with an event 
icon. If the event icons are too distracting, use the Edit > Clear All 
Events menu option to remove them.

Changing a subview (for example, by ignoring it or attaching a note 
to it) does not generate an event, and therefore does not cause an 
event icon to be displayed in this field.

Deleting an application server process, node, or signaling point with 
the Delete menu option does not generate an event, and therefore 
does not cause an event icon to be displayed in this field. However, 
if MWTM rediscovers a deleted application server process, node, or 
signaling point, events are generated and logged for both the deletion 
and the rediscovery, and the event icon is then displayed in this field.

Last Status Change Date and time that the status of the subview last changed.
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Nodes

The node table displays information about the nodes that are associated with the selected view.

To see mouse over help popup for each column in the table, place the cursor over a column header.

If a cell is too small to show all of its data, place the cursor over the cell to see the full data in a mouse 
over help popup.

You can resize each column, or sort the table based on the information in one of the columns. By default, 
this table is sorted by Status, and MWTM displays all of the columns in the node table except Internal 
ID, Router Uptime, Reboot Reason, and Last Status Change.

• To display hidden columns, right-click in the table header and select the checkboxes for the columns 
you want to display.

• To hide columns, right-click in the table header and clear the checkboxes for the columns you want 
to hide.

See the “Resizing, Sorting, and Hiding Table Columns” section on page 3-30 for more information about 
resizing, sorting, displaying, or hiding columns.

The node table contains the following columns:

Status Current status of the subview. Possible values are:

Active

Unmanaged

Warning

For detailed definitions of each status, see the “Status Definitions for Views” 
section on page A-4.

Status Reason Reason for the current status of the subview.

For a full list of possible reasons, see the stateReasons.html file:

• If you installed MWTM in the default directory, /opt, then the file is 
located at /opt/CSCOsgm/apache/share/htdocs/eventHelp directory.

• If you installed MWTM in a different directory, then the help directory 
and file are located in that directory.

If the cell is too small to show all of the status reason, place the cursor over 
the cell to see the full status reason in a mouse over help popup.

The status reasons are listed in order of decreasing magnitude. If two or more 
reasons apply, the reason of greatest magnitude is displayed.

If the status reason is Unsupported Configuration, correct the 
configuration and enter the mwtm cleandiscover command to delete all 
current network data and begin a clean discovery of the RAN-O network. If 
the status reason is still Unsupported Configuration, enter the mwtm clean 
command to restore the MWTM server to a “clean” state, such as would exist 
after a new installation of MWTM. For more information on the use of these 
commands, see the “MWTM Command Reference” section on page C-1.

Column Description
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Column Description

Internal ID Internal ID of the node. The internal ID is a unique ID for every object, 
assigned by MWTM for its own internal use. It can also be useful when the 
TAC is debugging problems.

Name Name of the node.

Primary SNMP 
Address

IP address of the node, used by SNMP to poll the node. (There might be other 
IP addresses on the node that are not the primary SNMP address.)

Device Type Device type of the node. Possible values are:

• CiscoMWR-1941-DC-A—Cisco MWR-1941-DC-A series router

• RNC—Radio Network Controller

• BSC—Base Station Controller

• BTS—Base Transceiver Station

• Node B—The radio transmission/reception unit for communication 
between radio cells

• IPDevice—IP device, other than those listed above. You can assign this 
icon to an unknown node if you know that it is an IP device.

• Unknown—MWTM is unable to determine the device type.

IOS MIB Level MIB conformance level used by the RAN-O device, such as GSM RAN.

Router Uptime Time the router has been up, in days, hours, minutes, and seconds.

Reboot Reason Reason for the last reboot of the router device.

Ignored Indicates whether the node is to be included when aggregating and 
displaying MWTM status information:

• Clear the checkbox to include the node. This is the default setting.

• Select the checkbox to exclude the node.

This field can be edited by users with authentication level Power User 
(Level 2) and higher.

Process Traps Indicates whether MWTM is to process traps from this node:

• Select the checkbox if you want MWTM to process traps from this node. 
This is the default setting.

• Clear the checkbox if you do not want MWTM to process traps from this 
node.

This field can be edited by users with authentication level Power User 
(Level 4) and higher.

Notes Indicates whether there is a note associated with the node.
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Events Indicates whether there is a recent event associated with the node. (Even if 
the server purges all of the events associated with the node, MWTM 
continues to display the event icon in this field.)

• To delete the event icon (orange triangle) from MWTM displays for a 
specific node, select the node and click the icon.

• To delete the event icon from MWTM displays for all nodes, select Edit 
> Clear All Events from the MWTM Main Menu.

Note During Discovery, MWTM might flag most nodes with an event 
icon. If the event icons are too distracting, use the Edit > Clear All 
Events menu option to remove them.

Last Status Change Date and time that the status of the node last changed.

Status Current status of the node. Possible values are:

Active

Discovering

Polling

Unknown

Unmanaged

Waiting

Warning

For detailed definitions of each status, see the “Status Definitions for Nodes” 
section on page A-4.

Status Reason Reason for the current status of the node.

For a full list of possible reasons, see the stateReasons.html file:

• If you installed MWTM in the default directory, /opt, then the file is 
located at /opt/CSCOsgm/apache/share/htdocs/eventHelp directory.

• If you installed MWTM in a different directory, then the help directory 
and file are located in that directory.

If the cell is too small to show all of the status reason, place the cursor over 
the cell to see the full status reason in a mouse over help popup.

The status reasons are listed in order of decreasing magnitude. If two or more 
reasons apply, the reason of greatest magnitude is displayed.

If the status reason is Unsupported Configuration, correct the 
configuration and enter the mwtm cleandiscover command to delete all 
current network data and begin a clean discovery of the RAN-O network. If 
the status reason is still Unsupported Configuration, enter the mwtm clean 
command to restore the MWTM server to a “clean” state, such as would exist 
after a new installation of MWTM. For more information on the use of these 
commands, see the “MWTM Command Reference” section on page C-1.

Column Description
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View Details: Configuration Data
The View Details: Configuration Data section is composed of the following sub-sections:

• Naming Information, page 4-17

• Status Information, page 4-17

Naming Information

The Naming Information sub-section contains the following fields:

Status Information

The Status Information table provides basic summary information about network objects in this view 
that have been discovered by MWTM.

Field Description

Name Name of the view.

Is Ignored Indicates whether the view is Ignored (that is, whether the view is to be included 
when aggregating and displaying MWTM status information).

Last Status 
Change

Date and time that the status of the view last changed.

Status Current status of the view. Possible values are:

Active

Unmanaged

Warning

For detailed definitions of each status, see the “Status Definitions for Views” 
section on page A-4.

Status Reason Reason for the current status of the view.

For a full list of possible reasons, see the stateReasons.html file:

• If you installed MWTM in the default directory, /opt, then the file is located at 
/opt/CSCOsgm/apache/share/htdocs/eventHelp directory.

• If you installed MWTM in a different directory, then the help directory and file 
are located in that directory.

If the cell is too small to show all of the status reason, place the cursor over the cell 
to see the full status reason in a mouse over help popup.

The status reasons are listed in order of decreasing magnitude. If two or more 
reasons apply, the reason of greatest magnitude is displayed.

If the status reason is Unsupported Configuration, correct the configuration and 
enter the mwtm cleandiscover command to delete all current network data and 
begin a clean discovery of the RAN-O network. If the status reason is still 
Unsupported Configuration, enter the mwtm clean command to restore the 
MWTM server to a “clean” state, such as would exist after a new installation of 
MWTM. For more information on the use of these commands, see the “MWTM 
Command Reference” section on page C-1.
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To see mouse over help popup for each column in the table, place the cursor over a column header.

If a cell is too small to show all of its data, place the cursor over the cell to see the full data in a mouse 
over help popup.

You can resize each column, or sort the table based on the information in one of the columns. By default, 
this table is sorted by Status, and MWTM displays all of the columns in the Status Information table 
except Linksets and Links.

• To display hidden columns, right-click in the table header and select the checkboxes for the columns 
you want to display.

• To hide columns, right-click in the table header and clear the checkboxes for the columns you want 
to hide.

See the “Resizing, Sorting, and Hiding Table Columns” section on page 3-30 for more information about 
resizing, sorting, displaying, or hiding columns.

The Status Information table contains the following columns:

Column Description

Status Current status of the network objects. Possible values are:

Unknown

Unavailable

Inactive

Failed

Down

Blocked

Pending

Warning

Shutdown

InhibitLoc

InhibitRem

Discovering

Polling

Waiting

Unmanaged

Active

For detailed definitions of each status for each type of network object, see 
the “MWTM Status Definitions” section on page A-1.

Total Total number of discovered objects with the indicated status.

Nodes Total number of discovered nodes with the indicated status.
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View Details: Notes
The View Details: Notes section displays:

• Notes associated with the view.

• The date and time the notes associated with the view were last updated, or the phrase Not Set if there 
are no notes associated with the view.

• The phrase No Notes if there are no notes associated with the view.

Related Topics:

• Attaching a Note to a View, page 4-27

• Viewing Notes for a View, page 4-30

View Details: Recent Events
The View Details: Recent Events table displays about all recent events associated with the view, and 
enables you to perform event-related tasks, such as setting filters and acknowledging events.

To see mouse over help popup for each column in the table, place the cursor over a column header.

If a cell is too small to show all of its data, place the cursor over the cell to see the full data in a mouse 
over help popup.

You can resize each column, or sort the table based on the information in one of the columns. By default, 
MWTM displays all of the columns in the table except Internal ID, Note, Message Name, Ack By, Ack 
Time, and Node.

• To display hidden columns, right-click in the table header and select the checkboxes for the columns 
you want to display.

• To hide columns, right-click in the table header and clear the checkboxes for the columns you want 
to hide.

See the “Resizing, Sorting, and Hiding Table Columns” section on page 3-30 for more information about 
resizing, sorting, displaying, or hiding columns.

The View Details: Recent Events table contains the following toolbar buttons and columns:

Toolbar Button or Column Description

Set Filter Opens the Event Filter dialog.

Apply Filter

or

Remove Filter

Activates and deactivates the event filter specified in the Event Filter 
dialog:

• If the filter is activated, MWTM displays only those events that pass 
the filter.

• If the filter is deactivated, MWTM displays all events.

• If you activate a filter in an object’s Recent Events table in the 
MWTM Main Window, the filter is activated in all Recent Events 
tables in the MWTM Main Window for all other objects. The filter 
is not activated in Recent Events tables in Show In New Window 
windows or Real-Time Data and Charts windows.
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Pause

or

Resume

Pauses or resumes the table.

While the table is paused, MWTM does not display new events in the 
table (unless you apply an event filter or edit your event preferences). 
When the table is resumed, all new events since the table was paused are 
added to the display.

If events are deleted while the table is paused, they are not removed from 
the table. Instead, they are grayed-out and cannot be acknowledged or 
edited. Deleted events are removed from the table when you resume the 
table.

Acknowledge Makes the selected event or events acknowledged.

Unacknowledge Makes the selected event or events unacknowledged.

Event Properties Opens the Event Properties window.

Edit Notes Opens the Edit Event Dialog.

Time Difference Displays the difference in days, minutes, hours, and seconds between 
two events.

Find Finds specific text in the event table.

Create Sound Filter Opens the Event Sound Filters dialog and the Event Sound Filters List 
dialog, with fields populated based on the selected event.

Adjust Row Height Adjusts the table row height and wraps the message text as follows:

• Click once to double the row height and wrap the message text.

• Click again to triple the row height and wrap the message text.

• Click again for single row height and no message text wrapping. 
This is the default setting.

This setting is saved automatically with your preferences.

Help for Event Displays context-sensitive help for the selected event in a separate Web 
browser.

Internal ID Internal ID of the event. The internal ID is a unique ID for every object, 
assigned by MWTM for its own internal use. It can also be useful when 
the TAC is debugging problems.

Ack Indicates whether the event has been acknowledged:

• To acknowledge an unacknowledged event, use the Acknowledge 
toolbar button.

• To make a previously acknowledged event unacknowledged, use the 
Unacknowledge toolbar button.

Toolbar Button or Column Description
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Category Type of the event. Default values are:

• Create—Creation event, such as the creation of a seed file.

• Delete—Deletion event, such as the deletion of an object or file.

• Discover—Discovery event, such as Discovery beginning.

• Edit—Edit event. A user has edited an object.

• Ignore—Ignore event. A user has Ignored a link or linkset.

• Login—Login event. A user has logged in to MWTM.

• LoginDisable—LoginDisable event. MWTM has disabled a user’s 
User-Based Access authentication as a result of too many failed 
attempts to log in to MWTM.

• LoginFail—LoginFail event. An attempt by a user to log in to 
MWTM has failed.

• Logout—Logout event. A user has logged out of MWTM.

• OverWrite—OverWrite event. An existing file, such as a seed file 
or route file, has been overwritten.

• Poll—Poll event, such as an SNMP poll.

• Purge—Purge event. A user has requested Discovery with Delete 
Existing Data selected, and MWTM has deleted the existing 
MWTM database.

• Status—Status change message generated.

• Trap—SNMP trap message generated.

You can customize this field. See the “Changing Event Categories” 
section on page 5-23 for more information.

Severity Severity of the event. Default values are:

• Critical—The default color is red.

• Indeterminate—The default color is aqua.

• Informational—The default color is white.

• Major—The default color is orange.

• Minor—The default color is yellow.

• Normal—The default color is green.

• Warning—The default color is blue.

You can customize this field. See the “Changing Event Severities and 
Colors” section on page 5-24 for more information.

Note Indicates whether there is a note associated with the event.

Time Date and time the event was logged.

Message Name User-specified message name for the event, used by MWTM for trap 
forwarding. The default message name is MWTM.

For more information about user-specified message names and trap 
forwarding, see the “Forwarding Events as Traps to Other Hosts” section 
on page 5-35.

Toolbar Button or Column Description
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View Details: Alarms
The View Details: Alarms table provides basic information about all currently active alarms in your 
network, that are not excluded from your current view. MWTM updates the information in the window 
at least once every minute.

To see mouse over help popup for each column in the table, place the cursor over a column header.

If a cell is too small to show all of its data, place the cursor over the cell to see the full data in a mouse 
over help popup.

You can resize each column, or sort the table based on the information in one of the columns. By default, 
this table is sorted by Age, with the most recent alarms at the top, and MWTM displays all of the columns 
in the table except Last Status Change.

• To display hidden columns, right-click in the table header and select the checkboxes for the columns 
you want to display.

• To hide columns, right-click in the table header and clear the checkboxes for the columns you want 
to hide.

See the “Resizing, Sorting, and Hiding Table Columns” section on page 3-30 for more information about 
resizing, sorting, displaying, or hiding columns.

The active alarms table contains the following columns:

Ack By If you have not implemented MWTM User-Based Access, name of the 
device that last acknowledged the event.

If you have implemented MWTM User-Based Access, name of the user 
who last acknowledged the event.

If no one has acknowledged the event, this field is blank.

Ack Time Date and time the event was last acknowledged or unacknowledged.

Node Name of the node associated with the event. If there is no node 
associated with the event, None is displayed.

Message Text of the message.

You can customize this field. See the “Changing the Way MWTM 
Processes Events” section on page 5-17 for more information.

Toolbar Button or Column Description

Column Description

Type Type of network object associated with the selected alarm.

To see all higher-level alarms associated with the network object, select the 
turner beside the object. MWTM displays the higher-level alarms below the 
selected alarm. For example, if you select the turner beside a link, MWTM 
displays the alarms for the linkset, signaling point, and node associated with 
that link.

Name Name of the network object associated with the selected alarm.
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Status Current status of the network object associated with the selected alarm. 
Possible values are:

Unknown

Unavailable

Inactive

Failed

Down

Blocked

Pending

Warning

Shutdown

InhibitLoc

InhibitRem

Discovering

Polling

Waiting

Unmanaged

Active

For detailed definitions of each status for each type of network object, see 
the “MWTM Status Definitions” section on page A-1.

Status Reason Reason for the current status of the network object associated with the 
selected alarm.

For a full list of possible reasons, see the stateReasons.html file:

• If you installed MWTM in the default directory, /opt, then the file is 
located at /opt/CSCOsgm/apache/share/htdocs/eventHelp directory.

• If you installed MWTM in a different directory, then the help directory 
and file are located in that directory.

If the cell is too small to show all of the status reason, place the cursor over 
the cell to see the full status reason in a mouse over help popup.

The status reasons are listed in order of decreasing magnitude. If two or more 
reasons apply, the reason of greatest magnitude is displayed.

If the status reason is Unsupported Configuration, correct the 
configuration and enter the mwtm cleandiscover command to delete all 
current network data and begin a clean discovery of the RAN-O network. If 
the status reason is still Unsupported Configuration, enter the mwtm clean 
command to restore the MWTM server to a “clean” state, such as would exist 
after a new installation of MWTM. For more information on the use of these 
commands, see the “MWTM Command Reference” section on page C-1.

Column Description
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Last Status Change Date and time that the status of the network object associated with the 
selected alarm last changed.

Age Age of the selected alarm, in days, hours, and minutes.

Column Description
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The active alarms table provides a subset of the MWTM Main Menu as a right-click menu. To see this 
menu, select an alarm and click the right mouse button. The alarm right-click menu provides the same 
options as the right-click menu for the associated network object, plus the following additional options:

Caution The alarms displayed in the active alarms table are the actual network objects in MWTM. Options you 
select in the right-click menu affect the object in MWTM. For example, if you delete a node in the active 
alarms table, you delete that node from the MWTM database.

Editing a View
MWTM enables you to edit the following aspects of a view:

• Editing View Properties, page 4-25

• Attaching a Note to a View, page 4-27

Editing View Properties
MWTM enables you to change the name and icon name associated with a view.

To edit a view’s properties, right-click the view in a window, then select Edit > Properties in the 
right-click menu. MWTM displays the Edit Properties Dialog for a View.

The Edit Properties Dialog contains the following fields and buttons:

Menu Command Description

Expand All Displays all higher-level alarms associated with all network objects in the active 
alarms table.

Collapse All Does not display higher-level alarms in the active alarms table.
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Field or Button Description

Name Name of the view.

You can also use this field to specify a new, more meaningful name for the view. 
The new name can be from 1 to 30 characters, and can contain any letters, 
numbers, or special characters.

When you click Save, all MWTM windows are updated automatically to reflect 
the new name.

Icon Name Name of the graphic icon to assign to this view in topology maps. MWTM 
automatically assigns an appropriate icon to each discovered Cisco device, and 
to Unknown nodes, but you can use this field to assign a different icon.

Valid values for RAN-O networks include:

• BSC—Base Station Controller

• BTS—Base Transceiver Station

• Building—Icon representing a collection of objects within a building

• CiscoMWR1900—Cisco Mobile Wireless Router 1900

Icon Name
(continued)

• City—Icon representing a collection of objects within a city

• Cloud—Collection of objects, called a submap. A submap can also contain 
other submaps.

• Database—Icon representing a database object

• IPDevice—IP device, other than those listed above

• MSC—Mobile switching center

• Node-B—Radio transmission/reception unit for communication between 
radio cells in UMTS network

• RNC—Radio Network Controller used in UMTS network

• Tower—Icon representing a PC tower

• TrafficGenerator—Icon representing a device or emulator used to generate 
traffic, usually in a test environment

• Unknown—MWTM is unable to determine the node or signaling point type.

• Workstation—Icon representing a workstation

• Workstation2—Icon representing a different workstation

When you click Save, the Topology Window is updated automatically to reflect 
the new icon.

Save Saves changes you have made to the view information, updates all MWTM 
windows to reflect your changes, and exits the dialog.

Restore Restores changes you have made to the Name and Icon Name fields of the Edit 
Properties Dialog, and leaves the dialog open.

Cancel Exits the dialog without saving any changes.

Help Displays online help for the dialog.
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Related Topics:

• Editing a View, page 4-25

• Viewing Notes for a View, page 4-30

Attaching a Note to a View
MWTM enables you to annotate a view, attaching a descriptive string to it.

To attach a note to a view, right-click the view in a window, then select Edit > Notes in the right-click 
menu. MWTM displays the Edit Notes Dialog for a View.

If you add notes to the DEFAULT view, you are prompted to save the view under a different name, since 
customization to the DEFAULT view is not allowed (for more details on saving views, see Saving a View, 
page 4-27.)

The Edit Notes Dialog for a View contains the following fields and buttons:

Related Topics:

• Viewing Basic Information for Views, page 4-4

• Viewing Detailed Information for a View, page 4-9

• Viewing Notes for a View, page 4-30

Saving a View
MWTM enables you to save a specific view, change the list of views, and select one view to be loaded 
automatically when the associated preferences file is saved.

When you are satisfied with the changes you have made to a view, use one of the following procedures 
to save the view:

• To save the changes you have made to the view without changing the name of the file, select File > 
Save from the View Editor Window menu.

Field or Button Description

Name Name of the view. You cannot edit this field.

Note Last Updated Date and time the Notes field for this view was last updated. If there is no note 
currently associated with this view, this field displays the value Not Set.

You cannot edit this field.

Notes Notes to associate with this view. In this field, you can enter any important 
information about the view, such as a detailed description, its history, and so on.

Save Saves changes you have made to the view’s notes, updates all MWTM windows 
to reflect your changes, and exits the dialog.

When you annotate a view, the topology map in the Topology Window displays 
a note icon in the upper left corner of the view element.

Cancel Exits the dialog without saving any changes.

Help Displays online help for the dialog.
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Note You cannot save changes to the DEFAULT view. If you are currently using the DEFAULT view 
and you select File > Save, MWTM displays the Save File Dialog: View List dialog .

• To save the changes you have made to the view with a new name, select File > Save As from the 
Discovery Dialog menu. MWTM displays the Save File Dialog: View List dialog .
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MWTM stores the view in the view file directory on the MWTM server:

• If you installed MWTM in the default directory, /opt, then the MWTM view file directory is 
/opt/CSCOsgm/views.

• If you installed MWTM in a different directory, then the MWTM view file directory is located in 
that directory.

Note If another user modifies and saves the view before you save your changes, MWTM asks if you want to 
overwrite that user’s changes. If you choose to do so, the other user’s changes are overwritten and lost. 
If you choose not to do so, your changes are lost, unless you save the view to a different filename.

The Save File Dialog: View List contains the following fields and buttons:

Field or Button Description

Type Icon indicating whether the item in the table is a file or a 
folder.

Name Name of the view file or folder.

Last Modified Date and time the view file or folder was last modified.

Size (bytes) Size of the view file or folder, in bytes.

Filename Name by which you want to save the view. You must specify 
a name other than DEFAULT. You cannot save changes to the 
DEFAULT view.

When you create a new view file name, you can use any 
letters, numbers, or characters in the name that are allowed by 
your operating system. However, if you include any spaces in 
the new name, MWTM converts those spaces to dashes. For 
example, MWTM saves file “a b c” as “a-b-c”.

Make this my preferred startup 
option

Specifies whether the selected view is to be loaded 
automatically whenever the associated preferences file is 
loaded:

• To load the saved view, select the view, then select this 
checkbox.

• To load the last-used view, clear the checkbox. This is the 
default setting.

Number of Files
(displayed in bottom left corner)

Total number of view files and folders.
4-29
Cisco Mobile Wireless Transport Manager User Guide 5.0

OL-7637-02



 

Chapter 4      Working with Views
  Viewing Notes for a View
Related Topics:

• Working with Views, page 4-1

Viewing Notes for a View
MWTM enables you to view any notes that have been associated with a view.

To view a note for a view, right-click a view in a window, then select View > Notes in the right-click 
menu. (The Notes option is grayed-out if there is no note associated with the selected view.)

MWTM displays the Notes panel for the selected view, which displays:

• Notes associated with the view.

• The date and time the notes associated with the view were last updated, or the phrase Not Set if there 
are no notes associated with the view.

• The phrase No Notes if there are no notes associated with the view.

Related Topics:

• Editing a View, page 4-25

OK Saves any changes you made to the current named view or to 
the list of views and closes the dialog.

To save the view with a new name, use one of the following 
procedures:

• To save the file with a completely new name, enter the 
new name and click OK.

• To save the file with an existing name, overwriting an old 
view, select the name in the list and click OK.

MWTM saves the view with the new name, closes the Save 
File Dialog: View List dialog, and returns to the Discovery 
Dialog.

To save any changes you made to the list of files, click OK. 
MWTM saves the changes and closes the Load File Dialog: 
View List dialog.

Delete Deletes the selected file from the view list. MWTM issues an 
informational message containing the name and location of 
the deleted file.

Cancel Closes the dialog without saving the view or any changes to 
the view list.

Help Displays online help for the dialog.

Field or Button Description
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Creating a New View
MWTM enables you to specify the nodes you want to see in MWTM displays. This is called a 
client-specific network view. All changes you make are reflected in topology tables and maps as soon as 
you make the changes.

Before creating a client-specific network view, make sure that Discovery has been run at least once, and 
there is data in the server’s MWTM database. See the “Discovery Overview” section on page 2-1 for 
details.

To create a client-specific network view, select Edit > Views from the MWTM Main Menu. MWTM 
displays the View Editor Window.

The View Editor Window displays two tabs, Edit View and Import Views:

• The Edit View tab provides the following information:

– All objects that are in the current view.

– All objects that have been excluded from the current view.

– New objects that have been found by MWTM.

• The Import Views tab provides the following information:

– All views currently defined on this MWTM client.

– Data about the views.

The View Editor Window also enables you to move objects into and out of the current view. All changes 
made in this window are reflected in the MWTM client and in the topology tables and maps as soon as 
you make the changes.

The View Editor Window is composed of the following sections:

• View Editor Window Menu, page 4-32

• Objects In Current View (Left Pane), page 4-33

• Excluded from View Panel, page 4-35

• New on the Network Panel, page 4-36

• Views List Panel, page 4-37

• View Data Panel, page 4-39

• Directory Listing Panel, page 4-39

• Closing the View Editor Window, page 4-39

Related Topics:

• Changing the Message Display, page 11-27

• Changing MWTM Client Preference Settings, page 11-2

• Viewing the Topology of the Network, page 8-1
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View Editor Window Menu
The menu on the View Editor Window provides the following options:

Menu Command Description

File > Load 
DEFAULT View

Loads the DEFAULT view, which is the view into which MWTM places all 
discovered objects when discovering the network. The DEFAULT view is stored 
on the MWTM server and shared by all MWTM clients, but it cannot be modified 
by the clients.

File > Load
(Ctrl-L)

Loads an already existing view.

If you have already saved a view and you want to change it, select the File > Load 
menu option. MWTM prompts you for the name of the view you want to load:

• Select the name of the view, or accept the default view name, then click OK 
to load the view.

• Click Cancel to close the prompt window without loading a view.

File > Save
(Ctrl-S)

Saves the current view:

• If you have not already saved the current view, opens the Save File Dialog: 
View List, which enables you to enter or select a file name under which to 
save the current view.

• If you have already saved the current view, saves the view to that file name.

If you have implemented MWTM User-Based Access, this option is available to 
users with authentication level Power User (Level 2) and higher.

File > Save As Opens the Save File Dialog: View List, which enables you to save changes you 
have made to the selected view with a new name, or overwrite an existing seed 
file. The view is updated immediately in the MWTM client.

If you have implemented MWTM User-Based Access, this option is available to 
users with authentication level Power User (Level 2) and higher.

File > Close
(Ctrl-W)

Closes the View Editor Window.

If you have modified the view, MWTM asks if you want to save your changes.

• Click Yes to save your changes to the current view.

• Click No to keep the current view as-is, without applying any changes. 
MWTM closes the View Editor Window.

• Click Cancel to close the prompt window and return to the View Editor 
Window without applying any changes to the current view.

Edit > 
Create Subview
(Ctrl-N)

Creates a new subview for the selected view or subview. Enter a name for the new 
subview.

Edit > Rename 
View
(Ctrl-R)

Enables you to rename the selected view. The new name can be from 1 to 30 
characters, and can contain any letters, numbers, or special characters.

Edit > Include In 
View
(Ctrl-I)

Enables you to include the selected object in the view.
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Objects In Current View (Left Pane)
The left pane of the View Editor Window lists the nodes that are in the current view.

To see the objects that are associated with a node, and that are in the current view, select the turner beside 
the node.

To exclude any of these objects from the current view, select them in the left pane, then select Edit > 
Exclude From View to move them to the Excluded From View panel of the View Editor Window.

Note If you are using an MWTM client with the DEFAULT view set, MWTM automatically adds all newly 
discovered objects to the left pane as soon as they are discovered.

If you delete an object, MWTM removes it from the left pane. If MWTM then discovers the object, 
MWTM places it in the New on the Network panel. To see this object again in your current view, you 
must move it into the left panel using Edit > Include In View from the View Editor Window.

The left pane of the View Editor Window provides the following right-click menus:

• Objects in Current View Right-Click Menu for a View, page 4-33

• Objects in Current View Right-Click Menu for a Subview, page 4-34

• Objects in Current View Right-Click Menu for an Object, page 4-35

Objects in Current View Right-Click Menu for a View

The right-click menu for a view in the left pane of the View Editor Window provides the following 
options:

Edit > Exclude 
From View
(Alt-X)

Enables you to exclude the selected object from the view.

Edit > Delete View
(Ctrl-D)

Deletes the selected view.

Edit > Cut
(Alt-X)

Cuts the selected object from the view.

Edit > Copy
(Alt-C)

Copies the selected object or view.

Edit > Paste
(Alt-V)

Pastes a cut or copied object or view into the selected view.

Help > Topics
(F1)

Displays the table of contents for the MWTM online help.

Help > Window
(Shift-F1)

Displays online help for the current window.

Help > About
(F3)

Displays build date, version, SSL support, and copyright information about the 
MWTM application.

Menu Command Description
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Objects in Current View Right-Click Menu for a Subview

The right-click menu for a subview in the left pane of the View Editor Window provides the following 
options:

Menu Command Description

Create Subview Creates a new subview for the selected view. Enter a name for the new subview.

Rename View Enables you to rename the selected view. The new name can be from 1 to 30 
characters, and can contain any letters, numbers, or special characters.

Copy Copies the selected view.

Paste Pastes a cut or copied object or view into the selected view.

Menu Command Description

Create Subview Creates a new subview for the selected subview. Enter a name for the new 
subview.

Rename View Enables you to rename the selected subview. The new name can be from 1 to 30 
characters, and can contain any letters, numbers, or special characters.

Delete From View Deletes the selected subview from the view or subview.

Export View Opens the Save File Dialog: View List dialog , which enables you to save the 
subview as a unique view.

Copy Copies the selected subview.

Paste Pastes a cut or copied object or view into the selected subview.
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Objects in Current View Right-Click Menu for an Object

The right-click menu for an object in the left pane of the View Editor Window provides the following 
options:

Excluded from View Panel
The Excluded from View panel lists the objects that have been excluded from the current view. To add 
these objects to the current view, select them in the Excluded from View panel, then select Edit > 
Include In View to move them to the left pane of the View Editor Window.

The Excluded from View panel provides the following right-click options for an object:

Menu Command Description

Exclude From View Excludes the selected object, and any lower-level associated objects, from the 
view or subview.

Cut Cuts the selected object from the view or subview.

Copy Copies the selected object.

Menu Command Description

Include In View Includes the selected object, and any lower-level associated objects, in the 
selected view or subview.

Copy Copies the selected object.
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New on the Network Panel
The New on the Network panel displays newly discovered objects, based on the following criteria:

• If you are using an MWTM client with the DEFAULT view set, this table never contains any objects. 
In the DEFAULT view, MWTM adds all newly discovered objects to the left pane of the View Editor 
Window as soon as they are discovered.

• If you are using an MWTM client with a custom view set, this table contains all objects discovered 
since the View Editor Window was opened in this session, that have not been excluded in the 
Excluded from View panel, or that are not in the current view.

When MWTM discovers one or more new objects in the network, MWTM also takes the following 
actions:

• MWTM broadcasts the discovery of the new objects to all MWTM clients.

• MWTM displays a “New!” icon in the bottom of most MWTM windows. Clicking the “New!” icon 
in the Topology Window opens the New Objects panel in the left pane. Clicking the “New!” icon in 
any other window opens the Edit View tab of the View Editor Window.

• MWTM adds graphical elements for the newly discovered objects to the New Objects panel in the 
left pane of the Topology Window. For more information, see the “Displaying the Topology New 
Objects Panel” section on page 8-17.

To add a newly discovered object to the current view, select one or more objects in the New on the 
Network panel, then select Edit > Include In View to move them to the left pane of the View Editor 
Window.

To exclude a newly discovered object from the current view, select one or more objects in the New on 
the Network panel, then select Edit > Exclude From View to move them to the Excluded From View 
panel of the View Editor Window.
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The New on the Network panel provides the following right-click options for an object:

Views List Panel
The Views List panel is found under the Import Views tab of the View Editor window. The Views List 
panel lists all views that are currently defined on this MWTM client. Note that if you have no views 
defined, this list will be empty.

To see mouse over help popup for each column in the Views List panel, place the cursor over a column 
header.

If a cell is too small to show all of its data, place the cursor over the cell to see the full data in a mouse 
over help popup.

You can resize each column, or sort the table based on the information in one of the columns. By default, 
this table is sorted by Name, and MWTM displays all of the columns in the Views List panel.

• To hide columns, right-click in the table header and clear the checkboxes for the columns you want 
to hide.

• To display hidden columns, right-click in the table header and select the checkboxes for the columns 
you want to display.

See the “Resizing, Sorting, and Hiding Table Columns” section on page 3-30 for more information about 
resizing, sorting, displaying, or hiding columns.

Menu Command Description

Include In View Includes the selected object, and any lower-level associated objects, in the 
selected view or subview.

Exclude From View Excludes the selected object, and any lower-level associated objects, from the 
view or subview.

Copy Copies the selected object.
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The Views List panel contains the following columns:

The Views List panel provides the following right-click menu option for views:

The Views List panel provides the following right-click menu option for folders:

Column Description

Type Indicates whether the selected name is a directory or a file.

Name Name of the view.

Last Modified Date and time the view was last modified.

Size (bytes) Size of the view in bytes.

Menu Command Description

Import View Copies the selected view into the view or subview that is currently selected in the 
left pane of the View Editor Window.

Delete View Deletes the selected folder, view, or subview. (You can delete a folder only if it 
contains no views or subviews.)

Menu Command Description

Open View Opens the selected folder, displaying views contained in the folder in the Views 
List panel.
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View Data Panel
The View Data panel lists all subviews and objects that are in the view that is selected in the Views List 
panel. If you have not saved a view yet, and there are no views in the Views List panel, this panel does 
not appear.

The View Data panel provides the following right-click menu option for views and subviews:

Directory Listing Panel
The Directory Listing panel lists all subfolders that are in the folder that is selected in the Views List 
panel. If there are no views in the Views List panel, or if a folder (not a file) exists in the Views List 
panel, the Directory Listing panel is displayed. If there are only files in the Views List panel, the 
Directory Listing panel does not appear.

To see the Directory Listing panel, select a folder in the Views List panel.

Closing the View Editor Window
To close the View Editor Window at any time, click File > Close. If you have modified the view, MWTM 
asks if you want to apply the changes before leaving the window:

• Click Yes to apply the changes to the current view. MWTM applies the changes to all MWTM 
windows immediately. MWTM then asks if you want to make this the default view:

– Click Yes to make this view the new default view. In the future, when this client is started, this 
will be the default view.

– Click No to retain your old default view.

MWTM closes the View Editor Window.

• Click No to keep the current view as-is, without applying any changes. MWTM closes the View 
Editor Window.

• Click Cancel to close the prompt window and return to the View Editor Window without applying 
any changes to the current view.

If you are working in a custom view (that is, not in the DEFAULT view) and you exit the MWTM client, 
MWTM automatically saves any changes you made to the view.

Loading the DEFAULT View
To load the DEFAULT network view, select File > Load DEFAULT View from the MWTM Main Menu. 
You may be prompted to save the view you are currently in. Once you have chosen whether or not to save 
your current view, MWTM loads the DEFAULT view. 

Menu Command Description

Import View Copies the selected view or subview into the view or subview that is currently 
selected in the left pane of the View Editor Window.
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Note Any custom views are saved in the View Editor window (Import Views tab) found under the Edit > 
Views option in the MWTM Main window.

Loading a Client-Specific View
MWTM enables you to load a specific view, change the list of views, and select one view to be loaded 
automatically when the associated preferences file is loaded.

To load a client-specific network view, select Edit > Views from the MWTM Main Menu. MWTM 
displays the View Editor Window. Then select File > Load from the View Editor Window menu. MWTM 
displays the Load File Dialog: View List dialog .

The Load File Dialog: View List contains the following fields and buttons:

Field or Button Description

Type Icon indicating whether the item in the table is a file or a folder.

Name Name of the view file or folder.

Last Modified Date and time the view file or folder was last modified.

Size (bytes) Size of the view file or folder, in bytes.

Make this my preferred start 
option

Specifies whether the selected view is to be loaded automatically 
whenever the associated preferences file is loaded:

• To load the selected view, select the view, then select this 
checkbox.

• To load the last-used view, clear the checkbox. This is the 
default setting.

Number of Files
(displayed in bottom left corner)

Total number of view files and folders.

OK Loads the selected view, saves any changes you made to the list 
of views, closes the dialog, and returns to the View Editor 
Window.

To load a view, double-click it in the list, select it in the list and 
click OK, or enter the name of the view and click OK. 

Note If the network elements belonging to a client-specific 
view have been removed from the network, a message 
displays when you load the view. The message warns you 
that the network elements have been removed from the 
view. To prevent the warning from being issued the next 
time you load the view, save the view using the same name 
(File > Save from the View Editor Window).

Delete Deletes the selected file from the view list. MWTM issues an 
informational message containing the name and location of the 
deleted file.
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Related Topics:

• Working with Views, page 4-1

Ignoring a View
You can instruct MWTM to ignore a view when it aggregates and displays network data. Setting views 
to Ignored prevents known problems in the views from affecting MWTM displays for associated objects. 
In effect, you are preventing a known problem from distracting you from other, more urgent network 
problems.

For example, you can set a view to Ignored before shutting down objects in the view for maintenance.

Cancel Closes the dialog without loading a view or saving any changes to 
the view list.

Help Displays online help for the dialog.

Field or Button Description
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Note If you set a view to Ignored, the view is ignored for only the current MWTM client.

Also, if you set a view to Ignored, make a note of the change, and do not forget to reset the view when 
the problem is corrected or the maintenance is complete.

You cannot ignore the DEFAULT view.

To set a view to Ignored, select the Ignored checkbox in the View Window for the view you want 
MWTM to ignore.

Viewing Ignored Views
To display all views that are Ignored, display the View Window and click the Ignored column header. 
MWTM displays all ignored views at the top of the table.
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