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Viewing the Topology of the Network

In addition to tabular (text) views of your network, MWTM provides a topology (graphical) view of the 
objects in your network, including adjacent devices, and enables you to customize the view to meet your 
needs.

To view the topology of your network, use one of the following procedures:

• Select View > Show Topology from the MWTM Main Menu.

• Right-click an object, then select View > Center in Topo in the right-click menu.

MWTM displays the Topology Window.

The Topology Window displays tabular information about MWTM objects in the left pane and the 
graphical topology map in the right pane.

The Topology Window is composed of the following sections:

• Topology Menu, page 8-2

• Topology Toolbar Buttons, page 8-2

• Topology View Table, page 8-5

• Topology New Objects Panel, page 8-7

• Topology Excluded Objects Panel, page 8-7

• Topology Map, page 8-7
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MWTM provides the following functions related to the topology map:

• Creating a Custom Layout, page 8-14

• Finding an Object, page 8-15

• Using the Selection Dialog, page 8-16

• Scrolling in the Topology Map, page 8-16

• Centering the Topology Map on an Object, page 8-17

• Displaying Detailed Information About a Topology Map Element, page 8-17

• Displaying the Topology New Objects Panel, page 8-17

• Displaying the Topology Excluded Objects Panel, page 8-17

• Printing the Topology Map, page 8-17

• Saving the Topology Map as a JPEG File, page 8-18

• Selecting a Directory for the JPEG File, page 8-19

• Activating a Magnetic Grid on the Topology Map, page 8-20

• Specifying a Color for the Magnetic Grid, page 8-21

• Specifying a Background Color for the Topology Map, page 8-23

• Aligning Objects on the Topology Map, page 8-25

• Hiding and Redrawing Lines When Redrawing, page 8-26

• Hiding and Showing Lines When Redrawing, page 8-26

• Locking and Unlocking the Position of an Icon, page 8-26

• Turning Off Antialiasing to Improve Performance, page 8-27

• Saving the Topology Map, page 8-27

• Restoring the Topology Map, page 8-27

Related Topics:

• Diagnosing a Typical Network Problem, page 12-5

• Changing MWTM Client Preference Settings, page 11-2

• Working with Views, page 4-1

Topology Menu
The Topology Window uses the MWTM Main Menu. See the “Using the MWTM Main Menu” section 
on page 3-7 for detailed descriptions of the options it provides.

Topology Toolbar Buttons
The Topology Window contains the following toolbar buttons:
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Button Description

Close view tab Closes the currently displayed view in the Topology Window.

This option is grayed-out if the currently displayed view is the 
highest level parent view.

Open parent view Opens the parent view of the currently displayed view in the 
Topology Window.

This option is grayed-out if the currently displayed view is the 
highest level parent view.

Lay out nodes in a circle Displays the map in a circular layout.

Lay out nodes in a spring Displays the map in a spring layout. That is, nodes with the 
most links are drawn closer to the center of the map, while 
nodes with fewer links are drawn farther away. This is the 
default setting the first time the map is displayed.

Note You can change how far apart nodes are spaced when 
MWTM draws the spring layout. For details, see the 
“Topology Settings” section on page 11-9.

Zoom in by a factor of 200% Makes the map twice as large.

Zoom out by a factor of 50% Makes the map half as large.

Zoom by percentage Zooms the map by a selected percentage. Either select a 
percentage from the drop-down list box, or enter a percentage 
and click Enter. Valid values are integers in the range 
5 through 400.

Zoom in on an area Zooms in on the selected area of the map. Click the button, then 
click in the topology map and drag a rectangle around the area 
you want to zoom in on. MWTM expands the selected area to 
fill the topology map.

Zoom to fit window Adjusts the size of the map to fit in the window. This is the 
default setting the first time the map is displayed.

Find objects Opens the Find Objects dialog, which enables you to find and 
highlight an object in the Topology Window.

Set magnetic grid properties Opens the Magnetic Grid Settings dialog, which enables you to 
activate and deactivate the magnetic topology grid, and 
modifies how it is displayed. With the grid activated, when you 
move objects on the topology map they “snap” to align with the 
grid.

Align objects on map Opens the Align Objects dialog, which enables you to align two 
or more objects on the topology map.
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Node Dragging Optimizer Turns the Node Dragging Optimizer on or off:

• When the Node Dragging Optimizer is On, MWTM hides 
connection lines as you drag an object around the topology 
map. MWTM draws the linkset lines when you drop the 
object in its final position. This is the default setting.

• When the Node Dragging Optimizer is Off, MWTM 
continually redraws connection lines as you drag an object 
around the topology map.

This setting, with the Node Dragging Optimizer on or off, is 
saved automatically with your preferences.

Hiding/Showing Dangling 
Connections

Hides or shows nodes and lines that connect to objects that are 
not in the current view, called dangling connections:

• When the Hiding Dangling Connections is set to Hide, 
MWTM hides dangling connections. This is the default 
setting.

• When the Hiding Dangling Connections is set to Show, 
MWTM shows dangling connections, drawing the nodes 
and connections in shades of gray to distinguish them from 
actual objects in the current view.

This setting, with the Hiding Dangling Connections set to Show 
or Hide, is not saved when you save the view.

To include a dangling node and its connection in the current 
view, select the node, then select Include In View.

Lock position

or

Unlock position

Locks or unlocks the position of an icon on the topology map. 
Locking the position of an icon can be useful if you want to 
keep the icon in its position, and you want to make sure you do 
not move it inadvertently. Locked icons are not included in the 
circular or spring layouts.

• To lock the position of an icon, select an unlocked icon, 
then select Lock position.

• To unlock the position of an icon, select a locked icon, then 
select Unlock position. This is the default setting.

This setting, with icon positions locked or unlocked, is saved 
automatically with your view.

Button Description
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Topology View Table
The topology view table in the left pane of the Topology Window displays information about the MWTM 
objects that are currently displayed in the topology map.

To display the topology view table, select the Tables tab in the left pane of the Topology Window. By 
default, this table is sorted by Status.

To redraw the topology map centered on a specific object, double-click the object in this table.

You cannot select more than one object at a time in this table.

To see mouse over help popup for each column in the table, place the cursor over a column header.

If a cell is too small to show all of its data, place the cursor over the cell to see the full data in a mouse 
over help popup.

You can resize each column, or sort the table based on the information in one of the columns. By default, 
MWTM displays only the Type, Name, Node Name, and Status columns in the topology view table.

• To display hidden columns, right-click in the table header and select the checkboxes for the columns 
you want to display.

• To hide columns, right-click in the table header and clear the checkboxes for the columns you want 
to hide.

See the “Resizing, Sorting, and Hiding Table Columns” section on page 3-30 for more information about 
resizing, sorting, displaying, or hiding columns.

The topology view table contains the following columns:

Column Description

Internal ID Internal ID of the object. The internal ID is a unique ID for every object, 
assigned by MWTM for its own internal use. It can also be useful when the 
TAC is debugging problems.

Type Type of object:

• MWRNode—A Mobile Wireless Router node

• Node—Any interconnecting node that is not an MWR node

• View—Custom view (if one exists)

Name Name of the object.

Node Name of the node associated with the object.

Notes Indicates whether there is a note associated with the object.

Events Indicates whether there is a recent event associated with the object. (Even if 
the server purges all of the events associated with the object, MWTM 
continues to display the event icon in this field.)

During Discovery, MWTM might flag most objects with an event icon 
(orange triangle). If the event icons are too distracting, select Edit > Clear 
All Events from the MWTM Main Menu to remove them.

Last Status Change Date and time that the status of the object last changed.
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Status Current status of the object. Possible values are:

Active

Unknown

Unmanaged

Warning

For detailed definitions of each status, see the “MWTM Status Definitions” 
section on page A-1.

Status Reason Reason for the current status of the object.

For a full list of possible reasons, see the stateReasons.html file:

• If you installed MWTM in the default directory, /opt, then the file is 
located at /opt/CSCOsgm/apache/share/htdocs/eventHelp directory.

• If you installed MWTM in a different directory, then the help directory 
and file are located in that directory.

If the cell is too small to show all of the status reason, place the cursor over 
the cell to see the full status reason in a mouse over help popup.

The status reasons are listed in order of decreasing magnitude. If two or more 
reasons apply, the reason of greatest magnitude is displayed.

If the status reason is Unsupported Configuration, correct the 
configuration and enter the mwtm cleandiscover command to delete all 
current network data and begin a clean discovery of the RAN-O network. If 
the status reason is still Unsupported Configuration, enter the mwtm clean 
command to restore the MWTM server to a “clean” state, such as would exist 
after a new installation of MWTM. For more information on the use of these 
commands, see the “MWTM Command Reference” section on page C-1.

Ignored Indicates whether the object is to be included when aggregating and 
displaying MWTM status information:

• Clear the checkbox to include the object. This is the default setting.

• Select the checkbox to exclude the object.

This field can be edited by users with authentication level Power User 
(Level 2) and higher.

Column Description
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Topology New Objects Panel
The topology New Objects panel in the left pane of the Topology Window displays graphical elements 
for newly discovered objects, based on the following criteria:

• If you are using an MWTM client with the DEFAULT view set, this panel never contains any objects. 
In the DEFAULT view, MWTM adds all newly discovered objects to the topology map as soon as 
they are discovered.

• If you are using an MWTM client with a custom view set, this panel contains all objects discovered 
since the Topology Window was opened in this session that have not been excluded in the Excluded 
from View table of the View Editor Window, or that are not in the current view.

To display the topology New Objects panel, select the New Objects tab in the left pane of the Topology 
Window, or click the “New!” icon in the bottom of the window.

To add a newly discovered object to the topology map, select one or more objects and drag them to the 
map while holding down the left mouse button.

To exclude a newly discovered object, use the View Editor Window. See the “Creating a New View” 
section on page 4-31 for more details.

Topology Excluded Objects Panel
The topology Excluded Objects panel in the left pane of the Topology Window displays graphical 
elements for excluded objects. Excluded objects are objects that you have chosen not to manage, that 
you have moved to the Excluded from View table of the View Editor Window. (See the “Creating a New 
View” section on page 4-31 for more information about excluding objects from views.)

To display the topology Excluded Objects panel, select the Excluded Objects tab in the left pane of the 
Topology Window.

To add an excluded object to the topology map, select the object and drag it to the map while holding 
down the left mouse button. When you do so, the object is no longer excluded, and it is removed from 
the Excluded from View table of the View Editor Window.

Topology Map
The topology map in the right pane of the Topology Window displays the objects and views in your 
network in an easy-to-read graphical format.

If you have defined custom views, you can view them in the topology map. MWTM displays a tab for 
each displayed view. Each tab displays a colored ball that indicates the current status of that view:

• Active

• Warning

For detailed definitions of each status, see the “Status Definitions for Views” section on page A-4.

See the “Creating a New View” section on page 4-31 for more information about excluding objects.

To see mouse over help popup, place the cursor over an object.

Note You can turn off mouse over help. For details, see the “Topology Settings” section on page 11-9.
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To highlight an element in the topology view table or topology table in the left pane, click it:

• Click a node in the topology view table to display any associated interfaces in the topology table.

• Click a line, a diamond, or double-triangle to highlight the closest associated node in the topology 
view table. For example, if there is a line connecting node mwtm-1941a and node mwtm-1941b, 
and you click the line closer to node mwtm-1941a, then that node is highlighted in the topology 
view table.

To display detailed information about an element in the map, double-click it, then respond to MWTM’s 
prompts:

• Double-click a node to display the Details Window for that node.

• Double-click a line, a diamond, or double-triangle, to display the Details Window for that interface.

To scroll around in the topology map, click anywhere in the map, then click the arrow, Page Up, and 
Page Down keys.

To redraw the topology map centered on a specific node or interface, double-click the node or interface 
in the topology view table.

To save the topology map as a JPEG file, use the Save as JPEG dialog. See the “Saving the Topology 
Map as a JPEG File” section on page 8-18 for more details.

To activate or change the magnetic topology grid, which can help you align nodes when you move them, 
use the Magnetic Grid Settings dialog. See the “Activating a Magnetic Grid on the Topology Map” 
section on page 8-20 for more details.

To align two or more objects on the topology map, use the Align Objects dialog. See the “Aligning 
Objects on the Topology Map” section on page 8-25 for more details.

To hide connections to objects that are not in the current view (called dangling connections), click the 
Hiding/Showing Dangling Connections button to set it to Hide. To show dangling connections, click 
the Hiding/Showing Dangling Connections button to set it to Show. MWTM draws the nodes in shades 
of gray to distinguish them from actual objects in the current view. This setting, with the Hiding 
Dangling Connections set to Show or Hide, is not saved.

To include a dangling connection in the current view, right-click the connection and select Include In 
View.

To lock the position of an icon on the topology map, select an unlocked icon, then select Lock position. 
Locking the position of an icon can be useful if you want to keep the icon in its position, and you want 
to make sure you do not move it inadvertently. Locked icons are not included in the circular or spring 
layouts.

To unlock the position of an icon on the topology map, select a locked icon, then select Unlock position.

•

The color of a graphical element indicates its current status. For detailed definitions of each status, see 
the “MWTM Status Definitions” section on page A-1.

A note icon in the upper left corner of an element means a user has attached a descriptive string to the 
element.

An event icon (orange triangle) in the upper right corner of an element means there is a recent event 
associated with the element.

The topology map also provides right-click menus for elements. For more information, see the following 
sections:

• Topology Right-Click Menu: Map, page 8-9

• Topology Right-Click Menu: View, page 8-10
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Topology Right-Click Menu: Map
The Topology Window provides a subset of the MWTM Main Menu as a right-click menu. To see this 
menu for a map, right-click in a blank area of the topology map. The topology map right-click menu 
provides the following options:

Menu Command Description

Zoom In
(Ctrl-=)

Makes the map twice as large.

Zoom Out
(Ctrl-- or Ctrl-Minus)

Makes the map half as large.

Zoom Area Zooms in on the selected area of the map.

Zoom Fit Adjusts the size of the map to fit in the window. This is the default setting the 
first time the map is displayed.

Layout > Circular Displays the map in a circular layout.

Layout > Spring Displays the map in a spring layout. That is, nodes with the most links are 
drawn closer to the center of the map, while nodes with fewer links are drawn 
farther away. This is the default setting the first time the map is displayed.

Find Opens the Find Objects dialog, which enables you to find and highlight an 
object in the Topology Window.

Restore Positions Restores the view to the last saved view.

Save As JPEG
(Ctrl-J)

Opens the Save as JPEG dialog, enabling you to save the topology map to a 
JPEG file.

Magnetic Grid Opens the Magnetic Grid Settings dialog.

Change Background 
Color

Opens the Select Background Color dialog, which enables you to select a 
color for the background of the topology map.

Align Opens the Align Objects dialog, which enables you to align two or more 
objects on the topology map.

Create Subview Opens the View Editor Window, which enables you to select a new view to 
display in the Topology Window.

Open Parent View Opens the parent view of the currently displayed view in the Topology 
Window.

This option is grayed-out if the currently displayed view is the highest level 
parent view.

Close View Closes the currently displayed view in the Topology Window.

This option is grayed-out if the currently displayed view is the highest level 
parent view.
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Topology Right-Click Menu: View
The Topology Window provides a subset of the MWTM Main Menu as a right-click menu. To see this 
menu for a view, select a view in the topology map or topology view table, then click the right mouse 
button. The topology view right-click menu provides the following options:

Menu Command Description

Edit > Properties Opens the Edit Properties Dialog for the selected view.

If you have implemented MWTM User-Based Access, this 
option is available to users with authentication level Power 
User (Level 2) and higher.

Edit > Notes Opens the Edit Notes Dialog for the selected view.

If you have implemented MWTM User-Based Access, this 
option is available to users with authentication level Power 
User (Level 2) and higher.

Edit > SNMP IP Addresses Opens the Edit SNMP IP Addresses Dialog for a Node for 
the selected node.

This option is grayed-out if the selected node has no 
associated SNMP IP addresses.

If you have implemented MWTM User-Based Access, this 
option is available to users with authentication level 
Network Administrator (Level 4) and higher.

Clear Event Icon Deletes the event icon (orange triangle) from MWTM 
displays for the selected view, for this MWTM client only. 
The actual events are not deleted from MWTM, only the 
event icon for the selected view for this MWTM client.

This option is grayed-out if the selected view has no 
associated event icon.
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Delete Deletes the currently selected view from the MWTM 
database. MWTM displays the Confirm Deletion dialog:

• To delete the selected view, click Yes. The view is 
deleted from the MWTM database and the Confirm 
Deletion dialog is closed.

• To retain the selected view, click No. The view is kept 
in the MWTM database and the Confirm Deletion 
dialog is closed.

• To prevent MWTM from displaying the Confirm 
Deletion dialog, select the Do not show this again 
checkbox.

Note If you select the Do not show this again checkbox, 
and you later decide you want MWTM to begin 
displaying the Confirm Deletion dialog again, you 
must select the Confirm Deletions checkbox in the 
General GUI settings in the Preferences window. 
For more information, see the description of the 
Confirm Deletions checkbox in the “Startup/Exit 
Settings” section on page 11-6.

If you have implemented MWTM User-Based Access, this 
option is available to users with authentication level 
Network Administrator (Level 4) and higher.

Back > List of Windows Navigates back to a window viewed in this session.

MWTM maintains a list of up to 10 Back windows.

Forward > List of Windows Navigates forward to a window viewed in this session.

MWTM maintains a list of up to 10 Forward windows.

View > Components Displays the Components panel for the selected node.

View > Configuration Details Displays the Configuration Data window for the selected 
view.

View > Notes Displays the Notes dialog for the selected view.

If there are no notes associated with the selected view, this 
option is grayed-out.

View > Events Displays the Recent Events table for the selected view and 
its associated objects.

View > Center in Topo Opens the Topology Window, with the display zoomed to 
center on the selected view.

If more than one view contains the selected view, MWTM 
prompts you to choose one of the views.

Event History > Status Change 
Messages

Displays the MWTM Network Status Log for Status 
Change Messages in a Web browser, with messages 
displayed for only the selected node.

Menu Command Description
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Event History > SNMP Trap Messages Displays the MWTM Network Status Log for SNMP Trap 
Messages in a Web browser, with messages displayed for 
only the selected node.

Event History > Status and Trap 
Messages

Displays the MWTM Network Status Log for Status 
Change Messages and SNMP Trap Messages in a Web 
browser, with messages displayed for only the selected 
node.

Event History > Network Status 
Metrics

Displays the MWTM Network Status Log for Metrics in a 
Web browser, with messages displayed for only the 
selected node.

Ignore Ignores the selected view at the next polling cycle.

If you have implemented MWTM User-Based Access, this 
option is available to users with authentication level Power 
User (Level 2) and higher.

Unignore Stops ignoring the selected view at the next polling cycle.

If you have implemented MWTM User-Based Access, this 
option is available to users with authentication level Power 
User (Level 2) and higher.

Drill-Down > Show Syslog Messages Opens the Node Details: Syslog table, which polls the 
selected node and displays all messages in its system log.

This option is not available if the node is in Unknown or 
Unmanaged status.

Drill-Down > Show CPU Processes Opens the Node Details: CPU Processes panel, which polls 
the selected node for information about its CPU processes.

This option is not available if the node is in Unknown or 
Unmanaged status.

Drill-Down > Show Trap Configuration Opens the Node Details: Trap Configuration panel, which 
displays all trap settings for the node, as well as all hosts 
and port numbers to which the node sends traps.

If you have implemented MWTM User-Based Access, this 
option is available to users with authentication level 
System Administrator (Level 5).

This option is not available if the node is in Unknown or 
Unmanaged status.

Latest Reports > RAN Capacity 
Planning

Displays the RAN Capacity Planning Report for the node, 
in a Web browser.

This option is not available if the node is in Unknown or 
Unmanaged status.

Latest Reports > RAN Statistics Displays the RAN Backhaul 15 Minutes Statistics report 
associated with the node, in a Web browser.

This option is not available if the node is in Unknown or 
Unmanaged status.

Menu Command Description
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Router > Home Page Displays the home page of the router in a new Web browser 
window.

This option is grayed-out if the selected node is not a 
RAN-O node.

Router > Telnet To Links to the router.

This option is grayed-out if the selected node has no IP 
addresses.

If you have implemented MWTM User-Based Access, this 
option is available to users with authentication level 
Network Operator (Level 3) and higher.

Poll Node > Normal Poll Polls all selected nodes, retaining all currently known 
interfaces.

Normal Poll retains all interfaces associated with polled 
nodes, even interfaces that have been deleted and are 
therefore in Unknown status.

This option is grayed-out if the selected node has no IP 
addresses.

If you have implemented MWTM User-Based Access, this 
option is available to users with authentication level 
Network Operator (Level 3) and higher.

Poll Node > Clean Poll Polls all selected nodes and removes any Unknown 
network objects after the completion of the poll.

Clean Poll removes all network objects from the node at 
the completion of the poll.

This option is grayed-out if the selected node has no IP 
addresses.

If you have implemented MWTM User-Based Access, this 
option is available to users with authentication level 
Network Operator (Level 3) and higher.

Manage Removes the Unmanaged status from the selected node.

You cannot remove the Unmanaged status from a node 
with a Device Type of Unknown. If you select a node with 
a Device Type of Unknown, then this menu option is 
grayed-out and cannot be selected.

This option is grayed-out if the selected node has no IP 
addresses.

If you have implemented MWTM User-Based Access, this 
option is available to users with authentication level 
Network Administrator (Level 4) and higher.

Menu Command Description
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Creating a Custom Layout
MWTM enables you to create a custom layout for the topology map. To do so, move the nodes around, 
grouping them or isolating them to meet your needs.

To move a single node, click the left mouse button to select the node in the map and, while holding down 
the left mouse button, move the mouse to move the node to its new position.

Unmanage Labels the selected node Unmanaged.

You cannot label a node Unmanaged if it has a Device 
Type of Unknown. If you select a node with a Device Type 
of Unknown, then this menu option is grayed-out and 
cannot be selected.

This option is grayed-out if the selected node has no IP 
addresses.

If you have implemented MWTM User-Based Access, this 
option is available to users with authentication level 
Network Administrator (Level 4) and higher.

Exclude from View Excludes the selected node from the current view. See the 
“Creating a New View” section on page 4-31 for more 
information about excluding nodes.

Menu Command Description
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To move more than one node at the same time, use the following procedure:

Step 1 Press and hold down the Shift key on your keyboard.

Step 2 Still holding down Shift, click the left mouse button to select the nodes you want to move in the map.

Step 3 Still holding down Shift, select one of the nodes you want to move and hold down the left mouse button.

Step 4 Still holding down both Shift and the left mouse button, move the mouse to move the nodes to their new 
position. The moved nodes keep their positions relative to each other.

Step 5 Release both Shift and the left mouse button.

When you are satisfied with the new topology map layout, select File > Save View from the MWTM 
Main Menu. MWTM saves the changes you have made to the network view, including any changes you 
have made to the topology map layout.

Finding an Object
Some topology maps are so large and complex that it can be difficult to find a specific object.

If the object is listed in the tables in the left pane of the Topology Window, simply select the object, and 
MWTM highlights it in the topology map.

If the object is not listed in the tables in the left pane of the Topology Window, click the Find objects 
(binoculars) button in the Topology Window, or select Edit > Find from the MWTM Main Menu. 
MWTM displays the Find Objects dialog, which enables you to find and highlight an object in the 
Topology Window.
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The Find Objects dialog contains the following fields and buttons:

Using the Selection Dialog
If more than one object is found that matches the Search string in the Find Objects dialog, MWTM 
displays the Selection Dialog.

The Selection Dialog contains the following field and buttons:

Related Topics:

• Finding an Object, page 8-15

Scrolling in the Topology Map
To scroll around in the topology map, use one of the following procedures:

• Use the scroll bar with your mouse.

• Click anywhere in the map, then click the arrow, Page Up, and Page Down keys on your keyboard.

Field or Button Description

Search string Character string for which MWTM is to search.

OK Launches the search.

• If no matching object is found, MWTM displays an appropriate 
message.

• If exactly one object is found that matches the Search string, MWTM 
highlights the object in the Tables panel of the Topology Window, and 
zooms in on the selected object in the topology map.

• If more than one object is found that matches the Search string, 
MWTM displays the Choose dialog, enabling you to select from a list 
of the found objects. See the “Using the Selection Dialog” section on 
page 8-16 for further details.

Cancel Exits the Find Objects dialog without launching the search.

Field or Button Description

Select one in list Type, Name or Status of the found objects. Select the object you want 
to find.

Select Highlights the selected object in the left pane of the Topology Window, 
and zooms in on the selected object in the topology map.

Cancel Closes the Selection Dialog without selecting an object.
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Centering the Topology Map on an Object
To redraw the topology map centered on a specific node, double-click the object in a table in the left 
pane of the window.

Displaying Detailed Information About a Topology Map Element
To display detailed information about an element in the map, double-click it, then respond to MWTM 
prompts:

• Double-click a node to display the MWTM Main window details for that object.

• Double-click a single line, or a diamond, circle, or arrowhead at the end of a single line, to display 
the MWTM Main window details for that interface.

Displaying the Topology New Objects Panel
To display the topology New Objects panel, select the New Objects tab in the left pane, or click the 
“New!” icon in the bottom of the window. The topology New Objects panel displays graphical elements 
for newly discovered objects, based on the following criteria:

• If you are using an MWTM client with the DEFAULT view set, this panel never contains any objects. 
In the DEFAULT view, MWTM adds all newly discovered objects to the topology map as soon as 
they are discovered.

• If you are using an MWTM client with a custom view set, this panel contains all objects discovered 
since the Topology Window was opened in this session that have not been excluded in the Excluded 
from View table of the View Editor Window, or that are not in the current view.

• To add a newly discovered object to the topology map, select one or more objects in the topology 
New Objects panel and drag them to the map while holding down the left mouse button.

• To exclude a newly discovered object from the topology New Objects panel, see the “Creating a New 
View” section on page 4-31.

Displaying the Topology Excluded Objects Panel
To display the topology Excluded Objects panel, select the Excluded Objects tab in the left pane. The 
topology Excluded Objects panel displays graphical elements for excluded objects. Excluded objects are 
objects that you have chosen not to manage, that you have moved to the Excluded from View table of 
the View Editor Window. (See the “Creating a New View” section on page 4-31 for more information 
about excluding objects from views.)

To add an excluded object to the topology map, select the object and drag it to the map while holding 
down the left mouse button. When you do so, the object is no longer excluded, and it is removed from 
the Excluded from View table of the View Editor Window.

Printing the Topology Map
To print the topology map, see the “Printing MWTM Windows” section on page 3-31.
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Saving the Topology Map as a JPEG File
MWTM enables you to save the topology map to a JPEG file. You can save the entire topology map, or 
just the current window.

To save the topology map to a JPEG file, select Topology Tools > Save as JPEG from the MWTM Main 
Menu.

MWTM displays the Save as JPEG dialog.

The Save as JPEG dialog contains the following fields and buttons:

Field or Button Description

All Saves the entire topology map as a JPEG file. The default setting is for this 
checkbox to be selected.

Current Window Saves just the portion of the topology map displayed in the current window as 
a JPEG file. The default setting is for this checkbox to be cleared (that is, save 
the entire map, not just the current window).

Quality Specifies the quality of the JPEG file, from 0 (lowest quality) to 1.0 (highest 
quality). The default setting is 0.7, which is sufficient for most JPEG files.

Max. Size Specifies the size of the JPEG file, in pixels. Choose a value from the 
drop-down list box. The valid range is 400 pixels to 2400 pixels. The default 
value is 400 pixels, which is sufficient for most JPEG files.

Name Enter a name for the JPEG file, or accept the default filename, out.jpg.

The default directory for the JPEG file is the directory in which you installed 
the MWTM client:

• In Solaris/Linux, the default installation directory for the MWTM client is 
/opt/CSCOsgmClient.

• In Windows, the default installation directory for the MWTM client is 
C:\Program Files\SGMClient\.

• If you installed the MWTM client in a different directory, then the 
installation directory is located in that directory.

If you do not want to save the JPEG file to the default directory, click Browse 
to select a different directory.

Browse Opens the Save dialog for a topology map, which enables you to specify or 
select a name when you save the JPEG file. If you do not want to save the JPEG 
file to the default directory, click Browse to select a different directory.

Save Saves the JPEG file and closes the Save as JPEG dialog.

Cancel Closes the Save as JPEG dialog without saving the JPEG file.
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Selecting a Directory for the JPEG File
MWTM enables you to specify or select a name or directory when you save a topology map to a JPEG 
file. You can save the entire topology map, or just the current window.

To specify a name or directory for the JPEG file, click Browse in the Save as JPEG dialog.

MWTM displays the Save dialog for a topology map.

The Save dialog for a topology map contains the following fields and buttons:

Related Topics:

• Saving the Topology Map as a JPEG File, page 8-18

Field or Button Description

Save In Enables you to select the directory in which you want to save the topology map 
JPEG file. Either accept the default directory, or select a new directory from 
the drop-down list box.

File Name Enter a name for the JPEG file, or select a file from those listed in the Save In 
field.

Files of Type Specifies the type of file to save, and displays all files of that type in the 
selected directory. Select a file type from the drop-down list box:

• All files—Displays all files in the selected directory, and saves the 
topology map file as a JPEG file.

• jpg files—Displays only JPEG files in the selected directory, and saves the 
topology map file as a JPEG file. This is the default value.

Up One Level Displays the sub-folders and files that are in the folder that is up one level from 
the currently displayed folder.

Desktop Displays the sub-folders and files that are on your workstation desktop.

Create New Folder Creates a new sub-folder in the currently displayed folder.

List Displays only icons for sub-folders and files.

Details Displays detailed information for sub-folders and files, including their size, 
type, date they were last modified, and so on.

Save Saves the file and closes the Save dialog for a topology map.

When you are satisfied with the settings, click Save. MWTM closes the Save 
dialog for a topology map and populates the Name field in the Save as JPEG 
dialog with the new name and directory.

Cancel Closes the Save dialog for a topology map without saving the file.
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Activating a Magnetic Grid on the Topology Map
MWTM enables you to activate the magnetic topology grid, and change how it is displayed. With the 
grid activated, when you move objects on the topology map they “snap” to align with the grid.

Note Magnetic grid settings are not saved when you save the view.

To activate or change the magnetic topology grid, select Topology Tools > Magnetic Grid from the 
MWTM Main Menu. MWTM displays the Magnetic Grid Settings dialog.

The Magnetic Grid Settings dialog contains the following fields and buttons:

Field or Button Description

Grid Activated Specifies whether the magnetic topology grid is activated:

• To activate the grid, select this checkbox.

• To deactivate the grid, clear this checkbox. This is the default setting.

Display Grid Specifies whether the grid is to be displayed on the topology map:

• To display the grid, select this checkbox. This is the default setting.

• To hide the grid, clear this checkbox.

If Grid Activated is not selected, this checkbox is grayed-out.

Grid Spacing Specifies the spacing between lines on the grid, in pixels.

To specify the spacing between lines on the grid, in pixels, select the Grid 
Activated checkbox, then select a Grid Spacing level. The valid range is 
0 pixels to 150 pixels. The default setting is 50 pixels, which is sufficient for 
most topology maps.

Grid Color Opens the Select Grid Color dialog.

To specify a color for the grid, select the Grid Activated checkbox, then click 
Change Color in the Grid Color field. MWTM opens the Select Grid Color 
dialog.

OK Sets the new grid settings and closes the Magnetic Grid Settings dialog.

When you are satisfied with the magnetic grid settings, click OK.

Cancel Closes the Magnetic Grid Settings dialog without changing any settings.
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Specifying a Color for the Magnetic Grid
MWTM enables you to customize the color of the magnetic topology grid.

Note The grid color is not saved when you save the view.

To specify a color for the grid, select the Grid Activated checkbox in the Magnetic Grid Settings dialog, 
then click Select in the Grid Color field.

MWTM opens the Select Grid Color dialog.

The Select Grid Color dialog is composed of the following sections:

• Swatches Panel (Recommended), page 8-21

• HSB Panel, page 8-21

• RGB Panel, page 8-22

• Select Grid Color Field and Buttons, page 8-22

Related Topics:

• Activating a Magnetic Grid on the Topology Map, page 8-20

Swatches Panel (Recommended)
The Swatches panel of the Select Grid Color dialog enables you to select a grid color from a set of color 
swatches. This is the recommended method for selecting a grid color.

To display the Swatches panel, click the Swatches tab in the Select Grid Color dialog.

To select a grid color, select a swatch. The selected color is displayed in the Preview field. When you 
are satisfied with the color, click OK.

HSB Panel
The HSB panel of the Select Grid Color dialog enables you to select a grid color based on color hue, 
saturation, and brightness (HSB).

To display the HSB panel, click the HSB tab in the Select Grid Color dialog.

To select a grid color, use one of the following procedures:

• Select a color range on the vertical color bar, then select a specific color by moving the cursor around 
on the color square.

• Enter specific values in the hue (H), saturation (S), and brightness (B) fields.

The selected color is displayed in the Preview field. When you are satisfied with the color, click OK.
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RGB Panel
The RGB panel of the Select Grid Color dialog enables you to select a grid color based on the red, green, 
and blue (RGB) content of the color.

To display the RGB panel, click the RGB tab in the Select Grid Color dialog.

To select a grid color, select values for the Red, Green, and Blue fields. The selected color is displayed 
in the Preview field. When you are satisfied with the color, click OK.

Select Grid Color Field and Buttons
The Select Grid Color dialog contains the following field and buttons:

Field Description

Preview Displays a preview of the current selected grid color.

Whichever method you choose to select a grid color, the selected color is 
displayed in the Preview field. When you are satisfied with the color, click 
OK.

OK Sets the grid color as shown in the Preview field, and closes the Select Grid 
Color dialog.

Cancel Closes the Select Grid Color dialog without selecting a grid color.

Reset Resets the grid color to its initial setting.
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Specifying a Background Color for the Topology Map
MWTM enables you to customize the background color of the topology map.

Note The background color is not saved when you save the view.

To specify a background color for the topology map, right-click in a blank area of the topology map, then 
select Change Background Color from the right-click menu.

The Select Background Color dialog is composed of the following sections:

• Swatches Panel (Recommended), page 8-23

• HSB Panel, page 8-24

• RGB Panel, page 8-24

• Select Background Color Field and Buttons, page 8-25

Swatches Panel (Recommended)
The Swatches panel of the Select Background Color dialog enables you to select a background color 
from a set of color swatches. This is the recommended method for selecting a background color.

To display the Swatches panel, click the Swatches tab in the Select Background Color dialog.

To select a background color, select a swatch. The selected color is displayed in the Preview field. When 
you are satisfied with the color, click OK.
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HSB Panel
The HSB panel of the Select Background Color dialog enables you to select a background color based 
on color hue, saturation, and brightness (HSB).

To display the HSB panel, click the HSB tab in the Select Background Color dialog.

To select a grid color, use one of the following procedures:

• Select a color range on the vertical color bar, then select a specific color by moving the cursor around 
on the color square.

• Enter specific values in the hue (H), saturation (S), and brightness (B) fields.

The selected color is displayed in the Preview field. When you are satisfied with the color, click OK.

RGB Panel
The RGB panel of the Select Background Color dialog enables you to select a background color based 
on the red, green, and blue (RGB) content of the color.

To display the RGB panel, click the RGB tab in the Select Background Color dialog.

To select a background color, select values for the Red, Green, and Blue fields. The selected color is 
displayed in the Preview field. When you are satisfied with the color, click OK.
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Select Background Color Field and Buttons
The Select Background Color dialog contains the following field and buttons:

Aligning Objects on the Topology Map

Note To un-align objects, simply drag and drop the object to move it on the topology map. 

MWTM enables you to align two or more objects on the topology map. You can align the objects based 
on their left, right, top, or bottom edges, or you can center them in the map. The alignment is saved when 
you save the view.

To align objects, select the objects you want to align, then select Topology Tools > Align from the 
MWTM Main Menu. MWTM displays MWTM opens the Align Dialog.

The Align Dialog contains the following field and buttons:

Field Description

Preview Displays a preview of the current selected background color.

Whichever method you choose to select a background color, the selected color 
is displayed in the Preview field. When you are satisfied with the color, click 
OK.

OK Sets the background color as shown in the Preview field, and closes the Select 
Background Color dialog.

Cancel Closes the Select Background Color dialog without selecting a background 
color.

Reset Resets the background color to its initial setting.

Field Description

Vertically: None Does not align the selected objects vertically.

Vertically: Left Aligns the selected objects vertically, aligned with the left-most edge of 
the left-most selected object.

Vertically: Center Aligns the selected objects vertically, with centers aligned.

Vertically: Right Aligns the selected objects vertically, aligned with the right-most edge 
of the right-most selected object.

Vertically: Side by side Aligns the selected objects vertically, aligned side-by-side, with no 
horizontal space between the objects. (There might still be vertical space 
between the objects.)

Horizontally: None Does not align the selected objects horizontally.

Horizontally: Top Aligns the selected objects horizontally, aligned with the top-most edge 
of the top-most selected object.

Horizontally: Center Aligns the selected objects horizontally, with centers aligned.
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Hiding and Redrawing Lines When Redrawing
MWTM enables you to hide lines as you drag an object around the topology map, then draw the link 
lines when you drop the object in its final position. To do so, click the Node Dragging Optimizer button 
to turn it on. This is the default setting.

To have MWTM continually redraw lines as you drag an object around the topology map, click the Node 
Dragging Optimizer button to turn it off.

This setting, with the Node Dragging Optimizer on or off, is saved automatically with your preferences.

Hiding and Showing Lines When Redrawing
MTWM enables you to hide lines that connect to objects that are not in the current view, called dangling 
connections. To do so, click the Hiding/Showing Dangling Connections button to set it to Hide. This 
is the default setting.

To show dangling connections, click the Hiding/Showing Dangling Connections button to set it to 
Show. MWTM draws the lines in shades of gray to distinguish them from actual objects in the current 
view.

This setting, with the Hiding Dangling Connections set to Show or Hide, is not saved when you save the 
view.

To include a dangling connection in the current view, right-click the signaling point and select Include 
In View.

Locking and Unlocking the Position of an Icon
MWTM enables you to lock the position of an icon on the topology map. Locking the position of an icon 
can be useful if you want to keep the icon in its position, and you want to make sure you do not move it 
inadvertently. Locked icons are not included in the circular or spring layouts.

• To lock the position of an icon on the topology map, right-click an unlocked icon, then select Lock 
Position.

Horizontally: Bottom Aligns the selected objects horizontally, aligned with the bottom-most 
edge of the bottom-most selected object.

Horizontally: Side by side Aligns the selected objects horizontally, aligned side-by-side, with no 
vertical space between the objects. (There might still be horizontal space 
between the objects.)

Apply Aligns the selected objects and keeps the Align Dialog open, enabling 
you to continue aligning objects.

OK Aligns the selected objects and closes the Align Dialog.

Cancel Closes the Align Dialog. Changes you applied are saved; other changes 
are not saved.

Help Opens the Help window for this object. 

Field Description
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• To unlock the position of an icon on the topology map, right-click a locked icon, then select Unlock 
Position. This is the default setting.

This setting, with icon positions locked or unlocked, is saved when you save the view.

Turning Off Antialiasing to Improve Performance
Antialiasing, which is on by default, improves the appearance of the icons and connections in the 
topology map. However, antialiasing can impact the performance of the MWTM client on a remote 
workstation (that is, a Solaris/Linux workstation using xhost, or a Windows workstation using an 
X-Window system emulator such as eXceed or Reflection X).

MWTM enables you to turn off antialiasing to improve the performance of the MWTM client on a 
remote workstation. To do so, select the X Performance Enhancer (AntiAliasing Off) checkbox in the 
Topology settings in the Preferences window. For more information, see the “Topology Settings” section 
on page 11-9.

To turn antialiasing back on, clear the checkbox.

Keep in mind that performance is always better if you access MWTM by installing the MWTM client on 
the remote workstation.

Saving the Topology Map
When you are ready to close the Topology Window, select File > Save View from the MWTM Main 
Menu. MWTM prompts you to save any changes you made to the network view, including any changes 
you have made to the topology map layout, and closes the window.

For more information, see the “Closing the View Editor Window” section on page 4-39.

Restoring the Topology Map
MWTM enables you to restore the topology map to the way it looked in the last saved view. To do so, 
select Topology Tools > Restore Positions from the MWTM Main Menu. MWTM restores the view.
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