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Getting Started with MWTM

This chapter provides information about starting and stopping MWTM, and provides an overview of how 
to use MWTM to manage your Radio Access Network-Optimization (RAN-O) installation.

This chapter includes the following information:

• Becoming the Root User (Server Only), page 3-3

• Starting the MWTM Server (Server Only), page 3-3

• Starting the MWTM Client, page 3-4

• Viewing the MWTM Main Window, page 3-7

• Using the MWTM Main Menu, page 3-7

• Viewing Alarms, page 3-15

• Viewing Events, page 3-18

• Viewing a Summary of Network Objects, page 3-19

• Viewing Views, page 3-22

• Viewing Nodes, page 3-22

• Viewing the Topology of the Network, page 3-23

• Viewing MWTM Data on the Web, page 3-23

• Viewing Server Status Information, page 3-24

• Viewing Online Help, page 3-29

• Finding Information in a Window, page 3-29

• Resizing, Sorting, and Hiding Table Columns, page 3-30

• Editing Object Properties, page 3-30

• Attaching Notes to Objects, page 3-31

• Printing MWTM Windows, page 3-31

• Loading and Saving MWTM Files, page 3-31

• Viewing Real-Time Data for a Node, page 3-33

• Changing Real-Time Poller and Counter Settings, page 3-33

• Connecting to a New Server, page 3-33

• Integrating MWTM with Other Products, page 3-35

• Exporting MWTM Data, page 3-38
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• Using the Windows Start Menu, page 3-42

• Using the MWTM Command Line Interface, page 3-44

• Running Simultaneous MWTM Sessions, page 3-45

• Exiting the MWTM Client, page 3-45

For detailed information about MWTM’s supported platforms, and hardware and software requirements, 
see the Cisco Mobile Wireless Transport Manager Installation Guide.

Note The default directory for installing MWTM is /opt. In commands that call for the default directory, if 
you installed MWTM in a different directory, you must specify that directory instead of /opt.
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Becoming the Root User (Server Only)
Some MWTM procedures require you to be logged in as the root user.

Caution As the root user, you can adversely affect your operating environment if you are unaware of the effects 
of the commands you use. If you are a relatively inexperienced UNIX user, limit your activities as the 
root user to the tasks described in this manual.

If you are not logged in, log in as the root user:

> login: root

> Password: root-password 

If you are already logged in, but not as the root user, use the su command to change your login to root:

# su

# Password: root-password

Starting the MWTM Server (Server Only)
Before starting an MWTM server, verify the following prerequisite conditions:

• The RAN-O devices use supported IOS images

• The MWTM server has IP connectivity to the RAN-O devices

• SNMP is enabled on the RAN-O devices

• (Optional) Traps are enabled on the RAN-O devices

To enable traps on the RAN-O device, enter the following:

snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart

snmp-server enable traps ipran
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• (Optional) A trap host is defined in the RAN-O network

To receive the traps on a host, enter the following on the RAN-O device:

snmp-server host IP_address version 2c v2c

Because the MWTM application is comprised of a server component and a client component, you must 
start both components to run the application.

To start the MWTM server on a Solaris/Linux system, enter the following commands:

# cd /opt/CSCOsgm/bin

# ./mwtm start

Note To issue the mwtm start command, you must be logged in as the root user or as a super user, or your 
login must have administrator privileges. See the “Becoming the Root User (Server Only)” section on 
page 3-3 and the “Specifying a Super User (Server Only)” section on page 10-19 for more information.

Starting the MWTM Client
This section contains the following information:

• Before Starting the MWTM Client, page 3-5

• Starting the MWTM Client on Solaris/Linux, page 3-6

• Starting the MWTM Client on Windows, page 3-6

• Starting the MWTM Client for the First Time, page 3-6
3-4
Cisco Mobile Wireless Transport Manager User Guide 5.0

OL-7637-02



 

Chapter 3      Getting Started with MWTM
  Starting the MWTM Client
Before Starting the MWTM Client
When you start an MWTM client, the version and release of the client must match that of the MWTM 
server, and the patch level must be greater than or equal to that of the server. For example, the following 
MWTM client-server connections are allowed:

The following MWTM client-server connections are not allowed:

If there is a client-server mismatch, MWTM displays a warning message when you try to start the client. 
If you have a Web browser installed, MWTM optionally opens a Web page enabling you to download an 
allowed, matching client. See the “Downloading the MWTM Client from the Web” section on 
page 13-50 for more information about downloading the MWTM client.

Table 3-1 Allowed MWTM Client-Server Connections

Client Level Server Level

5.0.0 5.0.0

5.1.0 5.1.0

Table 3-2 Disallowed MWTM Client-Server Connections

Client Level Server Level

5.0.0 5.1.0

5.1.0 5.0.0
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Starting the MWTM Client on Solaris/Linux
To start the MWTM client on a Solaris/Linux system on which the MWTM server is installed, make sure 
the MWTM server is running, then enter the following commands:

# cd /opt/CSCOsgm/bin

# ./mwtm client

To start the MWTM client on a Solaris/Linux system other than the one on which the MWTM server is 
installed, make sure the MWTM server is running, then enter the following commands:

# cd /opt/CSCOsgmClient/bin

# ./mwtm client

To start the MWTM client on a Solaris/Linux system other than the one on which the MWTM server is 
installed, and connect to an MWTM server other than the default server, enter the following commands:

# cd /opt/CSCOsgmClient/bin

# ./mwtm client server_name_or_ip_address

where server_name_or_ip_address is the name or IP address of the Solaris/Linux system on which the 
MWTM server is running.

Starting the MWTM Client on Windows
To start the MWTM client on a Windows system, select Start > Programs > Cisco MWTM Client > 
Launch MWTM Client, or double-click the MWTM Client icon on the Windows desktop.

Starting the MWTM Client for the First Time
When you start MWTM for the first time, MWTM displays the Discovery Dialog and the MWTM Main 
Window.

The MWTM Main Window is the primary MWTM window. It is the first window to appear when you 
launch the MWTM client. It displays basic information about the events and objects that MWTM 
discovers.

When you start MWTM for the first time, if you did not configure the MWTM server to automatically 
discover your network the first time the server starts after installation, the MWTM database contains no 
information, and the MWTM Main Window is blank. The database is populated, and reflected in the 
MWTM Main Window, when you run Discovery for the first time; MWTM displays the Discovery 
Dialog to make it easier for you to do so. In fact, any time you start the MWTM client and the MWTM 
database is empty, MWTM automatically opens the Discovery Dialog so you can run Discovery and 
populate the database. For more information about Discovery, see the “Discovery Overview” section on 
page 2-1.

The events and objects that MWTM discovers are displayed in the left and right panes of the MWTM 
Main Window.

MWTM also uses the right pane of the MWTM Main Window when displaying more detailed 
information about your network, such as configuration details and real-time data.
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Viewing the MWTM Main Window
The MWTM Main Window is the primary MWTM client window. It is the first window to appear when 
you launch the MWTM client. It displays basic information about the events and objects that MWTM 
discovers in the left and right panes. MWTM also uses the right pane of the MWTM Main Window when 
displaying more detailed information about your network, such as configuration details and real-time 
data.

For detailed descriptions of the information that is displayed in the MWTM Main Window, see the 
following sections:

• Using the MWTM Main Menu, page 3-7

• Viewing Alarms, page 3-15

• Viewing Events, page 3-18

• Viewing a Summary of Network Objects, page 3-19

• Viewing Views, page 3-22

• Viewing Nodes, page 3-22

• Viewing Interfaces, page 3-23

Using the MWTM Main Menu
The MWTM Main Menu appears in the menu bar of most MWTM windows.

Some menu items do not appear on some windows. In addition, menu items that are grayed-out are not 
available on that window.

For detailed information about the menu options provided by other windows, see the descriptions of 
those windows.

The MWTM Main Menu provides the following menu options:

Menu Command Description

File > Load DEFAULT View
(Ctrl-D)

Loads the DEFAULT view, which is the view into 
which MWTM places all discovered objects when 
discovering the network. The DEFAULT view is stored 
on the MWTM server and shared by all MWTM 
clients, but it cannot be modified by the clients.

File > Load View
(Ctrl-L)

Loads an already existing view. MWTM prompts you 
for the name of the view you want to load:

• Select the name of the view, or accept the default 
view name, then click OK to load the view.

• Click Cancel to close the prompt window without 
loading a view.
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File > Save View
(Ctrl-S)

Saves the current view:

• If you have not already saved the current view, 
opens the Save File Dialog: View List, which 
enables you to enter or select a file name under 
which to save the current view.

• If you have already saved the current view, saves 
the view to that file name.

If you have implemented MWTM User-Based Access, 
this option is available to users with authentication 
level Power User (Level 2) and higher.

File > Save View As Opens the Save File Dialog: View List, which enables 
you to enter or select a file name under which to save 
the current view.

If you have implemented MWTM User-Based Access, 
this option is available to users with authentication 
level Power User (Level 2) and higher.

File > Connect to New Server
(Ctrl-O)

Connects to a new server. MWTM prompts you for the 
new server’s name or IP address, and UDP port 
number.

MWTM stops the MWTM client, then restarts the 
client connected to the new server.

File > Print
(Ctrl-P)

Enables you to:

• Specify options for printing

• Print the current window

• Save the current window to a file

The MWTM printing options require that you define a 
printer on your system. If you select File > Print and 
the Print window does not appear, make sure you have 
defined a printer on your system.

File > Exit
(Ctrl-Q)

Exits the MWTM application, after prompting you for 
confirmation.

If you are working in a custom view (that is, not the 
DEFAULT view), MWTM automatically saves any 
changes you made to the view.

Edit > Views
(Ctrl-M)

Opens the View Editor Window.

Edit > Find
(Ctrl-F)

Opens the Find dialog, which enables you to find a 
specific object, event, or text in the window.

If you select an object in the left pane of the MWTM 
Main Window, this option is grayed-out and cannot be 
selected.

Menu Command Description
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Edit > Clear All Events
(Ctrl-E)

Deletes the event icon (orange triangle) from MWTM 
displays for all known objects. The actual events are 
not deleted from MWTM, only the event icon for all 
known objects.

Note During Discovery, MWTM might flag most 
objects with an event icon. If the event icons 
are too distracting, use the Edit > Clear All 
Events menu option to remove them.

Edit > Delete
(Delete)

Deletes the currently selected element or elements 
from the MWTM database. MWTM displays the 
Confirm Deletion dialog:

• To delete the selected elements, click Yes. The 
items are deleted from the MWTM database and 
the Confirm Deletion dialog is closed.

• To retain the selected elements, click No. The 
items are kept in the MWTM database and the 
Confirm Deletion dialog is closed.

• To prevent MWTM from displaying the Confirm 
Deletion dialog, select the Do not show this again 
checkbox.

Note If you select the Do not show this again 
checkbox, and you later decide you want 
MWTM to begin displaying the Confirm 
Deletion dialog again, you must select the 
Confirm Deletions checkbox in the General 
GUI settings in the Preferences window. For 
more information, see the description of the 
Confirm Deletions checkbox in the 
“Startup/Exit Settings” section on page 11-6.

If you have implemented MWTM User-Based Access, 
this option is available to users with authentication 
level Network Administrator (Level 4) and higher.

Edit > Preferences
(Ctrl-H)

Opens the Preferences window.

Network > SNMP Configuration
(Ctrl-B)

Opens the SNMP Configuration Dialog.

If you have implemented MWTM User-Based Access, 
this option is available to users with authentication 
level Network Administrator (Level 4) and higher.

Network > Network Discovery
(Ctrl-Y)

Opens the Discovery Dialog.

If you have implemented MWTM User-Based Access, 
this option is available to users with authentication 
level Network Administrator (Level 4) and higher.

Menu Command Description
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Network > Poll Nodes > Normal Poll
(Alt-N)

Polls all selected RAN-O nodes.

If you have implemented MWTM User-Based Access, 
this option is available to users with authentication 
level Network Operator (Level 3) and higher.

Network > Poll Nodes > Clean Poll
(Alt-C)

Polls all selected RAN-O nodes and removes any 
Unknown objects after the completion of the poll.

If you have implemented MWTM User-Based Access, 
this option is available to users with authentication 
level Network Operator (Level 3) and higher.

View > Show Topology
(Ctrl-T)

Opens the Topology Window.

View > MWTM Server > Home Page Displays the MWTM Server Home Page in a Web 
browser.

View > MWTM Server > Telnet To
(Ctrl-N)

Opens a Telnet window to the server.

View > MWTM Server > Status 
Information

Opens the Server Status Information Window.

View > Network Status Dashboard Displays the MWTM Node Dashboard in a Web 
browser.

View > Event History > Status Changes Displays the MWTM Network Status Log for Status 
Change Messages in a Web browser, with messages 
displayed for all known objects.

View > Event History > SNMP Trap 
Messages

Displays the MWTM Network Status Log for SNMP 
Trap Messages in a Web browser, with messages 
displayed for all known objects.

View > Event History > Status and Trap 
Messages

Displays the MWTM Network Status Log for Status 
Change Messages and SNMP Trap Messages in a Web 
browser, with messages displayed for all known 
objects.

View > Event History > Network Status 
Metrics

Displays the MWTM Network Status Log for Metrics 
in a Web browser, with metrics displayed for all known 
objects.

View > Event History > Network Status 
Archives

Displays all archived Status Change Messages and 
SNMP Trap Messages in a Web browser.

View > User Audit > User Actions Displays action messages in the system log, in a Web 
browser.

View > User Audit > User Accounts Displays information about all user accounts that have 
been defined for the MWTM server, in a Web browser.

View > User Audit > Security Log Displays the contents of the MWTM system security 
log file for the server to which you are connected, and 
which is currently running the MWTM server, in a 
Web browser.

Menu Command Description
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View > User Audit > Command Log Displays the contents of the MWTM command log file 
for the server to which you are connected, and which 
is currently running the MWTM server, in a Web 
browser. The command log lists all mwtm commands 
that have been entered for the MWTM server, the time 
each command was entered, and the user who entered 
the command.

View > User Audit > Connected Clients Lists all MWTM clients that are currently connected to 
the MWTM server, in a Web browser. It also lists all 
Solaris/Linux users that are logged in to the MWTM 
server.

View > Message of the Day Opens the Message of the Day dialog.

View > Cisco.com Displays the Cisco.com Home Page in a Web browser.

Reports > Router Node IOS Versions Displays the RAN-O Node IOS Versions for the server 
to which you are connected, and which is currently 
running the MWTM server, in a Web browser.

Go > Back
(Alt-Left)

Navigates back to the last window viewed in this 
session.

Go > Forward
(Alt-Right)

Navigates forward to the last window viewed in this 
session.

Go > Back > List of Windows Navigates back to a window viewed in this session.

MWTM maintains a list of up to 10 Back windows.

Go > Forward > List of Windows Navigates forward to a window viewed in this session.

MWTM maintains a list of up to 10 Forward 
windows.

Tools > Event Configurator
(Alt-E)

Launches the Event Configurator, which enables you 
to customize the displayed category, severity, color, 
and message associated with events; configure sounds 
for MWTM to play for different types of events; and 
load, save, and deploy customized event 
configurations.

If you have implemented MWTM User-Based Access, 
this option is available to users with authentication 
level Network Operator (Level 3) and higher.

Tools > Event Sounds
(Alt-U)

Opens the Event Sound Filters dialog, which enables 
you to define sounds that the MWTM client is to play 
when specific events are logged.

Menu Command Description
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Products > CiscoWorks > 
Device Center
(Ctrl-2)

Links to the CiscoWorks Device Center, which 
provides a number of Web-based functions, including 
reachability trends, response time trends, interface 
status, Syslog browsing, and detailed inventory. 
MWTM prompts you for a CiscoWorks user ID and 
password before linking to CiscoWorks.

The link to CiscoWorks has the following 
prerequisites:

• CiscoWorks must be installed somewhere in the 
network.

• The specific Cisco device must to be monitored by 
CiscoWorks.

This option is grayed-out if the selected node is not a 
RAN-O  node, or if the selected node is in Unmanaged 
status or has a Device Type of Unknown. 
(CiscoWorks cannot monitor a non-RAN-O, 
Unmanaged, or Unknown node.)

This option is not displayed if you did not specify a 
CiscoWorks server during installation. See the 
“Installing MWTM on Solaris” and “Installing 
MWTM on Windows” chapters of the Cisco Mobile 
Wireless Transport Manager Installation Guide for 
more information.

Products > CiscoWorks >
CiscoView
(Ctrl-3)

Links to CiscoView, which provides a real-time, 
color-coded, graphical representation of Cisco 
devices. You can use CiscoView to quickly identify an 
incorrect status on a port or interface.

This option is grayed-out if the selected node is a 
non-RAN-O  node, or if the selected node is in 
Unmanaged status or has a Device Type of Unknown. 
(CiscoWorks cannot monitor a non-RAN-O , 
Unmanaged, or Unknown node.)

This option is not displayed if you did not specify a 
CiscoWorks server during installation. See the 
“Installing MWTM on Solaris” and “Installing 
MWTM on Windows” chapters of the Cisco Mobile 
Wireless Transport Manager Installation Guide for 
more information.

Help > Topics
(F1)

Displays the table of contents for the MWTM online 
help.

Help > Window
(Shift-F1)

Displays online help for the current window.

Help > About
(F3)

Displays build date, version, SSL support, and 
copyright information about the MWTM application.

Menu Command Description
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Topology Tools > Zoom In
(Ctrl-=)

Makes the map twice as large.

Note This option is displayed only in the Topology 
Window (View > Show Topology).

Topology Tools > Zoom Out
(Ctrl-- or Ctrl-Minus)

Makes the map half as large.

Note This option is displayed only in the Topology 
Window (View > Show Topology).

Topology Tools > Zoom Area Zooms in on the selected area of the map.

Note This option is displayed only in the Topology 
Window (View > Show Topology).

Topology Tools > Zoom Fit Adjusts the size of the map to fit in the window. This 
is the default setting the first time the map is displayed.

Note This option is displayed only in the Topology 
Window (View > Show Topology).

Topology Tools > Layout > Circular Displays the map in a circular layout.

Note This option is displayed only in the Topology 
Window (View > Show Topology).

Topology Tools > Layout > Spring Displays the map in a spring layout. That is, nodes 
with the most links are drawn closer to the center of the 
map, while nodes with fewer links are drawn farther 
away. This is the default setting the first time the map 
is displayed.

Note This option is displayed only in the Topology 
Window (View > Show Topology).

Topology Tools > Restore Positions Restores the view to the last saved view.

Note This option is displayed only in the Topology 
Window (View > Show Topology).

Topology Tools > Save As JPEG
(Ctrl-J)

Opens the Save as JPEG dialog, enabling you to save 
the topology map to a JPEG file.

Note This option is displayed only in the Topology 
Window (View > Show Topology).

Topology Tools > Magnetic Grid Opens the Magnetic Grid Settings dialog.

Note This option is displayed only in the Topology 
Window (View > Show Topology).

Topology Tools > Align Opens the Align Objects dialog, which enables you to 
align two or more objects on the topology map.

Note This option is displayed only in the Topology 
Window (View > Show Topology).

Menu Command Description
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Topology Tools > Exclude from View Excludes the selected node from the current view. See 
the “Creating a New View” section on page 4-31 for 
more information about excluding nodes.

Note This option is displayed only in the Topology 
Window (View > Show Topology).

This option is grayed-out if the selected node is not a 
RAN-O node.

Topology Tools > Open Parent View Opens the parent view of the currently displayed view 
in the Topology Window.

Note This option is displayed only in the Topology 
Window (View > Show Topology).

This option is grayed-out if the currently displayed 
view is the highest level parent view.

Topology Tools > Close View Closes the currently displayed view in the Topology 
Window.

Note This option is displayed only in the Topology 
Window (View > Show Topology).

This option is grayed-out if the currently displayed 
view is the highest level parent view.

Menu Command Description
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Viewing Alarms
MWTM enables you to view a summary of all currently active alarms in your network, including the 
current status of the associated network object. An active alarm is a network object with the following 
status:

• A node or interface that is Warning or worse and is not Ignored.

• A node or interface that is Pending or worse and is not Ignored.

To see a summary of all currently active alarms, click Alarms in the left pane. MWTM displays the 
Active Alarms Window in the right pane. For more information, see the “Viewing Alarms” section on 
page 3-15.

Right-click Alarms in the left pane to display the right-click menu for all alarms. For more information, 
see the “Right-Click Menu for All Alarms” section on page 3-18.

Right-click an alarm in the right pane to display the right-click menu for a specific alarm. For more 
information, see the “Right-Click Menu for a Specific Alarm” section on page 3-18.

Viewing Alarms
To view alarms, select Alarms in the left pane of the MWTM Main Window. MWTM displays the Active 
Alarms Window.

The Active Alarms Window provides basic information about all currently active alarms in your 
network, that are not excluded from your current view. MWTM updates the information in the window 
at least once every minute.

To see mouse over help popup for each column in the table, place the cursor over a column header.

If a cell is too small to show all of its data, place the cursor over the cell to see the full data in a mouse 
over help popup.

You can resize each column, or sort the table based on the information in one of the columns. By default, 
this table is sorted by Age, with the most recent alarms at the top, and MWTM displays all of the columns 
in the table except Last Status Change.

• To display hidden columns, right-click in the table header and select the checkboxes for the columns 
you want to display.

• To hide columns, right-click in the table header and clear the checkboxes for the columns you want 
to hide.

See the “Resizing, Sorting, and Hiding Table Columns” section on page 3-30 for more information about 
resizing, sorting, displaying, or hiding columns.

The active alarms table contains the following columns:

Column Description

Type Type of network object associated with the selected alarm.

To see all higher-level alarms associated with the network object, select the 
turner beside the object. MWTM displays the higher-level alarms below the 
selected alarm. 

Name Name of the network object associated with the selected alarm.
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Status Current status of the network object associated with the selected alarm. 
Possible values are:

Unknown

Unavailable

Inactive

Failed

Down

Pending

Warning

Shutdown

Discovering

Polling

Waiting

Unmanaged

Active

For detailed definitions of each status for each type of network object, see 
the “MWTM Status Definitions” section on page A-1.

Status Reason Reason for the current status of the network object associated with the 
selected alarm.

For a full list of possible reasons, see the stateReasons.html file:

• If you installed MWTM in the default directory, /opt, then the file is 
located at /opt/CSCOsgm/apache/share/htdocs/eventHelp directory.

• If you installed MWTM in a different directory, then the help directory 
and file are located in that directory.

If the cell is too small to show all of the status reason, place the cursor over 
the cell to see the full status reason in a mouse over help popup.

The status reasons are listed in order of decreasing magnitude. If two or more 
reasons apply, the reason of greatest magnitude is displayed.

If the status reason is Unsupported Configuration, correct the 
configuration and enter the mwtm cleandiscover command to delete all 
current network data and begin a clean discovery of the RAN-O  network. If 
the status reason is still Unsupported Configuration, enter the mwtm clean 
command to restore the MWTM server to a “clean” state, such as would exist 
after a new installation of MWTM. For more information on the use of these 
commands, see the “MWTM Command Reference” section on page C-1.

Column Description
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Last Status Change Date and time that the status of the network object associated with the 
selected alarm last changed.

Age Age of the selected alarm, in days, hours, and minutes. 

Note For the most accurate age data, ensure that the client and server 
clocks are in sync by using Network Time Protocol (NTP) or a 
similar service. For more details, see “Why are the age of my alarms 
always 0 minutes?” section on page B-14.

Column Description
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Right-Click Menu for All Alarms
To see the right-click menu for all active alarms, select Alarms in the left pane and click the right mouse 
button. The active alarms right-click menu provides the following options:

Right-Click Menu for a Specific Alarm
The active alarms table provides a subset of the MWTM Main Menu as a right-click menu. To see this 
menu, select an alarm and click the right mouse button. The alarm right-click menu provides the same 
options as the right-click menu for the associated network object, plus the following additional options:

Caution The alarms displayed in the active alarms table are the actual network objects in MWTM. Options you 
select in the right-click menu affect the object in MWTM. For example, if you delete a node in the active 
alarms table, you delete that node from the MWTM database.

Viewing Events
To see all events discovered by MWTM, click Events in the left pane. MWTM displays the Event 
Window in the right pane. For more information, see the “Working with Events” section on page 5-1.

Right-click Events in the left pane to display the right-click menu for all events. For more information, 
see the “Right-Click Menu for All Events” section on page 5-3.

Right-click an event in the right pane to display the right-click menu for a specific event. For more 
information, see the “Right-Click Menu for a Specific Event” section on page 5-3.

Menu Command Description

Show In New Window Opens the Active Alarms Window in a new window.

Sort Tree By Status Sorts the entire tree in the left pane by the status of each object.

Sort Tree By Name Sorts the entire tree in the left pane by the name of each object.

Back > List of Windows Navigates back to a window viewed in this session.

MWTM maintains a list of up to 10 Back windows.

Forward > List of 
Windows

Navigates forward to a window viewed in this session.

MWTM maintains a list of up to 10 Forward windows.

Menu Command Description

Expand All Displays all higher-level alarms associated with all network objects in the active 
alarms table.

Collapse All Does not display higher-level alarms in the active alarms table.
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Viewing a Summary of Network Objects
MWTM enables you to view basic summary information about all discovered network objects, including 
their status and the number of each object with that status.

To see a summary of all network objects discovered by MWTM, click Summary Lists in the left pane. 
MWTM displays the Summary Statistics Window in the right pane. For more information, see the 
“Viewing the Summary Lists” section on page 3-20.

Right-click Summary Lists in the left pane to display the right-click menu for the summary lists. For 
more information, see the “Right-Click Menu for the Summary Lists” section on page 3-22.

Note If an object in the left pane is not associated with any objects of a given type, MWTM does not display 
that sub-folder. 
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Viewing the Summary Lists
To view the summary lists, select Summary Lists in the left pane of the MWTM Main Window. MWTM 
displays the Summary Statistics Window.

The Summary Statistics Window provides basic summary information about all discovered network 
objects that have been discovered by MWTM.

To see mouse over help popup for each column in the table, place the cursor over a column header.

If a cell is too small to show all of its data, place the cursor over the cell to see the full data in a mouse 
over help popup.

You can resize each column, or sort the table based on the information in one of the columns. By default, 
this table is sorted by Status, with failures (red statuses) at the top.

• To display hidden columns, right-click in the table header and select the checkboxes for the columns 
you want to display.

• To hide columns, right-click in the table header and clear the checkboxes for the columns you want 
to hide.

See the “Resizing, Sorting, and Hiding Table Columns” section on page 3-30 for more information about 
resizing, sorting, displaying, or hiding columns.
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The summary list table contains the following columns:

Column Description

Status Current status of the network objects. Possible values are:

Unknown

Unavailable

Inactive

Failed

Down

Blocked

Pending

Warning

Shutdown

Discovering

Polling

Waiting

Unmanaged

Active

For detailed definitions of each status for each type of network object, see 
the “MWTM Status Definitions” section on page A-1.

Total Total number of network objects with the indicated status.

Objects in hidden columns are not included in the totals.

Nodes Total number of discovered nodes with the indicated status.
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Right-Click Menu for the Summary Lists
To see the right-click menu for the summary lists, select Summary Lists in the left pane and click the 
right mouse button. The summary lists right-click menu provides the following options:

Viewing Views
To see all views currently configured on this MWTM client, select the turner beside Summary Lists, 
then click Views in the left pane. MWTM displays the View Window in the right pane. For more 
information, see the “Viewing Basic Information for Views” section on page 4-4.

To display all views currently configured on this MWTM client in the left pane, select the turner beside 
Views. Then, you can select one of the views to display the View Details Window for that view in the 
right pane. For more information, see the “Viewing Detailed Information for a View” section on 
page 4-9.

To display the DEFAULT view, select the turner beside Views, then select DEFAULT to display the 
View Details Window for the DEFAULT view in the right pane. For more information, see the “Viewing 
Detailed Information for a View” section on page 4-9.

Right-click Views in the left pane to display the right-click menu for all views. For more information, 
see the “Right-Click Menu for All Views” section on page 4-4.

Right-click a view in the right pane to display the right-click menu for a specific view. For more 
information, see the “Right-Click Menu for a Specific View” section on page 4-5.

Viewing Nodes
To see all nodes discovered by MWTM, select the turner beside Summary Lists, then click Nodes in 
the left pane. MWTM displays the Node Window in the right pane. For more information, see the 
“Viewing Basic Information for Nodes” section on page 6-1.

To display all nodes discovered by MWTM in the left pane, select the turner beside Nodes. Then, you 
can select one of the nodes to display the Node Details Window for that node in the right pane. For more 
information, see the “Viewing Detailed Information for a Node” section on page 6-10.

Right-click Nodes in the left pane to display the right-click menu for all nodes. For more information, 
see the “Right-Click Menu for All Nodes” section on page 6-3.

Right-click a node in the right pane to display the right-click menu for a specific node. For more 
information, see the “Right-Click Menu for a Specific Node” section on page 6-4.

Menu Command Description

Show In New Window Opens the Summary Statistics Window in a new window.

Sort Tree By Status Sorts the entire tree in the left pane by the status of each object.

Sort Tree By Name Sorts the entire tree in the left pane by the name of each object.

Back > List of Windows Navigates back to a window viewed in this session.

MWTM maintains a list of up to 10 Back windows.

Forward > List of 
Windows

Navigates forward to a window viewed in this session.

MWTM maintains a list of up to 10 Forward windows.
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Viewing Interfaces
To see all interfaces discovered by MWTM, select the turner beside a node in the left pane. To see 
detailed information about an interface, select the interface in the left pane. MWTM displays the 
Interface Window in the right pane. For more information, see “Viewing Detailed Information for an 
Interface” section on page 7-1.

Right-click an interface in the left pane to display the right-click menu. For more information, see the 
“Interface Details: Right-Click Menu” section on page 7-2.

Viewing the Topology of the Network
To see a topology (graphical) view of the objects in your network select View > Show Topology in the 
MWTM Main Menu. MWTM displays the Topology Window in a new window. For more information, 
see the “Viewing the Topology of the Network” section on page 8-1.

Viewing MWTM Data on the Web
MWTM enables you to access MWTM data from the MWTM Server Home Page, using a Web browser. 
To do so, select View > MWTM Server > Home Page in the MWTM Main Menu. MWTM displays the 
MWTM Server Home Page in a Web browser. For more information, see the “Accessing MWTM Data 
from a Web Browser” section on page 13-1.
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Viewing Server Status Information
MWTM enables you to view detailed information about the processes, pollers, tasks, and clients for the 
server to which you are connected, and which is currently running the MWTM server.

To display server status information, select View > MWTM Server > Status Information in the 
MWTM Main Menu. MWTM displays the Server Status Information window.

The Server Status Information window is composed of the following sections:

• Server Status Information: Fields and Buttons, page 3-25

• Server Status Information: Processes, page 3-25

• Server Status Information: Pollers, page 3-26

• Server Status Information: Tasks, page 3-27

• Server Status Information: Clients, page 3-28
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Server Status Information: Fields and Buttons
The Server Status Information window contains the following fields and buttons:

Server Status Information: Processes
The Server Status Information: Processes section lists the processes that make up the MWTM server.

The Processes table contains the following columns:

Menu Command Description

Poll Interval Poll interval used to collect data for the table.

Last Poll Time the last poll was run.

This field initially displays the phrase Polling device. After the first 
polling cycle, MWTM populates this field with the actual time of the last 
poll.

Update Forces an immediate poll, and refreshes the Server Status Information 
window with the latest data.

Close Closes the Server Status Information window.

Help Displays online help for the Server Status Information Dialog.

Field Description

Name Name of the process, such as AppServer.

Process ID Number to uniquely identify the process.

Is Running Indicates whether the process is running (true) or not (false).
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Server Status Information: Pollers
The Server Status Information: Pollers table lists the detail and demand pollers that are currently being 
processed by the MWTM server.

The Server Status Information: Pollers table contains the following columns:

Field Description

Poller ID Number to uniquely identify each MWTM detail poller that is currently active.

MWTM detail pollers collect detailed data (such as real-time data, statistics, 
route detail, and so on) that is not collected by the regular MWTM poller.

Client Host Name of the MWTM client that started the detail poller.

Interval Poll interval for the detail poller, in hours, minutes, and seconds.

Iteration Number of times the detail poller is to poll. If this field displays Forever, the 
detail poller will never stop polling, until requested to stop by the MWTM 
client.

Next Poll Time until the next poll, in hours, minutes, and seconds.

Time Limit Time remaining, in hours, minutes, and seconds, until the poller times out. 
When the poller times out, MWTM automatically stops the poller to prevent 
unnecessary traffic on the network and sends an appropriate error message to 
the client.

By default, MWTM allows pollers to run up to 8 hours. To change that setting, 
see the description of the mwtm pollertimeout command in the “mwtm 
pollertimeout” section on page C-36.

Description Description of the detail poller.
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Server Status Information: Tasks
The Server Status Information: Tasks table lists long-running services being performed by the MWTM 
server.

The Server Status Information: Tasks table contains the following columns:

Field Description

Task ID Number to uniquely identify the task.

Interval Time between runs for the task, in hours, minutes, and seconds.

Iteration Number of times the task is to run. If this field displays Forever, the task will 
never stop polling.

Next Execution Time until the next run for the task, in hours, minutes, and seconds.

State Current state of the task. Valid values are:

• None—Task is stopped.

• Waiting—Task is waiting to transition to Ready or Running state.

• Ready—Task is ready to execute but is not yet in Running state.

• Running—Task has been started and is currently executing.

• Pending—Task was in Ready state when it was canceled by a user. The 
task is pending final removal from the scheduler.

• Error—Task encountered an error.

• Dying—Task was in Running state when it was canceled by a user. The 
task continues to run in Dying state until it completes, then it is removed 
from the scheduler.

Description Description of the task.
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Server Status Information: Clients
The Server Status Information: Clients table contains the following columns:

Field Description

Process Name Name of an MWTM client that is currently connected to the server.

User Name If you have implemented MWTM User-Based Access, this field displays the 
name of an MWTM client user who is currently logged in and connected to the 
server.

If you have not implemented MWTM User-Based Access, this field displays the 
name of the device being used by the user.

Message Mask Mask that indicates which messages [1-81] are allowed to be sent to the client:

• For the MWTM client, this field displays [1-81]. That is, all messages are 
allowed to be sent to the MWTM client.

• For the Event Configurator, this field displays [14, 56, 67]. That is, only 
messages 14, 56, and 67 are allowed to be sent to the Event Configurator.

Sleeping? Indicates whether the thread that is responsible for delivering messages is 
sleeping (yes) or not (no). The normal setting for this field is no.

Sleep Time Time in seconds the thread that is responsible for delivering messages has been 
sleeping. The normal setting for this field is 0.

Queue Size Number of messages waiting to be sent to the MWTM client. The normal 
setting for this field is 0, but it could be higher if the MWTM server or client is 
very busy, as during Discovery.
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Viewing Online Help
MWTM provides the following online help options in the MWTM Main Menu:

• To display the table of contents for the MWTM online help in a Web browser, select Help > Topics.

• To display online help for the current window in a Web browser, click Help > Window.

• To display build date, version, SSL support, and copyright information about the MWTM 
application in a Web browser, click Help > About.

Related Topics:

• Viewing the MWTM Technical Documentation, page 13-49

Finding Information in a Window
Sometimes it can be difficult to find a specific piece of information, such as a node name or event text, 
in a window. MWTM enables you to search for a character string in a window.

To find and highlight a character string in a window, select Edit > Find from the MWTM Main Menu. 
MWTM displays the Find dialog.

The Find dialog contains the following fields and buttons:

Field or Button Description

What Character string for which MWTM is to search in the window. This can be any 
character string: all or part of a node name, event text, status, and so on.

Match Case Checkbox used to indicate whether MWTM is to search for only character 
strings that match the case of the text in the What field:

• To search with case-matching on, select this check box.

• To search with case-matching off, clear this check box. This is the default 
setting.

Search Forward Specifies whether MWTM is to search forward (down and to the right) in the 
window. This radio button is mutually exclusive with the Search Backward 
button. The default setting for this checkbox is selected.

Search Backward Specifies whether MWTM is to search backward (up and to the left) in the 
window. This radio button is mutually exclusive with the Search Forward 
button. The default setting for this checkbox is cleared.

Find Launches the search:

• If a matching character string is found in the window, MWTM highlights 
the first line that contains the string.

To find the next occurrence of the string, click Find again.

You can continue to click Find until there are no more matches in the 
window. At that time, MWTM displays an appropriate message in the 
dialog, such as Bottom of table reached.

• If no matching character string is found, MWTM displays an appropriate 
message in the dialog, such as Bottom of table reached.

Close Closes the Find dialog when you are done searching.
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Resizing, Sorting, and Hiding Table Columns
The columns in some tables in MWTM can be resized, sorted, or hidden to meet your specific needs. 
MWTM automatically saves your new settings and, thereafter, launches the client with the new settings.

• To make a column wider or narrower, click the column divider in the header and move the divider 
to the right or left while holding down the left or right mouse button.

Changes you make to an object’s Components or Recent Events table in the MWTM Main Window 
are reflected in all Components or Recent Events tables in the MWTM Main Window for all other 
objects. The changes are not reflected in Show In New Window windows or Real-Time Data and 
Charts windows.

Depending on your system, as well as other factors, MWTM windows can sometimes display so 
small that text is illegible, and columns and text entry fields are very narrow and unusable. If this 
happens, resize the window and widen the individual columns until the information is again legible 
and the columns and text entry fields are usable.

• By default, MWTM displays most of the columns in tables, but some columns may be hidden.

– To display hidden columns, right-click in the table header and select the checkboxes for the 
columns you want to display.

– To hide columns, right-click in the table header and clear the checkboxes for the columns you 
want to hide.

Changes you make to an object’s Components or Recent Events table in the MWTM Main Window 
are reflected in all Components or Recent Events tables in the MWTM Main Window for all other 
objects. The changes are not reflected in Show In New Window windows or Real-Time Data and 
Charts windows.

• To sort a table based on the data in a column, left-click in the column header. The table is sorted 
alphanumerically from top to bottom, based on the data in the selected column. To sort the table in 
reverse order, left-click in the column header a second time. If two entries in the selected column 
are identical, MWTM sorts those rows based on the data in the remaining table columns, moving 
left to right.

• Many of the tables in MWTM Web pages display an icon in the column header to indicate the 
column on which the table is sorted, and the direction of the sort. The icon displays an 
upward-pointing arrow if the table is sorted in ascending order (1-9, A-Z), and a downward-pointing 
arrow if the table is sorted in descending order (Z-A, 9-1).

• If you sort a table in an MWTM Web page based on the Nodes column, by default the table is sorted 
based on the DNS names of the nodes, as discovered by MWTM. However, if you modified your 
preferences to identify nodes by their user-defined names, then the table is sorted based on the 
user-defined names of the nodes. For more information, see the “Node Name Settings” section on 
page 11-8.

• To customize the order in which status settings are sorted in the Status column of tables, use the 
Status settings section of the Preferences window. For more information, see the “Status Settings” 
section on page 11-15.

Editing Object Properties
MWTM enables you to quickly and easily edit some properties of nodes and views. For more 
information, see the following sections:

• Editing Node Properties, page 6-43
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• Editing View Properties, page 4-25

Attaching Notes to Objects
MWTM enables you to quickly and easily attach notes to objects in the MWTM database. For more 
information, see the following sections:

• Attaching a Note to an Event, page 5-16

• Attaching a Note to a Node, page 6-46

• Attaching a Note to a View, page 4-27

Printing MWTM Windows
You can print most MWTM windows, as well as the topology map, for those times when you need 
hardcopy.

To print an MWTM window, select File > Print from most MWTM windows (for example, the MWTM 
Main Window or Topology Window).

MWTM displays the Print dialog.

The Print dialog enables you to specify print settings, such as which printer to print to, whether to send 
output to a file (the default location for the print file is your home directory), and whether to print duplex.

Note You can send output to a file only in the file formats supported by your printer drivers. Sending output 
to a file can also result in very large files.

When you are satisfied with your print settings, click Print. MWTM prints the map.

To exit the Print dialog at any time without printing, click Cancel.

Loading and Saving MWTM Files
MWTM enables you to quickly and easily load and save MWTM files. The files are stored on the 
MWTM server and can be loaded on any connected MWTM client.

To display a Load File Dialog, use one of the following procedures:

• To display the Load File Dialog: Load Filter, click Load in the Event Filter dialog. For more 
information, see the “Loading an Existing Event Filter” section on page 5-12.

• To display the Load File Dialog: Preferences File List, select File > Load from the Preferences 
window. For more information, see the “Loading an Existing Preference Settings File” section on 
page 11-22.

• To display the Load File Dialog: Seed File List, select File > Load Seeds from the Discovery 
Dialog. For more information, see the “Loading Seed Nodes and Seed Files” section on page 2-11.

• To display the Load File Dialog: View List, select File > Load from the View Editor Window. For 
more information, see the “Loading a Client-Specific View” section on page 4-40.
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• To load the DEFAULT network view, select File > Load DEFAULT View from the MWTM Main 
Menu. MWTM loads the DEFAULT view.

To display a Save File Dialog, use one of the following procedures:

• To display the Save File Dialog: Save Filter, click Save in the Event Filter dialog. For more 
information, see the “Saving an Event Filter File” section on page 5-13.

• To display the Save File Dialog: Preferences File List, select File > Save As from the Preferences 
window. For more information, see the “Saving the Preference Settings File” section on page 11-23.
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• To display the Save File Dialog: Seed File List, select File > Save As from the Discovery Dialog. 
For more information, see the “Saving a Seed File” section on page 2-13.

• To display the Save File Dialog: View List, select File > Save As from the View Editor window. For 
more information, see the “Closing the View Editor Window” section on page 4-39.

Viewing Real-Time Data for a Node
MWTM enables you to view detailed statistics for a selected node.

To display detailed statistics for one of these nodes, select the Shorthaul Performance or Backhaul 
Performance tab in the Node Details window. 

For more information, see the following sections:

• “Node Details: Shorthaul Performance” section on page 6-18

• “Node Details: Backhaul Performance” section on page 6-24

Changing Real-Time Poller and Counter Settings
MWTM provides three pollers for use in the MWTM client GUI and Web pages: a fast poller, a slow 
poller, and a status refresh poller. MWTM enables you to change settings for those pollers, and also 
enables you to specify how you want MWTM to aggregate displayed counter values.

To change MWTM poller refresh and counter display settings, use one of the following methods:

• The fast poller, slow poller, and status refresh poller have default minimum, maximum, and default 
settings specified in the MWTM System.properties file. To change those settings, see the “Changing 
MWTM System Poller Settings” section on page 11-24.

• To change MWTM poller refresh and counter display settings for the MWTM GUI using the 
MWTM Preferences window, see the “Poller Settings” section on page 11-8.

Connecting to a New Server
MWTM enables you to connect the client to a new MWTM server. For example, you can monitor two or 
more networks from the same MWTM client, simply by switching servers. Or, if you have two MWTM 
servers monitoring the same network, and one server fails, the MWTM client automatically switches to 
the secondary server.

If you want to determine the default host name before you connect to the new server, it is contained in 
the SERVER_NAME entry in the System.properties file:

• If you installed MWTM in the default directory, /opt, then the location of the System.properties file 
is /opt/CSCOsgm/properties/System.properties.

• If you installed MWTM in a different directory, then the System.properties file is located in that 
directory.

To connect the client to a new server, select File > Connect to New Server from the MWTM Main 
Menu. MWTM displays the Connect to New Server Dialog.
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The Connect to New Server Dialog contains the following fields and buttons:

Field or Button Description

Server Name or IP Address Name or IP address of the new server. Enter the name of the new server, 
or its IP address, in the Server Name or IP Address field.

Name Server Port UDP port number for the new server. Enter the MWTM Naming Server 
UDP port number for the new server in the Name Server Port field.

The default value is 44742.

OK Stops the MWTM client, then restarts the client connected to the 
specified server.

When you have entered the name of the new server, or its IP address, 
and its UDP port number, click OK. MWTM stops the MWTM client, 
then restarts the client connected to the new server.

Cancel Closes the Connect to New Server Dialog without connecting to the 
new server.

Help Displays online help for the Connect to New Server Dialog.
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Integrating MWTM with Other Products
MWTM does not require either CiscoWorks or HP OpenView, but MWTM does integrate with those 
products to provide added value. See the following sections for more information:

• Integrating MWTM with HP OpenView, page 3-35

• Integrating MWTM with CiscoWorks, page 3-35

• Forwarding Traps to Other Hosts (Server Only), page 3-36

Integrating MWTM with HP OpenView
MWTM can integrate with HP OpenView during installation, registering to receive forwarded traps. See 
the “Installing MWTM on Solaris” chapter of the Cisco Mobile Wireless Transport Manager Installation 
Guide for more information.

You can also integrate MWTM with HP OpenView after installation, using the mwtm trapsetup 
command. See the “mwtm trapsetup” section on page C-69 for more information.

Integrating MWTM with CiscoWorks
MWTM can integrate with CiscoWorks during installation, registering with CiscoWorks as an installed 
application. See the “Installing MWTM on Solaris” and “Installing MWTM on Windows” chapters of 
the Cisco Mobile Wireless Transport Manager Installation Guide for more information.

You can also integrate MWTM with CiscoWorks after installation, using the mwtm cwsetup command. 
See the “mwtm cwsetup” section on page C-16 for more information.

When MWTM is integrated with CiscoWorks, you can launch the CiscoWorks Device Center and 
CiscoView from the MWTM Main Menu. See the following sections for more information:

• Launching the CiscoWorks Device Center, page 3-36

• Launching CiscoView, page 3-36
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Launching the CiscoWorks Device Center

The CiscoWorks Device Center provides a number of useful Web-based device-monitoring functions, 
including reachability trends, response time trends, interface status, Syslog browsing, and a detailed 
inventory.

To link MWTM to the Device Center:

Step 1 Make sure CiscoWorks is installed in the network.

Step 2 Select a node that you know CiscoWorks is monitoring in a window. If you select a non-RAN-O  node, 
or a node with a status of Unmanaged or a Device Type of Unknown, the CiscoWorks menu option is 
grayed-out.

Step 3 Select Products > CiscoWorks > Device Center from the MWTM Main Menu.

Step 4 At the prompt, enter a CiscoWorks user ID and password. MWTM links to CiscoWorks Device Center 
dashboard.

Launching CiscoView

CiscoView provides a real-time, color-coded, graphical representation of Cisco devices. You can use 
CiscoView to quickly identify an incorrect status on a port or interface. If you are running CiscoWorks 
on UNIX or Windows, you can access CiscoView through the link to the Web version of CiscoWorks.

To link MWTM to CiscoView:

Step 1 Select a node that you know CiscoWorks is monitoring in a window. If you select a non-RAN-O  node, 
or a node with a status of Unmanaged or a Device Type of Unknown, the CiscoWorks menu option is 
grayed-out.

Step 2 Select Products > CiscoWorks >CiscoView from the MWTM Main Menu.

Step 3 At the prompt, enter a CiscoWorks user ID and password. MWTM links to CiscoView.

Forwarding Traps to Other Hosts (Server Only)
MWTM enables you to forward SNMP traps to other SNMP servers, or hosts. This enables MWTM to 
function as a trap multiplexer, integrating with high-level event- and alarm-monitoring systems such as 
the Cisco Info Center (CIC), HP OpenView, and Micromuse's Netcool suite of products. These systems 
can provide a single high-level view of all alarm monitoring in your network, making it easier to detect 
and resolve problems.

To enable MWTM to forward SNMP traps to other hosts, specify the list of hosts in the 
TrapForwarder.properties file. The default file is located in the MWTM properties directory:

• If you installed MWTM in the default directory, /opt, then the default file is located at 
/opt/CSCOsgm/properties/TrapForwarder.properties.

• If you installed MWTM in a different directory, then the default file is located in that directory.

In the TrapForwarder.properties file, begin all comment lines with a pound sign (#).

All other lines in the file are host definition lines, with the following format:
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SERVERxx=dest-address[:portno]

where:

• xx is the user-defined server number.

• dest-address is the host name, or the IP address in dotted decimal format.

• portno is the optional port number. The default port number is 162.

For example, the following host definition line:

SERVER02=64.102.86.104:162

enables MWTM to forward traps to Server 02, with IP address 64.102.86.104, on port 162.
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Any changes you make to the TrapForwarder.properties file take effect when you restart the MWTM 
server. Thereafter, MWTM forwards all traps from the listed hosts except:

• Traps that MWTM cannot parse.

• Traps from hosts listed in the trapaccess.conf file. For more information, see the “Limiting Traps by 
IP Address (Server Only)” section on page 11-29.

Version 2c traps that do not have the agent IP address already specified in the varbind list are modified 
to include the agent IP address in the varbind list.

You can also forward MWTM events to other hosts, in the form of SNMP traps. For more information, 
see the “Forwarding Events as Traps to Other Hosts” section on page 5-35.

Exporting MWTM Data
MWTM enables you to export its data for use by other products, such as CiscoWorks or Microsoft Excel. 
This section includes the following information:

• Exporting Current MWTM Data for Network Objects, page 3-39

• Exporting Current MWTM Node Names and SNMP Community Names, page 3-40

• Viewing RAN Data Export Files, page 3-40
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Exporting Current MWTM Data for Network Objects
You can use the MWTM command line interface (CLI) to export all MWTM data, or to export only 
selected MWTM data.

To export all current MWTM data, with fields separated by vertical bars (|; this is the default setting), 
enter the mwtm export all command with the -d bar keywords:

mwtm export all -d bar

To export all MWTM data with fields separated by commas (,), specify the -d comma keywords:

mwtm export all -d comma

To export all MWTM data with fields separated by tabs, specify the -d tab keywords:

mwtm export all -d tab

To export only node-specific MWTM data, specify the node keyword:

mwtm export nodes

You can also specify the -d comma or -d tab keywords on any of these object-specific mwtm export 
commands.

Here is sample output for the mwtm export nodes command:

mwtm-sun24:2> ./mwtm export nodes
# v5.0.0.9
# t1122238712043|Sun Jul 24 16:58:32 EDT 2005
#
# Total 12 nodes
# name|displayname|sgmid|old_description|cllicode|ipaddress|
old_pointcode|old_secondary|old_capability|state|statetimestamp|
ioslevel|devicetype|usericonname|sysdescr|lastpolltimestamp|
lastpolltime|avgpolltime|old_lasterrormsg|
old_lasterrortime|notesexist|old_variant|sysuptime|rebootreason|
statereason|discoveredtime|eventRcvd|telnetTo|ignore|customDisplayname|processTraps|nsocon
fig|mtp3offload|rfpeerstate|trapPollingEnabled|
reportPollingEnabledRNC_to_ems1941kb|RNC_to_ems1941kb|1215|not_used|
not_used|null|not_used|not_used|not_used|Unmanaged|1121953480035|0|RNC|null|null|-1|-1|-1|
not_used|not_used|false|not_used|-1|null|0|
1121953480036|false|null|false|null|true|not_used|not_used|not_used|
false|false|BSC_to_ems1941kb|BSC_to_ems1941kb|1219|not_used|not_used|
null|not_used|not_used|not_used|Unmanaged|1121953480044|0|BSC|null|
null|-1|-1|-1|not_used|not_used|false|not_used|-1|null|0|1121953480045|false|null|false|nu
ll|true|not_used|not_used|not_used|false|false|
BSC_to_ems1941kb|BSC_to_ems1941kb|1223|not_used|not_used|null|not_used|not_used|not_used|U
nmanaged|1121953480050|0|BSC|null|null|-1|-1|-1|
not_used|not_used|false|not_used|-1|null|0|1121953480050|false|null|
false|null|true|not_used|not_used|not_used|false|false|
BSC_to_ems1941kb|BSC_to_ems1941kb|1227|not_used|not_used|null|not_used|not_used|not_used|U
nmanaged|1121953480055|0|BSC|null|null|-1|-1|-1|
not_used|not_used|false|not_used|-1|null|0|1121953480055|false|null|
false|null|true|not_used|not_used|not_used|false|false|
ems1941kb.cisco.com|ems1941kb.cisco.com|1182|not_used|not_used|
[172.18.156.21][20.1.1.254]|not_used|not_used|not_used|Unknown|
1122221399654|1|CiscoMWR-1941-DC|null|sysDescr|1122220550854|170|170|
not_used|not_used|false|not_used|22232166|reload|8|1121953480066|false|null|false|null|tru
e|not_used|not_used|not_used|false|false|
RNC_to_ems1941ka|RNC_to_ems1941ka|1291|not_used|not_used|null|not_used|not_used|not_used|U
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nmanaged|1121953480230|0|RNC|null|null|-1|-1|-1|
not_used|not_used|false|not_used|-1|null|0|1121953480230|false|null|
false|null|true|not_used|not_used|not_used|false|false|
BSC_to_ems1941ka|BSC_to_ems1941ka|1294|not_used|not_used|null|not_used|not_used|not_used|U
nmanaged|1121953480231|0|BSC|null|null|-1|-1|-1|
not_used|not_used|false|not_used|-1|null|0|1121953480231|false|null|
false|null|true|not_used|not_used|not_used|false|false|
BSC_to_ems1941ka|BSC_to_ems1941ka|1297|not_used|not_used|null|not_used|not_used|not_used|U
nmanaged|1121953480233|0|BSC|null|null|-1|-1|-1|
not_used|not_used|false|not_used|-1|null|0|1121953480233|false|null|
false|null|true|not_used|not_used|not_used|false|false|
BSC_to_ems1941ka|BSC_to_ems1941ka|1300|not_used|not_used|null|not_used|not_used|not_used|U
nmanaged|1121953480234|0|BSC|null|null|-1|-1|-1|
not_used|not_used|false|not_used|-1|null|0|1121953480234|false|null|
false|null|true|not_used|not_used|not_used|false|false|
ems1941ka.cisco.com|ems1941ka.cisco.com|1233|not_used|not_used|
[172.18.156.20][20.1.1.253]|not_used|not_used|not_used|Warning|
1122221418932|1|CiscoMWR-1941-DC|null|sysDescr|1122238176675|312|314|
not_used|not_used|false|not_used|1752636|reload|60|1121953480235|false|null|false|null|tru
e|not_used|not_used|not_used|false|false|
JMX0710L3S9|JMX0710L3S9|1786|not_used|not_used|null|not_used|not_used|not_used|Waiting|112
1957445502|0|IPDevice|null|null|-1|-1|-1|not_used|not_used|false|not_used|-1|null|0|112195
7445502|false|null|false|null|true|not_used|not_used|not_used|false|false|JMX0710L2YY|JMX0
710L2YY|
3608|not_used|not_used|null|not_used|not_used|not_used|Waiting|
1121986548590|0|IPDevice|null|null|-1|-1|-1|not_used|not_used|false|
not_used|-1|null|0|1121986548590|false|null|false|null|true|not_used|
not_used|not_used|false|false|
#

For more information about the use of the mwtm export command, see the “mwtm export” section on 
page C-21.

Exporting Current MWTM Node Names and SNMP Community Names
To export current MWTM node names and read and write SNMP community names, in CiscoWorks 
import format, with fields separated by commas (,), specify the cw keyword:

mwtm export cw

You can export this data to a file, then use the file to import the devices into the CiscoWorks 
database.

For more information about the use of the mwtm export cw command, see the “mwtm export cw” 
section on page C-21.

Viewing RAN Data Export Files
MWTM provides yearly, monthly, daily, and hourly RAN data export files for all nodes and interfaces 
known to MWTM.

To view RAN data files, select RAN Backhaul Utilization from the MWTM Server Home Page. This 
action opens the MWTM - RAN Backhaul Utilization Statistics page. Then select a year, month, day, or 
hour for a specific node. This action displays capacity planning and backhaul utilization statistics for the 
selected node and interval.
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To export the RAN data, click RAN Data Export from the menu bar of the MWTM - RAN Backhaul 
Utilization Statistics page. This action opens the File Download window. Click Open to view the export 
data or Save to download the export file to your computer.
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Using the Windows Start Menu
This section includes the following information:

• Launching the MWTM Client, page 3-42

• Launching the MWTM Event Configurator, page 3-42

• Changing the Default MWTM Server Name, page 3-43

• Changing the Default MWTM Telnet Path, page 3-43

• Launching the MWTM DOS Prompt, page 3-44

• Launching the MWTM SSL Certificate Tool, page 3-44

• Uninstalling MWTM, page 3-44

• Viewing the MWTM README File, page 3-44

Launching the MWTM Client
To launch the MWTM Client, select Start > Programs > Cisco MWTM Client > 
Launch MWTM Client from the Windows Start menu, or double-click the MWTM icon on the desktop. 
MWTM launches the MWTM Client.

Launching the MWTM Event Configurator
To launch the MWTM Event Configurator, select Start > Programs > Cisco MWTM Client > 
Launch MWTM Event Configurator from the Windows Start menu. 
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Changing the Default MWTM Server Name
If there is a failure of the IP address or host name to which your MWTM client is bound, you can change 
the default MWTM server name from the Windows Start menu.

To change the default MWTM server name, use the following procedure:

Step 1 Close all open MWTM windows.

Step 2 Select Start > Programs > Cisco MWTM Client > Modify Default MWTM Server  Name. MWTM 
opens a DOS window, and asks you to enter the name of the new default MWTM server.

Step 3 Type the name of the new default MWTM server, and press Enter. MWTM sets the default server to the 
new name you entered.

See the “Connecting to a New Server” section on page 3-33 for more information about changing the 
default MWTM server name.

Changing the Default MWTM Telnet Path
MWTM provides a default Telnet interface for Telnet sessions, but you can also specify a path to a 
different Telnet application, if you prefer.

To specify the path to the new Telnet application, use the following procedure:

Step 1 Select Start > Programs > Cisco MWTM Client > Modify Default MWTM Telnet  Path. MWTM 
opens a DOS window, and asks you to enter the full Telnet executable pathname.

Step 2 Type the new pathname, and press Enter. If you do not enter a new pathname, MWTM uses the system 
default Telnet executable. MWTM asks you to enter any special parameters you want to pass to the new 
Telnet application. The default is n, for no special parameters.
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Step 3 Type the special parameters you want to pass to the new Telnet application, and press Enter. MWTM 
uses the new Telnet application for all Telnet sessions on the MWTM client, such as when you select 
View > MWTM Server > Telnet To.

Step 4 Close the DOS window.

Launching the MWTM DOS Prompt
To launch a DOS prompt for MWTM from the Windows Start menu, select Start > Programs > 
Cisco MWTM Client > MWTM DOS Prompt. MWTM opens a DOS window, starting in the bin 
directory:

• If you installed the MWTM client in the default directory, C:\Program Files, then the DOS prompt 
starts at C:\Program Files\SGMClient\bin.

• If you installed the MWTM client in a different directory, then the bin directory is located in that 
directory.

Launching the MWTM SSL Certificate Tool
To launch the MWTM SSL Certificate Tool from the Windows Start menu, select Start > Programs > 
Cisco MWTM Client > MWTM SSL Certificate Tool.

Uninstalling MWTM
You can uninstall MWTM from the Windows Start menu. For details, see the “Uninstalling MWTM” 
section of the Cisco Mobile Wireless Transport Manager Installation Guide.

Viewing the MWTM README File
The MWTM README file contains late-breaking information about MWTM that might not be found 
in the other product documentation. To open the MWTM README file from the Windows Start menu, 
select Start > Programs > Cisco MWTM Client > View README.

Using the MWTM Command Line Interface
MWTM provides a command line interface that enables you to interact with the MWTM and with the 
Cisco IOS software operating system by entering commands and optional arguments. For more 
information, see the “MWTM Command Reference” section on page C-1.
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Running Simultaneous MWTM Sessions
MWTM uses a client/server architecture that allows you to run multiple sessions of the MWTM client 
simultaneously. Central services and database functions are provided on an MWTM server that 
communicates with multiple MWTM clients. You can install the MWTM client software on the same 
system as the MWTM server, or on a different system on the same network as the MWTM server.

Note Running more than one MWTM client on the same workstation can degrade the workstation’s 
performance.

MWTM recommends a maximum of 20 clients per MWTM server. If you connect more than 20 clients 
to a single server, the server requires additional memory and a more powerful CPU.

Exiting the MWTM Client
When you are finished monitoring network performance statistics, you can exit the MWTM client using 
the following procedure:

Step 1 From the MWTM Main Menu, select File > Exit. The Exit MWTM confirmation window is displayed.

Step 2 Click Yes to close the MWTM client application.
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