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Discovering Your RAN-O Networks Using 
MWTM

This chapter provides details on using MWTM to discover your RAN-O networks. It includes the 
following sections:

• Discovery Overview, page 2-1

• Configuring SNMP Settings, page 2-3

• Launching the Discovery Dialog, page 2-9

• Loading Seed Nodes and Seed Files, page 2-11

• Running Discovery, page 2-18

• Verifying Discovery, page 2-24

Discovery Overview
MWTM uses a discovery process to populate the MWTM database, discovering the objects in your 
network. When a new node is discovered, it is added to the database. The node is set up to be polled if 
its SNMP access is defined as out-of-band. To prevent a node from being polled, right-click the node in 
a window, select Edit > RAN Properties, and change the SNMP access to in-band.

You can run Discovery if MWTM User-Based Access is disabled, or if it is enabled and you are a 
Network Administrator or System Administrator. (For more information about user authorization levels 
in MWTM, see the “Configuring MWTM User Authentication Levels (Server Only)” section on 
page 10-6.)

To discover your network in MWTM:

Step 1 Start the MWTM client, as described in the “Starting the MWTM Client” section on page 3-4.

Step 2 If you want to change SNMP settings, do so before running Discovery. See the “Configuring SNMP 
Settings” section on page 2-3 for more information.

Step 3 Select Network > Network Discovery from the MWTM Main Menu. MWTM displays the Discovery 
Dialog. See the “Launching the Discovery Dialog” section on page 2-9 for more information.

Step 4 Select the Seed Settings tab, if it is not already selected. MWTM displays the Seed Settings panel of the 
Discovery Dialog, which enables you to create, save, load, and delete MWTM seed files. Load one or 
more seed nodes, or an existing seed file, using the procedures in the Loading Seed Nodes and Seed 
Files, page 2-11.
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Step 5 Select the Discovery tab, or click Next. MWTM displays the Discovery panel of the Discovery Dialog, 
which enables you to discover the objects in your network. See the “Running Discovery” section on 
page 2-18 for more information.

• To specify the extent of the network discovery, use the Entire Network checkbox. See the 
description of the Entire Network checkbox in the “Running Discovery” section on page 2-18 for 
more information.

• To specify whether MWTM is to keep or delete the existing database when discovering the network, 
use the Delete Existing Data checkbox. See the description of the Delete Existing Data checkbox 
in the “Running Discovery” section on page 2-18 for more information.

• To specify the maximum number of hops for discovering objects in your network, enter a value in 
the Max. Hops text box. See the description of the Max. Hops text box in the “Running Discovery” 
section on page 2-18 for more information.

Step 6 When the “Discovery In Progress” message disappears, Discovery is complete. The Discovered Nodes 
section of the Discovery panel lists all nodes that were discovered by MWTM (all nodes, including new 
and excluded nodes, not just the nodes in the current view). See the “Discovered Nodes” section on 
page 2-21 for more information.
2-2
Cisco Mobile Wireless Transport Manager User Guide 5.0

OL-7637-02



 

Chapter 2      Discovering Your RAN-O Networks Using MWTM
  Configuring SNMP Settings
Step 7 Examine the Discovered Nodes table to verify that MWTM discovered all of the nodes in the network. 
If you suspect that MWTM did not discover all of the nodes, see the “Verifying Discovery” section on 
page 2-24 for troubleshooting information. You might need to add more seed nodes and run Discovery 
again.

Step 8 When you are satisfied that MWTM discovered all of the nodes in the network, save the list of seed nodes 
in a seed file. See the “Saving a Seed File” section on page 2-13 for more information.

Related Topics:

• Backing Up or Restoring MWTM Files (Server Only), page 11-31

• Investigating Data Problems, page 12-2

Configuring SNMP Settings

Note If you want to change SNMP settings, do so before running Discovery.

If MWTM User-Based Access is disabled, or if it is enabled and you are a Network Administrator or 
System Administrator, MWTM enables you to view and change some SNMP settings.

For more information about user authorization levels in MWTM, see the “Configuring MWTM User 
Authentication Levels (Server Only)” section on page 10-6.

For more information about SNMP, refer to “Configuring SNMP Support” in the Cisco IOS Release 12.2 
Configuration Fundamentals Configuration Guide, Part 3, System Management.

To change SNMP settings in MWTM, start the MWTM client, as described in the “Starting the MWTM 
Client” section on page 3-4, then select Network > SNMP Configuration from the MWTM Main Menu. 
(If you have implemented MWTM User-Based Access, this option is available to users with 
authentication level Network Administrator [Level 4] and higher.)

MWTM displays the SNMP Configuration Dialog.

The SNMP Configuration Dialog is composed of the following sections:

• SNMP Configuration Menu, page 2-4

• SNMP Settings Table, page 2-5

• SNMP Configuration Table, page 2-6

• SNMP Configuration Buttons, page 2-7

MWTM also provides a set of commands that you can use to configure SNMP settings:

• SNMP Configuration Commands, page 2-8
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SNMP Configuration Menu
The menu on the SNMP Configuration Dialog provides the following options:

Menu Command Description

File > Save
(Ctrl-S)

Saves the SNMP configuration changes.

When you are satisfied with all of your changes to the SNMP settings, select 
the File > Save menu option. MWTM saves the changes, updates the SNMP 
information on the MWTM server in real time.

Note If another user modifies and saves the SNMP configuration before 
you save your changes, MWTM asks if you want to overwrite that 
user’s changes. If you choose to do so, the other user’s changes are 
overwritten and lost. If you choose not to do so, your changes are lost.

File > Close
(Ctrl-W)

Closes the current window.

Help > Topics
(F1)

Displays the table of contents for the MWTM online help.

Help > Window
(Shift-F1)

Displays online help for the current window.

Help > About
(F3)

Displays build date, version, SSL support, and copyright information about 
the MWTM application.
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SNMP Settings Table
The SNMP settings table displays current SNMP information for nodes in MWTM. You can edit these 
fields in the SNMP Configuration Table, page 2-6.

The SNMP configuration table contains the following columns:

Column Description

IP Address Range or 
Hostname

IP address or DNS name of a node or range of nodes. An asterisk (*) indicates 
a wildcard value.

Read Community SNMP community name used by the node for read access to the information 
maintained by the SNMP agent on the RAN-O device.

Timeout (secs) Time, in seconds, MWTM waits for a response from the node.

Retries Number of times MWTM attempts to connect to the node.

Poll Interval (mins) Time, in minutes, between polls for the node.
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SNMP Configuration Table
The SNMP configuration table enables you to change SNMP settings for a node.

The SNMP configuration table contains the following fields:

Field Description

IP Address 
Range or 
Hostname

IP address or DNS name of a node.

To change the IP address or DNS name of a node, select the node, enter the new 
address or name in the IP Address Range or Hostname field, then click Update.

IP addresses use the format x.x.x.x, where each x has one of the following values:

• An integer in the range 0 through 255.

• A range of integers separated by a dash (-), such as 10-60.

• An asterisk (*), which is equivalent to specifying 0-255.

Unlike IP addresses, you cannot specify a range of node names or use wildcards in 
node names. Each node name corresponds to a single node in the network.

The default value for this field is the IP address *.*.*.*, which MWTM uses for all 
nodes not covered by other IP address ranges or names.

Read 
Community

SNMP community name to be used by the node for read access to the information 
maintained by the SNMP agent on the RAN-O node. 

To change the SNMP community name for a node, select the node and enter the new 
name in the Read Community field, then click Update.

This new SNMP community name must match the name used by the node. The 
default name is public.

For information about exporting SNMP community names from CiscoWorks 
Resource Manager Essentials (RME), see the “Importing SNMP Community 
Names from CiscoWorks (Solaris Only)” section on page 11-2.

Timeout (secs) Time, in seconds, MWTM waits for a response from the node.

If you determine that MWTM waits too long for a response from a node, or does 
not wait long enough, you can change the timeout value. To change the time that 
MWTM waits for a response from a node, select the node and enter the new timeout 
value in the Timeout (secs) field, then click Update.

The valid range is 1 to 60 seconds. The default value is 1 second.
2-6
Cisco Mobile Wireless Transport Manager User Guide 5.0

OL-7637-02



 

Chapter 2      Discovering Your RAN-O Networks Using MWTM
  Configuring SNMP Settings
SNMP Configuration Buttons
The SNMP Configuration Dialog contains the following buttons:

Retries Number of times MWTM attempts to connect to the node.

If you determine that MWTM retries a node too many times, or not enough times, 
you can change the number of retries. To change the number of times MWTM 
attempts to connect to a node, select the node and enter the new number in the 
Retries field, then click Update.

The valid range is 0 to 99. The default value is 2 retries.

Poll Interval 
(mins)

Time, in minutes, between polls for the node.

If you determine that MWTM polls a node too often, or not often enough, you can 
change the poll interval. To change the time, in minutes, between polls for a node, 
select the node and enter the new interval in the Poll Interval (mins) field, then 
click Update.

The valid range is 5 to 1440. The default value is 15 minutes.

Field Description

Button Description

Add Adds the new SNMP settings to the MWTM database.

To add a new node or range of nodes, enter the SNMP information in the appropriate fields 
and click Add. The new SNMP settings are added to the MWTM database.

Update Applies the values in the SNMP configuration fields to the selected node or range of 
nodes.

Delete Deletes the selected node or range of nodes.

To delete a node, select it and click Delete. MWTM deletes the node without asking for 
confirmation.
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SNMP Configuration Commands
MWTM also provides the following SNMP-related commands:

• To set a new default SNMP read community name, use the mwtm snmpcomm command.

• To change the file used for SNMP parameters, such as community names, timeouts, and retries, use 
the mwtm snmpconf command.

• To query a host using SNMP GetRequests, use the mwtm snmpget command.

• To query a host using SNMP GetNextRequests, use the mwtm snmpnext command.

• To query a host, using SNMP GetNextRequests to “walk” through the MIB, use the mwtm 
snmpwalk command.

For more information on the use of these commands, see the “MWTM Command Reference” section on 
page C-1.
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Launching the Discovery Dialog
To launch the Discovery Dialog and begin the Discovery process, select Network > Network Discovery 
from the MWTM Main Menu. MWTM displays the Discovery Dialog.

The Discovery Dialog enables you to load and configure seed nodes, and use those seed nodes to 
discover the objects in your network.

If you start the MWTM client and the MWTM database is empty (including the very first time you start 
the MWTM client), MWTM automatically opens the Discovery Dialog so you can run Discovery and 
populate the database.

The Discovery Dialog is composed of the following sections:

• Discovery Dialog Menu, page 2-10

• Discovery Dialog Tabs, page 2-11
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Discovery Dialog Menu
The menu on the Discovery Dialog provides the following options:

Menu Command Description

File > Load Seeds
(Ctrl-L)

Opens the Load File Dialog: Seed File List, enabling you to load a 
seed file into MWTM:

• Enter the name of the seed file, and click OK to load it.

• Click Cancel to return to the Seed Settings panel without 
loading a seed file.

File > Save Seeds
(Ctrl-S)

Opens the Save File Dialog: Seed File List, which enables you to 
save changes you have made to the selected seed file.

File > Save As Opens the Save File Dialog: Seed File List, which enables you to 
save changes you have made to the selected seed file with a new 
name, or overwrite an existing seed file.

File > Close
(Ctrl-W)

Closes the current window.

Edit > SNMP Configuration
(Ctrl-B)

Opens the SNMP Configuration Dialog.

If you have implemented MWTM User-Based Access, this option is 
available to users with authentication level Network Administrator 
(Level 4) and higher.

Help > Topics
(F1)

Displays the table of contents for the MWTM online help.

Help > Window
(Shift-F1)

Displays online help for the current window.

Help > About
(F3)

Displays build date, version, SSL support, and copyright 
information about the MWTM application.
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Discovery Dialog Tabs
The Discovery Dialog contains the following tabs:

Loading Seed Nodes and Seed Files
MWTM enables you to load one or more new seed nodes, or to create, save, load, and delete existing 
MWTM seed files.

This section includes the following information:

• Loading a Seed Node, page 2-11

• Loading a Seed File, page 2-11

• Saving a Seed File, page 2-13

• Creating a New Seed File, page 2-15

• Creating a New Seed File, page 2-15

• Creating and Changing Seed Files Using a Text Editor, page 2-17

Loading a Seed Node
To load a seed node, enter the name or IP address of the seed node in the IP Address or DNS Hostname 
field, and click Add Node (or press Enter). MWTM displays details of the SNMP settings for the seed 
nodes in the right pane of the window.

Continue adding seed nodes until you are certain that MWTM will be able to discover the entire network.

Loading a Seed File
If you have already created and saved one or more seed files, you can load a seed file, change the list of 
seed files, and select one seed file to be loaded automatically when the MWTM client is started or the 
Discovery Dialog is opened.

To load an existing seed file, select File > Load Seeds from the Discovery Dialog menu. SGM displays 
the Load File Dialog: Seed File List dialog.

The Load File Dialog: Seed File List contains the following fields and buttons:

Tab Description

Seed Settings Displays the Seed Settings panel in the Discovery Dialog.

Discovery Displays the Discovery panel in the Discovery Dialog.

Field or Button Description

Type Icon indicating whether the item in the table is a file or a folder.

Name Name of the seed file or folder.

Last Modified Date and time the seed file or folder was last modified.
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Size (bytes) Size of the seed file or folder, in bytes.

Make this my preferred start 
option

Specifies whether the selected seed file is to be loaded 
automatically whenever this MWTM client is started or the 
Discovery Dialog is opened.

By default, this checkbox is cleared for all seed files. That is, no 
seed file is loaded automatically when the MWTM client is 
started or the Discovery Dialog is opened.

Number of Files
(displayed in bottom left corner)

Total number of seed files and folders.

OK Loads the selected seed file, saves any changes you made to the 
list of files, and closes the dialog.

To load a seed file, double-click it in the list, select it in the list 
and click OK, or enter the name of the file and click OK.

MWTM saves any changes you made to the list of files, closes the 
Load File Dialog: Seed File List dialog, loads the seed file, and 
returns to the Discovery Dialog. MWTM lists all of the seed 
nodes in the seed file in the left pane of the window, and displays 
details of the SNMP settings for the seed nodes in the right pane.

Delete Deletes the selected file from the seed file list. MWTM issues an 
informational message containing the name and location of the 
deleted file.

Cancel Closes the dialog without loading a seed file or saving any 
changes to the seed file list.

Help Displays online help for the dialog.

Field or Button Description
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Saving a Seed File
MWTM enables you to save a specific seed file, change the list of seed files, and select one seed file to 
be loaded automatically when the MWTM client is started or the Discovery Dialog is opened.

When you are satisfied that MWTM has discovered all of the nodes in the network, save the list of seed 
nodes in a seed file, using one of the following procedures:

• To save the changes you have made to the seed file without changing the name of the file, select File 
> Save from the Discovery Dialog menu.

• To save the changes you have made to the seed file with a new name, select File > Save As from the 
Discovery Dialog menu. MWTM displays the Save File Dialog: Seed File List dialog.

MWTM stores the seed file in the seed file directory on the MWTM server:

• If you installed MWTM in the default directory, /opt, then the MWTM seed file directory is 
/opt/CSCOsgm/seeds.

• If you installed MWTM in a different directory, then the MWTM seed file directory is located in 
that directory.

Note If another user modifies and saves the seed file before you save your changes, MWTM asks if you want 
to overwrite that user’s changes. If you choose to do so, the other user’s changes are overwritten and lost. 
If you choose not to do so, your changes are lost, unless you save the seed file to a different filename.

The Save File Dialog: Seed File List contains the following fields and buttons:

Field or Button Description

Type Icon indicating whether the item in the table is a file or a folder.

Name Name of the seed file or folder.

Last Modified Date and time the seed file or folder was last modified.

Size (bytes) Size of the seed file or folder, in bytes.

Filename Name by which you want to save the seed file.

If you create a new seed file name, you can use any letters, 
numbers, or characters in the name that are allowed by your 
operating system. However, if you include any spaces in the new 
name, MWTM converts those spaces to dashes. For example, 
MWTM saves file “a b c” as “a-b-c”.

Make this my preferred start 
option

Specifies whether the selected seed file is to be loaded 
automatically whenever this MWTM client is started or the 
Discovery Dialog is opened.

By default, this checkbox is cleared for all seed files. That is, no 
seed file is loaded automatically when the MWTM client is 
started or the Discovery Dialog is opened.

Number of Files
(displayed in bottom left corner)

Total number of seed files and folders.
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OK Saves the seed file and any changes you made to the seed file list 
and closes the dialog.

To save the seed file with a new name, use one of the following 
procedures:

• To save the file with a completely new name, enter the new 
name and click OK.

• To save the file with an existing name, overwriting an old 
seed file, select the name in the list and click OK.

MWTM saves the seed file with the new name, saves any changes 
you made to the list of files, closes the Save File Dialog: Seed File 
List dialog, and returns to the Discovery Dialog.

Delete Deletes the selected file from the seed file list. MWTM issues an 
informational message containing the name and location of the 
deleted file.

Cancel Closes the dialog without saving the seed file or saving any 
changes to the seed file list.

Help Displays online help for the dialog.

Field or Button Description
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Creating a New Seed File
To create a new seed file in MWTM, launch the Discovery Dialog, as described in the “Launching the 
Discovery Dialog” section on page 2-9, then select the Seed Settings tab, if it is not already selected. 
MWTM displays the Seed Settings panel.

The Seed Settings panel in the Discovery Dialog enables you to create, save, load, and delete MWTM 
seed files.

The Seed Settings panel on the Discovery Dialog contains the following fields and buttons:

Field or Button Description

Seed Nodes Lists the seed nodes currently defined in MWTM.

IP Address Range 
or Hostname

IP address of the seed node. The default is *.*.*.*.

Retries Number of times MWTM attempts to connect to the seed node. The valid range 
is 0 to 99. The default value is 2.

Timeout (sec) Time, in seconds, MWTM waits for a response from the seed node. The valid 
range is 0 (no timeout) to 9999. The default value is 1 second.

Read Community SNMP community name for read access to the information maintained by the 
SNMP agent on the RAN-O device. This value can be up to 32 characters in 
length. Do not include special characters such as ` @ $ ^ * ' '' & |. This value is 
usually set to public (the default).

Poll Interval 
(mins)

Time, in minutes, between polls. The valid range is 0 to 9999. The default value 
is 15 minutes.

IP Address, 
Address range, 
Subnet, CIDR, or 
DNS Hostname

Address or name of the selected seed node.

To create a new seed file, enter the name or address of a seed node in this field. 
Examples of acceptable input include:

• IP Address: 1.2.3.4

• Address Range: 1.2.3.2-15

• Subnet, CIDR: 1.2.3.0/24, 1.2.3.0/255.255.255.0

• DNS Hostname: mwtm.cisco.com

MWTM displays details of the SNMP settings for the seed node in the right pane 
of the window. 

Continue to add as many seed nodes as necessary to discover your entire network.

When you are ready to save the list of seed nodes in a new seed file, select File 
> Save As from the Discovery Dialog menu. MWTM displays the Save File 
Dialog: Seed File List dialog. See the “Saving a Seed File” section on page 2-13 
for more information about saving seed files.

Add Node Adds a new seed node to MWTM.
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Changing an Existing Seed File
To change an existing seed file in MWTM, load the seed file as described in the “Loading a Seed File” 
section on page 2-11.

To add another seed node to the seed file, enter the name or IP address of the seed node in the IP Address 
or DNS Hostname field, and click Add Node.

To delete a seed node from the seed file, select the seed node and click Delete.

When you are ready to save the modified seed file, use the procedure described in the “Saving a Seed 
File” section on page 2-13.

Delete Node Deletes the selected seed node. MWTM deletes the seed node without asking for 
confirmation.

Next Displays the Discovery panel in the Discovery Dialog.

If you enter a seed node IP address or name in the IP Address or DNS Hostname 
field, then click Next, MWTM automatically adds the seed node before 
displaying the Discovery panel.

Field or Button Description
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Creating and Changing Seed Files Using a Text Editor
A seed file is simply an unformatted list of seed node names. To create a seed file using a text editor, 
simply create a file and list the seed node names, one on each line, with no other formatting:

new-york-a

new-york-b

chicago-c

When you save and name the seed file, keep the following considerations in mind:

• You can use any letters, numbers, or characters in the name that are allowed by your operating 
system, except blanks.

• MWTM saves the seed file with a .see file extension.

• MWTM saves the seed file in the MWTM server’s seed file directory, seeds:

– If you installed MWTM in the default directory, /opt, then the seed file directory is 
/opt/CSCOsgm/seeds/.

– If you installed MWTM in a different directory, then the seed file directory is located in that 
directory.

When MWTM loads the seed file, it verifies the syntax of the file, deleting blank lines and extraneous 
leading and trailing spaces as needed. MWTM also verifies that each seed node name resolves to a valid 
IP address. If a name does not resolve to a valid IP address, MWTM logs the erroneous entry and ignores 
it.

For example, given the following seed file:

new-york-a<space>

<space>new-york-b

zzzzzzzzzzzz

<blank line>

<tab>chicago-c<tab>
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MWTM loads the following entries:

new-york-a

new-york-b

chicago-c

Running Discovery
The Discovery panel in the Discovery Dialog enables you to discover the objects in your network.

To display the Discovery panel, launch the Discovery Dialog, as described in the “Launching the 
Discovery Dialog” section on page 2-9, then select the Discovery tab in the Discovery Dialog, or click 
Next in the Seed Settings panel. MWTM displays the Discovery panel. (If you enter a seed node IP 
address or name in the IP Address, Address range, Subnet, CIDR, or DNS Hostname field, then click 
Next, MWTM automatically adds the seed node before displaying the Discovery panel.) 

The Discovery panel is composed of the following sections:

• Discovery Settings, page 2-19

• Discovered Nodes, page 2-21

Related Topics:

• Discovery Overview, page 2-1

• Polling a Node, page 6-53
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Discovery Settings
The Discovery Settings section of the Discovery panel contains the following fields and button:

Field or Button Description

Entire Network Checkbox used to specify the extent of the network discovery:

• To discover the entire network, select this checkbox. This is called recursive 
discovery, and it is the default setting.

With this checkbox selected, MWTM discovers all seed nodes and attempts to 
manage them; then attempts to discover and manage all RAN-O nodes that are 
adjacent to those seed nodes (unless the nodes are connected by serial links 
only); then attempts to discover and manage all RAN-O nodes that are adjacent 
to those nodes; and so on, until MWTM has discovered the entire network.

• To rediscover only seed nodes, clear this checkbox. This is called nonrecursive 
discovery.

With this checkbox cleared, MWTM discovers all seed nodes and attempts to 
manage them, then labels all nodes that are adjacent to those seed nodes 
Unmanaged.

Delete Existing 
Data

Checkbox used to keep or delete the existing MWTM database when discovering 
the network:

• To keep all existing network data in the MWTM database before rediscovering 
the network, clear this checkbox. This is the default setting.

• To delete all existing network data from the MWTM database before 
rediscovering the network, select this checkbox. Choose this option if you 
know that network elements have been deleted from your network since the last 
Discovery.

If you discover the network with Delete Existing Data selected, MWTM stops any 
real-time polls that are running and issues appropriate messages.

Max Hops The maximum number of hops from the seed node to search for other nodes to 
discover. Default is 3.
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If you run Discovery with Entire Network cleared, then you run Discovery with Entire Network 
selected, any Unmanaged nodes in the first Discovery are not rediscovered by the second Discovery.

To recover from this situation and generate a new, complete, and reliable MWTM database, you must 
perform one of the following procedures:

1. Run Discovery again, with both Entire Network and Delete Existing Data selected.

2. Change the Unmanaged nodes to managed status. See the “Unmanaging and Managing a Node” 
section on page 6-51 for more information.

Discover 
Network

Begins discovering the network.

Click Discover Network to begin Discovery.

If you have not defined at least one seed node in the Seed Settings panel, MWTM 
prompts you to do so.

When Discovery begins:

• The Discover Network button changes to Stop Discovery.

• The “Discovery In Progress” message is displayed in the title bar of all MWTM 
client windows.

Discovery progresses in bursts. You might see a number of updates, followed by a 
pause, followed by more updates. The information displayed in MWTM windows 
is not fully updated until Discovery is complete.

By default, Discovery times out after 600 seconds (10 minutes). To change the 
Discovery timeout, change the value of the DISCOVERY_TIMELIMIT entry in the 
Server.properties file:

• If you installed MWTM in the default directory, /opt, then the location of the 
Server.properties file is /opt/CSCOsgm/properties/Server.properties.

• If you installed MWTM in a different directory, then the Server.properties file 
is located in that directory.

Because MWTM is an asynchronous system, with the MWTM server contacting 
clients one at a time, and because clients might run at different speeds, the 
information displayed by MWTM clients during Discovery might not always be 
synchronized.

All other MWTM windows (Node, Topology, and so on) are also populated with 
the newly discovered network data.

Stop Discovery Stops the Discovery process. For example, if you click Discover Network, then 
you realize that you loaded a seed node that you did not intend to load, you can 
click Stop Discovery to stop the Discovery process.

Note If you stop the Discovery process, the information in the MWTM database 
is incomplete and unreliable. To generate a new, complete, and reliable 
MWTM database, you must run Discovery again, with Delete Existing 
Data selected.

This button replaces the Discover Network button when the Discovery process 
begins, and changes back to the Discover Network button when the Discovery 
process ends.

Field or Button Description
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3. Poll the nodes that were Unmanaged in the first Discovery. See the “Polling a Node” section on 
page 6-53 for more information.

Discovered Nodes
The Discovered Nodes section of the Discovery panel lists all nodes that have been discovered by 
MWTM (all nodes, including new and excluded nodes, not just the nodes in the current view). By 
default, this table is sorted by Status.

To see mouse over help popup for each column in the table, place the cursor over a column header.

If a cell is too small to show all of its data, place the cursor over the cell to see the full data in a mouse 
over help popup.

You can resize each column, or sort the table based on the information in one of the columns. By default, 
MWTM displays all of the columns in the Discovered Nodes section except Internal ID, Router 
Uptime, Reboot Reason, Process Traps, and Last Status Change.

• To display hidden columns, right-click in the table header and select the checkboxes for the columns 
you want to display.

• To hide columns, right-click in the table header and clear the checkboxes for the columns you want 
to hide.

See the “Resizing, Sorting, and Hiding Table Columns” section on page 3-30 for more information about 
resizing, sorting, displaying, or hiding columns.
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The Discovered Nodes section contains the following columns and buttons:

Column or Button Description

Internal ID Internal ID of the event. The internal ID is a unique ID for every object, assigned 
by MWTM for its own internal use. It can also be useful when the TAC is 
debugging problems.

Name Name or IP address of the discovered node.

All discovered nodes are placed in a DEFAULT configuration view, which is 
stored on the MWTM server and shared by all MWTM clients. Initially, all 
clients use the DEFAULT view. Clients can then create their own views, which 
are subsets of the DEFAULT view, to meet their individual needs. However, the 
DEFAULT view stored on the MWTM server cannot be modified by the clients. 
It is always available, for users who need to view the entire network.

Primary SNMP 
Address

IP address of the node, used by SNMP to poll the node. (There might be other 
IP addresses on the node that are not the primary SNMP address.)

Device Type Device type of the node. Possible values are:

• CiscoMWR-1941-A—Cisco MWR-1941-DC-A series router

• CiscoMWR1900—Cisco Mobile Wireless Router 1900

• BSC—Base Station Controller

• BTS—Base Transceiver Station

• Node-B—Radio transmission/reception unit for communication between 
radio cells in UMTS network

• RNC—Radio Network Controller

• IPDevice—IP device, other than those listed above. You can assign this icon 
to an unknown node if you know that it is an IP device.

• Unknown—MWTM is unable to determine the device type.

IOS MIB Level MIB conformance level used by the RAN-O device.

Trap Polling Indicates whether trap polling is enabled or not. This checkbox is read-only. 

• If you want to enable trap polling for this node, set ipran-mib snmp-access 
to inBand on the device.

• If you want to disable trap polling for this node, set ipran-mib snmp-access 
to outOfBand on the device.

Report Polling Indicates whether report polling is enabled or not. This checkbox is read-only. 

• If you want to enable report polling for this node, set ipran-mib location to 
aggSite on the device.

• If you want to disable report polling for this node, set ipran-mib location to 
cellSite on the device.

Router Uptime Time the RAN-O device has been up, in days, hours, minutes, and seconds.

Reboot Reason Reason for the last reboot of the RAN-O device.
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Ignored Indicates whether the node is to be included when aggregating and displaying 
MWTM status information:

• Clear the checkbox to include the node. This is the default setting.

• Select the checkbox to exclude the node.

This field can be edited by users with authentication level Power User (Level 2) 
and higher.

Process Traps Indicates whether MWTM is to process traps from this node:

• Select the checkbox if you want MWTM to process traps from this node. 
This is the default setting.

• Clear the checkbox if you do not want MWTM to process traps from this 
node.

This field can be edited by users with authentication level Power User (Level 4) 
and higher.

Notes Indicates whether there is a note associated with the node.

Events Indicates whether there is a recent event associated with the node. (Even if the 
server purges all of the events associated with the node, MWTM continues to 
display the event icon in this field.)

During Discovery, MWTM might flag most nodes with an event icon (orange 
triangle). If the event icons are too distracting, select Edit > Clear All Events 
from the MWTM Main Menu to remove them.

Last Status 
Change

Date and time that the status of the node last changed.

Status Current status of the node. Possible values are:

Active

Discovering

Polling

Unknown

Unmanaged

Waiting

Warning

For detailed definitions of each status, see the “Status Definitions for Nodes” 
section on page A-4.

Column or Button Description
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Verifying Discovery
After you discover the network (see the “Discovery Overview” section on page 2-1), examine the 
Discovered Nodes table to verify that MWTM discovered all of the RAN-O nodes in the network. If you 
suspect that MWTM did not discover all of the RAN-O nodes, verify the following conditions:

• Verify that no nodes are excluded from your current view.

• Verify that the MWTM server can ping the nodes.

• Verify that the nodes are running images that are compatible with the MWTM server.

• Verify that SNMP is enabled on the nodes.

• Verify that MWTM is configured with the correct SNMP community name. See the “Configuring 
SNMP Settings” section on page 2-3 for details.

• Verify that you selected Entire Network when you ran Discovery. If you suspect that you did not, 
run Discovery again with Entire Network selected.

Status Reason Reason for the current status of the object.

For a full list of possible reasons, see the stateReasons.html file:

• If you installed MWTM in the default directory, /opt, then the file is located 
at /opt/CSCOsgm/apache/share/htdocs/eventHelp directory.

• If you installed MWTM in a different directory, then the help directory and 
file are located in that directory.

If the cell is too small to show all of the status reason, place the cursor over the 
cell to see the full status reason in a mouse over help popup.

The status reasons are listed in order of decreasing magnitude. If two or more 
reasons apply, the reason of greatest magnitude is displayed.

If the status reason is Unsupported Configuration, correct the configuration 
and enter the mwtm cleandiscover command to delete all current network data 
and begin a clean discovery of the RAN-O network. If the status reason is still 
Unsupported Configuration, enter the mwtm clean command to restore the 
MWTM server to a “clean” state, such as would exist after a new installation of 
MWTM. For more information on the use of these commands, see the “MWTM 
Command Reference” section on page C-1.

Back Displays the Seed Settings panel in the Discovery Dialog.

Delete Deletes the selected node or nodes from the Discovery database. MWTM deletes 
the nodes without asking for confirmation.

Poll Node Begins a poll of all nodes selected in the Discovered Nodes section of the 
Discovery panel.

You cannot poll a node with a Primary SNMP Address of N/A:

• If you select a node with a Primary SNMP Address of N/A, then the Poll 
button is grayed-out and cannot be selected.

• If you select more than one node, and even one of them has a Primary 
SNMP Address of N/A, then the Poll button is grayed-out and cannot be 
selected.

Column or Button Description
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