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Working with Interfaces

MWTM enables you to view information about all discovered interfaces, including their status and other 
important information.

This section includes the following information:

• Viewing Detailed Information for an Interface, page 7-1

• Attaching a Note to an Interface, page 7-13

• Viewing Notes for an Interface, page 7-14

• Deleting an Interface, page 7-14

• Ignoring an Interface, page 7-16

Related Topics:

• Changing MWTM Client Preference Settings, page 11-2

• Resizing, Sorting, and Hiding Table Columns, page 3-30

Viewing Detailed Information for an Interface
MWTM can display detailed information about a selected interface, including its status and other 
information.

Updates for the interface that are received from the MWTM server are reflected automatically in this 
window.

To display detailed information for an interface, select the turner beside Nodes in the left pane of the 
MWTM Main Window. Then select the turner beside a specific node to display its interfaces. Finally, 
select an interface.

MWTM displays the Interface Details Window.

The Interface Details Window is composed of the following sections:

• Interface Details: Right-Click Menu, page 7-2

• Interface Details: Configuration Details, page 7-4

• Interface Details: Notes, page 7-9

• Interface Details: Recent Events, page 7-10

Related Topics:

• Viewing Detailed Information for a Node, page 6-10
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Interface Details: Right-Click Menu
The Interface Details Window provides a right-click menu. To see this menu, select an interface in the 
left pane and click the right mouse button. The interface details right-click menu provides the following 
options:

Menu Command Description

Show In New Window Opens the Interface Details Window for the selected 
interface in a new window.

Edit > Notes Opens the Edit Notes Dialog for the selected interface.

If you have implemented MWTM User-Based Access, this 
option is available to users with authentication level Power 
User (Level 2) and higher.

Clear Event Icon Deletes the event icon (orange triangle) from MWTM 
displays for the selected interface, for this MWTM client 
only. The actual events are not deleted from MWTM, only 
the event icon for the selected interface for this MWTM 
client.

This option is grayed-out if the selected interface has no 
associated event icon.

Delete Deletes the currently selected interface from the MWTM 
database. MWTM displays the Confirm Deletion dialog:

• To delete the selected interface, click Yes. The 
interface is deleted from the MWTM database and the 
Confirm Deletion dialog is closed.

• To retain the selected interface, click No. The interface 
is kept in the MWTM database and the Confirm 
Deletion dialog is closed.

• To prevent MWTM from displaying the Confirm 
Deletion dialog, select the Do not show this again 
checkbox.

Note If you select the Do not show this again checkbox, 
and you later decide you want MWTM to begin 
displaying the Confirm Deletion dialog again, you 
must select the Confirm Deletions checkbox in the 
General GUI settings in the Preferences window. 
For more information, see the description of the 
Confirm Deletions checkbox in the “Startup/Exit 
Settings” section on page 11-6.

If you have implemented MWTM User-Based Access, this 
option is available to users with authentication level 
Network Administrator (Level 4) and higher.

Go to > Parent Node Navigates to the Node Details window of the parent node.

Back > List of Windows Navigates back to a window viewed in this session.

MWTM maintains a list of up to 10 Back windows.
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Forward > List of Windows Navigates forward to a window viewed in this session.

MWTM maintains a list of up to 10 Forward windows.

View > Configuration Details Displays the Configuration Details panel for the selected 
interface.

View > Notes Displays the Notes panel for the selected interface.

If there are no notes associated with the selected interface, 
this option is grayed-out.

View > Events Displays the Recent Events panel for the selected interface 
and its associated network objects.

View > Center in Topo Opens the Topology Window and displays the interface in 
the center of the topology map.

Event History > Status Change 
Messages

Displays the MWTM Network Status Log for Status 
Change Messages in a Web browser, with messages 
displayed for only the selected node.

Event History > SNMP Trap Messages Displays the MWTM Network Status Log for SNMP Trap 
Messages in a Web browser, with messages displayed for 
only the selected interface.

Event History > Status and Trap 
Messages

Displays the MWTM Network Status Log for Status 
Change Messages and SNMP Trap Messages in a Web 
browser, with messages displayed for only the selected 
interface.

Event History > Network Status 
Metrics

Displays the MWTM Network Status Log for Metrics in a 
Web browser, with messages displayed for only the 
selected interface.

Ignore Ignores the selected interface at the next polling cycle.

If you have implemented MWTM User-Based Access, this 
option is available to users with authentication level Power 
User (Level 2) and higher.

Unignore Stops ignoring the selected interface at the next polling 
cycle.

If you have implemented MWTM User-Based Access, this 
option is available to users with authentication level Power 
User (Level 2) and higher.

Latest Reports > RAN Capacity 
Planning

Displays the RAN Capacity Planning Report for the 
interface, in a Web browser.

This option is not available if the interface is in Unknown 
or Unmanaged status.

Latest Reports > RAN Statistics Displays the RAN Backhaul 15 Minutes Statistics report 
associated with the interface, in a Web browser.

This option is not available if the interface is in Unknown 
or Unmanaged status.

Menu Command Description
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Interface Details: Configuration Details
The Interface Details: Configuration Details section is composed of the following sub-sections:

• Naming Information, page 7-4

• General Information, page 7-5

• Status Information, page 7-5

• RAN Information, page 7-9

Naming Information

The Naming Information sub-section contains the following fields:

Field Description

Name Name of the interface.

Node Name of the node to which the interface belongs.

Physical Address Physical address of the interface.

IF Index Interface index number.

IF Type Interface type.

RAN Connection 
To

Node to which the interface is connected.
7-4
Cisco Mobile Wireless Transport Manager User Guide 5.0

OL-7637-02



 

Chapter 7      Working with Interfaces
  Viewing Detailed Information for an Interface
General Information

The General Information sub-section contains the following fields:

Status Information

The Status Information sub-section contains the following fields:

Field Description

Maximum Packet 
Size

Maximum packet size on the interface, in bytes.

Speed (Bits/Sec) Interface speed in bits per second.

Field Description

Is Ignored Indicates whether the interface is Ignored (that is, whether the interface is to 
be included when aggregating and displaying MWTM status information).

Admin Status Displays the administrative status of the interface. Status can be:

Unknown—Unknown administrative status

Up —Administratively up

Shutdown—Administratively down

Testing—Administrator is testing the interface

Operational Status Displays the operational status of the interface. Status can be:

Unknown—Unknown operational status.

Up —Interface is up.

Down—Interface is down.

Testing—Interface is in test mode.

Dormant—Interface is dormant.

Not Present —An interface component is missing.

Lower Layer Down —An interface is down because of a lower-layer interface.
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Connect State
(for GSM Abis)

Displays the connection state of a GSM interface. States can be:

Connected —The device is monitoring local and remote alarm status.

Disconnected—The system ignores the local alarm status. The local 
transmitter on the short-haul is disabled. Capabilitymessages are transmitted to 
the remote describing the provisioning. The system stays disconnected until 
the remote capabilities are known and the peer state is transitioned to 
connected.

Send Connect —One or more attempts have been made to connect to remote 
peer.

Receive Connect —The local-peer has received a connect request from the 
remote-peer.

Connect Rejected —Connection was rejected.

ACK Connect —The initial connect request was sent and acknowledged by 
remote-peer. The local-peer is now waiting for a connect request from the 
remote-peer.

Check Connect —The local peer has reason to believe its remote peer has 
failed. Additional tests are being processed to verify peer's state.

Connect State 
(for UMTS Iub)

Displays the connection state of a UMTS interface. States can be:

Initialized —The connection is starting initialization.

Starting—The shorthaul interface is administratively active, but the backhaul 
interface is down.

Closed—The backhaul interface is active, but the shorthaul is administratively 
closed.

Stopped—Unable to connect to peer in specified time interval. Additional 
attempts will be tried based on peer request or restart timers.

Closing—Connection closed by administration request.

Stopping —Connection shut down by peer's Term-Request. Will transition to 
stopped state. 

Connect Sent —Connection request sent to peer.

ACK Received —Connection request sent and acknowledgement has been 
received from peer. Now waiting for peer's connection request.

ACK Sent —Connection request received and acknowledgement has been sent 
to peer. Connection request sent and waiting for peer's acknowledgement.

Open —Connection open and available for traffic.

Field Description
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Local Receive Alarm 
State

Local Transmit 
Alarm State

Remote Receive 
Alarm State

Remote Transmit 
Alarm State

Displays alarm states for UMTS Iub interface. States can be:

Remote Alarm —Indicates a problem at the remote end. The alarm generated 
by the remote interface in the E1/T1 data stream is sent and no other action is 
required. 

No Alarm —No alarm is present. 

Local Alarm —Indicates local interface problem. The interface has not 
received synchronization from the GSM device. Device stops transmitting 
backhaul samples.

Received Alarm —Indicates receive problem in the local device. The remote 
device stops transmitting backhaul data and indicates a blue alarm.

Alarm State Unavailable —Indicates the alarm state is not available. This 
state only applies to the remote and occurs when the peer connection is 
inactive.

Redundancy State Displays information about the GSM Abis or UMTS Iub interface redundancy 
state. States can be:

Active—Active owner of interface.

Standby—Active owner of interface.

Status Current status of the interface. Possible values are:

Active

Discovering

Down

Polling

Unknown

Unmanaged

Waiting

Warning

For detailed definitions of each status, see the “Status Definitions for Nodes” 
section on page A-4.

Field Description
7-7
Cisco Mobile Wireless Transport Manager User Guide 5.0

OL-7637-02



 

Chapter 7      Working with Interfaces
  Viewing Detailed Information for an Interface
Last Status Change Date and time of last change to status.

Status Reason Reason for the current status of the interface.

For a full list of possible reasons, see the stateReasons.html file:

• If you installed MWTM in the default directory, /opt, then the file is 
located at /opt/CSCOsgm/apache/share/htdocs/eventHelp directory.

• If you installed MWTM in a different directory, then the help directory and 
file are located in that directory.

If the cell is too small to show all of the status reason, place the cursor over the 
cell to see the full status reason in a mouse over help popup.

The status reasons are listed in order of decreasing magnitude. If two or more 
reasons apply, the reason of greatest magnitude is displayed.

If the status reason is Unsupported Configuration, correct the configuration 
and enter the mwtm cleandiscover command to delete all current network data 
and begin a clean discovery of the RAN-O network. If the status reason is still 
Unsupported Configuration, enter the mwtm clean command to restore the 
MWTM server to a “clean” state, such as would exist after a new installation 
of MWTM. For more information on the use of these commands, see the 
“MWTM Command Reference” section on page C-1.

Field Description
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RAN Information

Note This sub-section appears only for configured RAN interfaces (GSM Abis and UMTS Iub interfaces).

The RAN Information sub-section contains the following fields:

Interface Details: Notes
The Interface Details: Notes section displays:

• Notes associated with the interface.

• The date and time the notes associated with the interface were last updated, or the phrase Not Set if 
there are no notes associated with the interface.

• The phrase No Notes if there are no notes associated with the interface.

Field Description

Protocol Protocol of the interface (GSM-Abis or UMTS-Iub).

Local IP Address IP address of the local device.

Local Port Local port used by the interface.

Remote IP Address IP address of the remote (peer) device.

Remote Port Remote port used by the interface.
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Interface Details: Recent Events
The Interface Details: Recent Events table displays all recent events associated with the interface, and 
enables you to perform event-related tasks, such as setting filters and acknowledging events.

To see mouse over help popup for each column in the table, place the cursor over a column header.

If a cell is too small to show all of its data, place the cursor over the cell to see the full data in a mouse 
over help popup.

You can resize each column, or sort the table based on the information in one of the columns. By default, 
MWTM displays the following columns: Act , Category, Severity, Time, and Message.
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• To display hidden columns, right-click in the table header and select the checkboxes for the columns 
you want to display.

• To hide columns, right-click in the table header and clear the checkboxes for the columns you want 
to hide.

See the “Resizing, Sorting, and Hiding Table Columns” section on page 3-30 for more information about 
resizing, sorting, displaying, or hiding columns.

The Interface Details: Recent Events table contains the following toolbar buttons and columns:

Toolbar Button or Column Description

Set Filter Opens the Event Filter dialog.

Apply Filter

or

Remove Filter

Activates and deactivates the event filter specified in the Event Filter 
dialog:

• If the filter is activated, MWTM displays only those events that pass 
the filter.

• If the filter is deactivated, MWTM displays all events.

• If you activate a filter in an object’s Recent Events table in the 
MWTM Main Window, the filter is activated in all Recent Events 
tables in the MWTM Main Window for all other network objects. 
The filter is not activated in Recent Events tables in Show In New 
Window windows or real-time data and charts windows.

Pause

or

Resume

Pauses or resumes the table.

While the table is paused, MWTM does not display new events in the 
table (unless you apply an event filter or edit your event preferences). 
When the table is resumed, all new events since the table was paused are 
added to the display.

If events are deleted while the table is paused, they are not removed from 
the table. Instead, they are grayed-out and cannot be acknowledged or 
edited. Deleted events are removed from the table when you resume the 
table.

Acknowledge Makes the selected event or events acknowledged.

Unacknowledge Makes the selected event or events unacknowledged.

Event Properties Opens the Event Properties window.

Edit Notes Opens the Edit Event Dialog.

Time Difference Displays the difference in days, minutes, hours, and seconds between 
two events.

Find Finds specific text in the event table.

Create Sound Filter Opens the Event Sound Filters dialog and the Event Sound Filters List 
dialog, with fields populated based on the selected event.
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Adjust Row Height Adjusts the table row height and wraps the message text as follows:

• Click once to double the row height and wrap the message text.

• Click again to triple the row height and wrap the message text.

• Click again for single row height and no message text wrapping. 
This is the default setting.

This setting is saved automatically with your preferences.

Help for Event Displays context-sensitive help for the selected event in a separate Web 
browser.

Internal ID Internal ID of the event. The internal ID is a unique ID for every object, 
assigned by MWTM for its own internal use. It can also be useful when 
the TAC is debugging problems.

Ack Indicates whether the event has been acknowledged:

• To acknowledge an unacknowledged event, use the Acknowledge 
toolbar button.

• To make a previously acknowledged event unacknowledged, use the 
Unacknowledge toolbar button.

Category Type of the event. Default values are:

• Create—Creation event, such as the creation of a seed file.

• Delete—Deletion event, such as the deletion of an object or file.

• Discover—Discovery event, such as Discovery beginning.

• Edit—Edit event. A user has edited an object.

• Ignore—Ignore event. A user has Ignored a link or linkset.

• Login—Login event. A user has logged in to MWTM.

• LoginDisable—LoginDisable event. MWTM has disabled a user’s 
User-Based Access authentication as a result of too many failed 
attempts to log in to MWTM.

• LoginFail—LoginFail event. An attempt by a user to log in to 
MWTM has failed.

• Logout—Logout event. A user has logged out of MWTM.

• OverWrite—OverWrite event. An existing file, such as a seed file 
or route file, has been overwritten.

• Poll—Poll event, such as an SNMP poll.

• Purge—Purge event. A user has requested Discovery with Delete 
Existing Data selected, and MWTM has deleted the existing 
MWTM database.

• Status—Status change message generated.

• Trap—SNMP trap message generated.

You can customize this field. See the “Changing Event Categories” 
section on page 5-23 for more information.

Toolbar Button or Column Description
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Attaching a Note to an Interface
MWTM enables you to annotate an interface, attaching a descriptive string to it.

To attach a note to an interface, right-click the interface in a window, then select Edit > Notes in the 
right-click menu. MWTM displays the Edit Notes Dialog for an Interface .

The Edit Notes Dialog for an Interface contains the following fields and buttons:

Severity Severity of the event. Default values are:

• Critical—The default color is red.

• Indeterminate—The default color is aqua.

• Informational—The default color is white.

• Major—The default color is orange.

• Minor—The default color is yellow.

• Normal—The default color is green.

• Warning—The default color is blue.

You can customize this field. See the “Changing Event Severities and 
Colors” section on page 5-24 for more information.

Note Indicates whether there is a note associated with the event.

Message Name User-specified message name for the event, used by MWTM for trap 
forwarding. The default message name is MWTM.

For more information about user-specified message names and trap 
forwarding, see the “Forwarding Events as Traps to Other Hosts” section 
on page 5-35.

Time Date and time the event was logged.

Ack By If you have not implemented MWTM User-Based Access, name of the 
device that last acknowledged the event.

If you have implemented MWTM User-Based Access, name of the user 
who last acknowledged the event.

If no one has acknowledged the event, this field is blank.

Ack Time Date and time the event was last acknowledged or unacknowledged.

Node Name of the node associated with the event. If there is no node 
associated with the event, None is displayed.

Message Text of the message.

You can customize this field. See the “Changing the Way MWTM 
Processes Events” section on page 5-17 for more information.

Toolbar Button or Column Description
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Viewing Notes for an Interface
MWTM enables you to view any notes that have been associated with an interface.

To view a note for an interface, right-click a node in a window, then select View > Notes in the right-click 
menu. (The Notes option is grayed-out if there is no note associated with the selected node.)

MWTM displays the Notes panel for the selected node, which displays:

• Notes associated with the interface.

• The date and time the notes associated with the interface were last updated, or the phrase Not Set if 
there are no notes associated with the interface.

• The phrase No Notes if there are no notes associated with the interface.

Related Topics:

• Attaching a Note to an Interface, page 7-13

Deleting an Interface
After Discovery, the interfaces in your network are known to MWTM and added to the MWTM database. 
Physically deleting interfaces from your network is not the same as deleting them from the MWTM 
database. The following sections describe the differences between deleting interfaces from your 
network, from the MWTM database, and from the MWTM Discovery database, and the procedures for 
doing so:

• Deleting an Interface from Your Network, page 7-15

• Deleting an Interface from the MWTM Database, page 7-15

Field or Button Description

Name Name of the interface. You cannot edit this field.

Note Last Updated Date and time the Notes field for this interface was last updated. If there is no 
note currently associated with this interface, this field displays the value Not Set.

You cannot edit this field.

Notes Notes to associate with this interface. In this field, you can enter any important 
information about the interface, such as a detailed description, its location, its 
service history, and so on.

Save Saves changes you have made to the interface’s notes, updates all MWTM 
windows to reflect your changes, and exits the dialog.

When you annotate a node, MWTM displays a note icon in the Notes column of 
all interface tables for the annotated interface.

Cancel Exits the dialog without saving any changes.

Help Displays online help for the dialog.
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Deleting an Interface from Your Network
If you physically delete a known interface from your network (for example, by powering down a router), 
it remains in the MWTM database, MWTM labels it Unknown, and it is the system administrator’s 
responsibility to delete it from the MWTM database, if you choose to do so.

Deleting an Interface from the MWTM Database
Typically, you delete an interface from the MWTM database because you have physically deleted the 
interface from your network. This is the most common reason for deleting an interface from the MWTM 
database.

If you have physically deleted an interface from your network, and you then delete it from MWTM, it is 
no longer in the MWTM database, it does not appear in MWTM windows, and it is not discovered when 
you run Discovery.

Note If you delete an interface from the MWTM database, the interface is deleted for all MWTM clients and 
views connected to that MWTM server. If the interface is still configured on the router, it will re-appear 
on the MWTM at the next poll.

To delete an interface from the MWTM database, use one of the following procedures:

• Select an interface in a window, then select Edit > Delete from the MWTM Main Menu.

• Right-click an interface in a window, then select Delete in the right-click menu. 

MWTM asks you to confirm the deletion:

• Select Yes to delete the selected interface. MWTM deletes the interface from the MWTM database.

• Select No to return to the window without deleting any interfaces from the MWTM database.
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Ignoring an Interface
You can instruct MWTM to ignore an interface. Setting interfaces to Ignored prevents known interface 
problems from affecting MWTM displays for associated network objects. In effect, you are preventing 
a known problem from distracting you from other, more urgent network problems.

Note If you set an interface to Ignored, the interface is ignored for all MWTM clients and views connected 
to that MWTM server.

Also, if you set an interface to Ignored, make a note of the change, and do not forget to reset the interface 
when the problem is corrected or the maintenance is complete.

To set an interface to Ignored, right-click the interface in the left panel, then select Ignore from the 
right-click menu.
7-16
Cisco Mobile Wireless Transport Manager User Guide 5.0

OL-7637-02


	Working with Interfaces
	Viewing Detailed Information for an Interface
	Interface Details: Right-Click Menu
	Interface Details: Configuration Details
	Naming Information
	General Information
	Status Information
	RAN Information

	Interface Details: Notes
	Interface Details: Recent Events

	Attaching a Note to an Interface
	Viewing Notes for an Interface
	Deleting an Interface
	Deleting an Interface from Your Network
	Deleting an Interface from the MWTM Database

	Ignoring an Interface


