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Using Cisco ANA PathTracer to Diagnose 
Problems

Cisco ANA enables you to view a network path between two network objects using Cisco ANA 
PathTracer in the following types of networks:

• Circuit-switched network, such as Frame Relay or ATM

• Packet-switched networks, such as Ethernet and IP 

In addition, beginning with Cisco ANA 3.7, you can specify either IPv4 or IPv6 addresses for the source 
or destination of a path trace.

The following topics describe the Cisco ANA PathTracer working environment and the functionality 
available when using Cisco ANA PathTracer:

• User Roles Required to Work with Cisco ANA PathTracer, page 11-2

• Cisco ANA PathTracer Overview, page 11-2

• Using Cisco ANA PathTracer, page 11-3

• Cisco ANA PathTracer Multipath Window, page 11-12

• Cisco ANA PathTracer Single-Path Window, page 11-16

• Viewing Path Information, page 11-20

• Saving and Opening Cisco ANA PathTracer Map Files, page 11-20

• Saving Cisco ANA PathTracer Counter Values, page 11-21

• Rerunning a Path and Comparing Results, page 11-22

• Viewing Q-in-Q Path Information, page 11-22

• Viewing L2TP Path Information, page 11-23

• Using Cisco ANA PathTracer in MPLS Networks, page 11-24
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User Roles Required to Work with Cisco ANA PathTracer
Table 11-1 identifies the roles that are required to work with Cisco ANA PathTracer. Cisco ANA 
determines whether you are authorized to perform a task as follows: 

• For GUI-based tasks (tasks that do not affect devices), authorization is based on the default 
permission that is assigned to your user account. 

• For device-based tasks (tasks that do affect devices), authorization is based on the default 
permission that is assigned to your account. That is, whether the device is in one of your assigned 
scopes and whether you meet the minimum security level for that scope. 

For more information on user authorization, see the Cisco Active Network Abstraction 3.7.1 
Administrator Guide.

Cisco ANA PathTracer Overview
Cisco ANA PathTracer enables end-to-end route tracing to be performed with informative performance 
information displayed simultaneously for the multiple networking layers. Upon receiving a path's start 
and endpoint, Cisco ANA PathTracer visually traces the route through the network. For example, in an 
ATM network environment, Cisco ANA PathTracer identifies all information regarding the connection 
of a subscriber to a provider, including all ATM PVCs, ATM switching tables, ATM class of service 
(CoS) definitions, IP-related information, and so on. You can also use Cisco ANA PathTracer to: 

• Trace paths using IPv4, IPv6, or both IPv4 and IPv6 addresses for the source and destination.

• Trace a hypothetical Ethernet frame from a VLAN interface to a specified MAC address.

• Trace a hypothetical Ethernet frame from an Ethernet interface to a specified MAC address within 
a specific VLAN ID.

Cisco ANA PathTracer can also be used for the following MPLS and Carrier Ethernet technologies: 

• Path trace across VLANs—Follows the path based on forwarding table, which means the trace 
follows ports in Forwarding STP state.

• Path trace across Q-in-Q—Creates a single path trace (if the MAC address is learned) or 
multiple-path (multipath) trace if the MAC address is not in the forwarding table. If the VLAN 
bridge has not learned a given MAC address, the bridge floods the Ethernet frame to the confines of 
a given VLAN or switching entity and across those ports that allow the given VLAN ID. A 

Table 11-1 Default Permission/Security Level Required for Working with Cisco ANA PathTracer

Task Viewer Operator OperatorPlus Configurator Administrator

Launch a path trace — — — — X

View path information — — — — X

Save Cisco ANA 
PathTracer map files

— — — — X

Save Cisco ANA 
PathTracer counter 
values

— — — — X

Rerun a path and 
compare results

— — — — X
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MAC/VLAN path trace can be conducted from a CE-VLAN interface across an SP-VLAN, that is, 
across Q-in-Q configurations with the CE-VLAN ID as inner VLAN ID and Cisco ANA PathTracer 
detecting the outer SP-VLAN ID that encapsulates the CE-VLAN.

• Path trace across pseudowires (also known as EoMPLS) —A MAC/VLAN path trace can be 
conducted from a VLAN interface across a VLAN attachment to a pseudowire.

• VLAN-VPLS-VLAN path trace—A multi-point MAC/VLAN path trace can be conducted on 
CE-VLANs across service provider VPLS transport from a VLAN interface that attaches to the 
VPLS.

• MAC address not reachable— If Cisco ANA PathTracer cannot complete a MAC/VLAN path trace 
to a specified destination MAC address across an MPLS core, VPLS, or H-VPLS, then Cisco ANA 
PathTracer displays the portion of the path that Cisco ANA PathTracer was able to trace toward the 
destination MAC address.

• Simulated Ethernet frame—Cisco ANA PathTracer can trace a simulated Ethernet frame from a 
VLAN port, across a VLAN (VLAN-based Flow Domain Fragment), VPLS (VPLS-based Flow 
Domain Fragment), and VLAN, for an end-to-end MAC address trace.

Cisco ANA derives the various paths on the network from its up-to-date knowledge of the network. After 
a user has selected a source and destination, Cisco ANA PathTracer finds and retrieves the path of a 
specified service. The retrieved information contains network elements in the path, including all 
properties at Layer 1, Layer 2, and Layer 3, plus alarm information, counters, and more.

Cisco ANA PathTracer enables you to view multiple paths between the source and the destination in the 
Cisco ANA PathTracer multipath window, or to view a selected single-path in the Cisco ANA PathTracer 
single-path window.

Using Cisco ANA PathTracer
Cisco ANA PathTracer can be launched from a bridge, switching entity, Ethernet interface, Ethernet 
flow point, VLAN interface, ATM VC, DLCI, or IP interface entry point. The virtual route is found 
according to the cross connect table of each ATM switch or Frame Relay device. The IP routing and path 
finding process is enabled according to the VRF tables of each router.

To view a specific path, you must specify an initial point, such as a VPI/VCI, DLCI, VLAN, Ethernet 
port, or IP interface and optionally a destination, such as an IP or MAC address. If you specify VC or 
DLCI information, which ends in a router, Cisco ANA PathTracer finds the next hop according to the 
destination IP address. If you do not specify a destination IP or MAC address, Cisco ANA PathTracer 
uses the default gateway in the router. The business tags that have been referred to the physical or logical 
entities are also displayed.

Note The path can also be opened if there is a business tag attached to an endpoint that can be used as the 
starting point for opening the Cisco ANA PathTracer.

The Cisco ANA PathTracer tool provides two windows in which to view the path: 

• Cisco ANA PathTracer Multipath Window, page 11-12—Displays all the paths available between 
the selected source and destination.

• Cisco ANA PathTracer Single-Path Window, page 11-16—Displays a single path available between 
the selected source and destination, as well as the subscribers and properties.
11-3
Cisco Active Network Abstraction 3.7.1 User Guide

OL-21803-02



 

Chapter 11      Using Cisco ANA PathTracer to Diagnose Problems
  Using Cisco ANA PathTracer
Cisco ANA PathTracer Right-Click Menu Options
Cisco ANA PathTracer is launched by using right-click menu options. Table 11-2 identifies the 
launching points for the different types of elements. 

Starting a Path Trace
You can start a path trace in the following ways:

• From the Map View, page 11-5

• From Logical or Physical Inventory, page 11-7

Table 11-2 Cisco ANA PathTracer Right-Click Menu Options

Element Location

Affected Parties • Inventory window

• Ticket Properties window (Affected Parties tab)

Bridge Inventory window

Business tag The path can be found using a business tag, which is attached to the 
VPI/VCI, or using an IP interface by entering its key; it can then be 
opened from the Find Business Tag dialog box.

Ethernet flow point Map view (Ethernet Flow Domain Properties window)

IP interface • Inventory window

• Affected entry

Layer 2 MPLS Tunnel Inventory window

MPLS-TE Tunnel Inventory window

Port Inventory window

Site Map view

Switching entity Map view

VC Cross Connect Table Inventory window (Cross Connect dialog box)

VC Table Inventory window (VC Table dialog box)

VLAN • Navigation pane

• Map view
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From the Map View

To start a path trace from the map view:

Step 1 In the Cisco ANA NetworkVision map view, start the path trace in one of the following ways:

• For a VLAN:

a. In the navigation pane or map pane, select the required network VLAN and then drill down 
to a switching entity or Ethernet flow point. 

b. Right-click the required item.

c. Choose PathTracer > From Here to Destination or PathTracer > Start Here.

• For a VPN: 

a. In the navigation pane or map pane, select the required network VPN and then drill down to 
the required site. 

b. Right-click the site.

c. Choose PathTracer > From Here to Destination or PathTracer > Start Here.

• For an Ethernet flow point:

a. Choose Network Inventory > Ethernet Flow Domains.

b. In the Ethernet Flow Domain List Properties window, double-click the required domain. 

c. In the Ethernet Flow Domain Properties window, right-click the required element. 

d. Choose PathTracer > From Here to Destination or PathTracer > Start Here.

The next step depends on your choice in Step 1: 

• If you chose PathTracer > From Here to Destination, the Path Information dialog box is displayed 
(Figure 11-1). Continue with Step 2. 

• If you chose PathTracer > Start Here, continue with Step 3. 

Figure 11-1 Path Information Dialog Box 
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Step 2 To specify a destination: 

a. In the Path Information dialog box, enter the required information, as described in Table 11-3. 

Note Depending on the launch point, the Path Information dialog box might not contain all of the 
following fields. 

b. Click OK. 

Step 3 If you chose Start Here, navigate to the destination interface, port, or bridge, right-click it, and choose 
End Here.

The PathTracer multipath window is displayed showing the paths that were found. For more information 
about this window, see Cisco ANA PathTracer Multipath Window, page 11-12.

Step 4 If the multipath window displays more than one path, select a path in the Paths pane.

Note If multiple paths are selected in the Paths pane, they will be opened. If nothing is selected in the 
Paths pane, then all the available paths will be opened automatically, and each one will be 
displayed in a separate PathTracer single-path window.

Step 5 On the multipath window toolbar, click Cisco PathTracer. The PathTracer single-path window is 
displayed showing the end-to-end path. 

For more information about the single-path window, see Cisco ANA PathTracer Single-Path Window, 
page 11-16.

Table 11-3 Cisco ANA PathTracer Path Information Dialog Box

Field Description

Destination IP Select this option to specify an IP address as the destination. Enter 
either an IPv4 or IPv6 address. 

Destination MAC Select this option to specify a MAC address as the destination. Enter 
the MAC address. 

VLAN ID Enter the required VLAN identifier. You must enter an IP address or 
a MAC address to use this option.

Inner VLAN ID Enter the required inner VLAN identifier. 

Stop trace after Check this check box to limit the number of hops that Cisco ANA 
PathTracer makes in its attempt to reach the destination. Enter the 
maximum number of hops that you want to allow in the hops field. 
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From Logical or Physical Inventory

To start a path trace from logical or physical inventory: 

Step 1 In Cisco ANA NetworkVision, open the inventory window for the required device using one of the 
following methods: 

• Double-click a device or element in the navigation pane or in a map.

• Right-click a device or element in the navigation pane or in a map and choose Inventory.

Step 2 Select one of the following launch points in logical or physical inventory: 

• IP Interface

• VLAN Bridge

• Port

Step 3 Right-click the selected item and choose one of the following: 

• PathTracer > From Here to Destination—If you choose this option, continue with Step 2 in From 
the Map View, page 11-5. 

Note If you select an IP interface as the launch point, the right-click menu displays IPv4 and IPv6 
options. These options are enabled or dimmed, depending on whether the IP interface has an 
IPv4 IP address, an IPv6 address, or both IPv4 and IPv6 addresses. For an example, see 
Figure 11-3.

• PathTracer > Start Here—If you choose this option, continue with Step 3 in From the Map View, 
page 11-5. 

Examples of Launching Cisco ANA PathTracer 
The following topics provide examples for launching Cisco ANA PathTracer from different points in 
Cisco ANA NetworkVision: 

• Using an Ethernet Flow Point, page 11-7

• Using an IP Interface, page 11-8

• Using a VLAN Bridge, page 11-10

• Using an Ethernet Port, page 11-11

• Using a Pseudowire, page 11-11

Using an Ethernet Flow Point

A network VLAN is required for you to start a path trace using an Ethernet flow point. 

To launch a path trace from an Ethernet flow point: 

Step 1 In the Cisco ANA NetworkVision navigation pane or map pane, select the required network VLAN. 

Step 2 Navigate down to an Ethernet flow point and right-click it. 
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Step 3 Choose PathTracer > From Here to Destination. The Path Information dialog box is displayed as 
shown in Figure 11-2. 

Figure 11-2 Ethernet Flow Point Path Trace Example

Step 4 Specify the destination and maximum number of hops using the information in Table 11-3. 

Step 5 Click OK. The Cisco ANA PathTracer window is displayed with the resulting path trace.

Using an IP Interface

Both IPv4 and IPv6 addresses are supported as valid path trace sources and destinations as illustrated in 
the following procedure.

To launch a path trace from an IP interface: 

Step 1 In logical inventory, select the required IP interface (Logical Inventory > Routing Entities > 
Routing Entity > ip-interface).

Step 2 Right-click the selected interface. 

The right-click menu displays IPv4 and IPv6 options. These options are enabled or dimmed, depending 
on whether the IP interface has an IPv4 address, an IPv6 address, or both IPv4 and IPv6 addresses. See 
Figure 11-3. 
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Figure 11-3 IP Interface Path Trace Launch Point

Step 3 Choose PathTracer > From Here to Destination. 

The Path Information dialog box is displayed as shown in Figure 11-4.

Figure 11-4 IP Interface Path Trace Launch Point Path Information Dialog Box

Step 4 In the Destination IP field, enter the IPv4 or IPv6 address. 

Step 5 To limit the number of hops for the path trace, check the Stop trace after check box, and enter the 
maximum number of hops for the path trace.

Step 6 Click OK. The Cisco ANA PathTracer window appears, displaying the resulting path trace.
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Using a VLAN Bridge

You can launch path traces from VLAN bridges. Additionally, MAC addresses in the VLAN bridge 
forwarding table can be path trace destinations. 

To launch a path trace from a VLAN bridge:

Step 1 In logical inventory, select the required bridge (Logical Inventory > Bridges > bridge).

Step 2 Right-click the selected bridge, then choose one of the following options as shown in Figure 11-5: 

• PathTracer > From Here to Destination 

• PathTracer > Start Here 

Figure 11-5 VLAN Bridge Path Trace Launch Point

Step 3 If you chose From Here to Destination in Step 2, the Path Information dialog box is displayed. Specify 
the required destination using the information in Table 11-3.

Step 4 If you chose Start Here, navigate to the destination, right-click it, and choose End Here. Destination 
options include: 

• IP interface—Logical Inventory > Routing Entities > Routing Entity > IP-interface

• Bridge—Logical Inventory > Bridges > bridge

• MAC address—Logical Inventory > Bridges > bridge > Bridge Table > MAC-address 

• Ethernet port—Physical Inventory > chassis > slot > port 

When a destination is selected, the system extracts the relevant IP address from this point and uses it as 
the destination.

The Cisco ANA PathTracer window is displayed with the resulting path trace.
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Using an Ethernet Port

To launch a path trace from an Ethernet port: 

Step 1 In physical inventory, select the required port (Physical Inventory > Chassis > slot > subslot > port). 

Step 2 Right-click the selected port and choose one of the following as shown in Figure 11-6:

• PathTracer > From Here to Destination 

• PathTracer > Start Here 

Figure 11-6 Ethernet Port Path Trace Launch Point 

Step 3 Depending on your choice in Step 2, specify the required destination information or select the path trace 
end point. 

The Cisco ANA PathTracer window appears, displaying the resulting path trace.

Using a Pseudowire

To launch a path trace from network pseudowire: 

Step 1 In the Cisco ANA NetworkVision navigation pane or map pane, select the required network pseudowire. 

Step 2 Navigate down to the required pseudowire endpoint and right-click it. 

Step 3 In the right-click menu, choose PathTracer > From Here to Destination. 

The Path Information dialog box is displayed as shown in Figure 11-7. 
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Figure 11-7 Path Information Dialog Box

Step 4 Specify the destination using the information in Table 11-3. 

The Cisco ANA PathTracer window appears, displaying the resulting path trace.

Cisco ANA PathTracer Multipath Window 
The Cisco ANA PathTracer multipath window displays all the discovered paths for the selected context, 
including devices and physical links. 

The Cisco ANA PathTracer multipath window enables you to:

• View a previous path or view the next path.

• Open the Cisco ANA PathTracer single-path window in order to view a single selected path.

• Save the multipath map to a file.

• Run the Cisco ANA PathTracer again.
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An example of the Cisco ANA PathTracer multipath window is displayed in Figure 11-8.

Figure 11-8 Cisco ANA PathTracer Multipath Window

The Cisco ANA PathTracer multipath window contains the following elements:

• Menus, page 11-14

• Toolbar, page 11-14

• Tabs, page 11-15

• Paths Pane, page 11-16

• Content Pane, page 11-16

1 Menu bar 4 Paths pane

2 Toolbar 5 Status bar

3 Map pathtraced at...tabs 6 Content pane
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Menus
The menus in the Cisco ANA PathTracer multipath window provide the options described in Table 11-4. 

You can also right-click views and network elements in the multipath window and choose items from a 
shortcut menu. The shortcut menu is context sensitive depending on the view and the network element 
selected. For more information about the Device shortcut menu and for a detailed description of the 
menu options available, see Device Shortcut Menu, page 2-30.

Toolbar
The Cisco ANA PathTracer multipath window contains the following tools:

Table 11-4 Cisco ANA PathTracer Window Menu Options

Menu Option Description

File Menu

Run Again Runs the Cisco ANA PathTracer again, using the same source and 
destination parameters.

Save Saves the map displayed in the multipath window.

Close Closes the multipath window.

View Menu

Layout Defines the way in which the NEs are arranged in the Cisco ANA 
PathTracer window: circular, symmetric, tree, or hierarchical.

Overview Opens a window displaying an overview of the network.

Zoom In Enables you to zoom in for a closer view of the map.

Zoom Out Enables you to zoom out for a higher-level view of the map. 

Fit in Window Fits the entire subnetwork or map in the content pane.

Normal Select Activates the normal selection mode (the button toggles when selected 
or deselected).

Pan Activates the pan mode, which enables you to move around in the map 
by clicking and dragging (the button toggles when selected or 
deselected).

Zoom Selection Activates the zoom selection mode, which enables you to select an pane 
in the map to enlarge by clicking and dragging (the button toggles when 
selected or deselected).

Button Function

Selects the previous path viewed in the content pane.

Selects the next path viewed in the content pane.
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Tabs
The path is initially displayed in the content pane in a tab that displays the date and time when 
Cisco ANA started the path tracing process (snapshot time). 

If you load a saved path from a file or run the displayed path trace again, the opened or refreshed path 
is displayed in a new tab with a refreshed path map for each run or file. When using a saved path from 
a file, the source and destination must be the same as the current display for it to appear in the same path 
trace window. Each tab represents a run or file, and its header displays the snapshot time.

Clears the path selection made in the content pane.

Opens the Cisco ANA PathTracer single-path window based on the path selected in the 
Cisco ANA PathTracer multipath window. A map is displayed for the selected path, 
including NE details, links, and property information. For more information, see 
Cisco ANA PathTracer Single-Path Window, page 11-16.

Saves the multipath map displayed in the content pane. For more information, see Saving 
and Opening Cisco ANA PathTracer Map Files, page 11-20.

Defines the way in which the map is displayed in the content pane (circular, symmetric, 
tree, or hierarchical).

Opens a window displaying an overview of the network displayed in the content pane.

Offers the following options for running Cisco ANA PathTracer again for the same source 
and destination:

• Change Hop Count—Enables you to enter a new hop count. 

• Repeat Last Trace—Runs the previous trace with the same settings. 

• Run Full Path Trace—Runs the previous trace without a hop count limitation.

The new path trace map is displayed in the content pane. 

A new tab with the up-to-date (or refreshed) path map is created for each run, with each tab 
representing a run and the tab label indicating the snapshot time.

Fits the entire subnetwork or map in the content pane.

Activates the normal selection mode (the button toggles when selected or deselected).

Activates the zoom selection mode, which enables you to select an pane in the map to 
enlarge by clicking and dragging (the button toggles when selected or deselected).

Activates the pan mode, which enables you to move around in the map by clicking and 
dragging (the button toggles when selected or deselected).

Button Function
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Paths Pane
The Paths pane displays all of the paths available for the selected source and destination. A new path is 
created for each source and destination pair. The paths are identified by number, such as 1, 2, and 3. 
Selecting a path in the Paths pane enables you to view each individual path in the content pane of the 
Cisco ANA PathTracer single-path window, and the selected path is highlighted in the map.

If the path trace was launched with a specific hop count, the paths pane displays First n Hops where n is 
the number of hops specified. 

Content Pane
The content pane enables you to view a route map of the intermediate network elements. The map 
displays devices, links, and topological paths.

Icons are used in the content pane to display the network objects and their status. For more information 
about the icons used, see Chapter 2, “Working with the Cisco ANA NetworkVision Client.”

All links and nodes are labeled with the relevant paths numbers. The starting point is labeled with a 
special Starting Point label. All other edge points are displayed as clouds.

Cisco ANA PathTracer Single-Path Window
The Cisco ANA PathTracer single-path window displays the devices and links of the discovered path, as 
well as path layer properties and subscriber information. 

Note This section refers to single-path view only.

The Cisco ANA PathTracer single-path window enables you to:

• View a map of the intermediate network elements.

• View the following information for each network element:

– The relevant parameters for each interface on all layers along the path.

– For each layer, an indication of a mismatch between the parameters of the interfaces on both 
sides of a link.

– Traffic statistics along the path.

• Monitor the status and traffic of all links along the path.

• View In and Out port properties. 

In addition, right-clicking on an item in Cisco ANA PathTracer enables you to perform certain functions. 
For example, you can view device information, including device properties, and attach business tags.
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Figure 11-9 shows an example of the Cisco ANA PathTracer single-path window.

Figure 11-9 Cisco ANA PathTracer Single-Path Window

The Cisco ANA PathTracer single-path window contains the following items:

• Menus, page 11-18

• Toolbar, page 11-18

• Topological Map, page 11-19

• Properties Table and Layer Tabs, page 11-19

1 Menu bar 5 Properties table

2 Toolbar 6 Layer tabs

3 Content pane 7 Status bar

4 Hide/Display Properties table
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Menus
The following table provides a description of each option available in the Cisco ANA PathTracer 
single-path window menus.

In addition, you can right-click views and network elements in the single-path window and choose items 
from a shortcut menu. The shortcut menu is context sensitive depending on the view and the network 
element selected. The following right-click menu options are available only when you select a network 
element in the single-path window:

• Show ‘In’ Port—In the Properties table, highlights the In Port information of the selected network 
element.

• Show ‘Out’ Port—In the Properties table, highlights the Out Port information of the selected 
network element.

Toolbar
The Cisco ANA PathTracer single-path window contains the following tools:

Menu Name Options 

File Close—Closes the single-path window.

View • Show All—Displays all of the information contained in the Properties table.

• Hide All—Hides all of the information contained in the Properties table.

Tools • Export to File—Exports the currently displayed data to a file.

• Start Saving to File—Starts exporting the counter values of the path 
displayed in the Cisco ANA PathTracer single-path window to a CSV file.

• Stop Saving to File—Stops exporting the counter values of the path 
displayed in the Cisco ANA PathTracer single-path window to a CSV file.

Help • Help Contents—Opens the online help for Cisco ANA NetworkVision and 
Cisco ANA EventVision.

• Help About—Displays application information, such as the version number.

Table 11-5 Cisco ANA PathTracer Single-Path Window Tools

Button Name Function

Show All Displays all the information in the tabs.

Hide All Hides all the information in the tabs.

Export to File Exports the currently displayed data to a CSV file.
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Topological Map
The topological map displays the devices and links that are part of the path. Icons are used in Cisco ANA 
PathTracer to display the network objects and their status. For more information about the icons used, 
see Chapter 2, “Working with the Cisco ANA NetworkVision Client.”

For more information about the colors used to indicate severities, see Map View, page 2-6.

The same coloring conventions that are used in maps in the Cisco ANA NetworkVision content pane are 
used to display links in the Cisco ANA PathTracer single-path window. Selecting a device or link on the 
map automatically highlights the related parameters in the table.

Note The color of a selected link is customizable. The default color is blue.

The status of a network object can be indicated on the topological map in the following ways:

• Severity

• Management state

• New alarms 

For more information, see Network Element Status Indicators, page 2-17.

Properties Table and Layer Tabs
The Properties table and tabs display the supported parameters of the specified NE. The Cisco ANA 
PathTracer single-path window is divided into tabs as shown in the example in Cisco ANA PathTracer 
Single-Path Window, page 11-16.

The information parameters are displayed in a table, with the ingress and egress ports on the top and the 
parameters on the left.

Any inconsistencies between the two connected ports are colored to emphasize a discrepancy, such as 
different admin statuses.

The Cisco ANA PathTracer information parameters are arranged in groups as follows:

• Networking Layers—This group provides information about each network element, including 
ingress and egress port information. The information is either plain data that was extracted from the 
device or calculated data such as rates or statistics. This information is displayed in the Layer 1, 
Layer 2, and Layer 3 tabs.

If a field has no value on any of the interfaces, the field is not displayed in the table. For example, 
if none of the interfaces is configured for MTU, the MTU row is not displayed in the table. If at least 
one of the interfaces is configured for MTU, the MTU row is displayed.

Start Saving to File Starts exporting the counter values of the path displayed in the 
Cisco ANA PathTracer single-path window to a CSV file.

Stop Saving to File Stops exporting the counter values of the path displayed in the 
Cisco ANA PathTracer single-path window to a CSV file.

Table 11-5 Cisco ANA PathTracer Single-Path Window Tools (continued)

Button Name Function
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• Business—This area provides the name and key of the business tags that have been attached to the 
network entities displayed; for example, the port or the entire device (physical entity), VC, VP, 
DLCI, context (logical entity), or MPLS. This information is displayed in the Business Tag area.

The Cisco ANA PathTracer window is divided into the following tabs; all tabs appear empty when the 
window opens: 

• Layer 1—Displays the Layer 1 information in the selected path and enables you to view the link 
parameters. The name of each device is displayed, as well as the subslot, slot, and port details. 

• Layer 2—Displays the Layer 2 information in the selected path. In addition, it enables you to view 
the link and connection parameters. For each of the devices, the name and MAC address are 
displayed, as well as the VPI/VCI in an ATM link or the DLCI in a Frame Relay link. By default, 
the Cisco ANA PathTracer single-path window is displayed with the Layer 2 tab active. 

• Layer 3—Displays the Layer 3 information selected path and enables you to view the link 
parameters. The name of each device is displayed.

• Business Parameter—Displays the name and the key of the business tags that have been attached to 
the network entities displayed; for example, the port or the entire device (physical entity), VC, VP, 
DLCI, IP interface, or context (logical entity).

Viewing Path Information 
The Cisco ANA PathTracer tabs display information regarding each network element, including ingress 
and egress port information. The information is either plain data that was extracted from the device or 
calculated data such as rates or statistics. This information is displayed in the Layer 1, Layer 2, and 
Layer 3 tabs of the Cisco ANA PathTracer single-path window. 

To view path information, select the required tab, and click Show All. The path information is displayed 
in the active tab of the Cisco ANA PathTracer single-path window.

Note Selecting a device or link on the map automatically highlights the related parameters in the table.

Saving and Opening Cisco ANA PathTracer Map Files
Cisco ANA NetworkVision enables you to export the maps displayed in the Cisco ANA PathTracer 
multipath window to an .xml file. You can view the data at a later time to assess whether anything has 
changed.

Saving Cisco ANA PathTracer Map Files

To save Cisco ANA PathTracer Map Files:

Step 1 Open the Cisco ANA PathTracer multipath window as described in Using Cisco ANA PathTracer, 
page 11-3.

Step 2 Save the map in one of the following ways:

• Click Save MultiPath in the multipath window toolbar.

• Choose File > Save from the multipath window menu.

Step 3 In the Save dialog box, browse to the directory where you want to save the file.
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Step 4 In the File name field, enter a name for the map file.

Step 5 Click Save. The map file is saved in the selected directory.

Opening Cisco ANA PathTracer Map Files

Cisco ANA NetworkVision enables you to open saved XML-formatted path-tracing maps.

Note • When you load a multipath file, Cisco ANA queries the file (not the network), and loads all the 
persisted information. 

• When you load a multipath file that does not contain the same Start Here and End Here destination 
information, the map is automatically opened in another instance of Cisco ANA PathTracer.

To open Cisco ANA PathTracer Map Files:

Step 1 In Cisco ANA NetworkVision, choose File > Load PathTracer from the main menu. The Open dialog 
box is displayed.

Step 2 Browse to the directory of the saved file and select the file.

Step 3 Click Open. The Cisco ANA PathTracer multipath window is displayed with the previously saved map 
file.

Saving Cisco ANA PathTracer Counter Values
Cisco ANA NetworkVision enables you to export, over a period of time, the counter values of the path 
displayed in the Cisco ANA PathTracer single-path window to a CSV file. The data can then be viewed 
at a later stage.

Note This topic applies to the single-path view only.

To save Cisco ANA PathTracer counter values that are generated over a period of time: 

Step 1 Open the Cisco ANA PathTracer single-path window as described in Using Cisco ANA PathTracer, 
page 11-3. 

Step 2 Start saving counter values to a file in one of the following ways: 

• Click Start Saving to File in the single-path window toolbar.

• Choose Tools > Start Saving to File from the single-path window main menu.

Step 3 In the Export Table to File dialog box, browse to the directory where you want to save the Cisco ANA 
PathTracer counter values. 

Step 4 In the File name field, enter a name for the file in which to save the counter values.

Step 5 Click Save. Cisco ANA PathTracer starts saving the counter values to the specified file.
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Step 6 Stop exporting counter values to the file in one of the following ways: 

• Click Stop Saving to File in the single-path window toolbar.

• Choose Tools > Stop Saving to File from the single-path window main menu.

Cisco ANA NetworkVision stops exporting the counter values to the file.

Rerunning a Path and Comparing Results
If you save a path to a file (see Saving and Opening Cisco ANA PathTracer Map Files, page 11-20), you 
can use the file a later time to rerun the same path automatically with the same source and destination. 
If required, you can then compare the saved path and the newly run path to determine if the path has 
changed or to assess a problem. 

To rerun a saved path: 

Step 1 Load the required map file as described in Saving and Opening Cisco ANA PathTracer Map Files, 
page 11-20. The Cisco ANA PathTracer multipath window is displayed with the previously saved map 
file.

Step 2 Rerun the path in the file in one of the following ways:

• Click Run Again in the multipath window toolbar.

• Choose File > Run Again from the multipath window main menu.

The path runs automatically using the same source and destination as the loaded map file, and a new tab 
is displayed in the Cisco ANA PathTracer multipath window with the updated map. The tab also displays 
the updated details of the date and time when the path was rerun.

Step 3 Compare the previous map with the updated one by switching between the tabs in the Cisco ANA 
PathTracer multipath window.

Note • If you load a Cisco ANA PathTracer map file that does not contain the same source and destination 
information as the map that is currently displayed in the window, the map is automatically opened 
in another instance of the Cisco ANA PathTracer multipath window.

• If you load a Cisco ANA PathTracer map file that contains the same source and destination 
information as a map that is currently displayed in the window, the map is loaded in a new tab in the 
same window.

Viewing Q-in-Q Path Information 
The Q-in-Q (IEEE 802.1) tagging technology (also known as Dot1q tunneling) allows the nesting of an 
additional VLAN tag in a packet, in addition to an existing one. Either VLAN tag is considered an 
802.1Q header.
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Cisco ANA PathTracer uses the VLAN tags of the Ethernet header and the port configuration to trace 
the path from one interface to another over the network. Among other things, the tool lets you:

• View a Layer 2 path across a LAN domain with all the VLAN tag information.

• For each network element, view the relevant parameters for each interface on all layers along the 
path.

Q-in-Q and dot1q information is displayed in the Cisco ANA PathTracer windows when a path is traced 
over Ethernet ports with Dot1q and a Q-in-Q configuration.

As described in Using Cisco ANA PathTracer, page 11-3, to view a specific path, you must specify an 
initial start point, such as an IP interface, and then an endpoint, such as a destination IP address. 

To trace a Q-in-Q path, you start the path from any:

• Router or switch that is part of the Ethernet domain with Dot1q and Q-in-Q configurations.

• IP destination that can be reached from that point of the network.

As soon as you select the endpoint, the Cisco ANA PathTracer Multipath window is displayed. From this 
window, you can open the Cisco ANA PathTracer Single-Path window, with the appropriate Q-in-Q 
information displayed in the Layer 2 tab. 

The Layer 2 tab can display the following information specific to Q-in-Q and VLAN port configurations:

• VLAN Mode—The work mode for the interface: Unknown, Access, Trunk, or Dot1QTunnel. Trunk 
mode also refers to multiple tagging.

• Native VLAN ID—The VLAN identifier that is used to tag untagged traffic received on a trunked 
interface: 

– If VLAN tagging is enabled, the default native VLAN identifier is 1.

– If VLAN tagging is disabled, the native VLAN identifier is 0 (zero) or ‘no VLAN ID.’ 

• CE VLAN ID—The customer edge device VLAN identifier.

• SP VLAN ID—The service provider VLAN identifier.

Viewing L2TP Path Information
Cisco ANA uses VC ID encapsulation information to trace the path from one tunnel interface to another 
over the network. The Cisco ANA PathTracer tool enables you to:

• View a path for the defined Layer 2 Tunneling Protocol (L2TP) session across the network.

• For each network element, view the relevant parameters for each interface on all layers along the 
path.

Layer 2 and Layer 3 L2TP information is displayed in the Cisco ANA PathTracer windows when a path 
is traced over L2TP tunnels for Redback devices.

The Layer 3 tab displays the peer name for L2TP tunnels. 

Table 11-6 describes the information that is displayed in the Layer 2 tab for L2TP tunnels. 

Table 11-6 Layer 2 Tab Information for L2TP Tunnels

Field Description

Encapsulation Type The encapsulation type, such as Point-to-Point Protocol over ATM (PPPoA).

Binding Information The name of the subscriber.
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Using Cisco ANA PathTracer in MPLS Networks
You can open and view Cisco ANA PathTracer information between service endpoints, such as an IP 
interface that is attached to the VRF over an MPLS network. The LSP in the MPLS network is found 
according to the cross-connect table of each router.

Note The LSP can be traced and displayed by Cisco ANA PathTracer as part of an end-to-end tracing of a 
service, as well; for example, when viewing a path between one CE device and another. Cisco ANA 
PathTracer traces the path that goes over circuits or VLANs in the access networks. It also traces the 
LSPs between the VRFs going through all intermediate devices such as CE devices, aggregation 
switches, PE routers, and core routers.

To view a specific path, you must specify an initial starting point, such as an IP interface; specifying a 
destination IP address is optional. If the traced circuit (for example, a VC or VLAN) ends in a router, 
Cisco ANA PathTracer finds the next hop according to the destination IP address. When you select an 
endpoint, Cisco ANA extracts the relevant IP address from this point and uses it as the destination.

Binding Status The binding status: bound or unbound.

Tunnel Session Count The number of current sessions.

Tunnel Remote ID The remote tunnel identifier.

Tunnel ID The local tunnel identifier.

Tunnel Name The name of the subscriber and the tunnel ID.

Session ID The session identifier.

Traffic >
L2TPSessionCounters

The number of traffic packets passing through the L2TP tunnel.

Traffic < 
L2TPSessionCounters

The number of traffic packets passing through the L2TP tunnel.

Tunnel Ctl Errors The number of control errors.

Tunnel State The tunnel state: unknown, idle, connecting, established, or disconnecting.

Session Type The session type: unknown, LAC, or LNS.

Peer Name The peer name.

Tunnel Remote IP The remote IP address of the tunnel.

Last Error Code The value of the last error code that caused the tunnel disconnection.

Session State The session state: unknown, idle, connecting, established, or disconnecting.

Remote Session ID The remote session identifier.

Table 11-6 Layer 2 Tab Information for L2TP Tunnels (continued)

Field Description
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Cisco ANA PathTracer MPLS Starting Points
You can open Cisco ANA PathTracer by right-clicking a starting point and entering the required 
destination IP address. Table 11-7 lists the Cisco ANA PathTracer starting points.

Cisco ANA PathTracer MPLS Endpoints
If you choose the Start Here option, Table 11-8 lists the endpoints that can be selected as path 
destinations.

The Cisco ANA PathTracer multipath window is displayed. From this window you can open the 
Cisco ANA PathTracer single-path window with the appropriate VPN information displayed in the 
Layer 2 and Layer 3 tabs. 

Note If multiple paths are selected in the paths pane, or if nothing is selected in the paths pane, all available 
paths are opened automatically, and each is displayed in a separate Cisco ANA PathTracer single-path 
window.

Table 11-7 Cisco ANA PathTracer Starting Points

Element Location Start Options

IP Interface • Inventory window.

• Affected entity (enabled only if the 
affected entity has an IP interface).

• From Here to Destination

• Start Here

Site Service view map. • From Here to Destination

• To Subnet Destination

• Start Here

Business tag 
attached to the 
VPI/VCI or IP 
interface 

The path can be found using a business tag, 
which is attached to the VPI/VCI or IP 
interface by entering its key. It can then be 
opened from the Find Business Tag window.

From Here to Destination

Layer 2 MPLS 
Tunnel

Inventory window. From Here to Destination

LCP Service view map. • From Here to Destination

• Start Here

Table 11-8 Cisco ANA PathTracer Endpoints

Element Location End Options

IP Interface • Inventory window

• Affected entity (enabled only if the 
affected entity has an IP interface)

End Here

Site Service view map End Here

LCP Service view map End Here
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Using Cisco ANA PathTracer for Layer 3 VPNs
Cisco ANA PathTracer uses VRF routing and label switching information to trace the path from one 
VRF interface to another. If you choose a start and endpoint from the right-click menu, you can open the 
Cisco ANA PathTracer for Layer 3 VPNs. The Cisco ANA PathTracer multipath window shows the VPN 
topology map. From this window, you can open the Cisco ANA PathTracer single-path window with the 
appropriate VPN information displayed in the Layer 2 and Layer 3 tabs. 

For Layer 3 path information, Cisco ANA uses VRF routing and label switching information to trace the 
path from one VRF interface to another. Layer 3 Cisco ANA PathTracer information is displayed in the 
Cisco ANA PathTracer window when the path goes over connections and ends in VRFs. 

If a VRF table includes more than one path toward a destination, Cisco ANA PathTracer shows all paths.

To view Layer 3 path information, choose the Layer 3 tab and choose Show All from the View menu. 
The path information is displayed in the active tab.

Note Selecting a device or link on the map automatically highlights the related parameters in the table.

The Cisco ANA PathTracer single-path window with the Layer 3 tab is displayed. The table displays the 
Layer 3 VPN information on the device that has a VRF. The following Layer 3 properties displayed in 
the Layer 3 tab relate specifically to VPNs:

• Name—The name of the site. For example, ATM4/0.100(10.0.0.1) is a combination of the interface 
name and IP address used to reach the site. Each site belongs to a particular VPN, so the address 
must be unique within the VPN.

• IP Address—The IP address of the interface.

• Mask—The mask of the specific network.

• State—The state of the interface (up or down).

• VRF Name—The name of the VRF.

• Sending Alarms—Whether or not the interface is configured for sending alarms: True or False.

Cisco ANA PathTracer does not display or trace EXP bits for L3 VPNs that use policy-based tunnel 
selection (PBTS). 

Using Cisco ANA PathTracer for Layer 2 VPNs
Cisco ANA uses VC ID and label switching information to trace the path from one tunnel interface to 
another over the MPLS network.

The Cisco ANA PathTracer also covers end-to-end Layer 2 VPN service paths from one CE router to 
another. The path goes over circuits (such as a VC) or VLANs in access networks and over LSP between 
the Layer 2 tunnel edge.

The Cisco ANA PathTracer multipath window shows the VPN topology map for the relevant devices and 
links. From this window, you can open the Cisco ANA PathTracer single-path window with the 
appropriate VPN information displayed in the Layer 2 and Layer 3 tabs. 

For Layer 2 path information, Cisco ANA uses VC ID and label switching information to trace the path 
from one tunnel interface to another. Layer 2 Cisco ANA PathTracer information is displayed in the 
Cisco ANA PathTracer window when the path goes over pseudowire tunnels.
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To view Layer 2 path information, choose the Layer 2 tab and then View > Show All. The path 
information is displayed in the active tab.

Note Selecting a device or link on the map automatically highlights the related parameters in the table.

Table 11-9 describes the Layer 2 properties that can be displayed in the Layer 2 tab specifically for 
VPNs.

Using Cisco ANA PathTracer for MPLS TE Tunnels
Cisco ANA Path Tracer uses label switching information to trace the end-to-end path of a TE tunnel path 
from one PE router to another.

Using MPLS TE technology, Cisco ANA PathTracer enables you to:

• View a path or list of devices.

• View the following information for each network element:

– The relevant parameters for each interface on all layers along the path.

– The path for the defined MPLS TE-LSP across the network.

Table 11-9 Cisco ANA PathTracer Layer 2 Properties for VPNs

Field Description

Outer Label The details of the outer MPLS label.

Inner Label The details of the inner MPLS label.

MAC Address The MAC address.

Tunnel ID The tunnel identifier. The identifier and the router IP address of the two 
tunnel edges identify the pseudowire tunnel

Tunnel Type The tunnel type: 

• 0—Unknown

• 1—PWE3

• 2—TE

Tunnel Status The operational state of the tunnel: Up or Down.

Tunnel Local VC Label The MPLS label that is used by the router to identify or access the 
tunnel. It is inserted in the MPLS label stack by the local router.

Tunnel Peer VC Label The MPLS label that is used by the router to identify or access the 
tunnel. It is inserted in the MPLS label stack by the peer router.

Tunnel Local Router IP The IP address of the tunnel edge, which is used as the MPLS router 
identifier.

Tunnel Peer Router IP The IP address of the peer tunnel edge, which is used as the MPLS router 
identifier.

Distribution Protocol 
Type

The protocol used by MPLS to build the tunnel, such as LDP or TDP.

Peer OID The tunnel identifier and device name.
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The Cisco ANA PathTracer multipath window is displayed showing the MPLS TE tunnel topology map. 
From this window, you can open the Cisco ANA PathTracer single-path window with the appropriate 
MPLS TE tunnel information displayed in the Layer 2 tab.

Note Cisco ANA PathTracer does not display or trace EXP bits for L3 VPNs that use PBTS. 

Layer 2 and Layer 3 Cisco ANA PathTracer information is displayed in the Cisco ANA PathTracer 
window when a path is traced over MPLS TE tunnels. To view Layer 2 path information, choose the 
Layer 2 tab and then View > Show All. The path information is displayed in the active tab.

Note Selecting a device or link on the map automatically highlights the related parameters in the table.

Table 11-10 describes the Layer 2 properties that can be displayed in the Layer 2 tab specifically for 
MPLS TE tunnels. 

Table 11-10 Cisco ANA PathTracer Layer 2 Properties for MPLS TE Tunnels

Field Description

MPLS TE Properties The MPLS TE data set in an MPLS interface, primarily bandwidth 
allocation levels and signaling protocol.

Tunnel Oper Status The operational status of the tunnel: Up or Down. 

If this value is Up, the Tunnel Admin Status must also be Up. See Tunnel 
Admin Status properties for additional information. 

Tunnel Bandwidth Kbps The configured bandwidth (in Kb/s) for the tunnel. 

Tunnel Description A description of the tunnel.

Tunnel Name The interface name.

Tunnel Admin Status The administrative status of the tunnel (Up or Down) with the following 
caveats:

• If the Tunnel Oper Status value is Up, the Tunnel Admin Status 
value must also be Up. 

• If the Tunnel Admin Status value is Down, the Tunnel Oper Status 
value must also be Down.

Tunnel Lockdown Whether or not the tunnel can be rerouted:

• Enabled—The tunnel cannot be rerouted.

• Disabled—The tunnel can be rerouted.

Tunnel LSP ID The LSP identifier. 

Tunnel Auto Route Whether or not destinations behind the tunnel are routed through the 
tunnel: Enabled or disabled.

Tunnel Hold Priority The tunnel priority after path setup. 

Tunnel Setup Priority The tunnel’s priority upon path setup.
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Tunnel Path Option The tunnel path option:

• Dynamic—The tunnel is routed along the ordinary routing 
decisions after taking into account the tunnel constraints such as 
attributes, priority, and bandwidth. 

• Explicit—The route is explicitly mapped with the included and 
excluded links.

Tunnel Out Label The TE tunnel MPLS label distinguishing the LSP selection in the 
adjacent device.

Tunnel Affinity The tunnel’s preferential bits for specific links.

Tunnel Destination Address The IP address of the device in which the tunnel ends.

Tunnel Peak Rate Kbps Peak flow specification (in Kb/s) for this tunnel.

Tunnel Out Interface The interface through which the tunnel exits the device.

Tunnel Burst Kbps Burst flow specification (in Kb/s) for this tunnel.

Tunnel Average Rate Kbps The tunnel average rate in Kb/s.

Tunnel Affinity Mask The tunnel affinity bits that should be compared to the link attribute bits.

Table 11-10 Cisco ANA PathTracer Layer 2 Properties for MPLS TE Tunnels (continued)

Field Description
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