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Working with the Cisco ANA EventVision Client

These topics describe the Cisco ANA EventVision application and the options you can use to view 
system events and tickets that are generated within the Cisco ANA system:

• User Roles Required to Work with Cisco ANA EventVision, page 7-1

• Starting Cisco ANA EventVision, page 7-2

• Cisco ANA EventVision Window, page 7-3

• Selecting Cisco ANA EventVision Viewing Options, page 7-8

User Roles Required to Work with Cisco ANA EventVision
Table 7-1 identifies the roles that are required to work with Cisco ANA EventVision. Cisco ANA 
determines whether you are authorized to perform a task as follows: 

• For GUI-based tasks (tasks that do not affect devices), authorization is based on the default 
permission that is assigned to your user account. 

• For device-based tasks (tasks that do affect devices), authorization is based on the default 
permission that is assigned to your account. That is, whether the device is in one of your assigned 
scopes and whether you meet the minimum security level for that scope. 

For more information on user authorization, see the Cisco Active Network Abstraction 3.7.1 
Administrator Guide. 

Table 7-1 Default Permission/Security Level Required for Cisco ANA EventVision

Task Viewer Operator OperatorPlus Configurator Administrator

Opening Cisco ANA 
EventVision

— — — — X

Selecting Cisco ANA 
event viewing options

— — — — X
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Starting Cisco ANA EventVision
This section provides instructions for starting Cisco ANA EventVision. Cisco ANA EventVision is 
password protected to ensure security. Before you start working with Cisco ANA EventVision, make 
sure you know your username and password, and the Cisco ANA gateway IP address or hostname that 
you require.

Note Only users with the administrator role can log into Cisco ANA EventVision. 

Note If you do not log into the Cisco ANA Manage, Cisco ANA NetworkVision, or Cisco ANA EventVision 
application during a specified period of time (the default is 30 days), your account is automatically 
locked. The default period can be changed in Cisco ANA Manage. The period of time is measured from 
the time you last logged out of any of the Cisco ANA client applications. For more information about 
changing the default period and unlocking an account, see the Cisco Active Network Abstraction 3.7.1 
Administrator Guide. 

To start Cisco ANA EventVision:

Step 1 Choose Start > Programs > Cisco ANA > Cisco ANA EventVision. 

The login dialog box appears.

Step 2 Enter your username and password.

Step 3 Do one of the following:

• Enter the required Cisco ANA gateway information in the Host field, as an IP address or hostname.

• Select a Cisco ANA gateway from the Host list.

Note • The Cisco ANA gateway IP address or hostname that was used when you last logged in is 
automatically displayed at the top of the Host list.

• Make sure that you use the leading IP address (the IP address on which the Cisco ANA gateway was 
configured) when logging into the system.

Step 4 Click OK. 

When you launch Cisco ANA EventVision, messages are displayed if the server and client have different 
versions of the application that launches the client. For more information about these messages, see the 
Cisco Active Network Abstraction 3.7.1 Installation Guide. 

The first time you log in, the Ticket tab is displayed in the Cisco ANA EventVision window.

When you log in again, the tab and filter that were visible when you last logged out of the application 
are displayed.
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Cisco ANA EventVision Window
The Cisco ANA EventVision window displays the events generated in the system. Figure 7-1 shows an 
example of the Cisco ANA EventVision window.

Figure 7-1 Cisco ANA EventVision Window 

Cisco ANA EventVision displays events for the last two days by default. To modify the default number 
of days for which events are displayed, see Selecting Cisco ANA EventVision Viewing Options, 
page 7-8. As you increase the number of days, it might take longer for the events to be displayed.

You can display the events list only (without the Event Properties pane), and select the required tab to 
display events, such as Provisioning events only.

You can also the Cisco ANA EventVision window toolbar and menu options to:

• Filter results so that events meeting your criteria are displayed. See Filtering Events and Tickets, 
page 8-21.

• View selected event properties in a separate window. See Viewing Event Properties, page 8-14.

1 Menu bar 4 Properties pane

2 Toolbar 5 Status bar

3 Table pane 6 Cisco ANA EventVision tabs
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Event Status Indicators

The events list is color coded according to the severity of the event. An icon appears for each ticket or 
event in the Cisco ANA EventVision tabs (based on its severity) as shown in Table 7-2.

Event Types and Categories

Every event that occurs in the Cisco ANA system and the Cisco ANA gateway is logged. This includes 
events that are performed as part of the normal operation of the Cisco ANA system, as well as events 
that may need further attention. Events are categorized, and any of the log entries can be viewed in the 
Cisco ANA EventVision tabs as described in Table 7-3. 

Table 7-2 Event Status Indicators

Icon Color Severity

Red Critical

Orange Major

Yellow Minor

Sky Blue Warning

Green Cleared, Normal, or OK

Dark Blue Information

White Indeterminate

Table 7-3 Event Categories in Cisco ANA EventVision

Tab Description

Audit Related to commands running in the Cisco ANA gateway.

Provisioning Related to configuration and provisioning activities.

Security Related to client login and user activity when managing the system 
and the environment.

Service Related to the alarms that are generated by the Cisco ANA system.

Syslog Related to the predefined set of syslogs received from the devices 
by the VNEs, which are used to generate the syslog events.

System Related to the everyday working of the internal system and its 
components. These events may be related to Cisco ANA and 
Cisco ANA gateway resources, representing the system log.

Ticket Related to all the tickets that were opened in Cisco ANA.
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Cisco ANA EventVision Toolbar
Table 7-4 describes the tools that are displayed in the Cisco ANA EventVision toolbar.

V1 Trap Related to SNMPv1 traps that are generated by a network element 
and received by Cisco ANA; Cisco ANA uses these traps to 
generate the trap events.

V2 Trap Related to SNMPv2 traps that are generated by a network element 
and received by Cisco ANA; Cisco ANA uses these traps to 
generate the trap events.

V3 Trap Related to SNMPv3 traps that are generated by a network element 
and received by Cisco ANA; Cisco ANA uses these traps to 
generate the trap events.

All Displayed when you choose File > Open All Tab. 

Provides a flat list of all events and tickets, sorted by time. 

To disable the All option, follow the instructions provided in the 
Cisco Active Network Abstraction 3.7.1 Installation Guide. 

3.6.x Type Five tabs where Type represents one of the following: 

• Ticket

• Service

• Syslog

• V1 Trap

• V2-V3 Trap

These tabs are:

• Available only if Cisco ANA was upgraded from version 3.6.7 
to Cisco ANA 3.7 or 3.7.1. 

• Displayed when you choose File > Open 3.6.x Tabs. 

Table 7-3 Event Categories in Cisco ANA EventVision (continued)

Tab Description

Table 7-4 Cisco ANA EventVision Tools

Button Function

Displays the previous page of events in the Cisco ANA EventVision window.

Displays the next page of events in the Cisco ANA EventVision window.

Refreshes the events displayed in the log by querying the database. If a filter is active, the 
refresh is done according to the filter. The log returns to the beginning of the list, 
displaying the events in ascending or descending order depending on the order of the 
current list. Descending order means that the last event is displayed first. For more 
information, see Refreshing Cisco ANA EventVision Information, page 8-20.
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Cisco ANA EventVision Menu Bar 
Table 7-5 describes the options available in the Cisco ANA EventVision main menus. In addition to 
these options, Cisco ANA EventVision displays a shortcut Properties option when you right-click an 
event or ticket (see Viewing Event Properties, page 8-14). 

Displays the Cisco ANA EventVision Filter dialog box, which enables you to define a 
filter for the events displayed in the Cisco ANA EventVision log. For more information, 
see Filtering Events and Tickets, page 8-21.

Toggles automatic refresh of event data on and off. You define the refresh-time period (in 
seconds) in the Cisco ANA EventVision Options dialog box. The default is 60 seconds. If 
a filter is active, the refresh is done according to the filter. For more information, see 
Selecting Cisco ANA EventVision Viewing Options, page 7-8.

Displays the properties of the selected event or ticket in the Properties pane.

Table 7-4 Cisco ANA EventVision Tools (continued)

Button Function

Table 7-5 Cisco ANA EventVision Menu Options

Menu Option Description

File Menu

Export Exports the log event information displayed in the Cisco ANA EventVision 
window according to the criteria defined in the Cisco ANA EventVision Options 
dialog box.

Open 3.6.x Tabs Displays the following tabs:

• 3.6.x Ticket

• 3.6.x Service

• 3.6.x Syslog

• 3.6.x V1 Trap

• 3.6.x V2-V3 Trap

This option is available only if Cisco ANA was upgraded from version 3.6.7 to 
Cisco ANA 3.7 or 3.7.1.

Open All Tab Displays the All tab so you can view a flat list of all events and tickets sorted only 
by time.

To disable the All option, follow the instructions provided in the Cisco Active 
Network Abstraction 3.7.1 Installation Guide. 

Exit Exits Cisco ANA EventVision. 

Edit Menu

Filter Defines a filter for the events displayed in the Cisco ANA EventVision window 
according to the tab selected. See Filtering Events and Tickets, page 8-21.

Purge This option is unavailable in this version.
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Right-Click Options
Cisco ANA EventVision offers the following right-click options in its tabs:

• Show Only Selected Rows—Displays only the rows that you choose.

• Show All Rows—Displays all rows that meet the current filter criteria.

• Launch external applications or tools—Enables you to launch any external application or tool for 
any event in Cisco ANA EventVision. For more information, see the Cisco Active Network 
Abstraction 3.7.1 Customization User Guide. 

• Properties—Displays the properties window for the selected event or ticket. 

View Menu

Refresh Refreshes the information displayed in the Cisco ANA EventVision window.

Go To Navigates through the pages of the Cisco ANA EventVision window. 

Properties Displays the properties of the selected event, such as the root cause and source. 
For more information, see Viewing Event Properties, page 8-14.

Details Pane Displays or hides the Properties pane. If an event is selected, the properties of the 
selected event are displayed in the Properties pane.

Tools Menu

Change User 
Password

Allows you to change the password used when logging into the Cisco ANA client 
application suite. The change takes effect the next time you log into the 
application.

Options Defines the display options for the Cisco ANA EventVision window. For more 
information, see Selecting Cisco ANA EventVision Viewing Options, page 7-8

Reports Menu

Report Manager Opens the Reports Manager dialog box so you can create, run, and manage 
reports.

Run Report Enables you to run standard event and inventory reports on demand.

Help Menu

Cisco ANA 
EventVision Help

Opens the online help for Cisco ANA EventVision and Cisco ANA 
NetworkVision.

Cisco.com This option is unavailable.

About Cisco ANA 
EventVision

Displays application information, such as the version number.

Table 7-5 Cisco ANA EventVision Menu Options (continued)

Menu Option Description
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Selecting Cisco ANA EventVision Viewing Options
The Cisco ANA EventVision Options dialog box enables you to define the options for displaying events 
in the Cisco ANA EventVision window.

To define Cisco ANA EventVision options:

Step 1 From the main menu, choose Tools > Options. 

Step 2 In the Cisco ANA EventVision Options dialog box, select the required settings as described in Table 7-6.

Step 3 Click OK.

Table 7-6 Cisco ANA EventVision Options Dialog Box

Option Description

Save last filter Saves the filter criteria defined per event type in the Filter Events dialog box. The 
filter criteria are available the next time you log into Cisco ANA EventVision. 

Note Events are not filtered automatically when you next log into Cisco ANA 
EventVision unless the Open using filter option is selected as well.

Open EventVision 
with saved filter

When enabled, applies the previously defined filter to the events as soon as you 
log into Cisco ANA EventVision. The events are continuously filtered according 
to the defined settings, even after you close the application.

Show n events 
per page

Specifies the number of events to be displayed per page.

Export n events 
in total

Sets the maximum number of events to be exported to a file.

Run auto refresh 
every n secs

Automatically refreshes the Cisco ANA EventVision display after the specified 
number of seconds. 

Note If you modify this option, you are prompted to confirm your choice. 
Confirmation is required because this option uses rapid refresh from the 
database, which can slow down other vital database options.

Display events for 
the last n days

Displays past events from the specified number of days. Values range from 1 to 
14 days, with a default of 2 days.

If you increase the number of days, it might take longer for the events to be 
displayed.
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