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Working with Cisco ANA NetworkVision Maps

This chapter describes how to work with the topological maps displayed in the workspace of the 
Cisco ANA NetworkVision window. The topological map is the main tool used by Cisco ANA 
NetworkVision to display the links and relationships between the network elements and/or aggregated 
nodes. 

• Opening Selected Maps, page 4-2, describes how to open maps that were last visited by you, quickly 
and easily when the application is launched.

• Creating a New Map, page 4-3, describes how to create a new map.

• Opening a Map, page 4-4, describes how to open an existing map.

• Adding a Device, page 4-5, describes how to add a device in a map.

• Removing a Device from the Map, page 4-6, describes how to remove a device from the map.

• Defining the Map Layout, page 4-6, describes how to define the layout of the network in a map.

• Saving a Map, page 4-7, describes how to save the layout of the map.

• Saving as a New Map, page 4-8, describes how to save a copy of the entire map or parts thereof while 
leaving the original map intact.

• Saving a Map as an Image, page 4-8, describes how to save a map as an image.

• Closing a Map, page 4-10, describes how to close a map.

• Deleting a Map, page 4-10, describes how to delete a map.

• Renaming a Map, page 4-10, describes how to rename an existing map.

• Resizing a Device, page 4-11, describes how to define the size of selected device(s) or aggregated 
nodes in the map pane.

• Viewing the Network, page 4-12, describes how to display the entire network map or any part of the 
map, in the Overview window. In addition, it describes how to display an aggregated node in a 
thumbnail.

• Viewing a Network Device, page 4-13, describes how to view any network device on the map. The 
device is selected in the appropriate map in the workspace and/or tree pane and the active tickets are 
shown in the ticket pane.

• Selecting Map Views, page 4-14, describes the various selection tools that can be used to view and 
analyze maps in the map pane.

• Finding a Ticket Source, page 4-15, describes how to find the source of a ticket displayed in the 
ticket pane.

• Finding a Link Source, page 4-15, describes how to find the source of a link displayed in the links 
view.
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• Finding a Network Device, page 4-15, describes how to find and display a network device on the 
map.

• Aggregating Devices, page 4-16, describes how to aggregate devices. In addition, it describes how 
to disaggregate the aggregated node selected in the map pane. 

• Renaming an Aggregated Node, page 4-17, describes how to rename an existing aggregated node.

• Filtering Links According To Type, page 4-17, describes how to filter (display or hide) the different 
types of links displayed in the map pane.

• Opening the CPU Usage Graph, page 4-20, describes how to display memory and CPU usage 
information for a device.

• Communicating with Devices, page 4-20, describes how to ping and telnet a device.

• Previewing a Map, page 4-21, describes how to preview a map before it is printed. 

• Defining the Print Setup, page 4-22, describes how to define the print setup. 

• Printing a Map, page 4-23, describes how to print the map that is currently displayed.

Opening Selected Maps 
When Cisco ANA NetworkVision is launched, the Cisco ANA NetworkVision window appears. Maps 
that were last visited by you can be opened quickly when the application is launched, if you closed the 
application without closing the maps.

Note First time users and users that closed their maps before closing the application will not be able to open 
maps using this functionality.

To open a selected map:

Step 1 Launch Cisco ANA NetworkVision. The Cisco ANA NetworkVision window is launched with the Open 
Selected Maps dialog box. For more information about launching Cisco ANA NetworkVision, see 
Starting Cisco ANA NetworkVision, page 2-1.

The Open Selected Maps dialog box displays a list of the maps last visited by you and that were not 
closed by you when exiting the application. By default all the maps that were last visited by you are 
selected.

The following buttons are displayed in the Open Selected Maps dialog box:

• All—Selects and opens all the last visited maps.

• Selected—Opens the maps that have been selected (checked) in the Open Selected Maps dialog box.

• None—Deselects all the last visited maps and displays an empty Cisco ANA NetworkVision 
window. You can now create a new map (see Creating a New Map, page 4-3) or open a map that was 
previously saved in the database.

Step 2 Click All,

or

Click None,

or
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Clear the checkbox(es) for the maps that you do not want to display in the Cisco ANA NetworkVision 
window and click Selected.

The maps are displayed in the Cisco ANA NetworkVision window according to the defined selection.

Note By default you can only view and work on a maximum of five maps at any given time in the 
NetworkVision map pane (to change this default setting please contact Cisco Professional 
Services). To create a new map or select a new map, close the required amount of maps.

Creating a New Map 
When Cisco ANA NetworkVision is launched for the first time, or if None is selected in the Open 
Selected Maps dialog box (as described in the previous section) the Cisco ANA NetworkVision window 
appears empty.

A new map must be created, or a map that was previously saved can be opened, in order to display the 
network. Cisco ANA NetworkVision supports the creation of multiple network maps in order to 
represent specific network views. Views can cover specific network segments, customer networks, or any 
other mix of network elements desired. When a user creates a map it is available to other users (assuming 
they have sufficient access/security privileges).

The network maps provide a graphic display of active faults and alarms and serve as an easy access point 
for the activation of services.

Note You can create a new map, select a filter and then add the devices to the map. This filter will then be 
applied to the new map and only the required link types will be visible in the map pane and recorded the 
links view. For more information see Filtering Links According To Type, page 4-17.

Note You cannot define the same name for two or more maps.

To create a new map:

Step 1 On the toolbar, click New Map, 

or

Select New Map from the File menu. The Create Map dialog box is displayed. 

Note Cisco ANA NetworkVision has the following pre-configured map name defaults; the 
administrator can however modify these defaults using the Cisco ANA Registry:
The minimum map name length of is 1 character.
The maximum map name length is 65 characters.
The map name cannot contain any symbols, excluding the $ symbol.

The Advanced button enables you to filter the links displayed in the map pane. For more information 
see Filtering Links According To Type, page 4-17.
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Step 2 Enter a name for the new map and click OK. An empty new map is displayed in the tree pane and map 
pane, as displayed below. For more information on adding devices, see Adding a Device, page 4-5. 

Opening a Map
Cisco ANA NetworkVision enables you to open a map that was previously saved. When you open the 
map, the network information is automatically refreshed. For example, if a device was up the last time 
that the map was saved and closed, and then the device is moved to maintenance, the next time you open 
the map the management status of the device will be updated accordingly and the device will display a 
maintenance status.

Note The maps that you last visited can be opened quickly when the application is launched provided that you 
closed the application without closing the maps. For more information 
see Opening Selected Maps, page 4-2.

To open a map:

Step 1 On the toolbar, click Open Map,

or

Select Open from the File menu. The Map List dialog box is displayed.

The Map List dialog box displays the map name as defined by the network administrator.

The Find field enables you to search for information in the table according to the selected column. For 
more information see Finding Text in a Table, page 3-2.

The Map List dialog box contains the following tools:

Tool Description

Export to CSV—Exports the information displayed in the table. For more 
information see Exporting the Table to a File, page 3-5.

Note The tools described above occur throughout the application and 
provide the same functionality.

Delete Map—Deletes the selected map from the Map List dialog box, the 
Cisco ANA NetworkVision window and from the database. If a map that is 
being opened is deleted, this map will close. For more information see 
Deleting a Map, page 4-10.

Rename Map—Renames the selected map in the Map List dialog box and 
Cisco ANA NetworkVision window. For more information see Renaming a 
Map, page 4-10.

Sort Table Values—Enables you to sort the information displayed in the 
table.

Filter—Defines a filter for the information displayed in the table. For more 
information see Defining a Filter, page 3-2.

Note When a filter is applied the Set Selection Filter button is activated.
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Step 2 Select the map that you require from the Map List and click Open,

or

Right-click on the required map, and select Open from the displayed shortcut menu,

or

Double-click on the required map. The map is displayed in the Cisco ANA NetworkVision window with 
the network.

One or more maps can be opened in the Cisco ANA NetworkVision window displaying the various 
available networks. Use the Windows menu to move between the open maps. For more information on 
the Cisco ANA NetworkVision window, see Chapter 2, “Getting Started”.

Note By default you can only view and work on a maximum of five maps at any given time in the 
NetworkVision map pane (to change this default setting please contact Cisco Professional Services). To 
create a new map or select a new map, close the required amount of maps.

Adding a Device
Cisco ANA NetworkVision enables you to add devices to the network. The device is added to the map 
or aggregation selected in the tree pane and workspace. In addition, devices that are added to the network 
are automatically saved. 

Note Based on the security level and access permissions assigned to a user, this option may not be available.

To add a device:

Step 1 On the toolbar, click Add Device,

or

Select Add Device from the File menu. The Device List dialog box is displayed, with all the devices that 
are managed by the system.

Set Selection Filter—Applies filters to the selected line or lines displayed in 
the Map List. 

Note When you select one or multiple lines, the Previous Selection Filter 
(and Rewind All) buttons are activated.

Previous Selection Filter—Enables you to undo the last applied filter 
selection. 

Rewind All—Enables you to undo previous filter selections, and display all 
the original information in the table. 

Help—Opens the online help.

Tool Description
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Note Locked devices only display device information and the Locked Device icon.

For more information about:

• The columns that are displayed in the Device List dialog box, see Device View, page 2-9.

• The buttons displayed in the Device List dialog box, see Device View, page 2-9.

Step 2 From the Device List, select the device that you want to add.

Note You can select and add multiple devices using <Ctrl> or <Ctrl +A> or by clicking and dragging 
the mouse.

Step 3 Click Add Device. The device is displayed in the tree pane and the selected map or sub-network in the 
Cisco ANA NetworkVision window’s workspace. In addition, any tickets are displayed in the ticket 
pane.

Note When a device is added to the network it is no longer displayed in the Device List dialog box 
dialog box.

Step 4 Click Close to close the Device List dialog box. The Cisco ANA NetworkVision window is displayed.

Removing a Device from the Map
Cisco ANA NetworkVision enables you to remove a device or aggregated node from the map. 

A device that has been removed from the map is not deleted from the network. 

To remove a device or aggregated node from the map:

Step 1 Select the device or aggregated node that you want to delete in the tree pane or map pane.

Step 2 Right-click to display the shortcut menu and select Remove from Map. The selected device or 
aggregated node is removed from the map.

Defining the Map Layout
Cisco ANA NetworkVision enables you to select the way in which the network object topology is 
displayed. The map pane displays the selected layout, namely, Circular, Symmetric, Hierarchical or 
Tree.
4-6
Cisco Active Network Abstraction NetworkVision User Guide, Version 3.6

OL-12500-01



 

Chapter 4      Working with Cisco ANA NetworkVision Maps
    Saving a Map
To define the map layout:

Step 1 On the toolbar, click on the dropdown list next to the Layout button and select one of the following 
options:

• Circular

• Symmetric

• Tree

• Hierarchical

or

Select Layout from the View menu and from the dropdown list, select one of the options displayed, as 
described above.

The map is displayed according to the selected option.

Note Clicking Layout on the toolbar displays the map according to the option last selected. Circular 
is the default layout option.

Saving a Map
Cisco ANA NetworkVision enables you to save map layouts and change existing ones. 

The following changes are saved automatically:

• Addition or removal of a device 

• Addition or removal of a link

• Aggregation or disaggregation of elements

The following changes to the workspace are only saved when the Save option is selected:

• The location of the devices on the map

• The layout

• Thumbnails

• The size of the devices

The maps can then be opened later as required.

To save changes to a map:

Step 1 On the toolbar, click Save Map Appearance,

or

Select Save Map from the File menu. Your changes are saved.
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Saving as a New Map
The user can save a copy of the entire map or parts thereof (specific devices and aggregations) while 
leaving the original map intact.

To save as a new map:

Step 1 Make sure that the map that you want to save is displayed in the Cisco ANA NetworkVision window or 
that the required network elements and/or aggregated nodes are selected in the tree pane and map pane.

Step 2 Right-click in the tree pane or map pane to display the Device shortcut menu. Select Save as New Map. 
The Create Map dialog box is displayed with a default name for the new map.

Step 3 Enter a new name for the map,

or

You can accept the name provided by default.

Step 4 Click OK. The new map is created.

Note For more information about how to open the new map, see Opening a Map, page 4-4.

Saving a Map as an Image
Cisco ANA NetworkVision enables you save the currently displayed map as an image.

To save a map as an image:

Step 1 Select Save As Image from the File menu. The Save as Image dialog box is displayed.
4-8
Cisco Active Network Abstraction NetworkVision User Guide, Version 3.6

OL-12500-01



 

Chapter 4      Working with Cisco ANA NetworkVision Maps
    Saving a Map as an Image
Figure 4-1 Save as Image Dialog Box

The following fields are displayed in the Image area:

• Type—Enables you to select the type of image required.

Note The file types .svg and .png are not available in this version.

• File Name—Enables you to define a name for the image.

The following checkboxes are displayed in the Image Content area:

• Visible Window Only—Saves only the currently displayed window as an image.

• Draw Grid—This option is not available in this version.

• Selected Objects Only—Saves only the selected network objects as an image.

The Image Characteristics area enables you to define the quality of the image by entering a figure or by 
clicking and dragging the slider.

The following radio buttons are displayed in the Size area:

• Current Zoom Level—Saves the image at the currently selected zoom level. Selecting this radio 
button enables the Visible Window Only checkbox.

• Actual Size—Saves the image at the actual size.

• Fit in Window—Saves the image to fit in the window.

• Custom—Saves the image at an enlarged or reduced size. Selecting this radio button enables the 
Width and Height options.

Step 2 Define the image settings that are required.

Step 3 Click OK. The map is saved, as an image is the defined directory.
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Closing a Map
Cisco ANA NetworkVision enables you to close a map displayed in the map pane whenever required. At 
the same time other maps can be left open in order to work with them. 

To close a map:

Step 1 Select Close from the File menu,

or

Click in the upper right-hand corner of the map in the workspace. 

If changes have been made to the map, an information message is displayed.

Step 2 Click Yes. The map is saved and closed. An empty Cisco ANA NetworkVision window is displayed, or 
the map that was last opened is displayed.

Deleting a Map
Cisco ANA NetworkVision enables you to delete a map from all the views in the Cisco ANA 
NetworkVision window.

To delete a map:

Step 1 On the toolbar, click Open Map,

or

Select Open from the File menu. The Map List dialog box is displayed.

Step 2 From the Map List, select the map that you want to delete.

Step 3 On the toolbar, click Delete Map. An confirmation message is displayed.

Step 4 Click Yes. The selected map is deleted from the Map List dialog box, the Cisco ANA NetworkVision 
window and the database.

Step 5 Click Close to close the Map List dialog box. The Cisco ANA NetworkVision window is displayed.

Note When a map that is open is deleted, a message is displayed to all users of the client that the map 
is being closed and deleted from the database.

Renaming a Map
Cisco ANA NetworkVision enables you to rename a map that is displayed in the Cisco ANA 
NetworkVision window. The name change affects all users of the map and the new name is displayed in 
the Cisco ANA NetworkVision window of all users.
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To rename a map:

Step 1 On the toolbar, click Open Map,

or

Select Open from the File menu. The Map List dialog box is displayed.

Step 2 From the Map List, select the map that you want to rename.

Step 3 On the toolbar, click Rename Map. The Rename Map dialog box is displayed.

Step 4 Enter the new map name.

Step 5 Click OK. The selected map is renamed in the Map List dialog box, in the Cisco ANA NetworkVision 
window and in the database.

Step 6 Click Close to close the Map List dialog box. The Cisco ANA NetworkVision window is displayed.

Resizing a Device
Cisco ANA NetworkVision enables you to define the size of selected devices or aggregated nodes in the 
map pane, according to predefined sizes or according to a percentage of the current size.

Note You can manually resize a node by selecting it and dragging the corner (handle).

To resize a device or aggregated node:

Step 1 Select the devices and/or aggregated node that you want to resize in the map pane.

Note The Resize option is only enabled when devices and/or aggregated nodes are selected. If there 
are any links selected this option is disabled.

Step 2 On the toolbar, click Resize Selected Nodes,

or

Select Resize from the Edit menu.

or

Right-click on the selected devices and/or aggregated node in the map pane to display the Device 
shortcut menu. Select Resize. 

The Resize Nodes Controller dialog box is displayed.

The following fields are displayed in the Resize Nodes Controller dialog box:

• Resize Node—Displays a dropdown list of percentages according to which the map selection is 
resized based on the current size.

• Set Node Sizes—Displays a dropdown list of fixed sizes according to which the map selection is 
resized.

Step 3 Select an option from the Resize Node or Set Node Sizes dropdown list.
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Step 4 Click OK. The selected devices and/or aggregated node are resized.

Viewing the Network
Cisco ANA NetworkVision enables you to display the entire network map or any part of the map in the 
Cisco ANA NetworkVision window.

You can use the Zoom tools or the Overview window to display the part of the map that you require. The 
Overview window enables you to view all the changes and alarms taking place in the network. In 
addition, you can display an aggregated node in a thumbnail. 

To open an overview of the network:

Step 1 On the toolbar, click Overview,

or

Select Overview from the View menu. The Overview window is displayed.

Figure 4-2 Overview Window

Step 2 In the Overview window, select the area that you require by clicking and dragging the mouse to view the 
required area and thereby enlarging it in the map pane. A blue rectangle is displayed around the selected 
area. You can move the selected area by placing the mouse above the rectangle. The mouse icon will be 
changed to a hand, and you can then click and drag the mouse to move the rectangle over the required 
area.

Step 3 Click and drag the rectangle again to select or resize a different network area.

Step 4 Click  to close the Overview window.

In addition, you can display a thumbnail of the selected aggregated node in the map pane, including all 
the aggregated devices. Thumbnails can also be nested.

To display a thumbnail of the node:

Step 1 Right-click on an aggregated node in the map pane to display the Aggregated Node shortcut menu.
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Step 2 Select Show Thumbnail. The thumbnail is displayed in the map pane.

Figure 4-3 Thumbnail

Note To redisplay the aggregated node in the map pane right-click on the thumbnail and select Show 
As Aggregation.

Note To resize the thumbnail select it, and click and drag any of the thumbnail handles.

Viewing a Network Device
Cisco ANA NetworkVision enables you to view any network device in the currently displayed map.

The network device is selected in the map pane and the tree pane. The ticket pane displays all the active 
and cleared tickets, however, the user can filter the tickets so that only the tickets of the selected network 
device are displayed in the ticket pane. 

For more information about filtering tickets by device, see Filtering Tickets by Device, page 8-4.

To view a network device:

Step 1 Click on the device in the tree pane or select the device on the map. 

Note • You can use the Zoom tools when viewing the network, see Cisco ANA NetworkVision Toolbar, 
page 2-18.

• Click Overview on the toolbar to display the network in the Overview window.
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Selecting Map Views
Cisco ANA NetworkVision provides you with various selection tools that can be used to view and 
analyze maps in the map pane.

You can view graphical representations of NEs and various links appearing in the map pane of the 
Cisco ANA NetworkVision window’s workspace using the toolbar buttons.

The Device View and Show Links View buttons open dynamic tables listing network element/device 
information and respective map context links in table-format (not graphical links). The respective tables 
are displayed in the Cisco ANA NetworkVision window’s workspace. For more information on viewing 
and working with device view tables and filtering the links view, see Chapter 3, “Working with 
Cisco ANA NetworkVision Tables”.

Cisco ANA NetworkVision provides you with various selection tools that can be used to view and 
analyze maps in the map pane and the links view table displayed in the workspace as described below.

To select a tool:

Step 1 From the View menu choose the required selection tool,

or

On the toolbar, click the required selection tool.

Button Function

Defines the way in which the map is displayed in the map pane of the 
Cisco ANA NetworkVision window, namely, Circular, Symmetric, Tree or 
Hierarchical. 

Displays the device view in the Cisco ANA NetworkVision window’s 
workspace (the button toggles when selected or deselected).

Displays the links view in the Cisco ANA NetworkVision window (the 
button toggles when selected or deselected). 

Displays the map pane in the Cisco ANA NetworkVision window (the button 
toggles when selected or deselected). 

Activates the normal selection mode (the button toggles when selected or 
deselected).

Activates the pan mode, which enables you to move around in the map pane 
by clicking and dragging (the button toggles when selected or deselected).

Activates the zoom selection mode, which enables you to select an area in the 
map pane to be enlarged by clicking and dragging to view the selected area 
(the button toggles when selected or deselected).

Fits the entire sub-network or map in the map pane.
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Finding a Ticket Source
Cisco ANA NetworkVision enables you to find the source of a ticket displayed in the ticket pane by 
highlighting the device in the tree pane and/or map pane.

To find the ticket source:

Step 1 Right-click on the required ticket in the ticket pane to display the Ticket shortcut menu. 

Step 2 Select Find Source from the Ticket menu. The source of the ticket is highlighted in the tree pane and/or 
map pane.

Note A blue selection box highlights the device that is the source of the ticket.

Step 3 Click anywhere in the tree pane or the map pane to remove the highlight from the selected device or link.

Finding a Link Source
Cisco ANA NetworkVision enables you to find a link displayed in the links view by highlighting the link 
in the map pane.

To find the link:

Step 1 Right-click on the required link in the links view to display the Links View menu. 

Step 2 Select Find Source from the Links View menu. 

The source of the link is highlighted in the map pane.

or

If there are two or more lines that represent the same links, for example, a VRF link, the Select Link 
Context dialog box is displayed. Select the required link context from the dropdown list and click OK. 
The source of the link is highlighted in the map pane.

Note A blue link highlights the source of the link in the map pane.

Step 3 Click anywhere in the tree pane or the map pane to remove the highlight from the selected link.

Finding a Network Device
Cisco ANA NetworkVision enables you to find a device in the map by entering the device name or the 
device IP address or any part thereof.
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To find a device in the map:

Step 1 On the toolbar, click Find in Map, 

or

Select Find in Map from the Edit menu. The Find in Map dialog box is displayed.

The Search all map levels checkbox enables you to search for a device or IP address at all levels of the 
map. This option is selected by default. Clearing this option searches for the device, but excludes device 
aggregations from the search.

Step 2 Enter the device name or the IP address.

Note You can enter a partial name (case sensitive) or IP address. For example, XY will find the devices 
with the names containing the letters XY.

Step 3 Click OK to enable the search in all the maps and sub-networks. A device matching the search criteria 
is displayed on the map.

Step 4 Press F3 to view the next device matching the search criteria.

Aggregating Devices
Cisco ANA NetworkVision enables you to aggregate devices in the map pane.

To aggregate devices:

Step 1 Select the required devices in the map pane,

or

Select the required devices in the tree pane or map pane using <Ctrl> or the selection tool.

Step 2 On the toolbar, click Aggregate,

or

Select Aggregate from the Node menu,

or

Right-click on the selected devices in the tree pane or map pane to display the Device menu. Select 
Aggregate. 

The Aggregation dialog box is displayed prompting you to enter a name for the aggregated node.

Step 3 Enter a unique name for the aggregated node and click OK. The aggregated node is displayed in the tree 
pane and map pane. Aggregated nodes are displayed as a single entity with the Aggregation icon.

The aggregated node icon changes color according to the alarm severity. For more information about 
device colors, see Status of Network Objects, page 2-15.

The aggregated node selected in the map pane and tree pane of the Cisco ANA NetworkVision window 
can be disaggregated.
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To disaggregate a node:

Step 1 Select the required branch in the tree pane,

or

Select the required aggregated node in the map pane.

Note The Aggregation icon indicates an aggregated node.

Step 2 Select Disaggregate from the Node menu,

or

Right-click on the aggregated node in the tree pane or map pane to display the Aggregated Node shortcut 
menu. Select Disaggregate. 

An information message is displayed.

Step 3 Click Yes. The node is disaggregated.

For more information about resizing an aggregated node, see Resizing a Device, page 4-11.

Renaming an Aggregated Node
Cisco ANA NetworkVision enables you to rename an aggregated node that is displayed in the 
Cisco ANA NetworkVision window.

The name change affects all users of the map and the new name is displayed in the Cisco ANA 
NetworkVision window of all users.

To rename an aggregated node:

Step 1 Select the aggregated node that you want to rename in the tree pane or map pane.

Step 2 Right-click on the aggregated node to display the Aggregated Node menu and select Rename. The 
Rename Node dialog box is displayed.

Step 3 Enter a new name for the aggregated node and click OK. The selected aggregated node is renamed in 
the tree pane and map pane and in the database.

Filtering Links According To Type
The links filter enables the user to filter the links displayed in the map pane and in the links view.
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The user quickly selects the types of links to be filtered by selecting from a predefined set of link types 
in the list or by manually configuring a customized set of link types. The user can either:

• Create a new map, select a filter and then add the devices to the map. This filter will then be applied 
to the new map and only the required link types will be visible in the map pane and the links view
(method 1)
or

• Create a map and add the devices with all the links enabled and visible in the map pane and links 
view. The user can then filter (display or hide) the different types of links required (method 2).

Note By default all the link types are displayed in the map pane and links view until the links filter is applied.

Note The filter only applies to the map pane and the links view; it has no affect elsewhere in Cisco ANA 
NetworkVision. Since the filtered links are removed from the map, it also has an affect on the severity 
of the network elements.

To filter links according to type (method 1):

Step 1 On the toolbar, click New Map,

or

Select New Map from the File menu.

The Create Map dialog box is displayed. For more information see Creating a New Map, page 4-3.

Step 2 Click Advanced. The Map Options dialog box is displayed.

Figure 4-4 Map Options Dialog Box
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Note By default all the link types are selected in the Map Options dialog box, namely, all the links are 
displayed in the map pane and links view.

The Map Options dialog box displays a list of all the types of links that can be filtered by the user in the 
map pane.

The Group dropdown list contains the following options:

• Custom—Only the links defined for the customized filter are displayed in the map pane.

• All—All the links are displayed in the map pane.

• Data Link—The data link layer class of links is displayed in the map pane, namely, ATM and FR.

• None—None of the links are displayed in the map pane.

• Physical—Only the physical links are displayed in the map pane.

• VPN—Only the VPN links are displayed in the map pane.

ATM, VPN, MPLS, and Ethernet are just some of the options displayed in the Map Options dialog box 
that can be used to filter the links displayed in the map pane and in the links view.

Note The Group dropdown list options can be customized by selecting an option and adding or 
removing the required link types. The next time the Map Options dialog box is opened the 
Custom option is displayed with the required link types.

Step 3 Select or clear the checkbox(es) for the links that you want or do not want to display in the map pane 
and links view.

Step 4 Click OK/Apply to apply the defined link filter settings.

Step 5 Enter a name for the new map and click OK. An empty new map is displayed in the tree pane and map 
pane.

Step 6 Add the required devices to the network. For more information see Adding a Device, page 4-5. 

The links are displayed in the map pane and links view according to the defined filter criterion.

A user can also create a map and add the devices with all the links enabled and visible in the map pane 
and links view. The user can then filter (display or hide) the different types of links required.

To filter links according to type (method 2):

Step 1 On the toolbar, click Map Options. The Map Options dialog box is displayed.

Step 2 Clear the checkbox(es) for the links that you do not want to display in the map pane and links view.

Step 3 Click OK/Apply to apply the defined link filter settings. The links are displayed in the map pane and 
links view according to the defined filter criterion

.
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Opening the CPU Usage Graph 
Cisco ANA NetworkVision enables you to display memory and CPU usage information for a 
device/network element, including its history.

To open the CPU usage graph:

Step 1 Right-click on a device/network element in the tree pane or map pane to display the Device shortcut 
menu.

Step 2 Select Tools | CPU Usage. The CPU Usage dialog box is displayed.

The following areas are displayed in the CPU Usage dialog box:

• CPU Usage—The CPU usage rate as a percentage.

• CPU Usage History—The CPU usage rate history is graphically displayed.

• Memory Usage—The memory usage rate as a percentage.

• Memory Usage History—The memory usage rate history is graphically displayed.

The following tool is displayed in the dialog box:

Step 3 Click Close to close the CPU Usage dialog box.

Communicating with Devices 
Cisco ANA NetworkVision enables you to communicate with devices in the following ways:

• Pinging the Device

• Telneting the Device

Pinging the Device
Cisco ANA NetworkVision enables you to ping the device in order to check whether the device is 
responding.

Note The ping is performed from the client to the device, and not from the ANA Unit hosting the VNE to the 
device.

To ping the device:

Step 1 Select the required device in the tree pane or map pane in the workspace.

Step 2 Right-click on the required device to display the Device shortcut menu.

Exports all the information currently displayed in the dialog box. This 
information can then be viewed at a later stage. For more information see 
Exporting the Table to a File, page 3-5.
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Step 3 Select Tools | Ping. The Ping window is displayed and the device is pinged.

Telneting the Device
Cisco ANA NetworkVision enables you to communicate with the device using the Telnet window.

Note The telnet is performed from the client to the device, and not from the ANA Unit hosting the VNE to the 
device.

To telnet the device:

Step 1 Select the required device in the tree pane or map pane in the workspace.

Step 2 Right-click on the required device to display the Device shortcut menu.

Step 3 Select Tools | Telnet. The Telnet window is displayed.

Step 4 Complete the necessary communication with the device.

Previewing a Map
Using Cisco ANA NetworkVision you can preview a map before it is printed.

To preview a map:

Step 1 Display the map that you want to print in the map pane.

Step 2 Select Print Preview from the File menu. The Print Preview dialog box is displayed with the active map.

The following buttons are displayed in the Print Preview dialog box:

• Print—Prints the displayed network/map to the selected printer.

• Print Setup—Opens the Print Setup dialog box enabling you to define how the network/map is 
printed. For more information see Defining the Print Setup, page 4-22.

• Zoom In—Zooms in on the network/map.

• Zoom Out—Zooms out of the network/map.

• Zoom %—Zoom in to get a close-up view of your network/map or zoom out to see more of the 
network/map at a reduced size. Click the arrow next to the Zoom box and the zoom setting that you 
want.

• Fit In Window—Displays the entire network/map in the Print Preview dialog box.

• Close—Closes the Print Preview dialog box.

Step 3 Click Print. The required map is printed to the selected printer.
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Defining the Print Setup
Cisco ANA NetworkVision enables you to define the print setup of a map before it is printed.

To define the print setup:

Step 1 Open the Print Preview dialog box, see Previewing a Map, page 4-21.

Step 2 Click Print Setup. The Print Setup dialog box is displayed.

Figure 4-5 Print Setup Dialog Box

The following radio buttons are displayed at the top of the Print Setup dialog box:

• Print Entire Graph—Prints the currently displayed map, including aggregated nodes.

• Print Current Window—Prints the currently displayed map, excluding aggregated nodes.

• Print Current Selection—Prints the area selected in the currently displayed map.

The following radio buttons are displayed in the Scale By area, enabling you to define the number of 
pages and size at which the map is printed:

• Pages—Prints the currently displayed map according to the numbers specified in the Page Columns 
and Page Rows fields.

• Actual Size—Prints the currently displayed map at the actual size.

• Zoom Level—Prints the currently displayed map according to the selected zoom level.

The following checkbox is displayed in the Caption area:

• Print Caption—Select this option to add a caption to the printed map and enter the required text in 
the field below.

The following field is displayed in the Caption area:

• Position—Defines the position of the caption in the printed map.

The Margins area enables you to define the print margins of the map.
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The following checkboxes are displayed in the Multipage Printing area:

• Print Page Numbers—Prints the map with page numbers.

• Print Crop Marks—Prints the map with crop marks.

The following checkboxes are displayed in the Other area:

• Print Border—Prints a border around the printed map.

• Print Background—Prints the background of the currently displayed map.

• Print Grid—Prints a grid for the printed map.

The following buttons are displayed in the Print Setup dialog box:

• Default—Restores the default print settings.

• Page Setup—Defines the page setup settings for printing.

Step 3 Define the print setup as required.

Step 4 Click OK. Now that you have defined the print setup you can print the map. For more information see 
Printing a Map, page 4-23.

Printing a Map
Cisco ANA NetworkVision enables you to print the map that is currently displayed.

To print a map:

Step 1 Select Print from the File menu.

or

Click Print in the Print Preview dialog box. For more information about the Print Preview dialog box, 
see Previewing a Map, page 4-21.
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