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Getting Started With Cisco ANA Manage

This chapter describes the Cisco ANA Manage working environment and how to access Cisco ANA 
Manage tools and commands. It also provides instructions for launching, and overviews operating 
Cisco ANA Manage application-using menu and toolbar options.

The Cisco ANA Manage window provides access to all Cisco ANA Manage’s functionality.

• Starting Cisco ANA Manage—Describes how to open the Cisco ANA Manage window.

• The Cisco ANA Manage Window—Briefly describes the Cisco ANA Manage window, including 
the tree pane and workspace.

• Cisco ANA Manage Window, Menus and Toolbars—Provides a detailed description of the 
information displayed in the Cisco ANA Manage window, the menus, and toolbars.

• Logging Out—Describes how to log out of Cisco ANA Manage.

Starting Cisco ANA Manage
Cisco ANA Manage is password protected to ensure security, and is only available to users with 
administrator privileges. Before you start working with Cisco ANA Manage, make sure you know the 
username, password and the Cisco ANA gateway IP address or hostname that you require.

Note If a user does not log into the Cisco ANA Manage, NetworkVision or EventVision applications during a 
specified period of time (the default is one month) the user’s account will be locked automatically. The 
default period can be changed in the Cisco ANA Registry. The period of time is measured from the time 
the user last logged out of any of the Cisco ANA client applications. For information about unlocking a 
user, see User’s Rights, page 10-9.

To start Cisco ANA Manage:

Step 1 From the Start menu, choose the Programs folder, then Cisco ANA/Cisco ANA Manage. The 
Cisco ANA Manage - Login dialog box is displayed.

It is recommended that you change the login password after logging in for the first time.

The last four Cisco ANA gateways to which the user logged in successfully are displayed in the Host 
dropdown list. The list is displayed in chronological order with the most recent gateway displayed at the 
top of the list.
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Step 2 Enter the Cisco ANA gateway information in the Host field, as an IP address or hostname,

or

Choose a Cisco ANA gateway from the Host dropdown list.

Note The gateway IP address or hostname that was used when you last logged in is automatically 
displayed at the top of the Host dropdown list.

Note Make sure that you use the leading IP address (the IP address on which the Cisco ANA gateway 
was configured) when logging into the system.

Step 3 Click OK. The Cisco ANA Manage window is displayed. The username and host information is 
displayed in the window title.

Note Some of the workspaces in the Cisco ANA Manage window may appear empty when the 
application is opened for the first time. 
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The Cisco ANA Manage Window
The Cisco ANA Manage window is displayed below.

Figure 2-1 Cisco ANA Manage Window

1 Menu bar

2 Toolbar

3 Tree pane

4 Shortcut menu

5 Workspace

6 Status bar
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The Cisco ANA Manage window includes:

• Tree Pane

• Cisco ANA Manage Window Workspace

• The Status Bar, displays the memory usage of the application process and connection status.

Dragging the borders in the window adjusts the size of each area. 

Tree Pane
The tree pane displays a tree-and-branch representation of the Cisco ANA Manage folders. The branches 
can be expanded and collapsed in order to display and hide information as needed. 

Cisco ANA Manage enables the user to manage and maintain information in Cisco ANA using the 
following branches in the Cisco ANA Manage window:

• ANA Servers—Enables the administrator to manage information relating to the Cisco ANA 
gateway, and Cisco ANA units, including the autonomous virtual machines (AVM) and the virtual 
network elements (VNE). This includes viewing a list of units, adding, editing and removing AVMs 
and VNEs, viewing VNE and AVM properties, starting and stopping AVMs and VNEs, and moving 
VNEs to maintenance mode. The ANA Servers branch includes the ANA gateway and AVM 
sub-branches. See ANA Servers Branch, page 2-7. 

• Global Settings—Includes the Client Licenses, DB segments, Message of the Day, Polling Groups 
and Protection Groups sub-branches. The Global Settings branch enables the administrator to:

– Install and manage client licenses. 

– View a table describing the storage allocated for all the database segments. See DB Segments 
Branch, page 2-21.

– Manage the service disclaimer (message of the day). See Managing Client Licenses, page 7-1.

– Manage the polling groups to be used by a group of devices. The administrator can define a few 
polling groups, and the devices will then be polled according to the polling group. Every polling 
group has a different set of polling intervals. See Managing Polling Groups, page 7-5. 

– Manage and change the default setup of the units by customizing protection groups (clusters) 
and then assigning units to these protection groups. See Managing Protection Groups, 
page 7-10.

For more information, see Global Settings Branch, page 2-18.

• Scopes—Group a collection of managed network elements together in order to enable the user to 
view and manage the network elements based on the user’s role. See Scopes Branch, page 2-27. 

• Topology—Manage topology-related parameters, namely, the static links between the devices. See 
Topology Branch, page 2-30. 

• Users—Define and manage user accounts. See Users Branch, page 2-32. 

• Workflow Engine—Manage workflow templates and running workflows in runtime. See Workflow 
Engine Branch, page 2-34.

Click on a branch in the tree pane to view information relating to the selected branch in the workspace. 
Right-click on a branch in the tree pane to open a shortcut menu to perform various functions.
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The following icons are displayed in the Cisco ANA Manage window:

Note The menus and toolbar are context sensitive; the options vary depending on your selection in the tree 
pane and the workspace.

Table 2-1 Cisco ANA Manage Window Icons

Branch Icon Description

ANA servers branch

Cisco ANA gateway

Cisco ANA units

Cisco ANA redundant unit

AVMs (VNE)

Global Settings branch

DB segments

Client licenses

Message of the day

Polling groups

Protection groups

Scopes

Topology

Users

Workflow engine

Templates

Workflows
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Cisco ANA Manage Window Workspace
The workspace pane displays the Cisco ANA Manage information according to the branch selected in 
the tree pane. The workspace is divided into two parts. The upper pane displays the properties of the 
element that is selected in the tree pane; the table in the lower pane displays its nested children.

Note Use the Ctrl key when selecting multiple rows in a table is displayed in the workspace.

The status bar displays the number of selected rows and the total number of rows in the table, for 
example, 6/6 Selected. It also displays the location of the selected rows in the table, for example, Line 2.

Table Toolbar
Whenever a table forms part of the workspace, the same toolbar is displayed, no matter which branch is 
selected in the tree pane. 

For details about choosing lines and applying filters, see Filtering Information, page 4-2 and Setting 
Selection Filters, page 4-3.

The Find field is used to search for information relating to the branch selected in the tree pane. See 
Finding Text In a Table, page 4-2.

Table 2-2 Table Toolbar Tools

Export to CSV—Save the current working environment as a file in Cisco ANA. 
See Exporting the Table To a File, page 4-5.

Sort Table Values—Sort the information displayed in the table, for example, 
according to status or IP address.

Filter—Define a filter on the information displayed in the table of the workspace 
using the Filter dialog box. See Filtering Information, page 4-2.

Note When a filter is applied the Set Selection Filter button and the Rewind 
All option under the Previous Selection Filter buttons are activated.

Set Selection Filter—Apply filters to the selected line or lines. 

Note When you choose one or multiple lines in a table, the Previous Selection 
Filter button is activated.

Previous Selection Filter—Undo the last applied filter selection. 

Rewind All—Undo all previous applied filter selections, and return all the 
originally displayed data to the table displayed in the workspace. 

Note This option is only activated when a filter is applied.

Opens the Cisco ANA Manage online help.
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Cisco ANA Manage Window, Menus and Toolbars
This section provides a detailed description of the information displayed in the Cisco ANA Manage 
window depending on the branch selected, the menus, and the toolbars.

For specific information about each branch, refer to:

• ANA Servers Branch

• ANA Server Entities Branch, including the ANA gateway and ANA units

• AVM Branch

• Global Settings Branch

• Scopes Branch

• Topology Branch

• Users Branch

• Workflow Engine Branch

ANA Servers Branch
Cisco ANA Manage maintains a list of all the servers defined in the system. The ANA Servers branch is 
used to add and remove unit servers.

You can expand this branch to view a list of the units, gateway and AVMs. Each gateway, unit and AVM 
has its own sub-branch. The ANA Servers branch (and associated sub-branches) is used to manage 
information relating to the AVMs and VNEs contained in the units. 

Note AVMs and VNEs should reside on a unit (as a common configuration) but they can also reside on a 
gateway. 
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The ANA Servers branch is displayed below.

Figure 2-2 ANA Servers Branch

The ANA Servers branch contains the following sub-branches:

• ANA Server Entities Branch

• AVM Branch

For more information about the ANA Server menu and toolbar options:

• ANA Servers Branch Menus

• ANA Servers Branch Toolbar

The workspace area displays a list of all the gateway and units and their status. Clicking on a column 
heading in the table in the workspace sorts the units in ascending or descending order according to the 
selected column.

Note Any changes that are made to the ANA Servers branch are saved automatically and registered 
immediately in Cisco ANA.

The following columns are displayed in the table in the workspace:

• IP Address—The IP address of the units, and gateways as defined in Cisco ANA Manage.

• Status—The status of the unit, as follows:

– Up—The unit is up.

– Down—The unit is down.

– Unreachable—The unit cannot be reached.

• Up Since—The date and time when the unit was last loaded.

• Physical Memory—The physical memory of the unit.

• Used Memory—The memory being used by the unit.
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• Allocated Memory—The amount of memory allocated to the unit. Allocated memory is the sum of 
all the memory settings for all the AVMs.

• Protection Group—The protection group to which the unit has been allocated.

• AVM HA—The unit is enabled for high availability (true) or disabled (false). By default this option 
is enabled for high availability.

For more information about the ANA Servers branch, see Chapter 5, “Managing Cisco ANA Units”.

ANA Servers Branch Menus

This section provides a description of each option available in the menus when the ANA Servers branch 
is selected. The following menus are available:

• File Menu

• Tools Menu

• Help Menu

• Tree Pane Menu

• Workspace Shortcut Menu

File Menu

The File menu is displayed.

New ANA Unit

Creates a new unit.

Exit

Exits Cisco ANA Manage. See Logging Out, page 2-39.

Tools Menu

The Tools menu is displayed.

Change User Password

Enables the user to change the password used when logging into the client application suite. The change 
will take effect the next time the user logs into the application. The Tools menu option is the same 
throughout the application.

Help Menu

The Help menu is displayed.

The Help menu enables the user to access online help about the application and to also display 
application information, for example, the version number. The Help menu options are the same 
throughout the application.
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Tree Pane Menu

When the user right-clicks on the ANA Servers branch the menu is displayed.

New ANA Unit

The user can add a new unit to the servers.

Workspace Shortcut Menu

When the user right-clicks on a selected unit the following shortcut menu (and sub-menu, when required) 
options are displayed.

New AVM

Adds an AVM to the selected unit. See Creating AVMs, page 6-1.

Properties

Displays the ANA Unit Properties dialog box. This dialog box lists the properties of the selected unit 
and indicates its status. See Editing Cisco ANA Unit Properties, page 5-4.

Delete

Deletes the selected unit.

Move VNEs

Move a VNE between AVMs. Actions can be performed on a single VNE or multiple VNEs.

ANA Servers Branch Toolbar

The ANA Servers branch contains the following toolbar options:

For more information about the ANA Servers branch, see Chapter 5, “Managing Cisco ANA Units”.

ANA Server Entities Branch 
The ANA Server Entities sub-branch includes the ANA Gateway and ANA Unit sub-branches. All the 
options described here refer to both sub-branches.

The ANA Server Entities sub-branch enables the user to manage information relating to the AVMs and 
VNEs on a selected unit. These include:

• Adding, editing and removing an AVM.

• Switching manually to the standby unit.

• Viewing AVM properties.

Table 2-3 ANA Servers Branch Tools

Adds a new unit to the Cisco ANA server.
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• Moving AVMs.

• Starting and stopping AVMs and VNEs.

• Adding VNEs.

An example of the Cisco ANA Manage window when a ANA Servers Entity sub-branch is selected is 
displayed below.

Figure 2-3 ANA Servers Entity Sub-Branch

Each row in the table in the workspace enables the user to view the status of an AVM. The AVMs can be 
sorted in ascending or descending order by clicking on the column heading in the table.

Note Any changes that are made to the ANA Servers Entity sub-branch are saved automatically and registered 
immediately in Cisco ANA.

The following columns are displayed in the workspace table for the AVMs that are listed or running 
under the server entity:

• ID—The name of the AVM as defined in Cisco ANA and unique to the AVM, for example, AVM 18.

• Status—The status of the AVM, as follows:

– Starting Up—When an AVM is started.

– Up—The AVM is up.

– Shutting Down—When an AVM is stopped.

– Down—The AVM is down.

– Unreachable—The AVM cannot be reached.

• Up Since—The date and time that the unit was last started.

• Max Memory—The maximum allocated memory size as defined when the AVM was created in 
Cisco ANA Manage. The default value is 256 MB.

• Key—The key of the AVM, which is unique to the system. By default the key is displayed as “AVM 
+ ID + timestamp”.
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For more information about specific menu and toolbar options, see:

• ANA Server Entities Branch Menus

• ANA Server Entities Branch Toolbar

ANA Server Entities Branch Menus

This section provides a description of each option available in the menus when the ANA Server 
sub-branch is selected. The following menus are available:

• File Menu

• Tools Menu

• Help Menu

• Tree Pane Shortcut Menu

• Workspace Shortcut Menu

File Menu

The File menu is displayed.

New AVM

Adds an AVM to the selected unit. See Creating AVMs, page 6-1.

Properties

Displays the ANA Unit Properties dialog box. This dialog box lists the properties of the selected unit 
and indicates its status. See Editing Cisco ANA Unit Properties, page 5-4.

Exit

Exits Cisco ANA Manage. See Logging Out, page 2-39.

Tree Pane Shortcut Menu

When the user right-clicks on the ANA Server Entities sub-branch in the tree pane the following shortcut 
menu is displayed.

New AVM

Adds an AVM to the selected unit.

Properties

Displays the properties of the selected unit.

Switch

This option is available when high availability is enabled and is only available for units. Manually switch 
to the standby unit. For more information, refer to the Cisco Active Network Abstraction High 
Availability User Guide.

Delete

Deletes the selected unit.
2-12
Cisco Active Network Abstraction Administrator Guide, Version 3.6

OL-12512-02



 

Chapter 2      Getting Started With Cisco ANA Manage
    Cisco ANA Manage Window, Menus and Toolbars
Workspace Shortcut Menu

New VNE

Creates a VNE for the selected AVM. See Creating AVMs, page 6-1.

Note A new VNE cannot be added to the reserved AVMs 0-100.

Actions

Starts or stops an AVM. See Starting and Stopping AVMs, page 6-5.

Delete

Deletes an AVM from the server.

Note Reserved AVMs 0-100 cannot be deleted.

Move AVM

Move an entire AVM between units. See Moving AVMs, page 6-6.

Note Reserved AVMs 0-100 cannot be moved.

Properties

Displays the properties of the selected AVM.

ANA Server Entities Branch Toolbar

When the ANA Server Entities sub-branch is selected in the tree pane the following tools are displayed 
on the toolbar:

For more information on the ANA Servers Entity sub-branch, see Chapter 6, “Managing AVMs and 
VNEs”.

Table 2-4 ANA Server Entities Tools

Creates a new AVM in the selected unit or gateway. 

Displays the server properties and status.

Deletes the selected unit. 

Search for a AVM/VNE amongst the Cisco ANA servers.

Note The Search Tool searches only on the selected unit and its 
sub-branches. It does not search all units.
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AVM Branch
The AVM sub-branch enables the user to manage information relating to the VNEs in a selected AVM. 
This includes:

• Adding, editing and removing a VNE.

• Viewing VNE or AVM properties.

• Deleting an AVM.

• Moving AVMs and VNEs.

• Starting and stopping VNEs or AVMs.

• Moving VNEs to maintenance mode.

An example of the Cisco ANA Manage window when the AVM sub-branch is selected is displayed 
below.

Figure 2-4 AVM Sub-Branch

When the user chooses the AVM sub-branch the workspace displays the properties of the AVM and a 
table with the list of VNEs. 

Note No VNEs are displayed when a special AVM (for example, AVM 66) that belongs to the gateway is 
selected.

The following columns are displayed in the workspace table:

• Key—The unique key of the VNE.

• IP Address—The IP address of the device as defined in Cisco ANA Manage.
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• Status—The status of the VNE, as follows:

– Starting Up—When a VNE is started.

– Up—The VNE is up.

– Shutting Down—When a VNE is stopped.

– Down—The VNE is down.

– Unreachable—Cisco ANA failed to access the VNE.

• Maintenance—Indicates whether the VNE is or is not in maintenance mode, namely, true or false.

• Up Since—The date and time that the VNE was last started.

• SNMP—Indicates whether this option is enabled or disabled on the VNE, namely, true or false.

• Telnet—Indicates whether this option is enabled or disabled on the VNE, namely, true or false.

• Element Class—Detects the VNE category, namely, Auto Detect, Generic SNMP, Cloud or ICMP. 

• Element Type—The device type (manufacturer name), for example, Cisco 7204.

• Polling Group—The name of the customized polling group or it is blank if it is an instance.

For more information about VNEs, see Chapter 6, “Managing AVMs and VNEs”.

For more information about AVM menu and toolbar options see:

• AVM Branch Menus

• AVM Branch Toolbar

AVM Branch Menus

This section provides a description of each option available in the menus when the AVM sub-branch is 
selected. The following menus are available:

• File Menu

• Tools Menu

• Help Menu

• Tree Pane Shortcut Menu

• Workspace Shortcut Menu

File Menu

The File menu is displayed.

New VNE

Adds a VNE to the selected AVM.

Note A new VNE cannot be added to the reserved AVMs 0-100.

Properties

Displays the properties of the selected AVM and its status.

Exit

Exits Cisco ANA Manage. See Logging Out, page 2-39.
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Tree Pane Shortcut Menu

When the user right-clicks on the AVM sub-branch in the tree pane the following menu is displayed.

New VNE

Creates a VNE for the selected AVM. See Creating AVMs, page 6-1.

Note A new VNE cannot be added to the reserved AVMs 0-100.

Actions

Starts or stops an AVM. See Starting and Stopping AVMs, page 6-5.

Delete

Deletes an AVM from the server.

Note Reserved AVMs 0-100 cannot be deleted.

Move AVM

Move an entire AVM between units. See Moving AVMs, page 6-6.

Note Reserved AVMs 0-100 cannot be moved.

Properties

Displays the properties of the selected AVM.

Workspace Shortcut Menu

When the user right-clicks on a selected VNE in the table the following shortcut menu (and sub-menu, 
when required) options are displayed.

Actions

Enables the user to start and stop a VNE. In addition, the VNE can be moved to maintenance mode. 
Actions can be performed on multiple VNEs.

Delete

Deletes the selected VNE from an AVM.

Move VNEs

Move a VNE between AVMs. Actions can be performed on a single VNE or multiple VNEs.

Properties

Displays the properties of the selected VNE.
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AVM Branch Toolbar

When the AVM sub-branch is selected in the tree pane the following tools are displayed on the toolbar:

When a VNE is selected in the table in the workspace the following tools are displayed on the toolbar:

For more information on the AVM sub-branch, see Chapter 6, “Managing AVMs and VNEs”.

Table 2-5 AVM Tools

Creates a new VNE in the selected AVM. 

Displays the properties of the selected AVM. 

Deletes the selected AVM.

Starts the selected AVM. 

Stops the selected AVM. 

Search for a Cisco ANA AVM/VNE amongst all the servers.

Table 2-6 VNE Tools

Creates a new VNE in the selected AVM.

Displays the properties of the selected VNE.

Deletes the selected VNE from an AVM.

Starts the selected VNE.

Moves the selected VNE to maintenance mode.

Stops the selected VNE.

Search for an AVM/VNE amongst all the servers.
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Global Settings Branch 
The Global Settings branch maintains system-wide settings, for example, polling and protection groups. 
Any changes that are made to the settings affect the configuration throughout the entire system.

The Global Settings branch includes the following sub-branches:

• Client Licenses Branch

• DB Segments Branch

• Message of the Day Branch

• Polling Groups Branch Menus and Toolbar

• Protection Groups Branch Menus and Toolbar

Client Licenses Branch

The Client Licenses sub-branch enables control and monitoring of the number of client connections over 
a limited or unlimited period of time as defined in terms of the client license. The Cisco ANA Manage 
window with the Client Licenses sub-branch selected is displayed below.

Figure 2-5 Client Licenses Sub-Branch

The following columns are displayed in the workspace table when the Client Licenses sub-branch is 
selected:

• Expiration Date—Date of the expiration of the license. The license can be for a limited or unlimited 
period of time.
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• License Type—The license type:

– Fixed—The number of installed users are identified by usernames or IP addresses or both. For 
example, 5 users with the usernames a, b, c, d and e.

or

– Floating—The number of installed users operating concurrently (unspecified). For example, 
5 users.

• License Users—The usernames and IP addresses of the users.

• Priority—Unavailable in this version.

• User Count—The number of users allowed to operate the client applications, as defined in terms of 
the license. The exact number of users is displayed if the number is limited or 0 indicates an 
unlimited number of users.

• Creation Date—The date when the license was implemented.

• Client Type—The applications to which the user is authorized to connect, namely, BQL and client 
applications.

For more information about:

• Menus options, see Client Licenses Branch Menus and Toolbar, page 2-19.

• Toolbar options, see Client Licenses BranchToolbar, page 2-20.

Client Licenses Branch Menus and Toolbar

This section provides a description of each option available in the menus when the Client Licenses 
sub-branch is selected. The following menus are available:

• File Menu

• Tools Menu

• Help Menu

• Tree Pane Shortcut Menu

• Workspace Shortcut Menu

File Menu 

The File menu is displayed.

New License

Install a new license.

Properties

Displays the properties of the selected license.

Exit

Exits Cisco ANA Manage. See Logging Out, page 2-39.
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Tree Pane Shortcut Menu

Right-click the Client Licenses sub-branch to display the shortcut menu:

New License

Install a new license.

Workspace Shortcut Menu

Right-click in the table in the workspace to display the following shortcut menu:

Delete

Deletes the selected license.

Properties

Displays the properties of the selected license.

Client Licenses BranchToolbar

When the Client Licenses sub-branch is selected in the tree pane the toolbar contains the following tools:

For more information about client licenses, see Managing Client Licenses, page 7-1.

Table 2-7 Client Licenses Tools

Install a new license.

Displays the properties of the selected license.

Deletes the selected license.
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DB Segments Branch 

The DB segments branch in Cisco ANA Manage displays a table describing the storage allocated for all 
database segments. An example of the Cisco ANA Manage window when the DB segments branch is 
selected is displayed below.

Figure 2-6 DB Segments Branch

The following columns are displayed in the workspace table when the DB segments branch is selected:

• Name—Name of the segment.

• Type—Type of segment, for example, INDEX PARTITION, TABLE PARTITION, TABLE, 
CLUSTER, INDEX, ROLLBACK, DEFERRED ROLLBACK, TEMPORARY, CACHE, 
LOBSEGMENT and LOBINDEX

• Tablespace Name—Name of the table space containing the segment.

• Partition Count—Number of partitions.

• Extent Count—Number of extents allocated to the segment where the data is stored.

• Next Extent Size—Size in bytes of the next extent to be allocated to the segment.

• Bytes—Size of the segment in bytes.
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Message of the Day Branch

The Message of the Day sub-branch enables the user to define a message (service disclaimer) that will 
be displayed when a user logs into client applications. An example of the Cisco ANA Manage window 
when the Message of the Day sub-branch is selected is displayed below.

Figure 2-7 Message Of The Day Sub-Branch

The following areas are displayed in the workspace:

• Title—The title of the message which is displayed as the title of the dialog box. By default the title 
“Terms of Use” is displayed.

• Message—A free text message for the user. The message supports HTML format.

Note The Abort and Continue buttons are displayed in the message dialog box by default, so the 
message must relate to these actions. The user must accept (Continue) the service disclaimer 
otherwise the user will be unable to login.

The following button is displayed in the workspace:

• Save—Saves the message so that it is displayed when the user logs into a client application.

For more information about the Message of the Day branch, see
Customizing a Message of the Day, page 7-4.
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Polling Groups Branch Menus and Toolbar

The Polling Groups sub-branch enables the user to manage polling groups, by categorizing a group of 
devices to be polled according to pre-set intervals. The Polling Groups sub-branch is displayed below.

Figure 2-8 Polling Groups Sub-Branch

The following columns are displayed in the workspace table when the Polling Groups sub-branch is 
selected:

• Polling Group—The polling group name defined by the user

• Description—A description of the polling group.

Note Any changes that are made to the Polling Groups sub-branch are saved automatically and registered 
immediately in Cisco ANA.

For more information about:

• Polling Group Menus

• Polling Groups Branch Toolbar

Polling Group Menus

This section provides a description of each option available in the menus when the Polling Groups 
sub-branch is selected. The following menus are available:

• File Menu

• Tools Menu
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• Help Menu

• Tree Pane Shortcut Menu

• Workspace Shortcut Menu

File Menu

The File menu is displayed.

New Polling Group

Creates a new polling group.

Properties

Displays the properties of the selected polling group.

Exit

Exits Cisco ANA Manage. See Logging Out, page 2-39.

Tree Pane Shortcut Menu

Right-clicking on the Polling Groups sub-branch displays the shortcut menu.

New Polling Group

Creates a new polling group.

Workspace Shortcut Menu

When the user right-clicks in the table in the workspace the following shortcut menu, is displayed.

Properties

Displays the properties of the selected polling group.

Delete

Deletes the selected polling group.

Note The default polling group must not be deleted.

Polling Groups Branch Toolbar

When the Polling Groups sub-branch is selected in the tree pane the toolbar contains the following tools:

Table 2-8 Polling Groups Tools

Creates a new polling group.

Displays the properties of the selected polling group.

Deletes the selected polling group.

Note The default polling group must not be delete.
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When a polling group is selected in the table in the workspace, clicking Properties on the toolbar 
displays the properties of the polling group in a Properties dialog box. 

For more information about polling groups, see Managing Polling Groups, page 7-5.

Protection Groups Branch Menus and Toolbar

By default all the units in the Cisco ANA fabric belong to one big cluster. The Protection Groups 
sub-branch enables the administrator to change the default setup of the units by customizing protection 
groups (clusters) and then assigning units to these protection groups. 

For more information, refer to the Cisco Active Network Abstraction High Availability User Guide.

The Cisco ANA Manage window with the Protection Groups sub-branch selected is displayed below.

Figure 2-9 Protection Groups Sub-Branch

The following columns are displayed in the workspace table when the Protection Groups sub-branch is 
selected:

• Name—The protection group name defined by the administrator.

• Description—A description of the protection group.

For more information about:

• Protection Group Menus

• Protection Groups Branch Toolbar
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Protection Group Menus

This section provides a description of each option available in the menus when the Protection Groups 
sub-branch is selected. The following menus are available:

• File Menu

• Tools Menu

• Help Menu

• Tree Pane Shortcut Menu

• Workspace Shortcut Menu

File Menu 

The File menu is displayed.

New Protection Group

Creates a new protection group.

Properties

Displays the properties of the selected protection group.

Exit

Exits Cisco ANA Manage. See Logging Out, page 2-39.

Tree Pane Shortcut Menu 

Right clicking on the Protection Groups sub-branch displays the shortcut menu.

New Protection Group

Creates a new protection group.

Workspace Shortcut Menu 

When the user right-clicks in the table in the workspace the following shortcut menu is displayed.

Delete

Deletes the selected protection group.

Note The default protection group must not be deleted.

Properties

Displays the properties of the selected protection group in a Properties dialog box.
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Protection Groups Branch Toolbar 

When the Protection Groups sub-branch is selected in the tree pane the toolbar contains the following 
tools:

For more information about protection groups, refer to the Cisco Active Network Abstraction High 
Availability User Guide.

Scopes Branch
The Scopes branch enables the administrator to group a collection of managed network elements 
together in order to enable the user to view and manage the network elements based on the role granted 
to the user for the scope. For more information on the Scopes branch, see Chapter 10, “Managing 
Security”.

The Scopes branch is displayed below.

Figure 2-10 Scopes Branch

Table 2-9 Protection Group Tools

Creates a new protection group.

Displays the properties of the selected protection group.

Deletes the selected protection group.

Note The default protection group must not be deleted.
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Each row in the table in the workspace displays the name of a scope as defined in Cisco ANA Manage.

For more information about:

• Menu options, refer to following section.

• Scopes Branch Toolbar

Note The menus and toolbar displayed in the Cisco ANA Manage window are context sensitive; the options 
vary depending on your selection in the tree pane and workspace.

Scopes Branch Menus

This section provides a description of each option available in the menus when the Scopes branch is 
selected. The following menus are available:

• File Menu

• Tools Menu

• Help Menu

• Tree Pane Shortcut Menu

• Workspace Shortcut Menu

File Menu

The File menu for the Scopes branch is displayed.

New Scope

Creates a new scope.

Properties

Displays the properties of the selected scope.

Exit

Exits Cisco ANA Manage. See Logging Out, page 2-39.

Tree Pane Shortcut Menu 

When the user right-clicks on the Scopes branch in the tree pane the shortcut menu is displayed.

New Scope

Creates a new scope.

Workspace Shortcut Menu

When the user right-clicks in the table in the workspace the following shortcut menu is displayed.

Delete

Deletes the selected scope.
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Properties

Displays the properties of the selected scope.

Note The user cannot delete or edit the All Managed Elements scope in the table in the workspace. See 
Scopes, page 10-1.

Scopes Branch Toolbar 

When the Scopes branch is selected in the tree pane the toolbar contains the following tools:

When a scope is selected in the table in the workspace, clicking Properties on the toolbar displays the 
properties of the selected scope in a Properties dialog box.

Table 2-10 Scopes Branch Tools

Creates a new scope. See Creating Scopes, page 10-5.

Displays the properties of the selected scope.

Deletes the selected scope.
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Topology Branch
The Topology branch enables the user to define static links between the network elements in order to 
supplement or override existing auto-discovered topology. The Cisco ANA Manage window with the 
Topology branch selected is displayed below.

Figure 2-11 Topology Branch

The Topology branch displays all the static links defined in the system including the A side and Z side 
of the link.

For more information about:

• Menu options, see Topology Branch Menus, page 2-30.

• Toolbar options, see Topology Branch Toolbar, page 2-31.

Topology Branch Menus

This section provides a description of each option available in the menus when the Topology branch is 
selected. The following menus are available:

• File Menu

• Tools Menu

• Help Menu

• Tree Pane Shortcut Menu

• Workspace Shortcut Menu
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File Menu 

The File menu is displayed.

New Static Link

Creates a new static link.

Properties

This option is unavailable.

Exit

Exits Cisco ANA Manage. See Logging Out, page 2-39.

Tree Pane Shortcut Menu

When the user right-clicks on the Topology branch in the tree pane the shortcut menu is displayed.

New Static Link

Creates a new static link.

Workspace Shortcut Menu 

When the user right-clicks in the table in the workspace the shortcut menu is displayed.

Delete

Deletes the selected static link.

Topology Branch Toolbar 

The Topology branch contains the following tools:

For more information about the Topology branch, see Chapter 8, “Managing Links”.

Table 2-11 Topology branch Tools

Opens the New Link dialog box enabling the user to create a link between 
two devices. See Creating a Static Link, page 8-1.

Deletes the selected static link.
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Users Branch 
The Users branch enables the administrator to define and manage user accounts. For more information 
about the Users branch, see Chapter 10, “Managing Security”.

The Cisco ANA Manage window with the Users branch selected is displayed below.

Figure 2-12 Users Branch

Each row in the table in the workspace displays the username and a description of the user.

The following columns are displayed in the workspace table:

• User Name—The username (unique) defined for the current client station.

• Description—A description of the user.

• Default Permission—The default permission of the user, namely, viewer to administrator. For 
example, a user with the default permission viewer can view maps and the Device List.

Note The default permission only applies at an application level, namely, all the activities that are 
related to GUI functionality, not the activities related to devices. See Chapter 10, “Managing 
Security”.

• Last Login—The date and time that the user last logged in.

For more information about:

• Users Branch Menus

• Users Branch Toolbar
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Note The menus and toolbar displayed in the Cisco ANA Manage window are context sensitive; the options 
vary depending on your selection in the tree pane and workspace.

Users Branch Menus

This section provides a description of each option available in the menus when the Users branch is 
selected. The following menus are available:

• File Menu

• Tools Menu

• Help Menu

• Tree Pane Menu

• Workspace Shortcut Menu

File Menu

The File menu is displayed.

New User

Creates a new user for the current client station.

Properties

Displays the properties of the selected user.

Exit

Exits Cisco ANA Manage. See Logging Out, page 2-39.

Tree Pane Menu 

When the user right-clicks on the Users branch in the tree pane the shortcut menu is displayed.

New User

Creates a new user for the current client station.

Workspace Shortcut Menu

When the user right-clicks in the table in the workspace the shortcut menu is displayed.

Change Password

Displays the Set Password dialog box that enables the administrator to edit a user’s password.

Delete

Deletes the selected username from the system.

Note The username root cannot be deleted.
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Properties

Displays the properties of the selected user.

Users Branch Toolbar

The Users branch contains the following tools:

Workflow Engine Branch

Note The Workflow Engine branch is only visible if the Workflow option was purchased and installed.

The Workflow Engine branch enables the user to manage workflow templates and running workflows in 
runtime. The Workflow Engine branch includes the following sub-branches:

• Templates—Displays a list of the deployed workflow templates and enables the user to view the 
properties of the workflow template. For more information, refer to the section below.

• Workflows—Displays a list of the running or completed workflows and enables the user to view 
and alter their current status. See Workflows, page 2-36.

Templates

The Templates sub-branch enables the user to:

• View a list of the deployed workflow templates.

• View the properties (attributes) of a workflow template.

• Delete a workflow template.

Table 2-12 Users branch Tools

Opens the New User dialog box enabling the user to define a new user for 
the current client station.

Displays the properties of the selected user. 

Deletes the selected username from the system.
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The Cisco ANA Manage window with the Templates sub-branch selected is displayed below.

Figure 2-13 Templates Sub-Branch

The table displays the names of the workflow templates (in the workspace), as defined using the Cisco 
Workflow Editor.

For more information about:

• Menu options, refer to the following section.

• Templates Branch Toolbar

Templates Branch Menus

This section provides a description of each option available in the menus when the Templates sub-branch 
is selected. The following menus are available:

• Tools Menu

• Help Menu

• Tree Pane Shortcut Menu

• Workspace Shortcut Menu

Tree Pane Shortcut Menu 

Right clicking on the Templates sub-branch displays the shortcut menu.

Properties

Displays a list of the workflow templates available on the gateway.
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Workspace Shortcut Menu 

When the user right-clicks in the table in the workspace the shortcut menu is displayed.

Properties

Displays the properties (attributes) of the selected workflow template.

Delete

Deletes the selected workflow template.

Templates Branch Toolbar 

When the Templates sub-branch is selected in the tree pane and a template is selected in the workspace, 
the toolbar contains the following tool:

For more information about workflows, refer to the Cisco Active Network Abstraction Workflow User 
Guide.

Workflows

The Workflows sub-branch enables the user to:

• View the list of running or completed workflows and the status of each.

• View the output of a workflow.

• Abort a workflow that is being processed or that has been completed, and initiate rollback.

• Delete a workflow.

• View the properties of a workflow.

Table 2-13 Templates Sub-Branch Tools

Deletes the selected workflow template.
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The Cisco ANA Manage window with the Workflows sub-branch selected is displayed.

Figure 2-14 Workflows Sub-Branch

The following columns are displayed in the workspace table when the Workflows sub-branch is selected:

• ID—A unique sequential number given to the workflow.

• Name—The name of the workflow, as defined using the Cisco Workflow Editor.

• State—The current status of the workflow, namely, Ready, Running, Done, or Aborted.

• Blocking Locks—The locks that this workflow is waiting to release.

• Locks—The locks that this workflow currently owns (is holding).

For more information about:

• Menu options, refer to the following section.

• Workflows Branch Toolbar

Workflows Menus

This section provides a description of each option available in the menus when the Workflows 
sub-branch is selected. The following menus are available:

• Tools Menu

• Help Menu

• Tree Pane Menu

• Workspace Shortcut Menu
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Tree Pane Menu 

Right clicking on the Workflows sub-branch displays the shortcut menu.

Properties

Displays a list of the scripts and their current status.

Workspace Shortcut Menu 

When the user right-clicks in the table in the workspace the shortcut menu is displayed.

Show Output

View the output of the workflow.

Abort/Rollback

Aborts the workflow and performs rollback if the workflow is running, or if the workflow has already 
been completed it performs rollback. 

Delete

Deletes the workflow from the database.

Note A workflow can only be deleted from the database when it is Done or Aborted. It cannot be deleted 
while the process is still running.

Properties

Displays the properties (attributes) of the selected workflow, including its status.

Workflows Branch Toolbar

When the Workflows sub-branch is selected in the tree pane and a workflow is selected in the workspace, 
the toolbar contains the following tool:

For more information about workflows, refer to the Cisco Active Network Abstraction Workflow User 
Guide.

Table 2-14 Workflows Sub-Branch Tools

Deletes the workflow from the database.
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Logging Out
When the user has finished working with Cisco ANA Manage the user can log out of the application. 
Any changes that were made are automatically saved when logging out.

To log out of Cisco ANA Manage:

Step 1 From the File menu, choose Exit,

or

Click in the top right-hand corner to close the Cisco ANA Manage window.

A confirmation message is displayed.

Step 2 Click Yes. The Cisco ANA Manage window is closed.
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