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Using Cisco ANA PathTracer to Diagnose 
Problems

Cisco ANA enables you to view a network path between two network objects using Cisco ANA 
PathTracer:

• In a circuit-switched network, such as Frame Relay or ATM, or

• In packet-switched networks, such as Ethernet and IP. 

These topics describe the Cisco ANA PathTracer working environment and the functionality available 
when using Cisco ANA PathTracer:

• Cisco ANA PathTracer Overview, page 9-2, describes the Cisco ANA PathTracer single and 
multipath route tracing functionality and the information that can be viewed in the two main 
Cisco ANA PathTracer windows.

• Opening Cisco ANA PathTracer, page 9-2, describes how to open Cisco ANA PathTracer.

• Cisco ANA PathTracer Multipath Window, page 9-4, describes the Cisco ANA PathTracer 
multipath window working environment and the information that can be viewed.

• Cisco ANA PathTracer Single-Path Window, page 9-6, describes the Cisco ANA PathTracer 
single-path window working environment and the information that can be viewed.

• Viewing Path Information, page 9-10, describes how to view information about the path between 
two network objects, including ingress and egress port information.

• Saving and Opening Cisco ANA PathTracer Map Files, page 9-11, describes how to export the maps 
(paths) displayed in the Cisco ANA PathTracer multipath window to an .xml file.

• Saving Cisco ANA PathTracer Counter Values, page 9-12, describes how to export the counter 
values of the path displayed in the Cisco ANA PathTracer single-path window to a .csv file.

• Rerunning a Path and Making a Comparison, page 9-12, describes how to rerun a path using a 
previously saved map file with the same source and destination and then compare the paths.

• Viewing QinQ Path Information, page 9-13, describes how to use Cisco ANA PathTracer to display 
path information for QinQ-tagged VLANs.

• Viewing L2TP Path Information, page 9-14, describes how to use Cisco ANA PathTracer to display 
path information for L2 tunnels.
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Cisco ANA PathTracer Overview
Cisco ANA PathTracer enables end-to-end route tracing to be performed with informative performance 
information displayed simultaneously for the multiple networking layers. Upon receiving a path's start 
and endpoint, Cisco ANA PathTracer visually traces the route through the network. For example, in an 
ATM network environment, Cisco ANA PathTracer identifies all information regarding the connection 
of a subscriber to a provider, including all ATM PVCs, ATM switching tables, ATM class of service 
(CoS) definitions, IP-related information, and so on.

Cisco ANA understands and is able to derive the various paths on the network due to the up-to-date 
knowledge of the network. Cisco ANA PathTracer finds and retrieves the path of a specified service, 
after the user has selected a source and destination. The retrieved information contains network elements 
in the path, including all properties at Layer 1, Layer 2, and Layer 3, plus alarm information, counters, 
and more.

Cisco ANA PathTracer enables you to view multiple paths between the source and the destination in the 
Cisco ANA PathTracer multipath window, or to view a selected single-path in the Cisco ANA PathTracer 
single-path window.

Opening Cisco ANA PathTracer
Cisco ANA PathTracer can be opened from an ATM VC, DLCI, or from an IP interface entry point. The 
virtual route is found according to the Cross Connect table of each ATM switch or Frame Relay device. 
The IP routing and path finding process is enabled according to the VRF tables of each router.

To view a specific path, you must specify an initial point, such as a VPI/VCI, DLCI, Ethernet port or IP 
interface and (optionally) a destination IP address. If you specified VC information or DLCI 
information, which ends in a router, Cisco ANA PathTracer finds the next hop according to the 
destination IP address. If you did not specify the destination IP address, the system uses the default 
gateway in the router. In addition, the related business tags that have been referred to the physical or 
logical entities are also displayed.

Note The path can also be opened if there is a business tag attached to an endpoint that can be used as the 
starting point for opening the Cisco ANA PathTracer.

The Cisco ANA PathTracer tool provides the user with two windows in which to view the path:

• Cisco ANA PathTracer Multipath Window—Displays all the paths available between the selected 
source and destination.

• Cisco ANA PathTracer Single-Path Window—Displays a single path available between the selected 
source and destination, as well as the subscribers and properties.

You can also enter the required destination IP address after opening the Cisco ANA PathTracer from the 
right-click shortcut menu at one of the following locations:

Element Location

Affected Parties Inventory window

Ticket Properties window (Affected Parties tab)

VC Cross Connect Table Inventory window (Cross Connect dialog box)

Site Service View map
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To open Cisco ANA PathTracer:

Step 1 Open the network element’s Inventory window using one of the following methods:

• Double-click a device or element in the tree pane or map pane.

• Right-click a device or element in the tree pane or map pane and choose Inventory.

The Inventory window is displayed.

Step 2 Open PathTracer from either the physical inventory or logical inventory branch:

• From the physical inventory, drill down, right-click the required port and choose 
PathTracer > From Here to IP Destination, and enter the required IP address.

• From the logical inventory branch, open the Routing Entity properties pane, right-click the required 
element in the IP Interfaces tab, and choose PathTracer > Start Here and PathTracer > End Here 
from the shortcut menu.

Note The End Here option indicates that when a certain point is selected as the End Here point, the 
system extracts the relevant IP address from this point and uses it as the destination.

Step 3 Click OK. The PathTracer multipath window is displayed showing the paths that were found. For more 
information about this window, see Cisco ANA PathTracer Multipath Window, page 9-4

Step 4 If there is more than one path in the multipath window, select a path in the Paths pane.

Note If multiple paths are selected in the Paths pane, they will be opened. If nothing is selected in the 
Paths pane, then all the available paths will be opened automatically, and each one will be 
displayed in a separate PathTracer single-path window.

Step 5 On the multipath window toolbar, click the PathTracer icon. The PathTracer single-path window is 
displayed showing the end-to-end path. 

For more information about this window, see Cisco ANA PathTracer Single-Path Window, page 9-6.

For more information about opening the Cisco ANA PathTracer from other Cisco ANA NetworkVision 
windows, and about selecting multipath options, see the Cisco Active Network Abstraction 3.6.6 MPLS 
User Guide.

IP Interface Inventory window

Affected entry

Layer 2 MPLS Tunnel Inventory window

VC Table Inventory window (VC Table dialog box)

Business tag The path can be found using a business tag, which is attached to the 
VPI/VCI, or using an IP interface by entering its key; it can then be 
opened from the Find Business Tag dialog box.

Ethernet port Inventory window

MPLS-TE Tunnel Inventory window

Element Location
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Cisco ANA PathTracer Multipath Window 
The Cisco ANA PathTracer multipath window displays all the discovered paths for the selected context, 
including devices and physical links. 

The Cisco ANA PathTracer multipath window enables you to perform the following functions:

• View a previous path or view the next path.

• Open the Cisco ANA PathTracer single-path window in order to view a single selected path.

• Save the multipath map to a file.

• Run the Cisco ANA PathTracer again.

An example of the Cisco ANA PathTracer multipath window is displayed in Figure 9-1.

Figure 9-1 Cisco ANA PathTracer Multipath Window

The Cisco ANA PathTracer multipath window is divided into the following areas:

• Cisco ANA PathTracer Multipath Window Toolbar, page 9-5

• Cisco ANA PathTracer Multipath Window Menus, page 9-5

• Tabs, page 9-6

• Paths Pane, page 9-6

• Map Pane, page 9-6

1 Menu bar 4 Paths pane

2 Toolbar 5 Status bar

3 Map pathtraced at...tabs 6 Map pane
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Cisco ANA PathTracer Multipath Window Toolbar
The Cisco ANA PathTracer multipath window contains the following tools:

For information about the selection tools displayed on the toolbar, see Cisco ANA NetworkVision 
Toolbar, page 2-17.

Cisco ANA PathTracer Multipath Window Menus
The File menu in the Cisco ANA PathTracer multipath window provides the following options:

• Run Again—Runs the Cisco ANA PathTracer again, using the same source and destination 
parameters.

• Save—Saves the map displayed in the multipath window.

• Close—Closes the multipath window.

In addition, you can right-click views and network elements in the multipath window and choose items 
from a shortcut menu. The shortcut menu is context sensitive depending on the view and the network 
element selected. For more information about the Device shortcut menu and for a detailed description of 
all the menu options available here, see Device Shortcut Menu, page 2-23.

Button Function

Selects the previous path viewed in the topological map pane.

Selects the next path viewed in the topological map pane.

Clears the path selection made in the topological map pane.

Opens the Cisco ANA PathTracer single-path window based on the path selected in the 
Cisco ANA PathTracer multipath window. A map is displayed for the selected path, 
including NE details, links and property information. For more information, see 
Cisco ANA PathTracer Single-Path Window, page 9-6.

Saves the multipath map displayed in the topological map pane. For more information, see 
Saving and Opening Cisco ANA PathTracer Map Files, page 9-11.

Defines the way in which the map is displayed in the topological map pane (circular, 
symmetric, tree, or hierarchical).

Opens a window displaying an overview of the network displayed in the topological map 
pane.

Runs Cisco ANA PathTracer again, creating a new map that is displayed in a topological 
map pane tab. A new tab with an up-to-date (refreshed) path map is created for each run 
(the source and destination must be the same), with each tab representing a run, and its 
header indicating the snapshot time.
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Tabs
The path is initially displayed in the map pane in a tab that displays the starting point date and time at 
which Cisco ANA commenced the path tracing process (snapshot time). 

If you want to load a saved path from a file or run the displayed path again, a new tab with an up-to-date 
(refreshed) path map is created for each run or file (the source and destination must be the same). This 
is displayed in a separate tab, with each tab representing a run or file, and its header indicating the 
snapshot time.

Paths Pane
The Paths pane displays all the paths available for the selected source and destination (for each source 
and destination pair, new path is created). The paths are displayed using numbers. Selecting a path in the 
Paths pane enables you to view each individual path in the map pane of the Cisco ANA PathTracer 
single-path window, and the selected path is highlighted in the map pane.

Map Pane
The map pane enables you to view a route map of the intermediate network elements. The map displays 
devices, links and paths (topological paths).

Icons are used in the map pane to display the network objects and these icons provide a visual 
representation of the network object’s status. For more information about the icons used, see 
Appendix A, “Icon Reference”.

All links and nodes are labeled with the relevant paths numbers. The starting point is labeled with a 
special Starting Point label. All other edge points are displayed as clouds.

Cisco ANA PathTracer Single-Path Window
The Cisco ANA PathTracer single-path window displays the devices and links of the discovered path, as 
well as path layer properties and subscriber information. 

Note This section refers to single-path view only.

The Cisco ANA PathTracer single-path window enables you to:

• View a map of the intermediate network elements.

• View the following information for each network element:

– The relevant parameters for each interface on all layers along the path.

– For each layer, an indication of a mismatch between the parameters of the interfaces on both 
sides of a link.

– Traffic statistics along the path.

• Monitor the status and traffic of all the links along the path.

• View In and Out port properties. 
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In addition, right-clicking on an item in Cisco ANA PathTracer enables you to perform certain functions. 
For example, you can view device information, including device properties, and attach business tags.

An example of the Cisco ANA PathTracer single-path window is displayed.

Figure 9-2 Cisco ANA PathTracer Single-Path Window

The Cisco ANA PathTracer single-path window is divided into the following areas:

• Cisco ANA PathTracer Single-Path Window Toolbar

• Cisco ANA PathTracer Single-Path Window Menus

• Topological Map

• Properties Table and Layer Tabs

1 Menu bar 5 Properties table

2 Toolbar 6 Layer tabs

3 Map pane 7 Status bar

4 Hide/Display Properties table
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Cisco ANA PathTracer Single-Path Window Toolbar
The Cisco ANA PathTracer single-path window contains the following tools:

Cisco ANA PathTracer Single-Path Window Menus
The following table n provides a description of each option available in the Cisco ANA PathTracer 
single-path window menus.

Table 9-1 Cisco ANA PathTracer Single-Path Window Tools

Button Function

Displays all the information in the tabs.

Hides all the information in the tabs.

Exports the currently displayed data to a CSV file.

Starts exporting the counter values of the path displayed in the Cisco ANA PathTracer 
single-path window to a CSV file.

Stops exporting the counter values of the path displayed in the Cisco ANA PathTracer 
single-path window to a CSV file.

Menu Name Option Description

File • Close—Closes the single-path window.

View • Show All—Displays all of the information contained in the Properties table.

• Hide All—Hides all of the information contained in the Properties table.

Tools • Export to File—Exports the currently displayed data to a file.

• Start Saving to File—Starts exporting the counter values of the path 
displayed in the Cisco ANA PathTracer single-path window to a CSV file.

• Stop Saving to File—Stops exporting the counter values of the path 
displayed in the Cisco ANA PathTracer single-path window to a CSV file.

Help • Help Contents—Opens the Cisco ANA NetworkVision online help.

• Help About—Displays application information, such as the version number.
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In addition, you can right-click views and network elements in the single-path window and choose items 
from a shortcut menu. The shortcut menu is context sensitive depending on the view and the network 
element selected. The following two Device shortcut menu options are available only from the 
single-path window:

• Show ‘In’ Port—In the Properties table, highlights the In Port information (of the device in the path) 
of the selected network element.

• Show ‘Out’ Port—In the Properties table, highlights the Out Port information (of the device in the 
path) of the selected network element.

Topological Map

The topological map displays the devices and links that are part of the path. Icons are used in Cisco ANA 
PathTracer to display the network objects and these icons provide a visual representation of the network 
object’s status. For more information about the icons used, see Appendix A, “Icon Reference.”

For more information about the colors used to indicate severities, see Map View, page 2-5.

The same coloring conventions that are used in the map pane of the Cisco ANA NetworkVision window 
are used to display links in the Cisco ANA PathTracer single-path window. Selecting a device or link on 
the map automatically highlights the related parameters in the table.

Note The color of a selected link is customizable. The default color is blue.

There are three ways in which the status of a network object is indicated on the topological map:

1. By severity

2. By management state

3. By new alarms 

For more information, see Network Element Status Indicators, page 2-13.

Properties Table and Layer Tabs

The Properties table and tabs display the supported parameters of the specified NE. The Cisco ANA 
PathTracer single-path window is divided into tabs as shown in the example in Cisco ANA PathTracer 
Single-Path Window, page 9-6.

The information parameters are displayed in a table, with the ingress and egress ports on the top and the 
parameters on the left.

Any inconsistencies between the two connected ports are colored to emphasize a discrepancy, for 
example, different admin statuses.
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The Cisco ANA PathTracer information parameters are arranged in groups as follows:

• Networking Layers—This group displays information regarding each network element, including 
ingress and egress port information. The information is either plain data that was extracted from the 
device or calculated data such as rates or statistics. This information is displayed in the Layer 1, 
Layer 2 and Layer 3 tabs.

• Business—This area displays the name and the key of the business tags that have been attached to 
the network entities displayed; for example, the port or the entire device (physical entity), VC, VP, 
DLCI, context (logical entity) or MPLS. This information is displayed in the Business Tag area.

The Cisco ANA PathTracer window is divided into the following tabs and all appear empty when the 
window opens:

• Layer 1—Displays the Layer 1 information in the selected path and enables you to view the link 
parameters. The name of each device is displayed, as well as the subslot, slot and port details. 

• Layer 2—Displays the Layer 2 information in the selected path. In addition, it enables you to view 
the link and connection parameters. For each of the devices, the name and MAC address are 
displayed, as well as the VPI/VCI in an ATM link or the DLCI in a Frame Relay link. By default, 
the Cisco ANA PathTracer single-path window is displayed with the Layer 2 tab active. 

• Layer 3—Displays the Layer 3 information selected path and enables you to view the link 
parameters. The name of each device is displayed.

• Business Parameter—Displays the name and the key of the business tags that have been attached to 
the network entities displayed; for example, the port or the entire device (physical entity), VC, VP, 
DLCI, IP interface or context (logical entity).

For specific information about VPN Cisco ANA PathTracer information, see the Cisco Active Network 
Abstraction 3.6.6 MPLS User Guide.

Viewing Path Information 
The Cisco ANA PathTracer tabs display information regarding each network element, including ingress 
and egress port information. The information is either plain data that was extracted from the device or 
calculated data such as rates or statistics. This information is displayed in the Layer 1, Layer 2 and 
Layer 3 tabs of the Cisco ANA PathTracer single-path window. 

To view path information, select the required tab, and click Show All. The path information is displayed 
in the active tab of the Cisco ANA PathTracer single-path window.

Note Selecting a device or link on the map automatically highlights the related parameters in the table.

Note Drag the scroll bar at the bottom of the Cisco ANA PathTracer window to view the various areas of the 
selected path and the parameters.
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Saving and Opening Cisco ANA PathTracer Map Files
Cisco ANA NetworkVision enables you to export the maps (paths) displayed in the Cisco ANA 
PathTracer multipath window to an .xml file. The data can then be viewed at a later stage in order to 
assess whether anything has changed.

To save Cisco ANA PathTracer Map Files:

Step 1 Open the Cisco ANA PathTracer multipath window (see Opening Cisco ANA PathTracer, page 9-2).

Step 2 Do one of the following to save the map:

• Click the Save MultiPath icon in the multipath window toolbar.

• Choose File > Save from the multipath window menu.

The Save dialog box is displayed.

Step 3 Browse to the directory where you want to save the file.

Step 4 In the File name field, enter a name for the map file.

Step 5 Click Save. The map file is saved in the selected directory.

Cisco ANA NetworkVision enables you to open saved xml format path-tracing maps.

Note • When you load a multipath file, Cisco ANA queries the file (not the network), and loads all the 
persisted information. 

• When you load a multipath file that does not contain the same Start Here and End Here destination 
information, the map is automatically opened in another instance of Cisco ANA PathTracer.

To open Cisco ANA PathTracer Map Files:

Step 1 In Cisco ANA NetworkVision, choose File > Load PathTracer from the main menu. The Open dialog 
box is displayed.

Step 2 Browse to the directory of the saved file and select the file.

Step 3 Click Open. The Cisco ANA PathTracer multipath window is displayed with the previously saved map 
file.
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Saving Cisco ANA PathTracer Counter Values
Cisco ANA NetworkVision enables you to export the counter values of the path displayed in the 
Cisco ANA PathTracer single-path window to a CSV file. The data can then be viewed at a later stage.

Note This section refers to single-path view only.

To save Cisco ANA PathTracer counter values:

Step 1 Open the Cisco ANA PathTracer single-path window (see Opening Cisco ANA PathTracer, page 9-2). 

Step 2 From the single-path window, do one of the following:

• Click the Start Saving to File icon in the single-path window toolbar.

• Choose Tools > Start Saving to File from the single-path window main menu.

The Export Table to File dialog box is displayed.

Step 3 Browse to the directory where you want to save the Cisco ANA PathTracer counter values. 

Step 4 In the File name field, enter a name for the Cisco ANA PathTracer counter values.

Step 5 Click Save. The Cisco ANA PathTracer counter values are saved in the selected directory.

You can then stop exporting the counter values of the path displayed in the Cisco ANA PathTracer 
single-path window to a CSV file.

To stop saving Cisco ANA PathTracer counter values, do one of the following:

• Click the Stop Saving to File icon in the single-path window toolbar.

• Choose Tools > Stop Saving to File from the single-path window main menu.

Cisco ANA NetworkVision stops exporting the counter values to the CSV file.

Rerunning a Path and Making a Comparison
Cisco ANA NetworkVision enables you to save and load a path (see Saving and Opening Cisco ANA 
PathTracer Map Files, page 9-11). This file can then be used at a later stage to rerun the path 
automatically using the same source and destination. You can then compare the paths if, for example, 
you suspect that the path has changed, and assess where the problem is occurring.

To rerun the path:

Step 1 Load the required map file. See Saving and Opening Cisco ANA PathTracer Map Files, page 9-11. The 
Cisco ANA PathTracer multipath window is displayed with the previously saved map file.

Step 2 From the multipath window, do one of the following:

• Click the run Again icon in the multipath window toolbar.

• Choose File > Run Again from the multipath window main menu.
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The path reruns automatically using the same source and destination as the loaded map file and a new 
tab is displayed in the Cisco ANA PathTracer multipath window with the updated map (path). The tab 
also displays the updated details of the date and time when the path was rerun.

Step 3 Compare the two paths by switching between the tabs in the Cisco ANA PathTracer multipath window 
and comparing the old map (path) with the new updated one.

Note • When you load a Cisco ANA PathTracer map file that does not contain the same source and 
destination information as the map that is currently displayed in the window, the map is 
automatically opened in another instance of the Cisco ANA PathTracer multipath window.

• If you load a Cisco ANA PathTracer map file that contains the same source and destination 
information as a window which has already been opened, the file will be loaded in a new tab within 
this window.

Viewing QinQ Path Information 
The QinQ (IEEE802.1) tagging technology (also known as Dot1q tunneling) allows the nesting of an 
additional VLAN tag in a packet, in addition to an existing one. Either VLAN tag is considered an 
802.1Q header.

Cisco ANA PathTracer uses the VLAN tags of the Ethernet header and the port configuration to trace 
the path from one interface to another over the network. Among other things, the tool lets you:

• View a Layer 2 path across a LAN domain with all the VLAN tag information.

• For each network element, view the relevant parameters for each interface on all layers along the 
path.

QinQ and Dot1q information is displayed in the Cisco ANA PathTracer windows when a path is traced 
over Ethernet ports with Dot1q and a QinQ configuration.

As explained in Opening Cisco ANA PathTracer, page 9-2, to view a specific path, you must specify an 
initial start point, such as an IP interface, and then an endpoint, such as a destination IP address. 

To trace a QinQ path, you start the path from any:

• Router or switch which is part of the Ethernet domain with Dot1q and QinQ configurations.

• IP destination which can be reached from that point of the network.

Table 9-2 describes the starting points available in the shortcut menu when you open Cisco ANA 
PathTracer:

Table 9-2 Cisco ANA PathTracer Starting Points

Element Location Start PathTracer Options

IP Interface Inventory window • to IP Destination

• Start Here
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If you select the Start Here option, the following endpoints can be selected as a path destination, which 
will then open the Cisco ANA PathTracer:

As soon as you select the endpoint, the Cisco ANA PathTracer Multipath window is displayed (see 
Cisco ANA PathTracer Multipath Window, page 9-4). From this window, you can open the Cisco ANA 
PathTracer Single-Path window, with the appropriate QinQ information displayed in the Layer 2 tab (see 
Cisco ANA PathTracer Single-Path Window, page 9-6). 

The Layer 2 tab can display the following information specific to QinQ and VLAN port configurations:

• VLAN Mode—The work mode for the interface (Unknown, Access, Trunk, Dot1QTunnel). Trunk 
mode refers to multiple tagging too.

• Native VLAN ID—The VLAN ID that is used to tag untagged traffic received on a trunked interface. 
The default native VLAN ID is ‘1’ if VLAN tagging is enabled. The native VLAN ID is ‘0’ or ‘no 
VLAN ID’ if VLAN tagging is disabled.

• CE VLAN ID—The customer edge device’s VLAN ID.

• SP VLAN ID—The service provider’s VLAN ID.

Viewing L2TP Path Information
Cisco ANA uses VC ID encapsulation information to trace the path from one tunnel interface to another 
over the network. The Cisco ANA PathTracer tool enables you to:

• View a path for the defined Layer 2 Tunneling Protocol (L2T) session across the network.

• For each network element, view the relevant parameters for each interface on all layers along the 
path.

Layer 2 and Layer 3 L2TP information is displayed in the Cisco ANA PathTracer windows when a path 
is traced over L2TP tunnels for Redback devices.

The Layer 3 tab can display the following information specific to L2TP tunnels:

• Name—The peer name is displayed.

The Layer 2 tab can display the following information specific to L2TP tunnels:

Table 9-3 Cisco ANA PathTracer Endpoints

Element Location Start PathTracer Options

IP Interface Inventory window End Here

Field Description

Encapsulation Type The encapsulation type, for example, PPPoA.

Binding Information The name of the subscriber.

Binding Status The binding status: bound or unbound.

Tunnel Session Count The number of current sessions.

Tunnel Remote ID The remote tunnel identifier.

Tunnel ID The local tunnel identifier.

Tunnel Name The name of the subscriber and the tunnel ID.
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Session ID The session identifier.

Traffic >
L2TPSessionCounters

The number of traffic packets passing through the L2TP tunnel.

Traffic < 
L2TPSessionCounters

The number of traffic packets passing through the L2TP tunnel.

Tunnel Ctl Errors The number of control errors.

Tunnel State The tunnel state: unknown, idle, connecting, established, or disconnecting.

Session Type The session type: unknown, LAC, or LNS.

Peer Name The peer name.

Tunnel Remote IP The remote IP address of the tunnel.

Last Error Code The value of the last error code that caused the tunnel disconnection.

Session State The session state: unknown, idle, connecting, established, or disconnecting.

Remote Session ID The remote session identifier.

Field Description
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