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Working with Cisco ANA NetworkVision Maps

The topological map is the main tool used by Cisco ANA NetworkVision to display the links and 
relationships between the network elements and aggregated nodes. These topics describe how to work 
with the topological maps displayed in the workspace of the Cisco ANA NetworkVision window:

• Opening and Closing Maps, page 8-2, describes how to open maps that were last visited by you, 
quickly and easily when the application is launched.

• Creating a New Map and Adding and Deleting Devices, page 8-5, describes how to create a new 
map, add and remove devices from a map, and define the map layout.

• Defining a Map Layout, page 8-7, describes how to define the layout of the network in a map.

• Saving Maps, page 8-7, describes how to use the Save Map option to save additional map 
information (that is not saved by default); how to save a map as a copy or template; and how to save 
a map as an image.

• Deleting a Map from the Cisco ANA Database, page 8-9, describes how to delete a map.

• Renaming a Map, page 8-10, describes how to rename an existing map.

• Resizing a Map Element, page 8-10, describes how to define the size of selected network elements 
or aggregated nodes in the map pane.

• Viewing the Network Map, page 8-11, describes how to display the entire network map, or any part 
of the map, in the Overview window. In addition, it describes how to display an aggregated node in 
a thumbnail.

• Viewing a Network Device, page 8-12, describes how to view any network device on the map. The 
device is selected in the appropriate map in the workspace or tree pane and the active tickets are 
shown in the ticket pane.

• Selecting Map Views, page 8-13, describes the various selection tools that can be used to view and 
analyze maps in the map pane.

• Finding a Ticket Source, page 8-14, describes how to find the source of a ticket displayed in the 
ticket pane.

• Finding a Link Source, page 8-14, describes how to find the source of a link displayed in the links 
view.

• Finding a Network Device, page 8-14, describes how to find and display a network device on the 
map.

• Working with Aggregations, page 8-15, describes how to aggregate network elements. In addition, 
it describes how to disaggregate these nodes. 

• Renaming Aggregated Nodes, page 8-16, describes how to rename an existing aggregated node.
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• Filtering Links According to Type, page 8-17, describes how to filter (display or hide) the different 
types of links displayed in the map pane.

• Opening the CPU Usage Graph, page 8-19, describes how to display memory and CPU usage 
information for a device.

• Communicating with Devices Using Ping and Telnet, page 8-20, describes how to ping and Telnet a 
device.

• Previewing and Printing a Map, page 8-20, describes how to preview a map, define the print setups 
for a map, and print a map.

Opening and Closing Maps
Cisco ANA provides two methods for opening maps:

• You can quickly open commonly used maps (if you left the maps open when you last exited 
Cisco ANA NetworkVision). See Opening Commonly Used Maps, page 8-2.

• You can view all existing maps and choose the ones you want to open. See Opening a New Map from 
the Map List Dialog Box, page 8-3.

For information on how to close a map, see Closing a Map, page 8-4.

When you open a map, the network information is automatically refreshed. For example, if a device was 
up the last time that the map was saved and closed, and then the device is moved to maintenance, the 
next time you open the map the management status of the device will be updated accordingly and the 
device will display a maintenance status.

Opening Commonly Used Maps
When you launch Cisco ANA NetworkVision, you will see a list of all maps you recently viewed but did 
not close when you exited the client session. In this way you can avoid having to view the complete list 
of available maps, which can be quite lengthy.

Note First-time users and users who closed their maps before closing the application will not be able to open 
maps using this functionality.

To open a commonly used map that you did not close previously:

Step 1 Launch Cisco ANA NetworkVision as described in Starting Cisco ANA NetworkVision, page 2-1. The 
Cisco ANA NetworkVision window opens, and the Open Selected Maps dialog box is displayed.

Step 2 Select the maps you want to open. By default, the Open Selected Maps dialog box displays a list of the 
maps you last visited but did not close before exiting Cisco ANA NetworkVision. Do one of the 
following:

• To open all maps in the list, click All.

• To open only certain maps, check the maps and click Selected.

• To display an empty Cisco ANA NetworkVision window, click None. 
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Opening a New Map from the Map List Dialog Box
You can open any maps that are in the Map List dialog box, even if you have never accessed them before. 

Step 1 Display the Map List dialog box by doing one of the following:

• Click the Open Map icon in the main toolbar.

• Choose File > Open... from the main menu

The Map List dialog box displays existing maps as defined by the network administrator.

The Find field enables you to search for information in the table according to the selected column. For 
more information, see Finding Text in a Table, page 2-30.

You can use the following tools to manage maps in the Map List dialog box:

Tool Description

Export to CSV—Exports the information displayed in the table. For more information, see 
Exporting Cisco ANA NetworkVision Tables to a File, page 2-34.

Delete Map—Deletes the selected map from the Map List dialog box, the Cisco ANA 
NetworkVision window and the database. If a map that is being opened is deleted, this map 
will close. For more information, see Deleting a Map from the Cisco ANA Database, 
page 8-9.

Rename Map—Renames the selected map in the Map List dialog box and Cisco ANA 
NetworkVision window. For more information, see Renaming a Map, page 8-10.

Sort Table Values—Enables you to sort the information displayed in the table.

Filter—Defines a filter for the information displayed in the table. For more information, see 
Defining a Filter, page 2-31.

Note When a filter is applied, the Set Selection Filter button is activated.

Set Selection Filter—Applies filters to the selected line or lines displayed in the Map List. 

Note When you select one or multiple lines, the Previous Selection Filter (and Rewind All) 
buttons are activated.

Previous Selection Filter—Enables you to undo the last applied filter selection. 

Rewind All—Enables you to undo previous filter selections, and display all the original 
information in the table. 

Help—Opens the Cisco ANA online help.
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Step 2 Select the maps you want to open using one of the following methods. You can select multiple maps by 
pressing <Ctrl> as you click.

• Click the maps in which you are interested, and then click Open.

• Right-click the required maps and choose Open.

• Double-click the required maps.

Use the Windows menu to move between the open maps. For more information on the Cisco ANA 
NetworkVision window, see Cisco ANA NetworkVision Window, page 2-3.

Note By default you can only view and work on a maximum of five maps at any given time in the 
Cisco ANA NetworkVision map pane (to change this default setting, contact the Cisco Account 
Team). To create a new map or select a new map, close the required number of maps.

Closing a Map
When you close a map, by default, Cisco ANA saves basic map information regardless of whether you 
manually save the map. This default information includes device and link additions and removals, along 
with all aggregations and disaggregations. However, you must use the Save Map option if you want to 
retain the following information in the database:

• The location of the devices on the map

• The layout

• Thumbnails

• The size of the devices

To close a map:

Step 1 (Optional) To save more than the default map information (see the items listed previously), manually 
save your map using one of the following methods:

• Click the Save Map Appearance icon in the main toolbar.

• Choose File > Save Map from the main menu.

Step 2 Do one of the following:

• Choose File > Close from the main menu.

• Click in the upper right corner of the map in the workspace. 

If changes have been made to the map, an information message is displayed.

Step 3 Click Yes. The map is saved and closed. An empty Cisco ANA NetworkVision window is displayed, or 
the map that was last opened is displayed.
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Creating a New Map and Adding and Deleting Devices
Cisco ANA NetworkVision supports the creation of multiple network maps in order to represent specific 
network views. Views can cover specific network segments, customer networks, or any other mix of 
network elements desired. When a user creates a map it is available to other users (assuming they have 
sufficient access/security privileges).

The network maps provide a graphic display of active faults and alarms and serve as an easy access point 
for the activation of services.

Creating a New (Empty) Map

To create a new map:

Step 1 Do one of the following:

• Click the New Map icon in the main toolbar.

• Choose File > New Map in the main menu.

The Create Map dialog box is displayed. 

Note Cisco ANA NetworkVision has the following preconfigured map name defaults; the 
administrator can, however, modify these defaults using the Cisco ANA Registry:

The minimum map name length is 1 character.
The maximum map name length is 65 characters.
The map name cannot contain any symbols, except for the dollar sign ($).

The Advanced button enables you to filter the links displayed in the map pane. For more information, 
see Filtering Links According to Type, page 8-17.

Step 2 Enter a name for the new map and click OK.

Note You cannot define the same name for two or more maps.

An empty new map is displayed in the tree pane and map pane. 

Step 3 Add devices to your new map as described in Adding Devices to a Map, page 8-5. 

Adding Devices to a Map

When you add a device to a map, the map is automatically saved in the Cisco ANA database.

You can create a new map, select a filter, and then add the devices to the map. This filter is then applied 
to the new map, and only the required link types are visible in the map pane and recorded in the links 
view. For more information, see Filtering Links According to Type, page 8-17.

Note Based on the security level and access permissions assigned to a user, this option may not be available.
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To add a device:

Step 1 Do one of the following:

• Click the Add Device icon in the main toolbar.

• Choose File > Add Device from the main menu.

The Device List dialog box is displayed, with all the devices that are managed by the system.

Note If a device is not included in your scope, it is displayed with the locked device icon.

For more information about the columns and buttons displayed in the Device List dialog box, see Device 
View, page 2-7.

Step 2 From the Device List, select the device that you want to add. You can select and add multiple devices 
using <Ctrl> or <Ctrl +A> or by clicking and dragging the mouse.

Step 3 Click Add Device. The device is displayed in the tree pane and the selected map or subnetwork in the 
Cisco ANA NetworkVision window workspace. In addition, any tickets are displayed in the ticket pane.

Note When a device is added to the network it is no longer displayed in the Device List dialog box 
dialog box.

Step 4 Click Close to close the Device List dialog box. The Cisco ANA NetworkVision window is displayed.

The device information is saved with the map in the Cisco ANA database.

Removing Elements from a Map

When you delete a device or aggregated node from a map, it is removed from the map in the database, 
but the elements are still managed by Cisco ANA.

Note Based on the security level and access permissions assigned to a user, this option may not be available.

To remove a device or aggregated node from a map:

Step 1 Select the device or aggregated node that you want to delete in the tree pane or map pane.

Step 2 Right-click to display the shortcut menu and choose Remove from Map. The selected device or 
aggregated node is removed from the map.

The device is removed from the map in the database, but is still managed by Cisco ANA and is available 
to be added again.
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Defining a Map Layout
Cisco ANA NetworkVision enables you to select the way in which the network object topology is 
displayed. The map pane displays the selected layout: circular, symmetric, tree, or hierarchical.

You can select the map layout using one of the following methods:

• In the toolbar, click the drop-down list next to the Layout button, and choose one of the options.

• Choose View > Layout from the main menu and select one of the layout options.

By default, Cisco ANA uses the circular layout for maps. If you click the Layout icon in the main toolbar, 
Cisco ANA displays the map according to the option last selected. 

Saving Maps
Cisco ANA provides three variations for saving maps:

• If you want to save more information than Cisco ANA saves by default, see Saving a Map and All 
of Its Information, page 8-7.

• If you want to save a copy of a map so you can use it as a template for another map, see Saving a 
Map as a New Map (Creating a Copy), page 8-8.

• If you want to save a map as an image, see Saving a Map as an Image, page 8-8.

Saving a Map and All of Its Information
By default, Cisco ANA saves basic map information regardless of whether you manually save the map. 
This default information includes device and link additions and removals, along with all aggregations 
and disaggregations. However, you must use the Save Map option if you want to retain the following 
information in the database:

• The location of the devices on the map

• The layout

• Thumbnails

• The size of the devices

To save these changes, do one of the following:

• Click the Save Map Appearance icon in the main toolbar.

• Choose File > Save Map from the main menu.
8-7
Cisco Active Network Abstraction 3.6.6 User Guide

OL-19195-02



 

Part 3: Chapter 8      Working with Cisco ANA NetworkVision Maps
  Saving Maps
Saving a Map as a New Map (Creating a Copy)
You can save a copy of an entire map or parts thereof (specific devices and aggregations) while leaving 
the original map intact.

To save as a new map:

Step 1 Make sure that the map that you want to save is displayed in the Cisco ANA NetworkVision window or 
that the required network elements or aggregated nodes are selected in the tree pane and map pane.

Step 2 Right-click in the tree pane or map pane and choose Save as New Map. The Create Map dialog box is 
displayed with a default name for the new map.

Step 3 Enter a new name for the map.

Step 4 Click OK. The new map is created.

Note For information about how to open the new map, see Opening a New Map from the Map List Dialog Box, 
page 8-3.

Saving a Map as an Image
To save a map as an image:

Step 1 Choose File > Save As Image from the main menu. The Save as Image dialog box is displayed.

Figure 8-1 Save as Image Dialog Box
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Step 2 Define your image characteristics, as needed:

• From the Image area:

– Type—Enables you to select the type of image required.

Note The file types .svg and .png are not available in this version.

– File Name—Enables you to define a name for the image.

• From the Image Content area:

– Visible Window Only—Saves only the currently displayed window as an image.

– Draw Grid—This option is not available in this version.

– Selected Objects Only—Saves only the selected network objects as an image.

• From the Image Characteristics area: Define the quality of the image by entering a figure or by 
clicking and dragging the slider

• From Size area:

– Current Zoom Level—Saves the image at the currently selected zoom level. Selecting this radio 
button enables the Visible Window Only check box.

– Actual Size—Saves the image at the actual size.

– Fit in Window—Saves the image to fit in the window.

– Custom—Saves the image at an enlarged or reduced size. Selecting this radio button enables the 
Width and Height options.

Step 3 Click OK. The map is saved as an image in the defined directory.

Deleting a Map from the Cisco ANA Database
Cisco ANA NetworkVision enables you to delete a map from all the views in the Cisco ANA 
NetworkVision window.

If another client is using a map that you are deleting, Cisco ANA displays a message to those clients 
advising them that the map is being closed and deleted from the database.

To delete a map from Cisco ANA NetworkVision and the Cisco ANA database:

Step 1 Do one of the following to open the map list:

• Click the Open Map icon in the main toolbar.

• Choose File > Open from the File menu.

The Map List dialog box is displayed.

Step 2 In the Map List dialog box, do the following:

a. In the Map List, click the map that you want to delete.

b. In the toolbar, click the Delete Map icon. A confirmation message is displayed.
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c. Click Yes. The selected map is deleted from the Map List dialog box, the Cisco ANA NetworkVision 
window, and the database.

d. Click Close to close the Map List dialog box.

The Cisco ANA NetworkVision window is displayed.

Renaming a Map
Cisco ANA NetworkVision enables you to rename a map that is displayed in the Cisco ANA 
NetworkVision window. The name change affects all users of the map and the new name is displayed in 
the Cisco ANA NetworkVision window of all users.

To rename a map:

Step 1 Do one of the following:

• Click the Open Map icon in the main toolbar.

• Choose File > Open from the main menu.

The Map List dialog box is displayed.

Step 2 From the Map List, select the map that you want to rename.

Step 3 Click the Rename Map icon in the Map List toolbar.

Step 4 Enter the new map name.

Step 5 Click OK. The selected map is renamed in the Map List dialog box, in the Cisco ANA NetworkVision 
window and in the database.

Step 6 Click Close to close the Map List dialog box.

Resizing a Map Element
Cisco ANA NetworkVision enables you to define the size of selected devices or aggregated nodes in the 
map pane, according to predefined sizes or according to a percentage of the current size.

Note You can manually resize a node by selecting it and dragging the corner (handle).

To resize a device or aggregated node:

Step 1 Select the devices or aggregated node that you want to resize in the map pane.

Note The Resize option is only enabled when devices or aggregated nodes are selected. If there are 
any links selected, this option is disabled.
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Step 2 Do one of the following:

• Click the Resize Selected Nodes e icon in the main toolbar.

• Choose Edit > Resize from the main menu.

• Right-click the selected devices or aggregated node from the map pane, and choose Resize.

Step 3 Select your options from the Resize Nodes Controller dialog box, as required:

• In the Resize Node field, select a resizing percentage from the drop-down list.

• In the Set Node Sizes field, select a fixed size from the drop-down list.

Step 4 Click OK. The selected devices or aggregated node are resized.

Viewing the Network Map
Cisco ANA NetworkVision enables you to display the entire network map or any part of the map in the 
Cisco ANA NetworkVision window.

You can use the Zoom tools or the Overview window to display the part of the map that you require. The 
Overview window enables you to view all the changes and alarms taking place in the network. In 
addition, you can display an aggregated node in a thumbnail. 

To open an overview of the network:

Step 1 Do one of the following:

• Click the Overview icon in the main toolbar.

• Choose View > Overview from the main menu.

The Overview window is displayed.

Figure 8-2 Overview Window

Step 2 In the Overview window, select the area that you require by clicking and dragging the mouse to view the 
required area and thereby enlarging it in the map pane. A blue rectangle is displayed around the selected 
area. You can move the selected area by placing the mouse above the rectangle. The mouse icon will be 
changed to a hand, and you can then click and drag the mouse to move the rectangle over the required 
area.
8-11
Cisco Active Network Abstraction 3.6.6 User Guide

OL-19195-02



 

Part 3: Chapter 8      Working with Cisco ANA NetworkVision Maps
  Viewing a Network Device
Step 3 Click and drag the rectangle again to select or resize a different network area.

Step 4 Click  to close the Overview window.

In addition, you can display a thumbnail of the selected aggregated node in the map pane, including all 
the aggregated devices. Thumbnails can also be nested.

To display a thumbnail of the node:

Step 1 Right-click an aggregated node, and choose Show Thumbnail. The thumbnail is displayed in the map 
pane.

Figure 8-3 Thumbnail

Step 2 From here you can do the following:

• To redisplay the aggregated node in the map, right-click the thumbnail and choose Show As 
Aggregation.

• To resize the thumbnail, select it and click and drag any of the thumbnail handles.

Viewing a Network Device
To view a device, select it from the map pane or the tree pane. When you select a device, the ticket pane 
displays all the active and cleared tickets; however, the user can filter the tickets so that only the tickets 
of the selected network device are displayed in the ticket pane. 

To view a network device, click the device in the tree pane or select the device on the map. Note that you 
can:

• Use the Zoom tools when viewing the network (see Cisco ANA NetworkVision Toolbar, page 2-17).

• Click the Overview icon in the main toolbar to display the network in the Overview window.

For more information about filtering tickets by device, see Filtering Tickets by Device, page 15-8.
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Selecting Map Views
Cisco ANA NetworkVision provides you with various selection tools that can be used to view and 
analyze maps in the map pane.

You can view graphical representations of NEs and various links appearing in the map pane of the 
Cisco ANA NetworkVision window’s workspace using the toolbar buttons.

The Device View and Show Links View icons open dynamic tables listing network element/device 
information and respective map context links in table format (not graphical links). The respective tables 
are displayed in the Cisco ANA NetworkVision window’s workspace. For more information on viewing 
and working with device view tables and filtering the links view, see Managing Cisco ANA 
NetworkVision Tables, page 2-29.

Cisco ANA NetworkVision provides you with various selection tools that can be used to view and 
analyze maps in the map pane and the links view table displayed in the workspace as described in the 
following table.

To select a tool, do one of the following:

• From the View menu choose the required selection tool,

• In the toolbar, click the required tool icon.

Button Function

Defines the way in which the map is displayed in the map pane of the 
Cisco ANA NetworkVision window (circular, symmetric, tree, or 
hierarchical). 

Displays the device view in the Cisco ANA NetworkVision window’s 
workspace (the button toggles when selected or deselected).

Displays the links view in the Cisco ANA NetworkVision window (the 
button toggles when selected or deselected). 

Displays the map pane in the Cisco ANA NetworkVision window (the button 
toggles when selected or deselected). 

Activates the normal selection mode (the button toggles when selected or 
deselected).

Activates the pan mode, which enables you to move around in the map pane 
by clicking and dragging (the button toggles when selected or deselected).

Activates the zoom selection mode, which enables you to select an area in the 
map pane to be enlarged by clicking and dragging to view the selected area 
(the button toggles when selected or deselected).

Fits the entire subnetwork or map in the map pane.
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Finding a Ticket Source
Cisco ANA NetworkVision enables you to find the source of a ticket displayed in the ticket pane by 
highlighting the device in the tree pane or map pane.

To find the ticket source:

Step 1 Right-click the required ticket and choose Find Source. The source of the ticket is highlighted in the 
tree pane or map pane.

Note A blue selection box highlights the device that is the source of the ticket.

Step 2 Click anywhere in the tree pane or the map pane to remove the highlight from the selected device or link.

Finding a Link Source
Cisco ANA NetworkVision enables you to find a link displayed in the links view by highlighting the link 
in the map pane.

To find the link:

Step 1 Right-click the required link in the links view and choose Find Source. 

The source of the link is highlighted in the map pane.

Step 2 If there are two or more lines that represent the same links, for example, a VRF link, the Select Link 
Context dialog box is displayed. Select the required link context from the drop-down list and click OK. 
The source of the link is highlighted in the map pane.

Note A blue link highlights the source of the link in the map pane.

Step 3 Click anywhere in the tree pane or the map pane to remove the highlight from the selected link.

Finding a Network Device
Cisco ANA NetworkVision enables you to find a device in the map by entering the device name or the 
device IP address or any part thereof.

To find a device in the map:

Step 1 Do one of the following:

• Click the Find in Map icon in the main toolbar.

• Choose Edit > Find from the main menu.

The Find in Map dialog box is displayed.
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The Search all map levels check box enables you to search for a device or IP address at all levels of the 
map. This option is selected by default. Clearing this option searches for the device, but excludes 
aggregations from the search.

Step 2 Enter the device name or the IP address.

Note You can enter a partial name (case sensitive) or IP address. For example, XY will find the devices 
with the names containing the letters XY.

Step 3 Click OK to enable the search in all the maps and subnetworks. A device matching the search criteria is 
displayed on the map.

Step 4 Press F3 to view the next device matching the search criteria.

Working with Aggregations
Cisco ANA NetworkVision enables you to group network elements and display them as an aggregated 
node. Aggregations can contain devices, VPNs, other aggregated nodes, and so forth.

Grouping Network Elements into Aggregations

To aggregate network elements:

Step 1 Select the network elements using one of the following methods:

• Select the required network element in the map pane.

• Select the required devices in the tree pane or map pane using <Ctrl> or the selection tool.

Step 2 Aggregate the network elements using one of the following methods:

• Click the Aggregate icon in the main toolbar.

• Choose Node > Aggregate from the main menu.

• Right-click the selected network elements in the tree pane or map pane and choose Aggregate. 

The Aggregation dialog box is displayed prompting you to enter a name for the aggregated node.

Step 3 Enter a unique name for the aggregated node and click OK. The aggregated node is displayed in the tree 
pane and map pane. Aggregated nodes are displayed as a single entity with the Aggregation icon.

The aggregated node icon changes color according to the alarm severity. For more information about 
device colors, see Network Element Status Indicators, page 2-13.
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Ungrouping Aggregated Nodes

All aggregated nodes can be ungrouped. If the node you disaggregate contains any child aggregations, 
the child aggregations move up one level, and the original aggregated node is removed. 

To disaggregate a node:

Step 1 Do one of the following:

• Select the required branch in the tree pane.

• Select the required aggregated node in the map pane.

Note The Aggregation icon indicates an aggregated node.

Step 2 Disaggregate the node using one of the following methods:

• Choose Node > Disaggregate from the main menu.

• Right-click the aggregated node in the tree pane or map pane and choose Disaggregate. 

An information message is displayed.

Step 3 Click Yes. The node is disaggregated. Any aggregations in the selected node move up one level, and the 
original aggregated node is removed. 

For more information about resizing an aggregated node, see Resizing a Map Element, page 8-10.

Renaming Aggregated Nodes

You can rename aggregated nodes that are displayed in the Cisco ANA NetworkVision window. The 
name change affects all users of the map and the new name is displayed in the Cisco ANA 
NetworkVision window of all users.

To rename an aggregated node:

Step 1 Select the aggregated node that you want to rename in the tree pane or map pane.

Step 2 Right-click the aggregated node and choose Rename. The Rename Node dialog box is displayed.

Step 3 Enter a new name for the aggregated node and click OK. The selected aggregated node is renamed in 
the tree pane and map pane and in the database.
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Filtering Links According to Type
The links filter enables you to filter the links displayed in the map pane and in the links view.

You can quickly select the types of links to be filtered by selecting from a predefined set of link types in 
the list, or by manually configuring a customized set of link types. You can do either of the following:

• (Method 1) Create a new map, select a filter and then add the devices to the map. This filter will then 
be applied to the new map and only the required link types will be visible in the map pane and the 
links view.

• (Method 2) Create a map and add the devices with all the links enabled and visible in the map pane 
and links view. You can then filter (display or hide) the different types of links required.

By default all the link types are displayed in the map pane and links view until the links filter is applied. 
The filter only applies to the map pane and the links view; it has no affect elsewhere in Cisco ANA 
NetworkVision. Since the filtered links are removed from the map, it also has an affect on the severity 
of the network elements.

Note You cannot filter links by their current maintenance state. To view link maintenance states, see 
Suppressing Link Alarms Using the Link Maintenance State, page 14-9.

To filter links according to type (method 1):

Step 1 Open the Create Map dialog box using one of the following methods:

• Click the New Map icon in the main toolbar.

• Choose File > New Map from the main menu.

The Create Map dialog box is displayed. For more information, see Creating a New Map and Adding 
and Deleting Devices, page 8-5.

Step 2 Click Advanced. The Map Options dialog box is displayed.
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Figure 8-4 Map Options Dialog Box

Note By default all the link types are selected in the Map Options dialog box. In other words, all the 
links are displayed in the map pane and links view.

The Map Options dialog box displays a list of all the types of links that you can filter in the map pane.

The Group drop-down list contains the following options:

• Custom—Only the links defined for the customized filter are displayed in the map pane.

• All—All the links are displayed in the map pane.

• Data Link—The data link layer class of links is displayed in the map pane (ATM and Frame Relay).

• None—None of the links are displayed in the map pane.

• Physical—Only the physical links are displayed in the map pane.

• VPN—Only the VPN links are displayed in the map pane.

ATM, VPN, MPLS, and Ethernet are just some of the options displayed in the Map Options dialog box 
that can be used to filter the links displayed in the map pane and in the links view.

Note The Group drop-down list options can be customized by selecting an option and adding or 
removing the required link types. The next time the Map Options dialog box is opened, the 
Custom option is displayed with the required link types.

Step 3 Select or clear the check boxes for the links that you want or do not want to display in the map pane and 
links view.

Step 4 Click OK/Apply to apply the defined link filter settings.
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Step 5 Enter a name for the new map and click OK. An empty new map is displayed in the tree pane and map 
pane.

Step 6 Add the required devices to the network. For more information, see Adding Devices to a Map, page 8-5. 

The links are displayed in the map pane and links view according to the defined filter criterion.

You can also create a map and add the devices with all the links enabled and visible in the map pane and 
links view. You can then filter (display or hide) the different types of links required.

To filter links according to type (method 2):

Step 1 Click the Map Options icon in the main toolbar. The Map Options dialog box is displayed.

Step 2 Clear the check boxes for the links that you do not want to display in the map pane and links view.

Step 3 Click OK/Apply to apply the defined link filter settings. The links are displayed in the map pane and 
links view according to the defined filter criterion

.

Opening the CPU Usage Graph 
Cisco ANA NetworkVision enables you to display memory and CPU usage information for a 
device/network element, including its history.

To open the CPU usage graph:

Step 1 Right-click a network element in the tree pane and choose Tools > CPU Usage. The CPU Usage dialog 
box is displayed.

Step 2 Examine the data that is provided:

• CPU Usage—The CPU usage rate as a percentage.

• CPU Usage History—The CPU usage rate history is graphically displayed.

• Memory Usage—The memory usage rate as a percentage.

• Memory Usage History—The memory usage rate history is graphically displayed.

Step 3 If desired, click the Save to CSV File icon (in the CPU Usage dialog box) to export the displayed data. 
For more information, see Exporting Cisco ANA NetworkVision Tables to a File, page 2-34.

Step 4 Click Close to close the CPU Usage dialog box.
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Communicating with Devices Using Ping and Telnet
Cisco ANA NetworkVision enables you to communicate with devices in the following ways:

• Pinging a Device, page 8-20

• Telneting a Device, page 8-20

Pinging a Device

Cisco ANA NetworkVision enables you to ping a device in order to verify that the device is responding.

Note The ping is performed from the client to the device, and not from the Cisco ANA unit hosting the VNE 
to the device.

To ping a device, right-click a device in the tree or map pane, and choose Tools > Ping.

Telneting a Device

Cisco ANA NetworkVision enables you to communicate with a device using the Telnet window.

Note The telnet is performed from the client to the device, and not from the Cisco ANA unit hosting the VNE 
to the device.

To telnet a device:

Step 1 Right-click a device in the tree or map pane, and choose Tools > Telnet.

Step 2 Log in and use the Telnet window as needed.

Previewing and Printing a Map
To print a map, choose File > Print. If you would like to preview a map before printing it, or define the 
print setup for a map, see the following topics:

• Previewing a Map Before Printing It, page 8-20

• Defining the Print Setup for a Map, page 8-21

Previewing a Map Before Printing It

Using Cisco ANA NetworkVision, you can preview a map before it is printed.

To preview a map:

Step 1 In the map pane, display the map that you want to print.

Step 2 From the main menu, choose File > Print Preview. The Print Preview dialog box is displayed with the 
active map.
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The following buttons are displayed in the Print Preview dialog box:

Step 3 Click Print. The required map is printed to the selected printer.

Defining the Print Setup for a Map

Cisco ANA NetworkVision enables you to define the print setup of a map before it is printed.

To define the print setup:

Step 1 From the main menu, choose File > Print Preview to open the Print Preview dialog box.

Step 2 Click Print Setup. The Print Setup dialog box is displayed.

Figure 8-5 Print Setup Dialog Box

Print Prints the displayed network or map to the selected printer.

Print Setup Opens the Print Setup dialog box, enabling you to define how the network or map 
is printed. For more information, see Defining the Print Setup for a Map, page 8-21.

Zoom In Zooms in on the network or map.

Zoom Out Zooms out of the network or map.

Zoom % Zooms in to get a close-up view of your network or map or zooms out to see more 
of the network or map at a reduced size. Click the arrow next to the Zoom box and 
the zoom setting that you want.

Fit In Window Displays the entire network or map in the Print Preview dialog box.

Close Closes the Print Preview dialog box.
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Step 3 Define the print setup, using the following options:

a. Indicate what you want to print:

b. Choose the page and scale settings:

c. Define a caption:

d. In the Margins area, enter the margin measurements.

e. Make your multipage printing selections:

f. Print the network or map with a border, background, or grid:

g. To choose portrait or landscape (and other standard printer settings), click Page Setup.

Step 4 Click OK to save your settings, or Default to restore the default settings.

Step 5 Preview your map by selecting File > Print Preview from the main menu. 

Step 6 If you are satisfied with your settings, click Print. Otherwise, click Print Setup and revise your settings.

Print Entire 
Graph

Prints the currently displayed map, including aggregated nodes.

Print Current 
Window

Prints the currently displayed map, excluding aggregated nodes.

Print Current 
Selection

Prints the area selected in the currently displayed map.

Pages Prints the currently displayed map according to the numbers specified in the Page 
Columns and Page Rows fields.

Actual Size Prints the currently displayed map at the actual size.

Zoom Level Prints the currently displayed map according to the selected zoom level.

Print Caption Select this option to add a caption to the printed map, and enter the required text.

Position Defines the position of the caption in the printed map.

Print Page 
Numbers

Prints the map with page numbers.

Print Crop 
Marks

Prints the map with crop marks.

Print Border Prints a border around the printed map.

Print 
Background

Prints the background of the currently displayed map.

Print Grid Prints a grid for the printed map.
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